JIVE REPORTの概要

ジャイブレポートの概要

ジャイブレポートWindows版は、アプリケーションを開発する時に使用する帳票作成ツールです。

各種伝票、ラベル、ハガキや封筒、宅配送り状など、様々な種類の印刷物を作成できます。

Webを利用した帳票システムを簡単に構築できます。

  開発をサポートするツールやコンポーネントが用意されています。

１．レポートエディタ
２．レポートライブラリ
３．プレビューコントロール

１．レポートエディタ

帳票のフォームを作成するエディタです。
ExcelやAccessから帳票データを読み込み、エディタから直接帳票印刷もできます。

２．レポートライブラリ

帳票アプリケーションを開発する時に使用するライブラリです。
開発完了後、実行環境へ無料で配布することができます。
4種類のライブラリが用意されています。

・レポートライブラリOCX
・レポートライブラリ.NETコントロール
・レポートライブラリ DLL
・レポートライブラリＪＮＩ

３．プレビューコントロール

帳票をプレビューするActiveXコントロールです。
印刷、ページジャンプ、拡大縮小などの機能を持っています。


X86製品解説

ﾌﾟﾛﾌｪｯｼｮﾅﾙ(X86)/ﾊﾟｰｿﾅﾙ(X86)の製品解説

製品概要

x86対応のコントロールやツールが入っています。

コントロール・ツール | ﾌﾟﾛﾌｪｯｼｮﾅﾙ(X86) | ﾊﾟｰｿﾅﾙ(X86)
レポートエディタ (x86対応版) | ○ | ○
レポートライブラリOCX (x86対応版) | ○ |
レポートライブラリ.NETコントロール (x86対応版) | ○ |
レポートライブラリDLL (x86対応版) | ○ |
レポートライブラリJNI (x86対応版) | ○ |
プレビューコントロール (x86対応版) | ○ |

動作環境

コントロールやツールは、Windows x86Editionで動作します。

動作確認済みのOSは、弊社Webサイト「製品種類／対応OS」で最新情報をご確認ください。

[ URL　 http://www.jive-comp.co.jp ]

各種類の使い方や制限

１．プロフェッショナル(X86)は、アプリケーションを開発する時に使います。
    パーソナル(X86)では、アプリケーションを開発することはできません。

２．プロフェッショナル(X86)は、32ビットアプリケーションを開発する時に使います。
    64ビットアプリケーションを開発する場合には、プロフェッショナル(X64)を使います。

３．プロフェッショナル(X86)は、次の環境で使用することができます。

    ・開発環境と実行環境がWindows x86Editionの場合
  ・開発環境や実行環境がWindows x64Editionでも、32ビットのアプリケーションを作成する場合

  ※JAVAで作成した32ビットアプリケーションは、Windows x64Editionで動作が確認されていません。
  ※Delphiで作成した32ビットアプリケーションは、Windows x64Editionで動作が確認されていません。
  ※レポートライブラリ.NETコントロールは、Delphiでは使用できません。

注意事項

レポートライブラリOCX、レポートライブラリ.NETコントロール、プレビューコントロールを使用する場合は、.NET Framework 2.0以上が必要です。


X64製品解説

プロフェッショナル(X64)の製品解説

製品概要

プロフェッショナル(X64)には、64ビットと32ビットの両方のコントロールやツールが入っています。（レポートエディタを除く）
以下のものが含まれています。

コントロール・ツール | 動作環境 | 注意事項
レポートエディタ (x86対応版) | (1)と(2) | ※1
レポートライブラリOCX (x64対応版) | (2) | ※2
レポートライブラリOCX (x86対応版) | (1)と(2) |
レポートライブラリ.NETコントロール (x64対応版) | (2) | ※2
レポートライブラリ.NETコントロール (x86対応版) | (1)と(2) | ※2
レポートライブラリDLL(x64対応版) | (2) |
レポートライブラリDLL(x86対応版) | (1)と(2) |
レポートライブラリJN I(x64対応版) | (2) |
レポートライブラリJN I(x86対応版) | (1)と(2) |
プレビューコントロール (x64対応版) | (2) | ※2
プレビューコントロール (x86対応版) | (1)と(2) | ※2

動作環境

(1)のコントロールやツールは、Windows x86Editionで動作します。
(2)のコントロールやツールは、Windows x64Editionで動作します。

動作確認済みのOSは、弊社Webサイト「製品種類／対応OS」で最新情報をご確認ください。

[ URL　 http://www.jive-comp.co.jp ]

注意事項

※1：レポートエディタは、Windows x64Editionの環境では、32ビットアプリケーションとして動作します。
※2：このコントロールやツールを使用する場合は、.NET Framework 2.0以上が必要です。
※3：このコントロールやツールを使用する場合は、.NET Framework 4.0以上が必要です。

その他

プロフェッショナル(X64)では、64ビットアプリケーション、32ビットアプリケーションのどちらも開発することができます。
レポートライブラリ.NETコントロールは、Delphiでは使用できません。


ライセンスについて

開発時のライセンス

ジャイブレポートを使ってアプリケーションを開発する時には、開発に使用するコンピュータ１台ごとに１ライセンスが必要です。
複数のコンピュータで使用する時は、それらのコンピュータを同時に使用しない場合でも、使用する台数分のライセンスが必要です。
開発とは、アプリケーションを開発する時にジャイブレポートを必要とする全ての作業（コーディング、コンパイル、リンク、デバッグなど）を指します。 ジャイブレポートをコンパイルやリンク、デバックのみに使用し、コードを記述するなどの直接的な製品の使用がない場合でも、その作業を行うコンピュータにはライセンスが必要です。
ネットワーク上でファイルを共有できるコンピュータにジャイブレポートをインストールし、そのコンピュータから各コンピュータの一時メモリにジャイブレポートを読み込んで使用する場合でも、一時メモリに読み込んで使用する台数分のライセンスが必要です。

実行時のライセンス

ジャイブレポートを使用したアプリケーションを実行環境へ配布する時には、アプリケーションと一緒に、使用許諾契約書に記載されたランタイム製品を使用許諾契約書に従って配布することができます。その際のランタイム製品のライセンスは、ユーザー登録を行うことによりフリー（無料）となります。 配布前にユーザー登録が必要です。

※ランタイム製品は、アプリケーションと一緒に配布してください。単体では配布できません。
※レポートエディタはランタイム製品ではありません。

再利用可能なコンポーネントへの組み込み

ActiveXコントロール、DLLなどの再利用可能なコンポーネントとしてソフトウェアを作成し、その中にジャイブレポートのランタイム製品を組み込んだ場合には、そのソフトウェアを配布する時のライセンスは、「実行時」ではなく「開発時」の扱いとなります。そのソフトウェアを配布する前に、配布数と同じ数のライセンスを購入してください。

貸与・レンタル・リースの禁止

ジャイブレポートは、他社への貸与・レンタル・リースが禁止された製品です。いかなる理由があろうとも、所有するジャイブレポートを他社へ貸与・レンタル・リースしないように注意してください。
ジャイブレポートを所有する会社が、開発を他社へ委託する場合、委託先の会社へジャイブレポートを貸し出すことはできません。また、ジャイブレポートを所有する会社が、開発者を他社へ出向または派遣する場合、出向または派遣先の会社へジャイブレポートを貸し出すこともできません。実際に開発を行う会社は、自社でジャイブレポートのライセンスを取得する必要があります。アプリケーションの納品先会社が保守やメンテナンスを行う場合には、納品先の会社がジャイブレポートのライセンスを購入してください。


起動と終了

レポートエディタの起動

１．MS-Windowsを起動します。

２．「スタート／すべてのプログラム／JiveReport10X／ﾚﾎﾟｰﾄｴﾃﾞｨﾀ」を実行します。

３．レポートエディタが起動します。

４．初回起動時は、レポートエディタの作業ディレクトリを設定後再起動して下さい。（『環境設定』参照）

レポートエディタの終了

１．「ファイル／終了」を選択します。

２．編集中のフォームが開いている場合、保存確認のダイアログが開きます。ファイルを保存後、終了を選択します。


レポートエディタの概要

レポートエディタは、帳票フォームを作成するための高機能なエディタです。

１．各種帳票フォームを簡単に作成することができます。
２．作成した帳票フォームに帳票データを埋め込み、帳票を完成させることができます。
    帳票データは、Excel・テキストファイル・データベースから取得することができます。
３．完成した帳票は印刷したり、PDF形式や各種イメージ形式のファイルに保存したりすることができます。


レポートエディタの特長

１．文字描画機能

3D文字、変形文字、グラデーション・テクスチャ・シャドウなどの飾り文字、など様々なタイプの文字を表現できます。
フォントの種類・サイズ、文字回転、網掛文字、下線・打消線、下線の位置指定、フォントの横幅拡大、行ピッチ、文字ピッチ、禁則処理、英文ワードラップ、インデント、段組などの各種のプロパティも設定可能です。

２．グラフィックス描画機能

グラフィックス機能には、直線、矢印、四角形、楕円、円弧、多角形、自由曲線、イメージ、グラフ、バーコードがあります。
それぞれ、グラデーションやシャドウ、ソフトエッジなどで飾ることができます。線種、線幅、網掛パターン、色など各種のプロパティも設定可能です。四角形では、任意の角を任意のサイズで丸めることができます。多角形では、頂点と頂点を直線で結ぶことも曲線で結ぶこともできます。

３．フィールド設定機能

帳票データを描画するためのフィールド機能があります。

数値・文字データにはテキストフィールドまたはグリッドフィールドを使用します。グリッドフィールドは、表形式のデータ出力に適しており、列毎にフォントや幅、編集子などのプロパティが設定可能です。
バーコードデータにはバーコードフィールド、イメージデータにはイメージフィールド、グラフデータにはグラフフィールドが用意されています。
セレクトボタンフィールド（ラジオボタンタイプ）は、複数項目から任意の項目を選択する時に使います。セレクトボタンフィールド（チェックボックスタイプ）は、項目の選択状態／選択解除状態を表現する時に使います。
テキストフィールドには四則演算機能、頁番号や印刷年月日などを自動表示する予約語機能もあります。

４．帳票印刷機能

レポートエディタ上で、フォームに貼り付けられたフィールドに、ACCESSやExcelなどからデータを取り込んだり、テキストファイルからデータを読み込んだりして、手軽に帳票を印刷することができます。

ラベル設計機能もあるので、タックラベルなどのラベル印刷も簡単に行なえます。

５．マルチページ編集機能

ページ毎に用紙サイズや用紙方向、グリッド間隔などの異なるフォームを作成できます。作成した複数のフォームは１ファイルとして保存され、レポートライブラリからは、ページ番号またはページキーで呼び出し可能です。

６．編集機能

複数の文字や図形を１つのグループとするグルーピング機能があります。グループ化された文字や図形は、１つのオブジェクトとして移動、コピー、サイズ変更などを行なえます。その他、複数回実行可能なアンドゥ・リドゥ機能、オブジェクトのロック機能、整列機能などもあり、編集作業を円滑に行なうことができます。

７．パーツ登録機能

複数の文字や図形をひとまとめにしてパーツ登録しておき、必要なときにいつでも呼び出して使うことができます。いろいろな帳票で共通に使われる文字や図形を何度も作成する必要がありません。


レポートエディタの２大機能

レポートエディタには、帳票フォームの作成、帳票印刷という大きな２つの機能があります。

帳票フォームの作成

用紙サイズの設定、表やタイトルの描画、バーコード、グラフ、イメージなど帳票のフォームを設計します。
帳票フォームの作成はフォーム設計モードで行います。

帳票印刷

作成した帳票フォームに帳票データを読み込んで帳票を完成させることができます。
完成した帳票は、印刷したり、PDF形式やイメージ形式のファイルに保存したりすることができます。
帳票データは、Excelやテキストファイル、ACCESSなどのデータベースから読み込むことができます。
帳票印刷は、帳票印刷モードで行います。


帳票フォーム作成の概略

帳票フォームの作成は、フォーム設計モードで行います。
帳票印刷モードになっている場合は、フォーム設計モードに変更してください。

レポートエディタでは、以下の手順で帳票フォームを作成します。

１．用紙や画面の設定をする。
２．罫線や文字を描画する。
３．フィールドを貼り付ける。
４．フォームを保存する。

１．用紙や画面の設定をする。

用紙には、A4、B4、B5、はがきなど、様々なサイズがあります。
また、用紙は、横方向に使う場合と、縦方向に使う場合があります。

帳票のレイアウトを作成する前に、まず、用紙サイズと用紙方向を決定します。

用紙が決まったら、画面のグリッドの設定を行います。画面上の縦横の桝目をグリッドと呼びます。

グリッドの間隔は、作成するフォームに合ったものを選択しておくと、作業効率がアップします。

縦横のグリッド間隔は、「フォーム／グリッドの間隔」で選択します。
グリッドに左右されず自由に描画する場合は、編集メニューで「グリッドに合わせない」を選択します。

２．罫線や文字を描画する

帳票には、どのページも同じ内容の固定部分と、ページごとに内容が変わる可変部分があります。

表の枠やタイトルなどは、ページが変わっても変わることはありません。
まず、このような固定部分を描画します。

タイトルなどの固定文字には、文字ツールを使います。
入力した文字は、フォントの種類やサイズなどのプロパティを設定できます。

罫線や枠は、直線ツールや四角形ツールなどを使って描画します。
グリッドフィールドを貼り付ける場合は、グリッドフィールドの罫線描画機能が利用できます。

プロパティは、プロパティウィンドウや文字属性画面で設定します。
文字属性画面は、描画した文字を選択しマウスの右ボタンをクリックすると開きます。

３．フィールドを貼り付ける

ページごとに内容が変わる可変部分には、フィールドを貼り付けます。

フィールドには、テキストフィールド、グリッドフィールド、イメージフィールド、バーコードフィールド、グラフフィールド、セレクトボタンフィールドがあります。
描画する内容に合わせて、これらのフィールドを使い分けます。

フォームにテキストフィールドを貼り付けてみましょう。

テキストフィールドツールボタンをマウスでクリックし、マウスポインタを描画する位置へ移動します。
マウスの左ボタンをクリックすると文字プロパティ画面がポップアップし、各種のプロパティを設定することができます。
編集子タブで桁数を設定しOKボタンを押すとテキストフィールドが作成されます。
編集子とは、テキストフィールドに入れる最大文字数やフィールドの型を設定するためのものです。
数字用のフィールドには「#」または「0」、文字用のフィールドには「&」または「@」が設定されます。

フォントの種類やサイズなどのプロパティは、プロパティウィンドウや文字属性画面で設定します。
文字属性画面は、フィールドを選択しマウスの右ボタンをクリックすると開くことができます。

４．フォームを保存する

帳票のフォームが完成したら、フォームを保存します。
保存したフォームは、レポートエディタの帳票印刷やレポートライブラリから使うことができます。


レポートエディタからの帳票印刷の概略

帳票印刷は、帳票印刷モードで行います。
フォーム設計モードになっている場合は帳票印刷モードに変更してください。

レポートエディタから帳票を印刷する場合は、以下の手順で行います。
（帳票フォームは、帳票印刷の前に作成しておきます。）

１．帳票登録をする。
２．データを読み込む。
３．印刷する。

１．帳票登録をする。

まず、フォームのフィールド部分にデータを取り込んで帳票を完成させます。

データの取り込み先などの設定を行うことを「帳票登録」と呼びます。
帳票登録は帳票登録画面で行います。

帳票登録画面は「表示／帳票登録ウィンドウ」で開きます。
ウィザード画面で対話形式に設定する場合は、「表示／帳票登録ウィザード」を実行します。

帳票登録では、帳票フォームに取り込むデータの取得先を設定します。

データは、Excel、テキストファイル、ACCESSなどのデータベースから取り込むことができます。
取り込むデータは、印刷実行前に準備しておきます。

設定した内容は、帳票名を付けて保存しておくと、何度でも利用できます。

２．データを読み込む。

帳票登録が終わったら、データを読み込んで帳票を完成させます。
データの読み込みは「帳票／データ読込」または、画面上部の「データ読込」ボタン [image] で行います。
帳票登録ウィンドウの「データの取り込み」ボタンを押して読み込むこともできます。

データを読み込むと、帳票フォームのフィールド部分にデータがセットされ帳票が完成します。

３．印刷する。

帳票が完成したら、印刷を行います。
印刷は、「ファイル／印刷」または、印刷ボタン [image] で行います。

４．PDFファイルを作成する。

完成した帳票をPDF形式でファイルに保存することもできます。
保存は、「ファイル／PDFファイル作成」で行います。


固定フォームを作る

レポートエディタでは、固定フォームと可変フォームを作ることができます。

帳票のレイアウトがいつも同じで変わることがない場合には、固定フォームを作成します。

帳票例：見積書

       →
      ＜見積書の固定フォーム＞　　　　　　　＜見積書の印刷＞

固定フォームが完成したら、レポートライブラリを使って各フィールドにデータを埋め込み、帳票を印刷します。
レポートエディタから帳票印刷モードで帳票を印刷することもできます。


可変フォームを作る

レポートエディタでは、固定フォームと可変フォームを作ることができます。

帳票のレイアウトが出力するデータによって変わる場合には、可変フォームを作成します。
可変フォームでは、帳票のフォームを複数のセクションに分割して作成します。

帳票例：見積書

      ＜見積書の可変フォーム＞

この例では、帳票を5つのセクションに分割していますが、セクションの数は、最大20個まで自由に設計できます。
各セクションには、オブジェクトを自由に配置することができます。

－レポートエディタで可変フォームの作成

可変フォームが完成したら、レポートライブラリを使って帳票を印刷します。

帳票印刷例：見積書

        ＜複数ページにわたる見積書の印刷　１ページ～3ページ＞

レポートライブラリには、セクションをコントロールして、最終ページまで印刷する機能が備わっています。
可変フォームは、レポートエディタの帳票印刷モードでは印刷できません。


各部の名称と機能(フォーム設計モード)

フォーム設計モード画面　各部の名称と機能

表示メニューから「フォーム設計モード」を選択すると、フォームを設計するモードになります。
フォーム設計画面では、設計に必要なツールバーやプロパティウィンドウが表示されます。

メニューバー
メニューバーには、レポートエディタを操作するためのコマンドが並んでいます。

上ツールバー
上ツールバーには、メニューバーのよく使われるコマンドやプロパティ設定コマンドが並んでいます。マウスポインタを各ボタン上に置くと、ボタンの説明が表示されます。ツールバーをマウスで掴んで、別な位置に移動することもできます。
※上ツールバーは、フォーム設計モードと帳票印刷モードでは、内容が異なります。

左ツールバー
左ツールバーには、描画オブジェクトのボタンが並んでいます。
上から［選択、文字、直線、四角形、円（楕円）、弧（弓・扇）、多角形、イメージ（フィールド）、テキストフィールド、グリッドフィールド、バーコード（フィールド）、グラフ（フィールド）、セレクトボタンフィールド］となっています。
マウスポインタを各ボタン上に置くと、ボタンの説明が表示されます。ツールバーをマウスで掴んで、別な位置へ移動することもできます。
※左ツールバーは、フォーム設計モード時のみ表示されます。

ページウィンドウ（固定フォームの場合のみ表示）
編集中のフォームファイルのページ情報を表示します。
ページウィンドウの表示／非表示は、表示メニューで操作します。

セクションウィンドウ（可変フォームの場合のみ表示）
編集中のフォームファイルのセクション情報を表示します。
セクションウィンドウの表示／非表示は、表示メニューで操作します。

プロパティウィンドウ
オブジェクトのプロパティを設定します。
プロパティの種類は、選択したオブジェクトにより異なります。
プロパティウィンドウの表示／非表示は、表示メニューで操作します。
※プロパティウィンドウは、フォーム設計モード時のみ表示されます。

フィールドウィンドウ
フィールド名称を一覧表示します。
フィールドウィンドウの表示／非表示は、表示メニューで操作します。

ルーラー
ルーラーは、設定したグリッドの単位で表示されます。

ステータスバー
ステータスバーには、編集中のフォーム情報が表示されます。
１行目のステータスバー：［用紙寸法、マウスポインタの座標、ページ番号］
１行目のステータスバー：［用紙サイズ、用紙方向、グリッドの間隔、倍率、ラベル印刷］

画面スクロールバー
編集中のページ内をスクロールします。

ページスクロールバー
編集中のファイル内をページ単位にスクロールします。


ファイルメニュー(フォーム設計モード)

ファイルメニューのコマンド

１．新規作成[固定長フォーム]
新しい固定のフォームを作成します。
帳票のレイアウトが固定の場合に選びます。

２．新規作成[可変長フォーム]
新しい可変のフォームを作成します。
帳票のレイアウトがデータによって変化する場合に選びます。

３．フォームを開く
作成済みのフォームファイルを開きます。

４．フォームの上書き保存
編集中のフォームを上書き保存します。

５．名前を付けてフォームを保存
編集中のフォームに名前を付けて新規保存します。

６．印刷 （可変フォームの場合には使用できません）
編集中のフォームを印刷します。
テキストフィールドやグリッドフィールドには、編集子が印刷されます。
環境設定画面で「印刷時にフィールド名称を印刷する」をチェックすると、フィールド部分にフィールド名称が印刷されます。
環境設定画面で「印刷時にグリッド線を描画する」をチェックすると、画面のグリッドも一緒に印刷されます。
印刷ページ、マージンやスケール、プリンタやプリンタプロパティなどの設定ができます。
ここでの印刷は、フォームの印刷です。完成した帳票を印刷するには、帳票印刷機能を利用します。
※可変フォームの場合には帳票印刷モードは使用できません。

７．フォーム設定ウィザード （可変フォームの場合には使用できません）
フォームの用紙サイズや方向などを対話形式で設定する フォーム設定ウィザード 画面が開きます。

８．RDFファイル作成 （可変フォームの場合には使用できません）
フォームファイルを RDF形式でファイル に保存します。

９．PDFファイル作成 （可変フォームの場合には使用できません）
フォームファイルをAdobe PDF形式でファイルに保存します。

10．環境設定
レポートエディタの環境設定、ユーザー定義サイズ作成、用紙の余白の設定を行います。

11．ファイル情報
フォームファイル全体のファイル情報を設定します。

12．パスワードの設定
フォームファイルにパスワードを設定します。

13．外字ファイル作成
ジャイブレポート専用の外字ファイルを作成します。
帳票データに外字を使用する時や、フォームに外字の固定文字がある時には、ジャイブレポート外字ファイルを作成して実行環境へコピーすると、実行環境に外字フォントがなくても外字を描画することができます。
外字では、影付き文字、フェードアウト、ソフトエッジ、３Ｄ文字、文字の変形機能は利用できません。

－外字の描画
－ジャイブレポート外字ファイルの作り方
－ジャイブレポート外字ファイルの使い方

14．高速印刷モード
帳票を高速に印刷する場合は、高速印刷モードを選択します。
高速印刷モードを選択すると、シャドウ、フェードアウト、ソフトエッジ、グラデーション、テクスチャ、カスタムブラシ、３Ｄ、文字変形が使用できなくなります。
高速印刷モードの設定は、PDFファイルを作成する時には無効です。

15．終了
レポートエディタを終了します。


編集メニュー

１．元に戻す（アンドゥ）
直前に行った操作を取り消し元の状態に復帰します。
実行可能なアンドゥの回数は、環境設定画面で設定することができます。

２．やり直し（リドゥ）
直前に行った操作を繰り返します。
実行可能なリドゥの回数は、環境設定画面で設定することができます。

３．切り取り
選択中のオブジェクトを切り取ります。

４．コピー
選択中のオブジェクトをコピーします。

５．貼り付け
「切り取り」または「コピー」されたオブジェクトを貼り付けます。

６．削除
選択中のオブジェクトを削除します。

７．全て選択
フォーム上のオブジェクトをすべて選択された状態にします。

８．選択解除
選択中のオブジェクトをすべて選択されていない状態にします。

９．上層へ移動
選択中のオブジェクトをオブジェクトの一番上へ移動します。

10．下層へ移動
選択中のオブジェクトをオブジェクトの一番下へ移動します。

11．グルーピング
複数の選択されたオブジェクトをグループ化し、１つのオブジェクトにします。
グループ化されたオブジェクトを再グループ化することもできます。
グループ化されたオブジェクトは、１つのオブジェクトとして編集作業を行なうことができます。

12．グルーピング解除
グループ化されたオブジェクトのグルーピングを解除します。

13．オブジェクトを揃える
選択中のオブジェクトの横位置、縦位置、幅、高さを揃えます。
揃えることができるオブジェクトは、文字列、テキストフィールド、直線、ボックスのみです。
横位置は、一番上のオブジェクトの座標に揃えられます。その他のプロパティは、一番左のオブジェクトの座標やサイズに揃えられます。

14．オブジェクトのロック
選択中のオブジェクトをロックし、編集不可の状態にします。
編集が完了したオブジェクトをロックすると、次の編集作業が簡単に行えます。
・すべてのオブジェクトをロックする
フォーム上のすべてのオブジェクトをロックし、操作できないようにします。
・選択中のオブジェクトをロックする
選択中のオブジェクトをロックし、操作できないようにします。
既にロック済みのオブジェクトはロックされたままです。
・ロックを解除する
すべてのオブジェクトのロックを解除し、操作ができるようにします。

15．グリッドに合わせる
・グリッドに合わせない
フォーム上のオブジェクトをグリッド線に合わせないようにします。
・オブジェクトの左上の頂点をグリッドに合わせる
オブジェクトの左上の頂点をグリッド線に合わせます。
・全ての選択オブジェクトの左上をグリッドに合わせる
選択されている全てのオブジェクトの左上の頂点をグリッド線に合わせます。
・全ての選択オブジェクトの全ての頂点をグリッドに合わせる
選択されている全てのオブジェクトの全ての頂点をグリッド線に合わせます。


表示メニュー(フォーム設計モード)

表示メニュー

１．フォーム設計モード
レポートエディタをフォーム設計モードにします。
フォーム設計モードとは、フォームを作成する時のモードです。
フォーム設計モードでは、各種のツールバーやプロパティウィンドウ、ページウィンドウが表示されます。
また、フォーム上に描画されたオブジェクトを編集することができます。

２．帳票印刷モード（可変フォームの場合には使用できません）
レポートエディタを帳票印刷モードにします。
帳票印刷モードとは、フィールドにデータをセットし、帳票を完成させて印刷する時のモードです。
帳票印刷モードにすると画面が変わり、帳票データの読み込み先などを指定することができます。
帳票印刷モードにすると、フォーム上のオブジェクトは編集できません。

３．グリッド
グリッド線の表示／非表示を切り替えます。

４．ルーラー
ルーラー（ものさし）の表示／非表示を切り替えます。

５．ステータスバー
ステータスバーの表示／非表示を切り替えます。

６．パーツウィンドウ
パーツ登録用のパーツウィンドウを表示します。

７．
（固定フォームの場合）ページウィンドウ
マルチページ編集用のページウィンドウを表示します。

（可変フォームの場合） セクションウィンドウ
セクションウィンドウを表示します。

８．フィールドウィンドウ
フィールドウィンドウを表示します。

９．プロパティウィンドウ
プロパティウィンドウを表示します。

10．データウィンドウ
データウィンドウは、帳票印刷モードの時のみ使用できます。

11．ツールバー
ツールバーの表示／非表示を切り替えます。

12．倍率
画面の表示倍率を切り替えます。
倍率を選択後、画面の任意の場所をクリックすると、指定した倍率でフォームが表示されます。


フォームメニュー

フォームメニューは、固定フォームと可変フォームでは内容が異なります。

１．用紙サイズ
フォームの用紙サイズを設定します。用紙サイズはフォーム情報画面でも設定できます。

２．用紙方向
フォームの用紙方向を設定します。用紙方向はフォーム情報画面でも設定できます。

３．グリッドの間隔（横）
フォームの横方向のグリッド間隔をCPIまたはmm単位で設定します。
CPI（キャラクタ／インチ）とは、1インチ当たりの文字数を表わします。

４．グリッドの間隔（縦）
フォームの縦方向のグリッド間隔をLPIまたはmm単位で設定します。
LPI（ライン／インチ）とは、1インチ当たりの行数を表わします。

５．フォーム情報
用紙に関する情報を設定します。

６．ラベル印刷 （固定フォームの場合のみ表示されます）
ラベル用紙を設定します。

７．フィールド順指定
フォームに貼り付けられたフィールドの順番を設定します。
フィールドの順番は、帳票印刷モードでの帳票印刷時に使われます。

８．フィールド情報の取得
フィールドの情報を取得します。

固定フォームのメニュー

９．ページの追加
編集中のページの後ろに新しいページを追加します。

10．ページコピー
編集中のページの後ろに、編集中のページと同じフォームを追加します。

11．ページ削除
フォーカスのあるページを削除します。

12．ページを上に移動
フォーカスのあるページを上へ移動します。

13．ページを下に移動
フォーカスのあるページを下へ移動します。

14．ページキー変更
フォーカスのあるページのページキーを変更します。

15．すべてのページキーをコピー
すべてのページキーをクリップボードにコピーします。
メモ帳などのテキストエディタで「貼り付け」をすると、全部のページキーを取得できます。

可変フォームのメニュー

９．セクション追加
編集中のセクションの後ろに新しいセクションを追加します。

10．セクションコピー
編集中のセクションの後ろに、編集中のセクションと同じセクションを追加します。

11．セクション削除
フォーカスのあるセクションを削除します。

12．セクションを上に移動
フォーカスのあるセクションを上へ移動します。

13．セクションを下に移動
フォーカスのあるセクションを下へ移動します。

14．セクションキー変更
フォーカスのあるセクションのセクションキーを変更します。

15．すべてのセクションキーをコピー
すべてのセクションキーをクリップボードにコピーします。
メモ帳などのテキストエディタで「貼り付け」をすると、全部のセクションキーを取得できます。


ヘルプ(フォーム設計モード)

ヘルプ

１．目次
ヘルプを表示します。

２．バージョン情報
レポートエディタのバージョン情報を表示します。


用紙の設定

レポートエディタでは、様々な用紙サイズのフォームを作成することができます。
用紙の設定は、フォームメニューの「用紙サイズ」「用紙方向」「フォーム情報」で行います。

１．フォームメニュー／用紙サイズ

フォームの用紙サイズを指定します。

２．フォームメニュー／用紙方向

フォームの用紙方向を指定します。
ユーザー定義サイズの場合は「環境設定／ユーザー定義サイズ」で作成した時の用紙方向となります。

３．フォームメニュー／フォーム情報

用紙サイズ
用紙サイズを指定します。
ユーザー定義サイズを使用する場合は「環境設定／ユーザー定義サイズ」で用紙を作成しておきます。

用紙方向
用紙方向を指定します。
ユーザー定義サイズの場合は、作成時の用紙方向を変更することはできません。

単位
余白を設定する単位を指定します。

余白
用紙の余白を指定します。
「初期値」ボタンを押すと、「環境設定／用紙の余白」で設定された値となります。
余白は、ジャイブレポートのバージョンによって仕様が異なります。
余白の詳細は「付録／用紙の余白（マージン）設定」を参照してください。


ラベル印刷の設定

レポートエディタでは、様々なサイズのラベルを作成することができます。
ラベル印刷の設定は、フォームメニューのラベル印刷タブで行います。

※ラベルは固定フォームで作成します。可変フォームでは作成できません。

１．ラベル印刷を行う
ラベル印刷を行う時にクリックします。チェックがはずれていると各種の設定ができません。

２．用紙方向、用紙サイズ、マージン
用紙情報タブで選択されている用紙方向、用紙サイズ、マージンが表示されます。変更する場合は、用紙情報タブで変更を行なってください。

３．ラベル枚数
一枚の用紙内の縦横のラベル枚数を指定します。

４．ラベルサイズ
ラベル一枚のサイズを指定します。

５．ラベル間隔
ラベルとラベルの間隔を指定します。

６．コンボボックス・登録・削除
設定した内容は保存して何度も使うことができます。
保存する場合は、コンボボックスにラベル名称を入力して登録ボタンを押し、最後にOKボタンで終了します。キャンセルボタンで終了すると登録されません。

ラベルを登録すると、次回からコンボボックスで登録済みラベルを選択することができます。
登録済みのラベルを削除する場合は、コンボボックスで削除するラベルを選択し、削除ボタンを押し、最後にOKボタンで終了します。
ラベルの登録を行なう場合は、環境設定でラベル定義ファイル名の設定が必要です。

ナナフォームのラベル印刷
ジャイブレポートには、ナナフォームのラベル定義ファイルが添付しています。
すぐにタックラベルを印刷したい時には、ナナフォームのラベル用紙を用意すれば、タックラベルを印刷することができます。

－ナナフォームのラベル印刷方法


フォームファイル情報の設定

ファイル情報の設定

フォームファイルの情報は、ファイルメニューのファイル情報で設定します。
フォームファイル情報は、フォームファイル全体に対して1つ持つことができます。
フォームファイルに複数のフォームが存在してもフォーム毎に持つことはできません。

１．フォームファイル名称
フォームファイルの名称を32バイト以内で指定します。
この名称は、ページウィンドウでページツリーの先頭に表示されます。
この名称は、レポートライブラリから取得できます。
（jvGetStringファンクション、FormTitleプロパティ）

２．作成者
フォームファイルの作成者を32バイト以内で指定します。
この作成者は、レポートライブラリから取得できます。
（jvGetStringファンクション、FormCreatorプロパティ）

３．フォームファイルの説明
フォームファイルの説明を256バイト以内で指定します。
この説明は、レポートライブラリから取得できます。
（jvGetStringファンクション、FormCommentプロパティ）

４．禁則文字
フォームファイルに描画された固定文字列とテキストフィールドに対して、禁則処理の対象となる禁則文字を指定します。
禁則処理とは、行頭に句読点や終わり括弧がきたり、行末に始まり括弧がきたりすることを防ぐ機能です。行頭禁則文字は192バイトまで、行末禁則文字は64バイトまで指定できます。

５．カラー描画を行う
フォームファイルのすべてのオブジェクトをカラー描画するかどうかを指定します。この項目がチェックされていると画面も印刷もカラー出力され、チェックされていないと画面も印刷もモノクロで出力されます。

６．高速印刷モードにする
帳票を高速に印刷する場合は、高速印刷モードを選択します。
高速印刷モードを選択すると、シャドウ、フェードアウト、ソフトエッジ、グラデーション、テクスチャ、カスタムブラシ、３Ｄ、文字変形が使用できなくなります。

７．バーコードのPDF出力をバージョン10.03以前の精度で行う
PDF形式で出力されるバーコードは、Ver.10.04で、高精度に描画するための改良が行われました。旧バージョン（～Ver.10.03）の精度のままで描画する場合には、この項目をチェックしてください。Ver.10.03までのフォームファイルを開くと、この項目は自動的にチェックされ、バーコードは旧バージョンの精度で描画されます。高精度で描画したい場合にはチェックをはずします。

８．文字列の描画をバージョン10.0以前の仕様で行う
文字列の描画は、Ver.10.1で、Windowsの標準サイズになるように改良が行われました。特に、プロポーショナルフォントの文字や、文字回転機能で回転した文字は、文字の描画位置が変わっています。Ver.10.0以前のまま描画したい場合には、この項目をチェックしてください。古いバージョンのフォームファイルを読み込んだ時には、自動的にこの項目がチェックされます。新しい描画位置で描画したい場合にはチェックをはずします。

9．PDF出力時にフォームオーバーレイ登録を行う
PDF形式で出力する時に、帳票の固定部分をオーバーレイ登録し、出力されるファイルのデータ量を減らします。出力ページ数が多い場合に効果があります。
Adobe PDFデータのオーバーレイ登録


オブジェクトの選択

レポートエディタ上で、作成したオブジェクトを選択する操作を解説します。

１．オブジェクトを選択する時には、選択するオブジェクト上にマウスポインタを移動し左ボタンをクリックします。

２．複数のオブジェクトを選択する場合には、マウスをドラッグして選択するオブジェクトをすべて含む矩形を描きます。

３．選択するオブジェクト上にマウスポインタを移動し、シフトキーを押しながら左ボタンをクリックすると、複数のオブジェクトを選択できます。

４．複数オブジェクトが選択された状態でリサイズすると、選択中の全オブジェクトがリサイズされます。

５．重なり合ったオブジェクトの下のオブジェクトを選択する場合には、オブジェクト上にマウスポインタを移動しマウスの右ボタンをクリックすると、「下のオブジェクトを選択」を実行することができます。

６．塗り潰し無しの四角形を選択する時には、四角形の線上をクリックします。


文字の入力

１．左ツールバーの文字オブジェクトボタンをクリックします。

２．文字を描画する位置にマウスポインタを移動しマウスをクリックします。

３．文字を入力します。
    サロゲートペアを入力する時には、文字プロパティ画面の入力ボックスで入力してください。

４．改行コードを入力すると次の行に入力できます。

５．文字の位置調整や領域のリサイズを行います。

６．入力した文字を変更する場合には、変更する文字を選択しマウスをダブルクリックすると再入力できます。
    入力した文字列にサロゲートペアが含まれる場合には、文字をダブルクリックすると文字プロパティ画面が開きます。
    再入力は、文字プロパティ画面で行います。


文字プロパティの設定

文字のプロパティは、文字プロパティ画面、またはプロパティウィンドウで設定します。

文字プロパティ画面の表示
・文字を選択後、プロパティウィンドウのプロパティページボタンをクリックする。
・文字を選択後、マウスの右ボタンをクリックし、ポップアップメニューでプロパティを選択する。

全体タブ

１．文字ピッチ
文字と文字の間のピッチを指定します。

２．行ピッチ
行と行の間のピッチを指定します。

３．インデント
複数行にまたがる文字列のインデント（字下げ、ぶら下げ）を指定します。
正の値は1行目のインデント（字下げ）となり、負の値は2行目以降のインデント（ぶら下げ）となります。

４．段数
文字列の段組を指定します。5段まで指定することができます。

５．段の間隔
段数を2以上の値にした場合の段と段の間隔を指定します。

６．文字配置（横）
横方向の文字列の位置を指定します。

７．文字配置（縦）
縦方向の文字列の位置を指定します。
改行方向に「改行なし」を指定した場合のみ設定可能です。

８．文字方向
文字の描画方向を指定します。「横書き逆」を選択すると右から左へ描画します。
「縦書き逆」を選択すると下から上へ描画します。

９．改行方向
改行コードを入力したときの改行方向を指定します。
「改行なし」を選択するとシングルラインになります。
改行位置はプリンタドライバによって異なります。プリンタドライバによっては、1行で収まるはずの文字列が自動改行され2行になることがあります。改行したくない文字列は［改行なし］を選択しておくと自動改行されません。

10．文字位置の微調整
入力した文字位置の縦横の微調整を行います。

11．禁則処理
禁則処理を指定します。
禁則処理の対象となる文字は［フォーム／フォームファイルの情報］で登録することができます。

12．ワードラップ
英文ワードラップを指定します。

フォントタブ

１．フォント名称
フォントの種類を指定します。
フォント選択ボックスには、使用中のPCにインストール済みのフォントが一覧表示されます。先頭に＠記号が付いているものは縦書き用フォント、先頭に－記号が付いているものはTrueType以外のフォントです。
既に作成済みのフォームを開いた時、フォーム中に設定されているフォントがPCに存在しない場合は、該当フォント名の先頭に＊記号がつきまうｓ。

２．フォントサイズ
フォントサイズを指定します。

３．フォント横幅拡大率
フォントサイズの横幅の拡大縮小率を指定します。

４．フォント回転角度
文字の回転角度を指定します。文字は、設定された角度で反時計回りに回転します。文字を回転させる場合は、TrueTypeフォントを選択するときれいに回転します。

５．イタリック・ボールド
文字の斜体と太字を指定します。

６．打ち消し線
文字の打ち消し線を指定します。

７．下線
文字の下線を指定します。

８．下線と文字の距離
文字と下線との間の距離を指定します。

文字タブ

１．文字入力ボックス
表示する文字列を入力します。
文字を入力すると、入力ボックスの左上に、文字の桁数(バイト数)が表示されます。
サロゲートペアを入力する場合には、この入力ボックスで入力します。
サロゲートペアを入力する前に、UNICODEのチェックボックスをチェックしておきます。
サロゲートペアは、レポートエディタの画面上で直接入力することができません。

２．UNICODE
UNICODE文字を入力する時にチェックします。
サロゲートペアを入力する時には、ここをチェックします。

３Ｄタブ

※３Ｄタブは、高速印刷モードの時は使用できません。

１．スタイル
３Dのスタイルを指定します。なしを選択するとサイズと3Dの深さは指定できません。

２．サイズ
3D文字の斜面サイズを指定します。値が大きくなるにつれ、斜面の面積が増え立体感が増します。選択したフォントによって斜面サイズは変わります。

３．3Dの深さ
3Dの深さを指定します。値が大きくなるにつれ、3Dが深くなり立体感が強調されます。
注意）
「特殊効果／ソフトエッジ」が設定されている場合、3Dは有効になりません。
「特殊効果／シャドウ」で下段(4つ)のスタイルが選択されている場合、3Dは有効になりません。

３Ｄの例
１．「JIVEREPORT」

＜ﾌｫﾝﾄ＞種類：Impact、ﾌｫﾝﾄｻｲｽﾞ：50ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：60％
＜固定文字領域＞Width：3825、Height：2130
＜3D＞ｽﾀｲﾙ：凸型　ｻｲｽﾞ：100%　3Dの深さ：25
＜文字変形＞ﾊﾟﾀｰﾝ：5番目、変形度：75
＜ﾌｪｰﾄﾞｱｳﾄ＞ﾊﾟﾀｰﾝ：4番目、X軸ｵﾌｾｯﾄ：8.00mm、Y軸ｵﾌｾｯﾄ：8.00mm、色：2色（色1黒、色2白）

輪郭線タブ

１．輪郭線チェックボックス
文字の輪郭線描画を指定します。
チェックされていない場合、輪郭線は描画されず、２以降のプロパティは設定できません。

２．輪郭線の種類
文字につける輪郭線の種類を選択します。「なし」が選択されていると輪郭線は描画されません。

３．輪郭線の幅
文字につける輪郭線の幅を指定します。
幅が0.00ミリに設定された場合、輪郭線は「前景色」で描画されます。
幅が0.01ミリ以上に設定された場合は、輪郭線は「輪郭線の色」で選択された色で描画されます。

４．輪郭線の色
文字につける輪郭線の色を指定します。

５．線の端
文字に輪郭線を描画した場合、輪郭線の先端の形状を選択します。
輪郭線に「実線」以外の種類が選択された場合のみ有効です。

６．線の接合部
文字に輪郭線を描画した場合、輪郭線の接合部の形状を選択します。
輪郭線に「実線」以外の種類が選択された場合のみ有効です。
注意）特殊効果の「ソフトエッジ」が設定されていると、輪郭線は有効になりません。

変形タブ

※変形タブは、高速印刷モードの時は使用できません。
※変形文字の機能は、UNICODEの文字には使用できません。

１．文字の変形チェックボックス
文字の変形を指定します。チェックされていない場合、文字は変形されません。

２．変形度
変形の度合いを指定します。

３．変形パターンリスト
変形するパターンを26種類の中から選択します。
文字が回転するタイプのパターンは、フォントの種類をTrueTypeフォントにするときれいに回転します。（TrueType以外のフォントではきれいに回転しない場合があります。）

文字変形の例

１．「帳票作成ツール」

＜ﾌｫﾝﾄ＞種類：HG創英角ｺﾞｼｯｸUB、ﾌｫﾝﾄｻｲｽﾞ：29ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：79％、ﾎﾞｰﾙﾄﾞ
＜固定文字領域＞Width：3945、Height：1635
＜輪郭線＞実線：0.52ﾐﾘ、色：白
＜文字変形＞ﾊﾟﾀｰﾝ：23番目、変形度：35
＜ｼｬﾄﾞｳ＞ﾊﾟﾀｰﾝ：上段4番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：1.00mm、ｼｬﾄﾞｳｻｲｽﾞ：100%、透明度：30%、ｿﾌﾄｴｯｼﾞ：2.00mm

２．「帳票作成ツール」

＜ﾌｫﾝﾄ＞種類：HGP創英角ﾎﾟｯﾌﾟ体、ﾌｫﾝﾄｻｲｽﾞ：30ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：80％、ﾎﾞｰﾙﾄﾞ
＜固定文字領域＞Width：3330、Height：2655
＜3D＞ｽﾀｲﾙ：凸型　ｻｲｽﾞ：100%　3Dの深さ：50
＜文字変形＞ﾊﾟﾀｰﾝ：24番目、変形度：40
＜ｼｬﾄﾞｳ＞ﾊﾟﾀｰﾝ：上段4番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：1.00mm、ｼｬﾄﾞｳｻｲｽﾞ：100%、透明度：50%、ｿﾌﾄｴｯｼﾞ：2.00mm

３．「JIVEREPORT」

＜ﾌｫﾝﾄ＞種類：Impact、ﾌｫﾝﾄｻｲｽﾞ：50ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：60％
＜固定文字領域＞Width：3825、Height：2130
＜3D＞ｽﾀｲﾙ：凸型　ｻｲｽﾞ：100%　3Dの深さ：25
＜文字変形＞ﾊﾟﾀｰﾝ：5番目、変形度：75
＜ﾌｪｰﾄﾞｱｳﾄ＞ﾊﾟﾀｰﾝ：4番目、X軸ｵﾌｾｯﾄ：8.00mm、Y軸ｵﾌｾｯﾄ：8.00mm、色：2色（色1黒、色2白）

４．「JiveReport」

＜ﾌｫﾝﾄ＞種類：ＭＳ 明朝、ﾌｫﾝﾄｻｲｽﾞ：50ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：50％
＜固定文字領域＞Width：2625、Height：2805
＜文字変形＞ﾊﾟﾀｰﾝ：19番目、変形度：なし
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：黒、2色：白、種類：縦、ﾊﾞﾘｴｰｼｮﾝ：左右
※バックの赤いぼかしは、四角形で作成されています。
四角形の値　＜ｸﾞﾗﾃﾞｰｼｮﾝ＞種類：楕円、ﾊﾞﾘｴｰｼｮﾝ：中心から

クエリー／計算式タブ

クエリーや計算式を設定します。

このタブはテキストフィールドの時に使用できます。固定文字では使用できません。

その他のプロパティ

プロパティウィンドウでは、前景色、背景色、塗り潰し効果、特殊効果、背景モード、位置(Left,Top)、領域(Height,Width)を設定することができます。

前景色と背景色は、「塗り潰し効果／パターン」のストックブラシ3番目～6番目（塗り潰しタイプ）以外のパターンを選択した時に使われます。

背景モードでは、「上書き」と「透過」を選択できます。「透過」は、「塗り潰し効果／パターン／ストックブラシ」の右から6個のみ有効となります。それ以外のパターン、テクスチャ、グラデーションでは無効です。


塗り潰し効果

文字や図形には、塗り潰し効果を設定することができます。
塗り潰し効果には、グラデーション、テクスチャ、パターンの3種類があります。

図形では以下のオブジェクトに設定できます。
四角形、楕円、扇、弓、多角形（クローズ）、ベジェ（クローズ）

塗り潰し効果は、高速印刷モードの時は設定できません。
3Dなど、他の機能と一緒に使うこともできます。

グラデーションの例

テクスチャの例

パターンの例

塗り潰し効果ダイアログは、以下の方法でポップアップします。
・オブジェクトを選択→プロパティウィンドウの塗り潰し効果をクリック
・オブジェクトを選択→マウスの右ボタンクリック→ポップアップメニューの塗り潰し効果を選択

グラデーションタブ

１．色（1色、2色）
グラデーションに使う色を選択します。1色を選択すると、元になる色と明暗を設定できます。2色を選択すると、元になる2つの色を選択できます。

２．グラデーションの種類
グラデーションの種類を選択します。

３．バリエーション
グラデーションの種類によってバリエーションが異なります。好みのバリエーションを選択します。
注意1）特殊効果の「ソフトエッジ」が設定されていると、グラデーションは有効になりません。
注意2）図形（四角形、楕円、扇、弓、クローズした多角形）の塗り潰し効果にグラデーションを設定し、特殊効果のシャドウやフェードアウトを付ける場合は、背景モードを「上書き」にします。背景モードを「透過」にすると、シャドウやフェードアウトが浮き上がります。

テクスチャタブ

１．テクスチャリスト
40種類のリストからテクスチャを選択します。

２．色相
選択したテクスチャの色相を指定します。リストのままでよい場合は0を指定します。

３．明度
選択したテクスチャの明度を指定します。リストのままでよい場合は0を指定します。

４．彩度
選択したテクスチャの彩度を指定します。リストのままでよい場合は0を指定します。
注意）特殊効果の「ソフトエッジ」が設定されていると、テクスチャは有効になりません。
注意2）図形（四角形、楕円、扇、弓、クローズした多角形）の塗り潰し効果にテクスチャを設定し、特殊効果のシャドウやフェードアウトを付ける場合は、背景モードを「上書き」にします。背景モードを「透過」にすると、シャドウやフェードアウトが浮き上がります。

パターンタブ

１．ストックブラシ
ストックブラシはWindowsで用意されているパターンです。カスタムブラシに比べて高速に印刷できます。左から7番目のパターン～14番目のパターンまでは、背景を透過にできます。
※ストックブラシの左から7番目～14番目のパターン上に、3Dや特殊効果を設定したオブジェクト（文字と一部の図形）をのせた場合、オブジェクトの周辺がきれいに印刷されないことがあります。

２．カスタムブラシ
カスタムブラシはユーザー定義パターンです。48種類の中から選択できます。カスタムブラシは、背景を透過にできません。

３．前景色
パターンの柄の部分の色を指定します。
図形の場合、線種に「なし」以外を選択していると、前景色の色で線を描画します。
※文字の縁は、「プロパティ／輪郭線」で設定した色になります。
※前景色は、ソフトエッジを設定すると、ソフトエッジで選択した色に変わります。

４．背景色
パターンの背景部分の色を指定します。
注意）特殊効果の「ソフトエッジ」が設定されていると、パターンは有効になりません。
注意2）図形（四角形、楕円、扇、弓、クローズした多角形）の塗り潰し効果にパターンを設定し、特殊効果のシャドウやフェードアウトを付ける場合は、背景モードを「上書き」にします。背景モードを「透過」にすると、選択したパターンによっては、シャドウやフェードアウトが浮き上がります。


特殊効果

文字や図形には、特殊効果を設定することができます。
特殊効果では、シャドウ、フェードアウト、ソフトエッジを設定できます。

3Dなどの他の機能と一緒に使うこともできます。
塗り潰し効果は、高速印刷モードの時は設定できません。

注意）図形（四角形、楕円、扇、弓、クローズした多角形）にシャドウやフェードアウトを設定する場合には、背景モードを「上書き」にしておきます。「透過」にすると、塗り潰し効果の種類によっては、シャドウやフェードアウトが浮き出ることがあります。

シャドウの例

フェードアウトの例

ソフトエッジの例

特殊効果ダイアログは、以下の方法でポップアップします。
・オブジェクトを選択→プロパティウィンドウの特殊効果をクリック
・オブジェクトを選択→マウスの右ボタンクリック→ポップアップメニューの特殊効果を選択

シャドウ

１．形状
シャドウの形状を選択します。上段の6種類は、オブジェクトの外側にシャドウがつきます。下段の4種類は、オブジェクトの内側にシャドウがつきます。
※下段4種類を選択すると、3Dは無効になります。

２．色
シャドウの色を選択します。

３．X軸オフセット
オブジェクトからシャドウまでのX軸方向の距離を指定します。0mmの時、オブジェクトとシャドウがX軸方向で重なります。

４．Y軸オフセット
オブジェクトからシャドウまでのY軸方向の距離を指定します。0mmの時、オブジェクトとシャドウがY軸方向で重なります。

５．シャドウサイズ
シャドウの大きさを指定します。100%の時、オブジェクトと同サイズのシャドウが描画されます。

６．傾斜角度
シャドウの傾斜角度を指定します。
形状が傾斜タイプのもの（上段の右端と右から2つ目）を選択した場合に指定可能です。

７．透明度
シャドウの色の透明度を指定します。
0%の時、シャドウ色＝設定色となり、100%の時、シャドウ色は透明になります。

８．ソフトエッジ
シャドウの縁のソフトエッジ幅を指定します。
0mmの時、シャドウの縁はくっきりと描画され、値が大きくなると、シャドウの縁に淡くぼかしがかかります。

シャドウの例）

この文字と図形は以下の値で作成しました。
文字
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：75ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：100％
＜3D＞ｽﾀｲﾙ：凸型、ｻｲｽﾞ：100％、3Dの深さ：25
＜ﾃｸｽﾁｬ＞種類：1番目、色相：0、明度：45、彩度：0
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：2.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、
ｼｬﾄﾞｳｻｲｽﾞ100%、透明度50%、ｿﾌﾄｴｯｼﾞ：2.00mm
図形
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：赤、2色：白、種類：中央から、ﾊﾞﾘｴｰｼｮﾝ：中心から

この文字と図形は以下の値で作成しました。
文字
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：75ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：100％
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：赤、2色：黄、種類：右上対角線、ﾊﾞﾘｴｰｼｮﾝ：右上から
＜ｼｬﾄﾞｳ＞種類：上段6番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：1.00mm、
ｼｬﾄﾞｳｻｲｽﾞ100%、傾斜角度：４5度、透明度50%、ｿﾌﾄｴｯｼﾞ：2.00mm
図形
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：黒、2色：白、種類：横、ﾊﾞﾘｴｰｼｮﾝ：下から

この文字と図形は以下の値で作成しました。
文字
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：75ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：100％
＜ﾃｸｽﾁｬ＞種類：1番目、色相：0、明度：45、彩度：0
＜ｼｬﾄﾞｳ＞種類：下段3番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：1.00mm、
ｼｬﾄﾞｳｻｲｽﾞ100%、透明度35%、ｿﾌﾄｴｯｼﾞ：1.50mm
図形
＜3D＞ｽﾀｲﾙ：凸型、枠全体のｻｲｽﾞ：2.00ﾐﾘ、枠の平坦部のｻｲｽﾞ：1.50ﾐﾘ、3Dの深さ：50
＜ﾃｸｽﾁｬ＞種類：1番目、色相：0、明度：0、彩度：0
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：2.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、
ｼｬﾄﾞｳｻｲｽﾞ100%、透明度50%、ｿﾌﾄｴｯｼﾞ：2.00mm

フェードアウト

１．形状
フェードアウトの形状を選択します。

２．X軸オフセット
フェードアウトのX軸方向の距離を指定します。

３．Y軸オフセット
フェードアウトのY軸方向の距離を指定します。

４．色（1色、2色）
フェードアウトの色を指定します。

ソフトエッジ

１．サイズ
ソフトエッジのサイズを指定します。

２．色
ソフトエッジの色を指定します。
※ソフトエッジが設定されていると、塗り潰し効果は無効となります。


図形の描画

１．直線の描画
直線ボタンをクリックします。
直線の描画開始位置へマウスポインタを移動します。
直線の描画終了位置までマウスをドラッグします。
※シフトキーを押しながら操作すると、垂直線または水平線のみ描画できます。

２．四角形の描画
四角形ボタンをクリックします。
四角形の描画開始位置へマウスポインタを移動します。
四角形の描画終了位置までマウスをドラッグします。

３．円・楕円の描画
円ボタンをクリックします。
円の描画開始位置へマウスポインタを移動します。
円の描画終了位置までマウスをドラッグします。

４．弧・弓・扇の描画
弧・弓・扇ボタンをクリックします。
弧の描画開始位置へマウスポインタを移動します。
弧の描画終了位置までマウスをドラッグし円を描画します。
弧の始点へマウスポインタを移動し、反時計回りにドラッグし弧のサイズを調節します。
プロパティウィンドウの弧弓扇で弧・弓・扇のいずれかを選択します。
※「編集／グリッドに合わせる」が設定されていると、弧は15度単位で描画されます。

５．多角形・曲線の描画
多角形・曲線ボタンをクリックします。
多角形の描画開始位置へマウスポインタを移動します。
多角形の頂点となる位置にマウスの左ボタンをクリックし頂点をセットします。
マウスの左ボタンをダブルクリックすると多角形が描画されます。
描画された多角形を選択しマウスの右ボタンを押すと「はさみ」を選択することができます。はさみを使うと、既に描画された多角形の頂点を増やし、多角形の形を変えることができます。はさみを選択するとマウスカーソルがはさみになります。多角形の線上の頂点を増やす位置にマウスポインタを移動し、マウスの左ボタンをクリックすると、新しい頂点が作成されます。
プロパティウィンドウの多角形/ベジェプロパティで多角形かベジェのどちらかを選択します。多角形を選択すると頂点と頂点は直線で結ばれ、ベジェを選択すると頂点と頂点はベジェ曲線で結ばれます。
プロパティウィンドウのオープン/クローズプロパティでオープンかクローズのどちらかを選択します。クローズを選択すると、最初にセットした頂点と最後にセットした頂点は結ばれて閉じた図形となり、オープンを選択すると、最初にセットした頂点と最後にセットした頂点は結ばれず開いた図形となります。
頂点が２つ以下の場合には多角形は描画されません。
頂点が３つ以下の場合にはベジェ曲線による図形は描画されません。


図形プロパティの設定

図形のプロパティは、図形プロパティ画面、またはプロパティウィンドウで設定します。

図形プロパティ画面の表示
・図形を選択後、プロパティウィンドウのプロパティページボタンをクリックする。
・図形を選択後、マウスの右ボタンをクリックし、ポップアップメニューでプロパティを選択する。
複数の図形を選択しプロパティを変更すると、選択中の図形のプロパティが変更されます。
（変更できないプロパティもあります。）

線種／線幅タブ

１．線種
線の種類を選択します。

２．線幅
線の幅をドット単位かミリ単位で指定します。
ドット単位で指定した場合は、プリンタの解像度によって線の幅が変わります。
ミリ単位の指定では、プリンタの解像度に関係なく同じ幅の線を描画できます。
環境設定で指定したプリンタの解像度の値が画面の解像度（通常96～120DPI）と比べて非常に大きい場合、線の幅を太くしても画面上は変化しないことがありますが、印刷すると設定した線の幅で描画されます。（『環境設定』参照）

線の端と接合部タブ

１．線の端
線の端の形状を選択します。

２．接合部
線の接合部の形状を選択します。四角形、弓などの接合部がある図形に有効です。

角丸めタブ（四角形のみ）

１．角丸め半径指定
四角形の角丸め半径を指定します。

２．角丸め位置ボックス
角を丸める位置を指定します。小さなボックスをクリックすると任意の角を指定できます。
中央の大きなボタンをクリックするとすべての角を指定できます。

３Ｄパネルタブ（四角形、楕円）

※３Ｄパネルタブは、高速印刷モードの時は使用できません。

１．スタイル
3Dのスタイルを選択します。

２．枠全体のサイズ
立体部分のサイズを設定します。値が大きくなるにつれ、立体部分が増え立体感が増します。

３．枠の平坦部のサイズ
立体上部の平坦部のサイズを設定します。

４．3Dの深さ
3Dの深さを設定します。値が大きくなるにつれ、3Dが深くなり立体感が強調されます。
注意１）特殊効果の「ソフトエッジ」が設定されている場合、3Dは有効になりません。
注意２）特殊効果の「シャドウ」に内側のパターン(下段)が選択されている場合、3Dは有効になりません。

矢印タブ（直線、オープンした多角形／ベジェ）

１．始点のスタイル
始点の矢印のスタイルを選択します。

２．始点のサイズ
始点の矢印のサイズを選択します。

３．終点のスタイル
終点の矢印のスタイルを選択します。

４．終点のサイズ
終点の矢印のサイズを選択します。

その他のプロパティ

プロパティウィンドウでは、前景色、背景色、塗り潰し効果、特殊効果、背景モード、位置(Left,Top)、領域(Height,Width)を設定することができます。
四角形、クローズした多角形／ベジェ、扇、弓、楕円の場合、前景色と背景色は、プロパティウィンドウまたは「塗り潰し効果／パターン」のどちらでも設定できます。
直線、オープンした多角形／ベジェ、弧の色は、プロパティウィンドウの前景色で設定します。
背景モードの「透過」は、「塗り潰し効果／パターン／ストックブラシ」の右から6個のみ有効となります。それ以外のパターン、テクスチャ、グラデーションでは無効です。


バーコードの描画

レポートエディタでは、JAN標準形、JAN短縮形、CODE39、NW7、ITF、CODE128(EAN128)、UPC、カスタマバーコード、QRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードを描画することができます。

１．バーコードオブジェクトボタン [image] をクリックします。

２．バーコードを描画する位置にマウスポインタを移動しクリックします。

３．ダミーのバーコードが表示されます。


バーコードプロパティの設定

バーコードのプロパティは、バーコード画面、またはプロパティウィンドウで設定します。

バーコード画面の表示
・バーコードを選択後、プロパティウィンドウのプロパティページボタンをクリックする。
・バーコードを選択後、マウスの右ボタンをクリックし、ポップアップメニューでプロパティを選択する。

全体タブ

１． 可変（フィールド）・固定
印刷時に描画するバーコードが変わる場合は、可変（フィールド）をクリックします。
常に同じバーコードを描画する場合は、固定コードをクリックします。

２． クエリー
可変（フィールド）の場合に入力できます。クエリーは、レポートエディタの帳票印刷モードによる帳票印刷時に使用します。データの取得先がACCESSかODBCの場合には、ここにクエリーを設定しておくと、データを取得することができます。（『クエリーの設定』参照）

３． コード
固定バーコードの場合に入力できます。描画するコードを入力します。
設定されているバーコードの種類によって入力制限があります。

４． バーコードの種類
描画するバーコードの種類を指定します。

５． チェックディジット
入力コードにチェックディジットを付加して出力します。
バーコードの種類がCODE39、NW7、CODE128の場合にのみ有効です。

６． 向き
バーコードを出力する向きを指定します。

各バーコードの詳細は、以下を参照してください。
－JAN標準形・短縮形
－CODE39、
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マイクロQRコード
－PDF417コード
－マイクロPDF417コード

サイズタブ（カスタマバーコード・QR・マイクロQR・PDF417・マイクロPDF417以外の場合）

１．バーの長さ
バーコードのバーの高さを指定します。

２．バーの幅（細い順）
バーの幅を細い方から順番に指定します。最も細いバーの幅を指定すると、他のバー幅は自動的に設定されますが、任意の値にすることもできます。

３．スペースの幅（細い順）
スペースの幅を細い方から順番に指定します。最も細いスペースの幅を指定すると、他のスペース幅は自動的に設定されますが、任意の値にすることもできます。
細いスペースと太いスペースの標準的な比率はバーの幅と同じです。

４．キャラクタ間ギャップ
キャラクタ間ギャップを指定します。

サイズタブ（カスタマバーコードの場合）

※カスタマバーコードは、４種類のバーで構成されます。バーの幅はすべて同じで、長さの違いによってコードを表します。ロングバーの長さは3.4mm～3.6mm、タイミングバーの長さは1.05mm～1.35mmで、3:1の比率になるように指定します。

バーの幅は0.5mm～0.7mm、スペースの幅は0.45mm～0.6mmで指定します。基準値としては、ロングバーが3.6mm、タイミングバーが1.2mm、バーの幅とスペースの幅が0.6mmです。

１．ロングバー/タイミングバーの長さ
ロングバーとタイミングバーの高さを指定します。

２．バーとスペースの幅
バーとスペースの幅を指定します。

QRタブ（QRコードの場合）

１．誤り訂正レベル
コード面積の汚れや破損に対する復元率を指定します。
(低) Ｌ→Ｍ→Ｑ→Ｈ (高)の順に高い復元率となります。
高レベルを設定する程復元率は高まりますが、誤り訂正コードの含有率が高くなるため、表現できる情報量は減少します。

２．一辺の長さ
描画するQRコードの一辺の長さを3ミリ～100ミリの範囲内で指定します。

３．型番
QRコードの型番を指定します。
自動を指定すると、渡されたコード（情報量）から最適な型番が自動選択されます。
型番1を指定すると、QRコードは最小の21×21セルで描画されます。
型番40を指定すると、QRコードは最大の177×177セルで描画されます。
型番を指定すると、情報量が型番の容量を超えた時エラーとなり、QRコードは描画されません。

４．マスクNo.
QRコードのモジュールバランスを最適化するマスク処理のパターンを指定します。
自動を指定すると、作成するQRコードに最適なパターンが自動選択されます。
マスクNo.には、8種類のパターンが用意されていますが、通常は自動を選択することを推奨します。
描画したQRコードが読み取れない時は、8種類のパターンの中から、読み取れるパターンを探してください。

マイクロQRタブ（マイクロQRコードの場合）

１．誤り訂正レベル
コード面積の汚れや破損に対する復元率を指定します。
(低) Ｌ→Ｍ→Ｑ (高)の順に高い復元率となります。
高レベルを設定する程復元率は高まりますが、誤り訂正コードの含有率が高くなるため、表現できる情報量は減少します。

２．一辺の長さ
描画するマイクロQRコードの一辺の長さを1ミリ～100ミリの範囲内で指定します。

３．型番
マイクロQRコードの型番を指定します。
自動を指定すると、渡されたコード（情報量）から最適な型番が自動選択されます。

４．マスクNo.
マイクロQRコードのモジュールバランスを最適化するマスク処理のパターンを指定します。
自動を指定すると、作成するマイクロQRコードに最適なパターンが自動選択されます。
マスクNo.には、4種類のパターンが用意されていますが、通常は自動を選択することを推奨します。
描画したQRコードが読み取れない時は、読み取れるパターンを探してください。

PDF417タブ（PDF417コード）

１．誤り訂正レベル
コード面積の汚れや破損に対する復元率を指定します。
自動を指定すると、渡されたコード（情報量）から最適な誤り訂正レベルが自動選択されます。

２．列数
2～30の範囲内で指定します。

３．行数
10～90の範囲内で指定します。

４．高さ
3ミリ～100ミリの範囲内で指定します。

５．縦横比率（横／縦）
10%～1000%の範囲内で指定します。

マイクロPDF417タブ（マイクロPDF417コード）

１．サイズ（列数×行数）
自動を指定すると、渡されたコード（情報量）から最適なサイズが自動選択されます。

２．高さ
3ミリ～100ミリの範囲内で指定します。

３．縦横比率（横／縦）
10%～1000%の範囲内で指定します。


イメージの描画

レポートエディタでは、BMP形式、DIB形式、JPEG形式、PNG形式、TIFF形式(圧縮形式はパックビット圧縮、非圧縮のみ対応)、 EMF形式(拡張メタファイル)のイメージを描画することができます。

１．イメージオブジェクトボタン [image] をクリックします。

２．イメージを描画する位置にマウスポインタを移動し、イメージを描画するための領域を確保します。

３．イメージ枠が表示されます。


イメージプロパティの設定

イメージのプロパティは、イメージ画面、またはプロパティウィンドウで設定します。

イメージ画面の表示
・イメージを選択後、プロパティウィンドウのプロパティページボタンをクリックする。
・イメージを選択後、マウスの右ボタンをクリックし、ポップアップメニューでプロパティを選択する。

１． 可変（フィールド）・固定
印刷時に描画するイメージが変わる場合は可変（フィールド）を選択します。常に同じイメージを描画する場合は固定を選択します。

２． クエリー
可変（フィールド）の場合に有効です。帳票印刷時にデータの取得先がACCESSかODBCの場合には、ここにクエリーを設定しておくと、データを取得することができます。（『クエリーの設定』参照）

３． 表示サイズ
イメージの表示サイズを指定します。「枠指定」を選択すると、イメージは確保したイメージ領域の大きさで表示されます。「DPI指定」を選択すると、イメージは指定されたDPIで表示されます。

４． 背景
イメージの背景を指定します。「透過」を選択すると、イメージと他のオブジェクトが重なっている場合、下のオブジェクトが透けて見えます。［非透過］を選択すると、下のオブジェクトは透けて見えません。
※プリンタによっては、透過が有効にならないことがあります。


グラフの描画

レポートエディタでは、横棒、縦棒、円、レーダーチャート、面、折れ線、散布図の7種類のグラフの他、3種類の3Dグラフ（横棒、縦棒、円）を描画することができます。

１．グラフオブジェクトボタン [image] をクリックします。

２．グラフを描画する位置にマウスポインタを移動し、グラフを描画するための領域を確保します。

３． ダミーのグラフが表示されます。


グラフプロパティの設定

グラフのプロパティは、グラフ画面、またはプロパティウィンドウで設定します。

グラフ画面の表示
・グラフを選択後、プロパティウィンドウのプロパティページボタンをクリックする。
・グラフを選択後、マウスの右ボタンをクリックし、ポップアップメニューでプロパティを選択する。

全体タブ

１．可変（フィールド）・固定
印刷時に描画するグラフが変わる場合は可変（フィールド）を選択します。常に同じグラフを描画する場合は固定を選択します。

２． クエリー
可変（フィールド）の場合に有効です。帳票印刷時にデータの取得先がACCESSかODBCの場合には、ここにクエリーを設定しておくと、データを取得することができます。（『クエリーの設定』参照）

３．グラフの種類
グラフの種類を指定します。選択したグラフの種類によって5以降の設定内容が異なります。

４．凡例を表示する
グラフの凡例を表示するかどうかを指定します。

５．壁面の色
グラフ壁面の色を指定します。横棒（3D）グラフ、縦棒（3D）グラフの場合のみ指定可能です。壁面の色には、塗り潰し効果（グラデーション、テクスチャ、パターン）を設定できます。

６．底面の色
グラフ底面の色を指定します。横棒（3D）グラフ、縦棒（3D）グラフの場合のみ設定可能です。底面の色には、塗り潰し効果（グラデーション、テクスチャ、パターン）を設定できます。

数値軸情報タブ

数値軸の情報を指定します。円グラフではこの設定値は使用しません。最小値・最大値・増分が設定されていない場合は、グラフは描画されません。
最小値には、数値軸の最小となる値を指定します。最大値よりも大きな値を指定するとグラフは描画されません。
最大値には、数値軸の最大となる値を指定します。最小値よりも小さな値を指定するとグラフは描画されません。
増分には、最小値から最大値までの目盛りの増分を指定します。負の値は指定できません。
表示単位には、数値軸の単位を指定します。表示単位が設定された場合、設定値は数値軸の最大値の上（横棒グラフでは右）に表示されます。
目盛り色には、数値軸の目盛り文字の表示色を指定します。
フォント名には、数値軸の目盛りを表示する文字フォントの種類を指定します。
フォントサイズには、数値軸の目盛りを表示する文字フォントのサイズを指定します。

系列情報タブ（散布図以外の場合）

系列情報を設定します。散布図を選択した場合は、この項目は表示されません。
系列数には、必要な系列の数を指定します。０にすることはできません。
フォント名には、系列名称を表示する文字フォントの種類を指定します。
フォントサイズには、系列名称を表示する文字フォントのサイズを指定します。
系列名称には、各系列の名称を指定します。項目情報の項目数が０の場合には、この系列名称が横軸（横棒グラフでは縦軸）の名称となります。項目情報の項目数に1以上の値が設定されると、系列名称は凡例として表示されます。
前景色／背景色には、各系列データを表示する色を指定します。棒グラフ・面グラフ・円グラフでは前景色・背景色・網掛けの設定値で塗り潰されます。折れ線グラフ・レーダーチャートでは前景色の設定値で線が描画されます。
名称色には、各系列名称を表示する文字色を指定します。
網掛けには、各系列を表示する網掛けパターンを指定します。折れ線グラフ、レーダーチャートでは無効です。
線種には、各系列データを表示する線の種類を指定します。
ポイント種には、折れ線グラフの各ポイント地点を表示する図形の種類を指定します。折れ線グラフ以外では無効です。

項目情報タブ（散布図以外の場合）

散布図を選択した場合は、この項目は表示されません。円グラフではこの設定値は使用しません。
項目情報は、系列情報で設定されたｎ個の系列が、ｎ×ｍ個ある場合に指定します。（m＞１）
項目数には、ｍの数を指定します。ｍが１つ（ｎ×１）の場合は、項目数に０を指定します。この場合、横軸（横棒グラフでは縦軸）はすべて系列情報で作成され、名称には系列名称が表示されます。項目数に０以外の値が設定された場合、横軸（横棒グラフでは縦軸）はすべて項目情報で作成され、系列名称は凡例として表示されます。
フォント名には、綱目名称を表示する文字フォントの種類を指定します。
フォントサイズには、綱目名称を表示する文字フォントのサイズを指定します。
項目名称には、項目の名称を指定します。
名称色には、項目名称を表示する文字色を指定します。

X軸情報タブ（散布図の場合）

X軸の情報を指定します。散布図を選択した場合のみこの項目が表示されます。最小値・最大値・増分が設定されていない場合は、散布図は描画されません。
最小値には、X軸の最小となる値を指定します。最小値よりも小さな値を指定するとグラフは描画されません。
最大値には、X軸の最大となる値を指定します。最大値よりも大きな値を指定するとグラフは描画されません。
増分には、最小値から最大値までの目盛りの増分を指定します。負の値は指定できません。
表示単位には、X軸の単位を指定します。表示単位が設定された場合、設定値はX軸の右に表示されます。
目盛り色には、X軸の目盛り文字の表示色を指定します。
フォント名には、X軸の目盛りを表示する文字フォントの種類を指定します。
フォントサイズには、X軸の目盛りを表示する文字フォントのサイズを指定します。

散布図描画情報タブ（散布図の場合）

散布図を描画するための情報を指定します。散布図を選択した場合のみこの項目が表示されます。
ポイント種には、データのポイント地点を表示する図形の種類を指定します。
ポイント色には、データのポイント地点を表示する図形の色を指定します。
データ数には、散布図のデータ数を指定します。固定グラフのみ設定可能です。ここで設定された数分のデータをセットすることができます。

グラフデータタブ

描画するグラフのデータを指定します。固定グラフのみ設定可能です。
散布図では小数（小数点以下3桁まで有効）を指定できますが、散布図以外では、小数は四捨五入されて整数値となります。


グラフデータの設定

１． 横棒グラフ・縦棒グラフ・折れ線グラフ・面グラフ

横棒グラフ・縦棒グラフ・折れ線グラフ・面グラフでは、数値軸情報と系列情報が設定されていないとグラフは作成されません。
各グラフは数値軸ともう一つの軸で構成されます。もう一つの軸は、項目情報が設定されていない場合（項目数が０の場合）は系列情報で作成され、項目情報が１つ以上設定されている場合は項目情報で作成されます。
横棒グラフは、横軸に数値、縦軸に系列または項目が表示されます。
縦棒グラフ・折れ線グラフ・面グラフは、横軸に系列または項目、縦軸に数値が表示されます。
＜例１＞
グラフプロパティを以下のように設定すると、グラフは「図：例１のグラフ」のように作成されます。
［数値軸情報］
  最小値：10　　最大値：100　　増分：20
［系列情報］］
系列数：3
系列名称1：東京　　系列名称2：名古屋　　系列名称3：大阪
［項目情報］
項目数：０
［グラフデータ］
  東京：22　　名古屋：44　　大阪：67

図：例１のグラフ
＜例２＞
グラフプロパティを以下のように設定すると、グラフは「図：例２のグラフ」のように作成されます。
［数値軸情報］
  最小値：10　　最大値：100　　増分：20
［系列情報］］
系列数：3
系列名称1：東京　　系列名称2：名古屋　　系列名称3：大阪
［項目情報］
項目数：3
項目名称1：1995　　項目名称2：1996　　項目名称3：1997
［グラフデータ］
  1995の系列データ　　東京：22　　名古屋：56　　大阪：68
  1996の系列データ　　東京：44　　名古屋：35　　大阪：21
  1997の系列データ　　東京：67　　名古屋：77　　大阪：57

図：例２のグラフ

２． 円グラフ

円グラフは、系列情報とグラフデータのみで作成されます。数値軸情報や項目情報の値は無視されます。系列名称は凡例として表示されます。
＜例３＞
グラフプロパティを以下のように設定すると、円グラフは「図：例３のグラフ」のように作成されます。
［系列情報］］
系列数：3
系列名称1：東京　　系列名称2：名古屋　　系列名称3：大阪
［グラフデータ］
東京：22　　名古屋：44　　大阪：67

図：例３のグラフ

３．レーダーチャート

レーダーチャートは、数値軸情報、系列情報、項目情報の項目数に3以上の値が設定されていないと正常に作成されません。
＜例４＞
グラフプロパティを以下のように設定すると、レーダーチャートは「図：例４のグラフ」のように作成されます。
［数値軸情報］
  最小値：10　　最大値：100　　増分：20
［系列情報］］
系列数：3
系列名称1：東京　　系列名称2：名古屋　　系列名称3：大阪
［項目情報］
項目数：5
項目名称1：1993　　項目名称2：1994　　項目名称3：1995
項目名称4：1996　　項目名称5：1997
［グラフデータ］
  1993の系列データ　　東京：88　　名古屋：68　　大阪：50
  1994の系列データ　　東京：54　　名古屋：58　　大阪：56
  1995の系列データ　　東京：87　　名古屋：44　　大阪：67
  1996の系列データ　　東京：65　　名古屋：55　　大阪：77
  1997の系列データ　　東京：68　　名古屋：60　　大阪：57

図：例４のグラフ

４． 散布図

散布図は２つの数値軸で構成されます。レポートエディタでは、この２つの数値軸を数値軸（Y方向の軸）とX軸（X方向の軸）と呼んでいます。
数値軸情報とX軸情報が設定されていないと作成されません。
散布図のグラフデータには小数（小数点以下3桁まで有効）を設定することができます。
グラフプロパティを以下のように設定すると、散布図は「図：例５のグラフ」のように作成されます。
［数値軸情報］
  最小値：0　　最大値：100　　増分：20
［X軸情報］］
最小値：0　　最大値：100　　増分：20
［散布図描画情報］
データ数：3
［グラフデータ］
  1番目のデータ　　X：15　　Y：25
  2番目のデータ　　X：40　　Y：45
  3番目のデータ　　X：50　　Y：25

図：例５のグラフ


テキストフィールド

テキストフィールドは、単独のデータを描画する場合に使用します。

テキストフィールドの貼り付け

１．テキストフィールドオブジェクトボタン [image] をクリックします。
２．テキストフィールドを描画する位置にマウスポインタを移動しクリックします。
３．文字プロパティ画面がポップアップします。
４．必要な項目を設定します。
５．プロパティウィンドウでフィールド名称を指定します。

テキストフィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldTextファンクション
  レポートライブラリOCXの場合：SetFieldTextメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略

テキストフィールドプロパティの設定

テキストフィールドのプロパティは、プロパティウィンドウ、または文字プロパティ画面で指定します。

文字プロパティ画面は、以下のどちらかの方法で表示させます。
・テキストフィールドを選択後マウスの右ボタンをクリックし、ポップアップメニューのプロパテイを選択する。
・プロパティウィンドウのプロパティページをクリックする。

文字プロパティ画面

文字プロパティ画面の全体タブ、フォントタブ、３Dタブ、輪郭線タブ、変形タブには、文字オブジェクトの文字プロパティ画面と同じプロパティが並んでいます。
詳細は、文字オブジェクトの文字プロパティの設定を参照してください。
ここでは、文字オブジェクトの文字プロパティ画面にない項目のみを解説します。

全体タブ

１．PDF入力ボックス
PDF形式の帳票（PDFフォーム）に、データ入力用のボックスを作成する時にチェックします。
詳細は、PDF入力ボックスフィールドを参照してください。

２．拡張機能
テキストフィールドに拡張機能を設定する時にチェックします。この機能は帳票印刷モードでは無効です。

拡張機能とは、テキストフィールドに描画される文字のプロパティをプログラムから変更する機能です。
以下のプロパティを変更することができます。

  ・フォント：種類、横幅拡大率、サイズ、色、イタリック、ボールド
  ・文字の背景：色、高さ、縦位置
  ・下線：色、幅、位置、種類
  ・打ち消し線：色、幅、位置、種類

プロパティは、予約語を使い、プログラムコードに記述して変更します。
詳細は「付録／テキストフィールド拡張機能」で変更するプロパティを参照してください。

フォントプロパティを変更
文字の背景プロパティの設定
下線プロパティの設定
打ち消し線プロパティの設定

拡張機能をチェックすると、以下の機能が使用不可となります。
  インデント、段数、段の間隔、文字方向、逆改行、文字位置の微調整、ワードラップ、
  PDF入力ボックス、フォント回転角度、打ち消し線、下線、下線と文字の距離、
  ３Dタブ・輪郭線タブ・変形タブ・クエリー／計算式タブの各機能

拡張機能が設定されたテキストフィールドは文字型となります。編集子タブでは、桁数のみ設定可能です。＆を1つ以上設定してください。

                  1桁の編集子を設定した画面

編集子の＆は任意の数だけ入力できますが、ここで設定した桁数は、レポートエディタの画面上でのみ有効です。テキストフィールドの領域の大きさを確認したり、テキストフィールドに入れる文字数を確認したりすることに利用してください。
テキストフィールドに文字列を渡す時には、ここで設定した桁数に関係なく何文字でも渡すことができます。半角・全角に拘らず、最大2000文字まで渡すことができます。拡張機能が設定されたテキストフィールドでは、オーバーフローエラーは起こりません。2000文字を超えた場合でもエラーは起こりませんが、そのテキストフィールドには何も描画されません。何も描画されない時には、渡した文字列の桁数を確認してください。

３．フォントの自動調整
フォントの自動調整は、拡張機能の一つです。フォントの自動調整をチェックすると、拡張機能も同時にチェックされた状態となります。
この機能は帳票印刷モードでは無効です。

フォントの自動調整とは、文字列をテキストフィールドの枠内に収めて描画する機能です。はみ出る場合には、自動的にフォントサイズを小さくして枠内に収めます。
拡張機能の一つであるため、以下のプロパティを変更することができます。

  ・フォント：色、イタリック、ボールド
  ・文字の背景：色、高さ
  ・下線：色、幅、種類
  ・打ち消し線：色、幅、種類

プロパティは、予約語を使い、プログラムコードに記述して変更します。
詳細は「付録／テキストフィールド拡張機能」で変更するプロパティを参照してください。

フォントプロパティを変更
文字の背景プロパティの設定
下線プロパティの設定
打ち消し線プロパティの設定

フォントの自動調整をチェックすると、以下の機能が使用不可となります。
  インデント、段数、段の間隔、文字方向、逆改行、文字位置の微調整、ワードラップ、
  PDF入力ボックス、フォント回転角度、打ち消し線、下線、下線と文字の距離、
  ３Dタブ・輪郭線タブ・変形タブ・クエリー／計算式タブの各機能

フォントの自動調整機能が設定されたテキストフィールドは文字型となります。編集子タブでは、桁数のみ設定可能です。＆を1つ以上設定してください。

                  1文字の編集子を設定した画面

編集子の＆は任意の数だけ入力できますが、ここで設定した桁数は、レポートエディタの画面上でのみ有効です。テキストフィールドの領域の大きさを確認したり、テキストフィールドに入れる文字数を確認したりすることに利用してください。
テキストフィールドに文字列を渡す時には、ここで設定した桁数に関係なく何文字でも渡すことができます。半角・全角に拘らず、最大2000文字まで渡すことができます。拡張機能が設定されたテキストフィールドでは、オーバーフローエラーは起こりません。2000文字を超えた場合でもエラーは起こりませんが、そのテキストフィールドには何も描画されません。何も描画されない時には、渡した文字列の桁数を確認してください。

フォントタブ

１．文字の縦位置
全体タブで拡張機能を選択すると、フォントサイズが変更された場合の文字の縦位置を指定できます。
この機能は、拡張機能のフォントサイズ変更の場合にのみ有効です。それ以外の機能では無効です。
帳票印刷モードでも無効となります。

「上端を揃える」を選択すると、隣り合った異なるサイズの文字は、文字の上端が揃います。
「中央を揃える」を選択すると、隣り合った異なるサイズの文字は、文字の中央が揃います。
「下端を揃える」を選択すると、隣り合った異なるサイズの文字は、文字の下端が揃います。

編集子の設定

フィールド編集子には、文字型、数値型、日付型のいずれかを指定します。

※「拡張機能」、「フォントの自動調整」を使用する場合には、編集子タブの機能は利用できません。

文字型編集子タブ

１．桁数
テキストフィールドに表示する文字列の最大桁数を指定します。
桁数は、全角文字を2桁、半角文字を1桁として数えます。

２．空白詰めあり
表示する文字列が編集子の桁数より少ない時、文字列の前に余った桁数分の空白を詰める場合に、チェックします。
空白詰めを指定した場合には、編集子の記号は「@」、空白詰めを指定しない場合には「&」が表示されます。

３．編集子入力ボックス
設定された桁数分の編集子が表示されます。
入力ボックスにカーソルを入れて、直接編集子を入力することもできます。

数値型編集子タブ

１．整数部桁数
整数部の桁数を指定します。

２．小数点以下桁数
小数点以下の桁数を指定します。

３．カンマ編集
3桁ごとにカンマをつけて表示します。例）1,000,000

４．前ゼロ詰め
編集子の桁数が数値の桁数より多い時に場合、余った位をゼロ詰めします。
例）編集子「000.00」設定値「10.5」印字結果「010.50」

５．ゼロ非表示
値が０の時、空白を表示します。

６．編集子入力ボックス
設定された編集子が表示されます。
入力ボックスにカーソルを入れて、直接編集子を入力することもできます。

日付型編集子タブ

１．日付を含める
日付を表示する編集子を作成します。

２．時間を含める
時間を表示する編集子を作成します。

クエリー／計算式タブ

※「拡張機能」、「フォントの自動調整」を使用する場合には、クエリー／計算式タブの機能は利用できません。

１．クエリー
クエリープロパティでは、クエリーの設定、列名の設定、予約語の設定のいずれかができます。
設定された文字列が複数のワードを持つ場合には、クエリーとして認識されます。
設定された文字列が1つのワードの場合、そのワードが予約語であれば予約語として認識され、それ以外であれば列名として認識されます。

２．計算式
テキストフィールドに計算式の設定する場合は、ここに計算式を記述します。


グリッドフィールド

グリッドフィールドは、表形式のデータを描画する場合に使用します。

グリッドフィールドの貼り付け

１．グリッドフィールドオブジェクトボタン [image] をクリックします。
２．グリッドフィールドを描画する位置にマウスポインタを移動しクリックします。
３．グリッドフィールドのプロパティ画面がポップアップします。
４．プロパティ画面でプロパティを設定し、プロパティ画面を閉じます。
５．プロパティウィンドウでフィールド名称を指定します。

フィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldGridファンクション
  レポートライブラリOCXの場合：SetFieldGridメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略

グリッドフィールドプロパティの設定

グリッドフィールドプロパティは、プロパティウィンドウ、またはグリッドフィールド画面で設定します。

グリッドフィールド画面は、以下のどちらかの方法で表示させます。
・グリッドフィールドを選択後マウスの右ボタンをクリックし、ポップアップメニューのプロパテイを選択する。
・プロパティウィンドウのプロパティページをクリックする。

全体タブ

１．列数
全体の列数を指定します。

２．行数
全体の行数を指定します。

３．クエリー
グリッドフィールドにはクエリーを 指定 することができます。

４．縦書き
縦書き／横書きを指定します。

５．データ設定行のみ罫線を描画
実行時にすべての行の罫線を描画するか、またはデータ設定行までの罫線を描画するかを指定します。

６．フィールド幅指定
フィールド全体の幅を指定します。（列幅ではありません。）幅は、現在選択されている「グリッドの横方向の間隔」の単位で指定可能です。

７．フィールド高指定
フィールド全体の高さを指定します。（行の高さではありません。）高さは、現在選択されている「グリッドの縦方向の間隔」の単位で指定可能です。

８．罫線の種類
罫線の種類を枠線、横罫線、縦罫線毎に指定します。”なし”を設定した場合、レポートエディタ上では点線が表示されますが、印刷時には何も描画されません。

９．罫線を3Dにする
罫線を3Dにする場合は、この項目をチェックします。罫線を3Dにする場合は、枠線の太さを6種類から選択します。横罫線、縦罫線は、“ある”、“なし”のどちらかを設定します。

列情報タブ

１．列指定
列毎に以下の項目を設定できますが、ここでは、設定の対象となる列を指定します。

２．フォント名称
列のフォント名を指定します。

３．フォントサイズ
列のフォントサイズを指定します。

４．フォント横幅拡大率
フォントサイズの横幅の拡大率を指定します。

５．文字ピッチ
文字と文字の間のピッチを指定します。

６．行ピッチ
マルチラインの場合の行ピッチを指定します。

７．列名
フォームにクエリーが設定されている場合には、クエリー中に記述した列の名前を指定することができます。列名はレポートエディタからの帳票印刷に使用します。

８．編集子
列のフィールド編集子を設定します。
数値型の場合：
「整数部桁・小数部桁数・カンマ編集・前ゼロ詰め・ゼロ非表示」を指定します。
文字型の場合：
「桁数・前空白詰め」を指定します。
日付型の場合：
「日付を含める・時間を含める」を指定します。

９．列幅指定
列の列幅を指定します。列幅は、現在選択されている「グリッドの横方向の間隔」の単位で指定可能です。
列幅は、レポートエディタ上で、マウスをドラッグさせて指定することもできます。

10．改行幅の調整
描画に使用する列幅を調整します。値はマイナス値で指定します。
セルの右側に余白を設けたい場合などに使用します。
調整値＝０ ---→ 描画に使用する列幅＝確保した列幅
調整値＝－１---→ 描画に使用する列幅＝確保した列幅－１
調整値＝－２---→ 描画に使用する列幅＝確保した列幅－２
設定例）セルの列幅が20ミリで、調整値に-4ミリを設定した場合
描画に使用する列幅は、文字配置によって以下のように異なります。

※印刷時には文字が欠けないように自動調整されるため、選択したフォントやフォントサイズよっては、設定値通りにならない場合があります。

11．文字配置（横）
横方向の文字列の位置を指定します。

12．文字配置（縦）
縦方向の文字列の位置を指定します。
マルチラインをチェックした場合は指定できません。

13．文字位置の微調整
指定された列の文字描画位置を微調整します。

14．イタリック・ボールド
フォントのイタリック・ボールドを指定します。

15．マルチライン
改行あり／なしを指定します。


バーコードフィールド

バーコードフィールドは、ページ毎に描画するバーコードのコードが異なる場合に使用します。ページが変わってもコードが固定の場合には、固定バーコードの方が便利です。

バーコードフィールドの貼り付け

１．バーコードフィールドオブジェクトボタン [image] をクリックします。
２．バーコードフィールドを描画する位置にマウスポインタを移動しクリックします。
３．バーコードフィールドのプロパティ画面がポップアップします。
４．プロパティ画面でプロパティを設定し、プロパティ画面を閉じます。
５．プロパティウィンドウでフィールド名称を指定します。

フィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldBarcodeファンクション
  レポートライブラリOCXの場合：SetFieldBarcodeメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略

バーコードフィールドプロパティの設定

バーコードフィールドには、バーコードプロパティを設定することができます。
バーコードプロパティの設定方法は、『バーコードプロパティの設定』を参照してください。

クエリープロパティの設定

バーコードフィールドにはクエリーを設定することができます。


イメージフィールド

イメージフィールドは、ページ毎に描画するイメージが異なる場合に使用します。ページが変わっても同じイメージを描画する場合には、固定イメージの方が便利です。

イメージフィールドの貼り付け

１．イメージフィールドオブジェクトボタン [image] をクリックします。
２．イメージフィールドを描画する位置にマウスポインタを移動しクリックします。
３．イメージフィールドのプロパティ画面がポップアップします。
４．プロパティ画面でプロパティを設定し、プロパティ画面を閉じます。
５．プロパティウィンドウでフィールド名称を指定します。

フィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldImage ファンクション
  レポートライブラリOCXの場合：SetFieldImage メソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略

イメージフィールドプロパティの設定

イメージフィールドには、イメージプロパティを設定することができます。
イメージプロパティの設定方法は、『イメージプロパティの設定』を参照してください。

クエリープロパティの設定

イメージフィールドにはクエリーを設定することができます。


グラフフィールド

グラフフィールドは、ページ毎に描画するグラフのデータが異なる場合に使用します。ページが変わってもグラフのデータが固定の場合には、固定グラフの方が便利です。

グラフフィールドの貼り付け

１．グラフフィールドオブジェクトボタン [image] をクリックします。
２．グラフフィールドを描画する位置にマウスポインタを移動しクリックします。
３．グラフフィールドのプロパティ画面がポップアップします。
４．プロパティ画面でプロパティを設定し、プロパティ画面を閉じます。
５．プロパティウィンドウでフィールド名称を指定します。

フィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：j vSetFieldGraph ファンクション
  レポートライブラリOCXの場合：SetFieldGraphメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略

グラフフィールドプロパティの設定

グラフフィールドには、グラフプロパティを設定することができます。
グラフプロパティの設定方法は、『グラフプロパティの設定』を参照してください。

クエリープロパティの設定

グラフフィールドにはクエリーを設定することができます。


セレクトボタンフィールド

セレクトボタンフィールドは、プレビューコントロールのデータ入力機能のためのプロパティです。
プレビューコントロールに表示された帳票で、項目を選択する時に使います。

セレクトボタンフィールドの貼り付け

１．セレクトボタンオブジェクトボタン [image] をクリックします。
２．セレクトボタンを描画する位置にマウスポインタを移動しマウスをクリックします。
３．セレクトボタンフィールドのプロパティ画面がポップアップします。
４．プロパティ画面でプロパティを設定し、プロパティ画面を閉じます。
５．プロパティウィンドウでフィールド名称を指定します。

フィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldTextファンクション
  レポートライブラリOCXの場合：SetFieldTextメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略
  セレクトボタンフィールドの値には「1」または「0」を指定します。「1」をセットすると選択状態になり、「0」をセットすると選択が解除された状態になります。

セレクトボタンフィールドプロパティの設定

セレクトボタンフィールドのプロパティは、セレクトボタン画面やプロパティウィンドウで設定します。

セレクトボタン画面は、以下のどちらかの方法で表示させます。
・セレクトボタンフィールドを選択後、マウスの右ボタンをクリックしポップアップメニューのプロパティを選択する。
・プロパティウィンドウのプロパティページをクリックする。

１．形状
描画する形状を以下の中から指定します。

例）楕円を選択すると楕円が描画されます。

例）チェックタイプを選択するとチェックマークがつきます。

２．線の幅
この項目は、形状に楕円（7～9）を選択した場合のみ設定できます。
描画する楕円の線幅を指定します。

３．サイズ
形状のサイズ（大きさ）を指定します。

４．セレクトボタンの枠内の表示位置（横位置／縦位置）
セレクトボタンを表示する横位置と縦位置を指定します。
各位置は、確保したセレクトボタンフィールドの枠（領域）の範囲内で設定されます。

例）横位置：上　　　横位置：中央　　横位置：下
縦位置：上　　　縦位置：中央　　縦位置：下
セレクトボタンフィールドの枠（領域）は、自由に指定することができます。
プレビューコントロールから直接値を入力をする場合、セレクトボタンフィールドをマウスでクリックすると、選択と選択解除が繰り返されます。
セレクトボタンフィールドの枠（領域）の範囲内では、どこをクリックしても入力可能です。
※レポートエディタ帳票印刷画面上での直接入力では、クリックによる選択／選択解除はできません。

５．ラジオボタン型
ラジオボタン型にする時は、「ラジオボタン型」をチェックします。

ラジオボタン型は、複数の項目から１つまたは複数を選択する場合に使います。
例）下図のように、3つの中から1つだけ選択したり、2つを選択したりする機能です。

複数のラジオボタンは、以下のように作成します。

(1) セレクトボタンフィールドを選択しフォームに貼り付けます。
(2) 「ラジオボタン型」をチェックします。。
(3) 形状やサイズなどを指定し、OKボタンを押してプロパティ画面を閉じます。
(4) プロパティウィンドウで、フィールド名称をつけます。
   フィールド名称は以下の規則に従って作成してください。

  ・選択グループの中に含めるラジオボタンには、同じフィールド名称をつけます。
  ・グループ内のラジオボタンには、各々、名称の後ろに「_1」「_2」という連番をつけます。
    アンダーバーと連番には半角文字を使用します。全角文字を使うとグループとして認識されません。

    例）　「SELECT_1, SELECT_2, SELECT_3」　　「保険料_1, 保険料_2, 保険料_3」　など

注意：

・グループに含めないラジオボタンには、別名をつけてください。
・レポートエディタの帳票印刷モードによる帳票印刷では、ラジオボタン機能は利用できませｎ。
・レポートライブラリを使いプログラム内でデータを指定する場合、ラジオボタン機能は利用できません。

グループ内で同時に選択できる個数は、最大同時選択数で指定します。 （下記参照）

６．最大同時選択数
ラジオボタン型セレクトボタンフィールドの同一グループ内で、同時に選択できる最大数を指定します。

  フィールド名称に_1がついているラジオボタンの場合

このプロパティは、フィールド名称に「_1」がつくラジオボタンのプロパティ画面で設定することができます。
フィールド名称に「_1」がついていないラジオボタンの場合には以下の画面が開いて設定できません。

フィールド名称に_1がついていないラジオボタンの場合

注意：

レポートエディタの帳票印刷モードによる帳票印刷では、最大同時選択数は無効です。
レポートライブラリを使いプログラム内でデータを設定する場合、最大同時選択数は無効です。

７．PDFチェックボックス

PDFフォームにチェックボックスを作る時にチェックします。
PDFフォームではない場合には、チェックを外しておきます。


PDF入力フィールド

PDF入力ボックスフィールド

PDF入力ボックスフィールドは、PDFフォームにデータ入力用のボックスを作成する時に使います。

PDFフォーム機能

入力ボックスの貼り付け

１．テキストフィールドオブジェクトボタン [image] をクリックします。
２．PDF入力ボックスを描画する位置にマウスポインタを移動しクリックします。
３．文字プロパティ画面がポップアップします。
４．全体タブで「PDF入力ボックス」をチェックします。
５．必要な項目を設定します。
６．プロパティウィンドウでフィールド名称を指定します。

データをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldTextファンクション
  レポートライブラリOCXの場合：SetFieldTextメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略

プロパティの設定

PDF入力ボックスのプロパティは、プロパティウィンドウ、または文字プロパティ画面で指定します。

文字プロパティ画面は、以下のどちらかの方法で表示させます。
・入力ボックスを選択後、マウスの右ボタンをクリックし、ポップアップメニューのプロパテイを選択する。
・プロパティウィンドウのプロパティページをクリックする。

文字プロパティ画面

PDF入力ボックスフィールドを作成する時には、全体タブの「PDF入力ボックス」をチェックします。

「PDF入力ボックス」をチェックすると、全体タブ画面が、下図のようにPDF入力ボックスフィールド用に変わります。
グレー表示された機能は使用できません。

全体タブ

１．文字配置（横）
PDFフォームに配置する入力ボックスの文字位置を指定します。
均等割付は選択できません。
文字配置（縦）は、常に中央揃えとなります。

フォントタブ

１．フォント名称
PDFフォームに配置する入力ボックスのフォント名称を指定します。

２．フォントサイズ
PDFフォームに配置する入力ボックスのフォントサイズを指定します。

編集子の設定

フィールド編集子には、文字型、数値型、日付型のいずれかを指定します。

文字型編集子タブ

１．桁数
テキストフィールドに表示する文字列の最大桁数を指定します。
桁数は、全角文字を2桁、半角文字を1桁として数えます。

２．空白詰めあり
表示する文字列が編集子の桁数より少ない時、文字列の前に余った桁数分の空白を詰める場合に、チェックします。
空白詰めを指定した場合には、編集子の記号は「@」、空白詰めを指定しない場合には「&」が表示されます。

３．編集子入力ボックス
設定された桁数分の編集子が表示されます。
入力ボックスにカーソルを入れて、直接編集子を入力することもできます。

数値型編集子タブ

１．整数部桁数
整数部の桁数を指定します。

２．小数点以下桁数
小数点以下の桁数を指定します。

３．カンマ編集
3桁ごとにカンマをつけて表示します。例）1,000,000

４．前ゼロ詰め
編集子の桁数が数値の桁数より多い時に場合、余った位をゼロ詰めします。
例）編集子「000.00」設定値「10.5」印字結果「010.50」

５．ゼロ非表示
値が０の時、空白を表示します。

６．編集子入力ボックス
設定された編集子が表示されます。
入力ボックスにカーソルを入れて、直接編集子を入力することもできます。

日付型編集子タブ

１．日付を含める
日付を表示する編集子を作成します。

２．時間を含める
時間を表示する編集子を作成します。

PDF入力ボックスタブ

１．PDF入力ボックスの未入力時のプロパティ

・文字の色
  入力ボックスに初期値がある場合、初期値の文字色となります。
  ユーザーが文字を入力すると、文字色はレポートエディタのプロパティウィンドウで指定した前景色に変わります。

・背景の色
  ユーザーが入力ボックスに値を入力するまでの背景色となります。
  レポートエディタ上で編集作業をする時の背景色ではありません。

・輪郭線の色
  ユーザーが入力ボックスに値を入力するまでの枠（輪郭線）の色となります。

  通常のフィールドとPDF入力ボックスを区別するため、レポートエディタ画面に枠を表示することができます。
  表示する場合には、環境設定画面で、「PDF入力ボックスの枠を表示する」をチェックします。
  PDF入力ボックスは、レポートエディタ画面では常に赤色で表示されます。
  ここで設定した輪郭線の色ではないので注意してください。

・輪郭線の幅
  ユーザーが入力ボックスに値を入力するまでの枠（輪郭線）の太さです。
  レポートエディタ上で編集する時の輪郭線の幅ではないので注意してください。


PDFセレクトボタンフィールド

PDFセレクトボタンフィールドは、PDFフォームにセレクトボタンを作成する時に使います。

PDFフォーム機能

セレクトボタンフィールドの貼り付け

１．セレクトボタンオブジェクトボタン [image] をクリックします。
２．セレクトボタンを描画する位置にマウスポインタを移動しマウスをクリックします。
３．セレクトボタンフィールドのプロパティ画面がポップアップします。
４．「PDFチェックボックス」をチェックします。
５．プロパティ画面でプロパティを設定し、プロパティ画面を閉じます。
６．プロパティウィンドウでフィールド名称を指定します。

フィールドにデータをセットする時は、以下の機能を使います。
  レポートライブラリDLLの場合：jvSetFieldTextファンクション
  レポートライブラリOCXの場合：SetFieldTextメソッド
  レポートエディタからの帳票印刷の場合：帳票印刷の概略
  セレクトボタンフィールドの値には「1」または「0」を指定します。「1」をセットすると選択状態になり、「0」をセットすると選択が解除された状態になります。

セレクトボタンフィールドプロパティの設定

セレクトボタンフィールドのプロパティは、セレクトボタン画面やプロパティウィンドウで設定します。
セレクトボタン画面は、以下のどちらかの方法で表示させます。
・セレクトボタンフィールドを選択後、マウスの右ボタンをクリックしポップアップメニューのプロパティを選択する。
・プロパティウィンドウのプロパティページをクリックする。

１．形状
描画する形状を１から６の中から指定します。
７から９は使用できません。７ら９選択すると、「PDFチェックボックス」のチェックが自動的にはずれます。
PDFセレクトボタンの場合には、線の幅を指定できません。

例）形状１を選択すると、下図のセレクトボタンが表示されます。

２．サイズ
セレクトボタンのサイズ（大きさ）を指定します。

３．セレクトボタンの枠内の表示位置（横位置／縦位置）
セレクトボタンを表示する横位置と縦位置を指定します。
各位置は、確保したセレクトボタンフィールドの枠（領域）の範囲内で設定されます。

例） 横：上／縦：上　　 横：中央／縦：中央　横：下／縦：下

セレクトボタンフィールドの枠（領域）は、自由に指定することができます。

４．ラジオボタン型
セレクトボタンをラジオボタン型にする時には、「ラジオボタン型」をチェックします。

ラジオボタン型は、複数のセレクトボタンの中から１つの選択を許可する場合に使います。
例）下図のように、3つの中から1つだけ選択する機能です。

ラジオボタン型のセレクトボタンを複数作成する場合には、以下のようにします。

(1) セレクトボタンフィールドを選択しフォームに貼り付けます。
(2) 「ラジオボタン型」をチェックします。。
(3) 形状やサイズなどを指定し、OKボタンを押してプロパティ画面を閉じます。
(4) プロパティウィンドウで、作成したラジオボタンにフィールド名称をつけます。
    フィールド名称は以下の規則に従って作成してください。

  ・選択グループの中に含めるラジオボタンには、同じ名称をつけます。
  ・グループ内のラジオボタンには、各々、フィールド名称の後ろに「_1」「_2」という連番をつけます。
    アンダーバーと連番には半角文字を使用します。全角文字を使うとグループとして認識されません。

    例）　「SELECT_1, SELECT_2, SELECT_3」　　「保険料_1, 保険料_2, 保険料_3」　など

注意：

・グループに含めないラジオボタンには、別名をつけてください。
・レポートライブラリを使ってプログラム内でデータを指定する場合、ラジオボタン機能は利用できません。
グループ内では、１つのラジオボタンのみ選択できます。


プロパティウィンドウ

オブジェクトのプロパティは、プロパティウィンドウで設定することができます。
プロパティウィンドウは、「表示メニュー／プロパティウィンドウ」で表示・非表示を行います。

１．プロパティウィンドウには、選択中のオブジェクトのプロパティが一覧表示されます。
２．表示されるプロパティは、オブジェクトの種類により内容が異なります。
３．プロパティページのボタンを押すと、オブジェクト専用のプロパティ画面が開きます。

フィールド名称プロパティ

フィールドを作成すると、作成時に自動的にフィールド名称がつけられます。
フィールド名称を変更する場合には、プロパティウィンドウのフィールド名称欄に入力します。
フィールド名称は30バイト以内で設定します。


フィールドウィンドウ

フィールドウィンドウでは、フォーム上のフィールドを一覧表示します。
フィールドウィンドウは、「表示メニュー／フィールドウィンドウ」で表示・非表示を行います。

１．1列目には、フィールドの種類が表示されます。
フィールドの絵をクリックすると、各フィールドのプロパティ画面が表示されます。

２．2列目には、フィールド名称が表示されます。
セルをダブルクリックすると、フィールド名称を入力することができます。

３．フィールドウィンドウに一覧表示される順番は、フィールド順となります。
フィールド順、フィールドの並べ替え


フィールドの並べ替え

フォーム上の各フィールドには、順番があります。
順番は、作成された順となりますが、順番を変更することができます。
フィールドの順番は、帳票印刷モードから帳票印刷をする時に使われます。
順番の変更は［フォームメニュー／フィールド順指定］でフィールド順指定画面を開いて行ないます。

１．フィールド名称リストのフィールド名をマウスでクリックして選択します。
上へ移動する場合は、上矢印ボタンを押します。
下へ移動する場合は、下矢印ボタンを押します。

２．フィールド名をマウスでクリックし、移動場所へドラッグして移動することもできます。


フィールド情報の取得

フォーム上のフィールド情報を取得することができます。
フィールド情報は「フォームメニュー／フィールド情報の取得」で取得します。
「フィールド情報の取得」を行うとフィールド情報画面が表示されます。

１．1項目目にはフィールドの種類が表示されます。

２．2項目目にはフィールド名称が表示されます。

３．3項目目からは、フィールドの種類により異なります。
テキストフィールド：編集子
グリッドフィールド：列数、行数、編集子
バーコードフィールド：バーコードの種類
イメージフィールド：なし
セレクトボタンフィールド：編集子

４．フィールド情報画面の「ファイルメニュー／名前を付けて保存」では、フィールド情報をテキスト形式でファイルに保存することができます。


パーツ登録

パーツの登録

良く使うオブジェクトをパーツとして登録し、いつでも使用することができます。
複数のオブジェクトをまとめて1つのパーツとして登録することもできます。
パーツ登録は次の手順で行います。

１．レポートエディタでオブジェクトを描画し、パーツ登録するオブジェクトをすべて選択します。

２．「編集メニュー／コピー」を実行し、選択したオブジェクトをコピーします。

３．「表示メニュー／パーツウィンドウ」を実行し、パーツウィンドウをポップアップさせます。

４．パーツを初めて登録する場合は、パーツウィンドウの「ファイルメニュー／新規作成」を実行します。
表示されているパーツ登録用の小さなウィンドウを選択し、パーツウィンドウの「編集メニュー／貼り付け」を実行すると、コピーされているオブジェクトがウィンドウに貼り付けられます。

５．既に作成済みのパーツファイルにパーツを登録する場合は、パーツウィンドウの「ファイルメニュー／開く」を実行します。
目的のパーツファイルを開くと、登録数分のウィンドウが表示され、既に登録済みのパーツが各々のウィンドウに描画されます。
追加登録する場合は、パーツウィンドウの「編集メニュー／パーツの追加」を実行すると新しいウィンドウが表示されます。このウィンドウを選択し、パーツウィンドウの「編集メニュー／貼り付け」を実行すると、コピーされているオブジェクトがウィンドウに貼り付けられます。
上書き登録する場合は、上書きするパーツを選択します。パーツウィンドウの「編集メニュー／貼り付け」を実行すると、コピーされているオブジェクトがウィンドウに貼り付けられます。

６．パーツウィンドウの下のボックスにはパーツ名称を入力することができます。

７．新しいパーツファイルを作成する場合には、パーツウィンドウの「ファイルメニュー／新規保存」、既に存在するファイルに上書きする場合には、「ファイルメニュー／上書き保存」を実行するとパーツが登録されます。


パーツの利用

レポートエディタで、フォームに登録済みのパーツを貼り付ける場合は、次の手順で行います。

１．「表示メニュー／パーツウィンドウ」を実行し、パーツウィンドウをポップアップさせます。

２．パーツウィンドウの「ファイルメニュー／開く」で、目的のパーツファイルを開きます。

３．目的のパーツウィンドウを選択し、パーツウィンドウの「編集メニュー／コピー」を実行します。

４．マウスカーソルをレポートエディタ上に戻し、「編集メニュー／貼り付け」を実行すると、コピーされているパーツがフォームに貼り付けられます。


可変フォームとは

帳票のレイアウトが、出力するデータによって変わる場合には、可変フォームを作成します。

可変フォームとは、1枚のレイアウトを複数のセクションに分割して作成したフォームです。

  ＜例：見積書の可変フォーム＞

上記の例では、1枚の見積書を複数のセクションに分割して作成しています。

可変フォームでは、出力するデータ量や内容などに合わせて、レイアウトを変えることができます。


可変フォームの作り方

１．レポートエディタを起動します。

２．ファイルメニューの「新規作成 [可変長フォーム] 」を実行します。

３．ファイルメニューが可変フォーム用に変わります。

４．画面が、可変フォーム画面に切り替わります。画面には、1つ目のセクションが表示されます。

５．セクションの高さは、マウスで調整します。

マウスポインタを上下矢印の形にして、マウスをドラッグさせると、セクションの高さを変えることができます。

６．セクションの中にオブジェクトを描画します。


セクションの追加

セクションは、1つのフォームファイルに、最大20個まで作成することができます。

１．セクションを追加する時は、フォームメニューの「セクションの追加」を実行します。

編集中のセクションと同じ高さのセクションが、編集中のセクションの下に追加されます。
セクションの高さは、マウスで調整します。

画面上部のツールバーでも、セクションの追加や削除ができます。

２．セクションキーをつけます。

新規作成時やセクション追加時には、自動的にセクションキーがつけられますが、セクションキーは変更できます。
セクションキーは、レポートライブラリからセクションを指定する時に使います。

セクションキーをつける時には、フォームメニューの「セクションキー変更」を実行します。
上部のツールバー「セクションキー」ボタン（上図参照）でも変更できます。

セクションキー指定画面でセクションキーを入力します。
セクションキー指定画面は、セクションウィンドウ上で、該当するセクションをダブルクリックして開くこともできます。


セクションの編集

１．セクションの削除

不要になったセクションは、セクション上で、フォームメニューの「セクション削除」、または、削除ボタンを押すと削除できます。

２．セクションの移動

セクションを上下に移動させる時には、フォームメニューの「セクションを上に移動」「セクションを下に移動」、または、上下移動ボタンを使います。

３．セクションの非表示／表示

セクションの右上にある「×」ボタンを押すと、セクションが非表示になります。
セクションウィンドウのセクションキーを押すと、非表示中のセクションを表示できます。


セクションウィンドウ

複数のセクションを作成する時には、セクションウィンドウでセクション管理をします。

セクションウィンドウを表示する時は、表示メニューの「セクションウィンドウ」を実行します。

セクションウィンドウには、作成中のセクションがすべて表示されます。

セクションの上をマウスでクリックすると、クリックしたセクションにフォーカスが移動します。

セクションの上をマウスでダブルクリックすると、セクションキーを入力する画面が開きます。

     ＜セクションキー入力画面＞


可変フォームの印刷

可変フォームは、レポートライブラリを使って印刷します。
レポートエディタからは印刷できません。

例：見積書可変フォーム

例：複数ページにわたる見積書の印刷　１ページ～3ページ


クエリーの設定

フォームとフィールドには、クエリーを設定することができます。
クエリーは、レポートエディタの帳票印刷モードによる帳票印刷時に使います。データの取得先が Access または ODBC 場合にのみ有効です。

※レポートライブラリでは、クエリーの取得はできますが、データの取得はできません。
※クエリーの設定機能は、可変フォームでは使用できません。

フォームのクエリー

フォームにはクエリーを１つ設定することができます。
クエリーは「フォーム情報メニュー／クエリー」でクエリー画面を開き、直接入力します。

クエリーは、レポートエディタからそのままデータベースに送られます。
利用するデータベースで有効なSQLを記述してください。

テキストフィールドのクエリー

テキストフィールドのクエリープロパティには、クエリー、列名、予約語を設定することができます。
文字列が複数のワードで構成されている場合はクエリーとして認識されます。
文字列が１つのワードの場合、そのワードが予約語であれば予約語として認識され、それ以外であれば列名として認識されます。

１．．クエリープロパティに列名を設定する
テキストフィールドのクエリープロパティに、フォームのクエリー中に記述した列名を設定すると、フォームクエリー実行後に、抽出した列の値がテキストフィールドに自動でセットされます。

例）
フォームクエリー：select 顧客名, 住所 from 顧客マスタ
テキストフィールドクエリー：顧客名

このように、テキストフィールドのクエリープロパティに、フォームクエリー中に記述した列名の１つである顧客名を設定しておくと、取得した顧客名をテキストフィールドの値とします。
フォームのクエリー中に記述した列名をテキストフィールド名称とリンクさせることもできます。
フォームクエリー：select 顧客名, 住所 from 顧客マスタ
テキストフィールドクエリー：何も設定しない
テキストフィールド名称：顧客名
このようにしても、取得した顧客名の値をテキストフィールドの値とします。
クエリーの設定値がまず評価され、次にフィールド名称が評価されるので、フィールド名称をリンクさせる場合は、クエリープロパティに何も設定しないようにします。

２．クエリープロパティにクエリーを設定する
テキストフィールドのクエリープロパティには、テキストフィールドの値を取得するクエリーを設定することができます。

例）
テキストフィールドクエリー：select 会社名 from 会社マスタ
この例では、会社マスタテーブルから会社名という列の値を取得します。
複数レコードを取得した場合は、先頭レコードを使用します。
フォームにクエリーが設定されている場合は、フォームクエリー中に記述されている列名を条件として記述することもできます。

例）
フォームクエリー：select 顧客コード, 売上金額 from 売上テーブル
テキストフィールドクエリー：
select 顧客名 from 顧客マスタ where 顧客コード = %顧客コード%

フォームクエリーで取得した顧客コードの値をテキストフィールドクエリーの条件に置き換えます。例えば取得した顧客コードが10の場合、「select 顧客名 from 顧客マスタ where 顧客コード=10」というクエリーが内部で生成され、実行されます。

条件式を記述する時の注意：

①フォームクエリーの列名に入っていない文字列は、使用できません。

②クエリー中に条件として記述する列名は、必ず％で囲んでください。
例）顧客コードを条件として記述する場合
select 顧客名 from 顧客マスタ where 顧客コード = %顧客コード%

③クエリー中に記述されている列が文字型（テキスト型、Char/Varchar型）の場合は、前後をシングルクォーテーションで囲んでください。
例）顧客コードが文字型の場合
select 顧客名 from 顧客マスタ where 顧客コード = ‘%顧客コード%’

④クエリー中に記述されている列が日付型の場合は、使用するデータベースで有効な記号で前後を囲んでください。
例）ACCESSの場合
select 売上高 from 顧客マスタ where 売上日 >= #%売上日%#
例）SQL Serverの場合
select 売上高 from 顧客マスタ where 売上日 >= ‘%売上日%’

３．予約語の設定
クエリープロパティには、予約語を設定することができます。

グリッドフィールドのクエリー

グリッドフィールドのクエリープロパティにはクエリーを設定することができます。
クエリー中の列と、グリッドフィールドの列とのリンク
グリッドフィールドには列ごとに個別の列名を設定できますが、このグリッドフィールドの列名をクエリー中の列名と同じものにしておくとリンクさせることができます。
例えば、クエリーで数量と単価を求めた場合、グリッドフィールドの列名を”数量”と”単価”にしておくと、取得した値は各々の列に入ります。
グリッドフィールドに同名の列名がない場合は、クエリーに記述された列の順番でグリッドの1列目から順に値を入れます。
例えば、クエリーで数量、単価を求めた場合、1列目に数量、2列目に単価が入ります。

例）
    フォームのクエリー　：
select 見積番号,顧客コード,日付 from 見積データ
    グリッドフィールドクエリー：
select 内容,数量,単価,数量*単価 AS 金額 from
見積明細データ where 見積番号=%見積番号%
グリッドフィールドの列名　：　"内容","数量","単価","金額"

フォームにクエリーが設定されている時は、フォームクエリー中の列名を条件として記述することができます。

条件を記述する時の注意：

①フォームクエリーの列名に入っていない文字列は、使用できません。

②クエリー中に条件として記述する列名は、必ず％で囲んでください。
例）顧客コードを条件として記述する場合
select 顧客名 from 顧客マスタ where 顧客コード = %顧客コード%

③クエリー中に記述されている列名が文字型（テキスト型、Char/Varchar型）の場合は、前後をシングルクォーテーションで囲んでください。
例）顧客コードが文字型の場合
select 顧客名 from 顧客マスタ where 顧客コード = ‘%顧客コード%’

④クエリー中に記述されている列名が日付型の場合は、使用するデータベースで有効な記号で前後を囲んでください。
例）ACCESSの場合
select 売上高 from 顧客マスタ where 売上日 >= #%売上日%#
例）SQL Serverの場合
select 売上高 from 顧客マスタ where 売上日 >= ‘%売上日%’

イメージフィールド・バーコードフィールドのクエリー

イメージフィールド・バーコードフィールドのクエリープロパティには、クエリー、列名を設定することができます。クエリープロパティに設定された文字列が複数のワードを持つ場合はクエリーとして認識されます。１つのワードが設定された場合は列名として認識されます。設定方法は、テキストフィールドと同じですが、予約語は設定できません。


予約語の設定

テキストフィールドには予約語を設定することができます。
ページ番号や印刷年月日などの帳票に必ず印刷されるものは、テキストフィールドに予約語を設定しておくと、レポートエディタの帳票印刷モードによる帳票印刷時に、データを準備しなくてもレポートエディタが自動的に値をセットします。

※予約語はレポートエディタの帳票印刷機能です。レポートライブラリからは利用できません。
※予約語の設定機能は、可変フォームでは使用できません。

予約語の設定

テキストフィールドのクエリープロパティには、クエリー、列名、予約語を設定することができます。クエリープロパティに設定された文字列が複数のワードを持つ場合はクエリーとして認識されます。１つのワードが設定された場合、そのワードが予約語であれば予約語として認識され、それ以外であれば列名として認識されます。

予約語の種類

テキストフィールドに設定できる予約語には以下のものがあります。

１．PAGE
帳票のページ番号を印刷します。ページ番号の開始ページは、帳票印刷時にツールバーの開始ページテキストボックスで指定することができます。

２．YEAR
４桁の西暦を印刷します。

３．SYEAR
西暦の下２桁を印刷します。

４．MONTH
月を印刷します。

５．DAY
日を印刷します。

６．HOUR
時間を印刷します。

７．MINUTE
分を印刷します。

８．SECOND
秒を印刷します。

９．SUM
グリッドの列の合計を印刷します。データの取得先がACCESSまたはODBCの場合にのみ有効です。
書式：SUM[グリッドフィールド名称:列番号]
例）
グリッドフィールド名称が”詳細”で、その４列目の合計値を表示したい場合には、SUM[詳細:4] と記述します。
グリッドフィールドに取得したクエリーの結果が複数ページにまたがる時、SUM機能は全ページ分の合計を計算します。1ページだけの合計を出す場合には計算式を設定します。
帳票登録ウィンドウで、求めた合計値を全ページに表示するか、先頭ページだけに表示するか、最終ページだけに表示するかを設定することができます。


計算式の設定

テキストフィールドには計算式を設定することができます。
合計欄など計算が必要なものは、テキストフィールドに計算式を設定しておくと自動計算します。

・レポートエディタの帳票印刷モードによる帳票印刷時、値を自動計算して出力します。
・レポートライブラリからの印刷時、値を自動計算して出力します。
（プレビューコントロールで表示する時はLockedプロパティの設定が必要です。）

※計算式の設定機能は、可変フォームでは使用できません。

計算式の設定

計算式は、テキストフィールドの計算式プロパティに設定します。

計算式の記述

使用できる演算子は加減乗除です。括弧も使うことができます。
使用できる値は定数、テキストフィールドの値、グリッドフィールドの値です。

１．定数
計算式中に値を記述します。

２．テキストフィールド
計算式中にフィールド名称を記述します。

３．グリッドフィールド
計算式中に以下の書式で記述します。
グリッドフィールド名称[列番号:行番号]

計算式の設定例

１．テキストフィールドの名称が "数量１"、"数量２"、"数量３"の平均
(数量１+数量２+数量３) / 3

２．テキストフィールドの名称が "税抜き金額"の値に、消費税5%を加える
税抜き金額 * 1.05

３．グリッドフィールドの名称が "詳細"の4列目を1行目から3行目まで合計する
詳細[4:1]+詳細[4:2]+詳細[4:3]

計算結果

計算の精度は有効桁数13桁です。
編集子を利用すると、小数点以下の桁数を操作することができます。
例えば、編集子に「###.##」を設定すると、小数点以下第2位まで表示し、以下は切り捨てられます。

計算式の評価順序

複数のテキストフィールドに計算式が設定されている場合、計算される順番はフィールド順となります。フィールド順は、「フォームメニュー／フィールド順指定」で設定します。


マルチページ編集

レポートエディタでは、1つのフォームファイル中に、複数のページを作成することができます。
各ページごとに、用紙サイズや用紙方向、グリッド間隔などを指定できます。
作成された複数のフォームは、保存時に、1つのファイルの中に保存されます。
レポートライブラリからフォームを使う時には、ページ番号またはページキーを使って目的のフォームを読み込みます。

※マルチページ編集機能は、可変フォームでは使用できません。

ページウィンドウ

ページをコントロールするページウィンドウがあります。
ページウィンドウはメニューバーの「表示／ページウィンドウ」で画面の右側に表示されます。

ページウィンドウには、ファイルのページ情報がツリー上に表示されます。
ページウィンドウ上でページフォルダをクリックすると、該当ページが表示されます。
ツールバーには、ページを操作するボタンが並んでいます。

１．ページの追加
表示中のページの後ろに新しいページを追加します。
実行すると、ページツリーに新しいページのアイコンが追加されます。
ページは、「フォームメニュー／ページの追加」でも追加されます。

２．ページの複写
表示中のページの後ろに、表示中のページと同じページを作成します。
実行すると、ページツリーに新しいページのアイコンが追加されます。

３．ページの削除
表示中のページを削除します。
実行すると、ページツリーから削除したページのアイコンが削除されます。

４．上へ移動
表示中のページを１つ前のページと入れ替えます。

５．下へ移動
表示中のページを１つ後ろのページと入れ替えます。

６．ページキーの変更
表示中のページにページキーを付けます。
ページキーとは、ページの名称で、上図のページウィンドウでは「納品書・請求書・納品書控え・受領書」がそれにあたります。
レポートライブラリからフォームを指定する時、このページキーを使うこともできます。
フォームファイル名称（上図の「複数伝票」）は、「フォームメニュー／フォームファイル情報」で設定します。

７．ページキーのコピー
すべてのページキーをクリップボードにコピーします。


フォーム設定ウィザード

レポートエディタを起動すると、フォーム設定ウィザードが開始します。
ウィザードでは、フォームの用紙やグリッドを対話形式で順番に設定していくことができます。
フォーム設定ウィザードの開始ページにある「レポートエディタ起動時にこのダイアログを表示する」がチェックされていない場合は、ウィザードは開きません。その場合は、表示メニューからウィザードを開始します。

※フォーム設定ウィザードは、可変フォームでは使用できません。

フォームファイルの選択

フォームを新規作成するか、最近使ったフォームを開くかを選択します。
「新規作成」を選択した場合は、次へボタンを押して次の画面へ移動します。
「既存のフォームを開く」を選択した場合は、フォーム名称を入力し、完了ボタンを押してウィザードを終了させます。
「最近使ったフォームを開く」を選択した場合は、リストからフォームを選択し、完了ボタンを押してウィザードを終了させます。

用紙の設定

帳票に使用する用紙のサイズと印刷の向きを設定します。
選択肢に挙がっていないサイズの用紙を使う場合は、ユーザー定義サイズとして作成します。
ユーザー定義サイズは、環境設定画面のユーザー定義サイズタブで、あらかじめ作成しておきます。ユーザー定義サイズのボックスには、作成したユーザー定義サイズが一覧として挙がり、使用するサイズを選択することができます。

マージンの設定

印刷時の余白（マージン）を設定します。
環境設定画面の「用紙の余白タブ」で設定された値が初期表示されます。ここでは、その値を変更することができます。

１．単位
設定値の単位を選択します。

２．用紙サイズ
用紙のサイズを指定します。

３．余白
印刷時の余白を指定します。

４．初期値
環境設定画面の「用紙の余白タブ」で設定されている値を再表示します。

ラベル印刷の設定

１．用紙方向、用紙サイズ、マージン
前画面で設定した用紙サイズ、余白が表示されます。変更する場合は、前の画面で変更します。

２．ラベル枚数
一枚の用紙内に、縦横にラベルが何枚はいるかを指定します。

３．ラベルサイズ
ラベル一枚のサイズを指定します。

４．ラベル間隔
ラベルとラベルの間隔を指定します。

５．ラベル名ボックス
登録済みのラベルを選択する場合は、ラベル名ボックスから選択します。

グリッド間隔の設定

レポートエディタのグリッド間隔を指定します。作成する帳票にあったものを設定しておくと、設計作業が楽に行えます。
グリッド間隔は、ｍｍ、CPI、LPI単位で指定することができます。
CPI（キャラクタ／インチ）とは、1インチ当たりの文字数を表わします。
LPI（ライン／インチ）とは、1インチ当たりの行数を表わします。
編集メニューの［グリッドに合わせる］で、［グリッドに合わせない］を選択すると、図形や文字をグリッドに左右されず自由に描画することができます。


ファイルメニュー((帳票印刷モード)

ファイルメニュー

１．フォームを開く
帳票印刷に使用するフォームファイルを開きます。

２．印刷
表示中の帳票を印刷します。

３．帳票登録ウィザード
帳票登録ウィザードを開始します。

４．RDFファイル作成
表示中の帳票をRDFファイルに保存します。
RDFファイル作成画面がポップアップします。

５．PDFファイル作成
表示中の帳票をAdobe PDF形式でファイルに保存します。
PDFファイル作成画面がポップアップします。

６．環境設定
帳票定義ファイル名やオーバーフロー処理などを設定します。

７．ファイル情報
フォームファイル全体のファイル情報を設定します。

８．外字ファイル作成
ジャイブレポート専用の外字ファイルを作成します。
帳票データに外字を使用する時や、フォームに外字の固定文字がある時には、ジャイブレポート外字ファイルを作成して実行環境へコピーすると、実行環境に外字フォントがなくても外字を描画することができます。

－ジャイブレポート外字ファイルの作り方
－ ジャイブレポート外字ファイルの使い方

９．高速印刷モード
帳票を高速に印刷する場合は、高速印刷モードを選択します。
高速印刷モードを選択すると、シャドウ、フェードアウト、ソフトエッジ、グラデーション、テクスチャ、カスタムブラシ、３Ｄ、文字変形が使用できなくなります。
高速印刷モードの設定は、PDFファイルを作成する時には無効です。

10．終了
レポートエディタを終了します。


表示メニュー(帳票印刷モード)

表示メニュー

１．フォーム設計モード
レポートエディタをフォーム設計モードにします。
フォーム設計モードではフォームの編集が行えます。

２．帳票印刷モード
レポートエディタを帳票印刷モードにします。
帳票印刷モードでは、帳票データの取りこみ先からデータを取りこみ、画面への表示、印刷を行ないます。

３．グリッド
グリッド線の表示／非表示を切り替えます。

４．ルーラー
ルーラーの表示／非表示を切り替えます。

５．ステータスバー
ステータスバーの表示／非表示を切り替えます。

６．ページウィンドウ
ページウィンドウを表示します。
キーフィールドを設定すると、データ取得後、ページウィンドウに各ページキーが表示されます。

７．帳票登録ウィンドウ
帳票登録ウィンドウを表示します。

８．データウィンドウ
帳票データ入力ウィンドウを表示します。

９．ツールバー
画面のツールバーの表示／非表示を切り替えます。

10．倍率
画面の表示倍率を設定します。


ツールバーの説明(帳票印刷モード)

ツールバーの説明

１．フォームを開くボタン
帳票印刷に使用するフォームファイルを開きます。

２．ズームコンボボックス
画面の表示倍率を選択します。

３．印刷ボタン
印刷ダイアログボックスを表示します。

４．帳票登録ウィンドウボタン
帳票登録ウィンドウを開きます。

５．データ入力ウィンドウボタン
データ入力ウィンドウを開きます。

６．帳票選択コンボボックス
登録済みの帳票名を選択します。

７．データ読込ボタン
帳票データを読み込みます。

８．先頭ページボタン
先頭ページへ移動します。複数ページ分の帳票データを読み込んだ場合に使用します。

９．前ページボタン
前のページへ移動します。複数ページ分の帳票データを読み込んだ場合に使用します。

10．次ページボタン
次のページへ移動します。複数ページ分の帳票データを読み込んだ場合に使用します。

11．最終ページボタン
最終ページへ移動します。複数ページ分の帳票データを読み込んだ場合に使用します。

12．表示ページボックス
表示中のページ番号を表示します。ページ番号を入力すると、指定ページにジャンプします。

13．ページ数ラベル
総ページ数を表示します。

14．データ入力ボタン
データ入力を選択すると、レポートエディタの画面上で値を入力することができます。
フィールドの位置でマウスをクリックすると、入力用のグレーボックスが表示されます。
イメージフィールドの場合は、イメージを選択するダイアログボックスが開きます。
グリッドフィールドの場合は、グリッドと同じ形式のシートが開きます。
計算式が設定されているテキストフィールドには値を入力することはできません。

15．データ保存ボタン
レポートエディタ画面で入力した値や、データウィンドウで入力した値をファイルへ書き込みます。実行前に帳票登録を行っておきます。

16．RDFファイル作成ボタン
帳票をRDF形式のファイルに保存します。

17．PDFファイル作成ボタン
帳票をAdobe PDF形式のファイルに保存します。

18．予約語開始ページボックス
テキストフィールドに「PAGE」という予約語を設定した場合に使用します。
帳票のページを自動出力する「PAGE」の開始番号を設定します。
設定しない場合は、開始番号は1になります。

19．帳票登録ウィザードボタン
帳票登録ウィザードを表示します。

20．帳票の削除ボタン
開いている帳票の登録情報を削除します。

21．ヘルプボタン
ヘルプを表示します。


帳票登録の方法

帳票登録とは、レポートエディタから帳票印刷を行なうための準備作業です。
帳票登録には、帳票登録ウィンドウから行う方法と、帳票登録ウィザードで対話形式に設定していく方法があります。
ここでは、帳票登録ウィンドウから行う方法を解説します。

１．メニューバーの「表示／帳票印刷モード」を実行し、帳票印刷モードに変更します。

２．帳票印刷に使用するフォームファイルを開きます。フォームファイルにフォームが複数ページある場合は、使用するページを表示します。

３．メニューバーの「表示／帳票登録ウィンドウ」を実行し、帳票登録ウィンドウを表示します。

４．キーフィールド

帳票が複数ページに渡って作成される場合、各ページを判別するテキストフィールド名をキーフィールドに指定しておくと、指定されたテキストフィールドのデータが、ページウィンドウのタイトルとして表示され、簡単に目的のページを見つけることができます。
例えば、複数の顧客の見積書を作成する場合、キーフィールドに顧客名のテキストフィールドを指定しておくと、ページウィンドウの各ページのタイトルに、顧客名が表示され、どのページがどの顧客の見積書であるかを一目で判別することができます。

５．クエリーの予約語を無視する

テキストフィールドに設定されている予約語を無効にします。
日付やページ番号などの予約語が設定されたテキストフィールドに、ExcelやACCESSなどのデータを表示する場合に使用します。

６．データの取得先を選択します。

データの取得先によって、設定画面が異なります。
－テキストファイルを選択する場合はここをクリックしてください。
－Excelを選択する場合はここをクリックしてください。
－AccessまたはODBCを選択する場合はここをクリックしてください。

７．帳票の登録

上記1～6の設定値を登録することができます。

7-1．帳票名
設定値に名称をつけます。登録後は、この帳票名で呼び出します。

7-2．この設定で登録する
ボタンを押すと登録します。設定値は、帳票定義ファイルに保存されます。
帳票定義ファイルは、環境設定画面で設定しておきます。

7-3．データの取り込み
1～6の設定に従ってデータを取得します。
データの取り込みは、画面上部のツールバーからも行えます。

7-4．終了
帳票登録画面を終了します。


テキストファイルからデータを取得

テキストファイルからデータを取得する

1．テキストファイル名
帳票印刷に使うテキストファイル名をフルパスで指定します。
参照ボタンを押すとファイル選択ボックスが開きます。

2． 区切り記号
テキストファイルのデータ間の区切り記号を指定します。
［自動］を選択すると、カンマとタブを自動判別します。

3．テキストファイルへデータを保存する
帳票データウィンドウの値を「テキストファイル」で指定したテキストファイルに保存します。


Excelファイルからデータを取得

Excelファイルからデータを取得する

1．ファイル名
帳票印刷に使うExcelファイル名を指定します。
ファイル名ボタンをクリックすると、ファイル選択ダイアログが表示されます。

2．ワークシート名
使用するワークシート名を指定します。
ワークシート名ボタンをクリックすると、ワークシート一覧が表示されます。

3．ページデータの向き
1ページ分のデータを取得する向きを指定します。
1ページ分のデータがワークシート上で横方向に並んでいる場合は横並びを選択します。
縦方向に並んでいる場合は縦並びを選択します。

－帳票データの作成

4．フィールド名の行
フィールド名が入っている行番号を指定します。
ワークシートにフィールド名がない場合は［指定なし］を指定します。
この項目は、ページデータの向きに横並びを選択した場合に設定します。

5．データ取得行
データを取得する開始行と終了行を指定します。
この項目は、ページデータの向きに横並びを選択した場合に設定します。

6．フィールド名の列
フィールド名が入っている列番号を指定します。
ワークシートにフィールド名がない場合は、［指定なし］を指定します。
この項目は、ページデータの向きに縦並びを選択した場合に設定します。

7．データ取得列
データを取得する開始列と終了列を指定します。
この項目は、ページデータの向きに縦並びを選択した場合に設定します。

8．R1C1形式
列表示形式を指定します。
チェックボックスにチェックマークがついていると列表示は数字となり、チェックマークがはずれていると列表示はアルファベットになります。
この項目は、ページデータの向きに縦並びを選択した場合に設定します。

9．Excelファイルへデータを保存する
帳票データウィンドウの値をExcelファイルへ保存します。
「フィールド名の行」が「指定なし」の場合は保存できません。
「ファイル名」で指定したExcelファイルの「ワークシート名」で指定したワークシートに書き込みます。「データ取得行」で指定した行が、書き込みの対象行となります。例えば、2～3行を指定した場合、ワークシートの2行目と3行目に、帳票データウィンドウの1行目と2行目のデータを書き込みます。帳票データウィンドウのセルが空白の場合には、該当するワークシートのセルが空白になります。既にデータがある場合は、上書きされるので注意が必要です。


データベースからデータを取得

データベースからデータを取得する

データ取得先でACCESSを選択した場合

1．Accessデータベースファイル名
ACCESSのファイル名（mdbファイル）をフルパスで指定します。
参照ボタンを押すとファイル選択ボックスが開きます。

2．クエリー
ACCESSからデータを抽出するためのクエリーを設定します。
フォームに設定されたクエリーが表示されますが、ここで編集することもできます。
編集中に元のクエリーに戻したい場合は「フォームのクエリーを再読み込み」ボタンを押すとフォームのクエリーが再表示されます。

3．予約語「SUM」の値表示
SUMとは、テキストフィールドに設定可能な予約語で、グリッドの列の値を集計する機能です。
データ取得により複数ページの帳票が作成された場合、合計値を表示するページを指定します。
「全ページ」では、全ページの合計欄に合計値が表示されます。「先頭ページ」「最終ページ」では、先頭ページ、または最終ページの合計欄にのみ合計値が表示されます。

データ取得先でＯＤＢＣを選択した場合

1．接続文字列
データベースへの接続文字列を指定します。
参照ボタンを押すと、接続文字列の作成ダイアログが表示されます。
ダイアログでは、コントロールパネルのODBCデータソースアドミニストレータで設定したデータソース名から接続文字列を取得することができます。
接続するデータベースがSQLサーバーの場合は、サーバー名、データベース名、ユーザーID、パスワードを指定して接続文字列を取得することもできます。

2．クエリー
データベースからデータを抽出するためのクエリーを指定します。
フォームに設定されているクエリーが表示されますが、ここでクエリーを編集することもできます。
編集中に元のクエリーに戻したい場合は、「フォームのクエリーを再読み込み」ボタンを押すとフォームのクエリーが再表示されます。

3．予約語「SUM」の値表示
SUMとは、テキストフィールドに設定可能な予約語で、グリッドの列の値を集計する機能です。
データ取得により複数ページの帳票が作成された場合、合計値を表示するページを指定します。
「全ページ」では、全ページの合計欄に合計値が表示されます。「先頭ページ」「最終ページ」では、先頭ページ、または最終ページの合計欄にのみ合計値が表示されます。


帳票印刷の方法

帳票データを読み込んで帳票印刷を行います。
※帳票印刷をする前に帳票登録が必要です。

１．メニューバーの「表示／帳票印刷モード」を実行し、帳票印刷モードに変更します。

２．帳票選択コンボボックスで、登録済みの帳票名を選択します。

３．データ読込ボタンをクリックし、帳票データを読み込みます。
Excelからデータを読み込む場合は、Microsoft Excelをインストールしておきます。
ACCESSからデータを読み込む場合は、ODBCドライバとMDBファイルを用意します。ACCESSをインストールする必要はありません。
SQL Serverからデータを読み込む場合は、SQL Serverと接続できる環境が必要です。

４．データが正常に読み込まれた場合は、帳票フォームのフィールドに取得値が表示されます。

５．レポートエディタの画面から直接値を入力することもできます。
レポートエディタから値を入力する時は、データ入力ボタンを押します。
フィールドをマウスでクリックすると、グレーの入力ボックスが表示されます。

６．帳票データウィンドウを開き、データを入力することもできます。

７．印刷は、印刷ダイアログを開いて行います。
印刷ダイアログは、メニューバーの「ファイル／印刷」またはツールバーの印刷ボタンでポップアップします。


帳票データウィンドウ

帳票データウィンドウでは、帳票データを入力することができます。
帳票データウィンドウの表示
・メニューバーの「表示／帳票印刷モード」を実行し、帳票印刷モードに変更します。
・「表示／データウィンドウ」で帳票データウィンドウを開きます。

データウィンドウのスプレッドシート

1．帳票データウィンドウには、データ用のスプレッドシートが表示されます。
スプレッドシートの列名には、フォーム上に貼り付けられたフィールド名称が表示されます。

2．フィールドとセルの対応は以下の通りです。
テキストフィールド・バーコードフィールド・イメージフィールドは、スプレッドシートのセルを1つ使います。
グリッドフィールドは、列数×行数分のセルを使用します。グリッドフィールドの左上から横方向に使います。
グラフフィールドは、グラフのデータ数分のセルを使用します。データの順番は、レポートエディタの固定グラフでデータを横向きにセットする時と同じです。

3．スプレッドシートのセルにデータを直接入力することができます。
セル上でマウスをクリックすると、セルにカーソルが入ります。

4．スプレッドシートの1行は、帳票の1ページに相当します。

5．スプレッドシートの行は追加することができます。
ExcelやACCESSなどからデータを取得した場合、スプレッドシートには取得した行数が表示されます。行はメニューバーの「行の追加」で追加することができます。

メニューバー：ファイル

1．テキストファイルへデータ保存
スプレッドシートのデータをテキストファイルに保存します。
ファイル保存のダイアログボックスが表示されます。

2．プレビュー
帳票のプレビューを行ないます。
カーソルのある行（ページ）をプレビューします。

3．終了
帳票データウィンドウ画面を閉じます。

メニューバー：オプション

1．フィールド名称の取得（横方向）
フィールド名称をクリップボードにコピーします。
フィールド名称とフィールド名称の間は、タブ記号で区切られます。
Excelのワークシート上で、貼り付けを行なうと、横方向にフィールド名称がセットされます。

2．［オプション／フィールド名称の取得（縦方向）］
フィールド名称をクリップボードにコピーします。
フィールド名称とフィールド名称の間は、改行コードで区切られます。
Excelのワークシート上で、貼り付けを行なうと、縦方向にフィールド名称がセットされます。

3．行の追加
スプレッドシートの最後に新しい行を追加します。

4．オプション／行の削除
スプレッドシート上のカーソルのある行を削除します。


帳票印刷の環境設定

帳票印刷の環境を設定します。
環境設定は、［ファイル／環境設定］で環境設定画面を開いて行ないます。
環境設定画面には、様々な項目がありますが、ここでは、帳票印刷に関する項目のみを解説します。

１．帳票定義ファイル
帳票登録用の定義ファイル名を指定します。
帳票定義ファイルとは、帳票登録の設定値を保存するファイルです。
パスが設定されていない場合は、レポートエディタが動作しているカレントディレクトリにファイルを作成します。
帳票定義ファイルには、複数の帳票登録情報が保存されます。

２．帳票印刷モード専用にする
レポートエディタを帳票印刷モード専用にします。
この項目がチェックされているとフォーム設計モードに変更できません。
帳票印刷のみを行なう場合には、誤ってフォームを変更してしまうことを防ぐことができます。

３．数値フィールドオーバーフロー時、“*”を出力
数値フィールドにデータを取得した時、取得したデータが編集子の桁数を超えた場合に、編集子の桁数分の*記号を出力します。
この項目がチェックされていない場合は、オーバーフロー時に何も出力されません。

４．文字フィールドオーバーフロー時、カットして出力
文字フィールドにデータを取得した時、取得したデータが編集子の桁数を超えた場合に、データを編集子の桁数分にカットして出力します。
この項目がチェックされていない場合は、オーバーフロー時に何も出力されません。
その他の項目については、『環境設定』を参照してください。


帳票データの作成

レポートエディタで読み込む帳票データを準備します。
データは、データベース、Excel、テキストファイルなどで準備します。
レポートエディタの画面から直接データを入力することもできます。

データベースからデータを読み込む

データベース（ACCESS、SQL Server）からデータを読み込む場合は、クエリーを記述します。

1．データベースからデータを取得する場合は、フォームやフィールドにクエリーを記述します。

2．帳票印刷モードでデータ読込ボタンを押すと、クエリーが実行されてデータを取得します。

3．クエリーは、利用するデータベースで有効なものを記述します。
レポートエディタは、クエリーをそのままACCESSやSQL Serverへ送ります。

4．全てのクエリーを記述できるため、ジャイブレポート専用のテーブルは不要です。

Excelファイルからデータを読み込む

Excelファイルからデータを読み込む場合は、形式にあったExcelデータを準備します。

1．テキストフィールド、イメージフィールド、バーコードフィールドのデータ
フィールドごとに、ワークシートのセルを１つ使います。

2．グリッドフィールド
グリッドフィールドのセル１つに対してワークシートのセル１つを使います。グリッドフィールドの列数×行数分のセルを使います。データの順番は、グリッドフィールドの左上が1番目となり、横に2番目、3番目と続きます。

3．グラフフィールド
ワークシートの１つのセルデータが１つのグラフデータとなります。グラフフィールドではグラフデータの数分のセルを使用します。

4．ワークシートの横1行、または縦１列を帳票の1ページ分のデータとして準備します。

・1ページ分のデータを横方向にとるか縦方向にとるかは、帳票登録画面で設定できます。
・Excelは、通常256列しかないため、フィールド総数が256を超える場合には、横1行を1ページ分のデータとすることはできません。その場合には、縦1列を1ページ分のデータとしてください。

5．ワークシートのデータの順番は、ワークシートにフィールド名称を貼り付けているかどうかで決まります。

ワークシートにフィールド名称を貼り付けている場合：

上図のように、フィールド名称を貼り付けた場合、レポートエディタは、フィールド名称に対応するセルからデータを取得します。各フィールドのデータは、フィールド名称に対応するセルにセットしておきます。
・フィールド名称の貼り付け方
フィールド名称は帳票データウィンドウで取得することができます。
帳票データウィンドウ（メニューバー：オプション）参照
フィールド名称を貼り付けた行（または列）は、帳票登録画面で指定できます。

ワークシートにフィールド名称を貼り付けていない場合：

レポートエディタは、ワークシートの先頭のセルから順番にデータを取得します。ワークシートのデータ順とフォームのフィールド順は揃っていなくてはなりません。

テキストファイルからデータを読み込む

テキストファイルから帳票データを読み込む場合には、テキストファイルを準備します。

1．テキストファイルは、データとデータの間をカンマまたはタブで区切っておきます。

2．テキストフィールド、イメージフィールド、バーコードフィールド
フィールドごとに、テキストファイルのデータを１つ読み込みます。

3．グリッドフィールド
グリッドフィールドの1つのセルにテキストファイルのデータを1つ読み込みます。グリッドフィールドの列数×行数分のデータを読み込みます。データの順番は、グリッドフィールドの左上が1番目となり、横に2番目、3番目と続きます。

4．フィールド
テキストファイルのデータ1つが1つのグラフデータとなります。グラフフィールドではグラフデータの数分のデータを使用します。

5．改行コードによって区切られた1行が、帳票の1ページ分のデータとなります。

6．行頭から順番にデータを取得します。
データの並び順とフィールドの並び順は、揃っていなくてはなりません。データが余った場合は、余ったデータは無視されます。

レポートエディタから値を入力する

レポートエディタの画面から帳票データを入力することもできます。
1．メニューバー「表示／帳票印刷モード」を実行し、帳票印刷モードに変更します。

2．メニューバー「帳票／データ入力」、または、データ入力ボタン [image] を押します。

3．画面上のフィールドをマウスでクリックすると、グレーの入力ボックスが表示され文字を入力することができます。

4．メニューバー「表示／データウィンドウ」で帳票データウィンドウを開き、データを入力することもできます。

5．入力したデータは、テキストファイルとして保存することもできます。


印刷画面

帳票の印刷

帳票が完成したら印刷します。
印刷は、「ファイル／印刷」で印刷画面を開いて行います。

１．マージンとスケール
印刷時のマージン（余白）やスケールを設定することができます。
余白の詳細は「付録／用紙の余白（マージン）設定」を参照してください。

２．印刷対象
「フォームとフィールド」を選択すると、帳票のフォームとデータが印刷されます。
「フィールドのみ」を選択すると、フォームは印刷されず、データだけが印刷されます。フォームが印刷されている専用用紙などの印刷に使用します。

３．プリンタの設定
プリンタプロパティ画面が開きます。
プリンタとプリンタドライバの設定を行ないます。

４．印刷する範囲
印刷する範囲を選択することができます。

５．印刷
印刷を開始します。

６．終了
印刷画面を終了します。


帳票登録ウィザード

帳票登録とは、レポートエディタから帳票印刷を行なうための準備作業です。
帳票登録ウィザードでは、帳票登録を対話形式で設定することができます。

メニューバーの「表示／帳票印刷モード」を実行し、帳票印刷モードに変更します。

帳票印刷モードに切り替えると、帳票登録ウィザードが開きます。
帳票登録ウィザードの開始ページにある「帳票印刷モード切り替え時にこのダイアログを表示する」がチェックされていない場合は、ウィザードは開きません。その場合は、帳票メニューからウィザードを開始します。

帳票定義ファイルの選択

１．新規作成
新しく帳票印刷の設定を行う場合には、ここをクリックし、次へボタンを押します。

２．既存の設定を開く
今から設定する内容は、最後に名前をつけて登録しておくことができます。
既に登録済みの設定を利用する場合は、「既存の設定を開く」をクリックし、登録した名前を選択します。登録済みの設定を選択した場合は、ウィザードはこれで終了です。完了ボタンを押してレポートエディタの画面に戻ります。

３．帳票印刷モード切り替え時にこのダイアログを表示する
この項目がチェックされていると、帳票印刷モードに切り替えた時、帳票登録ウィザードが開きます。ウィザードを開きたくない場合は、この項目のチェックをはずしておきます。

フォームファイルの選択

１．フォームファイル
帳票印刷に使うフォームファイルを選択します。

２．ページ
フォームファイルに複数のフォームが入っている場合は、ページを選択します。

データの取得先

１．データの取得先
帳票データの取り込み先を、テキストファイル、Excel、ACCESS、ODBCの中から
選択します。SQL Serverから取り込む場合は、ODBCをクリックします。

データ取得先がテキストファイル：テキストファイルの設定

１帳票データが保存されているテキストファイルを設定します。

２．区切り記号
データとデータの区切り記号を選択します。自動を選択すると、カンマとタブを自動判別します。

データ取得先がExcel：Excelファイル名とワークシートの設定

１．Excelファイル名
帳票データが保存されているExcelのファイル名を設定します。

２．ワークシート名
帳票データが保存されているExcelのフワークシート名を設定します。

データ取得先がExcel：ページデータの向きの選択

１．ページデータの向き
１ぺージ分のデータが、ワークシートのどの方向に並んでいるかを指定します。
１行に並んでいる場合は横並び、1列に並んでいる場合は縦並びを指定します。

データ取得先がExcel：ページデータが横並びの設定

１．フィールド名の行
ワークシートにフォームのフィールド名称を貼り付けている場合は、その行を指定します。

２．データ取得行
データを取得する開始行と終了行を設定します。

データ取得先がExcel：ページデータが縦並びの設定

１．フィールド名の行
ワークシートにフォームのフィールド名称を貼り付けている場合は、その列を指定します。

２．データ取得列
データを取得する開始列と終了列を設定します。

３．R1C1形式
R1C1形式をクリックすると、列の指定を数字で行うことができます。

データ取得先がACCESS：データベース名の設定

１．データベース名
帳票データを登録しているデータベース名を設定します。

データ取得先がACCESS:クエリーの設定

１．クエリー
フォームにクエリーを設定したい場合や、既に設定済みのクエリーを変更したい場合は、ここで設定します。

データ取得先がACCESS：予約語SUMの設定

１．予約語SUMの値表示
テキストフィールドに予約語のSUMを設定している場合は、合計を表示するページを指定します。

データ取得先がODBC：接続文字列の設定

１．接続文字列
データベースへの接続文字列を設定します。「・・・」ボタンを押すと、接続文字列を自動的に作成することができます。

キーフィールドの設定

１．キーフィールド
複数ページ分のデータを取得した時、ページウィンドウに、各ページを見分けるものが表示されていれば、見たいページをすぐに見つけることができます。キーフィールドには、このような各ページの見出しを設定することができます。
例えば、見積番号、顧客名、住所、売上金額のフィールドがあるフォームの場合、キーフィールドに顧客名を設定しておくと、ページウィンドウには、各ページの顧客名が表示されます。

２．クエリーの予約語を無効にする
テキストフィールドに予約語が設定されている場合、「クエリーの予約語を無効にする」をチェックすると、予約語を無視します。チェックがはずれている場合は、予約語が有効となり、予約語に設定されている内容のデータを自動的に印刷します。
これは、テキストファイルからデータを取り込む場合などのように、フィールドとデータが1対1に対応付けられている状況でのデータ調整に使います。

帳票名の設定

１．帳票名
今まで設定した内容に名前をつけて登録します。
この項目で帳票登録ウィザードは終わりです。レポートエディタ画面に戻り、帳票印刷が行えます。次回からは、帳票選択ボックスからここで登録した名前を選択するだけで、帳票印刷を行うことができます。


環境設定

レポートエディタの動作環境を設定します。

［ファイルメニュー／環境設定］を実行すると、環境設定画面が開きます。

１．カラー
グリッド、用紙、用紙外の表示色を指定します。

２．描画メモリサイズ
画面描画用に確保するメモリサイズを指定します。
大きなメモリサイズを設定するとスクロールが速くなりますが、メモリを消費します。

３．作業ディレクトリ・作業ファイル名
レポートエディタが動作するための作業ディレクトリと作業ファイル名を指定します。
正しく設定されていないとレポートエディタは正常に動作しません。設定された作業ディレクトリと作業ファイル名は、次回起動時から有効となります。
レポートエディタを初めて起動した場合は、作業ディレクトリと作業ファイル名を設定後、再起動してください。

４．帳票定義ファイル名
レポートエディタから帳票印刷をする時の定義内容を保存するファイル名を指定します。
帳票定義ファイルとは、帳票登録の設定値を保存するためのファイルです。

５．イメージ検索パス
フォーム上に貼り付けた固定イメージの検索パスを指定します。
レポートエディタは、固定イメージを表示する時、このイメージ検索パスを検索し、次に貼り付け時のパスを検索します。

６．ラベル定義ファイル
フォーム情報画面で作成したラベルを保存するファイル名を指定します。
ラベル定義ファイルには、複数のラベル定義情報が保存されます。

７．新元号
レポートエディタの帳票印刷モードで出力する帳票に、和暦で出力するフィールドがある場合には、ここで新元号を設定することができます。
「令和、平成、昭和、大正、明治」の各元号は、自動で表示されます。
新元号は、「開始年月日、ローマ字略称、漢字略称、元号」の順番で、それぞれの値を指定します。
情報と情報の間は、半角のコロン（：）を使います。

例）　2099年1月1日から元号が「永宝」になった場合
20990101：E：永：永宝

この項目は、レポートエディタからの和暦出力に対してのみ有効です。レポートライブラリから出力する場合には、レポートライブラリの機能を使ってください。

８．フォントサイズ計算にプリンタドライバを使用する
文字列描画に使用するフォントサイズを通常使うプリンタに設定されたプリンタドライバから取得します。
通常使うプリンタで印刷した時に、画面表示と印刷結果の文字位置が同じになります。

９．フィールド名称を表示する
フォームに貼り付けられたフィールドのフィールド名称を画面に表示します。

10．印刷時にフィールド名称を印字する
フォームを印刷する時に、フォームに貼り付けられたフィールドのフィールド名称を印刷します。
この項目は、レポートエディタからフォーム設計モードでフォームを印刷した時のみ有効です。

11．印刷時にグリッド線を描画する
フォームを印刷する時に、グリッド線を印刷します。
この項目は、レポートエディタからフォーム設計モードでフォームを印刷した時のみ有効です。

12．プリンタ設定時にプリンタ情報をコピーする
この機能はプリンタドライバ情報を取得する時に使います。取得したプリンタドライバ情報はレポートライブラリで使います。取得する必要がない時はチェックをはずしておきます。
［ファイル／印刷／プリンタの設定］でプリンタプロパティを設定した時、プリンタドライバ情報を取得しクリップボードにコピーします。

－プリンタドライバ情報とは
－プリンタドライバ情報の取得

13．ツールバーの設定を保存する
レポートエディタを終了した時に、ツールバーの状態を保存します。

14．帳票印刷モード専用にする
レポートエディタを帳票印刷モード専用にします。
この項目がチェックされていると、フォーム設計モードに変更できなくなります。帳票印刷のみを行なう場合に、誤ってフォームを変更してしまうことを防げます。

15．数値フィールドオーバーフロー時、“＊”を出力
この項目は帳票印刷モードでの帳票印刷時に使用します。
数値フィールドにデータを取得した時、取得したデータが編集子の桁数を超えた場合に、編集子の桁数分の*記号を出力します。
この項目がチェックされていない場合は、オーバーフロー時に何も出力されません。

16．文字フィールドオーバーフロー時、カットして出力
この項目は帳票印刷モードでの帳票印刷時に使用します。
文字フィールドにデータを取得した時、取得したデータが編集子の桁数を超えた場合に、データを編集子の桁数分にカットして出力します。
この項目がチェックされていない場合は、オーバーフロー時に何も出力されません。

17．データ取得時のエラーを表示しない
この項目は帳票印刷モードでの帳票印刷時に使用します。
帳票印刷モードでデータベースからデータを取得した時、エラーが発生してもエラーメッセージを表示しません。

18．PDF入力ボックスの枠を表示する
この項目はAdobePDF形式のデータを作成する場合に使用します。
PDFフォームには、3種類のフィールドを設定できます。PDFフォームのフィールドと通常のフィールドを区別するため、PDF用のフィールドには枠を表示することができます。枠を表示する場合には、この項目をチェックします。

－PDFフォーム機能

19．プリンタの解像度・標準プリンタの解像度を使用
オブジェクトを画面に表示する時の解像度を指定します。
「標準プリンタの解像度を使用する」がチェックされていると、「プリンタの解像度」ボックスには、通常使うプリンタに設定されたプリンタの解像度が表示されます。
任意の解像度を指定する時には、「標準プリンタの解像度を使用する」のチェックを外します。
この項目に印刷に使用するプリンタの解像度を指定しておくと、オブジェクトの画面表示と印刷結果がより近いものになります。

20．アンドゥバッファサイズ
アンドゥ・リドゥ用のバッファサイズを指定します。
設定されたサイズが大きいほど、アンドゥ・リドゥを繰り返し行うことができます。


ユーザー定義サイズ

ユーザー定義サイズタブ

レポートエディタで使うユーザー定義サイズ（規格以外の不定形用紙）の作成と登録を行ないます。
［フォームメニュー／フォーム情報］のユーザー定義サイズコンボボックスには、ここで作成したユーザー定義サイズが一覧表示されます。ユーザー定義サイズを使う場合は、ここで作成しておきます。

１．単位
単位を指定します。

２．用紙方向
用紙の向きを指定します。

３．用紙サイズ
用紙の縦横のサイズを「単位」で指定した単位で指定します。

４．余白
用紙の余白を指定します。
余白は、フォーム作成時に、フォーム情報画面から変更することができます。
印刷した時に、余白が設定値より大きい場合は、プリンタの印字原点や印字領域を確認してください。

５．登録
設定したユーザー定義サイズを登録します。
名称ボックスに登録名称を入力し登録ボタンを押します。
登録すると名称ボックスの下に一覧表示されます。

６．削除
登録済みのユーザー定義サイズを削除します。
削除するユーザー定義サイズを選択し削除ボタンを押します。
登録済みユーザー定義サイズは変更できません。変更する場合は、削除後に新しく作成します。
※ユーザー定義サイズは30個まで登録できます。
※ユーザー定義サイズは［フォームメニュー／フォーム情報］でも作成できますが登録できません。


用紙の余白

規定用紙の余白を設定します。

１．縦置き（左、上、右、下）
用紙の向きが縦置きの場合の上下、左右の余白を用紙サイズごとに設定します。
この設定値は「フォームメニュー／フォーム情報」で用紙を選択した時、余白の初期値として表示されます。

２．横置き（左、上、右、下）
用紙の向きが横置きの場合の上下、左右の余白を用紙サイズごとに設定します。
この設定値は「フォームメニュー／フォーム情報」で用紙を選択した時、余白の初期値として表示されます。

※余白は、「フォームメニュー／フォーム情報」で変更することができます。
※余白は、ジャイブレポートのバージョンによって仕様が異なります。
  詳細は「付録／用紙の余白（マージン）設定」を参照してください。


RDFファイル作成

フォームファイルや帳票をRDF形式でファイルに保存します。

※RDFファイル作成機能は、可変フォームでは使用できません。

フォーム設計モードでRDFファイルを作成すると、フォームのみRDFファイルに保存されます。
帳票印刷モードでRDFファイルを作成すると、フォームとデータ（フィールドにデータを埋め込んだ場合）がRDFファイルに保存されます。

１．RDFファイル名
保存するRDFファイル名を指定します。

２．文字フィールドオーバーフロー時の処理
文字型フィールドの文字数が編集子の桁数を超えた場合の処理を指定します。

３．カラーモード
印刷時のカラーモードを指定します。

４．数値フィールドオーバーフロー時の代替文字
数値型フィールドの値が編集子の桁数を超えた場合に表示する代替文字を指定します。

５．範囲
RDFファイルに保存するページを範囲指定します。
フォーム設計モードでは、フォームを1ページのみ作成するため、範囲指定はできません。
帳票印刷モードでは、RDFファイルに保存するページを範囲指定することができます。

６．ビュアーを表示する
RDFファイルを作成後に、プレビューツールでRDFファイルを表示します。
プレビューツールはインストールディレクトリに入っています。
ここで保存したRDFファイルは、プレビューツール（JvPreview80.exe）を使って表示や印刷ができます。
フォームやデータ中に外字が含まれている場合、使用した外字は、RDFファイルの中に埋め込まれます。

※プレビューコントロールの入力機能を使うと、帳票のレイアウト画面で、データを入力して印刷することができます。帳票レイアウト用のRDFファイルは、ここで作成します。

－帳票レイアウト用RDFファイルの作り方


Adobe PDFファイル作成

帳票のフォーム（レイアウト）や、完成した帳票をAdobe PDF形式でファイルに保存します。

※Adobe PDFファイル作成機能は、可変フォームでは使用できません。

フォームのみをAdobe PDFファイルに保存する場合には、フォーム設計モードで作成します。
完成した帳票をAdobe PDFファイルに保存場合には、帳票印刷モードで作成します。
フォーム設計モードと帳票印刷モードでは、PDFファイル作成画面での設定項目が違います。

    フォーム設計モードでのPDFファイル作成画面

    帳票印刷モードでのPDFファイル作成画面

１．PDFファイル名
保存するAdobe PDFファイル名を指定します。

２．文字フィールドオーバーフロー時の処理 （帳票印刷モードのみ）
文字型フィールドの文字数が編集子の桁数を超えた場合の処理を指定します。

３．カラーモード
印刷時のカラーモードを指定します。

４．数値フィールドオーバーフロー時の代替文字 （帳票印刷モードのみ）
数値型フィールドの値が編集子の桁数を超えた場合に表示する代替文字を指定します。

５．範囲 （帳票印刷モードのみ）
Adobe PDFファイルに保存するページを範囲指定します。
フォーム設計モードでは、表示中のフォームのみを作成するため、この項目は指定できません。

６．フォントを埋め込む
使用したフォントをAdobe PDFファイルに埋め込みます。
フォントを埋め込む場合は、True Typeフォントを使います。
True Typeフォントでも、種類によっては埋め込めない場合があります。
そのような場合には、エラーを表示し、埋め込めなかったことを知らせます。

７．サロゲートペア用代替フォント
固定文字やフィールドにサロゲートペアを使用する場合には、代替フォント名を指定します。
「*,SimSun-ExtB」が初期値として表示されます。

８．Adobe Readerを起動する
Adobe PDFファイルを作成後にAdobe Readerを起動しAdobe PDFファイルを表示します。
実行前に、PCにAdobe Readerをインストールしておきます。
保存したAdobe PDFファイルは、Adobe Readerを使って表示や印刷を行います。
フォームやデータ中に外字が含まれている場合、使用した外字は、Adobe PDFファイルの中に埋め込まれます。

－A dobe PDF形式データの制限


外字ファイル作成

ジャイブレポート外字ファイルの作り方

ジャイブレポート専用の外字ファイルを作成します。

帳票作成時に外字を描画する時や、フォームに外字の固定文字を描画した時には、ジャイブレポート外字ファイルを作成して実行環境へコピーすると、実行環境に外字フォントがなくても外字を描画することができます。

外字では、影付き文字、フェードアウト、ソフトエッジ、３Ｄ文字、文字の変形機能は利用できません。

１．「ファイル／外字ファイル作成」で外字ファイル作成画面を開きます。

２．ジャイブレポート外字ファイルの名前を外字ファイル名ボックスに入力します。
３．外字ファイル作成ボタンを押すとジャイブレポート外字ファイルが作成されます。
４．ジャイブレポート外字ファイルが作成されると、ファイル中に登録された外字が表示されます。

５．終了ボタンで画面を終了します。

ジャイブレポート外字ファイル作成時の注意

１．外字フォントの準備

ジャイブレポート外字ファイル作成前に、レポートエディタをインストールした環境に外字フォントを準備します。
外字フォントは、外字エディタなどで作成します。
外字エディタで外字を作成する場合は、特定フォントにリンクする機能は使用できません。

２．ジャイブレポート外字ファイルに保存される外字領域

Shift-JISの場合、上位８ビットは0xF0～0xF9、下位８ビットは0x7Fを除く0x40から0xFCの領域が保存されます。
UNICODEの場合、Shift-JISの外字領域に該当する領域だけが保存されます。

３．外字の描画サイズ

外字は、70ポイント程度のサイズでビットマップイメージとしてジャイブレポート外字ファイルに保存されます。そのため、外字を極端に小さなサイズや大きなサイズで描画すると、不鮮明になったり粗くなったりすることがあります。

４．外字の描画位置

外字と外字以外の文字では、描画位置が微妙にずれることがあります。

－ジャイブレポート外字ファイルの使い方
－外字の描画


パスワード登録

フォームファイルにパスワードをつけます。
パスワードの設定は「ファイル／パスワードの設定」でパスワード登録画面を開いて登録します。

パスワードの登録

新パスワードボックスと確認ボックスに同じパスワードを入力し、OKボタンを押します。
パスワードは30バイト以内で指定します。
パスワードを指定すると、フォームを開く時、パスワード入力画面が開きます。
注意：パスワードはフォームファイルを保存する時に登録されます。パスワードを指定してもフォームファイルを保存しない場合は、パスワードは登録されません。

パスワードの入力

パスワードが設定されたフォームファイルを開くと、パスワード入力画面が表示されます。
パスワードを入力しOKボタンを押します。
正しいパスワードを入力するまではフォームを開くことができません。
「読み取り専用で開く」ボタンを押すと、読み取り専用でフォームを開きます。
読み取り専用の場合、以下の作業はできません。
・フォームの上書き保存
・名前をつけてフォームを保存
・パスワードの設定

パスワードの変更

旧パスワードボックスに現在のパスワードを入力します。
新パスワードボックスと確認ボックスに新パスワードを入力し、OKボタンを押します。
注意：新しいパスワードはフォームファイルを保存する時に登録されます。パスワードを変更してもフォームファイルを保存しない場合は、パスワードは変更されません。


印刷プログラム作成

印刷アプリケーション作成

  ジャイブレポートを使った印刷アプリケーションは、次の手順で作成します。

                    開発言語にあった４種類のレポートライブラリが用意されています。
                     レポートライブラリOCX、レポートライブラリ.NETコントロール
                      レポートライブラリDLL、レポートライブラリJNI

  Web環境での帳票システムも簡単に構築できます。

・RDF形式の帳票は、ジャイブレポートのプレビューコントロールを使ってプレビューや印刷を行います。
・PDF形式の帳票は、Adobe Readerを使ってプレビューや印刷を行います。
・XPS形式の帳票は、XPS Viewerを使ってプレビューや印刷を行います。
・TIFF形式の帳票は、フォトギャラリーなどの描画ツールを使ってプレビューや印刷を行います。
・JPEG、PNG形式の帳票は、スマートフォンやタブレットなどの端末のために用意された形式です。

詳細は、Webアプリケーション開発をご覧ください。


Visual Basic.NETでの使い方

Visual Basic.NET、Visual Basic6.0 での開発

ジャイブレポートは、Visual Basicから使用することができます。

アプリケーションは、レポートライブラリを使って作成します。
帳票をプレビューする場合には、プレビューコントロールを使用します。

－レポートライブラリOCX (ActiveXコントロール)
－ レポートライブラリ.NETコントロール
－レポートライブラリDLL
－プレビューコントロール

サンプルや使い方の説明ファイルがジャイブレポートインストールディレクトリ\SampleProgram ディレクトリにあります。

１．Visual Basic.NET 2005以降で開発する

1-1．レポートライブラリDLLを使う場合

1）プロジェクトに、定義ファイル（jvrvbnetdll.vb）を入れます。
  定義ファイルは、サンプルプログラムと同じディレクトリに入っています。

2）直接印刷をする場合
  直接印刷をする場合には、プリンタのデバイスコンテキストに0を設定します。
  pid = jvCreate(JV_PRINTER, PictureDraw.Handle.ToInt32(), 0, 0, 0, 0, "")

3）ウィンドウ（パネル）に表示する場合
  ウィンドウ（パネル）に表示する場合には、ウィンドウのデバイスコンテキストを取得します。
  Dim hdc As IntPtr
  'ウィンドウ（パネル）のグラフィックスオブジェクトを取得します。
  Dim grpDraw As Graphics = PanelDraw.CreateGraphics()
  '背景を消去します。
  grpDraw.Clear(PanelDraw.BackColor)
  'グラフィックスオブジェクトのデバイスコンテキストを取得します。
  hdc = grpDraw.GetHdc()
  pid = jvCreate(JV_WINDOW, PanelDraw.Handle.ToInt32(), 0, hdc.ToInt32(), 0, 0, "")
  '帳票の描画処理を行います。
  '最後に以下の処理を行って下さい。
  'デバイスコンテキストを解放します。
  grpDraw.ReleaseHdc(hdc)
  'グラフィックスオブジェクトを消去します。
  grpDraw.Dispose()

1-2．レポートライブラリOCXを使う場合

1）プロジェクトに、定義ファイル（jvrvbnetocx.vb）を入れます。
  定義ファイルは、サンプルプログラムと同じディレクトリに入っています。

2）ツールボックスに追加します。
  次の手順で、レポートライブラリOCXをツールボックスに登録します。

  a．メニューの「ツール・ツールボックスのカスタマイズ」を実行します。

  b．レポートライブラリOCXの場合、ポップアップしたダイアログで[Jvrlib10XCtl Class] を選択しOKボタンを押します。

3）ツールボックスのコンポーネントタブ内にあるレポートライブラリを選択しフォーム上に配置します。

4）直接印刷する場合
  直接印刷する場合には、プリンタのデバイスコンテキストを設定するPrnHdcプロパティには何も指定しないようにします。

5）ウィンドウ（パネル）に表示する場合
  ウィンドウ（パネル）に表示する場合には、ウィンドウのデバイスコンテキストを取得します。
  Dim hdc As IntPtr
  'ウィンドウ（パネル）のグラフィックスオブジェクトを取得します。
  Dim grpDraw As Graphics = PanelDraw.CreateGraphics()
  '背景を消去します。
  grpDraw.Clear(PanelDraw.BackColor)
  'グラフィックスオブジェクトのデバイスコンテキストを取得します。
  hdc = grpDraw.GetHdc()
  'デバイスコンテキストをレポートライブラリのWinHdcプロパティに設定します。
  Jvr.WinHdc = hdc.ToInt32()
  '帳票の描画処理を行います。
  '最後に以下の処理を行って下さい。
  'デバイスコンテキストを解放します。
  grpDraw.ReleaseHdc(hdc)
  'グラフィックスオブジェクトを消去します。
  grpDraw.Dispose()

1-3．レポートライブラリ.NETコントロールを使う場合

1）プロジェクトに、定義ファイル（jvrvbnetocx.vb）を入れます。
  定義ファイルは、サンプルプログラムと同じディレクトリに入っています。

2）レポートライブラリ.NETコントロールを実行モジュールと同じ場所にコピーします。
  コントロールは、ジャイブレポートのインストールディレクトリの下にインストールされています。

  --インストールディレクトリ\DnetControl\x86\Framework2.0
  --インストールディレクトリ\DnetControl\x86\Framework4.0

  コントロールは、.NETFramework2.0と4.0に対応するものが用意されています。
  Visual Studio2005/2008の場合はFramework2.0ディレクトリにあるものをコピーします。
  Visual Studio2010以降の場合はFramework4.0ディレクトリにあるものをコピーします。

3）ツールボックスに追加します。
  次の手順で、レポートライブラリ.NETコントロールをツールボックスに登録します。

  a．「.NET Frameworkコンポーネント」タブを表示します。

  b．参照ボタンを押して、2)でコピーしたレポートライブラリ.NETコントロールを選択します。
    名前「Jvrnet10XControl」、名前空間「Jvrnet10Xのものを選択します。

  c．選択すると、ツールボックスの全般グループに「Jvrnet10XControl」が表示されます。

3）ツールボックスのコンポーネントタブ内にあるレポートライブラリを選択しフォーム上に配置します。

1-4．プレビューコントロールを使う場合

1）次の手順で、プレビューコントロールをツールボックスに登録します。

  a．メニューの「ツール・ツールボックスのカスタマイズ」を実行します。
  b．ポップアップしたダイアログで [Jvrvw10XCtrl Class] を選択しOKボタンを押します。

2）次の手順で、プレビューコントロールをフォームに配置します。

  a．ツールボックスのコンポーネントタブ内にあるJvrvw10XCtrlをクリックし、フォーム上に配置します。

3）コーディングの注意点

  ・プレビューコントロールのShowメソッドは、VB.NET2003の場合にはCtlShowメソッドになります。
  ・RDFファイルを作成するディレクトリは、書き込み権を設定して下さい。

２．Visual Basic6.0で開発する

※レポートライブラリ.NETコントロールは、Visual Basic6.0では使用できません。

2-1．レポートライブラリDLLを使う場合

1）プロジェクトに、定義ファイル（jvrvbdll.bas）を入れます。
  定義ファイルは、サンプルプログラムと同じディレクトリに入っています。

2-2．レポートライブラリOCXを使う場合

1）プロジェクトに、定義ファイル（jvrvbocx.bas）を入れます。
  定義ファイルは、サンプルプログラムと同じディレクトリに入っています。

2）次の手順で、ツールボックスにレポートライブラリを登録します。

  a．メニューバーの「プロジェクト/コンポーネント」を実行し「コンポーネント」ダイアログを表示します。
  b．レポートライブラリOCXの場合、リストボックスで、Jvrlib10X 1.0 ﾀｲﾌﾟﾗｲﾌﾞﾗﾘを選択し、OKボタンを押します。

3）ツールボックスに登録されたレポートライブラリを選択し、フォームに貼り付けます。

2-3．プレビューコントロールを使う場合

1）次の手順で、ツールボックスにプレビューコントロールを登録します。
  a．メニューバーの「プロジェクト/コンポーネント」を実行し「コンポーネント」ダイアログを表示します。
  b．リストボックスで、JVRVW10X 1.0 Type Libraryを選択し、OKボタンを押します。

2）ツールボックスに登録されたプレビューコントロールを選択し、フォームに貼り付けます。


Delphiでの使い方

Delphiでの開発

ジャイブレポートは、Delphiから使用することができます。

アプリケーションは、レポートライブラリを使って作成します。
帳票のプレビューには、プレビューコントロールを使用します。

－レポートライブラリOCX(ActiveXコントロール)
－レポートライブラリDLL
－プレビューコントロール

サンプルや使い方の説明ファイルがジャイブレポートインストールディレクトリ\SampleProgram ディレクトリにあります。

レポートライブラリOCXやプレビューコントロールをDelhiで使用するには、最初にインストールを行います。
Delphi7でのインストール手順を紹介します。

１．メニューバーの「コンポーネント／ActiveXコントロールの取り込み」を実行し、「ActiveXの取り込み」ダイアログを表示します。

２．レポートライブラリOCXをインストールします。
リストボックスで、Jvrlib10X 1.0 ﾀｲﾌﾟﾗｲﾌﾞﾗﾘ(Version 1.0)を選択し、インストールボタンをクリックします。

３．プレビューコントロールをインストールします。
「ActiveXの取り込み」ダイアログのリストボックスで、Jvrvw10X 1.0 Type Library (Version 1.0)を選択し、インストールボタンをクリックします。

注意：

１．レポートライブラリ.NETコントロールは、Delphiでは使用できません。

２．Delphi2007ではActiveXコントロールが読み込めないため、レポートライブラリOCXとプレビューコントロールは使用できません。


Javaでの使い方

Javaでの開発

ジャイブレポートはJavaから使用することができます。

アプリケーションは、レポートライブラリJNIを使って開発します。
レポートライブラリJNIは、Javaネイティブメソッドインターフェース（JNI）仕様のライブラリです。
レポートライブラリJNIは、Windows環境で使用可能です。

－レポートライブラリJNIの概要
－アプリケーション開発
－コーディング上の注意

レポートライブラリJNIは、レポートライブラリDLLとほぼ同じ機能を持っています。
ファンクションの使用方法の詳細はレポートライブラリDLLのリファレンスを参照してください。

サンプルや使い方の説明ファイルがジャイブレポートインストールディレクトリ\SampleProgram ディレクトリにあります。


VB2005/2008/2010(OCX)1

VB2005以降 (OCX)

RDF形式データをプレビューコントロールに設定する例

'印刷を終了します。

Call Jvrlib.End()

'プレビューコントロールにRDFデータを設定します。
Call JiveView.set_DocumentData(Jvrlib.DocumentData)
'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show()


VB2005/2008/2010(DLL)1

VB2005以降 (DLL)

RDF形式データをプレビューコントロールに設定する例

Dim iDocSize As Long

Dim sDocData() As Byte

'印刷を終了します。
ret = jvEndDoc(pid)

'RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
    'RDFデータ取得用バッファを確保します。
    ReDim sDocData(iDocSize)
    'RDFデータを取り出します。
    ret = jvGetDocument(pid, sDocData(0))
Else
    ReDim sDocData(1)
    sDocData(0) = 0
End If

'終了処理を実行します。
ret = jvClose(pid)

'プレビューコントロールにRDFデータを設定します。
Call JiveView.set_DocumentData(Jvrlib.DocumentData)
'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show()


VC#2005/2008/2010(OCX)1

VC#2005以降 (OCX)

RDF形式データをプレビューコントロールに設定する例

//印刷を終了します。
Jvrlib.End();

try
{
    //プレビューコントロールにRDFデータを設定します。
    object obj = Jvrlib.DocumentData;
    JiveView.set_DocumentData(ref obj);
    JiveView.Page = 1;
    JiveView.Show();
}
catch(Exception ex)
{
    jvrvcsocx.MsgBox(0,ex.ToString(),"Error",0);
}


VC#2005/2008/2010(DLL)1

VC#2005以降 (DLL)

RDF形式データをプレビューコントロールに設定する例

int iDocSize;
byte[] sDocData;

//印刷を終了します。
ret = jvrvcsdll.jvEndDoc(pid);
//RDFデータのサイズを取得します。
iDocSize = jvrvcsdll.jvGetLong(pid, jvrvcsdll.JV_DOCUMENT_SIZE);

if ( iDocSize > 0 )
{
    //RDFデータ取得用バッファを確保します。
    sDocData = new byte[iDocSize];
    //RDFデータを取り出します。
    ret = jvrvcsdll.jvGetDocument(pid, sDocData);
}
else
{
    sDocData = new byte[1];
}

//終了処理を実行します。
ret = jvrvcsdll.jvClose(pid);

//プレビューコントロールに描画します。
if (iDocSize > 0)
{
    object obj = (object)sDocData;
    JiveView.set_DocumentData(ref obj); //RDFデータの指定
    JiveView.Page = 1;
    JiveView.Show();
}


VC++2005/2008/2010(OCX)1

VC++2005以降 (OCX)

RDF形式データをプレビューコントロールに設定する例

//印刷を終了します。
Jvrlib->End();

try
{
    //プレビューコントロールにRDFデータを設定します。
    JiveView->set_DocumentData(Jvrlib->DocumentData);
    JiveView->Page = 1;
    JiveView->Show();
}
catch(Exception ^exp)
{
    MessageBox::Show(exp->ToString(), "Error");
}


VC++2005/2008/2010(DLL)1

VC++2005以降 (DLL)

RDF形式データをプレビューコントロールに設定する例

int iDocSize;
Object ^oDocData;

//印刷を終了します。
ret = jvEndDoc(pid);

//RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE);
if ( iDocSize > 0 )
{
    // RDFデータを取得します。
    array<Byte> ^ sDocData = gcnew array<Byte>(iDocSize);
    pin_ptr<Byte> pNative = &sDocData[0];
    ret = jvGetDocument(pid,pNative);
    pNative = nullptr;
    // RDFデータをオブジェクト型に変換します。
    oDocData = safe_cast<Object ^>(sDocData);
}

//終了処理を実行します。
ret = jvClose(pid);

//プレビューコントロールに描画します。
if (iDocSize > 0)
{
    // RDFデータを指定します。
    JiveView->set_DocumentData( oDocData );
    JiveView->Page = 1;
    JiveView->Show();
}


VB6(OCX)1

VB6(OCX)

RDF形式データをプレビューコントロールに設定する例

'印刷を終了します。
Call Jvrlib.End()

'プレビューコントロールにRDFデータを設定します。
JiveView.DocumentData = Jvrlib.DocumentData
'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show


VB6(DLL)1

VB6(DLL)

RDF形式データをプレビューコントロールに設定する例

Dim iDocSize As Long
Dim sDocData() As Byte

'印刷を終了します。
ret = jvEndDoc(pid)

'RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
    'RDFデータ取得用バッファを確保します。
    ReDim sDocData(iDocSize)
    'RDFデータを取り出します。
    ret = jvGetDocument(pid, sDocData(0))
Else
    ReDim sDocData(1)
    sDocData(0) = 0
End If

'終了処理を実行します。
ret = jvClose(pid)

'プレビューコントロールにRDFデータを設定します。
JiveView.DocumentData = sDocData
JiveView.Page = 1
JiveView.Show


DelphiXE(OCX)1

DelphiXE(OCX)

RDF形式データをプレビューコントロールに設定する例

//印刷を終了します。
Jvrlib.EndDoc;

// RDFデータをOleVariant形式で取得します。
oDocData := Jvrlib.DocumentData;

// プレビューコントロールにRDFデータを設定します。
JiveView.ControlInterface.Set_DocumentData(oDocData);
JiveView.Page := 1;
JiveView.Show;


DelphiXE(DLL)1

DelphiXE(DLL)

RDF形式データをプレビューコントロールに設定する例

type
    TByteArray = Array of byte;
var
    iDocSize: Longint;
    oDocData: OleVariant;
    vDocData: Variant;
    baDocData : TByteArray;
begin
    //印刷を終了します。
    ret := jvEndDoc(pid);

    //RDFデータのサイズを取得します。
    iDocSize := jvGetLong(pid, JV_DOCUMENT_SIZE);
    if iDocSize > 0 then
    begin
        // RDFデータを取得します。
        SetLength(baDocData, iDocSize);
        jvGetDocument(pid,baDocData[0]);
        // Variant型に変換します。
        DynArrayToVariant(vDocData,baDocData, TypeInfo(TByteArray));
        // さらにOleVariant型に変換します。
        oDocData := vDocData;
    end;

    //終了処理を実行します。
    jvClose(pid);

    //プレビューコントロールに描画します。
    if iDocSize > 0 then
    begin
        JiveView.ControlInterface.Set_DocumentData(oDocData);
        JiveView.Page := 1;
        JiveView.Show;
    end;


VB2005/2008/2010(OCX)2

VB2005以降 (OCX)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

'印刷を終了します。
Call Jvrlib.End()

'プレビューコントロールにRDFデータを設定します。
Call JiveView.set_DocumentData(Jvrlib.DocumentData)

'ページ番号と総ページ数を全ページに入れます。
For i = 1 To JiveView.PageCount
    JiveView.Page = i
    Call JiveView.set_FieldData("ページ番号", CStr(i))
    Call JiveView.set_FieldData("総ページ数", CStr(JiveView.PageCount))
Next i

'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show()


VB2005/2008/2010(DLL)2

VB2005以降 (DLL)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

Dim iDocSize As Long
Dim sDocData() As Byte

'印刷を終了します。
ret = jvEndDoc(pid)
'RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
    'RDFデータ取得用バッファを確保します。
    ReDim sDocData(iDocSize)
    'RDFデータを取り出します。
    ret = jvGetDocument(pid, sDocData(0))
Else
    ReDim sDocData(1)
    sDocData(0) = 0
End If
'終了処理を実行します。
ret = jvClose(pid)

'プレビューコントロールにRDFデータを設定します。
Call JiveView.set_DocumentData(CObj(sDocData))

'ページ番号と総ページ数を全ページに入れます。
For i = 1 To JiveView.PageCount
    JiveView.Page = i
    Call JiveView.set_FieldData("ページ番号", CStr(i))
    Call JiveView.set_FieldData("総ページ数", CStr(JiveView.PageCount))
Next i

'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show()


VC#2005/2008/2010(OCX)2

VC#2005以降 (OCX)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

//印刷を終了します。
Jvrlib.End();

try
{
    //プレビューコントロールにRDFデータを設定します。
    object obj = Jvrlib.DocumentData;
    JiveView.set_DocumentData(ref obj);

    //ページ番号と総ページ数を全ページに入れます。
    for ( i=1 ; i<= JiveView.PageCount; i++ )
    {
        JiveView.Page = i;
        JiveView.set_FieldData("ページ番号", i.ToString());
        JiveView.set_FieldData("総ページ数", JiveView.PageCount.ToString());
    }

    JiveView.Page = 1;
    JiveView.Show();
}
catch(Exception ex)
{
    jvrvcsocx.MsgBox(0,ex.ToString(),"Error",0);
}


VC#2005/2008/2010(DLL)2

VC#2005以降 (DLL)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

int iDocSize;
byte[] sDocData;

//印刷を終了します。
ret = jvrvcsdll.jvEndDoc(pid);
//RDFデータのサイズを取得します。
iDocSize = jvrvcsdll.jvGetLong(pid, jvrvcsdll.JV_DOCUMENT_SIZE);

if ( iDocSize > 0 )
{
    //RDFデータ取得用バッファを確保します。
    sDocData = new byte[iDocSize];
    //RDFデータを取り出します。
    ret = jvrvcsdll.jvGetDocument(pid, sDocData);
}
else
{
    sDocData = new byte[1];
}

//終了処理を実行します。
ret = jvrvcsdll.jvClose(pid);

//プレビューコントロールに描画します。
if (iDocSize > 0)
{
    object obj = (object)sDocData;
    JiveView.set_DocumentData(ref obj); //RDFデータを指定します。

    //ページ番号と総ページ数を全ページに入れます。
    for (i = 1; i <= JiveView.PageCount; i++)
    {
        JiveView.Page = i;
        JiveView.set_FieldData("ページ番号", i.ToString());
        JiveView.set_FieldData("総ページ数", JiveView.PageCount.ToString());
    }

    JiveView.Page = 1;
    JiveView.Show();
}


VC++2005/2008/2010(OCX)2

VC++2005以降 (OCX)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

//印刷を終了します。
Jvrlib->End();

try
{
    //プレビューコントロールにRDFデータを設定します。
    JiveView->set_DocumentData(Jvrlib->DocumentData);

    //ページ番号と総ページ数を全ページに入れます。
    for ( i=1 ; i<= JiveView->PageCount; i++ )
    {
        JiveView->Page = i;
        JiveView->set_FieldData("ページ番号", i.ToString("#0"));
        JiveView->set_FieldData("総ページ数", JiveView->PageCount.ToString("#0"));
    }

    JiveView->Page = 1;
    JiveView->Show();
}
catch(Exception ^exp)
{
    MessageBox::Show(exp->ToString(), "Error");
}


VC++2005/2008/2010(DLL)2

VC++2005以降 (DLL)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

int iDocSize;
Object ^oDocData;

//印刷を終了します。
ret = jvEndDoc(pid);

//RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE);
if ( iDocSize > 0 )
{
    // RDFデータを取得します。
    array<Byte> ^ sDocData = gcnew array<Byte>(iDocSize);
    pin_ptr<Byte> pNative = &sDocData[0];
    ret = jvGetDocument(pid,pNative);
    pNative = nullptr;
    // RDFデータをオブジェクト型に変換します。
    oDocData = safe_cast<Object ^>(sDocData);
}

//終了処理を実行します。
ret = jvClose(pid);

//プレビューコントロールに描画します。
if (iDocSize > 0)
{
    // RDFデータを指定します。
    JiveView->set_DocumentData( oDocData );

    //ページ番号と総ページ数を全ページに入れます。
    for ( i=1 ; i<= JiveView->PageCount; i++ )
    {
        JiveView->Page = i;
        JiveView->set_FieldData("ページ番号", i.ToString("#0"));
        JiveView->set_FieldData("総ページ数", JiveView->PageCount.ToString("#0"));
    }

    JiveView->Page = 1;
    JiveView->Show();
}


VB6(OCX)2

VB6(OCX)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

'プレビューコントロールにRDFデータを設定します。
JiveView.DocumentData = Jvrlib.DocumentData

'ページ番号と総ページ数を全ページに入れます。
For i = 1 To JiveView.PageCount
    JiveView.Page = i
    JiveView.FieldData("ページ番号") = CStr(i)
    JiveView.FieldData("総ページ数") = CStr(JiveView.PageCount)
Next i

'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show


VB6(DLL)2

VB6(DLL)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

Dim iDocSize As Long
Dim sDocData() As Byte

'印刷を終了します。
ret = jvEndDoc(pid)

'RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
    'RDFデータ取得用バッファを確保します。
    ReDim sDocData(iDocSize)
    'RDFデータを取り出します。
    ret = jvGetDocument(pid, sDocData(0))
Else
    ReDim sDocData(1)
    sDocData(0) = 0
End If

'終了処理を実行します。
ret = jvClose(pid)

'プレビューコントロールにRDFデータを設定します。
JiveView.DocumentData = sDocData

'ページ番号と総ページ数を全ページに入れます。
For i = 1 To JiveView.PageCount
    JiveView.Page = i
    JiveView.FieldData("ページ番号") = CStr(i)
    JiveView.FieldData("総ページ数") = CStr(JiveView.PageCount)
Next i

JiveView.Page = 1
JiveView.Show


DelphiXE(OCX)2

DelphiXE(OCX)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

//印刷を終了します。
Jvrlib.EndDoc;

// RDFデータをOleVariant形式で取得します。
oDocData := Jvrlib.DocumentData;

//プレビューコントロールにRDFデータを設定します。
JiveView.ControlInterface.Set_DocumentData(oDocData);

//ページ番号と総ページ数を全ページに入れます。
lPageNo := JiveView.PageCount;
for i:=1 to lPageNo do
begin
    JiveView.Page := i;
    JiveView.ControlInterface.Set_FieldData('ページ番号',WideString(IntToStr(i)));
    JiveView.ControlInterface.Set_FieldData('総ページ数',WideString(IntToStr(lPageNo)));
end;

JiveView.Page := 1;
JiveView.Show;


DelphiXE(DLL)2

DelphiXE(DLL)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

type
    TByteArray = Array of byte;
var
    iDocSize: Longint;
    oDocData: OleVariant;
    vDocData: Variant;
    baDocData : TByteArray;
begin

    //印刷を終了します。
    ret := jvEndDoc(pid);

    //RDFデータのサイズを取得します。
    iDocSize := jvGetLong(pid, JV_DOCUMENT_SIZE);
    if iDocSize > 0 then
    begin
        // RDFデータを取得します。
        SetLength(baDocData, iDocSize);
        jvGetDocument(pid,baDocData[0]);
        // Variant型に変換します。
        DynArrayToVariant(vDocData,baDocData, TypeInfo(TByteArray));
        // さらにOleVariant型に変換します。
        oDocData := vDocData;
    end;

    //終了処理を実行します。
    jvClose(pid);

    //プレビューコントロールに描画します。
    if iDocSize > 0 then
    begin
        //プレビューコントロールにRDFデータを設定します。
        JiveView.ControlInterface.Set_DocumentData(oDocData);

        //ページ番号と総ページ数を全ページに入れます。
        for i:=1 to lPageNo do
        begin
            JiveView.Page := i;
            JiveView.ControlInterface.Set_FieldData('ページ番号',PAnsiChar(AnsiString(IntToStr(i))));
            JiveView.ControlInterface.Set_FieldData('総ページ数',PAnsiChar(AnsiString(IntToStr(lPageNo))));
        end;

        JiveView.Page := 1;
        JiveView.Show;
    end;


VB2005/2008/2010(OCX)3

VB2005以降 (OCX)

イメージをデータ形式で設定する例

Dim imgDpi&, backmode&, imgFileName$
Dim imageLength As Long
Dim imageData() As Byte
Dim readSize As Long

'イメージファイルをByte配列に読み込みます。
Dim fs As New FileStream( imgFileName, FileMode.Open, FileAccess.Read)
imageLength = CInt(fs.Length) ' ファイルのサイズ
ReDim imageData(imageLength - 1) ' データ格納用配列
readSize = fs.Read(imageData, 0, imageLength)
fs.Close()

'イメージデータを描画します。
Call Jvrlib.DrawImageData(10000, 11000, 0, 0, imgDpi, backmode, imageLength, CObj(imageData))


VB2005/2008/2010(DLL)3

VB2005以降 (DLL)

イメージをデータ形式で設定する例

Dim ImageFile As String
Dim imageLength As Long
Dim imageData() As Byte
Dim readSize As Long

'イメージファイルをByte配列に読み込みます。
Dim fs As New FileStream(ImageFile, FileMode.Open, FileAccess.Read)
imageLength = CInt(fs.Length) ' ファイルのサイズ
ReDim imageData(imageLength - 1) ' データ格納用配列
readSize = fs.Read(imageData, 0, imageLength)
fs.Close()

'イメージデータを描画します。
ret = jvSetFieldImageData(pid, "IMAGE_2", imageLength, imageData(0))


VC#2005/2008/2010(OCX)3

VC#2005以降 (OCX)

イメージをデータ形式で設定する例

string ImageFile;

//イメージファイルを読み込みます。
FileStream fs = new FileStream(ImageFile, FileMode.Open, FileAccess.Read);
int imageLength = (int)fs.Length;
int readSize;
byte[] imageData = new byte[imageLength];
readSize = fs.Read(imageData, 0, imageLength);
fs.Close();
fs.Dispose();

//イメージデータを描画します。
object obj = (object)imageData;
Jvrlib.SetFieldImageData("IMAGE_2", imageLength, ref obj);


VC#2005/2008/2010(DLL)3

VC#2005以降 (DLL)

イメージをデータ形式で設定する例

string ImageFile;

//イメージファイルを読み込みます。
FileStream fs = new FileStream(ImageFile, FileMode.Open, FileAccess.Read);
int imageLength = (int)fs.Length;
int readSize;
byte[] imageData = new byte[imageLength];
readSize = fs.Read(imageData, 0, imageLength);
fs.Close();
fs.Dispose();

//イメージデータを描画します。
ret = jvrvcsdll.jvSetFieldImageData(pid, "IMAGE_2", imageLength, imageData);


VC++2005/2008/2010(OCX)3

VC++2005以降 (OCX)

イメージをデータ形式で設定する例

ImageFile = String::Concat(Jvrlib->ImagePath,L"watch.dib" );
FileStream^ fs = gcnew FileStream(ImageFile,FileMode::Open, FileAccess::Read, FileShare::Read );
int imageLength = (int)fs->Length;
int readSize;
array<Byte> ^ imageData = gcnew array<Byte>(imageLength);
readSize = fs->Read(imageData, 0, imageLength);
fs->Close();

// イメージデータをオブジェクト型に変換します。
Object ^oImageData;
oImageData = safe_cast<Object ^>(imageData);
//イメージデータを描画します。
Jvrlib->SetFieldImageData(L"IMAGE_2", imageLength,oImageData);


VC++2005/2008/2010(DLL)3

VC++2005以降 (DLL)

イメージをデータ形式で設定する例

String ^ImageFile;
FileStream^ fs = gcnew FileStream(ImageFile,FileMode::Open, FileAccess::Read, FileShare::Read );
int imageLength = (int)fs->Length;
int readSize;
array<Byte> ^ imageData = gcnew array<Byte>(imageLength);
readSize = fs->Read(imageData, 0, imageLength);
fs->Close();
pin_ptr<Byte> pNative = &imageData[0];

//イメージデータを描画します。
ret = jvSetFieldImageData(pid, "IMAGE_2", imageLength, pNative);
pNative = nullptr;


VB6(OCX)3

VB6(OCX)

イメージをデータ形式で設定する例

Dim ImageFile As String
Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte

'イメージファイルをByte配列に読み込みます。
fileNo = FreeFile 'ファイル番号取得
Open ImageFile For Binary As #fileNo 'イメージファイルオープン
imageLength = FileLen(ImageFile)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo

'イメージデータを描画します。
Call Jvrlib.SetFieldImageData("IMAGE_2", imageLength, imageData)


VB6(DLL)3

VB6(DLL)

イメージをデータ形式で設定する例

Dim ImageFile As String
Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte

'イメージファイルをByte配列に読み込みます。
fileNo = FreeFile 'ファイル番号取得
Open ImageFile For Binary As #fileNo 'イメージファイルオープン
imageLength = FileLen(ImageFile)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo

'イメージデータを描画します。
ret = jvSetFieldImageData(pid, "IMAGE_2", imageLength, imageData(0))


DelphiXE(OCX)3

DelphiXE(OCX)

イメージをデータ形式で設定する例

type
    TByteArray = Array of byte;
var
    imageLength: Longint;
    F: TFileStream;
    baImageData: TByteArray;
    ImageFile: array[0..255] of Char;
begin
    F:=TFileStream.Create(String(ImageFile),fmOpenRead);
    imageLength := F.Size;
    SetLength(baImageData, imageLength);
    F.ReadBuffer(Pointer(baImageData)^,imageLength);
    F.Free;

    // Variant型に変換します。
    DynArrayToVariant(vImageData,@baImageData[0], TypeInfo(TByteArray));
    // さらにOleVariant型に変換します。
    oImageData := vImageData;
    //イメージデータを描画します。
    Jvrlib.SetFieldImageData('IMAGE_2', imageLength,oImageData);


DelphiXE(DLL)3

DelphiXE(DLL)

イメージをデータ形式で設定する例

type
    TByteArray = Array of byte;
var
    ImageFile: array[0..255] of AnsiChar;
    imageLength: Longint;
    F: TFileStream;
    baImageData: TByteArray;
begin
    F:=TFileStream.Create(String(ImageFile),fmOpenRead);
    imageLength := F.Size;
    SetLength(baImageData, imageLength);
    F.ReadBuffer(Pointer(baImageData)^,imageLength);
    F.Free;

    //イメージデータを描画します。
    ret := jvSetFieldImageData(pid, 'IMAGE_2', imageLength,baImageData);


JAVA(JNI)3

JAVA(JNI)

イメージをデータ形式で設定する例

try

{
    FileInputStream fis = new FileInputStream(sImgFileName);
    int filelen = fis.available();
    byte[] imagedata = new byte[filelen];
    fis.read(imagedata,0,filelen);
    fis.close();
    ret = Jvalib.jvSetFieldImageData(pid, "IMAGE_2", filelen,imagedata);
    if ( ret != 0 )
    {
        //エラー表示
    }
}
catch(IOException ex2)
{
    //エラー表示
}


VB2005/2008/2010(OCX)4

VB2005以降 (OCX)

改ページ要求エラーを処理する例

'エラー処理を設定します。
On Error Resume Next

'セクションを描画します。
Call Jvrlib.DrawSection()

'セクションを描画した時に改ページが要求された場合、改ページします。
If Err.Number = JV_OCXERR_REQ_ENDPAGE Then
    Call Jvrlib.NewPage()
End If


VC#2005/2008/2010(OCX)4

VC#2005以降 (OCX)

改ページ要求エラーを処理する例

try
{
    Jvrlib.DrawSection();
}
catch (System.Runtime.InteropServices.COMException ex)
{
    //改ページが要求された場合、改ページします。
    if ((ex.ErrorCode & 0x0000FFFF) == jvrvcsocx.JV_OCXERR_REQ_ENDPAGE)
    {
        Jvrlib.NewPage();
    }
}


VC++2005/2008/2010(OCX)4

VC++2005以降 (OCX)

改ページ要求エラーを処理する例

try
{
    Jvrlib->DrawSection();
}
catch (System::Runtime::InteropServices::COMException ^ex)
{
    //改ページが要求された場合、改ページします。
    if ((ex->ErrorCode & 0x0000FFFF) == JV_OCXERR_REQ_ENDPAGE)
    {
        Jvrlib->NewPage();
    }
}


VB6(OCX)4

VB6(OCX)

改ページ要求エラーを処理する例

'エラー処理を設定します。
On Error Resume Next

'セクションを描画します。
Call Jvrlib.DrawSection

'セクションを描画した時に改ページが要求された場合、改ページします。
If Err.Number = JV_OCXERR_REQ_ENDPAGE Then
    Call Jvrlib.NewPage
End If


DelphiXE(OCX)4

DelphiXE(OCX)

改ページ要求エラーを処理する例

try
    Jvrlib.DrawSection;
except
    on E: Exception do // 改ページが要求された場合、改ページします。
        if EOleException(E).ErrorCode and $ffff = JV_OCXERR_REQ_ENDPAGE then
        begin
            Jvrlib.NewPage();
        end;
end;


VC#2005/2008/2010(OCX)5

VC#2005以降 (OCX)

フィールドオーバーフローエラーを処理する例

try
{
    Jvrlib.SetFieldText("商品名", sShohinName);
}
catch (System.Runtime.InteropServices.COMException ex)
{
    // フィールドオーバーフロー以外はメッセージを表示します。
    if ( (ex.ErrorCode & 0x0000FFFF) != jvrvcsocx.JV_OCXERR_FIELDOVERFLOW)
    {
        jvrvcsocx.MsgBox(0, "商品名 フィールド", " Error", 0);
    }
}


VC++2005/2008/2010(OCX)5

VC++2005以降 (OCX)

フィールドオーバーフローエラーを処理する例

try
{
    Jvrlib->SetFieldText(L"商品名", sShohinName);
}
catch (System::Runtime::InteropServices::COMException ^ex)
{
    // フィールドオーバーフロー以外はメッセージを表示します。
    if ( (ex->ErrorCode & 0x0000FFFF) != JV_OCXERR_FIELDOVERFLOW)
    {
        MessageBox::Show("商品名 フィールド", "Error " );
    }
}


DelphiXE(OCX)5

DelphiXE(OCX)

フィールドオーバーフローエラーを処理する例

try
    Jvrlib.SetFieldText('商品名', sShohinName);
except
    on E: Exception do // フィールドオーバーフロー以外はメッセージを表示する
        if EOleException(E).ErrorCode and $ffff <> JV_OCXERR_FIELDOVERFLOW then
            ShowMessage(E.ToString);
end;


Visual_BasicNETでの使い方x64.htm

Visual Studio での開発

アプリケーション開発の基本部分は、X86製品での 「Visual Basic .NETでの開発」を参照してください。
ここでは、アプリケーションを64ビットで動かす方法を中心に解説します。

１．プロフェッショナルX(64) について

プロフェッショナル(X64)には、64ビットと32ビットの両方のコントロールが入っています。
プロフェッショナル(X64)をインストールすると、次のようにインストールが行われます。

--\Windows\System32ディレクトリに、x64対応の各種コントロール
--\Windows\SysWOW64ディレクトリに、x86対応の各種コントロール

Windowsのx64Editionでは、64ビットアプリケーションは、WindowsのSystem32ディレクトリのコントロールを使って動きます。
32ビットアプリケーションは、WindowsのSysWOW64ディレクトリのコントロールを使って動きます。

32ビットアプリケーションを開発する場合は、X86製品での 「Visual Basic .NETでの開発」を参照してください。

２．アプリケーションを64ビットにする

次の手順で、アプリケーションを64ビットで動かすように変更します。

1）ジャイブレポートのコントロールが貼り付けられたフォームをすべて閉じます。
2）下記の2-1．の手順で、ターゲットCPUをx64に変更し、リビルドします。
    VisualC++の場合には、ソリューションプラットフォームをx64に変更し、リビルドします。

3）ターゲットCPUをx64に変更すると、レポートライブラリOCX、レポートライブラリDLL、プレビューコントロールは、自動的にx64対応のものに変わります。リビルドして実行すると、アプリケーションは64ビットで動きます。
レポートライブラリ.NETコントロールを使っている場合は、自動的に変わらないため、下記2-2．の作業が必要です。

  2-1．ターゲットCPUの変更方法

  プロジェクトのターゲットCPUを変更する方法は、開発環境によって違います。

  [VisualBasic 2005/2008/2010 の場合]
  1．メニューバーで、プロジェクト/XXXXXのプロパティを押します。
  2．コンパイル画面の「詳細コンパイルオプション」ボタンを押し、ビルドの詳細設定画面を表示します。
  3．ターゲットCPUボタンを押し、「x86、AnyCPU、x64」から選択します。
  4．64ビットにする時は「x64」を選択します。

  ［VisualBasic 2012以降の場合
  1．メニューバーで、プロジェクト/XXXXXのプロパティを押します。
  2．コンパイル画面で、対象のCPUに「x86,AnyCPU,x64」から選択します。
  3．64ビットにする時は「x64」を選択します。

  [VisualC# 2005以降の場合]
  1．メニューバーで、プロジェクト/XXXXXのプロパティを押します。
  2．ビルドのプラットフォームターゲットボタンを押し、「x86、AnyCPU、x64」から選択します。
  3．64ビットにする時は「x64」を選択します。

  [VisualC++ 2005以降の場合]
  1．メニューバーで、ビルド/構成マネージャを押します。
  2．デフォルトのソリューションプラットフォームはWin32になっています。（Win32はx86と同じです）
  3．ソリューションプラットフォームをx64にし、新しいソリューションプラットフォームを作成して下さい。

  2-2．レポートライブラリ.NETコントロールを64ビットに変える

  レポートライブラリ.NETコントロールをx86対応からx64対応に変える方法は、2通りあります。
  以下のどちらかの方法でコントロールを変えてください。

  1）現在参照しているx86対応のコントロールにx64対応のコントロールを上書きコピーする方法
  2）コントロールの参照設定をx64対応のコントロールのある場所に変更する方法

  レポートライブラリ.Netコントロールのインストール先はこちらで確認してください。
  －レポートライブラリ.NETコントロールのインストール先

３．64ビットアプリケーションを実行する

64ビットアプリケーションは、Visual Studioのデバッガでは起動できません。
ビルドが完了したら、直接、実行ファイルを起動してください。

４．注意事項

ターゲットCPUをx64にしたままVisual Studioを終了すると、Visual Studioは、次回もX64の状態で起動します。
この状態で、ジャイブレポートのコントロールが貼り付けられたフォームを開くとエラーになります。
エラーが起きたら、次の手順でエラー処理を行ってください。

1）ジャイブレポートのコントロールが貼り付けられたフォームを閉じます。
2）ターゲットCPUを「x86」に変更し、保存します。
3）Visual Studioを終了し、再起動します。

５．その他

プロフェッショナル(X64)には、2種類のプレビューコントロール（x86対応とx64対応）が入っています。
環境に合わせてどちらかを使用します。

－レポートライブラリOCX(ActiveXコントロール)
－ レポートライブラリ.NETコントロール
－レポートライブラリDLL
－プレビューコントロール

サンプルや使い方の説明ファイルがジャイブレポートインストールディレクトリ\SampleProgram ディレクトリにあります。
「X86製品での開発／各開発環境での使い方／Visual Basicでの開発」 も参考にしてください。


Javaでの使い方X64.htm

Javaでの開発

ジャイブレポートはJavaから使用することができます。

Javaアプリケーションは、レポートライブラリJNIを使って開発します。
レポートライブラリJNIは、Javaネイティブメソッドインターフェース（JNI）仕様のライブラリです。
レポートライブラリJNIは、Windows環境で使用可能です。

－ レポートライブラリJNIの概要
－アプリケーション開発
－コーディング上の注意

レポートライブラリJNIは、レポートライブラリDLLとほぼ同じ機能を持っています。
ファンクションの使用方法の詳細はレポートライブラリDLLのリファレンスを参照してください。

サンプルや使い方の説明ファイルがジャイブレポートインストールディレクトリ\SampleProgram ディレクトリにあります。


VB2010(DLL)1

VB2005以降 (DLL)

RDF形式データをプレビューコントロールに設定する例

Dim iDocSize As Long

Dim sDocData() As Byte

'印刷を終了します。
ret = jvEndDoc(pid)

'RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
    'RDFデータ取得用バッファを確保します。
    ReDim sDocData(iDocSize)
    'RDFデータを取り出します。
    ret = jvGetDocument(pid, sDocData(0))
Else
    ReDim sDocData(1)
    sDocData(0) = 0
End If

'終了処理を実行します。
ret = jvClose(pid)

'プレビューコントロールにRDFデータを設定します。
Call JiveView.set_DocumentData(Jvrlib.DocumentData)
'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show()


VB2010(DLL)2

VB2005以降 (DLL)

RDF形式データ設定後、フィールドの値を変更する例（帳票にページ番号を入れる）

Dim iDocSize As Long
Dim sDocData() As Byte

'印刷を終了します。
ret = jvEndDoc(pid)
'RDFデータのサイズを取得します。
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
    'RDFデータ取得用バッファを確保します。
    ReDim sDocData(iDocSize)
    'RDFデータを取り出します。
    ret = jvGetDocument(pid, sDocData(0))
Else
    ReDim sDocData(1)
    sDocData(0) = 0
End If
'終了処理を実行します。
ret = jvClose(pid)

'プレビューコントロールにRDFデータを設定します。
Call JiveView.set_DocumentData(CObj(sDocData))

'ページ番号と総ページ数を全ページに入れます。
For i = 1 To JiveView.PageCount
    JiveView.Page = i
    Call JiveView.set_FieldData("ページ番号", CStr(i))
    Call JiveView.set_FieldData("総ページ数", CStr(JiveView.PageCount))
Next i

'表示するページを指定します。
JiveView.Page = 1
'表示します。
JiveView.Show()


VB2010(DLL)3

VB2005以降 (DLL)

イメージをデータ形式で設定する例

Dim ImageFile As String
Dim imageLength As Long
Dim imageData() As Byte
Dim readSize As Long

'イメージファイルをByte配列に読み込みます。
Dim fs As New FileStream(ImageFile, FileMode.Open, FileAccess.Read)
imageLength = CInt(fs.Length) ' ファイルのサイズ
ReDim imageData(imageLength - 1) ' データ格納用配列
readSize = fs.Read(imageData, 0, imageLength)
fs.Close()

'イメージデータを描画します。
ret = jvSetFieldImageData(pid, "IMAGE_2", imageLength, imageData(0))


可変フォーム印刷アプリケーションの作成

可変フォーム印刷の概要

出力するデータによって帳票のレイアウトが変わる場合、可変フォームを使ってデータに合った帳票を作成できます。

１．可変フォームの作成

まず、レポートエディタを使って可変フォームを作成します。
可変フォームでは、帳票のフォームを用途ごとに分割し、それぞれを別のセクションとして作成します。

－レポートエディタで可変フォームを作る

＜例＞見積書の可変フォーム

２．可変フォームの印刷

可変フォームを使った帳票を印刷するには、専用のアプリケーションが必要です。
アプリケーションは、レポートライブラリを使って開発します。 可変フォームはレポートエディタから印刷できません。

アプリケーションは、用紙の先頭から、セクションを一つずつ描画するようにプログラミングします。
描画するセクションの順番は、自由に決めることができます。
見積書例の「明細セクション」のように、同じレイアウトでデータを繰り返し印刷する場合は、同じセクションを繰り返し使います。

用紙の下までセクションを描画したら、ページの最後に配置するセクションを描画して改ページします。
新しいページになったら、ページの先頭に配置するセクションを描画し、印刷を続けます。

改ページはプログラムの中で制御します。
用紙が残り少なくなったら、次に出力するセクションが残りの描画領域内に入るかどうかを判定します。
描画領域内に入らない時は、入るサイズのセクションに変更するか、または改ページをします。
このようにして、最後のページまでセクションを描画していきます。

３．可変フォーム印刷用の機能

レポートライブラリには、セクションを管理する機能が揃っています。
レポートライブラリを使えば、可変フォームの印刷プログラムを簡単に作成することができます。

○セクションを指定する

レポートライブラリOCX／レポートライブラリ.NETコントロール | SectionKeyプロパティ
レポートライブラリDLL／レポートライブラリJNI | jvSetSectionファンクション

○セクションを描画する

レポートライブラリOCX／レポートライブラリ.NETコントロール | DrawSectionメソッド
レポートライブラリDLL／レポートライブラリJNI | jvDrawSectionファンクション

○セクションの高さを取得する

レポートライブラリOCX／レポートライブラリ.NETコントロール | SectionHeightプロパティ
レポートライブラリDLL／レポートライブラリJNI | jvGetLongファンクション(JV_SECTION_HEIGHT)

○描画領域を取得する

レポートライブラリOCX／レポートライブラリ.NETコントロール | DrawHeight プロパティ、DrawWidthプロパティ
レポートライブラリDLL／レポートライブラリJNI | jvGetLongファンクション（JV_DRAW_HEIGHT/JV_DRAW_WIDTH）

○現在の描画位置を取得する
レポートライブラリOCX／レポートライブラリ.NETコントロール | CurrentTopプロパティ
レポートライブラリDLL／レポートライブラリJNI | jvGetLongファンクション（JV_CURRENT_TOP）

－実際のプログラム例


可変フォームサンプルプログラム

レポートライブラリOCXを使って可変フォームを印刷するVisual Basicサンプルプログラムを紹介します。

Private Sub XXXX_Click()

Dim DrawHeight As Long
Dim HeaderHeight As Long
Dim FooterHeight As Long
Dim PageFooterHeight As Long
Dim MeisaiHeight As Long
Dim ipage As Integer
Dim fMeisaiOut As Boolean
Dim lPageSum As Long
Dim lTotalSum As Long
Dim lKingaku As Long

'可変フォームを指定します
Jvrlib.FormName = "C:\可変フォーム.jfm"

'印刷を開始します
Call Jvrlib.Start

On Error GoTo SampleError

'各セクションの高さを取得します
Jvrlib.SectionKey = "ヘッダー"
HeaderHeight = Jvrlib.SectionHeight

Jvrlib.SectionKey = "フッター"
FooterHeight = Jvrlib.SectionHeight

Jvrlib.SectionKey = "ページフッター"
PageFooterHeight = Jvrlib.SectionHeight

Jvrlib.SectionKey = "明細"
MeisaiHeight = Jvrlib.SectionHeight

ipage = 1

'ヘッダーセクションを指定します
Jvrlib.SectionKey = "ヘッダー"

'ヘッダーセクションのテキストフィールドﾞに値を設定します
Call Jvrlib.SetFieldText("ページ", CStr(ipage) & "page")

'セクションを描画すると、改ページ要求の時もエラーが発生します
'そこで、改ページ要求エラーが発生しても処理を続行するように設定します
On Error Resume Next

ヘッダーセクションを描画します
Call Jvrlib.DrawSection
If Err <> 0 Then
  'ここでは改ページ要求(1131)は発生しないため、エラー処理のみ行います
  MsgBox "DrawSection Error ヘッダー" + CStr(ret)
  GoTo Error_Trap
End If

lTotalSum = 100
lPageSum = lTotalSum
fMeisaiOut = False

'明細セクションを指定します
Jvrlib.SectionKey = "明細"

'データをすべて印刷するまで明細セクションを繰り返し描画します
'このサンプルでは、1データにつき1行の明細セクションを使うものとします

For i = 1 To n

  '明細セクションのテキストフィールドに値を設定します
  lKingaku = x * 1.05　　'←これが実際に描画するデータだとします
  lPageSum = lPageSum + lKingaku
  lTotalSum = lTotalSum + lKingaku
  Call Jvrlib.SetFieldText("金額", CStr(lKingaku) & "円")

  '明細セクションを描画します
  Call Jvrlib.DrawSection

  If Err <> 0 Then
    If Err = 1131 Then　　'←1131は「DrawSectionの改ページ要求」です
      '戻り値「改ページ要求(1131)」を使って、ここで改ページの処理を行うこともできます
      'このサンプルでは改ページの判定に「1131」を使わないため、ここでの処理はありません
    Else
      MsgBox "DrawSection Error 明細 " + Error(Err)
      GoTo Error_Trap
    End If
  End If

  fMeisaiOut = True

  'このサンプルの改ページ判定は「描画領域、現在位置、セクション高」を使って行います
  'ここでは、明細セクションを描画したタイミングで、改ページの必要性を判定します

  '各ページの最後には必ずページフッターを描画するものとし、
  '「現在位置＋明細セクションの高さ＋ページフッターの高さ」が描画領域の高さを超える時は
  '次の明細セクションは描画できないものと判断し、ページフッターを描画して改ページします

  If Jvrlib.CurrentTop + MeisaiHeight + PageFooterHeight > Jvrlib.DrawHeight Then

    'ページフッターセクションを指定します
    Jvrlib.SectionKey = "ページフッター"

    'ページフッターセクションのテキストフィールドに値を設定します
    Call Jvrlib.SetFieldText("ページ合計", CStr(lPageSum) & "円")

    'ページフッタセクションを描画します
    Call Jvrlib.DrawSection

    '改ページします
    Jvrlib.NewPage

    'ページ毎の変数をクリアします
    lPageSum = 0
    fMeisaiOut = False

    '新しいページのためのヘッダーセクションを描画します
    ipage = ipage + 1
    Jvrlib.SectionKey = "ヘッダー"
    Call Jvrlib.SetFieldText("ページ", CStr(ipage) & "page")
    Call Jvrlib.DrawSection

    'セクションをヘッダーセクションから明細セクションへ戻します
    Jvrlib.SectionKey = "明細"

  End If

Next i

'すべてのデータを描画したら、最後の処理を行います（※注意参照）

'明細セクションが１行以上描画されている場合には、ページフッターを描画します
If fMeisaiOut = True Then
  Jvrlib.SectionKey = "ページフッター"
  Call Jvrlib.SetFieldText("ページ合計", CStr(lPageSum) & "円")
  Call Jvrlib.DrawSection
End If

'最後のページにフッターセクションを描画します
Jvrlib.SectionKey = "フッター"
Call Jvrlib.SetFieldText("総合計", CStr(lTotalSum) & "円")
Call Jvrlib.DrawSection

'改ページします
Jvrlib.NewPage

'レポートライブラリの終了処理を行います
Jvrlib.End

On Error GoTo 0
Exit Sub

SampleError:
  'クローズ
  Jvrlib.End
  On Error GoTo 0
  Exit Sub
Error_Trap:
  MsgBox CStr(Jvrlib.LastDllError)
End Sub

※注意
このプログラムはサンプルのため、処理が簡素化されています。
きめ細かなエラー処理、ループ終了後にフッターセクションが描画可能かどうかの判定、データ量によって最終ページにヘッダーとフッターだけが描画されることへの対応、などのきめ細かな処理はすべて省かれています。


ユーザー定義サイズの印刷

不定形用紙の印刷

不定形用紙（ユーザー定義サイズ）を印刷するアプリケーションは次の手順で作成します。

１．レポートエディタで帳票フォーム作成

(1) レポートエディタの環境設定画面でユーザー定義サイズの用紙を作成します。
(2) 用紙サイズに(1)で作成したユーザー定義サイズを選択します。
(3) 図形やフィールドを貼り付け帳票フォームを完成させます。

２．ユーザー定義サイズ印刷のための環境整備

(1) 印刷を実行するPCで、次の手順でユーザー定義サイズの用紙を作成します。
①コントロールパネルでプリンタの画面を開きます。
②「ファイル／サーバーのプロパティ」でプリントサーバーのプロパティ画面を開きます。
③用紙タブで「新しい用紙を作成する」をクリックします。
④ユーザー定義サイズの寸法を入力し「用紙の保存」ボタンで用紙を保存します。
ログインユーザーに用紙を作成する権限がない場合は用紙を作成できません。権限を設定するか、Administrator等の権限があるユーザーでログインしてください。

(2) (1)で作成した用紙を印刷できるプリンタドライバをインストールします。

３．レポートライブラリを使ってアプリケーション開発

ユーザー定義サイズの用紙を印刷する時には、プログラムにプリンタドライバを設定するコードを記述します。
プリンタドライバの設定には次の機能を使います。

レポートライブラリOCX、レポートライブラリ.NETコントロール： SetPrinter、PrinterDevMode、PrinterName
－コーディング

レポートライブラリDLL、レポートライブラリJNI： jvGetPrinterDevMode
－コーディング

プリンタドライバを設定するためには、プリンタドライバ情報を取得しなくてはなりません。
－プリンタドライバ情報とは
－プリンタドライバ情報の取得方法

プリンタドライバ情報でプリンタをコントロールできない時には、プリンタドライバ設定ファイルを使います。
－プリンタドライバ設定ファイルとは

プリンタドライバを設定する情報やファイルが準備できたらレポートライブラリの設定機能を使ってプリンタをコントロールします。

注意：

プリンタドライバ情報の用紙番号は、取得するPCによって異なります。値は印刷を実行するPCで取得してください。
開発環境と実行環境が異なる場合は、開発完了時には、実行環境の値に変更する必要があります。


Adobe PDF形式でのWeb帳票システム[.NETやASP]

Adobe PDF形式でのWeb帳票システム

Adobe PDF（Portable Document Format）形式を使ってWeb帳票システムを作成します。
帳票のプレビューや印刷にはAdobe Reader（無償配布）を使います。

特長

・Adobe社によって開発されたAdobe PDF（Portable Document Format）形式の帳票です。
・メモリ間のデータ転送です。

システムの概要

解説

１．クライアントからWebサーバーに帳票を要求します。 （①）
２．サーバーにあるWebアプリケーションは、レポートライブラリを使ってAdobe PDF形式の帳票を作成します。 （②）
３．Adobe PDF形式の帳票が、クライアントへダウンロードされます。 （③）
４．クライアントでは、Adobe Readerを使ってプレビューや印刷を行います。 （④）

※クライアントにはAdobe Readerを準備しておきます。
※サンプルが用意されています。サンプルはインストールディレクトリの下にあります。
    [ インストールディレクトリ\SampleProgram\Web\JiveSample10X\ ]

※プレビューコントロールを使ってPDF帳票を出力する方法もあります。その方法では帳票の総ページ数を取る事ができます。

Webアプリケーション開発と環境整備

製品と一緒に、Webアプリケーションのサンプルがインストールされています。Webアプリケーションは、サンプルを参考にして開発してください。サンプルは、製品をインストールしたディレクトリのSampleProgram\Webの下にあります。
サンプルがあるディレクトリには、Webサンプルの解説書（Readme.htm）もインストールされています。環境整備の詳細は、解説書をご覧ください。


XPS形式でのWeb帳票システム(.NET)

XPS形式・TIFF形式でのWeb帳票システム

XPS(XML Pager Specification)形式やTIFF形式を使ってWeb帳票システムを作成します。
XPS形式の場合には、XPS Viewerを使って帳票のプレビューや印刷を行います。
TIFF形式の場合には、フォトギャラリー（無償配布）などを使って帳票のプレビューや印刷を行います。

特長

・XPS(XML Pager Specification)形式は、Microsoft社によって開発されたファイル形式です。
・TIFF形式の帳票は、TIFF形式に対応したイメージツールで利用できます。
・メモリ間のデータ転送です。

システムの概要

解説

１．クライアントからWebサーバーに帳票を要求します。 （①）
２．サーバーにあるWebアプリケーションは、レポートライブラリを使ってRDF形式の帳票を作成します。 （②）
３．XPS形式の帳票が、クライアントへダウンロードされます。 （③）
４．クライアントでは、XPS Viewerやフォトギャラリーなどのツールを使ってプレビューや印刷を行います。 （④）

※サンプルが用意されています。サンプルはインストールディレクトリの下にあります。
    [ インストールディレクトリ\SampleProgram\Web\JiveSample10X\ ]

※プレビューコントロールを使ってXPS帳票を出力する方法もあります。その方法では帳票の総ページ数を取る事ができます。

Webアプリケーション開発と環境整備

製品と一緒に、Webアプリケーションのサンプルがインストールされています。Webアプリケーションは、サンプルを参考にして開発してください。サンプルは、製品をインストールしたディレクトリのSampleProgram\Webの下にあります。
サンプルがあるディレクトリには、Webサンプルの解説書（Readme.htm）もインストールされています。環境整備の詳細は、解説書をご覧ください。


その他のイメージ形式のWeb帳票システム(.NET)

PNG形式・JPEG形式でのWeb帳票システム

JPEG形式やPNG形式を使ってWeb帳票システムを作成します。

特長

・スマートフォンやタブレットで帳票をプレビューすることができます。
・メモリ間のデータ転送です。

システムの概要

解説

１．クライアントからWebサーバーに帳票を要求します。 （①）
２．サーバーにあるWebアプリケーションは、レポートライブラリを使ってRDF形式の帳票を作成します。 （②）
３．JPEG形式の帳票が、スマートフォンへダウンロードされます。 （③）
４．スマートフォンでは、Google Chromeなどを使ってプレビューや印刷を行います。 （④）

※サンプルが用意されています。サンプルはインストールディレクトリの下にあります。
    [ インストールディレクトリ\SampleProgram\Web\JiveSample10X\ ]

※JPEGやPNG形式は複数ページに対応していません。プレビューコントロールを使ってJPEGやPNG形式の複数ページ帳票を出力することもできます。

Webアプリケーション開発と環境整備

製品と一緒に、Webアプリケーションのサンプルがインストールされています。Webアプリケーションは、サンプルを参考にして開発してください。サンプルは、製品をインストールしたディレクトリのSampleProgram\Webの下にあります。
サンプルがあるディレクトリには、Webサンプルの解説書（Readme.htm）もインストールされています。環境整備の詳細は、解説書をご覧ください。


レポートライブラリOCXとは

レポートライブラリＯＣＸとは、レポートライブラリ.NETコントロールとは

レポートライブラリOCXとレポートライブラリ.NETコントロール

レポートライブラリOCXは、ActiveX形式のコントロールです。
レポートライブラリ.NETコントロールは、.Net Frameworkに対応したコントロールです。

様々な機能を持つメソッドやプロパティ

プリンタ制御、帳票フォームやフォーム上のフィールド描画、プログラムからのオブジェクト描画など、豊富な機能を持ち、RDF、PDF、XPS、TIFF、JPEG、PNG、BMPなどの様々な形式で帳票を出力できます。 UNICODE描画、外字埋め込み機能などもあります。

使用上の注意

レポートライブラリ.NETコントロールは、.NETFramework2.0と4.0の2種類が用意されています。
実行環境に合った方を使用します。


アプリケーション開発

レポートライブラリOCXでのアプリケーション開発

インストール先

レポートライブラリOCXは、Windowsのシステムディレクトリにインストールされています。
－ファイル名、クラスID、コントロールID

開発

レポートライブラリOCXは、ActiveXコントロールを利用できる開発環境でご利用ください。
使い方は、ヘルプの基本的な使い方やリファレンスを参照してください。
サンプルプログラムが、用意されています。コーディングの参考にしてください。
［サンプルプログラムインストール先：インストールディレクトリ￥SampleProgram ］

配布

レポートライブラリOCXを使って開発したアプリケーションを実行環境にインストールする時には、レポートライブラリOCXも一緒に配布します。
レポートライブラリOCXは単独で動作します。
配布の前に、製品パッケージに入っている使用許諾契約書をお読みください。

実行環境の整備

1．レポートライブラリOCXを実行環境のWindowsディレクトリにコピーします。

  1-1．32ビットアプリケーションを開発した場合

    実行環境のOSがx86Editionの場合：　実行環境のC:\Windows\System32ディレクトリ
    実行環境のOSがx64Editionの場合：　実行環境のC:\Windows\SysWOW64ディレクトリ

  1-2．64ビットアプリケーションを開発した場合

    実行環境のC:\Windows\System32ディレクトリ
    使用できるOSは、x64Editionのみとなります。

2．コピーしたレポートライブラリOCXをレジストリ登録します。
レジストリ登録は、以下のようにコマンドラインから行なうか、あるいはインストールツールを使用します。

  Regsvr32.exe Jvrlib10X.ocx
  ※Regsvr32.exeは、Windowsのシステムディレクトリにあります。

Web環境で使用する場合

Web環境の場合、レポートライブラリOCXのジストリ登録は、サーバー側で行います。


レポートライブラリOCXの詳細情報

プロフェッショナル(X86)

ファイル名 | Jvrlib103.ocx
クラスID | ED52EE1C-655A-46c6-8024-EC599E0F45B8
コントロールID | Jvrlib103Ctl
インストール場所 | Windowsのシステムディレクトリの下

プロフェッショナル(X64)

ファイル名 | Jvrlib103.ocx
クラスID | ED52EE1C-655A-46c6-8024-EC599E0F45B8
コントロールID | Jvrlib103Ctl
インストール場所 | Windows\System32ディレクトリの下 ※x64対応レポートライブラリOCX
 | Windows\SysWOW64ディレクトリの下 ※x86対応レポートライブラリOCX

プロフェッショナル(X64)には2種類のレポートライブラリOCXが入っています。

詳細は、「X64製品での開発／各種開発環境での使い方／Visual Studioでの開発」を参照してください。


レポートライブラリ.NETコントロールのアプリケーション開発

レポートライブラリ.NETコントロールでのアプリケーション開発

レポートライブラリ.NETコントロールの種類

レポートライブラリ.NETコントロールは、.Net Framework 2.0用と.Net Framework 4.0用が用意されています。
アプリケーションで使用する.Net Frameworkにあわせて使い分けてください。

.Net Framework 2.0/3.0/3.5の場合：.Net Framework 2.0用のレポートライブラリ.NETコントロールを使います。
.Net Framework 4.0以降の場合：.Net Framework 4.0用のレポートライブラリ.NETコントロールを使います。

インストール先

レポートライブラリ.NETコントロールは、インストールディレクトリ\DnetControlの下にインストールされます。
－インストール先、ファイル名

開発

レポートライブラリ.NETコントロールは、.NETコントロールを利用できる言語環境で使います。
※レポートライブラリ.NETコントロールは、Delphiでは使用できません。

使い方は、ヘルプの基本的な使い方やリファレンスを参照してください。
サンプルプログラムが、用意されています。コーディングの参考にしてください。
［サンプルプログラムインストール先：インストールディレクトリ￥SampleProgram ］

実行環境の整備

レポートライブラリ.Netコントロールを使ったアプリケーションを実行環境で動かす場合は次の作業を行います。

１．レポートライブラリ.Netコントロールを実行モジュールと同じディレクトリに入れます。

２．レポートライブラリDLLを実行環境のWindowsディレクトリにコピーします。
  （レポートライブラリ.NetコントロールはレポートライブラリDLLを使います。）

  2-1．32ビットアプリケーションを開発した場合

    実行環境のOSがx86Editionの場合：　実行環境のC:\Windows\System32ディレクトリ
    実行環境のOSがx64Editionの場合：　実行環境のC:\Windows\SysWOW64ディレクトリ

  2-2．64ビットアプリケーションを開発した場合

    実行環境のC:\Windows\System32ディレクトリ
    使用できるOSは、x64Editionのみとなります。

    －X64製品での開発／各種開発環境での使い方／Visual Studioでの開発

３．Visual Cのランタイムライブラリをコピーします。

  3-1．.32ビットアプリケーションを開発した場合

    [.Net Framework 2.0用コントロールを使用した場合]

    レポートライブラリ.Netコントロールは、Visual C 2008のランタイムライブラリを使用しています。
    以下のAまたはBのどちらかの方法でランタイムライブラリをインストールします。

    A．実行モジュールと同じディレクトリに、 以下の４つのファイルをコピーします。
      Microsoft.VC90.CRT.manifest、msvcm90.dll、msvcp90.dll、msvcr90.dll
      これらのファイルは、次の場所にインストールされています。
      インストールディレクトリ\DnetControl\x86\Framework2.0\Microsoft.VC90.CRT

    B．vcredist_x86.exeを実行します。このプログラムは次の場所にあります。
      インストールディレクトリ\DnetControl\x86\Framework2.0

    [.Net Framework 4.0用コントロールを使用した場合]

    レポートライブラリ.Netコントロールは、Visual C 2010のランタイムライブラリを使用しています。
    .Net Framework 4.0をインストールするとこのライブラリもインストールされるので、特別な作業はありません。

  3-2．.64ビットアプリケーションを開発した場合

    [.Net Framework 2.0用コントロールを使用した場合]

    レポートライブラリ.Netコントロールは、Visual C 2008のランタイムライブラリを使用しています。
    以下のAまたはBのどちらかの方法でランタイムライブラリをインストールします。

    A．実行モジュールと同じディレクトリに、 以下の４つのファイルをコピーします。
      Microsoft.VC90.CRT.manifest、msvcm90.dll、msvcp90.dll、msvcr90.dll
      これらのファイルは、次の場所にインストールされています。
      インストールディレクトリ\DnetControl\x64\Framework2.0\Microsoft.VC90.CRT

    B．vcredist_x64.exeを実行します。このプログラムは次の場所にあります。
      インストールディレクトリ\DnetControl\x64\Framework2.0
      ※このプログラムは、Microsoft社のWebサイトからダウンロードすることもできます。

    [.Net Framework 4.0用コントロールを使用した場合]

    レポートライブラリ.Netコントロールは、Visual C 2010のランタイムライブラリを使用しています。
    .Net Framework 4.0をインストールするとこのライブラリもインストールされるので、特別な作業はありません。


レポートライブラリ.NETの詳細情報

レポートライブラリ.NETコントロールの詳細情報

プロフェッショナル(X86)

ファイル名 | Jvrnet102.dll
インストール場所 | ジャイブレポートのインストールディレクトリ\DnetControl\x86\Framework2.0\ ※1
 | ジャイブレポートのインストールディレクトリ\DnetControl\x86\Framework4.0\ ※2

※1：.NETFramework2.0用のx86対応レポートライブラリ.NETコントロール
※2：.NETFramework4.0用のx64対応レポートライブラリ.NETコントロール

※1：開発環境がVisual Studio2005/2008の場合は、.Net Framework2.0用のコントロールを使います
※2：開発環境がVisual Studio2010以降の場合は、.Net Framework4.0用のコントロールを使います。

プロフェッショナル(X64)

ファイル名 | Jvrnet102.dll
インストール場所 | ジャイブレポートのインストールディレクトリ\DnetControl\x86\Framework2.0\ ※1
 | ジャイブレポートのインストールディレクトリ\DnetControl\x86\Framework4.0\ ※2
 | ジャイブレポートのインストールディレクトリ\DnetControl\x64\Framework2.0\ ※3
 | ジャイブレポートのインストールディレクトリ\DnetControl\x64\Framework4.0\ ※4

※1：.NETFramework2.0用のx86対応レポートライブラリ.NETコントロール
※2：.NETFramework4.0用のx86対応レポートライブラリ.NETコントロール
※3：.NETFramework2.0用のx64対応レポートライブラリ.NETコントロール
※4：.NETFramework4.0用のx64対応レポートライブラリ.NETコントロール

※1※3：開発環境がVisual Studio2005/2008の場合は、.Net Framework2.0用のコントロールを使います
※2※4：開発環境がVisual Studio2010以降の場合は、.Net Framework4.0用のコントロールを使います。

詳細は、「X64製品での開発／各種開発環境での使い方／Visual Studioでの開発」を参照してください。


旧バージョンからの移行

旧バージョンからの移行 [ レポートライブラリOCX ]

旧バージョンのレポートライブラリOCXを使ったプログラムを最新のレポートライブラリOCXに置き換える場合は、移行作業が必要です。

相違点

◆ファイル名が変わりました。（Ver.3～Ver.10.1から移行する場合）

◆プロポーショナルフォントの文字の描画位置が変わりました。（Ver.3～Ver.10.0から移行する場合）

◆文字回転機能を使って文字を回転させた時の描画位置が変わりました。（Ver.3～Ver.10.0から移行する場合）

◆余白（マージン）とスケールの考え方が変わりました。（Ver.3～Ver.9.1から移行する場合）

◆IDとクラスIDが変わりました。（ASPで使用している場合）
－レポートライブラリOCXのファイル名、クラスID、コントロールID

◆外字の描画方法が変わりました。（Ver.4～Ver.9.04から移行する場合）

◆メソッドの戻り値がなくなりました。（Ver.3～Ver.6から移行する場合）

◆CMFファイル作成機能がなくなりました。（Ver.4～Ver.6から移行する場合）

◆電子帳票関連機能がなくなりました。（Ver.6から移行する場合）

◆実行環境への配布ファイルがレポートライブラリOCXだけになりました。（Ver.3～Ver.6から移行する場合）

◆RDFファイル名とBMPファイル名の設定方法が変わりました。（Ver.3～Ver.8から移行する場合）
  ImageFileNameプロパティからOutFileNameプロパティに変わりました。

※ImageFileNameプロパティは、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しい方法へ変更することをお薦めします。ImageFileNameプロパティを引き続き使用する場合には、OutFileNameプロパティに値を設定しないようにしてください。

◆Adobe PDFファイルの作成方法が変わりました。（Ver.8から移行する場合）
  SaveFileメソッドからOutFileNameプロパティでファイル名を設定する方法に変わりました。

※SaveFileメソッドは、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しい方法へ変更することをお薦めします。

◆Adobe PDFド形式データの取得方法が変わりました。（Ver.8から移行する場合）
  PdfDataプロパティからDocumentDataプロパティに変わりました。

※PdfDataプロパティは、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しい方法へ変更することをお薦めします。

◆Adobe PDF形式データの各種プロパティの設定方法が変わりました。（Ver.8から移行する場合）
  KeyプロパティからSetParamプロパティに変わりました。

※Keyプロパティで設定する方法は、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しい方法へ変更することをお薦めします。

◆Adobe PDF形式で出力時、点線の幅と間隔、文字のボールド、罫線の太さが変わりました。（Ver.7.4から移行する場合）

◆32ビットから64ビットへ変更する場合[Visual Studioの場合]：　ターゲットCPUの変更
プロフェッショナル(X86)・スタンダード(X86)・プロフェッショナル版・スタンダード版・アプリケーション開発キットで作成したプログラムをプロフェッショナル(X64)で64ビットアプリケーションに移行する場合には、ターゲットCPUの変更が必要です。

◆プロフェッショナル(X64)（Ver8.3～Ver9.08の場合）
プロフェッショナル(X64)Ver8.3～Ver9.08でハンドルやデバイスコンテキストに関する問題が見つかりました。
この問題はインストールディレクトリの「ProX64のアップデート方法.htm 」に詳しく記述されています。ご参照ください。

移行作業

◆コントロールの参照設定変更

(1)プロジェクトファイルを開き、古いレポートライブラリOCXを削除します。
(2)コンポーネントの参照を新しいレポートライブラリOCXに変更します。
(3)新しいレポートライブラリOCXを貼り付けます。

◆プロポーショナルフォントの文字位置・回転文字の描画位置の確認（Ver.3～Ver.10.0から移行する場合）

プロポーショナルフォントや文字回転を使っている場合には、文字を描画する位置の確認が必要です。
旧バージョンの文字位置で描画する場合には、「文字列の描画をバージョン10.0以前の仕様で行う」をチェックします。

◆余白（マージン）とスケールの考え方が変わりました。

旧バージョンのフォームを使用する場合には、余白とスケールの確認作業が必要です。
－旧バージョンの余白（マージン）設定と変更

◆外字の描画方法変更による確認と、新機能への変更

Ver.4～Ver.7を使って外字を描画している場合は、Ver.8以降では外字の描画方法が変わったため、外字が正しく描画されるかどうかのチェックが必要です。
また、Ver.4～Ver.9.04までのレポートライブラリOCXでは、外字フォントを使って外字を描画していましたが、Ver.9.05でジャイブレポート外字ファイルを使って外字を描画する方法が追加されました。外字が正しく描画されない場合は、ジャイブレポート外字ファイルを使うことができます。
Webアプリケーションから外字を描画している場合、IIS7以降の環境では、外字フォントで外字を描画することができません。ジャイブレポート外字ファイルを使用する方法への変更が必要です。
－外字の描画

◆メソッドの戻り値を取得している箇所の修正（Ver.3～Ver.6の場合）

メソッドの戻り値を取得している場合は、戻り値を取得しないようにします。エラーについては、エラー処理でエラーコードを取得するように変更します。

◆CMFファイル設定箇所の修正（Ver.4～Ver.6の場合）

OutDeviceプロパティにJV_CMF(=4)を設定している場合は、JV_RDF(=5)に変更します。
プログラムの変更は、上記1箇所のみです。
過去のCMFファイル（xxx.cmf）は、最新のプレビューコントロールでそのまま利用することができます。

◆電子帳票関連部分のプログラム変更（Ver.6の場合）

電子帳票関連の機能がプログラム中に含まれている場合は削除します。
以下のプロパティが削除されました。
Owner,Group,Access,Password,ErfOwner,ErfGroup,ErfAccess,ErfUpdateTime,ErfPage

◆インストーラーの変更と実行環境の整備

アプリケーションをインストーラーで配布している場合は、インストールファイルをレポートライブラリOCXのみにします。
アプリケーションを手動で配布している場合は、レポートライブラリOCXを実行環境へコピーし、レジストリ登録を行います。

◆コントロールのIDとクラスIDの変更（ASPの場合）

ASPを利用している場合は、コントロールのIDとクラスIDを変更します。

◆32ビットから64ビットへ変更する場合[Visual Studioの場合]：　ターゲットCPUの変更

プロフェッショナル(X86)・スタンダード(X86)・プロフェッショナル版・スタンダード版・アプリケーション開発キットで作成したプログラムをプロフェッショナル(X64)で64ビットアプリケーションに移行する場合には、ターゲットCPUの変更が必要です。
－X64製品での開発／Visual Studioでの開発


基本的な使い方(レポートライブラリOCX)

最も基本的なｺｰﾃﾞｨﾝｸﾞ

最も基本的なコーディングです。

レポートライブラリOCX

Object.Start | 初期処理と印刷開始
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

ret = Object.Start() | 初期処理と印刷開始
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

Startメソッドはレポートライブラリが動作する資源を確保し、Endメソッドは確保した資源を解放します。
StartメソッドとEndメソッドは必ず対になるようにコーディングします。
StartメソッドからEndメソッドまでが１つの印刷ジョブとなります。


印刷ダイアログを表示(レポートライブラリOCX)

印刷ﾀﾞｲｱﾛｸﾞを表示

アプリケーション実行時に印刷ダイアログを表示するコーディングです。

レポートライブラリOCX

Object.OutDevice = JV_PRINTER | 出力先をプリンタにする
↓ |
Object. SetPrinter = JV_SPSHOWDIALOG | 印刷ダイアログの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ | （印刷ダイアログがポップアップ）
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.OutDevice = JV_PRINTER | 出力先をプリンタにする
↓ |
Object. SetPrinter = JV_SPSHOWDIALOG | 印刷ダイアログの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ | （印刷ダイアログがポップアップ）
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理


プリンタドライバを設定(レポートライブラリOCX)

実行時にﾌﾟﾘﾝﾀﾄﾞﾗｲﾊﾞを設定

実行時に、アプリケーション内部でプリンタドライバのプロパティを設定するコーディングです。

レポートライブラリOCX

Object.OutDevice = JV_PRINTER | 出力先をプリンタにする
↓ |
Object. SetPrinter = JV_SPDEVMODE | プリンタドライバのプロパティ変更指示
↓ |
Object. PrinterDevMode = “1,9” | 変更するプリンタドライバ情報の設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.OutDevice = JV_PRINTER | 出力先をプリンタにする
↓ |
Object. SetPrinter = JV_SPDEVMODE | プリンタドライバのプロパティ変更指示
↓ |
Object. PrinterDevMode = “1,9” | 変更するプリンタドライバ情報の設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

－プリンタドライバ情報とは
－プリンタドライバ情報の取得


帳票フォームとフィールドデータを印刷(レポートライブラリOCX)

固定フォームでフィールドを印刷

レポートエディタで作成した固定フォームと、フォームに貼り付けられたフィールドにデータを設定して印刷するコーディングです。

レポートライブラリOCX

Object.FormName = "固定フォーム.jfm" | フォームの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
Object.SetFieldText("text1", "金額") | ﾃｷｽﾄﾌｨｰﾙﾄﾞに値を設定
↓ |
Object.SetFieldGrid("grid1", 1, "1000") | ｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞの1行目に値を設定
↓ |
Object.SetFieldGrid("grid1", 2, "5000") | ｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞの2行目に値を設定
↓ |
（グリッドフィールドの行数分繰り返す） |
↓ |
Object.DrawForm | フォームとフィールドを描画
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.FormName = "固定フォーム.jfm" | フォームの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
ret = Object.SetFieldText("text1", "金額") | ﾃｷｽﾄﾌｨｰﾙﾄﾞに値を設定
↓ |
ret = Object.SetFieldGrid("grid1", 1, "1000") | ｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞの1行目に値を設定
↓ |
ret = Object.SetFieldGrid("grid1", 2, "5000") | ｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞの2行目に値を設定
↓ |
（グリッドフィールドの行数分繰り返す） |
↓ |
ret = Object.DrawForm() | フォームとフィールドを描画
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

グリッドフィールドへのデータセットは、グリッドフィールドの行数分繰り返します。
複数ページを印刷する時は、SetFieldTextメソッド～NewPageまでを繰り返します。


フォームとフィールド可変フォーム

可変フォームでフィールドを印刷

レポートエディタで作成した可変フォームと、セクションに貼り付けられたフィールドにデータを設定して印刷するコーディングです。

レポートライブラリOCX

Object.FormName = "可変フォーム.jfm" | フォームの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
Object.SectionKey = "ヘッダー" | セクションの設定
↓ |
Object.SetFieldText("text1", "金額") | ﾃｷｽﾄﾌｨｰﾙﾄﾞの値設定
↓ |
Object.DrawSection | セクションの描画
↓ |
Object.SectionKey = "明細" | セクションの設定
↓ |
On Error Resume Next |
↓ |
For i = 1 to n |
↓ |
Object.SetFieldGrid("grid1", 1, "1000") | ｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞの値設定
↓ |
Object.DrawSection | セクションの描画
↓ |
If Err.Number = 1131 Then | 改ページ要求の場合は改ページ
Object.NewPage |
End If |
↓ |
Next i |
↓ |
Object.SectionKey = "フッター" | セクションの設定
↓ |
Object.SetFieldText("text2", "頁") | ﾃｷｽﾄﾌｨｰﾙﾄﾞの値設定
↓ |
Object.DrawSection | セクションの描画
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.FormName = "可変フォーム.jfm" | フォームの設定
↓ |
Object.ErrorThrow = JV_ERROR_THROW_INVALID | 例外を発生させない
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
Object.SectionKey = "ヘッダー" | セクションの設定
↓ |
ret = Object.SetFieldText("text1", "金額") | ﾃｷｽﾄﾌｨｰﾙﾄﾞの値設定
↓ |
ret = Object.DrawSection() | セクションの描画
↓ |
Object.SectionKey = "明細" | セクションの設定
↓ |
For i = 1 to n |
↓ |
ret = Object.SetFieldGrid("grid1", 1, "1000") | ｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞの値設定
↓ |
ret = Object.DrawSection() | セクションの描画
↓ |
If ret = 1131 Then | 改ページ要求の場合は改ページ
ret = Object.NewPage() |
End If |
↓ |
Next i |
↓ |
Object.SectionKey = "フッター" | セクションの設定
↓ |
ret = Object.SetFieldText("text2", "頁") | ﾃｷｽﾄﾌｨｰﾙﾄﾞの値設定
↓ |
ret = Object.DrawSection() | セクションの描画
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

DrawSectionで改ページ要求が出た時は改ページを行います。

－可変フォームを使った印刷アプリケーション


複数のフォームを印刷(レポートライブラリOCX)

複数のフォームを印刷

複数の固定フォームを1枚の用紙に印刷するコーディングです。

レポートライブラリOCX

Object.FormName = "納品書.jfm" | 1つ目のフォームの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
Object.SetFieldText("text1", "金額") | 1つ目のフォームのデータ設定
↓ |
Object.DrawForm | 1つ目のフォームとフィールドを描画
↓ |
Object.FormName = "請求書.jfm" | 2つ目のフォームの設定
↓ |
Object.TopMargin = 15000 | 2つ目のフォームの上印字開始位置調整
↓ |
Object.SetFieldText("text1", "金額") | 2つ目のフォームのデータ設定
↓ |
Object.DrawForm | 2つ目のフォームとフィールドを描画
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.FormName = "納品書.jfm" | 1つ目のフォームの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
ret = Object.SetFieldText("text1", "金額") | 1つ目のフォームのデータ設定
↓ |
ret = Object.DrawForm () | 1つ目のフォームとフィールドを描画
↓ |
Object.FormName = "請求書.jfm" | 2つ目のフォームの設定
↓ |
Object.TopMargin = 15000 | 2つ目のフォームの上印字開始位置調整
↓ |
ret = Object.SetFieldText("text1", "金額") | 2つ目のフォームのデータ設定
↓ |
ret = Object.DrawForm() | 2つ目のフォームとフィールドを描画
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

可変フォームでは、1枚の用紙に複数のフォームを印刷することはできません。


RDFデータを作成する

RDF形式のデータを作成

ジャイブレポート専用のＲＤＦ形式で帳票を作成し、プレビューコントロールへ渡します。

レポートライブラリOCX

Object.OutDevice = JV_RDF | 出力先の設定
↓ |
Object.FormName = “見積書.jfm” | フォームファイルの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 終了処理（RDF形式のデータが完成）
↓ |
buf = Object.DocumentData | RDF形式のデータを取得
↓ |
JiveView.DocumentData = buf | プレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | プレビューコントロールで表示

レポートライブラリ.NETコントロール

Object.OutDevice = JV_RDF | 出力先の設定
↓ |
Object.FormName = “nouhin.jfm” | フォームファイルの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 終了処理（RDF形式のデータが完成）
↓ |
buf = Object.DocumentData | RDF形式のデータを取得
↓ |
JiveView.DocumentData = buf | プレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | プレビューコントロールで表示

作成したRDF形式のデータは、プレビューコントロールを使ってプレビューや印刷を行います。


PDF形式のデータをメモリ転送(レポートライブラリOCX)

Adobe PDF形式のデータを作成

Web環境で、帳票をAdobe PDF形式で作成するコーディングです。

レポートライブラリOCX

Object.OutDevice = JV_PDF | 出力先の設定
↓ |
Object.FormName = “納品書.jfm” | フォームファイルの設定
↓ |
Object.SetParam(JV_PDF_USER_PASSWORD ,"user") | ユーザーパスワード設定
↓ |
Object.DocName = "納品書" | ドキュメント名を設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.BookMark = "納品書" | ページにブックマークを設定
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 終了処理（PDF形式のデータが完成）
↓ |
Buf = Object.DocumentData | PDF形式のデータ取得
（Web環境で） |
・ |
・ |
Response.BinaryWrite Buf |

レポートライブラリ.NETコントロール

Object.OutDevice = JV_PDF | 出力先の設定
↓ |
Object.FormName = “納品書.jfm” | フォームファイルの設定
↓ |
ret = Object.SetParam(JV_PDF_USER_PASSWORD ,"user") | ユーザーパスワード設定
↓ |
Object.DocName = "納品書" | ドキュメント名を設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.BookMark = "納品書" | ページにブックマークを設定
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 終了処理（PDF形式のデータが完成）
↓ |
Buf = Object.DocumentData | PDF形式のデータ取得
（Web環境で） |
・ |
・ |
Response.BinaryWrite Buf |

Adobe PDF形式のデータは、ASPなどのコマンドでクライアントへ転送し、Adobe Readerを使ってプレビューします。


RDFファイルを作成する(レポートライブラリOCX)

RDF形式のファイルを作成

帳票をジャイブレポート専用のRDF形式でファイルに保存し、プレビューコントロールへ渡すコーディングです。

レポートライブラリOCX

Object.OutDevice = JV_RDF | 出力先の設定
↓ |
Object.ＯｕｔFileName = “C:\file.rdf” | RDFファイル名の設定
↓ |
Object.FormName = “nouhin.jfm” | フォームファイルの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.End | 終了処理（RDFファイル完成）
JiveView.FileName = "C:\file.rdf" | プレビューコントロールへ渡す
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | プレビューコントロールに表示

レポートライブラリ.NETコントロール

Object.OutDevice = JV_RDF | 出力先の設定
↓ |
Object.ＯｕｔFileName = “C:\file.rdf” | RDFファイル名の設定
↓ |
Object.FormName = “nouhin.jfm” | フォームファイルの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
ret = Object.End() | 終了処理（RDFファイル完成）
JiveView.FileName = "C:\file.rdf" | プレビューコントロールへ渡す
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | プレビューコントロールに表示

作成したRDFファイルは、プレビューコントロールを使ってプレビューや印刷を行います。


PDFファイルを作成する(レポートライブラリOCX)

Adobe PDF形式のファイルを作成

帳票をAdobe PDF形式で作成し、ファイルに保存するコーディングです。

レポートライブラリOCX

Object.OutDevice = JV_PDF | 出力先の設定
↓ |
Object.FormName = “nouhin.jfm” | フォームファイルの設定
↓ |
Object.OutFileName = “nouhin.PDF” | PDFファイル名の設定
↓ |
Object.SetParam(JV_PDF_USER_PASSWORD , "user") | ユーザーパスワード設定
↓ |
Object.DocName = "納品書" | ドキュメント名を設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.BookMark = "納品書" | ページにブックマークを設定
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 終了処理（PDFファイル完成）

レポートライブラリ.NETコントロール

Object.OutDevice = JV_PDF | 出力先の設定
↓ |
Object.FormName = “nouhin.jfm” | フォームファイルの設定
↓ |
Object.OutFileName = “nouhin.PDF” | PDFファイル名の設定
↓ |
ret = Object.SetParam(JV_PDF_USER_PASSWORD , "user") | ユーザーパスワード設定
↓ |
Object.DocName = "納品書" | ドキュメント名を設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.BookMark = "納品書" | ページにブックマークを設定
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 終了処理（PDFファイル完成）

Adobe PDFファイルは、Adobe Readerを使ってプレビューします。


ラベル印刷(レポートライブラリOCX)

ラベル印刷

ラベルを印刷するコーディングです。

レポートライブラリOCX

Object.FormName = "ラベル.jfm" | ラベル用フォームファイルの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
Object.LabelNo = 1 | 1枚目のラベルを指定
↓ |
Object.SetFieldText("text1", "名古屋市") | 1枚目のフィールドデータを設定
↓ |
Object.DrawForm | 1枚目のラベルを描画
↓ |
Object.LabelNo = 2 | 2枚目のラベルを指定
↓ |
Object.SetFieldText("text1", "大阪市") | 2枚目のフィールドデータを設定
↓ |
Object.DrawForm | 2枚目のラベルを描画
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.FormName = "ラベル.jfm" | ラベル用フォームファイルの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
Object.LabelNo = 1 | 1枚目のラベルを指定
↓ |
ret = Object.SetFieldText("text1", "名古屋市") | 1枚目のフィールドデータを設定
↓ |
ret = Object.DrawForm() | 1枚目のラベルを描画
↓ |
Object.LabelNo = 2 | 2枚目のラベルを指定
↓ |
ret = Object.SetFieldText("text1", "大阪市") | 2枚目のフィールドデータを設定
↓ |
ret = Object.DrawForm() | 2枚目のラベルを描画
↓ |
ret = Object.NewPage() | 改ページ
↓ |
et = Object.End() | 印刷終了と終了処理

１枚の用紙にラベルが複数枚ある場合、ラベル番号は、左上が1となります。
例）ラベルが横方向に２枚、縦方向に３枚ある場合は次のようになります。

1 | 2
3 | 4
5 | 6

ラベル印刷は固定フォームで作成します。可変フォームでは作成できません。


UNICODEを描画するレポートライブラリOCX)

UNICODEを描画する

テキストフィールドやグリッドフィールドでUNICODEの文字を描画するコーディングです。

レポートライブラリOCX

Object.FormName = "nouhin.jfm" | 帳票フォームの設定
↓ |
Object.CharacterSet=CHARSET_UNICODE | UNICODEの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
・ |
Object.SetFieldText("text1", "?") | テキストフィールドにUNICODE文字列を設定
・ |
・ | （フォームとフィールドを描画）
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.FormName = "nouhin.jfm" | 帳票フォームの設定
↓ |
Object.CharacterSet=CHARSET_UNICODE | UNICODEの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
・ |
ret = Object.SetFieldText("text1", "?") | テキストフィールドにUNICODE文字列を設定
・ |
・ | （フォームとフィールドを描画）
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

UNICODEの使用について


高速に印刷する(レポートライブラリOCX)

印刷スピードを高速にする

印刷スピードを高速にするコーディングです。

レポートライブラリOCX

Object.FormName = "nouhin.jfm" | 帳票フォームの設定
↓ |
Object.PrintMode=JV_PRINTMODE_HISPEED | 高速印刷モードの設定
↓ |
Object.Start | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
Object.NewPage | 改ページ
↓ |
Object.End | 印刷終了と終了処理

レポートライブラリ.NETコントロール

Object.FormName = "nouhin.jfm" | 帳票フォームの設定
↓ |
Object.PrintMode=JV_PRINTMODE_HISPEED | 高速印刷モードの設定
↓ |
ret = Object.Start() | 初期処理と印刷開始
↓ |
・ |
・ | フォームとフィールドを描画
・ |
↓ |
ret = Object.NewPage() | 改ページ
↓ |
ret = Object.End() | 印刷終了と終了処理

高速印刷モードでは、一部のグラフィックス機能に使用制限があります。

－高速印刷モードと機能制限


Abortメソッド

印刷を中断します。

[構文]

レポートライブラリOCX

Object.Abort

レポートライブラリ.NETコントロール

long Object.Abort ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]

値 | 内容
1029 | Startを行ってください

[解説]

Abortメソッドは、Startメソッドで印刷を開始した後に印刷を中断する時に使います。
Abortメソッドは、Startメソッドで確保した資源を解放します。
「Abort」が予約語に指定されている開発環境では、「AbortDoc」を使用してください。


DrawArcメソッド

弧・弓・扇を描画します。

[構文]

レポートライブラリOCX

Object.DrawArc (sx, sy , ex, ey, mx1, my1, mx2, my2, arcmode)

レポートライブラリ.NETコントロール

long Object.DrawArc (sx, sy , ex, ey, mx1, my1, mx2, my2, arcmode)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 外接する四角形の左上Ｘ座標(1/100mm単位)
sy | long | 外接する四角形の左上Ｙ座標(1/100mm単位)
ex | long | 外接する四角形の右下Ｘ座標(1/100mm単位)
ey | long | 外接する四角形の右下Ｙ座標(1/100mm単位)
mx1 | long | 弧・弓・扇の開始Ｘ座標(1/100mm単位)
my1 | long | 弧・弓・扇の開始Ｙ座標(1/100mm単位)
mx2 | long | 弧・弓・扇の終了Ｘ座標(1/100mm単位)
my2 | long | 弧・弓・扇の終了Ｙ座標(1/100mm単位)
arcmode | long | 描画する種類（設定値参照）

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください
1045 | 不正なコードがあります
1046 | コード長が不正です

[設定値]

arcmodeには次の値を指定します。

定数 | 値 | 内容
JV_ARC_ARC | 1 | 弧
JV_ARC_PIE | 2 | 扇
JV_ARC_CHORD | 3 | 弓

[解説]

図形のプロパティは、 L ineWidthプロパティ（線の幅）、LineStyleプロパティ（線の種類）、FillPatternプロパティ（塗り潰しパターン）、OutLineプロパティ（輪郭線）を使って設定します。 各プロパティは、改ページでページが変わった時には再設定が必要です。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX
Jvr.LineStyle = JV_PS_DASHDOTDOT | '線の種類
Jvr.backmode = JV_OPAQUE | '非透過
Jvr.DrawArc(3000, 3000, 4000, 4000, 3500, 3000, 4000, 3500, JV_ARC_CHORD) | '弧の描画

レポートライブラリ.NETコントロール

Jvr.LineStyle = JV_PS_DASHDOTDOT | '線の種類
Jvr.backmode = JV_OPAQUE | '非透過
ret = Jvr.DrawArc(3000, 3000, 4000, 4000, 3500, 3000, 4000, 3500, JV_ARC_CHORD) | '弧の描画


DrawBarcodeメソッド

バーコードを描画します。

[構文]

レポートライブラリOCX

Object.DrawBarcode (sx, sy, barheight, barsize, chargap, codetype, checkdigit, angle, barcode)

レポートライブラリ.NETコントロール

long Object.DrawBarcode (sx, sy, barheight, barsize, chargap, codetype, checkdigit, angle, barcode)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 描画する左上Ｘ座標(1/100mm単位)
sy | long | 描画する左上Ｙ座標(1/100mm単位)
barheight | long | バーの高さ(1/100mm単位)
barsize | string | 設定する値はバーコードの種類によって異なります。（下記参照）
chargap | long | キャラクタ間ギャップ(1/100mm単位)
codetype | long | バーコードの種類（設定値参照）
checkdigit | long | チェックディジットの有無（設定値参照）
angle | long | バーコードを描画する方向（設定値参照）
barcode | string | 描画するバーコードデータ

[エラーコード]

値 | 内容
1029 | Startを行ってください

[設定値]

barsize には、次の値を指定します。 データ間はカンマで区切ります。

カスタマーバーコードの場合
「ロングバーの長さ、タイミングバーの長さ、バーの幅、スペースの幅」をこの順番で設定します。未設定の場合は、デフォルト値で描画されます。

QRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードの場合
ここをクリックしてbarsize設定値を参照し値を指定してください。未設定の場合は、エラーになります。

上記以外のバーコード
「バー幅1,バー幅2,バー幅3,バー幅4,スペース幅1,スペース幅2,スペース幅3,スペース幅4」を細い方から順番に設定します。未設定の場合は、デフォルト値で描画されます。

codetype には次の値を指定します。

定数 | 値 | 内容
JV_BAR_JAN13 | 1 | JAN標準形
JV_BAR_JAN8 | 2 | JAN短縮形
JV_BAR_CODE39 | 3 | CODE39
JV_BAR_NW7 | 4 | NW7
JV_BAR_ITF | 5 | ITF
JV_BAR_CODE128 | 7 | CODE128
JV_BAR_CST | 8 | カスタマバーコード
JV_BAR_UPC | 9 | UPC
JV_BAR_QRCODE | 11 | QRコード
JV_BAR_MICROQR | 12 | マイクロQRコード
JV_BAR_PDF417 | 13 | PDF417コード
JV_BAR_MICROPDF417 | 14 | マイクロPDF417コード

checkdigit には次の値を指定します。

定数 | 値 | 内容
JV_CHECK_OFF | 0 | チェックディジットをつけない
JV_CHECK_ON | 1 | チェックディジットをつける

angle には次の値を指定します。

定数 | 値 | 内容
JV_ANGL_0 | 0 | 左→右
JV_ANGL_90 | 1 | 上→下
JV_ANGL_180 | 2 | 右→左
JV_ANGL_270 | 3 | 下→上

[解説]

barcode の値は、バーコードによって使用できるキャラクタが異なります。
chargap の値は、バーコードがcode39とNW7の時のみ有効です。

カスタマーバーコードでは、Barheight、chargap、checkdigit の値は無視されます。
QRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードでは、chargap、checkdigit の値は無視されます。

実際に描画したバーコードは、Barcodeプロパティで取得できます。
チェックディジットをつけた場合、Barcodeプロパティには、実際に描画したチェックディジットつきのコードが入ります。

StartメソッドとEnd（Abort）メソッドの間で実行します。

各バーコードの詳細は、以下を参照してください。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マクロQRコード
－PDF417コード
－マイクロPDF417コード

[コーディング例]

レポートライブラリOCX

barheight = 1000
barsize = "25,50,75,100,25,50,75,100"
chargap = 0
codetype = JV_BAR_JAN8
checkdigit = JV_CHECK_OFF
angle = JV_ANGLE90
barcode = "12345678"
Jvr.DrawBarcode(5000, 1000, barheight, barsize, chargap, _
codetype, checkdigit, angle, barcode)

barsize = "30,75,0,0,30,75,0,0"
barcode = " JIVE-REPORT"
codetype = JV_BAR_CODE39
Jvr.DrawBarcode(5000, 2000, barheight, barsize, chargap, _
codetype, checkdigit, angle, barcode)

barsize = "360,120,60,60"
barcode = "460-0011名古屋市中区大須1-25-28 "
codetype = JV_BAR_CST
Jvr.DrawBarcode(5000, 2000, barheight, barsize, chargap, _
codetype, checkdigit, angle, barcode)

barheight = 1000
barcode = "QRコードサンプル"
barsize = CStr(JV_QR_LEVEL_M) & "," & CStr(JV_QR_TYPE_AUTO) & "," & CStr(JV_QR_MASKNO_AUTO)
codetype = JV_BAR_QR
Jvr.DrawBarcode(1000, 1500, barheight, barsize, 0, codetype, 0, 0, barcode)

barheight = 800
barcode = "マイクロQR"
barsize = CStr(JV_QR_LEVEL_Q) & "," & CStr(JV_QR_TYPE_AUTO) & "," & CStr(JV_QR_MASKNO_AUTO)
codetype = JV_BAR_MICROQR
angle = JV_ANGLE180
Jvr.DrawBarcode(3000, 15000, barheight, barsize, 0, codetype, 0, angle, barcode)

barheight = 800
barcode = "PDF417"
barsize = CStr(JV_PDF417_ERROR_AUTO) & "," & CStr(2) & "," & CStr(20) & "," & CStr(50)
codetype = JV_BAR_PDF417
angle = JV_ANGLE0
Jvr.DrawBarcode(5000, 15000, barheight, barsize, 0, codetype, 0, angle, barcode)

barheight = 1000
barcode = "MicroPDF417"
barsize = CStr(JV_MICROPDF417_SIZE_2X23) & "," & CStr(70)
codetype = JV_BAR_MICROPDF417
angle = JV_ANGLE90
Jvr.DrawBarcode(10000, 15000, barheight, barsize, 0, codetype, 0, angle, barcode)

レポートライブラリ.NETコントロール

barheight = 1000
barsize = "25,50,75,100,25,50,75,100"
chargap = 0
codetype = JV_BAR_JAN8
checkdigit = JV_CHECK_OFF
angle = JV_ANGLE90
barcode = "12345678"
ret = Jvr.DrawBarcode(5000, 1000, barheight, barsize, chargap, _
codetype, checkdigit, angle, barcode)

barsize = "30,75,0,0,30,75,0,0"
barcode = " JIVE-REPORT"
codetype = JV_BAR_CODE39
ret = Jvr.DrawBarcode(5000, 2000, barheight, barsize, chargap, _
codetype, checkdigit, angle, barcode)

barsize = "360,120,60,60"
barcode = "460-0011名古屋市中区大須1-25-28 "
codetype = JV_BAR_CST
ret = Jvr.DrawBarcode(5000, 2000, barheight, barsize, chargap, _
codetype, checkdigit, angle, barcode)

barheight = 1000
barcode = "QRコードサンプル"
barsize = CStr(JV_QR_LEVEL_M) & "," & CStr(JV_QR_TYPE_AUTO) & "," & CStr(JV_QR_MASKNO_AUTO)
codetype = JV_BAR_QR
ret = Jvr.DrawBarcode(1000, 1500, barheight, barsize, 0, codetype, 0, 0, barcode)

barheight = 800
barcode = "マイクロQR"
barsize = CStr(JV_QR_LEVEL_Q) & "," & CStr(JV_QR_TYPE_AUTO) & "," & CStr(JV_QR_MASKNO_AUTO)
codetype = JV_BAR_MICROQR
angle = JV_ANGLE180
ret = Jvr.DrawBarcode(3000, 15000, barheight, barsize, 0, codetype, 0, angle, barcode)

barheight = 800
barcode = "PDF417"
barsize = CStr(JV_PDF417_ERROR_AUTO) & "," & CStr(2) & "," & CStr(20) & "," & CStr(50)
codetype = JV_BAR_PDF417
angle = JV_ANGLE0
ret = Jvr.DrawBarcode(5000, 15000, barheight, barsize, 0, codetype, 0, angle, barcode)

barheight = 1000
barcode = "MicroPDF417"
barsize = CStr(JV_MICROPDF417_SIZE_2X23) & "," & CStr(70)
codetype = JV_BAR_MICROPDF417
angle = JV_ANGLE90
ret = Jvr.DrawBarcode(10000, 15000, barheight, barsize, 0, codetype, 0, angle, barcode)


DrawBoxメソッド

四角形を描画します。

[構文]

レポートライブラリOCX

Object.DrawBox (sx, sy, ex, ey, round, roundptr)

レポートライブラリ.NETコントロール

long Object.DrawBox (sx, sy, ex, ey, round, roundptr)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 四角形の左上Ｘ座標(1/100mm単位)
sy | long | 四角形の左上Ｙ座標(1/100mm単位)
ex | long | 四角形の右下Ｘ座標(1/100mm単位)
ey | long | 四角形の右下Ｙ座標(1/100mm単位)
round | long | 角丸め半径(1/100mm単位)
roundptr | long | 角丸め位置（設定値参照）

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください

[設定値]

roundptr には次の値を指定します。複数指定する場合はORで連結します。

定数 | 値 | 内容
JV_ROUND_LT | 1 | 左上
JV_ROUND_RT | 2 | 右上
JV_ROUND_LB | 3 | 左下
JV_ROUND_RB | 4 | 右下

[解説]

round に0を指定すると角は丸められません。
四角形のプロパティは、 L ineWidthプロパティ（線の幅）、LineStyleプロパティ（線の種類）、FillPatternプロパティ（塗り潰しパターン）、OutLineプロパティ（輪郭線）を使って設定します。 各プロパティは、改ページでページが変わった時には再設定が必要です。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

Jvr.OutLine = JV_OUTLINE_OFF | '輪郭線なし
Jvr.LineWidth = 1 | '線の幅を1/100ｍｍにする
rsize = 300 | '角丸めサイズ
rptr = JV_ROUND_LT Or JV_ROUND_RB | '角丸め位置（左上、右下）
Jvr.DrawBox(500, 1000, 3000, 4000, rsize, rptr)

レポートライブラリ.NETコントロール
Jvr.OutLine = JV_OUTLINE_OFF | '輪郭線なし
Jvr.LineWidth = 1 | '線の幅を1/100ｍｍにする
rsize = 300 | '角丸めサイズ
rptr = JV_ROUND_LT Or JV_ROUND_RB | '角丸め位置（左上、右下）
ret = Jvr.DrawBox(500, 1000, 3000, 4000, rsize, rptr)


DrawEllipseメソッド

円・楕円を描画します。

[構文]

レポートライブラリOCX

Object.DrawEllipse (sx, sy, ex, ey)

レポートライブラリ.NETコントロール

long Object.DrawEllipse (sx, sy, ex, ey)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 外接する四角形の左上Ｘ座標(1/100mm単位)
sy | long | 外接する四角形の左上Ｙ座標(1/100mm単位)
ex | long | 外接する四角形の右下Ｘ座標(1/100mm単位)
ey | long | 外接する四角形の右下Ｙ座標(1/100mm単位)

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください

[解説]

円・楕円のプロパティは、 L ineWidthプロパティ（線の幅）、LineStyleプロパティ（線の種類）、FillPatternプロパティ（塗り潰しパターン）、OutLineプロパティ（輪郭線）を使って設定します。 各プロパティは、改ページでページが変わった時には再設定が必要です。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX
Jvr.FillPattern = JV_FILL_SOLID | '前景色で塗り潰し
Jvr.OutLine = JV_OUTLINE_ON | '輪郭線あり
Jvr.LineStyle = JV_PS_DOT | '点線
Jvr.DrawEllipse(3000, 1000, 4000, 2500) |

レポートライブラリ.NETコントロール
Jvr.FillPattern = JV_FILL_SOLID | '前景色で塗り潰し
Jvr.OutLine = JV_OUTLINE_ON | '輪郭線あり
Jvr.LineStyle = JV_PS_DOT | '点線
ret = Jvr.DrawEllipse(3000, 1000, 4000, 2500) |


DrawFormメソッド

フォームとフィールドを描画します。

[構文]

レポートライブラリOCX

Object.DrawForm

レポートライブラリ.NETコントロール

long Object.DrawForm ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]

値 | 内容
1005 | フォーム描画エラー
1029 | Startを行ってください
1124 | Adobe PDF形式のデータに埋め込めないフォントがある
1125 | Adobe PDF形式のデータにフォントを埋め込めない文字コードがある

[解説]

DrawFormメソッドは固定フォーム専用のメソッドです。可変フォームでは使用できません。
描画する部分（フォームのみ／フィールドのみ／フォームとフィールド）を指定する時は、DrawFormModeプロパティを使います。

1124エラーと1125エラーは、Adobe PDF形式のデータを作成中に起こるエラーです。EmbedFont メソッドで、フォントの埋め込みが設定されている場合に発生します。描画に使用したフォントを全て埋め込む指定にした時、埋め込めないフォントが見つかると、1124エラーが発生します。原因となったフォント名は、エラーメッセージから取得することができます。1125エラーは、埋め込むことができない文字コードが見つかった時に発生します。原因となった文字コードは、エラーメッセージから取得することができます。

－Adobe PDF形式データへフォントを埋め込む

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

On Error Resume Next
Jvr.DrawForm

'エラー処理
if Err.Number = 1125 then
chrCode = Jvr.LastDllError
end if

レポートライブラリ.NETコントロール

errCode = Jvr.DrawForm ()

'エラー処理
if errCode = 1125 then
chrCode = Jvr.LastDllError
end if


DrawGraphメソッド

グラフを描画します。

[構文]

レポートライブラリOCX

Object.DrawGrap (graphtype, sx, sy, width, height, data, fontinfo, numinfo, info1, info2)

レポートライブラリ.NETコントロール

long Object.DrawGraph (graphtype, sx, sy, width, height, data, fontinfo, numinfo, info1, info2)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
graphtype | long | グラフの種類（設定値参照）
sx | long | 描画する左上Ｘ座標(1/100mm単位)
sy | long | 描画する左上Ｙ座標(1/100mm単位)
width | string | 描画する領域の幅(1/100mm単位)
height | long | 描画する領域の高さ(1/100mm単位)
data | string | 描画するグラフデータ
fontinfo | string | 文字描画に使用するフォント情報
numinfo | string | 数値軸情報
info1 | string | データ系列情報または散布図Ｘ軸情報
info2 | string | 項目情報または散布図情報

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください
1124 | Adobe PDF形式データに埋め込めないフォントがある
1125 | Adobe PDF形式データにフォントを埋め込めない文字コードがある

[設定値]

graphtype には次の値を指定します。

定数 | 値 | 内容
JV_GRAPH_COL | 1 | ２Ｄ横棒グラフ
JV_GRAPH_BAR | 2 | ２Ｄ縦棒グラフ
JV_GRAPH_PIE | 3 | 円グラフ
JV_GRAPH_RADAR | 4 | レーダーグラフ
JV_GRAPH_AREA | 5 | 面グラフ
JV_GRAPH_SCATTER | 6 | 散布図グラフ
JV_GRAPH_LINE | 7 | 折れ線グラフ

ポイント種には次の値を指定します。

定数 | 値 | 内容
JV_POINT_NONE | 0 | なし
JV_POINT_BOX | 1 | 四角形
JV_POINT_CIRCLE | 2 | 円
JV_POINT_TRIANGLE1 | 3 | 三角形
JV_POINT_TRIANGLE2 | 4 | 逆三角形
JV_POINT_LOZENGE | 5 | ひし形

塗り潰しパターには次の値を指定します。

定数 | 値 | 内容
JV_FILL_NULL | 0 | 塗り潰しなし
JV_FILL_SOLID | 1 | 前景色で塗り潰し（初期値）
JV_FILL_DKGRAY | 2 | 濃い灰色
JV_FILL_GRAY | 3 | 灰色
JV_FILL_LTGRAY | 4 | 薄い灰色
JV_FILL_WHITE | 5 | 白
JV_FILL_FDIAGONAL | 6 | 45度右上がりハッチ
JV_FILL_BDIAGONAL | 7 | 45度右下がりハッチ
JV_FILL_HORIZONTAL | 8 | 水平ハッチ
JV_FILL_VERTICAL | 9 | 垂直ハッチ
JV_FILL_CROSS | 10 | 水平と垂直のクロスハッチ
JV_FILL_DIAGCROSS | 11 | 45度のクロスハッチ
JV_FILL_BLACK | 12 | 黒

線種には次の値を指定します。

定数 | 値 | 内容
JV_PS_SOLID | 0 | 実線 （初期値）
JV_PS_DASH | 1 | 破線
JV_PS_DOT | 2 | 点線
JV_PS_DASHDOT | 3 | 一点鎖線
JV_PS_DASHDOTDOT | 4 | 二点鎖線

[解説]

1124エラーと1125エラーは、Adobe PDF形式のデータを作成中に発生するエラーです。これらのエラーは、EmbedFont メソッドでフォントの埋め込みが設定されている場合に発生します。 1124エラーは、fontinfo で指定したフォントの中に埋め込むことができないフォントが見つかった時に発生します。このエラーは、描画に使われている全てのフォントを埋め込むようにEmbedFont メソッドで指定した場合に起こります。エラーの原因となったフォント名は、エラーが発生した時のエラーメッセージから取得することができます。1125エラーは、埋め込むことができない文字コードが見つかった時に発生します。エラーの原因となった文字コードは、エラーが発生した時のエラーメッセージから取得することができます。

－Adobe PDF形式データへフォントを埋め込む

data には、データ間をカンマで区切った値を指定します。データには整数を使用してください。小数を設定しても切り捨てられて整数となります。散布図では、Info2 のデータ倍率と組み合わせて小数を表現することができます。

fontinfo には、データ間をカンマで区切った値を指定します。データは「数値軸のフォント名、数値軸のフォントサイズ、info1 のフォント名、info1 のフォントサイズ、info2 のフォント名、info2 のフォントサイズ」の順番で指定します。フォントサイズの単位はポイントです。

numinfo には、データ間をカンマで区切った値を指定します。データは、「最小値、最大値、増分、目盛色、単位、凡例」の順番で指定します。ここで指定した最小値と最大値は、そのまま、数値軸の最小値と最大値となります。増分は、数値軸の最小値から最大値間の目盛のスキップ分となります。目盛色とは、目盛を描画する文字の色のことで、RGB値で指定します。単位とは、最大値の上側に、そのまま表示される文字列です。凡例には、表示（1）、非表示（0）を指定します。

データ系列情報または散布図Ｘ軸情報
info1 は、グラフの種類が散布図以外の場合はデータ系列情報として扱われ、散布図の場合はＸ軸情報として扱われます。info1 には、データ間をカンマで区切った値を指定します。

info1 をデータ系列情報として使う場合、データは「系列名称、前景色、背景色、名称色、塗り潰しパターン、線種、ポイント種」の順番で、先頭から、データ系列の数分、繰り返して指定します。系列名称とは、グラフに表示されるデータ系列の名称です。前景色と背景色は、グラフデータを描画する図形の色で、RGB値で指定します。名称色とは、系列名称を描画する文字の色で、RGB値で指定します。塗り潰しパターンは、グラフデータを描画する図形の塗り潰しパターンとなります。線種は、グラフデータを描画する図形の線の種類となります。ポイント種は、折れ線グラフのポイント地点を示す図形の種類となります。

info1 をＸ軸情報として使う場合、データは「最小値、最大値、増分、目盛色、単位」の順番で指定します。最小値と最大値は、X軸の最小値と最大値になります。増分は数値軸の最小値から最大値間の目盛のスキップ分になります。目盛色とは、目盛を描画する文字の色で、RGB値で指定します。単位とは、最大値の横側にそのまま表示される文字列です。

項目情報または散布図情報
Info2 は、グラフの種類が散布図以外の場合は項目情報として扱われ、散布図の場合は散布図情報として扱われます。nfo2 は、項目情報や散布図情報が必要な場合のみ指定します。Info2 には、データ間をカンマで区切った値を指定します。

項目情報が未設定の場合は、系列情報が軸となります。Info2 が項目情報として指定された場合は、系列情報が凡例として表示され、項目情報が軸となります。データは「項目名称、名称色」の順番で、先頭から、項目の数分繰り返して指定します。項目名称は項目の名称として表示されます。名称色とは、項目名称を描画する文字色で、RGB値で指定します。

Info2 を散布図情報として使う場合、データは「ポイント種、ポイント色、データ倍率」の順番で指定します。ポイント種とは、データのポイントを表わす図形の形になります。ポイント色とは、ポイント種を描画する色で、RGB値で指定します。データ倍率は、data に設定した整数の値を少数にする場合に使います。データ倍率に10を指定すると、data の値は1/10倍され、100を指定すると1/100倍されます。data の値が整数の場合は、データ倍率には１を指定します。例えば1.58という値を設定する時には、data に158を指定し、データ倍率に100を指定します。こうしておくと、レポートライブラリが158を1/100倍してグラフを描画します。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

''横棒グラフの描画
graphtype = JV_GRAPH_COL '２Ｄ横棒グラフ
numInfo = "0,100,10," + CStr(RGB(0, 0, 0)) + ",mm, 1" '数値軸情報
fontInfo = "ＭＳ 明朝,8,ＭＳ 明朝,8,ＭＳ ゴシック,8" 'フォント情報
'データ系列情報
info1 = "名古屋," + CStr(RGB(255, 0, 0)) + "," + CStr(RGB(255, 255, 255)) _
+ "," + CStr(RGB(255, 0, 0)) + "," + CStr(JV_FILL_FDIAGONAL) + "," _
+ CStr(JV_PS_SOLID) + "," + CStr(JV_POINT_BOX) + _
",東京," + CStr(RGB(0, 255, 0)) + "," + CStr(RGB(255, 255, 255)) _
+ "," + CStr(RGB(0, 255, 0)) + "," + CStr(JV_FILL_BDIAGONAL) + "," _
+ CStr(JV_PS_DASH) + "," + CStr(JV_POINT_CIRCLE) + _
",大阪," + CStr(RGB(0, 0, 255)) + "," + CStr(RGB(255, 255, 255)) _
+ "," + CStr(RGB(0, 0, 255)) + "," + CStr(JV_FILL_CROSS) + "," _
+ CStr(JV_PS_DASHDOT) + "," + CStr(JV_POINT_TRIANGLE1)
'項目情報
info2 = "1996," + CStr(RGB(255, 0, 0)) + _
",1997," + CStr(RGB(0, 255, 0)) + _
",1998," + CStr(RGB(0, 0, 255))
'グラフデータ
graphdata = "20,12,33,45,-5,58,67,25,41"
Jvr.DrawGraph(graphtype, 500, 0, 8000, 3500, _
graphdata, fontInfo, numInfo, info1, info2)

レポートライブラリ.NETコントロール

''横棒グラフの描画
graphtype = JV_GRAPH_COL '２Ｄ横棒グラフ
numInfo = "0,100,10," + CStr(RGB(0, 0, 0)) + ",mm, 1" '数値軸情報
fontInfo = "ＭＳ 明朝,8,ＭＳ 明朝,8,ＭＳ ゴシック,8" 'フォント情報
'データ系列情報
info1 = "名古屋," + CStr(RGB(255, 0, 0)) + "," + CStr(RGB(255, 255, 255)) _
+ "," + CStr(RGB(255, 0, 0)) + "," + CStr(JV_FILL_FDIAGONAL) + "," _
+ CStr(JV_PS_SOLID) + "," + CStr(JV_POINT_BOX) + _
",東京," + CStr(RGB(0, 255, 0)) + "," + CStr(RGB(255, 255, 255)) _
+ "," + CStr(RGB(0, 255, 0)) + "," + CStr(JV_FILL_BDIAGONAL) + "," _
+ CStr(JV_PS_DASH) + "," + CStr(JV_POINT_CIRCLE) + _
",大阪," + CStr(RGB(0, 0, 255)) + "," + CStr(RGB(255, 255, 255)) _
+ "," + CStr(RGB(0, 0, 255)) + "," + CStr(JV_FILL_CROSS) + "," _
+ CStr(JV_PS_DASHDOT) + "," + CStr(JV_POINT_TRIANGLE1)
'項目情報
info2 = "1996," + CStr(RGB(255, 0, 0)) + _
",1997," + CStr(RGB(0, 255, 0)) + _
",1998," + CStr(RGB(0, 0, 255))
'グラフデータ
graphdata = "20,12,33,45,-5,58,67,25,41"
ret = Jvr.DrawGraph(graphtype, 500, 0, 8000, 3500, _
graphdata, fontInfo, numInfo, info1, info2)


DrawImageメソッド

BMP、DIB、JPEG、TIFF、PNG、EMF形式のイメージファイルを描画します。

[構文]

レポートライブラリOCX

Object.DrawImage (sx, sy, ex, ey, dpi, backmode, image)

レポートライブラリ.NETコントロール

long Object.DrawImage (sx, sy, ex, ey, dpi, backmode, image)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 描画する領域の左上Ｘ座標(1/100mm単位)
sy | long | 描画する領域の左上Ｙ座標(1/100mm単位)
ex | long | 描画する領域の右下Ｘ座標(1/100mm単位)
ey | long | 描画する領域の右下Ｙ座標(1/100mm単位)
dpi | long | 解像度(0～10000)
backmode | long | 透過モード（設定値参照）
image | string | イメージファイル名

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください

[設定値]

backmodeには次の値を指定します。

定数 | 値 | 内容
JV_TRANSPARENT | 1 | 透過
JV_OPAQUE | 2 | 上書き

[解説]

dpi を０にすると、イメージは sx、sy、ex、ey のサイズで描画されます。
image には、イメージファイルをフルパスで指定します。 ImagePathプロパティを使ってイメージを検索するパスを設定することもできます。

StartメソッドとEnd（Abort）メソッドの間で実行します。

DrawImageメソッドは、イメージファイルを描画する時に使います。
メモリ上に読み込まれたイメージデータを描画する時は、DrawImageDataメソッドを使います。

－対応イメージ形式

[コーディング例]

レポートライブラリOCX

''イメージの描画
imgDpi = 0 '枠サイズ指定
backmode = JV_OPAQUE '上書き
imgFileName = "cup.dib"
Jvr.DrawImage(500, 1200, 4000, 4000, imgDpi, backmode, imgFileName)

imgDpi = 200 '200DPI
backmode = JV_TRANSPARENT '透過
imgFileName = "cup.jpeg"
Jvr.DrawImage(3500, 1200, 0, 0, imgDpi, backmode, imgFileName)

レポートライブラリ.NETコントロール

''イメージの描画
imgDpi = 0 '枠サイズ指定
backmode = JV_OPAQUE '上書き
imgFileName = "cup.dib"
Jvr.DrawImage(500, 1200, 4000, 4000, imgDpi, backmode, imgFileName)

imgDpi = 200 '200DPI
backmode = JV_TRANSPARENT '透過
imgFileName = "cup.jpeg"
ret = Jvr.DrawImage(3500, 1200, 0, 0, imgDpi, backmode, imgFileName)


DrawImageDataメソッド

BMP、DIB、JPEG、TIFF、PNG、EMF形式のイメージデータを描画します。

[構文]

レポートライブラリOCX

Object.DrawImageData (sx, sy, ex, ey, dpi, backmode, image, imagelength, imagedata)

レポートライブラリ.NETコントロール

long Object.DrawImageData (sx, sy, ex, ey, dpi, backmode, image, imagelength, imagedata)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 描画する領域の左上Ｘ座標(1/100mm単位)
sy | long | 描画する領域の左上Ｙ座標(1/100mm単位)
ex | long | 描画する領域の右下Ｘ座標(1/100mm単位)
ey | long | 描画する領域の右下Ｙ座標(1/100mm単位)
dpi | long | 解像度(0～10000)
backmode | long | 透過モード（設定値参照）
imagelength | long | イメージデータの長さ（バイト数）
imagedata | Byte配列 | イメージデータ

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください
1132 | イメージデータエラー

[設定値]

backmodeには次の値を指定します。

定数 | 値 | 内容
JV_TRANSPARENT | 1 | 透過
JV_OPAQUE | 2 | 上書き

[解説]

dpi を０にすると、イメージは sx、sy、ex、ey のサイズで描画されます。
imagedata には、Byte配列型変数を使用します。

StartメソッドとEnd（Abort）メソッドの間で実行します。

DrawImageDataメソッドは、メモリ上に読み込まれたイメージデータを描画する時に使います。
ファイルに保存されたイメージを描画する時は、DrawImageメソッドを使います。

－対応イメージ形式

※ヘルプの「アプリケーション開発／イメージをデータ形式で設定」に言語ごとのコーディングサンプルがあります。

[コーディング例]

レポートライブラリ.NETコントロール

Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte
Dim imgDpiAs Long
Dim backmodeAs Long
Dim imageFileName As String

imgDpi = 0 '枠サイズ指定
backmode = JV_OPAQUE '上書き
imageFileName = "c:\images\cup.dib"
fileNo = FreeFile 'ファイル番号取得
Open imageFileName For Binary As #fileNo 'ファイルオープン
imageLength = FileLen(imgFileName)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo
Call Jvrlib.DrawImageData(10000, 7700, 13500, 10500, imgDpi, backmode, imageLength, imageData)

レポートライブラリ.NETコントロール

Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte
Dim imgDpiAs Long
Dim backmodeAs Long
Dim imageFileName As String

imgDpi = 0 '枠サイズ指定
backmode = JV_OPAQUE '上書き
imageFileName = "c:\images\cup.dib"
fileNo = FreeFile 'ファイル番号取得
Open imageFileName For Binary As #fileNo 'ファイルオープン
imageLength = FileLen(imgFileName)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo
ret = Jvrlib.DrawImageData(10000, 7700, 13500, 10500, imgDpi, backmode, imageLength, imageData)


DrawLineメソッド

直線を描画します。

[構文]

レポートライブラリOCX

Object.DrawLine (sx, sy, ex, ey)

レポートライブラリ.NETコントロール

long Object.DrawLine (sx, sy, ex, ey)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 描画開始Ｘ座標(1/100mm単位)
sy | long | 描画開始Ｙ座標(1/100mm単位)
ex | long | 描画終了Ｘ座標(1/100mm単位)
ey | long | 描画終了Ｙ座標(1/100mm単位)

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください

[解説]

直線のプロパティは、 L ineWidthプロパティ（線の幅）、LineStyleプロパティ（線の種類）を使って設定します。 各プロパティは、改ページでページが変わった時には再設定が必要です。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

''直線の描画
Jvr.DrawLine(500, 1000, 3000, 4000)

レポートライブラリ.NETコントロール

''直線の描画
ret = Jvr.DrawLine(500, 1000, 3000, 4000)


DrawPolygonメソッド

多角形を描画します。

[構文]

レポートライブラリOCX

Object.DrawPolygon (close, mode, points)

レポートライブラリ.NETコントロール

long Object.DrawPolygon (close, mode, points)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
close | long | 多角形の種類（設定値参照）
mode | long | 線の種類（設定値参照）
points | string | 描画する多角形の座標(1/100mm単位)

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください

[設定値]

close には次の値を指定します。

定数 | 値 | 内容
JV_POLY_CLOSE | 1 | 閉じる
JV_POLY_OPEN | 0 | 閉じない

modeには次の値を指定します。

定数 | 値 | 内容
JV_POLYGON | 1 | 直線
JV_BEZIER | 0 | 曲線

[解説]

points には、座標をＸＹの順に、データ間をカンマで区切って指定します。
多角形のプロパティは、 L ineWidthプロパティ（線の幅）、LineStyleプロパティ（線の種類）、FillPatternプロパティ（塗り潰しパターン）、OutLineプロパティ（輪郭線）を使って設定します。 各プロパティは、改ページでページが変わった時には再設定が必要です。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

''ベジェ曲線に囲まれた図形の描画
Jvr.FrColor = RGB(128, 128, 0) '前景色
Jvr.BkColor = RGB(128, 255, 0) '背景色
Jvr.FillPattern = 39 '塗り潰しパターン
polymode = JV_BEZIER
pclose = JV_POLY_CLOSE
polypoint = "1000,4000,2000,4000,2500,4500,2000,5000,1000,5000"
Jvr.DrawPolygon(pclose, polymode, polypoint)

''ベジェ曲線を描画
Jvr.FrColor = RGB(0, 0, 0) '前景色
Jvr.LineWidth = 100 '線の幅を1ｍｍにする
pclose = JV_POLY_OPEN
polypoint = "5000,4000,6000,4000,6500,4500,6000,5000,5000,5000"
Jvr.DrawPolygon(pclose, polymode, polypoint)

レポートライブラリ.NETコントロール

''ベジェ曲線に囲まれた図形の描画
Jvr.FrColor = RGB(128, 128, 0) '前景色
Jvr.BkColor = RGB(128, 255, 0) '背景色
Jvr.FillPattern = 39 '塗り潰しパターン
polymode = JV_BEZIER
pclose = JV_POLY_CLOSE
polypoint = "1000,4000,2000,4000,2500,4500,2000,5000,1000,5000"
ret = Jvr.DrawPolygon(pclose, polymode, polypoint)

''ベジェ曲線を描画
Jvr.FrColor = RGB(0, 0, 0) '前景色
Jvr.LineWidth = 100 '線の幅を1ｍｍにする
pclose = JV_POLY_OPEN
polypoint = "5000,4000,6000,4000,6500,4500,6000,5000,5000,5000"
ret = Jvr.DrawPolygon(pclose, polymode, polypoint)


DrawSectionメソッド

可変フォームのセクションを描画します。

[構文]

レポートライブラリOCX

Object.DrawSection

レポートライブラリ.NETコントロール

long Object.DrawSection ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]

値 | 内容
1131 | 正常終了。改ページ要求
1029 | Startを行ってください
1126 | セクション描画エラー

[解説]

DrawSectionメソッドは可変フォーム専用のメソッドです。固定フォームでは使用できません。

描画するセクションは、SectionKeyプロパティで指定します。
セクションを描画すると、CurrentTopプロパティの値が、描画したセクションの高さ分だけ加算されます。

StartメソッドとEnd（Abort）メソッドの間で実行します。

セクションを正常に描画した後、同じセクションを描画する領域が残っていない場合には、1131のエラーが発生します。1131のエラーが発生した場合には、改ページや、セクションの変更が必要です。

DrawSectionメソッドを実行した時に、指定したセクションが残っている描画領域に入らない場合には、1126エラーが発生します。このエラーが起こると、フィールドにセットされたデータはクリアされるため、データの再セットが必要です。

※ヘルプの「アプリケーション開発／改ページ要求エラー処理」に言語ごとのコーディングサンプルがあります。

[コーディング例]

レポートライブラリOCX
On Error Resume Next |
Call Jvrlib.DrawSection |
If Err.Number = 1131 Then Jvrlib.NewPage | '改ページエラーの場合は改ページ

レポートライブラリ.NETコントロール
On Error Resume Next |
ret = Jvrlib.DrawSection () |
If ret = 1131 Then ret = Jvrlib.NewPage() | '改ページエラーの場合は改ページ


DrawTextメソッド

文字列を描画します。

[構文]

レポートライブラリOCX

Object.DrawText (sx, sy, ex, ey, charpitch, linepitch, format, angle, linefeed, kinsoku, wordlap, text)

レポートライブラリ.NETコントロール

long Object.DrawText (sx, sy, ex, ey, charpitch, linepitch, format, angle, linefeed, kinsoku, wordlap, text)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
sx | long | 先頭文字の左上Ｘ座標(1/100mm単位)
sy | long | 先頭文字の左上Ｙ座標(1/100mm単位)
ex | long | 文字を編集する領域の右下Ｘ座標(1/100mm単位)
ey | long | 文字を編集する領域の右下Ｙ座標(1/100mm単位)
charpitch | long | 文字と文字の間のピッチ(ポイント単位)
linepitch | long | 行と行の間のピッチ(ポイント単位)
format | long | 文字編集（設定値参照）
angle | long | 文字列の描画方向（設定値参照）
linefeed | long | 文字列の改行方向（設定値参照）
kinsoku | long | 禁則処理（設定値参照）
wordlap | long | 英文ワードラップ（設定値参照）
text | string | 描画文字列

[エラーコード]

値 | 内容
1011 | 描画エラー
1029 | Startを行ってください
1125 | Adobe PDF形式のデータにフォントを埋め込めない文字コードがある

[設定値]

format には次の値を指定します。

定数 | 値 | 内容
JV_TEXT_LEFT | 0 | 左寄せ
JV_TEXT_RIGHT | 1 | 右寄せ
JV_TEXT_CENTER | 2 | 中央揃え
JV_TEXT_EVEN | 3 | 均等割付

angle には次の値を指定します。

定数 | 値 | 内容
JV_ANGLE0 | 0 | 左→右
JV_ANGLE90 | 1 | 上→下
JV_ANGLE180 | 2 | 右→左
JV_ANGLE270 | 3 | 下→上

linefeed には次の値を指定します。

定数 | 値 | 内容
JV_LF_U2D | 0 | 右から左（上から下）
JV_LF_D2U | 1 | 左から右（下から上）
JV_LF_NULL | 2 | 改行なし（シングルライン）

kinsoku には次の値を指定します。

定数 | 値 | 内容
JV_KINSOKU_OFF | 0 | 禁則処理を行なわない
JV_KINSOKU_ON | 1 | 禁則処理を行なう

wordlap には次の値を指定します。

定数 | 値 | 内容
JV_WORDLAP_OFF | 0 | 英文ﾜｰﾄﾞﾗｯﾌﾟを行なわない
JV_WORDLAP_ON | 1 | 英文ﾜｰﾄﾞﾗｯﾌﾟを行なう

[解説]

文字のプロパティは、F ontName プロパティ（フォント名）、FontSize プロパティ（フォントサイズ）、FontScale プロパティ（フォント拡大縮小率）、FontItalic プロパティ（イタリック）、FontBold プロパティ（太字）、FontAngle プロパティ（文字回転）を使って設定します。 各プロパティは、改ページでページが変わった時には再設定が必要です。
描画文字列には、外字、UNICODEやサロゲートペアの文字を使用することができます。UNICODEやサロゲートペアの文字を使用する場合は、CharacterSetプロパティでUNICODEを指定します。

1125エラーは、Adobe PDF形式のデータを作成中に起こるエラーです。EmbedFont メソッドで、フォントの埋め込みが設定されている場合、 text で指定された文字列中に、埋め込むことができない文字コードが見つかると、1125エラーが発生します。原因となった文字コードは、エラーメッセージから取得することができます。

－Adobe PDF形式データへフォントを埋め込む

StartメソッドとEnd（Abort）メソッドの間で実行します。

－外字の描画
－UNICODEの使用
－ サロゲートペア

[コーディング例]

レポートライブラリOCX

''文字列の描画
charpitch = 0
linepitch = 0
tformat = JV_TEXT_LEFT
tangle = JV_ANGLE0
linefeed = JV_LF_U2D
kinsoku = JV_KINSOKU_ON
wordlap = JV_WORDLAP_ON
text = "DrawTextはﾚﾎﾟｰﾄﾗｲﾌﾞﾗﾘからの文字描画ﾒｿｯﾄﾞです。"
Jvr.DrawText(2500, 7500, 9000, 10000, charpitch, linepitch, tformat, _
tangle, linefeed, kinsoku, wordlap, text)

レポートライブラリ.NETコントロール

''文字列の描画
charpitch = 0
linepitch = 0
tformat = JV_TEXT_LEFT
tangle = JV_ANGLE0
linefeed = JV_LF_U2D
kinsoku = JV_KINSOKU_ON
wordlap = JV_WORDLAP_ON
text = "DrawTextはﾚﾎﾟｰﾄﾗｲﾌﾞﾗﾘからの文字描画ﾒｿｯﾄﾞです。"
ret = Jvr.DrawText(2500, 7500, 9000, 10000, charpitch, linepitch, tformat, _
tangle, linefeed, kinsoku, wordlap, text)


EmbedFontメソッド

Adobe PDF形式のデータの中に埋め込むフォントを設定します。

[構文]

レポートライブラリOCX

Object.EmbedFont (fontname)

レポートライブラリ.NETコントロール

long Object.EmbedFont (fontname)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fontname | string | フォント名

[エラーコード]

値 | 内容
1124 | Adobe PDF形式のデータに埋め込めないフォントがある
1029 | Startを行ってください

[解説]

EmbedFontメソッドは、Adobe PDF形式のデータの中にフォントを埋め込む時に使います。
埋め込むことができるフォントは、True Typeフォントのみです。
EmbedFontメソッドで指定しなかったフォントは、データ中に埋め込まれません。
描画に使ったすべてのフォントを埋め込む場合は、fontname に * を指定します。

Adobe PDF形式のデータを作成する環境に、指定したフォントファイルがない場合には、1124エラーが発生します。指定したフォントがTrue Typeフォントではない場合にも、1124エラーが発生します。エラーの原因となったフォント名は、エラーメッセージで取得することができます。

埋め込むフォントの設定は、EmbedFontメソッドをコールする前に行います。
EmbedFontメソッドは、Startメソッドの前で実行してください。

－Adobe PDF形式データにフォントを埋め込む
－Adobe PDF形式データの制限

[コーディング例]

レポートライブラリOCX
Call Jvrlib.EmbedFont("MS 明朝") | 'MS明朝埋め込み
Call Jvrlib.EmbedFont("*") | '全フォント埋め込み
Call Jvrlib.Start |

レポートライブラリ.NETコントロール
ret = Jvrlib.EmbedFont("MS 明朝") | 'MS明朝埋め込み
ret = Jvrlib.EmbedFont("*") | '全フォント埋め込み
ret = Jvrlib.Start() |


Endメソッド

印刷を終了します。

[構文]

レポートライブラリOCX

Object.End

レポートライブラリ.NETコントロール

long Object.End ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]

値 | 内容
1029 | Startを行ってください

[解説]

Endメソッドは、Startメソッドで確保した資源を解放します。Startメソッドを実行した場合は、必ずEndメソッドを実行してください。印刷を中断する時は、Abortメソッドを使います。
Endメソッドの実行前には、必ずNewPageメソッドを実行してください。
「End」が予約語に指定されている開発環境では、「EndDoc」を使用してください。

－基本的なコーディング

[コーディング例]

レポートライブラリOCX

''印刷の終了
Jvr.End

レポートライブラリ.NETコントロール

''印刷の終了
ret = Jvr.End ()


MakeDevFileメソッド

プリンタドライバ設定ファイルを作成します。

[構文]

レポートライブラリOCX

Object.MakeDevFile (filename)

レポートライブラリ.NETコントロール

long Object.MakeDevFile (filename)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
filename | string | プリンタドライバ設定ファイル名

[エラーコード]

値 | 内容
1015 | DEVMODE情報取得エラー

[解説]

プリンタドライバ設定ファイルを作成するプリンタは、PrinterName プロパティで設定します。プリンタは、MakeDevFileメソッドをコールする前に指定しておきます。プリンタが指定されなかった場合には、デフォルトのプリンタ（通常つかうプリンタ）が使われます。

MakeDevFileメソッドを実行すると、指定したプリンタの印刷ダイアログがポップアップします。印刷ダイアログ上で、プロパティを設定し終了（OK）ボタンを押すと、プリンタドライバ設定ファイルが作成されます。
作成したプリンタドライバ設定ファイルは、PrinterDevMode プロパティで使用します。

MakeDevFileメソッドは、StartメソッドからEndメソッド間で使用する必要はなく、単独で使用することができます。
作成したプリンタドライバ設定ファイルは、作成したプリンタ以外では使用できません。

[コーディング例]

レポートライブラリOCX

Jvr.PrinterName = "Canon LBP740"
Jvr.MakeDevFile("c:\prndev.bin")

レポートライブラリ.NETコントロール

ret = Jvr.PrinterName = "Canon LBP740"
ret = Jvr.MakeDevFile("c:\prndev.bin")


NewPageメソッド

改ページします。

[構文]

レポートライブラリOCX

Object.NewPage

レポートライブラリ.NETコントロール

long Object.NewPage ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]

値 | 内容
1003 | 改ページエラー
1029 | Startを行ってください
1048 | スプール用ディスク不足
1049 | スプール用メモリ不足
1050 | ENDPAGEエラー

[解説]

StartメソッドとEnd（Abort）メソッドの間で実行します。

－基本的なコーディング

[コーディング例]

レポートライブラリOCX

''改ページ
Jvr.NewPage

レポートライブラリ.NETコントロール

''改ページ
ret = Jvr.NewPage()


RefreshPropertiesメソッド

実行中に変更したプロパティをデザイン時の状態に戻します。

[構文]

レポートライブラリOCX

Object.RefreshProperties

レポートライブラリ.NETコントロール

long Object.RefreshProperties ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]

なし

[解説]

実行中に変更したプロパティの値は、Endメソッドを実行してもデザイン時の状態には戻りません。元に戻す時には、RefreshPropertiesメソッドを実行します。

[コーディング例]

レポートライブラリOCX

'プロパティの値をデザイン時に戻す
jvr.RefreshProperties

レポートライブラリ.NETコントロール

'プロパティの値をデザイン時に戻す
ret = jvr.RefreshProperties ()


SetFieldBarcodeメソッド

バーコードフィールドにデータを設定します。

[構文]

レポートライブラリOCX

Object.SetFieldBarcode (fieldname, barcode)

レポートライブラリ.NETコントロール

long Object.SetFieldBarcode (fieldname, barcode)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | バーコードフィールド名
barcode | string | バーコードデータ

[エラーコード]

値 | 内容
1004 | フィールドデータセットエラー
1029 | Startを行ってください
1041 | メモリエラー
1044 | 指定されたフィールドがありません
1045 | 不正なコードがあります
1046 | コード長が不正です

[解説]

barcode の値は、バーコードの種類によって制限があります。
実際に描画されたバーコードはBarcodeプロパティで取得することができます。

StartメソッドとEnd（Abort）メソッドの間で実行します。
各バーコードの詳細は、以下を参照してください。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マクロQRコード
－PDF417コード
－マイクロPDF417コード

[コーディング例]

レポートライブラリOCX

''バーコードフィールドへのデータセット
Jvr.SetFieldBarcode("BAR_JAN13", "453193952125")
Jvr.SetFieldBarcode("BAR_JAN8", "4985327")
Jvr.SetFieldBarcode("BAR_CODE39", "BAR-CODE39")
Jvr.SetFieldBarcode("BAR_NW7", "A12567A")
Jvr.SetFieldBarcode("BAR_ITF", "12345678901")
Jvr.SetFieldBarcode("カスタマバーコード ", "4600011名古屋市中区大須一丁目二十五番二十八号“)

レポートライブラリ.NETコントロール

''バーコードフィールドへのデータセット
ret = Jvr.SetFieldBarcode("BAR_JAN13", "453193952125")
ret = Jvr.SetFieldBarcode("BAR_JAN8", "4985327")
ret = Jvr.SetFieldBarcode("BAR_CODE39", "BAR-CODE39")
ret = Jvr.SetFieldBarcode("BAR_NW7", "A12567A")
ret = Jvr.SetFieldBarcode("BAR_ITF", "12345678901")
ret = Jvr.SetFieldBarcode("カスタマバーコード ", "4600011名古屋市中区大須一丁目二十五番二十八号“)


SetFieldGraphメソッド

グラフフィールドにデータを設定します。

[構文]

レポートライブラリOCX

Object.SetFieldGraph (fieldname, graphdata)

レポートライブラリ.NETコントロール

long Object.SetFieldGraph (fieldname, graphdata)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | グラフフィールド名
graphdata | string | グラフデータ

[エラーコード]

値 | 内容
1004 | フィールドデータセットエラー
1029 | Startを行ってください
1041 | メモリエラー
1044 | 指定されたフィールドがありません

[解説]

graphdata には、データ間をカンマで区切った値を指定します。複数のデータ系列と複数の項目が存在する場合は、「項目１の系列１、項目１の系列２、．．．項目１の系列ｎ、．．．、項目ｎの系列１、項目ｎの系列２、．．．項目ｎの系列ｎ」の順番で指定します。
散布図の場合は、実際のデータを1000倍した値を指定してください。（渡されたデータは内部で1/1000倍されます。これにより、小数点以下のデータも扱うことができます。）データは、1番目のＸ座標、1番目のＹ座標、・、ｎ番目のＸ座標、ｎ番目のＹ座標の順番で指定します。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

''グラフフィールドへのデータセット
graphdata = "350,520,450,750,350,880"
JvrBarField.SetFieldGraph("GRAPH_1", graphdata)

レポートライブラリ.NETコントロール

''グラフフィールドへのデータセット
graphdata = "350,520,450,750,350,880"
ret = JvrBarField.SetFieldGraph("GRAPH_1", graphdata)


SetFieldGridメソッド

グリッドフィールドにデータを設定します。

[構文]

レポートライブラリOCX

Object.SetFieldGrid (fieldname, line, text)

レポートライブラリ.NETコントロール

long Object.SetFieldGrid (fieldname, line, text)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | グリッドフィールド名
line | long | データを設定する行の番号
text | string | 1行分のデータ

[エラーコード]

値 | 内容
1004 | フィールドデータセットエラー
1029 | Startを行ってください
1041 | メモリエラー
1042 | フィールドオーバーフロー
1043 | 編集子が不正です
1044 | 指定されたフィールドがありません

[解説]

SetFieldGridメソッドでは、グリッドフィールドの1行分のデータを設定することができます。2行以上設定する場合は、設定する行の数だけSetFieldGridメソッドを実行してください。
1行に複数の列がある場合は、列データと列データの間を区切り記号で区切ります。区切り記号にはカンマが初期設定されていますが、GridSeparatorプロパティで別の記号に変えることができます。

渡した文字列が、デザイン時に設定した編集子の桁数を超えた場合には、オーバーフローとなります。
オーバーフロー時の処理は、編集子が文字型の場合にはCharOverFlowプロパティ、数値型の場合にはNumOverFlowプロパティを使って設定することができます。

描画文字列には、外字、UNICODEやサロゲートペアの文字を使用することができます。
UNICODEやサロゲートペアの文字を使用する場合には、CharcterSetプロパティでUNICODEを指定しておきます。

StartメソッドとEnd（Abort）メソッドの間で実行します。

－フィールド編集子
－外字の描画
－UNICODEの使用
－ サロゲートペア
－基本的なコーディング

[コーディング例]

レポートライブラリOCX

''グリッドフィールドへのデータセット
text = "営業" + "," + "" + "," + "50000000" + "," + "30000000" + "," + "10000000" + "," + "10000000"
JvrS.SetFieldGrid("所得金額１", 1, text)
text = "農業" + "," + "" + "," + "17000000" + "," + "10000000" + "," + "5000000" + "," + "2000000"
Jvr.SetFieldGrid("所得金額１", 2, text)

レポートライブラリ.NETコントロール

''グリッドフィールドへのデータセット
text = "営業" + "," + "" + "," + "50000000" + "," + "30000000" + "," + "10000000" + "," + "10000000"
ret = JvrS.SetFieldGrid("所得金額１", 1, text)
text = "農業" + "," + "" + "," + "17000000" + "," + "10000000" + "," + "5000000" + "," + "2000000"
ret = Jvr.SetFieldGrid("所得金額１", 2, text)


SetFieldImageメソッド

イメージフィールドにイメージファイル名を設定します。

[構文]

レポートライブラリOCX

Object.SetFieldImage (fieldname, imagefilename)

レポートライブラリ.NETコントロール

long Object.SetFieldImage (fieldname, imagefilename)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | イメージフィールド名
imagefilename | string | イメージファイル名（256バイト以下）

[エラーコード]

値 | 内容
1004 | フィールドデータセットエラー
1029 | Startを行ってください
1041 | メモリエラー
1044 | 指定されたフィールドがありません
1047 | イメージファイルがありません

[解説]

SetFieldImageメソッドは、イメージファイルを描画する時に使います。
メモリ上にあるイメージデータを描画する時は、SetFieldImageDataメソッドを使います。

ImagePathプロパティで、イメージファイルを検索するパスを設定することができます。

StartメソッドとEnd（Abort）メソッドの間で実行します。

－対応イメージ形式

[コーディング例]

レポートライブラリOCX

''イメージフィールドへのデータセット
ImageFile = "cd.dib"
Jvr.SetFieldImage("IMAGE_1", ImageFile)

レポートライブラリ.NETコントロール

''イメージフィールドへのデータセット
ImageFile = "cd.dib"
ret = Jvr.SetFieldImage("IMAGE_1", ImageFile)


SetFieldImageDataメソッド

イメージフィールドにイメージデータを設定します。

[構文]

レポートライブラリOCX

Object.SetFieldImageData (fieldname, imagelength, imagedata)

レポートライブラリ.NETコントロール

long Object.SetFieldImageData (fieldname, imagelength, imagedata)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | イメージフィールド名
imagelength | long | イメージデータの長さ(バイト数)
imagedata | Byte配列 | イメージデータ

[エラーコード]

値 | 内容
1029 | Startを行ってください
1041 | メモリエラー
1044 | 指定されたフィールドがありません
1071 | パラメータエラー
1132 | イメージデータエラー

[解説]

SetFieldImageData メソッドは、メモリ上にあるイメージデータを描画する時に使います。
ファイルに保存されたイメージを描画する場合は、SetFieldImageメソッドを使います。

imagedata には、Byte配列型変数を使用します。

StartメソッドとEnd（Abort）メソッドの間で実行します。

－対応イメージ形式

※ヘルプの「アプリケーション開発／イメージをデータ形式で設定」に言語ごとのコーディングサンプルがあります。

[コーディング例]

レポートライブラリOCX

Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte
Dim imageFileName As String

imageFileName = "c:\images\cup.dib"
fileNo = FreeFile 'ファイル番号取得
Open imageFileName For Binary As #fileNo 'ファイルオープン
imageLength = FileLen(imgFileName)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo
Call Jvrlib.SetFieldImageData("IMAGE_2", imageLength, imageData)

レポートライブラリ.NETコントロール

Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte
Dim imageFileName As String

imageFileName = "c:\images\cup.dib"
fileNo = FreeFile 'ファイル番号取得
Open imageFileName For Binary As #fileNo 'ファイルオープン
imageLength = FileLen(imgFileName)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo
ret = Jvrlib.SetFieldImageData("IMAGE_2", imageLength, imageData)


SetFieldLongメソッド

テキストフィールド、グリッドフィールドの各種プロパティを設定します。

[構文]

レポートライブラリOCX

Object.SetFieldLong (fieldname, mode, lval)

レポートライブラリ.NETコントロール

long Object.SetFieldLong (fieldname, mode, lval)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | プロパティを設定するフィールド名
mode | long | プロパティ（設定値参照）
lval | long | 設定値

[エラーコード]

値 | 内容
1044 | 指定されたフィールドがありません
1051 | パラメータエラー

[設定値]

mode には次の値を指定します。

定数 | 値 | 内容
JV_FONT_SIZE | 1 | フォントサイズの指定（1/10ポイント単位）
JV_FONT_BOLD | 2 | フォントボールドの指定
JV_FONT_ITALIC | 3 | フォントイタリックの指定
JV_TEXT_ALIGNMENT | 4 | 文字配置の指定
JV_TEXT_UNDERLINE | 5 | 下線の指定
JV_TEXT_DELETELINE | 6 | 打ち消し線の指定
JV_FORE_COLOR | 7 | 前景色（RGB値）
JV_BACK_COLOR | 8 | 背景色（RGB値）
JV_UNDERLINE_DISTANCE | 9 | 文字と下線の距離（1/10mm単位）
JV_TEXT_LINECOLOR | 10 | テキストフィールドの文字の輪郭線の色

フォントボールド（JV_FONT_BOLD）のlval には次の値を指定します。

定数 | 値 | 内容
JV_BOLD_OFF | 0 | ボールド解除
JV_BOLD_ON | 1 | ボールド設定

フォントイタリック（JV_FONT_ITALIC）のlval には次の値を指定します。

定数 | 値 | 内容
JV_ITALIC_OFF | 0 | イタリック解除
JV_ITALIC_ON | 1 | イタリック設定

文字配置（JV_FONT_ALIGNMENT）のlval には次の値を指定します。

定数 | 値 | 内容
JV_TEXT_LEFT | 0 | 左寄せ
JV_TEXT_RIGHT | 1 | 右寄せ
JV_TEXT_CENTER | 2 | 中央揃え
JV_TEXT_EVEN | 3 | 均等割付

下線（JV_TEXT_UNDERLINE）、打ち消し線（JV_TEXT_DELETELINE）のlval には次の値を指定します。
定数 | 値 | 内容
JV_LINE_OFF | 0 | なし
JV_LINE_DASH | 1 | 破線
JV_LINE_DOT | 2 | 点線
JV_LINE_DASHDOT | 3 | 一点鎖線
JV_LINE_DASHDOTDOT | 4 | 二点鎖線
JV_LINE_SOLID | 5 | 一重線
JV_LINE_DOUBLE | 6 | 二重線
JV_LINE_WIDE | 7 | 太線

文字と下線の距離（JV_UNDERLINE_DISTANCE）のlval には-50～50の値を指定します。

[解説]

各プロパティの初期値は、デザイン時に設定された値です。

fieldname には、プロパティを変更するフィールド名称を指定します。
グリッドフィールドの場合は、フィールド名称と一緒に行と列を指定することができます。

例）明細という名称のグリッドフィールドの場合
明細フィールド1行目2列目のセルを指定 | 明細@R1C2
明細フィールド2行目のセルを指定 | 明細@R2
明細フィールド3列目のセルを指定 | 明細@C3
明細フィールドの全てのセルを指定 | 明細

前景色
前景色を設定すると、デザイン時に設定したフォント色を変更することができます。
カラー印刷が指定されている場合のみ有効です。

背景色
背景色を設定すると、テキストフィールドではフィールド領域を塗り潰します。グリッドフィールドではセル領域を塗り潰します。 カラー印刷が指定されている場合のみ有効です。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

Call Jvr.Start

''顧客名テキストフィールドのフォント色を赤に変える
Call Jvr.SetFieldLong(“顧客名”, JV_FORE_COLOR, RGB(255, 0, 0))

''明細グリッドフィールド3行目4列目のセルを緑で塗り潰す
Call Jvr.SetFieldLong(“明細@R3C4”, JV_BACK_COLOR, RGB(0, 255, 0))

''テキストフィールドのフォントサイズを16ポイントに変える
Call Jvr.SetFieldLong("TEXT2", JV_FONT_SIZE, 160)

Call Jvr.SetFieldLong("TEXT2", JV_FONT_BOLD, JV_BOLD_ON)
Call Jvr.SetFieldLong("GRID1@R2C2", JV_FONT_ITALIC, JV_ITALIC_ON)

''グリッドフィールドの文字配置を均等割付に変える
Call Jvr.SetFieldLong("GRID1@R1C1", JV_TEXT_ALIGNMENT, JV_TEXT_EVEN)

''テキストフィールドの輪郭線の色を変更する
Call Jvr.SetFieldLong("TEXT2", JV_TEXT_LINECOLOR, RGB(255,0,0))

レポートライブラリ.NETコントロール

ret = Jvr.Start()

''顧客名テキストフィールドのフォント色を赤に変える
ret = Jvr.SetFieldLong(“顧客名”, JV_FORE_COLOR, RGB(255, 0, 0))

''明細グリッドフィールド3行目4列目のセルを緑で塗り潰す
ret = Jvr.SetFieldLong(“明細@R3C4”, JV_BACK_COLOR, RGB(0, 255, 0))

''テキストフィールドのフォントサイズを16ポイントに変える
ret = Jvr.SetFieldLong("TEXT2", JV_FONT_SIZE, 160)

ret = Jvr.SetFieldLong("TEXT2", JV_FONT_BOLD, JV_BOLD_ON)
ret = Jvr.SetFieldLong("GRID1@R2C2", JV_FONT_ITALIC, JV_ITALIC_ON)

''グリッドフィールドの文字配置を均等割付に変える
ret = Jvr.SetFieldLong("GRID1@R1C1", JV_TEXT_ALIGNMENT, JV_TEXT_EVEN)

''テキストフィールドの輪郭線の色を変更する
ret =l Jvr.SetFieldLong("TEXT2", JV_TEXT_LINECOLOR, RGB(255,0,0))


SetFieldTextメソッド

テキストフィールド、セレクトボタンフィールドにデータを設定します。

[構文]

レポートライブラリOCX

Object.SetFieldText (fieldname, text)

レポートライブラリ.NETコントロール

long Object.SetFieldText (fieldname, text)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fieldname | string | テキストフィールド名
text | string | 描画文字列

[エラーコード]

値 | 内容
1004 | フィールドデータセットエラー
1029 | Startを行ってください
1041 | メモリエラー
1042 | フィールドオーバーフロー
1043 | 編集子が不正です
1044 | 指定されたフィールドがありません

[解説]

［テキストフィールド］

１．文字列の設定
テキストフィールドに文字列を設定すると、実行時に文字列が描画されます。

－基本的なコーディング

渡した文字列が、デザイン時に設定した編集子の桁数を超えた場合には、オーバーフローとなります。オーバーフロー時の処理は、編集子が文字型の場合にはCharOverFlowプロパティ、数値型の場合にはNumOverFlowプロパティで設定することができます。

－フィールド編集子

２．描画に使用する文字
描画文字列には外字、UNICODEやサロゲートペアの文字を使用することができます。
UNICODEやサロゲートペアの文字を使用する場合には、CharcterSetプロパティでUNICODEを指定しておきます。

－外字の描画
－UNICODEの使用
－ サロゲートペア

３．拡張機能・フォントの自動調整
テキストフィールドには、拡張機能やフォントの自動調整機能があります。
拡張機能とは、テキストフィールドに設定されたプロパティをプログラムから変更する機能です。
フォントの自動調整とは、テキストフィールドに渡した文字列を枠内に収める機能です。枠からはみ出る場合には、フォントサイズを自動調整して枠内に収めます。
拡張機能やフォントの自動調整機能を使う場合には、フォームのデザイン時に設定しておく必要があります。

－拡張機能・フォントの自動調整の設定

拡張機能やフォントの自動調整が設定されたテキストフィールドは、以下のプロパティを変更または設定することができます。

  ・フォント：種類、横幅拡大率、サイズ、色、イタリック、ボールド
  ・文字の背景：色、高さ、縦位置
  ・下線：色、幅、位置、種類
  ・打ち消し線：色、幅、位置、種類

  ※フォントの自動調整では、以下のプロパティは使用できません。
  フォントの種類・横幅拡大率・サイズ、文字の背景の縦位置、下線の位置、打消し線の位置

これらのプロパティは、SetFieldLongを使って実行時に変えることもできますが、SetFieldLongでは、文字列全体のプロパティが変わります。拡張機能では、文字列を部分的に変えることができます。

プロパティは、予約語を使い、プログラムコードに記述して変更します。
使い方やコーディング例は、「付録／テキストフィールド拡張機能」を参照してください。

－フォントプロパティを変更
－文字の背景プロパティの設定
－下線プロパティの設定
－打ち消し線プロパティの設定

拡張機能とフォントの自動調整が設定されたテキストフィールドでは、オーバーフローエラーは起こりません。編集子の桁数に関係なく何文字でも渡すことができます。半角・全角に拘らず、最大2000文字まで渡すことができます。2000文字を超えた場合でもエラーは起こりませんが、そのテキストフィールドには何も描画されません。何も描画されない時には、渡した文字列の桁数を確認してください。

［セレクトボタンフィールド］
描画文字列には、「1」または「0（1以外）」を指定します。「1」を指定すると、セレクトボタンフィールドは選択された状態になります。「0（1以外）」を指定すると、セレクトボタンフィールドは選択が解除された状態になります。

StartメソッドとEnd（Abort）メソッドの間で実行します。

[コーディング例]

レポートライブラリOCX

Jvr.SetFieldText("住所", "名古屋市中区大須")
Jvr.SetFieldText("氏名", "じゃいぶ一郎")
Jvr.SetFieldText("電話", "052-339-9999")

レポートライブラリ.NETコントロール

ret = Jvr.SetFieldText("住所", "名古屋市中区大須")
ret = Jvr.SetFieldText("氏名", "じゃいぶ一郎")
ret = Jvr.SetFieldText("電話", "052-339-9999")

※拡張機能のコーディング例は、「付録／テキストフィールド拡張機能」の以下の項目を参照してください。

－フォントプロパティを変更
－文字の背景プロパティの設定
－下線プロパティの設定
－打ち消し線プロパティの設定


Startメソッド

印刷を開始します。

[構文]

レポートライブラリOCX

Object.Start

レポートライブラリ.NETコントロール

long Object.Start ()

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

[エラーコード]
値 | 内容
1000 | 初期処理エラー
1018 | フォームが指定されていません
1019 | フォーム設定エラー
1020 | ビットマップファイル名が指定されていません
1022 | 用紙サイズ・方向の設定に失敗しました
1023 | DEVMODE情報設定エラー
1025 | CreateDCエラー
1026 | StartDocエラー
1030 | 用紙サイズ取得エラー
1037 | ファイルオープンエラー
1038 | ファイルリードエラー
1039 | フォームのフォーマットが違います
1040 | フォームのバージョンが違います
1041 | メモリエラー
1053 | PageNoプロパティエラー 値が不正です
1062 | PageKeyプロパティエラー PageKey設定エラー
1071 | パラメータエラー
1072 | ウィンドウハンドルが指定されていません
1073 | ウィンドウのデバイスコンテキストが取得できません
1074 | 通常使用するプリンタが指定されていません
1075 | プリンタのデバイスコンテキストが作成できません
1076 | プリンタ解像度エラー
1077 | ウィンドウ解像度エラー
1079 | 出力ファイル名が指定されていません
1117 | REFファイル作成エラー

[解説]

Startメソッドを実行する前に、必ずFormNameプロパティでフォームを設定してください。
Startメソッドを実行した時は、印刷終了時にはEndメソッド、印刷中断時にはAbortメソッドを実行してください。
「Start」が予約語等に指定されている開発環境では、「StartDoc」を使用してください。

－基本的なコーディング

[コーディング例 ]

レポートライブラリOCX

Jvr.Start

レポートライブラリ.NETコントロール

ret = Jvr.Start ()


SetParamメソッド

各種パラメータを設定します。

[構文]

レポートライブラリOCX

Object.SetParam (mode, param)

レポートライブラリ.NETコントロール

long Object.SetParam (mode, param)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
mode | long | 設定する項目
param | string | 設定値

[エラーコード]

値 | 内容
1071 | パラメータエラー
1123 | Startが実行されています

[設定値]

mode には次の値を指定します。
定数 | 値 | 内容
JV_PDF_OWNER_PASSWORD | 20 | Adobe PDF形式データのオーナーパスワード（20バイト以内）
JV_PDF_USER_PASSWORD | 21 | Adobe PDF形式データのユーザーパスワード （20バイト以内）
JV_PDF_AUTHOR | 22 | Adobe PDF形式データの作成者（256バイト以内）
JV_PDF_CREATOR | 23 | Adobe PDF形式データのアプリケーション（256バイト以内）
JV_PDF_TITLE | 24 | Adobe PDF形式データのタイトル（256バイト以内）
JV_PDF_SUBJECT | 25 | Adobe PDF形式データのサブタイトル（256バイト以内）
JV_PDF_KEYWORD | 26 | Adobe PDF形式データのキーワード（256バイト以内）
JV_PDF_ENCRIPT_LEVEL | 41 | Adobe PDF形式データの暗号化レベル（設定値参照）
JV_PDF_ENABLE_PRINT | 42 | Adobe PDF形式データの文書の印刷（設定値参照）
JV_PDF_ENABLE_EDIT_ALL | 43 | Adobe PDF形式データの文書の変更 （設定値参照）
JV_PDF_ENABLE_COPY | 44 | Adobe PDF形式データの内容のコピーと抽出（設定値参照）
JV_PDF_ENABLE_EDIT | 45 | Adobe PDF形式データの注釈の追加と変更（設定値参照）
JV_PDF_OVERLAY | 47 | Adobe PDF形式データのオーバーレイ登録（設定値参照）
JV_GAIJI_FILE | 31 | ジャイブレポート外字ファイル名
JV_WINHDC | 32 | ウィンドウデバイスコンテキストの指定（X64対応版のみ使用可）
JV_PRNHDC | 33 | 印刷するプリンタの指定（X64対応版のみ使用可）
JV_LIB_VERSION | 38 | ライブラリバージョンの指定（0または9）
JV_BAR_QR_ADJUST | 52 | ＱＲコードのボックス太さ微調整（"-100"～"100"）
JV_BAR_MICROQR_ADJUST | 53 | マイクロQRコードのボックス太さ微調整（"-100"～"100"）
JV_ERA_NAME | 54 | 元号名と情報の指定
JV_SURROGATEPAIR_FONT | 55 | サロゲートペアで使用するフォント

暗号化レベル（JV_PDF_ENCRIPT_LEVEL）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_ENCRIPT_RCL | "2" | RC4(40ビット)
JV_PDF_ENCRIPT_RCH | "3" | RC4（128ビット)(初期値)
JV_PDF_ENCRIPT_AES128 | "4" | AES(128ビット)
JV_PDF_ENCRIPT_AES256 | "5" | AES(256ビット)

文書の印刷（JV_PDF_ENABLE_PRINT）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

文書の変更（JV_PDF_ENABLE_EDIT_ALL）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

内容のコピーと抽出（JV_PDF_ENABLE_COPY）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

注釈の追加と変更（JV_PDF_ENABLE_EDIT）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

オーバーレイ登録（JV_PDF_OVERLAY）のparam には次の値を指定します。

定数 | 値 | 内容
JV_SPDFOVERLAY_ON | "1" | 登録する
JV_SPDFOVERLAY_OFF | "0" | 登録しない

[解説]

Startメソッドの前に設定します。

オーナーパスワード
オーナーパスワードをつけると、次の利用許可制限を設定することができます。
文書の印刷、文書の変更、内容のコピーと抽出、注釈の追加と変更

ユーザーパスワード
ユーザーパスワードがついたAdobe PDF形式のデータは、利用時にユーザーパスワードが必要です。

文書の印刷
Adobe PDF形式のデータ利用時の印刷に対する制限を指定します。

文書の変更
Adobe PDF形式のデータ利用時の「テキスト注釈及び対話フォームフィールド以外の文書内容の変更」に対する制限を指定します。

内容のコピーと抽出
Adobe PDF形式のデータ利用時の「文書からのテキストとグラフィックスのコピー」に対する制限を指定します。

注釈の追加と変更
Adobe PDF形式のデータ利用時の「テキスト注釈及び対話フォームフィールドの追加または変更」に対する制限を指定します。

オーバーレイ登録
Adobe PDF形式データの出力時に、フォームの固定部分をオーバーレイ登録するかどうかを指定します。
初期値は、フォームファイルに設定された値です。

例）オーバーレイ登録をする
Call Jvr.SetParam(JV_PDF_OVERLAY,JV_SPDFOVERLAY_ON)

－Adobe PDF形式データのオーバーレイ登録

作成者、アプリケーション、タイトル、サブタイトル、キーワード
設定値は、Adobe PDF形式のデータのプロパティ画面で見ることができます。

ジャイブレポート外字ファイル名
ジャイブレポート外字ファイルの名前をフルパスで指定します。ジャイブレポート外字ファイルはレポートエディタで作成します。

ウィンドウデバイスコンテキストの指定（X64対応版のみ使用可）
X64対応版レポートライブラリでウィンドウデバイスコンテキストを設定する場合に使用します。
ウィンドウデバイスコンテキストについての詳細は、WinHdcプロパティを参照してください。
（X86対応版レポートライブラリではこの機能は使用できません。WinHdcプロパティを使用します。）

印刷するプリンタの指定（X64対応版のみ使用可）
X64対応版レポートライブラリで印刷するプリンタを設定する場合に使用します。
印刷するプリンタの設定についての詳細は、PrnHdcプロパティを参照してください。
（X86対応版レポートライブラリではこの機能は使用できません。PrnHdcプロパティを使用します。）

例）
  レポートライブラリOCX

  If IntPtr.Size = 4 Then
      Jvr.PrnHdc = hdc.ToInt32()
  Else
      Call Jvr.SetParam(JV_PRNHDC, hdc.ToString())
  End If

  レポートライブラリ.NETコントロール

  If IntPtr.Size = 4 Then
      Jvr.PrnHdc = hdc.ToInt32()
  Else
      ret = Jvr.SetParam(JV_PRNHDC, hdc.ToString())
  End If

ライブラリバージョン（JV_LIB_VERSION）
用紙の余白と拡大縮小をVer.8からVer.9の仕様で設定することができます。ライブラリバージョンに「0」を指定すると、余白や拡大縮小は最新バージョンの仕様で設定されます。「9」を指定すると、Ver.8からVer.9の仕様で設定されます。初期値は「0」です。
余白と拡大縮小についての詳細は「付録／用紙の余白（マージン）設定」を参照してください。

QRコードのボックスの太さ微調整（JV_BAR_QR_ADJUST）
QRコードのボックスの太さを0.1%単位で微調整します。
小さなボックスの集合により描画されるQRコードは、プリンタによってボックスの太さに違いが出ます。
例えば、"-10"を指定すると、ボックスの太さが1%小さくなります。※値は文字列で渡してください。
設定値は、その後に出力されるすべてのQRコードに有効となります。元へ戻す場合には、再設定が必要です。

マイクロQRコードのボックスの太さの微調整（JV_BAR_MICROQR_ADJUST）
マイクロQRコードは、小さなボックスの集合により描画されますが、プリンタによってボックスの太さに違いが出ます。
この機能では、0.1%単位でボックスの太さを微調整することができます。
例えば、大きく表示されてしまった場合には、"-10"を指定すると、ボックスの太さが1%小さくなります。
※値は文字列で渡してください。

元号名と情報の指定（JV_ERA_NAME）
和暦の元号の基本情報を指定します。ここで設定された元号は、日付型編集子を持つフィールドに使われます。
何も設定されていない場合には、「令和、平成、昭和、大正、明治」のみ自動で表示されます。
元号の基本情報は「開始年月日、ローマ字略称、漢字略称、元号」の順番で、それぞれの値を指定します。
情報と情報の間は、半角のコロン（：）を使います。
最大3つまで設定しておくことができます。※明治以前の元号を設定することはできません。

例）　2099年1月1日から元号が「永宝」になった場合
Call SetParam(JV_ERA_NAME,"20990101：E：永：永宝")

サロゲートペアで使用するフォントの指定（JV_SURROGATEPAIR_FONT）
サロゲートペアで使用するフォントを指定します。

例）　ＭＳ 明朝の代替フォントをSimSun-ExtBに設定し、その他のフォントの代替フォントをMingLiU-ExtBに設定する
Call SetParam(JV_SURROGATEPAIR_FONT, "ＭＳ 明朝,SimSun-ExtB,*,MingLiU-ExtB")

－外字の描画
－Adobe PDF形式データのセキュリティ


AllJobInfoプロパティ

指定したプリンタの全ジョブの全情報を取得します。

[構文]

string = Object.AllJobInfo
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 全ての印刷ジョブの全情報

[設定値]

設定不可。

[解説]

ジョブを取得するプリンタは、PrinterNameプロパティで指定します。

印刷ジョブの全情報を文字列型の値で返します。
全情報の内容と並び順は次の通りです。項目間はカンマで区切られます。
複数のジョブがある場合、ジョブ間は改行コード（CR+LF）で区切られます。

１．印刷ジョブＩＤ
２．プリンタ名
３．マシン名
４．ユーザー名
５．印刷ジョブ名（DocNameプロパティの値）
６．印刷ジョブを記録するために使われるデータの種類
７．印刷ジョブの状態（文字列）
８．印刷ジョブの状態（フラグ）
９．ジョブの優先順位
10．印刷キュー内のジョブの位置
11．文書のページ数
12．すでに印刷されたページ数
13．この文書がスプールされた時間（hh:mm:ss YY/MM/DD)

「８．印刷ジョブの状態」は、次の値のうち、該当する値の合計値となります。

定数 | 値 | 内容
JV_JOBSTATUS_PAUSED | 1 | 一時停止
JV_JOBSTATUS_ERROR | 2 | エラー
JV_JOBSTATUS_DELETING | 4 | 削除中
JV_JOBSTATUS_SPOOLING | 8 | スプール中
JV_JOBSTATUS_PRINTING | 16 | 印刷中
JV_JOBSTATUS_OFFLINE | 32 | オフライン
JV_JOBSTATUS_PAPEROUT | 64 | 紙切れ
JV_JOBSTATUS_PRINTED | 128 | 印刷済み

値の参照は実行時のみ可能です。

[コーディング例]

Jvr.PrinterName = "PC-PR201" | 'プリンタの指定
retBuf = Jvr.AllJobInfo | '印刷ジョブの全情報の取得


AllowSelectionプロパティ

印刷ダイアログにある「ページ指定」オプションボタンの使用フラグを初期設定します。
ユーザーが印刷ダイアログで設定した「ページ指定」オプションボタンの使用フラグ値を取得します。

[構文]

Object.AllowSelection = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 使用不可フラグ（設定値参照）

[設定値]

long には次の値を指定します。また、long で次の値を取得できます。

定数 | 値 | 内容
JV_ALLOWSELECT_ON | 1 | 「ページ指定」オプションボタンを使用可能にする
JV_ALLOWSELECT_OFF | 0 | 「ページ指定」オプションボタンを使用不可にする

[解説]

値の設定は、Startメソッドの前で行います。

AllowSelection プロパティに「JV_ALLOWSELECT_OFF」を指定すると、全ページ印刷となります。全ページ印刷では、印刷ダイアログがポップアップした時に、印刷開始ページと印刷終了ページを使用できません。

[コーディング例]

Jvrlib.MinPage = 1 |
Jvrlib.MaxPage = 3 |
Jvrlib.FromPage = 1 |
Jvrlib.ToPage = 3 |
Jvrlib.Copies = 2 |
Jvrlib.AllowSelection = JV_ALLOWSELECT_ON | 'ページ指定
Jvrlib.SetPrinter = JV_SPSHOWDIALOG |
Call Jvrlib.Start |


AllPrinterNamesプロパティ

使用可能なプリンタ名称を取得します。

[構文]

string = Object.AllPrinterNames
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 使用できるプリンタの名称

[設定値]

設定不可。

[解説]

プリンタ名とプリンタ名の間は、カンマで区切られます。
値の参照は実行時のみ可能です。

[コーディング例]

retBuf = Jvr.AllPrinterNames


BackModeプロパティ

図形やイメージの背景モードを設定します。

[構文]

レポートライブラリOCX

Object.BackMode = long

レポートライブラリ.NETコントロール

Object.BackMode = enumBackMode

Object.BackMode = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumBackMode | 背景モード（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_TRANSPARENT | 1 | 透過
JV_OPAQUE | 2 | 上書き （初期値）

enumBackMode （列挙型）には次の値を指定します。

値

透過

上書き

[解説]

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

レポートライブラリOCX

Jvr.BackMode = JV_OPAQUE | '非透過
Jvr.BackMode = JV_TRANSPARENT | '透過

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.BackMode = enumBackMode.上書き | '非透過
Jvr.BackMode = enumBackMode.透過 | '透過

（Visual C#）
Jvr.BackMode = enumBackMode.上書き; | '非透過
Jvr.BackMode = enumBackMode.透過; | '透過

（Visual C++）
Jvr->BackMode = enumBackMode::上書き; | '非透過
Jvr->BackMode = enumBackMode::透過; | '透過

’long 型を使う場合

（VisualBasic)
Jvr.BackMode = JV_OPAQUE | '非透過
Jvr.BackMode = JV_TRANSPARENT | '透過

（Visual C#） ※列挙型にキャストします
Jvr.BackMode = (enumBackMode)jvrvcsocx.JV_OPAQUE; | '非透過
Jvr.BackMode = (enumBackMode)jvrvcsocx.JV_TRANSPARENT; | '透過

（Visual C++）※列挙型にキャストします
Jvr->BackMode = (enumBackMode)JV_OPAQUE; | '非透過
Jvr->BackMode = (enumBackMode)JV_TRANSPARENT; | '透過


Barcodeプロパティ

DrawBarcodeメソッドとSetFieldBarcodeメソッドで描画されたコードを取得します。

[構文]

string = Object.Barcode

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 描画されたコード

[設定値]

設定不可。

[解説]

Barcodeプロパティには、チェックディジットやスタートストップキャラクタなどが付加された実際の描画コードが返ります。
カスタマーバーコードの場合には、住所表示番号（XX丁目XX番XX番地の部分）が返ります。
QRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードの場合には、Barcodeプロパティは使用できません。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間でDrawBarcodeメソッドやSetFieldBarcodeメソッドを実行後）に可能です。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）

[コーディング例]

''CODE39バーコードの描画
barsize = "30,75,0,0,30,75,0,0"
codetype = JV_BAR_CODE39
checkdigit = JV_CHECK_OFF
barcode = "JIVE-REPORT"
Jvr.DrawBarcode(1000, 4500, 1000, barsize, 0, codetype, checkdigit, 0, barcode)
retCode = Jvr.Barcode '' retCodeは "*JIVE-REPORT*"

''カスタマーバーコードの描画
codetype = JV_BAR_CST
barcode = "460-0011愛知県名古屋市中区大須一丁目２５番２８号小野田ビル８０１号"
Jvr.DrawBarcode(1000, 5500, 1000, barsize, 0, codetype, checkdigit, 0, barcode)
retCode = Jvr.Barcode '' retCodeは "1-25-28-801"


BookMarkプロパティ

Adobe PDF形式のデータにブックマーク（しおり）をつけます。

[構文]

Object.BookMark = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | ブックマーク（しおり）

[設定値]

string にはブックマーク（しおり）を指定します。

[解説]

ブックマークは、設定したページのみにつきます。全ページにつける場合は、各ページごとにブックマークを指定します。
ブックマークにはUNICODEを使用することができます。
ドキュメント名をつける場合は、DocNameプロパティを使います。
BookMarkプロパティは、Adobe PDF形式のデータを作成する時のみ使用可能です。

値の設定は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。
値の参照はできません。

－ UNICODEの使用

[コーディング例]

Jvr.BookMark = "納品書"


BkColorプロパティ

背景色を設定します。

[構文]

Object.BkColor = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 背景色（初期値は白）

[設定値]

long にはRGB値を指定します。

[解説]

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]
Jvr.FrColor = RGB(255, 0, 0) | '前景色
Jvr.BkColor = RGB(0, 255, 0) | '背景色


CharacterSetプロパティ

レポートライブラリOCXで使用する文字コードを設定します。

[構文]

Object.CharacterSet = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 文字コード（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
CHARSET_SJIS | 0 | Shift-JIS（初期値）
CHARSET_UNICODE | 1 | UNICODE

[解説]

UNICODEを指定すると、DrawTextメソッド、SetFieldTextメソッド、SetFieldGridメソッド、BookMarkメソッドで、UNICODEやサロゲートペアの文字を描画することができます。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

－基本的なコーディング
－UNICODEの使用
－ サロゲートペア

[コーディング例]

Jvr.CharacterSet = CHARSET_UNICODE


CharOverFlowプロパティ

文字型テキストフィールドとグリッドフィールドのオーバーフロー時の処理を設定します。

[構文]

レポートライブラリOCX

Object.CharOverFlow = long

レポートライブラリ.NETコントロール

Object.CharOverFlow = enumCharOverFlow

Object.CharOverFlow = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumCharOverFlow | オーバーフロー時の処理（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_OVERFLOW_ERROR | 0 | 出力しない
JV_OVERFLOW_CUT | 1 | カットして出力（初期値）

enumCharOverFlow （列挙型）には次の値を指定します。

値

出力しない

カットして出力

[解説]

出力する文字列が、デザイン時に設定した編集子の桁数を超えた時の処理を設定します。
CharOverFlowプロパティは、編集子が文字型のテキストフィールドとグリッドフィールドに使います。
編集子が数値型のテキストフィールドとグリッドフィールドには、NumOverFlowプロパティを使います。

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

CharOverFlowプロパティでオーバーフロー時の処理を設定しても、オーバーフローが発生した時には、オーバーフローをユーザーに知らせるため、SetFieldTextメソッドやSetFieldGridメソッドで、1042のオーバーフローエラー（例外）が発生します。エラーが発生しても処理を続行する場合には、エラーハンドラを作成し、その中で、1042エラーの処理を記述しておきます。
レポートライブラリ.NETコントロールでは、ErrorThrowプロパティで例外を発生させるかどうかの指定ができます。例外を発生させないように指定している場合には、オーバーフローが起きても例外は発生しません。オーバーフローが起きたかどうかはリターンコードで確認することができます。

※ヘルプの「アプリケーション開発／フィールドオーバーフローエラー処理」に言語ごとのコーディングサンプルがあります。

値の設定と参照はデザイン時、実行時に可能です。

－フィールド編集子

[コーディング例]

レポートライブラリOCX

Jvr.CharOverFlow = JV_OVERFLOW_CUT

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.CharOverFlow = enumCharOverFlow.カットして出力

（Visual C#）
Jvr.CharOverFlow = enumCharOverFlow.カットして出力;

（Visual C++）
Jvr->CharOverFlow = enumCharOverFlow::カットして出力;

’long 型を使う場合

（VisualBasic)
Jvr.CharOverFlow = JV_OVERFLOW_CUT

（Visual C#） ※列挙型にキャストします
Jvr.CharOverFlow = (enumCharOverFlow)jvrvcsocx.JV_OVERFLOW_CUT;

（Visual C++）※列挙型にキャストします
Jvr->CharOverFlow = (enumCharOverFlow)JV_OVERFLOW_CUT;


Collateプロパティ

印刷ダイアログにある「部単位で印刷」チェックボックスの初期設定を行います。
ユーザーが印刷ダイアログで設定した「部単位で印刷」チェックボックスの値を取得します。

[構文]

long = Object.Collate
Object.Collate = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | チェックボックスの値（設定値参照）

[設定値]

long には次の値を指定します。また、long で次の値を取得できます。

定数 | 値 | 内容
JV_COLLATE_ON | 1 | 「部単位で印刷」チェックボックスをチェック
JV_COLLATE_OFF | 0 | 「部単位で印刷」チェックボックスを未チェック

[解説]

値の設定は、Startメソッドの前で行います。
値の参照は、実行時のみ可能です。

部単位で印刷チェックボックスの設定
Collate プロパティは、印刷ダイアログの「部単位で印刷」チェックボックスを初期設定して印刷ダイアログをポップアップさせる時に使います。Copiesプロパティの値が2以上の時に使います。印刷ダイアログを表示する前に設定します。

部単位で印刷チェックボックスの値取得
Collate プロパティは、印刷ダイアログでユーザーが指定した「部単位で印刷」チェックボックスの値を取得する時に使います。ユーザーが「部単位で印刷」をチェックした時、Collate プロパティには以下の値が返ります。

①プリンタドライバが部単位印刷をサポートしている場合
Collate プロパティには「JV_COLLATE_OFF」が返ります。部単位印刷は、プリンタドライバが行います。

②プリンタドライバが部単位印刷をサポートしていない場合
Collate プロパティには「JV_COLLATE_ON」が返ります。「JV_COLLATE_ON」が返った時は部単位印刷を行う処理をプログラムに記述し、アプリケーション側で対応してください。

※部単位印刷に対応したプリンタドライバを使う時の注意
部単位印刷に対応したプリンタドライバで部単位印刷を行う時には、事前に、印刷するプリンタのプロパティ設定画面で「全ページ分のデータをスプールしてから印刷データをプリンタに送る」という項目を指定しておきます。この項目が指定されていないと、プリンタドライバが部単位印刷をサポートしていても部単位印刷はできません。

※Collate プロパティは、プリンタドライバによっては有効にならないことがあります。

[コーディング例]

Jvrlib.MinPage = 1 |
Jvrlib.MaxPage = 3 |
Jvrlib.FromPage = 1 |
Jvrlib.ToPage = 3 |
Jvrlib.Copies = 2 |
Jvrlib.Collate = JV_COLLATE_OFF | '部単位印刷
Jvrlib.SetPrinter = JV_SPSHOWDIALOG |
Call Jvrlib.Start |
If Jvrlib.Collate = JV_COLLATE_ON Then |
部単位印刷を行う処理を記述する |


ColorModeプロパティ

印刷時のカラーモードを設定します。

[構文]

レポートライブラリOCX

Object.ColorMode = long

レポートライブラリ.NETコントロール

Object.ColorMode = enumColorMode

Object.ColorMode = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumColorMode | カラーモード（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_COLOR_OFF | 0 | モノクロ印刷を行なう
JV_COLOR_ON | 1 | カラー印刷を行なう

enumColorMode （列挙型）には次の値を指定します。

値

モノクロ印刷

カラー印刷

[解説]

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

値の設定と参照はデザイン時、実行時に可能です。
初期値は、デザイン時に設定したフォームのカラーモードです。カラーモードは、レポートエディタのフォーム情報で設定します。

[コーディング例]

レポートライブラリOCX

Jvr.ColorMode = JV_COLOR_OFF

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.ColorMode = enumColorMode.モノクロ印刷

（Visual C#）
Jvr.ColorMode = enumColorMode.モノクロ印刷;

（Visual C++）
Jvr->ColorMode = enumColorMode::モノクロ印刷;

’long 型を使う場合

（VisualBasic)
Jvr.ColorMode = JV_COLOR_OFF

（Visual C#） ※列挙型にキャストします
Jvr.ColorMode = (enumColorMode)jvrvcsocx.JV_COLOR_OFF;

（Visual C++）※列挙型にキャストします
Jvr->ColorMode = (enumColorMode)JV_COLOR_OFF;


Copiesプロパティ

印刷ダイアログの印刷部数を初期設定します。
ユーザーが設定した印刷部数を取得します。

[構文]

Object.Copies = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 部数（初期値は 1）

[設定値]

long には1～10000の値を指定します。

[解説]

印刷部数の設定
Copiesプロパティは、印刷ダイアログの印刷部数に初期値を入れてポップアップさせる時に使います。印刷ダイアログを表示する前に設定しておきます。

印刷部数の取得
Copiesプロパティは、印刷ダイアログでユーザーが指定した印刷部数を取得する時に使います。 プリンタドライバが複数部数印刷をサポートしているかどうかで返る値が異なります。

①複数部数印刷をサポートしているプリンタドライバの場合
レポートライブラリは、プリンタドライバに印刷部数を設定し、Copiesプロパティに 1 を返します。複数部数印刷は、プリンタドライバが行います。

②複数部数印刷をサポートしていないプリンタドライバの場合
レポートライブラリは、Copiesプロパティにユーザーが設定した値を返します。
Copiesプロパティに2以上の値が返った時は、プリンタドライバに複数部数印刷の機能がないことを示しているので、印刷箇所をCopiesプロパティの回数分ループさせるなどの処理をプログラムに記述し、アプリケーション側で対応させてください。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時（StartメソッドとEndまたはAbortメソッドの間） に可能です。

－印刷ダイアログの表示

[コーディング例]

Jvr.SetPrinter = JV_SPSHOWDIALOG | 印刷ダイアログの設定
Jvr.Start | '印刷の開始
'印刷ダイアログ表示、設定値を取得 |
fromPage = Jvr.fromPage | '印刷開始ページ
toPage = Jvr.toPage | '印刷終了ページ
copies = Jvr.copies | '印刷部数


CurrentTopプロパティ

次に描画を開始する縦座標を取得します。 縦座標の設定も可能です。

[構文]

long = Object.CurrentTop

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 縦座標（1/10mm単位）（初期値は 0 ）

[設定値]

設定不可。

[解説]

CurrentTop プロパティは可変フォーム専用のプロパティです。固定フォームでは使用できません。

セクションを何も描画していない時のCurrentTop プロパティの値は0です。DrawSection メソッドでセクションを描画すると、CurrentTop プロパティには、描画したセクションの高さが加算されていきます。

CurrentTop プロパティは、描画領域の幅を取得するDrawWidth プロパティ、描画領域の高さを取得するDrawHeight プロパティ、セクションの高さを取得するSectionHeight プロパティと組み合わせて、セクションが描画可能かどうかや、改ページが必要かどうかを判断する時に使います。
CurrentTop プロパティには、フォームに設定されているマージンは含まれません。

描画する縦座標を変更する時は、CurrentTop プロパティに縦座標を指定します。

値の参照と設定は、実行時のみ可能です。

[コーディング例]

Dim CurrentTop As Long |
CurrentTop = Jvrlib.CurrentTop | '現在位置


DocNameプロパティ

印刷ジョブのドキュメント名やAdobe PDF形式データのドキュメント名を設定します。

[構文]

Object.DocName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | ドキュメント名

[設定値]

string にはドキュメント名を指定します。初期値はありません。

[解説]

印刷ジョブのドキュメント名
スプーラに印刷ジョブのドキュメント名を表示する場合は、DocNameプロパティにドキュメント名を指定します。OutDeviceプロパティには「JV_PRINTER」を指定します。

PDFのドキュメント名
Adobe PDF形式のデータにドキュメント名をつける場合は、DocNameプロパティにドキュメント名を指定します。OutDeviceプロパティには「JV_PDF」を指定します。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.DocName = "確定申告書"
Jvr.Start


DocumentDataプロパティ

帳票のデータを取得します。

[構文]

Variant = Object.DocumentData

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
Variant | ドキュメント

[設定値]

設定不可。

[解説]

DocumentData プロパティは、RDF形式、Adobe PDF形式、TIFF形式、XPS形式の帳票データを取得する時に使います。
Endメソッドをコールした後で取得します。

OutDeviceプロパティで設定した形式のデータを取得することができます。(下表参照）
ＯｕｔＤｅｖｉｃｅの値 | 取得するデータの種類
JV_RDF | RDF形式のデータ
JV_PDF | Adobe PDF形式のデータ
JV_TIFF | TIFF形式のデータ
JV_XPS | XPS形式のデータ

VBなどで取得したデータを変数に格納する場合は、Byte配列型変数を使用します。
データをファイルへ保存する場合は、OutFileNameプロパティを使用します。

－RDF形式データを取得する
－Adobe PDF形式データを取得する

[コーディング例]

RDF形式のデータを取り出す場合（VB）

Dim rdfData() As Variant
Dim i As Long

JvrlibCtrl1.Start
  ・
  ・
JvrlibCtrl1.End
'' RDF形式のデータを取得します
rdfData = JvrlibCtrl1.DocumentData

Adobe PDF形式のデータを取り出しクライアントへ送信する場合（ASP）

<%
JvrlibCtrl1.Start
  ・
  ・
JvrlibCtrl1.End
'' Adobe PDF形式のデータを取得します
pdfData = JvrlibCtl.DocumentData
'ブラウザへPDFデータを返します
Response.ContentType = "application/pdf"
Response.AddHeader "content-length", UBound(pdfData) - LBound(pdfData) + 1
Response.AddHeader "content-disposition", "inline; filename=JIVE.PDF"
Response.BinaryWrite pdfData
%>
<% 'ライブラリの指定を以下で行ないます %>
<OBJECT RUNAT=Server ID="JvrlibCtl"
CLASSID="CLSID:638818DD-4B15-4E52-A177-F79922186FE0">
</OBJECT>
  ・
  ・


DocumentDataTypeプロパティ

プリンタプロパティのプリントデータ型を設定します。

[構文]

Object.DocumentDataType = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントデータ型

[設定値]

string にはプリントデータ型を指定します。初期値はありません。

[解説]

DocumentDataTypeは、コントロールパネルのプリンターのプロパティ詳細設定画面にあるプリントデータ型プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

DocumentDataTypeは、印刷を実行するドキュメントに対し、一時的にプリントデータ型の設定を行います。アプリケーション終了後も設定が続くように永久登録する場合は、PrintDataTypeプロパティを使います。

プロパティを設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

指定できるプリントデータ型は、PrinterAllDataTypeプロパティで調べることができます。
コントロールパネルのプリンターのプロパティ詳細画面で調べることもできます。

RAW形式にするには　"RAW"　を指定し、EMF形式にするには　"NT EMF 1.006"などを指定します。
データ型が設定されない場合は、デフォルトのプリントデータ型が使われます。
イメージや２次元バーコード等が正しく印刷されない場合には、RAW形式にすると改善されることがあります。

プロパティの設定は、Startメソッドの前で行います。
値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.DocumentDataType = "RAW"
Jvr.Start


DrawFormModeプロパティ

フォームの描画モードを設定します。

[構文]

レポートライブラリOCX

Object.DrawFormMode = long

レポートライブラリ.NETコントロール

Object.DrawFormMode = enumDrawFormMode

Object.DrawFormMode = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumDrawFormMode | 描画モード（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_FORM_FIELD | 1 | フォームとフィールドの描画 （初期値）
JV_FORM_ONLY | 2 | フォームのみ描画
JV_FIELD_ONLY | 3 | フィールドのみ描画

enumDrawFormMode （列挙型）には次の値を指定します。

値

フォーム_フィールド

フォーム

フィールド

[解説]

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

値の設定は、デザイン時、実行時（DrawFormメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

レポートライブラリOCX

Jvr.DrawFormMode = JV_FORM_FIELD

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.DrawFormMode = enumDrawFormMode.フォーム_フィールド

（Visual C#）
Jvr.DrawFormMode = enumDrawFormMode.フォーム_フィールド;

（Visual C++）
Jvr->DrawFormMode = enumDrawFormMode::フォーム_フィールド;

’long 型を使う場合

（VisualBasic)
Jvr.DrawFormMode = JV_FORM_FIELD

（Visual C#） ※列挙型にキャストします
Jvr.DrawFormMode = (enumDrawFormMode)jvrvcsocx.JV_FORM_FIELD;

（Visual C++）※列挙型にキャストします
Jvr->DrawFormMode = (enumDrawFormMode)JV_FORM_FIELD;


DrawHeightプロパティ

可変フォームの描画領域の高さを取得します。

[構文]

long = Object.DrawHeight

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 描画領域の高さ（1/10mm単位）

[設定値]

設定不可。

[解説]

DrawHeight プロパティは可変フォーム専用のプロパティです。固定フォームでは使用できません。

描画領域の幅はDrawWidth プロパティで取得します。セクションの高さはSectionHeight プロパティで取得します。現在の描画位置はCurrentTop プロパティで取得します。DrawHeight プロパティとこれらのプロパティを組み合わせて、セクションが描画可能かどうかを判定することができます。
ここで取得される描画領域には、用紙のマージンは含まれていません。

値の参照は、実行時のみ可能です。

[コーディング例]

Dim CurrentTop As Long |
CurrentTop = Jvrlib.DrawHeight | '描画領域の高さ


DrawWidthプロパティ

可変フォームの描画領域の幅を取得します。

[構文]

long = Object.DrawWidth

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 描画領域の幅（1/10mm単位）

[設定値]

設定不可。

[解説]

DrawWidth プロパティは可変フォーム専用のプロパティです。固定フォームでは使用できません。

描画領域の高さはDrawHeight プロパティで取得します。セクションの高さはSectionHeight プロパティで取得します。現在の描画位置はCurrentTop プロパティで取得します。ここで取得される描画領域には、用紙のマージンは含まれていません。

値の参照は、実行時のみ可能です。

[コーディング例]

Dim CurrentTop As Long |
CurrentTop = Jvrlib.DrawWidth | '描画領域の幅


ErrorCodeプロパティ

ErrorCodeプロパティ（レポートライブラリ.NETコントロールのみ）

メソッドを実行した時に発生したエラーコードを取得します。

[構文]

long = Object.ErrorCode

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | エラーコード

[設定値]

設定不可。

[解説]

ErrorCode プロパティはレポートライブラリ.NETコントロール専用のプロパティです。レポートライブラリOCXでは使用できません。

ErrorThrow プロパティを例外を発生させる（JV_ERROR_THROW_VALID）設定にした場合、例外が発生した時のエラーコードは、ErrorCode プロパティで取得します。エラー内容は、ErrorText プロパティで取得します。

※レポートライブラリOCXでは、VisualBasicの場合には Err.Number にエラーコードが入ります。

値の参照は、実行時のみ可能です。

[コーディング例]

レポートライブラリ.NETコントロール

If Jvrnet.ErrorCode = JV_OCXERR_FIELDOVERFLOW Then

Resume Next

End if


ErrorTextプロパティ

ErrorTextプロパティ（レポートライブラリ.NETコントロールのみ）

メソッドを実行した時に発生したエラーコードを取得します。

[構文]

string = Object.ErrorText

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | エラー内容

[設定値]

設定不可。

[解説]

ErrorText プロパティはレポートライブラリ.NETコントロール専用のプロパティです。レポートライブラリOCXでは使用できません。

ErrorThrow プロパティを例外を発生させる（JV_ERROR_THROW_VALID）設定にした場合、例外が発生した時のエラー内容は、ErrorText プロパティで取得します。 エラーコードは、ErrorCode プロパティで取得します。

値の参照は、実行時のみ可能です。


ErrorThrowプロパティ

ErrorThrowプロパティ（レポートライブラリ.NETコントロールのみ）

メソッドを実行した時のエラー処理を設定します。

[構文]

Object.ErrorThrow = enumErrorThrow

Object.ErrorThrow = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | エラー処理（設定値参照）

[設定値]

enumErrorThrow には次の値を指定します。

定数 | 値 | 内容
JV_ERROR_THROW_VALID | 1 | 例外を発生させる(初期値）
JV_ERROR_THROW_INVALID | 0 | 例外を発生させない

[解説]

ErrorThrow プロパティはレポートライブラリ.NETコントロール専用のプロパティです。レポートライブラリOCXでは使用できません。

メソッド実行時に例外を発生させるかどうかを設定します。 値は、列挙型、または long型で設定します。
例外を発生させる設定にすると、メソッド実行時にエラーが起きた時、例外が発生します。エラーハンドラを作成しておく必要があります。例外が発生した時のエラーコードは、ErrorCode プロパティで取得します。エラー内容は、ErrorText プロパティで取得します。
例外を発生させない設定にすると、メソッド実行時にエラーが起きても例外は発生しません。メソッドが正常に終了したかどうかは、メソッドの戻り値で判断します。

※レポートライブラリOCXにはErrorThrowプロパティの機能を持つプロパティはなく、メソッド実行時にエラーが起きた時は必ず例外が発生します。VisualBasicの場合には Err.Number にエラーコードが入ります。

[コーディング例]

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.ErrorThrow = enumErrorThrow.出力しない

（Visual C#）
Jvr.ErrorThrow = enumErrorThrow.出力しない;

（Visual C++）
Jvr->ErrorThrow = enumErrorThrow::出力しない;

’long 型を使う場合

（VisualBasic)
Jvr.ErrorThrow = JV_ERROR_THROW_INVALID

（Visual C#） ※列挙型にキャストします
Jvr.ErrorThrow = (enumErrorThrow)JV_ERROR_THROW_INVALID;

（Visual C++）※列挙型にキャストします
Jvr->ErrorThrow = (enumErrorThrow)JV_ERROR_THROW_INVALID;

’例外を発生させる場合

Jvrnet.ErrorThrow = JV_ERROR_THROW_VALID |
On Error GoTo SampleError |
Call Jvrnet.SetFieldText("伝票番号", "012345678901234567890") |
： |
： |
SampleError: |
MsgBox(Err.Description) | '例外処理の記述
If Jvrnet.ErrorCode = JV_OCXERR_FIELDOVERFLOW Then |
Resume Next |
End if |

’例外を発生させない場合

Jvrnet.ErrorThrow = JV_ERROR_THROW_INVALID

ret = Jvrnet.SetFieldText("伝票番号", "012345678901234567890")

If ret = JV_OCXERR_FIELDOVERFLOW Then

MsgBox("フィールドオーバーフロー")

End if


FieldExプロパティ

フィールドの右下Ｘ座標を取得します。

[構文]

long = Object.FieldEx

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | フィールドの右下Ｘ座標（1/100mm単位）

[設定値]

設定不可。

[解説]

取得するフィールドは、FieldNameプロパティで指定します。
他の座標は、FieldSxプロパティ、FieldSyプロパティ、FieldEyプロパティで取得します。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間） に可能です。

[コーディング例]

Jvr.FieldName = "GRAPH_1" | 'フィールド名称のセット
sx = Jvr.FieldSx | 'フィールドの開始X座標の取得
sy = Jvr.FieldSy | 'フィールドの開始Y座標の取得
ex = Jvr.FieldEx | 'フィールドの終了X座標の取得
ey = Jvr.FieldEy | 'フィールドの終了Y座標の取得


FieldEyプロパティ

フィールドの右下Ｙ座標を取得します。

[構文]

long = Object.FieldEy

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | フィールドの右下Ｙ座標（1/100mm単位）

[設定値]

設定不可。

[解説]

取得するフィールドは、FieldNameプロパティで指定します。
他の座標は、FieldSxプロパティ、FieldSyプロパティ、FieldExプロパティで取得します。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間） に可能です。

[コーディング例]

Jvr.FieldName = "GRAPH_1" | 'フィールド名称のセット
sx = Jvr.FieldSx | 'フィールドの開始X座標の取得
sy = Jvr.FieldSy | 'フィールドの開始Y座標の取得
ex = Jvr.FieldEx | 'フィールドの終了X座標の取得
ey = Jvr.FieldEy | 'フィールドの終了Y座標の取得


FieldInfoプロパティ

フォームファイルのフィールド情報を取得します。

[構文]

Object.FieldInfo = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フィールド情報

[設定値]

設定不可

[解説]

フィールドを取得するフォームは、FormNameプロパティ、PageNoプロパティ、PageKeyプロパティで指定します。

フィールド情報の内容と並び順は次の通りです。項目間はタブで区切られます。

１ | フィールドの種類 |
２ | フィールド名称 |
３ | テキストフィールドの場合 | 編集子
 | グリッドフィールドの場合 | 列数
 | バーコードフィールドの場合 | バーコードの種類
４ | グリッドフィールドのみ | 行数
５ | グリッドフィールドのみ | 編集子

例）
TEXT | テキスト | &&&&&&&&&& |  |  |
GRID | 明細 | COLUMN=2 | ROW=32 | ### | &&&&&&
BARCODE | バーコード | JAN13 |  |  |
IMAGE | イメージ |  |  |  |
GRAPH | 3Dグラフ |  |  |  |

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "C:\Tmp\見積書.jfm"
Jvr.Start
Str = Jvr.FieldInfo
｜
Jvr.End


FieldNameプロパティ

フィールドの座標を取得するフィールド名称を設定します。

[構文]

Object.FieldName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フィールド名称

[設定値]

string にはフィールド名を指定します。 初期値はありません。

[解説]

フィールドの座標は、FieldSx、FieldSy、FieldEx、FieldEyプロパティで取得します。
グリッドフィールドの列数はGridColsプロパティ、行数はGridRowsプロパティで取得します。

値の設定と参照は実行時に可能です。

[コーディング例]

Jvr.FieldName = "GRAPH_1"


FieldQueryプロパティ

デザイン時に設定したフィールドのクエリーを取得します。

[構文]

string = Object.FieldQuery

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フィールドのクエリー

[設定値]

設定不可。

[解説]

取得するフィールドは、FieldNameプロパティで指定します。
値の参照は実行時（FieldNameプロパティ設定後） のみ可能です。

[コーディング例]
Jvr.Start | '印刷開始
Jvr.FieldName = "顧客名称" | 'フィールド名称の指定
query = Jvr.FieldQuery | 'クエリーの取得


FieldSxプロパティ

フィールドの左上Ｘ座標を取得します。

[構文]

long = Object.FieldSx

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | フィールドの左上Ｘ座標（1/100mm単位）

[設定値]

設定不可。

[解説]

取得するフィールドは、FieldNameプロパティで指定します。
他の座標は、FieldSyプロパティ、FieldExプロパティ、FieldEyプロパティで取得します。
値の参照は、実行時（StartメソッドとEndまたはAbortメソッドの間） に可能です。

[コーディング例]

Jvr.FieldName = "GRAPH_1" | 'フィールド名称のセット
sx = Jvr.FieldSx | 'フィールドの開始X座標の取得
sy = Jvr.FieldSy | 'フィールドの開始Y座標の取得
ex = Jvr.FieldEx | 'フィールドの終了X座標の取得
ey = Jvr.FieldEy | 'フィールドの終了Y座標の取得


FieldSyプロパティ

フィールドの左上Ｙ座標を取得します。

[構文]

long = Object.FieldSy

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | フィールドの左上Y座標（1/100mm単位）

[設定値]

設定不可。

[解説]

取得するフィールドは、FieldNameプロパティで指定します。
他の座標は、FieldSxプロパティ、FieldExプロパティ、FieldEyプロパティで取得します。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間） に可能です。

[コーディング例]

Jvr.FieldName = "GRAPH_1" | 'フィールド名称のセット
sx = Jvr.FieldSx | 'フィールドの開始X座標の取得
sy = Jvr.FieldSy | 'フィールドの開始Y座標の取得
ex = Jvr.FieldEx | 'フィールドの終了X座標の取得
ey = Jvr.FieldEy | 'フィールドの終了Y座標の取得


FillPatternプロパティ

図形の塗り潰しパターンを設定します。

[構文]

Object.FillPattern = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 塗り潰しパターン（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_FILL_NULL | 0 | 塗り潰しなし
JV_FILL_SOLID | 1 | 前景色で塗り潰し（初期値）
JV_FILL_DKGRAY | 2 | 濃い灰色
JV_FILL_GRAY | 3 | 灰色
JV_FILL_LTGRAY | 4 | 薄い灰色
JV_FILL_WHITE | 5 | 白
JV_FILL_FDIAGONAL | 6 | 45度右上がりハッチ
JV_FILL_BDIAGONAL | 7 | 45度右下がりハッチ
JV_FILL_HORIZONTAL | 8 | 水平ハッチ
JV_FILL_VERTICAL | 9 | 垂直ハッチ
JV_FILL_CROSS | 10 | 水平と垂直のクロスハッチ
JV_FILL_DIAGCROSS | 11 | 45度のクロスハッチ
201～248ビットマップパターン

[解説]

DrawBoxメソッドなどの図形描画メソッドで図形を描画する時は、FillPattern プロパティで塗り潰しパターンを指定します。改ページでページが変わった時には再設定が必要です。FillPatternプロパティではフォームに描画された図形の塗り潰しパターンを変更することはできません。
201～248のビットマップパターンは『付録／網掛けパターン』を参照してください。

値の設定と参照はデザイン時、実行時に可能です。
設定場所や参照場所に制限はありません。

[コーディング例]

Jvr.FillPattern = JV_FILL_SOLID | '前景色で塗り潰し
Jvr.FillPattern = JV_FILL_CROSS | '水平と垂直のクロスハッチ


FontAngleプロパティ

フォントの回転角度を設定します。

[構文]

Object.FontAngle = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 回転角度

[設定値]

long には0度～359度の値を指定します。 初期値は0度です。
反時計回りに回転します。

[解説]

FontAngleプロパティは、DrawTextメソッドで文字を描画する時の文字回転を設定する時に使います。DrawTextメソッドを実行する前に設定します。改ページでページが変わった時には再設定が必要です。FontAngleプロパティではフォームに描画された文字やフィールドの文字回転を変更することはできません。

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.FontAngle = 90　'９０度回転


FontBoldプロパティ

フォントのボールドを設定します。

[構文]

レポートライブラリOCX

Object.FontBold = long

レポートライブラリ.NETコントロール

Object.FontBold = enumFontBold

Object.FontBold = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumFontBold | ボールド（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_BOLD_OFF | 0 | ボールド解除（初期値）
JV_BOLD_ON | 1 | ボールド設定

enumFontBold （列挙型）には次の値を指定します。

値

ボールド解除

ボールド設定

[解説]

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

FontBoldプロパティは、DrawTextメソッドで文字を描画する時のボールドを指定します。ボールド設定はDrawTextメソッドを実行する前に行います。改ページでページが変わった時には再設定が必要です。
FontBoldプロパティではフォームに描画された文字やフィールドのボールドを変更することはできません。フォームの設定を変える場合は、SetFieldLong メソッドを使います。

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

レポートライブラリOCX

Jvr.FontBold = JV_BOLD_ON　　 'ボールドにする

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.FontBold = enumFontBold.ボールド設定

（Visual C#）
Jvr.FontBold = enumFontBold.ボールド設定;

（Visual C++）
Jvr->FontBold = enumFontBold::ボールド設定;

’long 型を使う場合

（VisualBasic)
Jvr.FontBold = JV_BOLD_ON　　 'ボールドにする

（Visual C#） ※列挙型にキャストします
Jvr.FontBold = (enumFontBold)JV_BOLD_ON;

（Visual C++）※列挙型にキャストします
Jvr->FontBold = (enumFontBold)JV_BOLD_ON;


FontItalicプロパティ

フォントのイタリックを設定します。

[構文]

レポートライブラリOCX

Object.FontItalic = long

レポートライブラリ.NETコントロール

Object.FontItalic = enumFontItalic

Object.FontItalic = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumFontItalic | イタリック（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_ITALIC_OFF | 0 | イタリック解除（初期値）
JV_ITALIC_ON | 1 | イタリック設定

enumFontItalic（列挙型）には次の値を指定します。

値

イタリック解除

イタリック設定

[解説]

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

FontItalicプロパティは、DrawTextメソッドで文字を描画する時のイタリックを設定する時に使います。イタリックの設定はDrawTextメソッドを実行する前に行います。改ページでページが変わった時には再設定が必要です。
FontItalicプロパティではフォームに描画された文字やフィールドのイタリックを変更することはできません。フォームの設定を変える場合は、SetFieldLong メソッドを使います。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

レポートライブラリOCX

Jvr.FontItalic = JV_ITALIC_ON 　　'イタリックにする

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.FontItalic = enumFontItalic.イタリック設定

（Visual C#）
Jvr.FontItalic = enumFontItalic.イタリック設定;

（Visual C++）
Jvr->FontItalic = enumFontItalic::イタリック設定;

’long 型を使う場合

（VisualBasic)
Jvr.FontItalic = JV_ITALIC_ON 　　'イタリックにする

（Visual C#） ※列挙型にキャストします
Jvr.FontItalic = (enumFontItalic)JV_ITALIC_ON;

（Visual C++）※列挙型にキャストします
Jvr->FontItalic = (enumFontItalic)JV_ITALIC_ON;


FontNameプロパティ

フォント名を設定します。

[構文]

Object.FontName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フォント名（初期値は「ＭＳ 明朝」）

[設定値]

string にはフォント名を指定します。

[解説]

FontNameプロパティは、DrawTextメソッドで文字を描画する時のフォント設定に使います。フォント設定はDrawTextメソッドを実行する前に行います。改ページでページが変わった時には再設定が必要です。
FontNameプロパティでフォームに描画された文字やフィールドのフォントを変更することはできません。

Adobe PDF形式のデータを作成している時に、FontNameプロパティにフォント名を指定すると、1124エラーが発生することがあります。このエラーは、EmbedFont メソッドで全てのフォントを埋め込む設定にしている場合に起こります。エラーが発生した時は、FontNameプロパティで指定したフォントのフォントファイルがない、または、指定したフォントがTrue Typeフォントではないなどの原因が考えられます。

－Adobe PDF形式データにフォントを埋め込む

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.FontName = "ＭＳ Ｐゴシック"


FontScaleプロパティ

フォントの横幅の拡大縮小率を設定します。

[構文]

Object.FontScale = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 拡大縮小率(%) （初期値は100）

[設定値]

long には1～1000の値を指定します。

[解説]

FontScaleプロパティは、DrawTextメソッドで文字を描画する時のフォント横幅拡大縮小率を設定する時に使います。この設定はDrawTextメソッドを実行する前に行います。改ページでページが変わった時には再設定が必要です。FontScaleプロパティではフォームに描画された文字やフィールドのフォント横幅拡大縮小率を変更することはできません。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.FontScale = 200 　　'横方向に２倍拡大する


FontSizeプロパティ

フォントのサイズを設定します。

[構文]

Object.FontSize = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | サイズ(1/10ポイント単位) （初期値は120）

[設定値]

long には1～2000の値を指定します。

[解説]

FontSizeプロパティは、DrawTextメソッドで文字を描画する時のフォントサイズを設定する時に使います。フォントサイズ設定はDrawTextメソッドを実行する前に行います。改ページでページが変わった時には再設定が必要です。
FontSizeプロパティではフォームに描画された文字やフィールドのフォントサイズを変更することはできません。フォームの設定を変える場合は、SetFieldLong メソッドを使います。

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.FontSize = 100 　　'10ポイント


FormCommentプロパティ

レポートエディタのフォームファイル情報で設定したフォームの説明を取得します。

[構文]

string = Object.FormComment

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フォームの説明

[設定値]

設定不可。

[解説]

レポートエディタのフォームファイル情報で設定した情報は、FormTitleプロパティ、FormCreatorプロパティ、FormCommentプロパティで取得することができます。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]
Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
comment = Jvr.FormComment | 'コメントの取得


FormCreaterプロパティ

FormCreatorプロパティ

レポートエディタのフォームファイル情報で設定したフォーム作成者を取得します。

[構文]

string = Object.FormCreator

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フォームの作成者

[設定値]

設定不可。

[解説]

レポートエディタのフォームファイル情報で設定した情報は、FormTitleプロパティ、FormCreatorプロパティ、FormCommentプロパティで取得することができます。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]
Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
creator = Jvr.FormCreator | '作成者の取得


FormHeightプロパティ

デザイン時に設定した用紙の高さを取得します。

[構文]

long = Object.FormHeight

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 用紙の高さ （1/10mm単位）

[設定値]

設定不可。

[解説]

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formHeight = Jvr.FormHeight | '用紙の高さの取得


FormNameプロパティ

フォームファイルを設定します。

[構文]

Object.FormName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フォームファイル名

[設定値]

string にはフォームファイル名を指定します。 初期値はありません。

[解説]

フォームファイル名はフルパスで指定します。
FormPathプロパティで、フォームファイルの検索パスを設定することができます。検索パスを設定した場合は、検索パスが最初に検索されます。
フォームファイルの中に複数のフォームが保存されている場合、使用するフォームは、PageNoプロパティやPageKeyプロパティで指定します。

値の設定は、デザイン時、実行時に可能です。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始


FormOrientプロパティ

デザイン時に設定した用紙方向を取得します。

[構文]

long = Object.FormOrient

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 用紙方向

[設定値]

F設定不可。

[解説]

long には次の値が返ります。

定数 | 値 | 内容
JV_ORIENT_PORTLAIT | 1 | 縦置き
JV_ORIENT_LANDSCAPE | 2 | 横置き

FormOrientプロパティの値は、プリンタドライバ情報の用紙方向として使用できます。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

－プリンタドライバ情報とは
－プリンタドライバ情報の取得方法

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formOrient = Jvr.FormOrient | '用紙の方向の取得


FormPathプロパティ

フォームファイルの検索パスを設定します。

[構文]

Object.FormPath = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 検索パス

[設定値]

string には、検索パスを256バイト以下で設定します。 初期値はありません。

[解説]

FormPathプロパティで指定されたパスは、最初の検索パスとなります。
値の設定は、デザイン時、実行時に可能です。Startメソッドの前で設定する場合には設定場所の制限はありません。Startメソッドの後で設定する場合には、FormNameプロパティの前で設定します。

値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.FormPath = "c:\Program Files\JiveReport" | 'パスの指定
Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始


FormQueryプロパティ

デザイン時に設定したフォームのクエリーを取得します。

[構文]

string = Object.FormQuery

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フォームのクエリー

[設定値]

設定不可。

[解説]

レポートエディタのフォームファイル情報で設定した情報は、FormTitleプロパティ、FormCreatorプロパティ、FormCommentプロパティで取得することができます。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]
Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
query = Jvr.FormQuery | 'クエリーの取得


FormScaleプロパティ

フォームを描画する時の拡大縮小率を設定します。

[構文]

Object.FormScale = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 拡大縮小率(%) （初期値は100）

[設定値]

long には1～1000の値を指定します。

[解説]

FormScaleプロパティは、出力先がRDF形式、Adobe PDF形式、XPS形式の場合には無効です。
RDF形式の場合には、プレビューコントロールのScaleプロパティを使って拡大縮小を行います。
Adobe PDF形式の場合には、Adobe Readerの機能を使って拡大縮小を行います。
XPS形式の場合には、XPS Viewerの機能を使って拡大縮小を行います。

拡大縮小率を設定しても、用紙の余白は変わりません。
詳細は「付録／用紙の余白（マージン）設定」を参照してください。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.FormScale = 50　　　 '1/2縮小


FormSizeプロパティ

デザイン時に設定した用紙サイズを取得します。

[構文]

long = Object.FormSize
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 用紙サイズ

[設定値]

設定不可。

[解説]

long には次の値が返ります。

定数 | 値 | 内容
JV_SIZE_A3 | 8 | A3
JV_SIZE_B4 | 12 | B4
JV_SIZE_A4 | 9 | A4
JV_SIZE_B5 | 13 | B5
JV_SIZE_A5 | 11 | A5
JV_SIZE_HAGAKI | 43 | はがき
JV_SIZE_15X11 | 46 | 15x11inch
JV_SIZE_10X1 | 45 | 10x11inch
JV_SIZE_FREE | 256 | 不定形用紙

FormSize プロパティの値は、プリンタドライバ情報の用紙サイズとして使用できますが、不定形用紙（ユーザー定義サイズ）は環境によって値が違うため、レポートエディタなどで値を取得し確認してください。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

－プリンタドライバ情報とは
－プリンタドライバ情報の取得方法

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formSize = Jvr.FormSize | '用紙サイズの取得


FormTitleプロパティ

レポートエディタのフォームファイル情報で設定したフォームファイル名称を取得します。

[構文]

string = Object.FormTitle

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フォームファイル名称

[設定値]

設定不可。

[解説]

レポートエディタのフォームファイル情報で設定した情報は、FormTitleプロパティ、FormCreatorプロパティ、FormCommentプロパティで取得することができます。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]
Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formTitle = Jvr.FormTitle | 'フォームファイル名称の取得


FormWidthプロパティ

デザイン時に設定した用紙の幅を取得します。

[構文]

long = Object.FormWidth

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 用紙の幅 （1/10mm単位）

[設定値]

設定不可。

[解説]

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formWidth = Jvr.FormWidth | '用紙の幅の取得


FormXMarginプロパティ

フォームの横方向のマージンを取得します。

[構文]

long = Object.FormXMargin

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 横マージン （1/10mm単位）

[設定値]

設定不可。

[解説]

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formXMargin = Jvr.FormXMargin | 'フォームの横マージンの取得


FormYMarginプロパティ

フォームの縦方向のマージンを取得します。

[構文]

long = Object.FormYMargin

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 縦マージン （1/10mm単位）

[設定値]

設定不可。

[解説]

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "確定申告書.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
formYMargin = Jvr.FormYMargin | 'フォームの縦マージンの取得


FrColorプロパティ

前景色を設定します。

[構文]

Object.FrColor = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 前景色 （初期値は黒）

[設定値]

long にはRGB値を指定します。

[解説]

値の設定と参照はデザイン時、実行時に可能です。
設定場所や参照場所に制限はありません。

[コーディング例]
Jvr.FrColor = RGB(255, 0, 0) | '前景色
Jvr.BkColor = RGB(0, 255, 0) | '背景色


FromPageプロパティ

印刷ダイアログの印刷開始ページを初期設定します。
ユーザーが設定した印刷開始ページを取得します。

[構文]

Object.FromPage = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷開始ページ（初期値は 1）

[設定値]

long には1～10000の値を指定します。

[解説]

印刷開始ページの設定
印刷ダイアログの印刷開始ページに初期値を入れてポップアップさせる時に使います。印刷開始ページは、印刷ダイアログを表示する前に設定しておきます。

印刷開始ページの初期値を設定する場合は、MinPageプロパティとMaxPageプロパティを設定し、FromPageプロパティには、MinPageプロパティとMaxPageプロパティの間の値を指定します。範囲外の値を指定すると、初期値はMinPageプロパティの値になります。

印刷開始ページの取得
印刷ダイアログでユーザーが指定した印刷開始ページを取得する時に使います。ユーザーが印刷開始ページを指定した時は、指定したページから印刷を開始するようにコーディングします。ユーザーが全ページを指定した時は、FromPageプロパティには0が返ります。

印刷終了ページの設定や取得は、 ToPageプロパティを使います。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時（StartメソッドとEndまたはAbortメソッドの間） に可能です。

－印刷ダイアログの表示

[コーディング例]

Jvr.SetPrinter = JV_SPSHOWDIALOG | 印刷ダイアログの設定
Jvr.OutDevice = JV_PRINTER | '出力先をプリンタにする
Jvr.fromPage = 3 | '印刷開始ページの設定
Jvr.Start | '印刷開始
fromPage = Jvr.fromPage | '印刷開始ページの取得


GridColsプロパティ

グリッドフィールドの列数を取得します。

[構文]

Object.GridCols = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 列数

[設定値]

設定不可。

[解説]

列数を取得するグリッドフィールドは、FieldNameプロパティで指定します。

値の参照は実行時のみ可能です。

[コーディング例]

Jvr.FieldName = "明細" | 'フィールドの指定
Cols = Jvr.GirdCols | '列数の取得


GridRowsプロパティ

グリッドフィールドの行数を取得します。

[構文]

Object.GridRows = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 行数

[設定値]

設定不可。

[解説]

行数を取得するグリッドフィールドは、FieldNameプロパティで指定します。

値の参照は実行時のみ可能です。

[コーディング例]

Jvr.FieldName = "明細" | 'フィールドの指定
Cols = Jvr.GirdRows | '行数の取得


GridSeparatorプロパティ

グリッドフィールドデータの区切り記号を設定します。

[構文]

Object.GridSeparator = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 区切り記号（初期値はカンマ）

[設定値]

string にはタブ（chr(9))、スペース、カンマ、コロン、セミコロンのいずれかを指定します。

[解説]

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

''区切り記号をタブコードに変更
Jvr.gridSeparator = Chr(9)


ImageHeightプロパティ

帳票の高さを設定します。

[構文]

Object.ImageHeight = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 高さ(1/100mm単位)

[設定値]

long には帳票の高さを指定します。初期値は0（自動設定）です。

[解説]

ImageHeightプロパティの値は、OutDeviceプロパティの値が「JV_RDF」「JV_RDFSVC」「JV_BMP」の場合のみ有効です。
「0」を指定すると、帳票はFormNameプロパティで指定したフォームの高さで作成され、ページごとにフォームのサイズが変わった場合でも 自動的にフォームの高さで作成されます。独自の値を指定した場合には、フォームのサイズが変わった時にも指定した高さで作成されます。

帳票の幅は、ImageWidthプロパティで設定します。

イメージ形式（BMP）の場合、作成される帳票の解像度は、ウィンドウの解像度と同じになります。
例）
ウィンドウの解像度が96DPIの時、ImageHeightプロパティの値に7000を設定すると、帳票の縦方向のビット数は約265になります。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

jvr.OutDevice = JV_BMP | '出力先をビットマップにする
jvr.ImageFileName = "C:\tmp\jvout.bmp" | 'ビットマップファイル名
jvr.ImageWidth = 21000 | 'イメージの幅(21cm)
jvr.ImageHeight = 29000 | 'イメージの高さ(29cm)
Jvr.Start | '印刷開始


ImagePathプロパティ

イメージファイルの検索パスを設定します。

[構文]

Object.ImagePath = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 検索パス

[設定値]

string にはイメージファイル検索パスを256バイト以下で設定します。
初期値はありません。

[解説]

ImagePathプロパティの値は、最も優先順位の高いイメージファイル検索パスとなります。
DrawImageメソッドとSetFieldImageメソッドでイメージを描画する前に設定します。
値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

jvr.ImagePath = "c:\JiveReport\Images"
Jvr.DrawImage(3500, 1200, 0, 0, 360, JV_TRANSPARENT, "cup.dib")


ImageWidthプロパティ

帳票の幅を設定します。

[構文]

Object.ImageWidth = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 幅(1/100mm単位)

[設定値]

long には帳票の幅を指定します。初期値は0（自動設定）です。

[解説]

ImageWidthプロパティの値は、OutDeviceプロパティの値が「JV_RDF」「JV_RDFSVC」「JV_BMP」の場合のみ有効です。
「0」を指定すると、帳票はFormNameプロパティで指定したフォームの幅で作成され、ページごとにフォームのサイズが変わった場合でも 自動的にフォームの幅で作成されます。独自の値を指定した場合には、フォームのサイズが変わった時にも指定した幅で作成されます。
帳票の高さは、 ImageHeight プロパティで設定します。

イメージ形式（BMP）の場合、作成される帳票の解像度は、ウィンドウの解像度と同じになります。
例）
ウィンドウの解像度が96DPIの時、ImageWidthプロパティの値に10000を設定すると、帳票の横方向のビット数は約380になります。

[コーディング例]

jvr.OutDevice = JV_BMP | '出力先をビットマップにする
jvr.ImageFileName = "C:\tmp\jvout.bmp" | 'ビットマップファイル名
jvr.ImageWidth = 21000 | 'イメージの幅(21cm)
jvr.ImageHeight = 29000 | 'イメージの高さ(29cm)
Jvr.Start | '印刷開始


JobIdプロパティ

印刷時の印刷ジョブIDの設定・取得をします。

[構文]

long = Object.JobId

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷ジョブID

[設定値]

long には印刷ジョブIDを指定します。初期値は-1です。

[解説]

印刷ジョブIDの取得
印刷ジョブIDを取得する時は、OutDeviceプロパティに「JV_PRINTER 」を指定します。印刷ジョブIDの取得に失敗した時は-1が返ります。

印刷ジョブIDの設定
JobInfoプロパティやJobStatusプロパティで情報を取得する時には、JobIdプロパティに印刷ジョブIDを設定して情報を取得するジョブを指定します。
印刷ジョブIDを設定する時は、OutDeviceプロパティに「JV_PRINTER 」を指定します。
値の設定は実行時に可能です。値の参照はStartメソッドと、EndメソッドまたはAbortメソッドの間で可能です。

[コーディング例]

印刷ジョブIDの取得と設定

''印刷ジョブIDを取得する
JobId = Jvr.JobId
Jvr.End '印刷終了

''印刷ジョブの状態を取得する
Jvr.PrinterName = "PC-PR201"
Jvr.JobId = JobId
jStatus = Jvr.JobStatus


JobInfoプロパティ

ジョブの全情報を取得します。

[構文]

string = Object.JobInfo

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | ジョブ情報

[設定値]

設定不可。

[解説]

印刷ジョブの全情報を文字列型の値で返します。
情報の内容と並び順は次の通りです。項目間はカンマで区切られます。
ジョブを取得するプリンタは、PrinterNameプロパティで指定します。
情報を取得する印刷ジョブは、JobIdプロパティで指定します。

１．印刷ジョブＩＤ
２．プリンタ名
３．マシン名
４．ユーザー名
５．印刷ジョブ名（DocNameプロパティで指定した名称）
６．印刷ジョブを記録するために使われるデータの種類
７．印刷ジョブの状態（文字列）
８．印刷ジョブの状態（フラグ）
９．ジョブの優先順位
１０．印刷キュー内のジョブの位置
１１．文書のページ数
１２．すでに印刷されたページ数
１３．この文書がスプールされた時間（hh:mm:ss YY/MM/DD)

「８．印刷ジョブの状態」は、次の値のうち、該当する値の合計値となります。

定数 | 値 | 内容
JV_JOBSTATUS_PAUSED | 1 | 一時停止
JV_JOBSTATUS_ERROR | 2 | エラー
JV_JOBSTATUS_DELETING | 4 | 削除中
JV_JOBSTATUS_SPOOLING | 8 | スプール中
JV_JOBSTATUS_PRINTING | 16 | 印刷中
JV_JOBSTATUS_OFFLINE | 32 | オフライン
JV_JOBSTATUS_PAPEROUT | 64 | 紙切れ
JV_JOBSTATUS_PRINTED | 128 | 印刷済み

値の参照は実行時に可能です。設定場所や参照場所に制限はありません。

[コーディング例]

Jvr.PrinterName = "PC-PR201" | 'プリンタの指定
jInfo = Jvr.JobInfo | '印刷ジョブの情報の取得


JobStatusプロパティ

印刷ジョブ状態の取得と設定を行います。

[構文]

long = Object.JobStatus

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ジョブ状態

[設定値]

long には次の値を指定します。 初期値は0です。

定数 | 値 | 内容
JV_JOBCONTROL_PAUSE | 1 | 印刷ジョブを一時停止
JV_JOBCONTROL_RESUME | 2 | 一時停止している印刷ジョブを再開
JV_JOBCONTROL_CANCEL | 3 | 印刷ジョブを削除
JV_JOBCONTROL_RESTART | 4 | 印刷ジョブを再開始

[解説]

状態を取得するジョブは、JobIdプロパティで指定します。
プリンタは、PrinterNameプロパティで指定します。
取得した印刷ジョブ状態は、次の値のうち、該当する値の合計値となります。

定数 | 値 | 内容
JV_JOBSTATUS_PAUSED | 1 | 一時停止
JV_JOBSTATUS_ERROR | 2 | エラー
JV_JOBSTATUS_DELETING | 4 | 削除中
JV_JOBSTATUS_SPOOLING | 8 | スプール中
JV_JOBSTATUS_PRINTING | 16 | 印刷中
JV_JOBSTATUS_OFFLINE | 32 | オフライン
JV_JOBSTATUS_PAPEROUT | 64 | 紙切れ
JV_JOBSTATUS_PRINTED | 128 | 印刷済み

値の設定と参照は、実行時に可能です。設定場所や参照場所に制限はありません。

[コーディング例]

''ジョブIDを取得する
JobId = Jvr.LastJobId
Jvr.End

''印刷ジョブの状態を取得する
Jvr.PrinterName = "PC-PR201"
Jvr.JobId = JobId
jStatus = Jvr.JobStatus


JpegProgressiveプロパティ

JPEG形式で出力する帳票の表示形式を設定します。

[構文]

レポートライブラリOCX

Object.JpegProgressive = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | プログレッシブ（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_JPEG_PROGRESSIVE_ON | 1 | プログレッシブに設定
JV_JPEG_PROGRESSIVE_OFF | 0 | プログレッシブを解除（初期値）

[解説]

JpegProgressiveプロパティを「JV_JPEG_PROGRESSIVE_OFF」にすると、JPEG形式の帳票は、上から徐々に表示されていきます。「JV_JPEG_PROGRESSIVE_ON」にすると、JPEG形式の帳票は、まず画像全体が荒く表示され、徐々に鮮明度を増していきます。

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.JpegProgressive = JV_JPEG_PROGRESSIVE_ON


JpegQualityプロパティ

JPEG形式で出力する帳票の品質を設定します。

[構文]

Object.JpegQuality = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | クオリティ （初期値は100）

[設定値]

long には1～100の値を指定します。

[解説]

数値が低くなるほど、JPEGイメージのサイズは小さくなりますが、品質は劣化します。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.JpegQuality = 50


Keyプロパティ

RDF形式のデータにキーを設定します。

[構文]

Object.Key (index) = string
index : 1 ～　5

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | キー

[設定値]

string にはRDF形式のデータにつけるキーを指定します。

[解説]

キーは、説明やタイトルなどとして利用できます。
キーは、プレビューコントロールのKeyプロパティを使って参照することができます。
キーは、Key(1)からKey(5)までつけることができます。各々32バイト以下で設定します。


LabelHeightプロパティ

ラベルの高さを取得します。

[構文]

long = Object.LabelHeight

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ラベルの高さ

[設定値]

設定不可。

[解説]

LabelHeightプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。

LabelPrintプロパティでフォームの種類を確認することもできます。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
LabelHeight = Jvr.LabelHeight | 'ラベルの高さ


LabelHGapプロパティ

ラベルの横方向の間隔を取得します。

[構文]

long = Object.LabelHGap

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ラベルの横方向の間隔

[設定値]

設定不可。

[解説]

LabelHGapプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。

LabelPrintプロパティでフォームの種類を確認することもできます。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
lLabelHGap = Jvr.LabelHGap | 'ラベルの横方向の間隔


LabelHNoプロパティ

横方向のラベル枚数を取得します。

[構文]

long = Object.LabelHNo

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 横方向のラベル枚数

[設定値]

設定不可。

[解説]

LabelHNoプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。

LabelPrintプロパティでフォームの種類を確認することもできます。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
llLabelHNo = Jvr.LabelHNo | 'ラベル枚数の取得


LabelNoプロパティ

処理の対象となるラベル番号を設定します。

[構文]

Object.LabelNo = long
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ラベル番号

[設定値]

long にはラベル番号を指定します。 初期値はありません。

[解説]

LabelNoプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。
LabelPrintプロパティでフォームの種類を確認することもできます。

1枚のラベル用紙には、通常、縦横に複数のラベルが配置されています。
LabelNoプロパティは、その中の1つを特定するためのプロパティです。
ラベル上のフィールドに値を設定したりラベルを描画したりする前に、LabelNoプロパティでラベル番号を指定します。

ラベル番号は、用紙左上を1とし、右側へ向かって、2、3と番号をつけます。最上段の右上まで進んだら、次は2段目の左側から同様に最後のラベルまで繰り返します。

例）ラベルが横方向に２枚、縦方向に３枚ある場合
1 | 2
3 | 4
5 | 6

値の設定は、実行時に可能です。 値の参照はできません。

－基本的なコーディング

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
Jvr.LabelNo = 1 | 'ラベル番号の指定
Jvr.SetFieldText("住所", "名古屋市中区大須") | 'フィールドの設定
Jvr.SetFieldText("氏名", "じゃいぶ一郎") |
Jvr.SetFieldText("電話", "052-339-9999") |
JvrLabelForm1.DrawForm | 'ラベルの描画


LabelPrintプロパティ

フォームの種類（ラベルフォーム／通常フォーム）を取得します。

[構文]

long = Object.LabelPrint

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | フォームの種類

[設定値]

設定不可。

[解説]

FormNameプロパティに設定されているフォームの種類を取得します。
種類には、ラベル印刷に使用するラベルフォームとそれ以外の通常フォームがあります。

取得値 | 内容
1 | ラベルフォーム
0 | 通常フォーム

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
llLabelPrint = Jvr.LabelPrint | 'フォームの種類


LabelVGapプロパティ

ラベルの縦方向の間隔を取得します。

[構文]

long = Object.LabelVGap

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ラベルの縦方向の間隔

[設定値]

設定不可。

[解説]

LabelVGapプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。

LabelPrintプロパティでフォームの種類を確認することもできます。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
lLabelVGap = Jvr.LabelVGap | 'ラベルの縦方向の間隔


LabelVNoプロパティ

縦方向のラベル枚数を取得します。

[構文]

long = Object.LabelVNo

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 縦方向のラベル枚数

[設定値]

設定不可。

[解説]

LabelVNoプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。

LabelPrintプロパティでフォームの種類を確認することもできます。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
lLabelVNo = Jvr.LabelVNo | 'ラベル枚数の取得


LabelWidthプロパティ

ラベルの幅を取得します。

[構文]

long = Object.LabelWidth

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ラベルの幅

[設定値]

設定不可。

[解説]

LabelWidthプロパティはラベルフォーム専用のプロパティです。ラベル以外のフォームでは使用できません。

LabelPrintプロパティでフォームの種類を確認することもできます。

値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "宛名ラベル.jfm" | 'フォームの指定
Jvr.Start | '印刷開始
llLabelWidth = Jvr.LabelWidth | 'ラベルの幅


LastDllErrorプロパティ

レポートライブラリOCXで発生したエラーの詳しいエラーコードを取得します。

[構文]

long = Object.LastDllError

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | エラーコード

[設定値]

設定不可。

[解説]

レポートライブラリOCXでエラーが発生すると、LastDllErrorプロパティに詳しいエラーコードが入ります。 エラーの内容を詳しく分析する場合は、LastDllErrorプロパティの値を参照し、レポートライブラリDLLのエラーで内容を確認します。LastDllErrorプロパティのエラーコードには、レポートライブラリDLLと同じ値が使われています。

注意：
Adobe PDF形式のデータを作成中、フォントの埋め込みに失敗すると、LastDllErrorプロパティには、失敗した文字コードが入ります。

値の参照は、実行時のみ可能です。

[コーディング例]

''DLLエラーコードを取得する
errCode = Jvr.LastDllError


LastJobIdプロパティ

最後に印刷したジョブＩＤを取得します。

[構文]

long = Object.LastJobId

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 最後に印刷したジョブＩＤ

[設定値]

設定不可。

[解説]

値の参照は、実行時のみ可能です。

[コーディング例]

''ジョブIDを取得する
JobId = Jvr.LastJobId
Jvr.End '印刷終了

''印刷ジョブの状態を取得する
Jvr.PrinterName = "PC-PR201"
Jvr.JobId = JobId
jStatus = Jvr.JobStatus


LeftMarginプロパティ

用紙の左マージンを設定します。

[構文]

Object.LeftMargin = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 左マージン(1/100mm単位)

[設定値]

long には左マージンを指定します。 初期値は0です。

[解説]

用紙の上マージンの設定には、TopMarginプロパティを使用します。

フォームに余白が設定されている場合には、フォームの余白に加算されます。
マイナス値を設定することもできます。
詳細は「付録／用紙の余白（マージン）設定」を参照してください。

余白は、ジャイブレポートのバージョンによって仕様が異なります。ご注意ください。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.LeftMargin = -500 | '左へ5mm移動
Jvr.LeftMargin = 1000 | '右へ10mm移動


LineStyleプロパティ

線の種類を設定します。

[構文]

Object.LineStyle = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 種類を表す定数または値（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_PS_SOLID | 0 | 実線 （初期値）
JV_PS_DASH | 1 | 破線
JV_PS_DOT | 2 | 点線
JV_PS_DASHDOT | 3 | 一点鎖線
JV_PS_DASHDOTDOT | 4 | 二点鎖線

[解説]

DrawLineメソッドやDrawBoxメソッドなどの図形描画メソッドで図形を描画する時は、LineStyle プロパティを使って線の種類を設定します。LineStyle プロパティは、改ページでページが変わった時には再設定が必要です。
LineStyle プロパティではフォームに描画された図形の線の種類を変更することはできません。
値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.LineStyle = JV_PS_DASH '破線


LineWidthプロパティ

線の幅を設定します。

[構文]

Object.LineWidth = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 線の幅(1/100mm単位)

[設定値]

long には0以上の値を指定します。初期値は0（出力デバイスの最小幅）です。

[解説]

0を指定すると、線の幅は出力デバイスの最小幅に設定されるため、出力デバイスの解像度によって線の幅が変わります。
DrawLineメソッドやDrawBoxメソッドなどの図形描画メソッドで図形を描画する時は、LineWidth プロパティを使って線の幅を設定します。LineWidth プロパティは、改ページでページが変わった時には再設定が必要です。
LineWidth プロパティではフォームに描画された図形の線の幅を変更することはできません。
値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.LineWidth = 300 | '線の幅を3mmに設定
Jvr.LineWidth = 0 | '線の幅を1ピクセルに設定


MaxPageプロパティ

印刷ダイアログで指定できる最大ページを設定します。

[構文]

Object.MaxPage = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 最大ページ数（初期値は1）

[設定値]

long には1～10000の値を指定します。

[解説]

MaxPageプロパティが設定されると、印刷ダイアログ上で、MaxPageプロパティより大きな値を指定することができなくなります。
最小値の設定にはMinPageプロパティを使用します。
MinPageプロパティとMaxPageプロパティが未指定の場合、または、MinPageプロパティとMaxPageプロパティに0が指定された場合、印刷ダイアログでは全ページ印刷のみとなり、印刷ページの指定ができなくなります。

値の設定と参照はデザイン時、実行時に可能です。設定場所や参照場所に制限はありません。

[コーディング例]

Jvr.MaxPage = 12 '最終ページを１２に設定


MinPageプロパティ

印刷ダイアログで指定できる最小ページを設定します。

[構文]

Object.MinPage = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 最小ページ数（初期値は1）

[設定値]

long には1～10000の値を指定します。

[解説]

MinPageプロパティが指定されると、印刷ダイアログ上で、MinPageプロパティより小さな値を指定することができなくなります。
最小値の設定にはMaxPageプロパティを使用します。
MinPageプロパティとMaxPageプロパティが未指定の場合、または、MinPageプロパティとMaxPageプロパティに0が指定された場合、印刷ダイアログでは全ページ印刷のみとなり、印刷ページの指定ができなくなります。

値の設定と参照はデザイン時、実行時に可能です。設定場所や参照場所に制限はありません。

[コーディング例]

Jvr.MinPage = 3 '最小ページを３に設定


NumOverFlowプロパティ

数値型フィールドにオーバーフロー時の代替文字を設定します。

[構文]

Object.NumOverFlow = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | オーバーフロー時の代替文字（初期値は * ）

[設定値]

string には代替文字を1文字で指定します。

[解説]

出力する数値が、設定した編集子の桁数を超えた時の代替文字を設定します。
NumOverFlowプロパティは、編集子が数値型のテキストフィールドとグリッドフィールドに使います。
編集子が文字型のテキストフィールドとグリッドフィールドには、CharOverFlowプロパティを使います。

NumOverFlowプロパティでオーバーフロー時の処理を設定しても、オーバーフローが発生した時には、オーバーフローをユーザーに知らせるため、SetFieldTextメソッドやSetFieldGridメソッドで、1042のオーバーフローエラー（例外）が発生します。エラーが発生しても処理を続行する場合には、エラーハンドラを作成し、その中で、1042エラーの処理を記述しておきます。
レポートライブラリ.NETコントロールでは、ErrorThrowプロパティで例外を発生させるかどうかの指定ができます。例外を発生させないように指定している場合には、オーバーフローが起きても例外は発生しません。オーバーフローが起きたかどうかはリターンコードで確認することができます。

デザイン時、実行時に値の設定・参照ができます。設定場所や参照場所に制限はありません。

－フィールド編集子

※ヘルプの「アプリケーション開発／フィールドオーバーフローエラー処理」に言語ごとのコーディングサンプルがあります。

[コーディング例 ]
jvr.NumOverFlow = "" | '数値ﾌｨｰﾙﾄﾞｵｰﾊﾞｰﾌﾛｰ時、出力しない
jvr.NumOverFlow = "*" | '数値ﾌｨｰﾙﾄﾞｵｰﾊﾞｰﾌﾛｰ時、* を出力


OutDeviceプロパティ

帳票の出力先を設定します。

[構文]

レポートライブラリOCX

Object.OutDevice = long

レポートライブラリ.NETコントロール

Object.OutDevice = enumOutDevice

Object.OutDevice = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long / enumOutDevice | 出力先（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_WINDOW | 1 | ウィンドウへ出力
JV_PRINTER | 2 | プリンタへ出力（初期値）
JV_BMP | 3 | BMP形式で出力
JV_RDF | 5 | RDF形式で出力
JV_PDF | 9 | Adobe PDF形式で出力
JV_JPEG | 10 | JPEG形式で出力
JV_TIFF | 11 | TIFF形式で出力
JV_PNG | 12 | PNG形式で出力
JV_XPS | 13 | XPS形式で出力

enumOutDevice （列挙型）には次の値を指定します。

値

ウィンドウへ出力

プリンタへ出力

ビットマップ形式で出力

RDF形式で出力

RDFサービスへ出力

PDF形式で出力

JPEG形式で出力

TIFF形式で出力

PNG形式で出力

XPS形式で出力

[解説]

レポートライブラリOCXの場合は、long型で値を設定します。
レポートライブラリ.NETコントロールの場合は、列挙型、または long型で値を設定します。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

ウィンドウへ出力
帳票をアプリケーションの画面に表示します。出力する画面はWinHdcプロパティで設定します。

プリンタへ出力
帳票をプリンタへ出力します。出力するプリンタはPrnHdcプロパティで設定します。

RDF形式で出力
帳票をRDF形式で出力します。帳票のサイズは、FormNameプロパティで指定されたフォームのサイズになります。それ以外のサイズにする場合には、ImageWidthプロパティとImageHeightプロパティで設定します。 帳票は、Endメソッドコール後にDocumentDataプロパティで取り出し、Web環境で使うことができます。ファイルに保存する場合には、OutFileNameプロパティを使います。保存したファイルはプレビューコントロールを使ってプレビューや印刷を行います。

－RDF形式を使ったWeb帳票システム
－RDFデータ作成
－RDFファイル作成

Adobe PDF形式で出力
帳票を Adobe PDF形式 で出力します。帳票は、Endメソッドコール後にDocumentDataプロパティで取り出し、Web環境で使うことができます。ファイルに保存する場合には、OutFileNameプロパティを使います。保存したファイルは、Adobe Readerを使ってプレビューや印刷を行います。

－Adobe PDF形式を使ったWeb帳票システム
－Adobe PDFファイル作成
－Adobe PDFデータ作成
－Adobe PDF形式の制限

TIFF形式で出力
帳票をTIFF形式で出力します。帳票のサイズは、FormNameプロパティで指定されたフォームのサイズになります。帳票は、Endメソッドコール後にDocumentDataプロパティで取り出し、Web環境で使うことができます。ファイルに保存する場合には、OutFileNameプロパティを使います。保存したファイルはフォトギャラリーなどのイメージツールを使ってプレビューや印刷を行います。

－TIFF形式を使ったWeb帳票システム

XPS形式で出力
帳票をXPS形式で出力します。帳票のサイズは、FormNameプロパティで指定されたフォームのサイズになります。帳票は、Endメソッドコール後にDocumentDataプロパティで取り出し、Web環境で使うことができます。ファイルに保存する場合には、OutFileNameプロパティを使います。保存したファイルはXPS Viewerを使ってプレビューや印刷を行います。

－XPS形式を使ったWeb帳票システム

BMP形式・JPEG形式・PNG形式で出力
帳票をBMP・JPEG・PNG形式で出力します。帳票のサイズは、FormNameプロパティで指定されたフォームのサイズになります。ファイルに保存する場合には、OutFileNameプロパティを使います。帳票は、NewPageメソッドをコールすると作成されます。複数ページある場合は、NewPageメソッドごとに上書きされるので対策が必要です。

[コーディング例]

レポートライブラリOCX

jjvr.OutDevice = JV_WINDOW | 'ウィンドウへ出力
jvr.WinHdc = PictureDraw.hDC | 'ウィンドウハンドル設定
jjvr.Start |

レポートライブラリ.NETコントロール

’列挙型を使う場合

（VisualBasic)
Jvr.OutDevice = enumOutDevice.RDF形式で出力

（Visual C#）
Jvr.OutDevice = enumOutDevice.RDF形式で出力;

（Visual C++）
Jvr->OutDevice = enumOutDevice::RDF形式で出力;

’long 型を使う場合

（VisualBasic)
Jvr.OutDevice = JV_RDF

（Visual C#） ※列挙型にキャストします
Jvr.OutDevice = (enumOutDevice)jvrvcsocx.JV_RDF;

（Visual C++）※列挙型にキャストします
Jvr->OutDevice = (enumOutDevice)JV_RDF;


OutFileNameプロパティ

帳票をファイルに保存する時のファイル名を設定します。

[構文]

Object.OutFileName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 出力ファイル名

[設定値]

string には出力ファイル名を指定します。

[解説]

OutFileNameプロパティは、帳票をファイルに保存する時に使います。
ファイルは、Endメソッド、または、NewPaｇｅメソッドをコールした後に作成されます。
作成されるファイルの種類は、OutDeviceプロパティの値によって異なります。(下表参照）

ＯｕｔＤｅｖｉｃｅの値 | 作成ファイル | ファイルが作成される時
JV_PRINTER | プリンタ言語ファイル | Endメソッドコール後
JV_BITMAP | ビットマップファイル | ＮｅｗＰａｇｅメソッドコール後
JV_RDF | RDＦファイル | Endメソッドコール後
JV_PDF | Adobe PDFファイル | Endメソッドコール後
JV_JPEG | JPEGファイル | ＮｅｗＰａｇｅメソッドコール後
JV_TIFF | TIFFファイル | Endメソッドコール後
JV_PNG | PNGファイル | ＮｅｗＰａｇｅメソッドコール後
JV_XPS | XPSファイル | Endメソッドコール後

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

プリンタ言語ファイルを作成する時は、ファイル出力機能があるプリンタドライバを使用します。

[コーディング例]

Jvr.OutDevice = JV_PRINTER | 'プリンタへ出力
Jvr.OutFileName = "c:\tmp\Out.Prn" | '出力ファイル名の指定
Jvr.Start |


OutLineプロパティ

図形の輪郭線を設定します。

[構文]

Object.OutLine = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 輪郭線（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_OUTLINE_OFF | 0 | 輪郭線を描画しない
JV_OUTLINE_ON | 1 | 輪郭線を描画する（初期値）

[解説]

OutLine プロパティは、DrawBoxメソッドなどの図形描画メソッドで図形を描画する時に使います。OutLine プロパティは、改ページでページが変わった時には再設定が必要です。
OutLine プロパティではフォームに描画された図形の輪郭線を変更することはできません。
値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.OutLine = JV_OUTLINE_ON | '輪郭線を描画
Jvr.LineWidth = 1 | '線の幅(1/100ｍｍ)
rptr = JV_ROUND_LT Or JV_ROUND_RB | '角丸め位置（左上、右下）
Jvr.DrawBox(500, 1000, 3000, 4000, 300, rptr) | 'ﾎﾞｯｸｽの描画


PageCountプロパティ

フォームのページ数を取得します。

[構文]

long = Object.PageCount

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ページ数

[設定値]

設定不可。

[解説]

FormNameプロパティに設定されているフォームファイルの総ページ数を取得します。
値の参照は、デザイン時、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）に可能です。

[コーディング例]

Jvr.FormName = "確定申告書.jfm | 'フォームの指定
Jvr.Start | '印刷開始
PageCount = Jvr.PageCount | 'ページ数の取得


PageKeyプロパティ

描画に使用するフォームをページキーで設定します。

[構文]

Object.PageKey = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | ページキー

[設定値]

string にはページキーを指定します。 初期値はありません。

[解説]

PageKeyプロパティは固定フォーム専用のプロパティです。可変フォームでは使用できません。

PageKeyプロパティやPageNoプロパティは、FormNameプロパティで指定したフォームファイルの中から、描画に使用するフォームを指定する時に使います。

PageKeyプロパティは、ページキーでフォームを指定する場合に使います。ページ番号でフォームを指定する場合にはPageNoプロパティを使います。PageKeyプロパティを使う場合は、PageNoプロパティには0を設定しておきます。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.FormName = "伝票.jfm | 'フォームの指定
Jvr.PageNo = 0 | 'PageNoﾌﾟﾛﾊﾟﾃｨを無効にする
Jvr.PageKey = “納品書” | 'ﾍﾟｰｼﾞｷｰが納品書のフォームを指定


PageNoプロパティ

描画に使用するフォームをページ番号で設定します。

[構文]

Object.PageNo = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ページ番号 （初期値は1）

[設定値]

long にはページ番号を指定します。

[解説]

PageNoプロパティは固定フォーム専用のプロパティです。可変フォームでは使用できません。

PageKeyプロパティやPageNoプロパティは、FormNameプロパティで指定したフォームファイルの中から、描画に使用するフォームを指定する時に使います。

PageNoプロパティは、ページ番号でフォームを指定する場合に使います。ページキーでフォームを指定する場合にはPageKeyプロパティを使います。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.FormName = "伝票.jfm | 'フォームの指定
Jvr.PageNo = 3 | '３ページ目に設定する


PrinterAllDataTypeプロパティ

すべてのプリントデータ型を取得します。

[構文]

string = Object.PrinterAllDataType
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントデータ型

[設定値]

設定不可。

[解説]

プリンタに設定されているプリントプロセッサのプリントデータ型をすべて取り出します。
取得したプリントデータ型が複数ある場合、それぞれの値はカンマで区切られます。

プリントデータ型を取得するプリンタは、PrinterNameプロパティで指定します。
プリンタ名を指定しなかった場合、値を取得するプリンタは、コントロールパネルで通常使うプリンタに指定されているプリンタとなります。
プリントデータ型はプリンターのプロパティのプリントプロセッサ画面にある”既定のデータ型”です。

値の参照は実行時のみ可能です。

[コーディング例]

Dim sBuffer As String
sBuffer = Jvrlib.PrinterAllDataType


PrinterAllProcNameプロパティ

すべてのプリントプロセッサ名を取得します。

[構文]

string = Object.PrinterAllProcName
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントプロセッサ名

[設定値]

設定不可。

[解説]

プリンタが属するプリントサーバーにあるプリントプロセッサ名をすべて取り出します。
取得したプリントプロセッサ名が複数ある場合、それぞれの値はカンマで区切られます。

プリントプロセッサ名を取得するプリンタは、PrinterNameプロパティで指定します。
プリンタ名を指定しなかった場合、値を取得するプリンタは、コントロールパネルで通常使うプリンタに指定されているプリンタとなります。

値の参照は実行時のみ可能です。

[コーディング例]

Dim sPrintProc As String
sPrintProc = Jvrlib.PrinterAllProcName


PrinterAllServerNameプロパティ

すべてのプリントサーバー名を取得します。

[構文]

string = Object.PrinterAllServerName
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントサーバー名

[設定値]

設定不可。

[解説]

接続されているすべてのプリントサーバー名を取り出します。
取得したプリントサーバー名が複数ある場合、それぞれの値はカンマで区切られます。

値の参照は実行時のみ可能です。

[コーディング例]

Dim sPrintServer As String
sPrintServer = Jvrlib.PrinterAllServerName


PrinterDataTypeプロパティ

プリンタプロパティの「プリントデータ型」を設定します。 値の取得も可能です。

[構文]

Object.PrinterDataType = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントデータ型

[設定値]

string にはプリントデータ型を指定します。初期値はありません。

[解説]

PrinterDataTypeは、コントロールパネルのプリンタのプロパティ詳細設定画面にある「プリントデータ型」をアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンタのプロパティ詳細設定画面から設定することもできます。

指定できるプリントデータ型は、PrinterAllDataTypeプロパティで調べることができます。
コントロールパネルのプリンタのプロパティ詳細画面で調べることもできます。

RAW形式にするには　"RAW"　を指定し、EMF形式にするには　"NT EMF 1.006"などを指定します。
イメージや２次元バーコード等が正しく印刷されない場合には、RAW形式にすると改善されることがあります。
データ型を設定しなかった場合、デフォルトのプリントデータ型が使われます。

プリントデータ型を設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名を指定しなかった場合、値を設定するプリンタは、コントロールパネルで通常使うプリンタに指定されているプリンタとなります。

PrinterDataTypeを使ってプロパティを設定すると、アプリケーション終了後も設定されたままの状態となります。
一時的に、印刷を実行するドキュメントにプリントデータ型の設定を行う場合は、DocumentDataTypeを使います。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterDataType = "RAW"


PrinterDefaultNameプロパティ

標準プリンタの名前を取得します。

[構文]

string = Object.PrinterDefaultName

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 標準プリンタ名

[設定値]

設定不可。

[解説]

パソコンで「通常使うプリンタ」として設定されているプリンタ名称を取得します。

PrinterDefaultName プロパティはどこでも参照することができます。
値の参照は、実行時のみ可能です。

[コーディング例]

Dim sPrinterDefaultName As String |
sPrinterDefaultName = Jvrlib.PrinterDefaultName | '標準プリンタ名


PrinterDoCmpleteFirstプロパティ

プリンタプロパティの「スプールされたドキュメントを最初に印刷する」を設定します。 値の取得も可能です。

[構文]

Object.PrinterDoCmpleteFirst = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | スプールされたドキュメントを最初に印刷する（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_PRNINFO_VALUE_ON | 1 | スプールされたドキュメントを最初に印刷する
JV_PRNINFO_VALUE_OFF | 0 | スプールされたドキュメントを最初に印刷しない

[解説]

PrinterDoCmpleteFirstは、コントロールパネルのプリンターのプロパティ詳細設定画面にある「スプールされたドキュメントを最初に印刷する」プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

PrinterDoCmpleteFirstを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

スプールされたドキュメントを最初に印刷しない設定にすると、スプールが完了した文書があっても優先順位のより高い文書がスプール中であれば、そちらが優先されます。

プロパティを設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterDoCmpleteFirst = JV_PRNINFO_VALUE_OFF


PrinterDevModeプロパティ

プリンタドライバのプロパティをアプリケーション実行時に設定または取得します。

[構文]

Object.PrinterDevMode = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリンタドライバ情報（ドライバ設定ファイル ）

[設定値]

string にはプリンタドライバ情報、またはプリンタドライバ設定ファイルを指定します。

[解説]

PrinterDevMode プロパティの値は、1つの印刷ジョブ（StartメソッドからEndメソッドの間）の中で何度でも変更できます。
PrinterDevMode プロパティは、OutDeviceプロパティの値が「JV_PRINTER」「JV_RDF」「JV_RDFSVC」の場合のみ有効です。
値の設定は、デザイン時、実行時（Startメソッドの前、NewPageメソッドの後） に可能です。
値の参照は、デザイン時、実行時に可能です。

－ プリンタドライバ情報とは
－ドライバ設定ファイルとは

プリンタドライバの設定
PrinterDevMode プロパティには、プリンタドライバ情報、または、プリンタドライバ設定ファイルのどちらかを設定することができます。
PrinterDevMode プロパティを使う時は、SetPrinterプロパティに「JV_SPDEVMODE」を指定します。プリンタは、PrinterNameプロパティで設定します。 Temporaryプロパティで状態を設定することができます。

プリンタドライバ設定ファイルを使う場合は、FormPathプロパティでファイルの検索パスを設定することができます。
OutDeviceプロパティの値が「JV_RDF」や「JV_RDFSVC」の場合には、プリンタドライバ設定ファイルは、RDF形式のデータ中に保存されます。

Webシステムでプリンタドライバを設定する場合は、設定値をクライアントのプリンタで有効なものにします。

－基本的なコーディング

プリンタドライバ情報の取得
取得する前に、情報を取得するプリンタをPrinterNameプロパティで指定します。

－プリンタドライバ情報の取得方法

[コーディング例]

用紙サイズや用紙方向を1度だけ設定する場合
Jvr.SetPrinter = JV_SPDEVMODE
'プリンタドライバ情報で設定する方法
'Jvr.PrinterDevMode = "2,9,2970,2100,,,1,,1,,,1,"
Jvr.Start
|
Jvr.DrawForm
Jvr.NewPage
Jvr.End

用紙サイズや用紙方向を途中で変更する場合
Jvr.SetPrinter = JV_SPDEVMODE
'ドライバ設定ファイルで設定する方法
Jvr.PrinterDevMode = "c:\prnDev1.bin"
Jvr.Start
|
Jvr.DrawForm ← Dev1.binの用紙設定で印刷
Jvr.NewPage
Jvr.PrinterDevMode = "c:\prnDev2.bin"
|
Jvr.DrawForm ← Dev2.binの用紙設定で印刷
Jvr.NewPage
Jvr.End


PrinterErrorプロパティ

NewPageメソッドでエラーが発生した時の詳しいエラーコードを取得します。

[構文]

long = Object.PrinterError

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | エラーコード

[設定値]

設定不可。

[解説]

取得したエラー番号は、WindowsAPIのGetLastErrorで取得した値です。エラー内容は、 MicroSoft社などのWebサイトで確認してください。

値の参照は、実行時のみ可能です。

[コーディング例]

''DLLエラーコードを取得する
errCode = Jvr.PrinterError


PrinterEmfSpoolプロパティ

プリンタプロパティの「詳細な印刷機能を有効にする」を設定します。 値の取得も可能です。

[構文]

Object.PrinterEmfSpool = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 詳細な印刷機能を有効にする（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_PRNINFO_VALUE_ON | 1 | 詳細な印刷機能を有効にする
JV_PRNINFO_VALUE_OFF | 0 | 詳細な印刷機能を無効にする

[解説]

PrinterEmfSpoolは、コントロールパネルのプリンターのプロパティ詳細設定画面にある「詳細な印刷機能を有効にする」プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

PrinterEmfSpoolを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

詳細な印刷機能が有効の場合、DocumentDataTypeやPrinterDataTypeでプリントデータ型にRAW形式、EMF形式を指定することができます。
詳細な印刷機能が無効の場合、DocumentDataTypeやPrinterDataTypeでプリントデータ型にEMF形式を指定してもエラーになります。

プロパティを設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterEmfSpool = JV_PRNINFO_VALUE_OFF


PrinterEnableDevqプロパティ

プリンタプロパティの「一致しないドキュメントを保留する」を設定します。 値の取得も可能です。

[構文]

Object.PrinterEnableDevq = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 一致しないドキュメントを保留する（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_PRNINFO_VALUE_ON | 1 | 保留する
JV_PRNINFO_VALUE_OFF | 0 | 保留しない

[解説]

PrinterEnableDevqは、コントロールパネルのプリンターのプロパティ詳細設定画面にある「一致しないドキュメントを保留する」プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

PrinterEnableDevqを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

「保留する」を設定した場合、アプリケーションの印刷設定とプリンタの設定が合致しない場合は印刷せずに保留します。

プロパティを設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterEnableDevq = JV_PRNINFO_VALUE_OFF


PrinterKeepPrintedJobsプロパティ

プリンタプロパティの「印刷後ドキュメントを残す」を設定します。 値の取得も可能です。

[構文]

Object.PrinterKeepPrintedJobs = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷後ドキュメントを残す（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_PRNINFO_VALUE_ON | 1 | 印刷後ドキュメントを残す
JV_PRNINFO_VALUE_OFF | 0 | 印刷後ドキュメントを残さない

[解説]

PrinterKeepPrintedJobsは、コントロールパネルのプリンターのプロパティ詳細設定画面にある「印刷後ドキュメントを残す」プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

PrinterKeepPrintedJobsを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

プロパティを設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterKeepPrintedJobs = JV_PRNINFO_VALUE_OFF


PrinterNameプロパティ

プリンタ名の設定や、プリンタ名の取得を行います。

[構文]

Object.PrinterName [ = string ]

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリンタ名

[設定値]

string にはプリンタ名を設定します。初期値はありません。

[解説]

プリンタ名の設定

1．印刷するプリンタの名前を設定することができます。プリンタ名を設定する場合には、 SetPrinterプロパティを「JV_SPDEVMODE」にします。PrinterNameプロパティでプリンタを指定すると、PrnHdcプロパティの値は無効になります。

2．PrinterNameプロパティにプリンタ名を設定し、以下のプリンタ関連処理を行うことができます。PrinterNameプロパティは、処理を行う前に設定します。

・プリンタドライバ情報を取得する。プリンタドライバ情報は、PrinterDevModeプロパティで取得します。
・プリンタドライバ設定ファイルを作成する。プリンタドライバ設定ファイルは、MakeDevFileメソッドで作成します。
・ジョブ情報を取得する。ジョブ情報は、 JobStatusプロパティ、JobInfoプロパティ、AllJobInfoプロパティで取得します。
・プリンタ印字原点を取得する。プリンタ印字原点は、 PrinterXMarginプロパティ、PrinterYMarginプロパティで取得します。
・プリントデータ型の取得や設定を行う。プリントデータ型の取得や設定には、PrinterDataTypeプロパティを使います。
・すべてのプリントデータ型を取得する。すべてのプリントデータ型は、PrinterAllDataTypeプロパティで取得します。
・プリントプロセッサ名の取得や設定を行う。プリントプロセッサ名の取得や設定には、PrinterProcessorNameプロパティを使います。
・プリントサーバー名を取得する。プリントサーバー名は、PrinterServerNameプロパティで取得します。
・すべてのプリントサーバー名を取得する。すべてのプリントサーバー名は、PrinterServerNameプロパティで取得します。
・標準プリンタ名を取得する。標準プリンタ名は、PrinterDefaultNameプロパティで取得します。
・「スプールされたドキュメントを最初に印刷する」の取得や設定を行う。この取得や設定には、PrinterDoCmpleteFirstプロパティを使います。
・「一致しないドキュメントを保留する」の取得や設定を行う。この取得や設定には、PrinterEnableDevqプロパティを使います。
・「印刷後ドキュメントを残す」の取得や設定を行う。この取得や設定には、PrinterKeepPrintedJobsプロパティを使います。
・「詳細な印刷機能を有効にする」の取得や設定を行う。この取得や設定には、PrinterEmfSpoolプロパティを使います。
・「印刷スプール形式」の取得や設定を行う。この取得や設定には、PrinterSpoolTypeプロパティを使います。

プリンタ名の取得

1．標準プリンタ名を取得することができます。標準プリンタとは、コントロールパネルで通常使うプリンタに指定されたプリンタです。プリンタ名を取得する時は、PrnHdcプロパティに0を指定し、PrinterNameプロパティの値を参照します。PrnHdcプロパティにプリンタデバイスコンテキストを指定すると、プリンタ名は取得できません。標準プリンタは、PrinterDefaultNameプロパティでも取得することができます。

2．印刷ダイアログでユーザーが選択したプリンタ名を取得することができます。プリンタ名は、Startメソッドで印刷ダイアログがポップアップした後からEndメソッドがコールされるまでの間で取得します。

[コーディング例]

Jvr.PrinterName = "PC-PR201"


PrinterProcessorNameプロパティ

プリンタプロパティの「プリントプロセッサ名」を設定します。 値の取得も可能です。

[構文]

Object.PrinterProcessorName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントプロセッサ名

[設定値]

string にはプリントプロセッサ名を指定します。初期値はありません。

[解説]

PrinterProcessorNameは、コントロールパネルのプリンターのプロパティ詳細設定画面にある「プリントプロセッサ名」プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

PrinterProcessorNameを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

プリントプロセッサ名を設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterProcessorName = "winprint"


PrinterServerNameプロパティ

プリントサーバー名を取得します。

[構文]

string = Object.PrinterServerName
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリントサーバー名

[設定値]

設定不可。

[解説]

プリントサーバー名を取得するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタのプリントサーバー名を取得します。

値の参照は実行時のみ可能です。

[コーディング例]

Dim sPrintServer As String
sPrintServer = Jvrlib.PrinterServerName


PrinterSpoolTypeプロパティ

プリンタプロパティの「印刷スプール形式」を設定します。 値の取得も可能です。

[構文]

Object.PrinterSpoolType = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷スプール形式（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_PRNINFO_SPTYPE_DIRECT | 1 | プリンタに直接印刷データを送る
JV_PRNINFO_SPTYPE_PRINTIMMEDIATELY | 2 | すぐに印刷データをプリンタに送る
JV_PRNINFO_SPTYPE_QUEUED_ALL | 3 | 全ページ分のデータをスプールしてから、印刷データをプリンタに送る

[解説]

PrinterSpoolTypeは、コントロールパネルのプリンターのプロパティ詳細設定画面にある「印刷スプール形式」プロパティをアプリケーションから設定するためのプロパティです。このプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

PrinterSpoolTypeを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

プロパティを設定するプリンタは、PrinterNameプロパティで指定します。
プリンタ名が指定されない場合は、コントロールパネルで通常使うプリンタに指定されているプリンタを設定します。

値の設定と参照は、実行時に可能です。

[コーディング例]

Jvr.PrinterSpoolType = JV_PRNINFO_SPTYPE_PRINTIMMEDIATELY


PrinterXMarginプロパティ

プリンタ印字原点の左マージンを取得します。

[構文]

long = Object.PrinterXMargin

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 左マージン（1/10mm単位）

[設定値]

設定不可。

[解説]

PrinterXMargin プロパティの値は、PrinterNameプロパティでプリンタを指定した後に取得します。
プリンタを指定しない場合は、デフォルトプリンタ（通常使うプリンタに指定されたプリンタ）のマージンが取得されます。
印刷ダイアログを表示した場合は、印刷ダイアログで選択されたプリンタのマージンを取得します。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）のみ可能です。

[コーディング例]

Jvr.Start | '印刷開始
printerXMargin = Jvr.PrinterXMargin | '左マージンの取得


PrinterYMarginプロパティ

プリンタ印字原点の上マージンを取得します。

[構文]

long = Object.PrinterYMargin

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 上マージン（1/10mm単位）

[設定値]

設定不可。

[解説]

PrinterYMargin プロパティの値は、PrinterNameプロパティでプリンタを指定した後に取得します。
プリンタを指定しない場合は、デフォルトプリンタ（通常使うプリンタに指定されたプリンタ）のマージンが取得されます。
印刷ダイアログを表示した場合は、印刷ダイアログで選択されたプリンタのマージンを取得します。
値の参照は、実行時（Startメソッドと、EndメソッドまたはAbortメソッドの間）のみ可能です。

[コーディング例]

Jvr.Start | '印刷開始
printerYMargin = Jvr.PrinterYMargin | '上マージンの取得


PrintModeプロパティ

印刷モードを変更します。

[構文]

Object.PrintMode = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷モード（設定値参照）

[設定値]

long には次の値を指定します。初期値はフォームファイルに設定された印刷モードです。

定数 | 値 | 内容
JV_PRINTMODE_NORMAL | 1 | 通常印刷モード
JV_PRINTMODE_HISPEED | 2 | 高速印刷モード

[解説]

PrintModeプロパティは、ページごとやセクションごとに印刷モードを変更する時に使います。
それ以外の場合には、印刷モードはフォームファイルで指定しておきます。

固定フォームの場合、FormNameプロパティ、PageKeyプロパティ、PageNoプロパティでフォームを設定した後に変更します。
可変フォームの場合、SectionKeyプロパティでセクションを設定した後に変更します。

高速印刷モードは高速で印刷を行いますが、３Ｄやグラデーションなどの一部のグラフィックス機能に使用制限があります。通常印刷モードには使用制限はありませんが、精密な描画を行うため、プリンタの性能によっては、印刷に時間がかかることがあります。

PrintModeプロパティは、Adobe PDF形式で出力する時には無効です。
値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.FormName = "C:\Tmp\見積書.jfm" | 'フォームの設定
Jvr.PrintMode = JV_PRINTMODE_HISPEED | '高速印刷モード
Jvr.Start | '印刷開始


PrnHdcプロパティ

印刷するプリンタを設定します。

[構文]

Object.PrnHdc = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 出力先プリンタのデバイスコンテキスト

[設定値]

long には出力先プリンタのデバイスコンテキスト（Printer.hDC）を指定します。
初期値は0です。

[解説]

PrnHdcプロパティは、32ビットのレポートライブラリ（X86対応版）のためのプロパティです。64ビットのレポートライブラリ(X64対応版）で印刷するプリンタを設定する場合には、SetParamメソッドを使用します。

PrnHdcプロパティは、プリンタのデバイスコンテキストを使ってプリンタを指定します。プリンタ名称でプリンタを指定する時は、PrinterNameプロパティを使います。
プリンタデバイスコンテキストが取得できない言語環境では0を指定することができます。0を指定した場合、PrnHdcプロパティには、デフォルトプリンタ（通常使うプリンタに指定されたプリンタ）のデバイスコンテキストが入ります。
レポートライブラリは、実行時に、プリンタドライバから様々な情報を取得し帳票を作成します。PrnHdcプロパティで指定したプリンタは、情報を取得するプリンタとしても使われます。フォーム作成時のプリンタデバイスコンテキストと同じものを設定すると、フォーム作成時と同じ状態で印刷やプレビューを行うことができます。フォーム作成時と異なるものにした場合は、線の太さや文字の印字位置などが変わることがあります。

以下の場合、PrnHdcプロパティで指定したデバイスコンテキストは無効となります。

(1)PrinterNameプロパティでプリンタを指定した場合。
(2)SetPrinterプロパティで印刷ダイアログを表示し、OKボタンで終了した場合。
(3)RDF形式の帳票の場合。プリンタドライバからの情報取得は、作成時ではなく、プレビューコントロールによるプレビュー時に行われます。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.PrnHdc = Printer.hDC 'プリンタオブジェクトのデバイスコンテキストを設定


SectionHeightプロパティ

セクションの高さを取得します。

[構文]

long = Object.SectionHeight

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | セクションの高さ（1/10mm単位）

[設定値]

設定不可。

[解説]

SectionHeight プロパティは可変フォーム専用のプロパティです。固定フォームでは使用できません。

SectionKeyプロパティで指定されたセクションの高さを取得します。

値の参照は、実行時のみ可能です。

[コーディング例]

Dim SectionHeight As Long |
SectionHeight = Jvrlib.SectionHeight | 'セクションの高さ


SectionKeyプロパティ

描画するセクションを設定します。

[構文]

Object.SectionKey = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | セクション名

[設定値]

string にはセクション名を指定します。

[解説]

SectionKey プロパティは可変フォーム専用のプロパティです。固定フォームでは使用できません。

SectionKey プロパティは、FormName プロパティでフォームを指定した後に使います。

StartメソッドとEnd（Abort)メソッドの間で実行します。
値の設定と参照は、実行時のみ可能です。

[コーディング例]

Call Jvrlib.Start |
Jvrlib.SectionKey = "ｾｸｼｮﾝ1" | 'セクションの設定


SetPrinterプロパティ

印刷の設定を行います。

[構文]

Object.SetPrinter = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷設定（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_SPNONE | 0 | 何も設定しない（初期値）
JV_SPSETPAPER | 1 | 用紙サイズと方向を自動的に設定
JV_SPSHOWDIALOG | 2 | 印刷ダイアログの表示
JV_SPDEVMODE | 3 | プリンタドライバ情報の設定

[解説]

用紙サイズと方向を自動的に設定
印刷実行時に、FormNameプロパティで指定されているフォームの用紙サイズと用紙方向をレポートライブラリが自動的に設定します。
設定値は、Windowsが提供する標準値です。プリンタドライバによっては、独自の設定値を使用しているなどの理由により有効にならない場合があります。そのような場合は「JV_SPDEVMODE(プリンタドライバ情報の設定)」に変更してください。

出力先が「JV_RDF」「JV_RDFSVC 」の場合には、レポートライブラリが自動的に設定した用紙サイズと用紙方向の値は、RDFデータの中に入ります。プレビューコントロールのPrintOutメソッドで印刷をすると、この設定値で印刷が行われ、プレビューコントロールのPrintDialogメソッドをコールすると、この設定値で初期設定された印刷ダイアログがポップアップします。RDFデータにこの設定値が入っている場合、プレビューコントロールの印刷ダイアログで、ユーザーが用紙サイズや用紙方向を変更しても有効とならず、この設定値で印刷が行われます。プレビューコントロールの印刷ダイアログで用紙サイズや用紙方向を変更する場合には、「JV_SPNONE」で何も設定しないようにしてください。

用紙サイズや用紙方向の違う帳票を1つのRDFデータに混在させ、且つ、プレビューコントロールから一括で印刷を行う場合には、RDFデータを作成する時、各ページごとに、「JV_SPSETPAPER」または「JV_SPDEVMODE」で用紙サイズや用紙方向の情報を設定しておきます。

印刷ダイアログの表示
実行時（Startメソッド実行時）に印刷ダイアログを表示します。

印刷ダイアログを表示する場合には、Startメソッドの前で設定してください。印刷ダイアログの表示は、OutDeviceプロパティが「JV_PRINTER 」の場合のみ有効です。
Startメソッドの前でFormnameプロパティにフォーム名が設定されている場合には、フォームの用紙サイズと用紙方向で初期設定された印刷ダイアログが表示されます。 PrinterNameプロパティにプリンタ名が設定されていれば、そのプリンタで印刷ダイアログボックスが表示されます。設定されていない場合は「通常使うプリンタ」で印刷ダイアログが表示されます。
印刷ダイアログを表示した時の初期値設定や、印刷ダイアログ上でユーザーが入力した値の取得には、Copiesプロパティ、FromPageプロパティ、ToPageプロパティ、MinPageプロパティ、MaxPageプロパティ、Collateプロパティ、AllowSelectionプロパティを使います。

1つの印刷ジョブ（StarｔからEndまでの間）の中で用紙サイズや用紙方向の異なる帳票を印刷する場合、印刷ダイアログは使用できません。そのような帳票で印刷ダイアログを使用する場合には、RDF形式のデータを作成し、プレビューコントロールから印刷を行ってください。プレビューコントロールで印刷ダイアログを表示する場合には、プレビューコントロールのPrintDialogメソッドを使います。

－基本的なコーディング

プリンタドライバ情報の設定
印刷実行時に、アプリケーション内部でプリンタドライバを設定します。
プリンタドライバの設定値は、PrinterDevModeプロパティで指定します。プリンタは、PrinterNameプロパティを使って指定します。
プリンタドライバの設定は、OutDeviceプロパティが「JV_PRINTER」「JV_RDF」「JV_RDFSVC 」の場合のみ有効です。

出力先が「JV_RDF」「JV_RDFSVC 」の場合には、設定したプリンタドライバ情報の値は、RDFデータの中に入ります。プレビューコントロールのPrintOutメソッドで印刷をすると、この設定値で印刷が行われ、プレビューコントロールのPrintDialogメソッドをコールすると、この設定値で初期設定された印刷ダイアログがポップアップします。RDFデータにプリンタドライバ情報の設定値が入っている場合、プレビューコントロールの印刷ダイアログで、ユーザーが用紙サイズや用紙方向を変更しても有効とならず、この設定値で印刷が行われます。プレビューコントロールの印刷ダイアログで用紙サイズや用紙方向を変更する場合には、「JV_SPNONE」で何も設定しないようにしてください。プリンタや印刷枚数などの用紙サイズと用紙方向以外の項目は、印刷ダイアログで変更可能です。プレビューコントロールの印刷ダイアログに初期設定をする場合には、Startメソッドの前でプリンタドライバ情報を設定してください。

用紙サイズや用紙方向の違う帳票を1つのRDFデータに混在させ、且つ、プレビューコントロールから一括で印刷を行う場合には、RDFデータを作成する時、各ページごとに、「JV_SPSETPAPER」または「JV_SPDEVMODE」で用紙サイズや用紙方向の情報を設定しておきます。

プリンタドライバ情報は、1つの印刷ジョブ（StartからEndまでの間）の中で何度でも変更することができます。変更する場合には、NewPageメソッドの後で変更します。プリンタドライバ情報が変更されると、前回の設定は無効になります。二回目以降に変更できるのは、用紙サイズと用紙方向のみで、プリンタや印刷枚数などは変更できません。

－基本的なコーディング

[コーディング例]

プリンタドライバ情報を設定する
Jvr.SetPrinter = JV_SPDEVMODE | 'プリンタドライバ情報の設定
Jvr.PrinterDevMode = "2,9" | 'A4横置き
Jvr.Temporary = JV_TEMPORARY_OFF | '永久登録
Jvr.OutDevice = JV_PRINTER | '出力先をプリンタにする
Jvr.Start |

自動設定機能を使い、印刷中に用紙のサイズや方向を変更する

Jvr.OutDevice = JV_PRINTER | '出力先をプリンタに設定
Jvr.FormName = "C:\tmp\請求書.jfm" | 'A4縦置きフォームを指定
Jvr.PrinterName = "EPSON PM-G860X" | 'プリンタの指定
Jvr.SetPrinter = JV_SPSETPAPER | '用紙サイズと方向を自動設定
Jvr.Start() | '印刷の開始
・ |
・ |
Jvr.DrawForm() | 'A4縦置きの帳票を描画
Jvr.NewPage() | '排紙
Jvr.FormName = "C:\tmp\受領書.jfm" | 'A4横置きフォームを指定
・ |
・ |
Jvr.DrawForm() | 'A4横置きの帳票を描画
Jvr.NewPage() | '排紙
Jvr.End() | '印刷終了

プリンタドライバ設定機能を使い、印刷中に用紙のサイズや方向を変更する

Jvr.OutDevice = JV_PRINTER | '出力先をプリンタに設定
Jvr.FormName = "C:\tmp\請求書.jfm" | 'A4縦置きフォームを指定
Jvr.PrinterName = "EPSON PM-G860X" | 'プリンタの指定
Jvr.PrinterDevmode = "1,9" | 'A4縦置きのプリンタドライバ情報を設定
Jvr.SetPrinter = JV_SPDEVMODE | 'プリンタドライバ情報の設定
Jvr.Start() | '印刷の開始
・ |
・ |
Jvr.DrawForm() | 'A4縦置きの帳票を描画
Jvr.NewPage() | '排紙
Jvr.FormName = "C:\tmp\受領書.jfm" | 'A4横置きフォームの指定
Jvr.PrinterDevmode = "2,9" | 'A4横置きのプリンタドライバ情報を設定
・ |
・ |
Jvr.DrawForm() | 'A4横置きの帳票を描画
Jvr.NewPage() | '排紙
Jvr.End() | '印刷終了

自動設定機能で用紙のサイズや方向を変更したRDFデータを作成し、プレビューコントロールで印刷する

Jvr.OutDevice = JV_RDF | '出力先をRDFタに設定
Jvr.FormName = "C:\tmp\請求書.jfm" | 'A4縦置きフォームを指定
Jvr.SetPrinter = JV_SPSETPAPER | '用紙サイズと方向を自動設定
Jvr.Start() | 'ジョブの開始
・ |
・ |
Jvr.DrawForm() | 'A4縦置きの帳票を描画
Jvr.NewPage() |
Jvr.FormName = "C:\tmp\受領書.jfm" | 'A4横置きフォームを指定
・ |
・ |
Jvr.DrawForm() | 'A4横置きの帳票を描画
Jvr.NewPage() |
Jvr.End() | 'ジョブの終了
Call JiveView.set_DocumentData(Jvr.DocumentData) 'RDFデータを設定
JiveView.PrinterName = "EPSON PM-G860X" | 'プリンタを設定
JiveView.Copies = 1 | '印刷部数を設定
JiveView.MinPage = 1 | '印刷開始ページを1にする
JiveView.MaxPage = JiveView.PageCount | '印刷終了ページに総ページ数を入れる
JiveView.PrintOut() | '印刷

プリンタドライバ設定機能で用紙のサイズや方向を変更したRDFデータを作成し、
プレビューコントロールで印刷する

Jvr.OutDevice = JV_RDF | '出力先をRDFに設定
Jvr.FormName = "C:\tmp\請求書.jfm" | 'A4縦置きフォームを指定
Jvr.PrinterDevmode = "1,9" | 'A4縦置きのプリンタドライバ情報を設定
Jvr.SetPrinter = JV_SPDEVMODE | 'プリンタドライバ情報の設定
Jvr.Start() | 'ジョブの開始
・ |
・ |
Jvr.DrawForm() | 'A4縦置きの帳票を描画
Jvr.NewPage() |
Jvr.FormName = "C:\tmp\受領書.jfm" | 'A4横置きフォームを指定
Jvr.PrinterDevmode = "2,9" | 'A4横置きのプリンタドライバ情報を設定
・ |
・ |
Jvr.DrawForm() | 'A4横置きの帳票を描画
Jvr.NewPage() |
Jvr.End() | 'ジョブの終了
Call JiveView.set_DocumentData(Jvr.DocumentData) 'RDFデータを指定
JiveView.PrinterName = "EPSON PM-G860X" | 'プリンタを指定
JiveView.Copies = 1 | '印刷部数を設定
JiveView.MinPage = 1 | '印刷開始ページを1にする
JiveView.MaxPage = JiveView.PageCount | '印刷終了ページに総ページ数を入れる
JiveView.PrintOut() | '印刷

プリンタドライバ設定機能で用紙のサイズや方向を変更したRDFデータを作成し、
プレビューコントロールで印刷ダイアログを表示する

Jvr.OutDevice = JV_RDF | '出力先をRDFに設定
Jvr.FormName = "C:\tmp\請求書.jfm" | 'A4縦置きフォームを指定
Jvr.PrinterDevmode = "1,9" | 'A4縦置きのプリンタドライバ情報を設定
Jvr.SetPrinter = JV_SPDEVMODE | 'プリンタドライバ情報の設定
Jvr.Start() | 'ジョブの開始
・ |
・ |
Jvr.DrawForm() | 'A4縦置きの帳票を描画
Jvr.NewPage() |
Jvr.FormName = "C:\tmp\受領書.jfm" | 'A4横置きフォームを指定
Jvr.PrinterDevmode = "2,9" | 'A4横置きのプリンタドライバ情報を設定
・ |
・ |
Jvr.DrawForm() | 'A4横置きの帳票を描画
Jvr.NewPage() |
Jvr.End() | 'ジョブの終了
Call JiveView.set_DocumentData(Jvr.DocumentData) 'RDFデータを指定
JiveView.Copies = 1 | '印刷部数を設定
JiveView.MinPage = 1 | '印刷開始ページを1にする
JiveView.MaxPage = JiveView.PageCount | '印刷終了ページに総ページ数を入れる
JiveView.PrintDialog() | '印刷ダイアログの表示


TempPathNameプロパティ

XPS形式で帳票を出力する時の一時ファイル用ディレクトリを設定します。

[構文]

Object.TempPathName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 一時ファイル用ディレクトリ

[設定値]

string には、一時ファイル用ディレクトリ名を256バイト以下で設定します。

[解説]

Startメソッドをコールする前に設定します。
何も指定しない場合には、Windowsの一時ファイル用ディレクトリが使われます。

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.TempPathName = "c:\Program Files\JiveReport" | 'パスの指定
Jvr.Start | '印刷開始


Temporaryプロパティ

プリンタドライバ情報の設定モードを設定します。

[構文]

Object.Temporary = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 設定モード（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_TEMPORARY_OFF | 0 | 永久登録
JV_TEMPORARY_ON | 1 | 一時登録（初期値）

[解説]

Temporaryプロパティに「JV_TEMPORARY_ON」を指定すると、PrinterDevModeプロパティの値は、アプリケーションを実行している間だけプリンタドライバに設定され、アプリケーション終了後には元の状態に戻ります。「JV_TEMPORARY_OFF」を指定すると、プリンタドライバ情報はアプリケーション終了後も設定されたままの状態となります。
Temporaryプロパティは、SetPrinterプロパティに「JV_SPDEVMODE」を指定した時に使います。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.SetPrinter = JV_SPDEVMODE | 'プリンタドライバ情報の設定
Jvr.PrinterDevMode = "2,9" | 'A4縦置き
Jvr.Temporary = JV_TEMPORARY_OFF | '永久登録
Jvr.OutDevice = JV_PRINTER | '出力先をプリンタにする
Jvr.Start |


TiffCompressionプロパティ

TIFF形式で出力する帳票の圧縮をやめることができます。

[構文]

レポートライブラリOCX

Object.TiffCompression = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | プログレッシブ（設定値参照）

[設定値]

long には次の値を指定します。

定数 | 値 | 内容
JV_TIFF_COMPRESSION_DEFLATE | 0 | デフレート圧縮（初期値）
JV_TIFF_COMPRESSION_NONE | 1 | 圧縮なし

[解説]

TIFF形式の帳票は、デフレート圧縮されて出力されますが、TiffCompressionプロパティで圧縮をやめることができます。

値の設定と参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.TiffCompression = JV_TIFF_COMPRESSION_NONE


ToPageプロパティ

印刷ダイアログの印刷終了ページを初期設定します。
ユーザーが設定した印刷終了ページを取得します。

[構文]

Object.ToPage = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷終了ページ（ 初期値は 1）

[設定値]

long には1～10000の値を指定します。

[解説]

印刷終了ページの設定
印刷ダイアログの印刷終了ページに初期値を入れてポップアップさせる時に使います。ToPageプロパティの値は、印刷ダイアログを表示する前に設定しておきます。
初期値を設定する場合は、MinPageプロパティとMaxPageプロパティを指定し、ToPageプロパティには、MinPageプロパティとMaxPageプロパティの間の値を指定します。範囲外の値を指定すると、初期値はMaxPageプロパティの値になります。

印刷終了ページの取得
印刷ダイアログでユーザーが指定した印刷終了ページを取得する時に使います。
ユーザーが印刷終了ページを指定した時は、指定したページまで印刷するようにコーディングします。ユーザーが全ページを指定した時は、ToPageプロパティには0が返ります。印刷開始ページの設定や取得は、FromPageプロパティを使います。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時（StartメソッドとEndまたはAbortメソッドの間） に可能です。

－印刷ダイアログの表示

[コーディング例]

Jvr.SetPrinter = JV_SPSHOWDIALOG | 印刷ダイアログの設定
Jvr.OutDevice = JV_PRINTER | '出力先をプリンタにする
Jvr.toPage = 10 | '印刷終了ページの設定
Jvr.Start | '印刷開始
toPage = Jvr.toPage | '印刷終了ページの取得


TopMarginプロパティ

用紙の上マージンを設定します。

[構文]

Object.TopMargin = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 上マージン(1/100mm単位)

[設定値]

long には上マージンを指定します。 初期値は0です。

[解説]

用紙の左マージンの設定には、LeftMarginプロパティを使用します。

フォームに余白が設定されている場合には、フォームの余白に加算されます。
マイナス値を設定することもできます。
詳細は「付録／用紙の余白（マージン）設定」を参照してください。

余白は、ジャイブレポートのバージョンによって仕様が異なります。ご注意ください。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

Jvr.TopMargin = -500 | '上へ5mm移動
Jvr.TopMargin = 1000 | '下へ10mm移動


WinHdcプロパティ

ウィンドウのデバイスコンテキストを設定します。

[構文]

Object.WinHdc = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ウィンドウのデバイスコンテキスト

[設定値]

long にはウィンドウのデバイスコンテキストを指定します。 初期値は0です。

[解説]

WinHdcプロパティは、32ビットのレポートライブラリ（X86対応版）のためのプロパティです。64ビットのレポートライブラリ(X64対応版）でウィンドウのデバイスコンテキストを設定する場合には、SetParamメソッドを使用します。

WinHdc プロパティは、OutDeviceプロパティが「JV_WINDOW」の場合に、出力するウィンドウを指定します。出力するフォームのNameプロパティがform1であれば、WinHdcプロパティにはform1.hDCを指定します。

WinHdcプロパティは、OutDeviceプロパティが「JV_WINDOW」以外の場合には設定する必要はありません。

値の設定は、デザイン時、実行時（Startメソッドの前）に可能です。
値の参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.WinHdc = PictureDraw.hDC 　'ウィンドウハンドル
Jvr.OutDevice = JV_WINDOW
Jvr.Start


XpsDriverNameプロパティ

XPS形式の帳票を作成するプリンタ名を設定します。

[構文]

Object.XpsDriverName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | XPSプリンタ名

[設定値]

string にはXPSプリンタ名を設定します。

[解説]

帳票をXPS形式で作成する時には、XPSプリンタドライバが必要です。通常、OSをインストールすると「Microsoft XPS Document Writer」という名前のXPSプリンタがインストールされます。このプリンタが、この名称で実行環境にある場合には、XpsDriverNameプロパティにプリンタ名を設定する必要はありません。このプリンタ名を変更した場合や、別のものを使用する場合には、Startメソッドをコールする前に、XpsDriverNameにプリンタ名を設定します。

値の設定や参照は、デザイン時、実行時に可能です。

[コーディング例]

Jvr.XpsDriverName = "ABC XPS Writer" | 'プリンタ名
Jvr.Start | '印刷開始


レポートライブラリDLLのアプリケーション開発

レポートライブラリDLLでのアプリケーション開発

レポートライブラリDLLとは

レポートライブラリDLLは、帳票アプリケーション開発に使用するDLL形式のライブラリです。

インストール先

レポートライブラリDLLは、Windowsのシステムディレクトリにコピーされています。
－ファイル名、インストール先

開発

レポートライブラリDLLは、DLLをコールできる開発環境で使います。
使い方は、ヘルプの基本的な使い方やリファレンスを参照してください。
サンプルプログラムが、用意されています。コーディングの参考にしてください。
［サンプルプログラムインストール先：インストールディレクトリ￥SampleProgram ］

配布

レポートライブラリDLLを使って開発したアプリケーションを実行環境で動かす時には、レポートライブラリDLLも一緒に配布します。
レポートライブラリDLLは単独で動作します。
配布の前に、製品パッケージに入っている使用許諾契約書をお読みください。

実行環境の整備

レポートライブラリDLLを実行環境のWindowsディレクトリにコピーします。

  1．32ビットアプリケーションを開発した場合

    実行環境のOSがx86Editionの場合：　実行環境のC:\Windows\System32ディレクトリ
    実行環境のOSがx64Editionの場合：　実行環境のC:\Windows\SysWOW64ディレクトリ

  2．64ビットアプリケーションを開発した場合

    実行環境のC:\Windows\System32ディレクトリ
    使用できるOSは、x64Editionのみとなります。

－レポートライブラリJNIでのアプリケーション開発


レポートライブラリDLLの詳細情報

プロフェッショナル(X86)

ファイル名 | jvrapi102.dll
インストール場所 | Windowsのシステムディレクトリの下

プロフェッショナル(X64)

ファイル名 | jvrapi102.dll
インストール場所 | Windows\System32ディレクトリの下 ※x64対応レポートライブラリDLL
 | Windows\SysWOW64ディレクトリの下 ※x86対応レポートライブラリDLL

プロフェッショナル(X64)には2種類のレポートライブラリDLLが入っています。

詳細は、「X64製品での開発／各種開発環境での使い方／Visual Studioでの開発」を参照してください。


旧バージョンからの移行(DLL)

旧バージョンからの移行（レポートライブラリDLL）

レポートライブラリJNIはこちらを参照してください。

旧バージョンのレポートライブラリDLLを使ったプログラムを最新のレポートライブラリDLLに置き換える場合は、移行作業が必要です。

相違点

◆ファイル名が変わりました。（Ver.1～Ver10.1から移行する場合）

◆プロポーショナルフォントの文字の描画位置が変わりました。（Ver.1～Ver.10.0から移行する場合）

◆文字回転機能を使って文字を回転させた時の描画位置が変わりました。（Ver.1～Ver.10.0から移行する場合）

◆余白（マージン）とスケールの考え方が変わりました。 （Ver.1～Ver.9.1から移行する場合）

◆外字の描画方法が変わりました。（Ver.4～Ver.9.04から移行する場合）

◆CMFファイル作成機能がなくなりました。（Ver.4～Ver.6から移行する場合）

◆電子帳票関連機能がなくなりました。（Ver.6から移行する場合）

◆32ビットから64ビットへ変更する場合[Visual Studioの場合]：　ターゲットCPUの変更
プロフェッショナル(X86)・スタンダード(X86)・プロフェッショナル版・スタンダード版・アプリケーション開発キットで作成したプログラムをプロフェッショナル(X64)で64ビットアプリケーションに移行する場合には、ターゲットCPUの変更が必要です。

◆プロフェッショナル(X64)（Ver8.3～Ver9.08の場合）
プロフェッショナル(X64)Ver8.3～Ver9.08でハンドルやデバイスコンテキストに関する問題が見つかりました。
この問題はインストールディレクトリの「ProX64のアップデート方法.htm 」に詳しく記述されています。ご参照ください。

移行作業

◆関数宣言中のファイル名変更

関数宣言文にレポートライブラリDLLのファイル名が含まれているため変更が必要です。
例）Declare Function jvClose& Lib "jvreport.dll" (ByVal pid&)
                                      ↑
レポートライブラリDLLのファイル名を変更します。
インストールディレクトリの各サンプルプログラムの下に新しい関数名を使ったjvrvbｄｌｌ.basやjvdel2.pasなどが入っています。
－レポートライブラリDLLのファイル名

◆プロポーショナルフォントの文字位置・回転文字の描画位置の確認（Ver.3～Ver.10.0から移行する場合）

プロポーショナルフォントや文字回転を使っている場合には、文字を描画する位置の確認が必要です。
旧バージョンの文字位置で描画する場合には、「文字列の描画をバージョン10.0以前の仕様で行う」をチェックします。

◆余白（マージン）の考え方が変わりました。

旧バージョンのフォームを使用する場合には、余白値の見直しが必要です。
－旧バージョンの余白（マージン）設定と変更

◆外字の描画方法変更による確認と、新機能への変更

Ver.4～Ver.7を使って外字を描画している場合は、Ver.8以降では外字の描画方法が変わったため、外字が正しく描画されるかどうかのチェックが必要です。
また、Ver.4～Ver.9.04までのレポートライブラリDLLでは、外字フォントを使って外字を描画していましたが、Ver.9.05でジャイブレポート外字ファイルを使って外字を描画する方法が追加されました。外字が正しく描画されない場合は、ジャイブレポート外字ファイルを使うことができます。
Webアプリケーションから外字を描画している場合、IIS7以降の環境では、外字フォントで外字を描画することができません。ジャイブレポート外字ファイルを使用する方法への変更が必要です。
－外字の描画

◆CMFファイル設定箇所の修正（Ver.4～Ver.6から移行する場合）

jvCreateファンクションの出力先デバイス(outdev)にJV_CMF(=4)を設定している場合は、JV_RDF(=5)に変更します。
プログラムの変更は、上記1箇所のみです。
過去のCMFファイル（xxx.cmf）は、最新のプレビューコントロールからそのまま利用することができます。

◆電子帳票関連機能の削除（Ver.6から移行する場合）

プログラム中に電子帳票関連機能がコーディングされている場合は削除します。
以下のファンクションがなくなりました。
JvCreateERF, jvGetErfLong, jvGetErfString

◆32ビットから64ビットへ変更する場合[Visual Studioの場合]：　ターゲットCPUの変更

プロフェッショナル(X86)・スタンダード(X86)・プロフェッショナル版・スタンダード版・アプリケーション開発キットで作成したプログラムをプロフェッショナル(X64)で64ビットアプリケーションに移行する場合には、ターゲットCPUの変更が必要です。
－X64製品での開発／Visual Studioでの開発


基本的な使い方(レポートライブラリDLL)

最も基本的なコーディング

最も基本的なコーディングです。

jvCreate | 初期処理
↓ |
jvStartDoc | 印刷の開始
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

jvCreateとjvClose、jvStartDocとjvEndDocは、必ず対になるようにコーディングします。

jvCreateではレポートライブラリDLLが動作する資源を確保し、jvCloseでは解放します。

jvStartDocからjvEndDocまでが１つの印刷ジョブとなります。


印刷ダイアログを表示(レポートライブラリDLL)

印刷ダイアログを表示

アプリケーション実行時に印刷ダイアログを表示するコーディングです。

jvCreate | 初期処理
↓ |
jvPrintDialog | 印刷ダイアログの表示
jvStartDoc | 印刷の開始
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

jvPrintDialogは、jvCreateからjvStartDocの間でコールします。


実行時にプリンタドライバを設定(レポートライブラリDLL)

実行時にプリンタドライバを設定

実行時に、アプリケーション内部でプリンタドライバのプロパティを設定するコーディングです。

jvCreate | 初期処理
↓ |
jvSetDevMode | プリンタドライバの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

プリンタドライバ情報はレポートエディタやレポートライブラリから取得できます。

－プリンタドライバ情報とは
－プリンタドライバ情報の取得


固定フォームフォームとフィールド印刷

固定フォームでフィールドを印刷

レポートエディタで作成した帳票フォームと、フォームに貼り付けられたフィールドにデータを設定して印刷するコーディングです。

jvCreate | 初期処理
↓ |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
jvSetFieldText | テキストフィールドにデータを設定
↓ |
jvSetFieldGrid | グリッドフィールドの1行目にデータを設定
↓ |
jvSetFieldGrid | グリッドフィールドの2行目にデータを設定
↓ |
グリッドフィールドの行数分繰り返し |
↓ |
jvDrawForm | フォームとフィールドの描画
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

グリッドフィールドへのデータ設定は、グリッドフィールドの行数分繰り返します。

複数ページ印刷する場合は、jvSetFieldTextからjvEndPageを繰り返します。


可変フォームフォームとフィールドフロー

可変フォームでフィールドを印刷

レポートエディタで作成した可変フォームと、セクションに貼り付けられたフィールドにデータを設定して印刷するコーディングです。

jvCreate | 初期処理
↓ |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
jvSetSection(jid, "ﾍｯﾀﾞｰ") | セクションの設定
↓ |
jvSetFieldText | テキストフィールドに値を設定
↓ |
jvDrawSection | セクションの描画
↓ |
jvSetSection(jid, "明細") | セクションの設定
↓ |
For i = 1 to n |
↓ |
jvSetFieldGrid | グリッドフィールドに値を設定
↓ |
jvDrawSection | セクションの描画
↓ |
If ret = JV_REQ_ENDPAGE Then | 改ページ要求の場合は改ページ
jvEndPage |
End If |
↓ |
Next i |
↓ |
jvSetSection(jid, "ﾌｯﾀｰ") | セクションの設定
↓ |
jvDrawSection | セクションの描画
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

jvDrawSectionで改ページ要求が出た時は改ページを行います。

－可変フォームを使った印刷アプリケーション


線のプロパティを変更し図形を描画(レポートライブラリDLL)

線のプロパティを変更し直線を描画

アプリケーションの中から直線を描画するコーディングです。

jvCreate | 初期処理
↓ |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
JvSetLong(jid,JV_FORE_COLOR,RGB(255,0,0) | 線の前景色を設定
↓ |
jvSetLong(jid, JV_LINE_WIDTH, 5) | 線の幅を設定
↓ |
jvSetLong(jid,JV_LINE_STYLE,JV_PS_SOLID) | 線の種類を設定
↓ |
jvDrawLine | 直線の描画
↓ |
jvDrawForm | フォームとフィールドの描画
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了


RDFドキュメントデータ作成DLL

RDF形式のデータを作成

帳票をジャイブレポート専用のＲＤＦ形式で作成しプレビューコントロールへ渡します。

jvCreate(JV_RDF, ･･･,“”) | 初期処理
↓ （出力先をRDF形式にする） |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
・ |
・ | フォームとフィールドの描画
・ |
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了（RDFデータ完成）
↓ |
jvGetLong | RDFデータサイズ取得
↓ |
jvGetDocument(jid, buf(0)) | RDデータの取得
↓ |
jvClose | 印刷終了
↓ |
JiveView.DocumentData = buf | プレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示ページ
↓ |
JiveView.Show | プレビューコントロールで表示

作成したRDFデータは、プレビューコントロールを使ってプレビューや印刷を行います。

RDFデータはWeb環境では使えません。

64ビット版レポートライブラリDLLの場合、jvGetDocumentはVisualBasic2005・VisualBasic2008の環境で使用できません。


RDFファイルを作成する(レポートライブラリDLL)

RDFファイルを作成する

RDF形式で作成したRDFデータをファイルに保存する場合のコーディングです。

jvCreate(JV_RDF, ･･･,“納品伝票.rdf”) | 初期処理
↓ （出力先をRDF形式にしてRDFﾌｧｲﾙ名を設定する） |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
・ |
・ | フォームとフィールドの描画
・ |
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了（RDFファイル完成）
↓ |
jvClose | 終了処理
↓ |
JiveView.FileName = "納品伝票.fdf" | プレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示ページ
↓ |
JiveView.Show | プレビューコントロールに表示

作成したRDFファイルは、プレビューコントロールを使ってプレビューや印刷を行います。


PDFファイルを作成する(レポートライブラリDLL)

Adobe PDFファイルを作成する

帳票をAdobe PDF形式で作成し、ファイルに保存するコーディングです。

jvCreate(JV_PDF, ･･･,“納品伝票.pdf”) | 初期処理
↓ （出力先をPDF形式にしてPDFﾌｧｲﾙ名を設定） |
jvSetForm | 帳票フォームの設定
↓ |
jvSetString(jid,JV_PDF_USER_PASSWORD,"user") | ユーザーパスワード設定
↓ |
jvSetLong(jid,JV_PDF_ENABLE_PRINT,JV_PDF_SEC_ENABLE) | 印刷の許可設定
↓ |
jvStartDoc(jid, “納品伝票”, “”) | 印刷の開始
↓ （PDFﾌｧｲﾙのﾄﾞｷｭﾒﾝﾄ名を設定） |
jvSetString(jid, JV_PDF_BOOKMARK, “納品書”) | ブックマークの設定
↓ |
・ |
・ | フォームとフィールドの描画
・ |
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了（PDFファイル完成）
↓ |
jvClose | 終了処理

Adobe PDFファイルは、Adobe Readerを使ってプレビューします。


ラベル印刷(レポートライブラリDLL)

ラベル印刷

ラベルを印刷するコーディングです。

jvCreate | 初期処理
↓ |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
jvSetLong(jid,JV_LABEL_NO,1) | 1つ目のラベルを指定
jvSetFieldText | 1つ目のラベルのフィールドデータを設定
↓ |
jvDrawForm | 1つ目のラベルを描画
↓ |
jvSetLong(jid,JV_LABEL_NO,2) | 2つ目のラベルを指定
↓ |
jvSetFieldText | 2つ目のラベルのフィールドデータを設定
↓ |
jvDrawForm | 2つ目のラベルを描画
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

jvSetLong～jvDrawFormは、用紙上にあるラベルの数分繰り返します。

１枚の用紙にラベルが複数枚ある場合、ラベル番号は、左上が1となります。
例）ラベルが横方向に２枚、縦方向に３枚ある場合は次のようになります。

1 | 2
3 | 4
5 | 6

ラベルは固定フォームで作成します。可変フォームでは作成できません。


UNICODEを描画する(レポートライブラリDLL)

UNICODEを描画する

テキストフィールドやグリッドフィールドでUNICODEの文字を描画するコーディングです。

jvCreate | 初期処理
↓ |
jvSetForm | 帳票フォームの設定
↓ |
jvStartDoc | 印刷の開始
↓ |
・ |
・ |
jvSetFieldTextW | テキストフィールドにUNICODE文字列を設定
↓ |
jvSetFieldGridW | グリッドフィールドにUNICODE文字列を設定
↓ |
jvDrawTextW | UNICODE文字列の描画
↓ |
・ |
・ | （フォームとフィールドの描画）
・ |
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了


印刷スピードを高速にする(レポートライブラリDLL)

印刷スピードを高速にする

印刷スピードを高速にするコーディングです。

jvCreate | 初期処理
↓ |
jvSetForm | 帳票フォームの設定
↓ |
jvSetLong(jid,JV_PRINT_MODE,JV_PRINTMODE_HISPEED) | 高速印刷モードを設定
↓ |
jvStartDoc | 印刷の開始
↓ |
・ |
・ | フォームとフィールドの描画
・ |
↓ |
jvEndPage | 改ページ
↓ |
jvEndDoc | 印刷の終了
↓ |
jvClose | 印刷終了

高速印刷モードでは、一部のグラフィックス機能に使用制限があります。

－高速印刷モードと機能制限


jvCreate

jvCreate（初期処理）

レポートライブラリが正常に動作するための初期処理を行います。

[構文]

X86対応版

Function jvCreate(ByVal outdev As Long, ByVal hwnd As Long, ByVal prnhdc As Long, ByVal winhdc As Long, ByVal width As Long, ByVal height As Long, ByVal filename As String ) As Long

X64対応版

Function jvCreate(ByVal outdev As Long, ByVal hwnd As IntPtr, ByVal prnhdc As IntPtr, ByVal winhdc As IntPtr, ByVal width As Long, ByVal height As Long, ByVal filename As String ) As Long

C言語
int jvCreate(int outdev, HWND hwnd, HDC prnhdc, HDC winhdc,int width, int height, char *filename);

JAVA
Int jvCreate(int outdev, int hwnd, int prnhdc, int winhdc,int width, int height, String filename);

Delphi
Function jvCreate(outdev, hwnd, prnhdc, winhdc, width, height: Longint; filename: PAnsiChar): Longint;

設定項目 | 内容
outdev | 出力先デバイス（設定値参照）
hwnd | ウィンドウハンドル
prnhdc | プリンタデバイスコンテキスト
winhdc | ウィンドウデバイスコンテキスト
width | 帳票の幅（1/100mm単位）
height | 帳票の高さ（1/100mm単位）
filename | 出力ファイル名

リターンコード

定数 | 値 | 内容
JV_ERR_JVCREATE以外 |  | 正常終了
JV_ERR_JVCREATE | -1 | オープンエラー

[設定値]

outdev には次の値を設定します。

定数 | 値 | 内容
JV_WINDOW | 1 | ウィンドウへ出力
JV_PRINTER | 2 | プリンタへ出力
JV_BMP | 3 | ビットマップ形式で出力
JV_RDF | 5 | RDF形式で出力
JV_PDF | 9 | Adobe PDF形式で出力
JV_JPEG | 10 | JPEG形式で出力
JV_TIFF | 11 | TIFF形式で出力
JV_PNG | 12 | PNG形式で出力
JV_XPS | 13 | XPS形式で出力

[解説]

jvCreateのリターン値は、ジョブIDとして他のファンクションのパラメータとなります。
jvCreateをコールした場合は、最後に必ずjvCloseをコールしてください。jvCreateとjvCloseは対になるようにコーディングします。
エラーが発生した時は、jvGetOpenErrorを使って詳しいエラー内容を取得することができます。

出力先デバイス
outdev には帳票の出力先を設定します。「JV_WINDOW」を指定すると、帳票はアプリケーションの画面に出力されます。「JV_PRINTER」を指定すると、帳票は直接プリンタへ出力されます。「JV_RDF」を指定すると、帳票はRDF形式で出力されます。RDF形式の帳票は、プレビューコントロールでプレビューや印刷を行います。「JV_PDF」を指定すると、帳票はAdobe PDF形式で出力されます。Adobe PDF形式の帳票は、Adobe Readerでプレビューします。「JV_XPS」を指定すると、帳票はXPS形式で出力されます。XPS形式の帳票は、XPSビューアでプレビューします。「JV_TIFF」「JV_BMP」「JV_PNG」「JV_JPEG」を指定すると、帳票はTIFF形式、BMP形式、PNG形式、JPEG形式で出力されます。これらの形式は、各々の形式に対応したイメージツールで表示します。
帳票を取得する場合には、jvGetDocument と jvGetLong を使います。

ウィンドウハンドル／ウィンドウデバイスコンテキスト
outdev に「JV_WINDOW」を指定した場合は、hwnd またはwinhdc のどちらかで、出力するウィンドウを設定します。出力するフォームのNameプロパティがform1であれば、hwnd の設定値はform1.hWndとなり、winhdc の設定値はform1.hDCとなります。hwnd と winhdc が共に設定された場合は、winhdc の値が優先されます。
値を設定しない場合や、outdev が「JV_WINDOW」以外の場合は、hwnd またはwinhdc には 0 を設定します。

プリンタデバイスコンテキスト
prnhdc には印刷するプリンタのデバイスコンテキスト（Printer.hDC）を設定します。プリンタデバイスコンテキストが取得できない言語環境では ０ を設定することができます。０ を設定すると、レポートライブラリがprnhdc にデフォルトプリンタ（通常使うプリンタに指定されたプリンタ）のデバイスコンテキストを設定します。
レポートライブラリは、実行時に、プリンタドライバから様々な情報を取得し帳票を作成します。prnhdc で指定したプリンタは、情報を取得するプリンタとしても使われるため、フォーム作成時と同じプリンタにすると、フォーム作成時と同じ状態で印刷やプレビューを行うことができます。フォーム作成時と異なるプリンタにした場合は、線の太さや文字の印字位置などが変わることがあります。
次の場合、prnhdc の値は無効となります。
(1) jvSetDevMode でプリンタを設定した場合
(2) jvPrintDialogEx で印刷ダイアログを表示した場合
(3) 帳票をRDF形式で作成した場合。プリンタドライバからの情報取得は、作成時ではなく、プレビューコントロールによるプレビュー時に行われます。

帳票の幅と高さ
outdev が「JV_RDF」「JV_BMP」の場合で、且つ、帳票の幅と高さをフォームの幅と高さ以外の値にする場合に設定します。「0」を指定すると、帳票はフォームの幅と高さで作成され、ページごとにフォームのサイズが変わった場合でも 自動的にフォームの幅と高さで作成されます。独自の値を指定した場合には、フォームのサイズが変わった時にも指定した幅と高さで作成されます。

出力ファイル名
帳票をファイルに保存する場合には、filename に保存するファイル名を指定します。 outdev が「JV_RDF」「JV_PDF」「JV_BMP」「JV_JPEG」「JV_TIFF」「JV_PNG」「JV_XPS」の場合に有効です。

－基 本的なコーディング
－RDFファイルを使った帳票印刷
－Adobe PDF形式の基本的なコーディング
－Adobe PDF形式の制限


jvGetOpenError

jvGetOpenError(エラー取得）

jvCreateで発生したエラーの詳しい内容を取得します。

[構文]

Function jvGetOpenError( ) As Long

C言語
int jvGetOpenError( );

JAVA
int jvGetOpenError( );

Delphi
Function jvGetOpenError( ): Longint;

リターンコード

定数 | 値 | 内容
 | 0 | エラーは発生していない
JV_ERR_OPEN_PARAM | -100 | jvCreateのパラメータが不正
JV_ERR_OPEN_HWND | -101 | Windowハンドルが指定されていない
JV_ERR_OPEN_WINHDC | -102 | Windowのデバイスコンテキストが取得できない
JV_ERR_OPEN_STDPRN | -103 | 通常使用するプリンタが指定されていない
JV_ERR_OPEN_PRNCREATEDC | -104 | プリンタデバイスコンテキストが作成できない
JV_ERR_OPEN_MEMORY | -105 | メモリ関連エラー
JV_ERR_OPEN_PRNDPI | -106 | プリンタ解像度取得エラー
JV_ERR_OPEN_WINDPI | -107 | ウィンドウ解像度取得エラー
JV_ERR_CREATE_RDF | -111 | RDFファイル作成エラー

[解説]

jvGetOpenErrorは、jvCreateのエラー情報を取得するファンクションです。jvCreateでエラーが発生した時は、jvGetOpenErrorの戻り値を取得すると詳しいエラー内容を知ることができます。


jvClose

jvClose（終了処理）

終了処理を行います。

[構文]

Function jvClose(ByVal jid As Long) As Long

C言語
int jvClose(int jid);

JAVA
int jvClose(int jid);

Delphi
Function jvClose(jid: Longint): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_CREATE_PDF | -123 | PDFファイル作成エラー

[解説]

jvCloseはjvCreateで確保した資源を解放します。jvCreateをコールした場合は、最後に必ずjvCloseをコールしてください。jvCreateとjvCloseは対になるようにコーディングします。

jvCreateの出力先デバイスに「JV_RDF」「JV_PDF」「JV_TIFF」「JV_XPS」を指定した場合には、jvCloseをコールした後にjvGetDocumentで帳票を取り出すことができます。jvCreateでファイルに保存するようにした場合には、jvCloseをコールするとファイルが作成されます。


jvStartDoc

jvStartDoc（文書開始）

印刷ジョブを開始します。

[構文]

Function jvStartDoc(ByVal jid As Long, ByVal docName As String, ByVal outFileName As String) As Long

C言語
int jvStartDoc(int jid, char *docName, char *outFileName);

JAVA
int jvStartDoc(int jid, String docName, String outFileName);

Delphi
Function jvStartDoc(jid: Longint; docName, outFileName: PAnsiChar): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
docName | ドキュメント名
outFileName | プリンタ言語ファイル名

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_OPEN_NOT_EXEC | -30 | jvCreateが実行されていない
JV_ERR_STARTDOC_ALREADY_EXEC | -31 | STARTDOC済み
JV_ERR_CREATEDC | -13 | デバイスコンテキスト作成エラー
JV_ERR_STARTDOC | -14 | 印刷開始エラー

[解説]

jvStartDocは、j vEndDoc と対になるようにコーディングしてください。

ドキュメント名
docName は、jvCreateの出力先デバイスが「JV_PRINTER」の場合には、スプーラに表示される印刷ジョブのドキュメント名となります。出力先デバイスが「JV_PDF」の場合には、Adobe PDF形式データのドキュメント名となります。出力先デバイスがそれ以外の場合、docName は無効です。

出力ファイル名
outFileName は、出力結果をプリンタ言語ファイルとして保存する時にファイル名を指定するパラメータです。jvCreateの出力先デバイスには「JV_PRINTER」を指定します。ファイル保存機能がないプリンタドライバでは、この機能は使用できません。


jvEndDoc

jvEndDoc（文書終了）

印刷ジョブを終了します。

[構文]

Function jvEndDoc(ByVal jid As Long) As Long

C言語
int jvEndDoc(int jid);

JAVA
int jvEndDoc(int jid);

Delphi
Function jvEndDoc(jid: Longint): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_STARTDOC_NOT_EXEC | -32 | STARTDOCが実行されていない
JV_ERR_ENDPAGE_NOT_EXEC | -34 | ENDPAGEが実行されていない
JV_ERR_ENDDOC | -15 | 印刷終了エラー

[解説]

jvEndDocはjvStartDocと必ず対になるようにコーディングしてください。


jvAbortDoc

jvAbortDoc（印刷キャンセル）

印刷の途中で印刷をキャンセルします。

[構文]

Function jvAbortDoc(ByVal jid As Long) As Long

C言語
int jvAbortDoc(int jid);

JAVA
int jvAbortDoc(int jid);

Delphi
Function jvAbortDoc(jid: Longint): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID

リターンコード

 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_STARTDOC_NOT_EXEC | -32 | STARTDOCが実行されていない
JV_ERR_ENDDOC | -15 | 印刷終了エラー

[解説]

jvAbortDocをコールした時は、jvEndDocをコールする必要はありません。


jvEndPage

jvEndPage（改ページ）

印刷時の改ページを行います。

[構文]

Function jvEndPage(ByVal jid As Long) As Long

C言語
int jvEndPage(int jid);

JAVA
int jvEndPage(int jid);

Delphi
Function jvEndPage(jid: Longint): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID

リターンコード

 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_STARTDOC_NOT_EXEC | -32 | STARTDOCが実行されていない
JV_ERR_STARTPAGE_NOT_EXEC | -33 | 出力するオブジェクトがない
JV_ERR_SP_OUTOFDISK | -18 | スプール用ディスク不足
JV_ERR_SP_OUTOFMEMORY | -19 | スプール用メモリ不足
JV_ERR_SP_ENDPAGE | -35 | ENDPAGEエラー

[解説]

jvEndPageで用紙が排紙されます。ページが変わる時は、必ず jvEndPage をコールします。

jvCreateの出力先デバイスが「JV_BMP」「JV_PNG」「JV_JPEG」の場合には、jvEndPageを実行すると、帳票が作成されます。複数ページの帳票を作成する時には、jvEndPageごとに帳票が上書きされていくので注意が必要です。


jvSetDevMode

jvSetDevMode（プリンタドライバ設定）

印刷実行時にアプリケーション側で自動的にプリンタドライバのプロパティを設定します。

[構文]

Function jvSetDevMode(ByVal jid As Long, ByVal temporary As Long, ByVal prnName As String, ByVal devMode As String) As Long

C言語
int jvSetDevMode(int jid, int temporary, char *prnName, char *devMode);

JAVA
int jvSetDevMode(int jid, int temporary, String prnName, String devMode);

Delphi
Function jvSetDevMode(jid, temporary: Longint; prnName, devMode: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
temporary | プリンタドライバの設定条件（設定値参照）
prnName | プリンタドライバを設定するプリンタ名
devMode | プリンタドライバ情報またはドライバ設定ファイル名

リターンコード

 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PRINTSET_ALREADY_EXEC | -36 | jvSetDevModeまたはjvPrintDialogEx実行済み
JV_ERR_PRINTERNAME | -10 | プリンタ名称エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_DRVSET | -11 | プリンタドライバ設定エラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_CREATEDC | -13 | デバイスコンテキスト作成エラー

[設定値]

temporary には次の値を設定します。

値 | 内容
0 | 永久設定
1 | 一時設定

[解説]

jvSetDevModeは、jvCreateの出力先デバイスが「JV_PRINTER」「JV_RDF」」「JV_RDFSVC」の場合に有効です。
prnName を設定しなかった場合には、jvCreateのプリンタデバイスコンテキストで指定されたプリンタが使われます。

devMode にプリンタドライバ設定ファイルを設定した場合には、ファイルの検索パスをjvSetStringで設定できます。
jvCreateの出力先デバイスが「JV_RDF」」や「JV_RDFSVC」の場合、プリンタドライバ設定ファイルは、RDF形式のデータの中に保存されます。

出力先が「JV_RDF」の場合には、設定したプリンタドライバ情報の値は、RDFデータの中に入ります。プレビューコントロールのPrintOutメソッドで印刷をすると、この設定値で印刷が行われ、プレビューコントロールのPrintDialogメソッドをコールすると、この設定値で初期設定された印刷ダイアログがポップアップします。RDFデータにプリンタドライバ情報の設定値が入っている場合、プレビューコントロールの印刷ダイアログで、ユーザーが用紙サイズや用紙方向を変更しても有効とならず、この設定値で印刷が行われます。プリンタや印刷枚数などの用紙サイズと用紙方向以外の項目は、印刷ダイアログで変更可能です。

用紙サイズや用紙方向の違う帳票を1つのRDFデータに混在させ、且つ、プレビューコントロールから一括で印刷を行う場合には、RDFデータを作成する時、各ページごとに、、jvSetDevModeで用紙サイズや用紙方向の情報を設定しておきます。

jvSetDevModeは、jvCreateからjvStartDocの間でコールします。
jvSetDevModeは、1つの印刷ジョブ（jvStartDocからjvEndDocまでの間）の中で複数回コールすることができます。jvSetDevModeを再コールする場合には、jvEndPageの後でコールします。jvSetDevModeが再びコールされると、前回の設定は無効になります。jvSetDevModeの再コールによって変更できるのは、用紙サイズと用紙方向のみで、プリンタや印刷枚数などの変更はできません。

－基 本的なコーディング
－プリンタドライバ設定ファイルとは
－プリンタドライバ情報とは
－プリンタドライバ情報の取得方法

[コーディング例]

用紙サイズや用紙方向を設定して印刷する

jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0,0,0,"")
'プリンタドライバ情報を設定する
ret = jvSetDevMode(jid, 1, "EPSON PM-G860X", "1,9,,0,75,3")
ret = jvStartDoc(jid, "請求書","")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)

用紙サイズや用紙方向を印刷の途中で変更する

jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0,0,0,"")
ret = jvSetForm(jid, "c:\JiveReport\請求書.jfm", 1, "", 100, 0, 0)
'プリンタドライバ情報を設定する
ret = jvSetDevMode(jid, 1, "EPSON PM-G860X", "1,9") 　　'A4縦置きの設定
ret = jvStartDoc(jid, "請求書","")
|
ret = jvDrawForm(jid)
ret = jvEndPage(jid)
ret = jvSetForm(jid, "c:\JiveReport\受領書.jfm", 1, "", 100, 0, 0)
ret = jvSetDevMode(jid, 1, "", "2,9") 　　'A4横置きの設定
|
ret = jvDrawForm(jid)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)

用紙のサイズや方向の異なるRDFファイルを作成しプレビューコントロールで印刷する

jid = jvCreate(JV_RDF, form1.hWnd, Printer.hDC, 0,0,0,"C:\tmp\a.rdf")
ret = jvSetForm(jid, "c:\JiveReport\請求書.jfm", 1, "", 100, 0, 0)
'プリンタドライバ情報を設定する
ret = jvSetDevMode(jid, 1, "", "1,9") 　　'A4縦置きの設定
ret = jvStartDoc(jid, "請求書","")
|
ret = jvDrawForm(jid)
ret = jvEndPage(jid)
ret = jvSetForm(jid, "c:\JiveReport\受領書.jfm", 1, "", 100, 0, 0)
ret = jvSetDevMode(jid, 1, "", "2,9") 　　'A4横置きの設定
|
ret = jvDrawForm(jid)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)

JiveView.FileName = "C:\tmp\a.rdf" 'RDFファイル名の指定
JiveView.PrinterName = "EPSON"　 '出力プリンタの指定
JiveView.Copies = 1 　 '1部印刷する
JiveView.MinPage = 1 　 '印刷開始ページを１にする
JiveView.MaxPage = JiveView.PageCount '印刷終了ページを全ページ数の値にする
JiveView.PrintOut()


jvPrintDialogEx

jvPrintDialogEx（印刷ダイアログボックス表示）

印刷時に印刷ダイアログをポップアップさせます。

[構文]

Function jvPrintDialogEx(ByVal jid As Long, ByVal prnCode As String, ByVal bufLen As Long, ByVal rval As String) As Long

C言語
int jvPrintDialogEx(int jid, char *prnCode, int bufLen, char *rval);

Java
int jvPrintDialogEx(int jid, StringBuffer prnCode, int bufLen, StringBuffer rval);

Delphi
Function jvPrintDialogEx(jid: Longint; prnCode: PAnsiChar; bufLen: Longint; rval: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
prnCode | 印刷ダイアログの初期値
bufLen | 出力値用バッファ（rval ）のバッファ長
rval | 出力値用バッファ

リターンコード

 | 値 | 内容
 | 0以上 | 出力値バッファサイズ不足（必要サイズが返る）
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PRINTSET_ALREADY_EXEC | -36 | jvSetDevModeまたはjvPrintDialog実行済み
JV_ERR_PRINTDLG_CANCEL | -12 | 印刷ダイアログでキャンセル
JV_ERR_CREATEDC | -13 | デバイスコンテキスト作成エラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[解説]

jvPrintDialogExで印刷ダイアログをポップアップさせる場合には、jvCreateの出力先デバイスを「JV_PRINTER」にします。
jvPrintDialogExをコールすると、jvCreateのプリンタデバイスコンテキストは無視されます。
j vPrintDialogExは、jvCreateからjvStartDocまでの間に、１回だけコールすることができます。
jvSetFormでフォームを指定した後にjvPrintDialogExをコールすると、フォームの用紙サイズと用紙方向で初期設定された印刷ダイアログがポップアップします。
1つの印刷ジョブ（jvStartDocからjvEndDocまでの間）の中で用紙サイズや用紙方向の異なる帳票を印刷する場合、jvPrintDialogExは使用できません。そのような帳票で印刷ダイアログを使用する場合には、RDF形式のデータを作成し、プレビューコントロールから印刷を行ってください。プレビューコントロールで印刷ダイアログを表示する場合には、プレビューコントロールのPrintDialogメソッドを使います。

印刷ダイアログの初期値
prnCode は、印刷ダイアログの初期値を設定する時に使います。
以下の項目をカンマ区切りで設定します。

１．指定可能な最小ページの値
２．指定可能な最大ページ の値
３．印刷開始ページの初期値
４．印刷終了ページの初期値
５．印刷部数
６．「部単位で印刷」チェックボックスの値（下記設定値参照）
７．「ページ指定」オプションボタンのフラグ（下記設定値参照）
８．プリンタ名
定数 | 値 | 内容
JV_COLLATE_ON | 1 | 「部単位で印刷」チェックボックスをチェックする
JV_COLLATE_OFF | 0 | 「部単位で印刷」チェックボックスのチェックをはずす
定数 | 値 | 内容
JV_ALLOWSELECT_ON | 1 | 「ページ指定」オプションボタンを使用可能にする
JV_ALLOWSELECT_OFF | 0 | 「ページ指定」オプションボタンを使用不可にする

「１．指定可能な最小ページ」と「２．指定可能な最大ページ」の値に0を指定すると全ページ印刷となります。「７．ページ指定オプションボタン」のフラグに0を指定した時も全ページ印刷となります。全ページ印刷では、印刷ダイアログがポップアップした時に、印刷開始ページと印刷終了ページは使用できません。

「３．印刷開始ページの初期値」には「１．指定可能な最小ページ」の設定値より小さな値を設定できません。
「４．印刷終了ページの初期値」には「２．指定可能な最大ページ」の設定値より大きな値を設定できません。

「６．部単位で印刷チェックボックス」は、印刷部数が1の時には設定できません。

「８．プリンタ名」が指定されると、そのプリンタで印刷ダイアログボックスが表示されます。未指定の場合、「通常使うプリンタ」で印刷ダイアログボックスが表示されます。

出力用バッファとバッファ長
bufLen と rval は、ユーザーが印刷ダイアログで設定した値を取得する時に使います。
bufLen には rval 用に確保したバッファサイズを設定します。

バッファ不足のため設定値を取得できなかった時には、0が返ります。jvPrintDialogExは１回しかコールできないため、バッファサイズ不足でエラーになった場合でも、再度コールすることはできません。余裕を持ったサイズのバッファを確保しておきます。

VisualBasic等でコーディングする時は、実行前にspace関数などでバッファを確保しておきます。

rval には、以下の項目がカンマ区切りで返ります。

１．プリンタ名称
２．印刷開始ページの値
３．印刷終了ページの値
４．印刷部数
５．「部単位で印刷」チェックボックスの状態（下記設定値参照）

定数 | 値 | 内容
JV_COLLATE_ON | 1 | 「部単位で印刷」チェックボックスがチェックされている
JV_COLLATE_OFF | 0 | 「部単位で印刷」チェックボックスがチェックされていない

ユーザーが開始ページや終了ページを入力した時には、ユーザーが指定したページをすべて印刷するようにプログラミングしてください。ユーザーが全ページ印刷を選択した時には、「２．印刷開始ページの値」と「３．印刷終了ページの値」に 0 が返ります。0 が返った時には、全ページを印刷するようにプログラミングしてください。

「４．印刷部数」には、複数部数の印刷をサポートしているプリンタドライバとサポートしていないプリンタドライバで返る値が異なります。プリンタドライバが複数部数の印刷をサポートしている場合には、レポートライブラリは、ユーザーが指定した印刷部数をプリンタドライバに設定し、「４．印刷部数」に 1 を返します。プリンタドライバが複数部数の印刷をサポートしていない場合には、レポートライブラリは、「４．印刷部数」にユーザーが指定した印刷部数を返します。「４．印刷部数」に 2 以上の値が返った時には、プリンタドライバに複数部数印刷の機能がないことを示しているので、ユーザーが指定した回数分の印刷処理をプログラミングし、アプリケーション側で複数部数の印刷に対応してください。

「５．部単位で印刷」がチェックされた時には、プリンタドライバが部単位印刷をサポートしていない場合のみ「JV_COLLATE_ON」を返します。チェックされなかった時や、プリンタドライバが部単位印刷をサポートしている時には「JV_COLLATE_OFF」を返します。 「JV_COLLATE_ON」が返った時には、部単位印刷の処理をプログラミングし、アプリケーション側で部単位印刷に対応してください。

※部単位印刷をサポートしたプリンタドライバを使う時の注意
部単位印刷に対応したプリンタドライバで部単位印刷を行う時には、事前に、印刷するプリンタのプロパティ設定画面で「全ページ分のデータをスプールしてから印刷データをプリンタに送る」という項目を設定しておきます。この項目が設定されていないと、プリンタドライバが部単位印刷をサポートしていても部単位印刷はできません。

－基本的なコーディング

[コーディング例]

実行時に印刷ダイアログを表示する

minPage = 1
maxPage = 3
fromPage = 1
toPage = 3
copies = 2
collate = JV_COLLATE_ON
pageset = JV_PAGESET_ON

prnCode = CStr(minPage) & "," & CStr(maxPage) & "," & CStr(fromPage) & "," + CStr(toPage) & "," & CStr(copies) & "," & CStr(collate) & "," & CStr(pageset)

rval = Space(100)

'プリンタダイアログボックスの表示
ret = jvPrintDialogEx(jid, prnCode, 100, rval)
If ret <> 0 Then
    MsgBox "jvPrintDialogEx Error " + CStr(ret)
End If

用紙のサイズや方向の異なるRDFファイルを作成しプレビューコントロールの印刷ダイアログを表示する

jid = jvCreate(JV_RDF, form1.hWnd, Printer.hDC, 0,0,0,"C:\tmp\a.rdf")
ret = jvSetForm(jid, "c:\JiveReport\請求書.jfm", 1, "", 100, 0, 0)
'プリンタドライバ情報を設定する
ret = jvSetDevMode(jid, 1, "", "1,9") 　　'A4縦置きの設定
ret = jvStartDoc(jid, "請求書","")
|
ret = jvDrawForm(jid)
ret = jvEndPage(jid)
ret = jvSetForm(jid, "c:\JiveReport\受領書.jfm", 1, "", 100, 0, 0)
ret = jvSetDevMode(jid, 1, "", "2,9") 　　'A4横置きの設定
|
ret = jvDrawForm(jid)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)

JiveView.FileName = "C:\tmp\a.rdf" 'RDFファイル名の指定
JiveView.Copies = 1 　 '1部印刷する
JiveView.MinPage = 1 　 '印刷開始ページを１にする
JiveView.MaxPage = JiveView.PageCount '印刷終了ページを全ページ数の値にする
JiveView.PrintDialog()


jvGetPrinterName

jvGetPrinterName（プリンタ名称取得）

使用できるプリンタの名称を取得します。

[構文]

Function jvGetPrinterName(ByVal bufLen As Long, ByVal buffer As String) As Long

C言語
int jvGetPrinterName(int bufLen ,char *buffer);

JAVA
int jvGetPrinterName(int bufLen , StringBuffer buffer);

Delphi
Function jvGetPrinterName(bufLen: Longint; buffer: PAnsiChar): Longint;
設定項目 | 内容
bufLen | 確保した情報取得バッファの長さ
buffer | 情報取得バッファ

リターンコード

 | 値 | 内容
 | 0 | 正常終了
 | 0以上 | 情報取得バッファに必要な長さ
JV_ERR_ENUMPRINTER | -17 | プリンタ名称取得エラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[解説]

プリンタ名称を正常に取得できた場合には、リターンコードに 0が返ります。取得するためのバッファが不足している場合には、リターンコードに必要なバッファサイズが返ります。リターンコードが1以上の時には、リターンコードで取得したサイズのバッファを確保し、もう一度jvGetPrinterNameをコールしてください。

取得したプリンタ名称が複数ある場合には、プリンタ名称はカンマ区切りで返ります。

JAVAでは、bufLen パラメータは無視されます。
jvGetPrinterNameはどこでもコールすることができます。


jvGetPrinterDevMode

jvGetPrinterDevMode（プリンタドライバ情報取得）

プリンタドライバの情報を取得します。

[構文]

Function jvGetPrinterDevMode(ByVal prnName As String, ByVal bufLen As Long, ByVal buffer As String) As Long

C言語
int jvGetPrinterDevMode(char *prnName, int bufLen, char *buffer);

JAVA
int jvGetPrinterDevMode(String prnName, int bufLen, StringBuffer buffer);

Delphi
Function jvGetPrinterDevMode(prnName: PAnsiChar; bufLen: Longint; buffer: PAnsiChar): Longint;
設定項目 | 内容
prnName | 情報を取得するプリンタ名称
bufLen | 確保した情報取得バッファの長さ
buffer | 情報取得バッファ

リターンコード

 | 値 | 内容
 | 0 | 正常終了
 | 0以上 | 情報取得バッファに必要な長さ
JV_ERR_DEVMODEGET | -20 | プリンタドライバ情報取得エラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[解説]

プリンタドライバ情報が正常に取得できた場合には、リターンコードに0が返ります。取得するためのバッファが不足している場合には、リターンコードに必要なバッファサイズが返ります。リターンコードが1以上の時には、リターンコードから取得したサイズのバッファを確保し、もう一度jvGetPrinterDevModeをコールしてください。

bufLen に0を設定して jvGetPrinterDevModeをコールすると、情報取得に必要なバッファサイズが返ります。JAVAでは、bufLen の値は無視されます。

buffer で取得した値はjvSetDevModeファンクションで使うことができます。
jvGetPrinterDevModeはどこでもコールすることができます。

－プリンタドライバ情報について

[コーディング例]

Dim ret&, bufLen&, buffer$
bufLen = jvGetPrinterDevMode ("EPSON", 0, buffer)
If bufLen > 0 Then
'取得用ﾊﾞｯﾌｧを確保し、再度実行する
buffer = Space(bufLen)
ret= jvGetPrinterDevMode ("EPSON", bufLen, buffer)
Else
MsgBox " jvGetPrinterDevMode " + CStr(bufLen)
End If


jvMakeDevFile

jvMakeDevFile（ドライバ設定ファイル作成）

プリンタドライバ設定ファイルを作成します。

[構文]

Function jvMakeDevFile(ByVal prnName As String, ByVal fileName As String) As Long

C言語
int jvMakeDevFile(char *prnName, char *fileName);

JAVA
int jvMakeDevFile(String prnName, String fileName);

Delphi
Function jvMakeDevFile(prnName, fileName: PAnsiChar): Longint;
設定項目 | 内容
prnName | 情報を取得するプリンタ名称
fileName | プリンタドライバ設定ファイルのファイル名称

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_OPEN_PRINTER | -91 | OpenPrinterエラー
JV_ERR_PRNSETUP | -25 | ﾌﾟﾘﾝﾀｾｯﾄｱｯﾌﾟﾀﾞｲｱﾛｸﾞｴﾗｰ
JV_ERR_GET_PRINTER | -95 | GetPrinterエラー
JV_ERR_CREATE_FILE | -45 | ファイル作成エラー
JV_ERR_WRITE_FILE | -44 | ファイルライトエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[解説]

作成したファイルはjvSetDevModeで使用します。
jvMakeDevFileはどこでもコールすることができます。

－ドライバ設定ファイルとは


jvSetPrinterLong

jvSetPrinterLong(プリンタプロパティ数値情報設定)

プリンタプロパティの各種数値情報を設定します。

[構文]

Function jvSetPrinterLong(ByVal prnName As String, ByVal mode As Long, ByVal lval As Long) As Long

C言語
int jvSetPrinterLong(char *prnName , int mode, int lval);

JAVA
int jvSetPrinterLong(String prnName , int mode, int lval);

Delphi
Function jvSetPrinterLong(prnName: PAnsiChar , mode, lval: Longint): Longint;
設定項目 | 内容
prnName | プリンタ名
mode | プロパティの種類（設定値参照）
lval | プロパティの設定値（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_OPEN_STDPRN | -103 | 通常使用するプリンタが指定されていない
JV_ERR_SETPRINTER_INFO | -129 | プリンタ情報設定エラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_PRNINFO_SPOOL_TYPE | 1 | 印刷スプール形式
JV_PRNINFO_ENABLE_DEVQ | 2 | 一致しないドキュメントを保留する
JV_PRNINFO_DO_COMPLETE_FIRST | 3 | スプールされたドキュメントを最初に印刷する
JV_PRNINFO_KEEPPRINTEDJOBS | 4 | 印刷後ドキュメントを残す
JV_PRNINFO_EMF_SPOOL | 5 | 詳細な印刷機能を有効にする

mode が印刷スプール形式（JV_PRNINFO_SPOOL_TYPE）の場合、lval には次の値を設定します。

定数 | 値 | 内容
JV_PRNINFO_SPTYPE_DIRECT | 1 | プリンタに直接印刷データを送る
JV_PRNINFO_SPTYPE_PRINTIMMEDIATELY | 2 | すぐに印刷データをプリンタに送る
JV_PRNINFO_SPTYPE_QUEUED_ALL | 3 | 全ページ分の印刷データをスプールしてからプリンタに送る

mode が印刷スプール形式以外の場合、lval には次の値を設定します。
定数 | 値 | 内容
JV_PRNINFO_VALUE_ON | 1 | 有効にする
JV_PRNINFO_VALUE_OFF | 0 | 無効にする

[解説]

jvSetPrinterLongは、コントロールパネルのプリンターのプロパティ詳細設定画面にあるプロパティをアプリケーションから設定するための関数です。これらのプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。jvSetPrinterLongを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。

jvSetPrinterLongでは数値型の値を持つプロパティを設定します。 文字列を設定する時はjvSetPrinterStringを使います。
設定値を取得する時にはjvGetPrinterLongを使います。

prnName でプリンタ名を設定しなかった場合には、コントロールパネルで通常使うプリンタに指定されているプリンタが使われます。

jvSetPrinterLongはどこでもコールすることができますが、jvCreateの前でコールすると、設定値で印刷することができます。

一致しないドキュメントを保留する(JV_PRNINFO_ENABLE_DEVQ)
一致しないドキュメントを保留する設定にすると、アプリケーションの印刷設定とプリンタの設定が合致しない場合は印刷せずに保留します。

スプールされたドキュメントを最初に印刷する(JV_PRNINFO_DO_COMPLETE_FIRST)
スプールされたドキュメントを最初に印刷しない設定にすると、スプールが完了した文書があっても優先順位のより高い文書がスプール中であれば、そちらが優先されます。

詳細な印刷機能を有効にする(JV_PRNINFO_EMF_SPOOL)
詳細な印刷機能を有効にすると、jvSetStringでプリントデータ型にRAW形式、EMF形式の指定を行うことができます。
無効にすると、jvSetStringでプリントデータ型にEMF形式の指定を行った時エラーになります。

※各プロパティの詳細は、Microsoft社が提供するWindowsのヘルプなどをご参照ください。

[コーディング例]

ret = jvSetPrinterLong("PM-G860",JV_PRNINFO_SPOOL_TYPE,JV_PRNINFO_SPTYPE_DIRECT)
ret = jvSetPrinterLong("",JV_PRNINFO_EMF_SPOOL,JV_PRNINFO_VALUE_ON)


jvSetPrinterString

jvSetPrinterString(プリンタプロパティ文字情報設定)

プリンタプロパティの各種文字情報を設定します。

[構文]

Function jvSetPrinterString(ByVal prnName As String, ByVal mode As Long, ByVal sval As String) As Long

C言語
int jvSetPrinterString(char *prnName , int mode, char *sval);

JAVA
int jvSetPrinterString(String prnName , int mode, String sval);

Delphi
Function jvSetPrinterString(prnName, sval: PAnsiChar): Longint;
設定項目 | 内容
prnName | プリンタ名
mode | プロパティの種類（設定値参照）
sval | プロパティの設定値（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_OPEN_STDPRN | -103 | 通常使用するプリンタが指定されていない
JV_ERR_GETPRINTER_INFO | -128 | プリンタ情報取得エラー
JV_ERR_SETPRINTER_INFO | -129 | プリンタ情報設定エラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_PRNSTR_PROCESSOR | 2 | プリントプロセッサ名の設定
JV_PRNSTR_DATATYPE | 3 | プリントデータ型の設定

[解説]

jvSetPrinterStringは、コントロールパネルのプリンターのプロパティ詳細設定画面にあるプリントプロセッサの値をアプリケーションから設定するための関数です。これらのプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。

jvSetPrinterStringを使って設定したプロパティは、アプリケーション終了後も設定されたままの状態となります。
jvSetStringを使うと、プリントデータ型を一時的に設定することができます。

jvSetPrinterStringでは文字型の値を持つプロパティを設定します。 数値型を設定する時はjvSetPrinterLongを使います。
設定値を取得する時にはjvGetPrinterStringを使います。

prnName でプリンタ名を設定しなかった場合には、コントロールパネルで通常使うプリンタに指定されているプリンタが使われます。

jvSetPrinterStringはどこでもコールすることができますが、jvCreateの前でコールすると、設定値で印刷することができます。

※プロパティの詳細は、Microsoft社が提供するWindowsのヘルプなどをご参照ください。

[コーディング例]

ret = jvSetPrinterString("PM-G860",JV_PRNSTR_PROCESSOR,"winprint")
ret = jvSetPrinterString("",JV_PRNSTR_DATATYPE,"NT EMF 1.006")


jvGetPrinterLong

jvGetPrinterLong(プリンタプロパティ数値情報取得)

プリンタプロパティの各種数値情報を取得します。

[構文]

Function jvGetPrinterLong(ByVal prnName As String, ByVal mode As Long) As Long

C言語
int jvGetPrinterLong(char *prnName , int mode);

JAVA
int jvGetPrinterLong(String prnName , int mode);

Delphi
Function jvGetPrinterLong(prnName: PAnsiChar , mode: Longint): Longint;
設定項目 | 内容
prnName | プリンタ名
mode | プロパティの種類（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_OPEN_STDPRN | -103 | 通常使用するプリンタが指定されていない
JV_ERR_GETPRINTER_INFO | -128 | プリンタ情報取得エラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_PRNINFO_SPOOL_TYPE | 1 | 印刷スプール形式
JV_PRNINFO_ENABLE_DEVQ | 2 | 一致しないドキュメントを保留する
JV_PRNINFO_DO_COMPLETE_FIRST | 3 | スプールされたドキュメントを最初に印刷する
JV_PRNINFO_KEEPPRINTEDJOBS | 4 | 印刷後ドキュメントを残す
JV_PRNINFO_EMF_SPOOL | 5 | 詳細な印刷機能を有効にする

[設定値]

mode が印刷スプール形式（JV_PRNINFO_SPOOL_TYPE）の場合には次の値が返ります。

定数 | 値 | 内容
JV_PRNINFO_SPTYPE_DIRECT | 1 | プリンタに直接印刷データを送る
JV_PRNINFO_SPTYPE_PRINTIMMEDIATELY | 2 | すぐに印刷データをプリンタに送る
JV_PRNINFO_SPTYPE_QUEUED_ALL | 3 | 全ページ分の印刷データをスプールしてからプリンタに送る

mode が印刷スプール形式以外の場合には次の値が返ります。
定数 | 値 | 内容
JV_PRNINFO_VALUE_ON | 1 | 有効にする
JV_PRNINFO_VALUE_OFF | 0 | 無効にする

[解説]

jvGetPrinterLongは、コントロールパネルのプリンターのプロパティ詳細設定画面にあるプロパティの設定値をアプリケーション側で取得するための関数です。これらのプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から確認することもできます。

jvGetPrinterLongでは数値型の値を持つプロパティの設定値を取得します。 文字型を取得する時はjvGetPrinterStringを使います。
値を設定する時はjvSetPrinterLongを使います。

prnName でプリンタ名を設定しなかった場合には、コントロールパネルで通常使うプリンタに指定されているプリンタが使われます。

jvGetPrinterLongはどこでもコールすることができます。

※各プロパティの詳細は、Microsoft社が提供するWindowsのヘルプなどをご参照ください。

[コーディング例]

spoolType = jvGetPrinterLong("PM-G860",JV_PRNINFO_SPOOL_TYPE)
emfSpool = jvGetPrinterLong("",JV_PRNINFO_EMF_SPOOL)


jvGetPrinterString

jvGetPrinterString(プリンタプロパティ文字情報取得)

プリンタプロパティの各種文字情報を取得します。

[構文]

Function jvGetPrinterString(ByVal prnName As String, ByVal mode As Long, ByVal bufLen As Long, ByVal buffer As String)As Long

C言語
int jvGetPrinterString(char *prnName , int mode, int bufLen, char *buffer );

JAVA
int jvGetPrinterString(String prnName , int mode, int bufLen, StringBuffer buffer );

Delphi
Function jvGetFieldString(prnName : PAnsiChar; mode, bufLen: Longint; buffer : PAnsiChar): Longint;

設定項目 | 内容
prnName | プリンタ名
mode | プロパティの種類（設定値参照）
bufLen | 情報取得バッファ(buffer)のサイズ
buffer | 情報を取得するバッファ

リターンコード

定数 | 値 | 内容
 | 1以上 | 情報取得に必要なバッファのサイズ
 | 0 | 正常終了
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_OPEN_STDPRN | -103 | 通常使用するプリンタが指定されていない
JV_ERR_GETPRINTER_INFO | -128 | プリンタ情報取得エラー

[設定値]

prnName はmode の値によって設定値が異なります。mode によって次の値を設定してください。
mode の値 | prnName に設定する値
JV_PRNSTR_SERVER | プリンタ名。未指定の場合、デフォルトプリンタ（※1）を使用。
JV_PRNSTR_PROCESSOR | プリンタ名。未指定の場合、デフォルトプリンタ（※1）を使用。
JV_PRNSTR_DATATYPE | プリンタ名。未指定の場合、デフォルトプリンタ（※1）を使用。
JV_PRNSTR_SERVER_ALL | 何も指定しない。
JV_PRNSTR_PROCESSOR_ALL | プリントサーバー名。未指定の場合、ローカルサーバーを使用。
JV_PRNSTR_DATATYPE_ALL | プリントサーバー名とプリントプロセッサ名（※2）。未指定の場合、ローカルサーバーを使用。
※1：デフォルトプリンタとは、コントロールパネルで通常使うプリンタに指定されているプリンタです。
※2：プリントサーバー名とプリントプロセッサ名はカンマで区切って指定します。（例：\\server1,winprint）

mode には次の値を設定します。

定数 | 値 | 内容
JV_PRNSTR_SERVER | 1 | 指定したプリンタのプリントサーバー名を取得
JV_PRNSTR_PROCESSOR | 2 | 指定したプリンタのプリントプロセッサ名を取得
JV_PRNSTR_DATATYPE | 3 | 指定したプリンタのプリントデータ型を取得
JV_PRNSTR_SERVER_ALL | 4 | すべてのプリントサーバー名を取得
JV_PRNSTR_PROCESSOR_ALL | 5 | 指定したプリントサーバーのすべてのプリントプロセッサ名を取得
JV_PRNSTR_DATATYPE_ALL | 6 | 指定したプリントプロセッサのすべてのプリントデータ型を取得

[解説]

jvGetPrinterStringは、コントロールパネルのプリンターのプロパティ詳細設定画面にあるプロパティの設定値をアプリケーション側で取得するための関数です。これらのプロパティは、コントロールパネルのプリンターのプロパティ詳細設定画面から確認することもできます。

jvGetPrinterStringでは文字型の値を持つプロパティの設定値を取得します。 数値型を取得する時はjvGetPrinterLongを使います。
値を設定する時はjvSetPrinterStringを使います。

prnName でプリンタ名を設定しなかった場合には、コントロールパネルで通常使うプリンタに指定されているプリンタが使われます。

jvGetPrinterStringはどこでもコールすることができます。

※各プロパティの詳細は、Microsoft社が提供するWindowsのヘルプなどをご参照ください。

[コーディング例]

Dim buflen As Long
Dim buffer As String

'すべてのプリントサーバー名の取得
buflen = jvGetPrinterString("", JV_PRNSTR_SERVER_ALL, 0, buffer)
If buflen > 0 Then
buffer = Space(buflen)
ret = jvGetPrinterString("", JV_PRNSTR_SERVER_ALL, buflen, buffer)
End If

'プリントサーバー名の取得
buflen = jvGetPrinterString("PM-G860", JV_PRNSTR_SERVER, 0, sPrintServer)
If buflen > 0 Then
sPrintServer = Space(buflen)
ret = jvGetPrinterString("PM-G860", JV_PRNSTR_SERVER, buflen, sPrintServer)
End If


jvSetLong

jvSetLong（整数型情報設定）

各種のプロパティを設定します。

[構文]

Function jvSetLong(ByVal jid As Long, ByVal mode As Long, ByVal lval As Long) As Long

C言語
int jvSetLong(int jid, int mode, int lval);

JAVA
int jvSetLong(int jid, int mode, int lval);

Delphi
Function jvSetLong(jid, mode, lval: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | プロパティの種類（設定値参照）
lval | プロパティの設定値（設定値参照）

リターンコード

 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_CREATEPEN | -50 | CREATEPENエラー
JV_ERR_CREATEBRUSH | -51 | CREATEBRUSHエラー
JV_ERR_PARAMETER | -2 | パラメータエラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_LINE_WIDTH | 1 | 線の幅（1/100mm単位）
JV_LINE_STYLE | 2 | 線の形状（設定値参照）
JV_FILL_PATTERN | 3 | 塗り潰しパターン（設定値参照）
JV_OUTLINE | 4 | 輪郭線有無（設定値参照）
JV_BACK_MODE | 5 | 背景モード（設定値参照）
JV_COLOR_MODE | 6 | カラーモード（設定値参照）
JV_FORE_COLOR | 7 | 前景色（RGB値）
JV_BACK_COLOR | 8 | 背景色（RGB値）
JV_FIELD_OVERFLOW | 9 | 文字フィールドオーバーフロー制御（設定値参照）
JV_LABEL_NO | 13 | ラベル番号
JV_PRINT_MODE | 14 | 印刷モードの変更（設定値参照）
JV_CURRENT_TOP | 25 | 描画を開始する縦座標 (1/10mm単位)
JV_JPEG_QUALITY | 35 | JPEG形式データの品質（1～100）
JV_JPEG_PROGRESSIVE | 36 | JPEG形式データのプログレッシブ（設定値参照）
JV_TIFF_COMPRESSION | 37 | TIFF形式データの圧縮（設定値参照）
JV_LIB_VERSION | 38 | ライブラリバージョンの指定(0または9）
JV_PDF_ENCRIPT_LEVEL | 41 | PDF形式データの暗号化レベル（設定値参照）
JV_PDF_ENABLE_PRINT | 42 | PDF形式データの印刷制限（設定値参照）
JV_PDF_ENABLE_EDIT | 43 | テキスト注釈及び対話フォームフィールド以外の文書内容の変更（設定値参照）
JV_PDF_ENABLE_COPY | 44 | 文書からのテキストとグラフィックスのコピー（設定値参照）
JV_PDF_ENABLE_EDIT | 45 | テキスト注釈及び対話フォームフィールドの追加または変更（設定値参照）
JV_PDF_OVERLAY | 47 | PDF形式データのオーバーレイ登録
JV_BAR_QR_ADJUST | 52 | QRコードのボックス太さ微調整（-100～100）
JV_BAR_MICROQR_ADJUST | 53 | マイクロQRコードのボックス太さ微調整（-100～100）

線の形状（JV_LINE_STYLE）のlval には次の値を設定します。
実線以外では、背景モードを透過にするか、前景色と背景色の設定をしてください。

定数 | 値 | 内容
JV_PS_SOLID | 0 | 実線
JV_PS_DASH | 1 | 破線
JV_PS_DOT | 2 | 点線
JV_PS_DASHDOT | 3 | 一点鎖線
JV_PS_DASHDOTDOT | 4 | 二点鎖線

塗り潰しパターン（JV_FILL_PATTERN）のlval には次の値を設定します。
定数 | 値 | 内容
JV_FILL_NULL | 0 | 塗り潰しなし
JV_FILL_SOLID | 1 | 前景色で塗り潰し
JV_FILL_DKGRAY | 2 | 濃い灰色
JV_FILL_GRAY | 3 | 灰色
JV_FILL_LTGRAY | 4 | 薄い灰色
JV_FILL_WHITE | 5 | 白
JV_FILL_FDIAGONAL | 6 | 45度右上がりハッチ
JV_FILL_BDIAGONAL | 7 | 45度右下がりハッチ
JV_FILL_HORIZONTAL | 8 | 水平ハッチ
JV_FILL_VERTICAL | 9 | 垂直ハッチ
JV_FILL_CROSS | 10 | 水平と垂直のクロスハッチ
JV_FILL_DIAGCROSS | 11 | 45度のクロスハッチ
（201～248 ビットマップパターン ）『網掛けパターン』参照

輪郭線有無（JV_OUTLINE）のlval には次の値を設定します。
定数 | 値 | 内容
JV_OUTLINE_OFF | 0 | 輪郭線を描画しない
JV_OUTLINE_ON | 1 | 輪郭線を描画する

背景モード（JV_BACK_MODE）のlval には次の値を設定します。
定数 | 値 | 内容
JV_TRANSPARENT | 1 | 透過
JV_OPAQUE | 2 | 上書き

カラーモード（JV_COLOR_MODE）のlval には次の値を設定します。フォームの設定値が初期値です。

定数 | 値 | 内容
JV_COLOR_OFF | 0 | モノクロ印刷を行なう
JV_COLOR_ON | 1 | カラー印刷を行なう

文字フィールドオーバーフロー制御（JV_FIELD_OVERFLOW）のlval には次の値を設定します。

定数 | 値 | 内容
JV_OVERFLOW_ERROR | 0 | 出力しない
JV_OVERFLOW_CUT | 1 | カットして出力

印刷モード（JV_PRINT_MODE）のlval には次の値を設定します。
定数 | 値 | 内容
JV_PRINTMODE_NORMAL | 1 | 通常印刷モード
JV_PRINTMODE_HISPEED | 2 | 高速印刷モード

JPEG形式データのプログレッシブ（JV_JPEG_PROGRESSIVE）のlval には次の値を設定します。
定数 | 値 | 内容
JV_JPEG_PROGRESSIVE_OFF | 0 | プログレッシブを解除 (初期値)
JV_JPEG_PROGRESSIVE_ON | 1 | プログレッシブに設定

TIFF形式データの圧縮（JV_TIFF_COMPRESSION）のlval には次の値を設定します。
定数 | 値 | 内容
JV_TIFF_COMPRESSION_DEFLATE | 0 | デフレート圧縮 (初期値)
JV_TIFF_COMPRESSION_NONE | 1 | 圧縮なし

PDF形式データ暗号化レベル（JV_PDF_ENCRIPT_LEVEL）のlval には次の値を設定します。

定数 | 値 | 内容
JV_PDFKEY_ENCRIPT_RCL | 2 | RC4(40ビット)
JV_PDFKEY_ENCRIPT_RCH | 3 | RC4(128ビット)(初期値)
JV_PDFKEY_ENCRIPT_AES128 | 4 | AES(128ビット)
JV_PDFKEY_ENCRIPT_AES256 | 5 | AES(256ビット)

PDF形式データの印刷（JV_PDF_ENABLE_PRINT）のlval には次の値を設定します。
定数 | 値 | 内容
JV_PDFKEY_SEC_ENABLE | 1 | 許可（初期値）
JV_PDFKEY_SEC_DISABLE | 0 | 許可しない

PDF形式データの文書の変更（JV_PDF_ENABLE_EDIT_ALL）のlval には次の値を設定します。
定数 | 値 | 内容
JV_PDFKEY_SEC_ENABLE | 1 | 許可（初期値）
JV_PDFKEY_SEC_DISABLE | 0 | 許可しない

PDF形式データの内容のコピーと抽出（JV_PDF_ENABLE_COPY）のlval には次の値を設定します。

定数 | 値 | 内容
JV_PDFKEY_SEC_ENABLE | 1 | 許可（初期値）
JV_PDFKEY_SEC_DISABLE | 0 | 許可しない

PDF形式データの注釈（JV_PDF_ENABLE_EDIT）のlval には次の値を設定します。

定数 | 値 | 内容
JV_PDFKEY_SEC_ENABLE | 1 | 許可（初期値）
JV_PDFKEY_SEC_DISABLE | 0 | 許可しない

PDF形式データのオーバーレイ登録（JV_PDF_OVERLAY）のlval には次の値を設定します。

定数 | 値 | 内容
JV_PDFOVERLAY_ON | 1 | 登録する
JV_PDFOVERLAY_OFF | 0 | 登録しない

[解説]

jvSetLongは数値を設定するファンクションです。 文字列を設定する時はjvSetStringを使います。

前景色（JV_FORE_COLOR）
図形や文字の前景色を指定します。カラー印刷が設定されている場合のみ有効です。
前景色は、線の幅、線の形状、塗り潰しパターンの各プロパティを設定する前に指定してください。この3種類のプロパティの後に前景色を指定しても有効になりません。

背景色（JV_BACK_COLOR）
図形や網掛け文字の背景色を指定します。カラー印刷が設定されている場合のみ有効です。
背景色は、塗り潰しパターンプロパティを設定する前に指定してください。塗り潰しパターンの後に背景色を指定しても有効になりません。

文字フィールドオーバーフロー制御（JV_FIELD_OVERFLOW）
jvSetFieldTextやjvSetFieldGridでオーバーフローが発生した時の処理を指定します。jvSetLongでは、文字型編集子を持つフィールドの処理を設定します。数値型編集子を持つフィールドのオーバーフローは、jvSetStringで設定します。処理を設定しても、オーバーフローが発生した時は、オーバーフローの発生をユーザーに知らせるため、戻り値にはオーバーフローエラーが返ります。

ラベル番号（JV_LABEL_NO）
ラベル番号はラベルフォーム専用の機能です。ラベル以外のフォームでは使用できません。
1枚のラベル用紙には、通常、縦横に複数のラベルが配置されています。
ラベル番号は、その中の1つを特定する時に使います。
ラベル上のフィールドに値を設定したりラベルを描画したりする前に、ラベル番号を指定します。
ラベル番号は、用紙左上を1とし、右側へ向かって、2、3と番号をつけます。最上段の右上まで進んだら、次は2段目の左側から同様に最後のラベルまで繰り返します。

例）ラベルが横方向に２枚、縦方向に３枚ある場合
1 | 2
3 | 4
5 | 6

－基本的なコーディング

印刷モードの変更（JV_PRINT_MODE）
この機能は、ページごとやセクションごとに印刷モードを変更する時に使います。
それ以外の場合では、印刷モードはフォームファイルで指定しておきます。
固定フォームの場合、印刷モードの変更は、jvSetFormでフォームを設定した後に行います。
可変フォームの場合、印刷モードの変更は、jvSetSectionでセクションを設定した後に行います。

高速印刷モードは高速で印刷を行いますが、一部のグラフィックス機能（３Ｄなど）に使用制限があります。通常印刷モードには使用制限はありませんが、精密な描画を行うためプリンタの性能により印刷に時間がかかることがあります。
印刷モードは、Adobe PDF形式で出力する時には無効です。

JPEG形式データの品質（JV_JPEG_QUALITY）
JPEG形式で出力する帳票の品質を設定します。数値が低くなるほど、JPEGデータのサイズは小さくなりますが、品質は劣化します。

JPEG形式データのプログレッシブ（JV_JPEG_PROGRESSIVE）
JPEG形式で出力する帳票の表示形式を設定します。「JV_JPEG_PROGRESSIVE_OFF」にすると、JPEG形式の帳票は、上から徐々に表示されていきます。「JV_JPEG_PROGRESSIVE_ON」にすると、JPEG形式の帳票は、まず画像全体が荒く表示され、徐々に鮮明度を増していきます。

TIFF形式データの圧縮（JV_TIFF_COMPRESSION）
TIFF形式の帳票はデフレート圧縮されて出力されますが、「JV_TIFF_COMPRESSION_NONE」にすると圧縮をやめることができます。

Adobe PDF形式データの設定（JV_PDF_ENCRIPT_LEVEL～JV_PDF_ENABLE_EDIT）
jvStartDocの前で設定します。
－Adobe PDF形式データのセキュリティ

Adobe PDF形式データのオーバーレイ登録（JV_PDF_OVERLAY）
Adobe PDF形式データの出力時に、フォームの固定部分をオーバーレイ登録するかどうかを指定します。
初期値は、フォームファイルに設定された値です。
－A dobe PDF形式データのオーバーレイ登録

ライブラリバージョン（JV_LIB_VERSION）
用紙の余白と拡大縮小をVer.8からVer.9の仕様で設定することができます。ライブラリバージョンに「0」を指定すると、余白や拡大縮小は最新バージョンの仕様で設定されます。「9」を指定すると、Ver.8からVer.9の仕様で設定されます。初期値は「0」です。
余白と拡大縮小についての詳細は「付録／用紙の余白（マージン）設定」を参照してください。

QRコードのボックスの太さ微調整（JV_BAR_QR_ADJUST）
QRコードは、小さなボックスの集合により描画されますが、プリンタによってボックスの太さに違いが出ます。
この機能では、0.1%単位でボックスの太さを微調整することができます。
例えば、大きく表示されてしまった場合には、-10を指定すると、ボックスの太さが1%小さくなります。

マイクロQRコードのボックスの太さの微調整（JV_BAR_MICROQR_ADJUST）
マイクロQRコードは、小さなボックスの集合により描画されますが、プリンタによってボックスの太さに違いが出ます。
この機能では、0.1%単位でボックスの太さを微調整することができます。
例えば、大きく表示されてしまった場合には、-10を指定すると、ボックスの太さが1%小さくなります。

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "売上実績",1, "",100,0,0)

ret = jvSetLong(jid, JV_PRINT_MODE,JV_PRINTMODE_HISPEED)
ret = jvSetLong(pid, JV_PDF_ENCRIPT_LEVEL, 3)
ret = jvSetLong(pid, JV_PDF_ENABLE_PRINT, 0)
ret = jvStartDoc(jid, "売上実績", "")
ret = jvSetLong(jid, JV_FORE_COLOR, RGB(255,255,255))
ret = jvSetLong(jid, JV_LINE_WIDTH, 5)
ret = jvSetLong(jid, JV_LINE_STYLE, JV_PS_SOLID)
ret = jvSetLong(jid,JV_PDF_OVERLAY,JV_PDFOVERLAY_OFF)

ret = jvDrawLine(jid, 0, 0, 1000, 1000)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetString

jvSetString（文字型情報設定）

各種のプロパティを設定します。

[構文]

Function jvSetString(ByVal jid As Long, ByVal mode As Long, ByVal sval As String) As Long

C言語
int jvSetString(int jid, int mode, char *sval);

JAVA
int jvSetString(int jid, int mode, String sval);

Delphi
Function jvSetString(jid, mode: Longint; sval: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | プロパティの種類（設定値参照）
sval | プロパティの設定値（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_FONTEMBED_FILE | -124 | フォントが埋め込めない

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_PATH_NAME | 1 | フォームファイル検索パス(256バイト以下)
JV_IMAGE_PATH_NAME | 2 | イメージファイル検索パス(256バイト以下)
JV_REPLACE_CHAR | 3 | 数値フィールドオーバーフロー時の代替文字
JV_GRID_SEPARATOR | 4 | グリッドフィールドデータの区切り記号
JV_RDF_KEY1 ～ JV_RDF_KEY5 | 11～15 | RDF形式データのキー(32バイト以下)
JV_PDF_BOOKMARK | 19 | Adobe PDF形式データのブックマーク
JV_PDF_OWNER_PASSWORD | 20 | AdobePDF形式データのオーナーパスワード(20バイト以下)
JV_PDF_USER_PASSWORD | 21 | AdobePDF形式データのユーザーパスワード(20バイト以下)
JV_PDF_AUTHOR | 22 | AdobePDF形式データの作成者(256バイト以下)
JV_PDF_CREATOR | 23 | AdobePDF形式データのアプリケーション(256バイト以下)
JV_PDF_TITLE | 24 | AdobePDF形式データのタイトル(256バイト以下)
JV_PDF_SUBJECT | 25 | AdobePDF形式データのサブタイトル(256バイト以下)
JV_PDF_KEYWORD | 26 | AdobePDF形式データのキーワード(256バイト以下)
JV_PDF_FONTEMBED | 29 | AdobePDF形式データに埋め込むフォント名
JV_GAIJI_FILE | 31 | ジャイブレポート外字ファイル名
JV_DOCUMENT_DATATYPE | 34 | プリントデータ型
JV_TEMP_PATH_NAME | 51 | XPS形式データの一時ファイル用ディレクトリ
JV_XPS_DRIVER_NAME | 52 | XPS形式データのプリンタ名
JV_OUTFILE_NAME | 53 | 帳票のファイル名
JV_ERA_NAME | 54 | 元号名と情報の指定
JV_SURROGATEPAIR_FONT | 55 | サロゲートペアで使用する代替フォントを指定

[解説]

jvSetStringは文字列を指定するファンクションです。数値を指定する場合にはjvSetLongを使います。
また、文字列をShift-JISではなく、UNICODEやサロゲートペアの文字で指定する場合には、jvSetStringWを使います。

フォームファイル検索パス（JV_FORM_PATH_NAME）
フォームファイルの検索パスを指定します。ここで指定されたパスは優先順位が最も高く、最初に検索されます。

イメージファイル検索パス（JV_IMAGE_PATH_NAME）
イメージファイルの検索パスを指定します。ここで指定されたパスは優先順位が最も高く、最初に検索されます。フォームに貼り付いている固定イメージ、jvDrawImage、jvSetFieldImage のイメージファイルに対して有効です。

数値フィールドオーバーフロー制御（JV_REPLACE_CHAR）
jvSetFieldText や jvSetFieldGrid でオーバーフローが発生した時の代替文字を指定します。
ここでは、数値型編集子を持つフィールドの代替文字を設定します。文字型編集子のオーバーフローは、jvSetLong で設定します。オーバーフローが発生した時に代替文字が設定されていないと、フィールドには何も表示されません。代替文字の設定を行っても、オーバーフローが発生した時は、ユーザーにオーバーフローを知らせるためオーバーフローエラーが返ります。

グリッドフィールドデータの区切り記号（JV_GRID_SEPARATOR）
グリッドフィールドの列データを区切る区切り記号を指定します。指定できる記号は、タブコード（chr(9))、スペース、カンマ、コロン、セミコロンの５種類です。デフォルトはカンマです。

RDF形式データのキー（JV_RDF_KEY1 ～　JV_RDF_KEY5）
RDF形式データにキーをつけます。キーは、説明やタイトルなどに利用できます。ここでつけたキーは、プレビューコントロールの Key プロパティを使って参照することができます。キーは、１から５までつけることができます。キーはjvCreatの出力先デバイスが「JV_RDF」の場合のみ使用できます。

Adobe PDF形式データのブックマーク（JV_PDF_BOOKMARK）
Adobe PDF形式データにブックマーク（しおり）をつけます。ブックマークは、設定したページのみにつきます。 全ページにつける場合は、各ページ毎にブックマークをつけます。ブックマークをUNICODEでつける場合は、jvSetStringW を使います。ブックマークはjvCreatの出力先デバイスが「JV_PDF」の場合のみ使用できます。

Adobe PDF形式データの設定（20～26）
Adobe PDF形式データの各種の情報を設定します。情報は、jvStartDoc の前で取得します。
ユーザーパスワードを設定すると、利用時にユーザーパスワードが必要となります。

Adobe PDF形式データに埋め込むフォント名（JV_PDF_FONTEMBED）
Adobe PDF形式データの中にフォントを埋め込む時に使います。埋め込むことができるフォントは、True Typeフォントのみです。 指定しなかったフォントは、埋め込まれません。描画に使用するすべてのフォントを埋め込む場合は、 * を指定します。
指定したフォントファイルが、作成する環境にない場合には、「JV_ERR_FONTEMBED_FILE」が発生します。指定したフォントがTrue Typeフォント以外の場合にも、同じエラーが発生します。エラーの原因となったフォント名は、jvGetString で取得します。
－Adobe PDF形式データのフォント埋め込み
－Adobe PDF形式データのセキュリティ

ジャイブレポート外字ファイル名（JV_GAIJI_FILE）
ジャイブレポート外字ファイルを使う時に使います。外字ファイル名はフルパスで設定します。ジャイブレポート外字ファイルはレポートエディタで作成します。jvStartDocの前で設定します。
－外字の描画

プリントデータ型（JV_DOCUMENT_DATATYPE）
プリントデータ型は、コントロールパネルのプリンターのプロパティ詳細設定画面にあるプリントデータ型プロパティをアプリケーションから設定するための機能です。プリントデータ型は、コントロールパネルのプリンターのプロパティ詳細設定画面から設定することもできます。指定可能なプリントデータ形式は、jvGetPrinterStringで取得することができます。コントロールパネルのプリンターのプロパティ詳細画面から取得することもできます。取得したデータ型のみ有効です。
jvSetStringで設定したプリントデータ型は、直後に印刷するドキュメントに対してのみ有効です。アプリケーションが終了しても有効となるように永久登録する場合には jvSetPrinterString関数を使用します。
RAW形式にする場合は"RAW"を指定します。EMF形式にする場合は"NT EMF 1.006"などを指定します。
イメージや２次元バーコード等が正しく印刷されない場合、RAW形式にすることによって現象が改善されることがあります。
jvStartDocの前に設定します。

XPS形式データの一時ファイル用ディレクトリ（JV_TEMP_PATH_NAME）
XPS形式で帳票を出力する時の一時ファイル用ディレクトリを設定します。jvCreatをコールした直後に設定します。何も指定しない場合には、Windowsの一時ファイル用ディレクトリが使われます。

XPS形式データのプリンタ名（JV_XPS_DRIVER_NAME）
帳票をXPS形式で作成する時には、XPSプリンタが必要です。通常、OSをインストールすると「Microsoft XPS Document Writer」という名前のXPSプリンタがインストールされます。このプリンタが、この名称で実行環境にある場合には、jvSetStringでプリンタ名を設定する必要はありません。このプリンタ名を変更した場合や、別のものを使用する場合には、jvCreatをコールした直後に、jvSetStringでプリンタ名を設定します。

帳票のファイル名（JV_OUTFILE_NAME）
メモリ上に作成されている帳票をファイルに保存する時のファイル名を設定します。jvCreateの出力ファイル名で設定したファイル名を変更する場合に使用します。
出力先がJPEG、PNG、BMPの場合のみ、jvEndPageの直後に使用できます。

元号名と情報の指定（JV_ERA_NAME）
和暦の元号の基本情報を指定します。ここで設定された元号は、日付型編集子を持つフィールドに使われます。
何も設定されていない場合には、「令和、平成、昭和、大正、明治」のみ自動で表示されます。
元号の基本情報は「開始年月日、ローマ字略称、漢字略称、元号」の順番で、それぞれの値を指定します。
情報と情報の間は、半角のコロン（：）を使います。
最大3つまで設定しておくことができます。※明治以前の元号を設定することはできません。

例）　2099年1月1日から元号が「永宝」になった場合
jvSetString(pid,JV_ERA_NAME,"20990101：E：永：永宝")

サロゲートペアで使用する代替フォントを指定（JV_SURROGATEPAIR_FONT）
サロゲートペアで使用する代替フォントを指定します。

例）　ＭＳ 明朝の代替フォントをSimSun-ExtBに設定し、その他のフォントの代替フォントをMingLiU-ExtBに設定する
ret = jvSetString(pid, JV_SURROGATEPAIR_FONT, "ＭＳ 明朝,SimSun-ExtB,*,MingLiU-ExtB")

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetString(jid, JV_PDF_OWNER_PASSWORD, "owner")
ret = jvSetString(jid, JV_PDF_USER_PASSWORD, "user")
ret = jvSetString(jid, JV_PDF_AUTHOR, "ジャイブコンピュータ")
ret = jvSetString(jid, JV_PDF_CREATOR, "確定申告書印刷プログラム")
ret = jvSetString(jid, JV_DOCUMENT_DATATYPE,"RAW")

ret = jvStartDoc(jid, "販売実績", "")

ret = jvSetString(jid, JV_IMAGE_PATH_NAME,"c:\temp")
ret = jvSetString(jid, JV_REPLACE_CHAR, "*")
ret = jvSetString(jid, JV_GRID_SEPARATOR, ",")
ret = jvSetString(jid, JV_RDF_KEY1, "販売実績６月分")
ret = jvSetString(jid, JV_RDF_KEY2, "名古屋支店")
ret = jvSetString(jid, JV_PDF_BOOKMARK, "納品書")
ret = jvSetString(jid, JV_PDF_FONTEMBED, "MS 明朝")
ret = jvSetString(jid, JV_PDF_FONTEMBED, "*")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetStringW

jvSetStringW（文字型情報設定　UNICODE用）

各種のプロパティをUNICODEやサロゲートペアの文字で設定します。

[構文]

Function jvSetStringW(ByVal jid As Long, ByVal mode As Long, ByVal sval As String) As Long

C言語
int jvSetStringW(int jid, int mode, wchar_t *sval);

JAVA
int jvSetStringW(int jid, int mode, String sval);

Delphi
Function jvSetStringW(jid, mode: Longint; sval: PWideChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | プロパティの種類（設定値参照）
sval | プロパティの設定値

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_PDF_BOOKMARK | 19 | Adobe PDF形式データのブックマーク

[解説]

jvSetStringWは、UNICODEやサロゲートペア用のファンクションです。Shift-JISの場合は、jvSetStringを使います。

Adobe PDF形式データのブックマーク（JV_PDF_BOOKMARK）
ブックマークは、設定したページのみにつきます。すべてのページにつける場合は、各ページ毎にブックマークをつけます。設定されなかったページにはブックマークはつきません。jvCreatの出力先デバイスが「JV_PDF」の場合に使用できます。

－UNICODEの使用について
－ サロゲートペア

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvStartDoc(jid, "伝票", "")
ret = jvSetStringW(jid, JV_PDF_BOOKMARK,"納品書")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvGetLong

jvGetLong（整数型情報取得）

各種の数値情報を取得します。

[構文]

Function jvGetLong(ByVal jid As Long, ByVal mode As Long)As Long

C言語
int jvGetLong(int jid, int mode);

JAVA
int jvGetLong(int jid, int mode);

Delphi
Function jvGetLong(jid, mode: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | 取得する情報の種類（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0以上 | 取得した値
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_ORIENT | 1 | フォームの用紙方向
JV_FORM_SIZE | 2 | フォームの用紙サイズ
JV_FORM_WIDTH | 3 | フォームの用紙の幅（1/10mm単位）
JV_FORM_HEIGHT | 4 | フォームの用紙の高さ（1/10mm単位）
JV_JOB_ID | 5 | 印刷中の印刷ジョブＩＤ
JV_PAGE_COUNT | 6 | フォームファイルのページ数
JV_HDC | 7 | 出力先のデバイスコンテキスト
JV_FORM_XMARGIN | 8 | フォームの左マージン（1/10mm単位）
JV_FORM_YMARGIN | 9 | フォームの上マージン（1/10mm単位）
JV_PRINTER_YMARGIN | 10 | 用紙の左上からプリンタの印字原点までの横マージン（1/10mm単位）
JV_PRINTER_YMARGIN | 11 | 用紙左上からプリンタ印字原点までの縦マージン（1/10mm単位）
JV_LABEL_PRINT | 12 | フォームの種類
JV_LABEL_WIDTH | 13 | ラベルの横幅（1/10mm単位）
JV_LABEL_HEIGHT | 14 | ラベルの高さ（1/10mm単位）
JV_LABEL_HNO | 15 | ラベルの横方向の枚数
JV_LABEL_VNO | 16 | ラベルの縦方向の枚数
JV_LABEL_HGAP | 17 | ラベルの横方向の間隔（1/10mm単位）
JV_LABEL_VGAP | 18 | ラベルの縦方向の間隔（1/10mm単位）
JV_PRINTER_ERROR | 21 | プリンタエラー(jvEndPage、jvStartDoc、jvEndDoc 実行時のエラー詳細)
JV_DOCMENT_SIZE | 22 | 帳票のサイズ
JV_PDF_ERRORCODE | 23 | PDFフォント埋め込みエラー文字
JV_SECTION_HEIGHT | 24 | セクションの長さ(1/10mm単位)
JV_CURRENT_TOP | 25 | 現在の縦座標 (1/10mm単位)
JV_DRAW_WIDTH | 26 | 描画領域の幅(1/10mm単位)
JV_DRAW_HEIGHT | 27 | 描画領域の高さ(1/10mm単位)

[取得値]

フォームの用紙方向（JV_FORM_ORIENT）では次の値が返ります。
定数 | 値 | 内容
JV_ORIENT_PORTLAIT | 1 | 縦置き
JV_ORIENT_LANDSCAPE | 2 | 横置き

フォームの用紙サイズ（JV_FORM_SIZE）では次の値が返ります。
定数 | 値 | 内容
JV_SIZE_A3 | 8 | A3
JV_SIZE_B4 | 12 | B4
JV_SIZE_A4 | 9 | A4
JV_SIZE_B5 | 13 | B5
JV_SIZE_A5 | 11 | A5
JV_SIZE_HAGAKI | 43 | はがき
JV_SIZE_15X11 | 46 | 15x11inch
JV_SIZE_10X11 | 45 | 10x11inch
JV_SIZE_FREE | 256 | 不定形用紙

フォームの用紙種類（JV_LABEL_PRINT）では次の値が返ります。
値 | 内容
1 | ラベルフォーム
0 | 通常フォーム

[解説]

jvGetLongは、各種の数値情報を取得します。文字列情報を取得する場合はjvGetString を使います。
正常に取得できた場合は、リターンコードに取得した数値情報が返ります。

用紙方向/サイズ（JV_FORM_ORIENT/JV_FORM_SIZE）
フォームの用紙方向やサイズを取得する場合は、jvSetForm 実行後にコールします。取得した値は、プリンタドライバ情報の値として使用できますが、不定形用紙（ユーザー定義サイズ）の用紙番号は環境によって値が違うため、レポートエディタなどで値を取得し確認してください。 ここで取得した値ではプリンタが制御できない場合もプリンタドライバ情報を取得し、内容を確認してください。

－プリンタドライバ情報とは
－プリンタドライバ情報の取得方法

印刷ジョブID（JV_JOB_ID）
印刷ジョブIDは、jvStartDoc から jvEndDoc の間で取得して下さい。ここで取得した印刷ジョブＩＤは、jvGetJobStatus、jvGetJobInfo、jvSetJobStatusで使用します。印刷ジョブＩＤが取得できなかった場合には、-1が返ります。

出力先のデバイスコンテキスト（JV_HDC）
デバイスコンテキストは、jvCreate と ｊｖClose の間で取得します。jvCreateの出力先が「JV_PRINTER」の場合は、プリンタのデバイスコンテキストを取得します。出力先が「JV_WINDOW」 の場合は、ウィンドウのデバイスコンテキストを取得します。

プリンタの印字縦横マージン（JV_PRINTER_XMARGIN/JV_PRINTER_YMARGIN）
用紙の左上からプリンタの印字原点までのマージンを取得します。
マージンを取得するプリンタは、jvCreate のプリンタデバイスコンテキストで指定したプリンタです。プリンタデバイスコンテキストに0が指定されている場合には、デフォルトプリンタ（通常使うプリンタに指定されたプリンタ）のマージンを取得します。 jvSetDevMode でプリンタ名が指定されると、そのプリンタのマージンを取得します。jvPrintDialogEx で印刷ダイアログが表示されると、印刷ダイアログで選択されたプリンタのマージンを取得します。
jvPrintDialogEx、または、jvSetDevModeをコールする場合には、jvPrintDialogEx、または、jvSetDevModeをコールした後でマージンを取得します。jvPrintDialogEx、または、jvSetDevModeをコールしない場合には、jvStartDocをコールした後で取得します。

ラベル情報（13～18）
各種のラベル情報を取得します。jvSetFormで指定したフォームがラベルフォームの場合に使用できます。

プリンタエラー（JV_PRINTER_ERROR）
jvEndPage、jvStartDoc、jvEndDoc でエラーが発生した場合に詳しいエラー番号を取得します。取得したエラー番号は、WindowsAPIのGetLastErrorで取得した値です。エラー内容は、 MicroSoft社などのWebサイトで確認してください。

帳票のサイズ（JV_DOCMENT_SIZE）
帳票データのサイズを取得します。jvGetDocument と組み合わせて使います。

PDFフォント埋め込みエラー文字（JV_PDF_ERRORCODE）
Adobe PDF形式のデータを出力中、jvDrawForm 、jvDrawText 、jvDrawTextW 、jvDrawGraph で「JV_ERR_FONTEMBED_CODE」エラーが発生した時に、エラーの原因となった文字コードを取得します。文字コードは、エラーが発生した直後のみ取得できます。

－AdobePDF形式データへフォントを埋め込む

現在の縦座標（JV_CURRENT_TOP）
この機能は可変フォーム専用の機能です。固定フォームでは使用できません。
可変フォームを描画している時に、現在の縦座標を取得します。
セクションを何も描画していない時の縦座標は0です。jvDrawSection でセクションを描画すると、縦座標には、描画したセクションの高さが加算されていきます。「JV_DRAW_HEIGHT」と組み合わせて、セクションが描画可能かどうかや、改ページが必要かどうかを判断する時に使います。
縦座標には、フォームのマージンは含まれません。縦座標を変更する時は、jvSetLong を使います。

描画領域の幅と高さ（JV_DRAW_WIDTH/JV_DRAW_HEIGHT）
この機能は可変フォーム専用の機能です。固定フォームでは使用できません。
可変フォームの描画領域を取得します。描画領域には、マージンは含まれません。

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\契約書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "火災保険契約書", "")
ret = jvGetLong(jid, JV_FORM_SIZE)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvGetStringEx

jvGetStringEx（文字型情報取得）

各種の文字情報を取得します。

[構文]

Function jvGetStringEx(ByVal jid As Long, ByVal mode As Long, ByVal buflen As Long, ByVal rval As String)As Long

C言語
int jvGetStringEx(int jid, int mode, int buflen, char *rval);

Delphi
Function jvGetStringEx(jid, mode, buflen: Longint; rval: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | 取得する情報の種類（設定値参照）
buflen | rvalのバッファサイズ
rval | 情報を取得するバッファ

リターンコード

定数 | 値 | 内容
 | 0以上 | 取得した文字列の長さ
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_NAME | 1 | フォームファイル情報のフォームファイル名（33バイト以下）
JV_FORM_CREATOR | 2 | フォームファイル情報のフォーム作成者（33バイト以下）
JV_FORM_COMMENT | 3 | フォームファイル情報のフォームの説明（257バイト以下）
JV_PRINTER_NAME | 4 | 印刷に使うプリンタ名称（33バイト以下）
JV_DEFAULT_PRINTER_NAME | 6 | 標準プリンタの名前（33バイト以下）
JV_EMBEDERR_FONT | 11 | Adobe PDF形式のデータに埋め込めないフォント名（33バイト以下）

[解説]

jvGetString は文字情報を取得します。数値情報を取得する場合は、jvGetLong を使います。
buflenにはrvalで確保したバッファサイズを指定します。
rval は、取得する情報に応じたサイズを確保してください。

フォームファイル情報（JV_FORM_NAME/JV_FORM_CREATOR/JV_FORM_COMMENT）
フォームファイル情報は、jvSetForm でフォームを設定した後に取得してください。

印刷に使うプリンタ名称（JV_PRINTER_NAME）
プリンタ名称は、jvStartDoc から jvEndDoc の間で取得して下さい。取得したプリンタ名称は、jvGetJobStatus、j vGetJobInfo 、jvGetAllJobInfo、jvSetJobStatusで使用できます。
jvCreate のプリンタデバイスコンテキストに 0 を指定した場合には、コントロールパネルで通常使うプリンタに設定されているプリンタ名称を取得します。特定のプリンタのデバイスコンテキストを指定した場合にはプリンタ名称を取得できません。
jvSetDevMode をプリンタ名を指定してコールした時は、同じプリンタ名称を取得します。
jvPrintDialogEx をコールして印刷ダイアログがポップアップされた場合には、印刷ダイアログでユーザーが選択したプリンタ名称を取得します。

標準プリンタの名前（JV_DEFAULT_PRINTER_NAME）
標準プリンタ名は、jvCreate と jvClose 間以外でも取得できます。jvCreate とjvClose の外で取得する時には、jvCreateで取得したジョブID（jid） には 0 を指定します。

Adobe PDF形式のデータに埋め込めないフォント名（JV_EMBEDERR_FONT）
Adobe PDF形式のデータを出力中、jvDrawForm 、jvSetString 、jvDrawGraph で「JV_ERR_FONTEMBED_FILE(-124)」エラーが発生した時に、エラーの原因となったフォント名を取得します。フォント名は、エラーが発生した直後のみ取得できます。

－Adpbe PDF形式データへフォントを埋め込む

[コーディング例]

Dim jid&, ret&
Dim rval$
rval = space(100)
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\見積書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "見積書", "")
ret = jvGetStringEx(jid, JV_FORM_NAME, 100, rval)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvGetString

jvGetString（文字型情報取得）

これは、旧バージョンの関数です。
旧バージョンとの互換性のため、及び、JAVAで開発するユーザーのために残されています。
JAVA以外で開発する場合には、 jvGetStringEx を使ってください。

[構文]

Function jvGetString(ByVal jid As Long, ByVal mode As Long, ByVal rval As String)As Long

C言語
int jvGetString(int jid, int mode, char *rval);

JAVA
int jvGetString(int jid, nt mode, StringBuffer rval);

Delphi
Function jvGetString(jid, mode: Longint; rval: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | 取得する情報の種類（設定値参照）
rval | 情報を取得するバッファ

リターンコード

定数 | 値 | 内容
 | 0以上 | 取得した文字列の長さ
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_NAME | 1 | フォームファイル情報のフォームファイル名（33バイト以下）
JV_FORM_CREATOR | 2 | フォームファイル情報のフォーム作成者（33バイト以下）
JV_FORM_COMMENT | 3 | フォームファイル情報のフォームの説明（257バイト以下）
JV_PRINTER_NAME | 4 | 印刷に使うプリンタ名称（33バイト以下）
JV_DEFAULT_PRINTER_NAME | 6 | 標準プリンタの名前（33バイト以下）
JV_EMBEDERR_FONT | 11 | Adobe PDF形式のデータに埋め込めないフォント名（33バイト以下）

[解説]

jvGetString は文字情報を取得します。数値情報を取得する場合は、jvGetLong を使います。

rval は、取得する情報に応じたサイズを確保してください。

フォームファイル情報（JV_FORM_NAME/JV_FORM_CREATOR/JV_FORM_COMMENT）
フォームファイル情報は、jvSetForm でフォームを設定した後に取得してください。

印刷に使うプリンタ名称（JV_PRINTER_NAME）
プリンタ名称は、jvStartDoc から jvEndDoc の間で取得して下さい。取得したプリンタ名称は、jvGetJobStatus、j vGetJobInfo 、jvGetAllJobInfo、jvSetJobStatusで使用できます。
jvCreate のプリンタデバイスコンテキストに 0 を指定した場合には、コントロールパネルで通常使うプリンタに設定されているプリンタ名称を取得します。特定のプリンタのデバイスコンテキストを指定した場合にはプリンタ名称を取得できません。
jvSetDevMode をプリンタ名を指定してコールした時は、同じプリンタ名称を取得します。
jvPrintDialogEx をコールして印刷ダイアログがポップアップされた場合には、印刷ダイアログでユーザーが選択したプリンタ名称を取得します。

標準プリンタの名前（JV_DEFAULT_PRINTER_NAME）
標準プリンタ名は、jvCreate と jvClose 間以外でも取得できます。jvCreate とjvClose の外で取得する時には、jvCreateで取得したジョブID（jid） には 0 を指定します。

Adobe PDF形式のデータに埋め込めないフォント名（JV_EMBEDERR_FONT）
Adobe PDF形式のデータを出力中、jvDrawForm 、jvSetString 、jvDrawGraph で「JV_ERR_FONTEMBED_FILE(-124)」エラーが発生した時に、エラーの原因となったフォント名を取得します。フォント名は、エラーが発生した直後のみ取得できます。

－Adpbe PDF形式データへフォントを埋め込む

[コーディング例]

Dim jid&, ret&
Dim rval$
rval = space(33)
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\見積書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "見積書", "")
ret = jvGetString(jid, JV_FORM_NAME, rval)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFont

jvSetFont（フォント指定）

jvDrawTextで文字を描画する時のフォントを設定します。

[構文]

Function jvSetFont(ByVal jid As Long, ByVal fontName As String, ByVal fontSize As Long, ByVal italic As Long, ByVal bold As Long, ByVal scaleX As Long, ByVal angle As Long) As Long

C言語
int jvSetFont(int jid, char *fontName, int fontSize, int italic, int bold, int scaleX, int angle);

JAVA
int jvSetFont(int jid, string fontName, int fontSize, int italic, int bold, int scaleX,int angle);

Delphi
Function jvSetFont(jid: Longint; fontName: PAnsiChar; fontSize, italic, bold, scaleX, angle: Longint):Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fontName | フォント名称
fontSize | フォントサイズ（1/10ポイント単位。1～2000の値を設定）
italic | フォントのイタリック（設定値参照）
bold | フォントのボールド（設定値参照）
scaleX | フォントの横方向の拡大縮小率（1%～1000%）
angle | フォントの回転角度（0度～359度を設定。反時計回りに回転）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_CREATEFONT | -68 | フォント作成エラー
JV_ERR_FONTEMBED_FILE | -124 | PDFドキュメントに埋め込めないフォントがある

[設定値]

italic には次の値を設定します。
定数 | 値 | 内容
JV_ITALIC_OFF | 0 | イタリック解除
JV_ITALIC_ON | 1 | イタリック指定

bold には次の値を設定します。
定数 | 値 | 内容
JV_BOLD_OFF | 0 | ボールド解除
JV_BOLD_ON | 1 | ボールド指定

[解説]

出力先がAdobe PDF形式データの場合には、jvSetFontでフォント名を設定した時、「JV_ERR_FONTEMBED_FILE(-124)」エラーが発生することがあります。このエラーは、ｊｖSetStringで全てのフォントを埋め込む設定がされている時に起こります。このエラーが発生した時には、設定しようとしたフォントのフォントファイルがない、または、フォントがTrue Typeフォントではないなどの原因が考えられます。
Adobe PDF形式データにフォントを埋め込む場合には、jvSetStringでフォントの埋め込みを設定後、jvSetFontでフォント名を設定します。

－Adobe PDF形式データにフォントを埋め込む


jvGetFormString

jvGetFormString（文字型フォーム情報取得）

各種の文字列型フォーム情報を取得します。

[構文]

Function jvGetFormString(ByVal jid As Long, ByVal mode As Long, ByVal bufLen As Long, ByVal rval As String)As Long

C言語
int jvGetFormString(int jid, int mode, int bufLen, char *rval);

JAVA
int jvGetFormString(int jid, int mode, int bufLen, StringBuffer rval);

Delphi
Function jvGetFormString(jid, mode, bufLen: Longint; rval: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | プロパティの種類（設定値参照）
bufLen | 情報取得バッファ(rval )のサイズ
rval | 情報を取得するバッファ

リターンコード

 | 値 | 内容
 | 1以上 | 情報取得に必要なバッファのサイズ
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_QUERY | 5 | フォームファイル情報で設定したクエリー
JV_FIELD_INFO | 6 | フィールド情報の取得

[解説]

jvSetForm 実行後にコールしてください。
rval は、取得する情報に応じたサイズを確保してください。取得した値の最後にNULL文字が入るため、必要サイズ＋1バイト分の領域が必要です。
bufLen に0を指定すると、取得に必要なバッファサイズが返ります。 JAVAの場合には、bufLen は無視されます。

フィールド情報の取得（JV_FIELD_INFO）
取得する項目と並び順は次の通りです。項目間はタブで区切られます。

１．フィールドの種類
２．フィールド名称
３．テキストフィールドの編集子
    グリッドフィールドの列数
    バーコードフィールドのバーコードの種類
４．グリッドフィールドのみ　行数
５．グリッドフィールドのみ　編集子

例）
TEXT | 顧客名 | &&&&&&&&&& |  |  |
GRID | 明細 | COLUMN=2 | ROW=32 | ### | &&&&&&
BARCODE | バーコード1 | JAN13 |  |  |
IMAGE | イメージ1 |  |  |  |
GRAPH | 3Dグラフ |  |  |  |

[コーディング例]

Dim jid&, ret&, PrintJobId&, rval$
jid = jvCreate(JV_WINDOW, form1.hWnd, Printer.hDC, form1.hDC, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1,"", 100, 0, 0)
bufLen = jvGetFormString(jid, JV_FORM_QUERY, 0, rval)
If bufLen > 0 Then
'取得用ﾊﾞｯﾌｧを確保し、再度実行する
rval= Space(bufLen )
ret=jvGetFormString(jid, JV_FORM_QUERY,bufLen,rval)
Else
MsgBox "jvGetFormStringError " + CStr(ret)
End If
：
：
：


jvGetFieldString

jvGetFieldString（文字型フィールド情報取得）

各種フィールドの文字型情報を取得します。

[構文]

Function jvGetFieldString(ByVal jid As Long, ByVal fieldName As String, ByVal mode As Long, ByVal bufLen As Long, ByVal rval As String)As Long

C言語
int jvGetFieldString(int jid, char *fieldName, int mode, int bufLen, char *rval);

JAVA
int jvGetFieldString(int jid, String fieldName, int mode, int bufLen, StringBuffer rval);

Delphi
Function jvGetFieldString(jid: Longint; fieldName: PAnsiChar; mode, bufLen: Longint; rval: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | プロパティの種類（設定値参照）
bufLen | 情報取得バッファ(rval )のサイズ
rval | 情報を取得するバッファ

リターンコード

 | 値 | 内容
 | 1以上 | 情報取得に必要なバッファのサイズ
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FLD_QUERY | 3 | フィールドのクエリー

[解説]

jvSetForm 実行後にコールしてください。
rval は、取得する情報に応じたサイズを確保してください。取得した値の最後にNULL文字が入るため、必要サイズ＋1バイト分の領域が必要です。
bufLen に0を指定すると、取得に必要なバッファサイズが返ります。 JAVAの場合には、bufLen は無視されます。

[コーディング例]

Dim jid&, ret&, bufLen&, rval$
jid = jvCreate(JV_WINDOW, form1.hWnd, Printer.hDC, form1.hDC, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1,"", 100, 0, 0)
bufLen = jvGetFieldString(jid, "顧客名", JV_FLD_QUERY, 0, rval)
If bufLen > 0 Then
'取得用ﾊﾞｯﾌｧを確保し、再度実行する
rval= Space(bufLen )
ret=jvGetFieldString(jid, "顧客名", JV_FLD_QUERY, bufLen, rval)
Else
MsgBox "jvGetFieldString " + CStr(ret)
End If
：
：
：


jvGetFieldPointEx

jvGetFieldPointEx（フィールド座標値取得）

フィールドの座標値を取得します。

[構文]

Function jvGetFieldPointEx(ByVal jid As Long, ByVal fieldName As String, ByVal buflen As Long, ByVal retString As String) As Long

C言語
int jvGetFieldPointEx(int jid, char *fieldName, int buflen, char *retString);

Delphi
Function jvGetFieldPointEx(jid: Longint; fieldName: PAnsiChar; buflen: Longint; retString: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
buflen | retStringのバッファサイズ
retString | 座標値（1/100mm単位）を返すバッファ（25バイト以上）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvGetFieldPointはjvSetForm の後にコールします。
buflenにはretStringで確保したバッファサイズを指定します。
retString には、フィールドの座標が「左上X座標、左上Y座標、右下X座標、右下Y座標」の順に返ります。データ間はカンマで区切られます。


jvGetFieldPoint

jvGetFieldPoint（フィールド座標値取得）

これは、旧バージョンの関数です。
旧バージョンとの互換性のため、及び、JAVAで開発するユーザーのために残されています。
JAVA以外で開発する場合には、jvGetFieldPoint を使ってください。

[構文]

Function jvGetFieldPoint(ByVal jid As Long, ByVal fieldName As String, ByVal retString As String) As Long

C言語
int jvGetFieldPoint(int jid, char *fieldName, char *retString);

Java
int jvGetFieldPoint(int jid, String fieldName, StringBuffer retString);

Delphi
Function jvGetFieldPoint(jid: Longint; fieldName, retString: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
retString | 座標値（1/100mm単位）を返すバッファ（25バイト以上）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvGetFieldPointはjvSetForm の後にコールします。
retString には、フィールドの座標が「左上X座標、左上Y座標、右下X座標、右下Y座標」の順に返ります。データ間はカンマで区切られます。


jvSetFieldLong

jvSetFieldLong（フィールド情報設定 整数型情報設定）

テキストフィールド・グリッドフィールドのプロパティを変更します。

[構文]

Function jvSetFieldLong(ByVal jid As Long, ByVal fieldName As String, ByVal mode As Long, ByVal lval As Long)As Long

C言語
int jvSetFieldLong(int jid, char *fieldName, int mode, int lval);

JAVA
int jvSetFieldLong(int jid, String fieldName, int mode, int lval);

Delphi
Function jvSetFieldLong(jid: Longint; fieldName: PAnsiChar; mode, lval: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
mode | プロパティの種類（設定値参照）
lval | プロパティの値

リターンコード

値 | 内容
0 | 正常終了
0未満 | エラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FONT_SIZE | 1 | フォントサイズの指定(1/10ポイント単位)
JV_FONT_BOLD | 2 | フォントボールドの指定
JV_FONT_ITALIC | 3 | フォントイタリックの指定
JV_TEXT_ALIGNMENT | 4 | 文字配置の指定
JV_TEXT_UNDERLINE | 5 | 下線の指定
JV_TEXT_DELETELINE | 6 | 打ち消し線の指定
JV_FORE_COLOR | 7 | 前景色（RGB値）
JV_BACK_COLOR | 8 | 背景色 （RGB値）
JV_UNDERLINE_DISTANCE | 9 | 文字と下線の距離（1/10mm単位）
JV_TEXT_LINECOLOR | 10 | テキストフィールドの文字の輪郭線の色（RGB値）

フォントボールド（JV_FONT_BOLD）のlval には次の値を設定します。

定数 | 値 | 内容
JV_BOLD_OFF | 0 | ボールド解除
JV_BOLD_ON | 1 | ボールド設定

フォントイタリック（JV_FONT_ITALIC）のlval には次の値を設定します。
定数 | 値 | 内容
JV_ITALIC_OFF | 0 | イタリック解除
JV_ITALIC_ON | 1 | イタリック設定

文字配置（JV_FONT_ALIGNMENT）のlval には次の値を設定します。

定数 | 値 | 内容
JV_TEXT_LEFT | 0 | 左寄せ
JV_TEXT_RIGHT | 1 | 右寄せ
JV_TEXT_CENTER | 2 | 中央揃え
JV_TEXT_EVEN | 3 | 均等割付

下線（JV_TEXT_UNDERLINE）、打ち消し線（JV_TEXT_DELETELINE）のlval には次の値を設定します。
定数 | 値 | 内容
JV_LINE_OFF | 0 | なし
JV_LINE_DASH | 1 | 破線
JV_LINE_DOT | 2 | 点線
JV_LINE_DASHDOT | 3 | 一点鎖線
JV_LINE_DASHDOTDOT | 4 | 二点鎖線
JV_LINE_SOLID | 5 | 一重線
JV_LINE_DOUBLE | 6 | 二重線
JV_LINE_WIDE | 7 | 太線

文字と下線の距離（JV_UNDERLINE_DISTANCE）のlval には-50～50の値を設定します。

[解説]

各プロパティの初期値は、フォーム上で設定されている値です。

fieldname には、プロパティを変更するフィールド名称を指定します。
グリッドフィールドの場合は、フィールド名称と一緒に行と列を指定することができます。

例）明細という名称のグリッドフィールドの場合
明細@R1C2 | → | 明細フィールド1行目2列目のセルを指定
明細@R2 | → | 明細フィールド2行目のセルを指定
明細@C3 | → | 明細フィールド3列目のセルを指定
明細 | → | 明細フィールドの全てのセルを指定

前景色（JV_FORE_COLOR）
前景色を設定すると、フォームで設定されているフォント色を変更することができます。カラー印刷が指定されている場合のみ有効です。

背景色（JV_BACK_COLOR）
テキストフィールドの背景色を設定すると、テキストフィールドの領域を塗り潰します。グリッドフィールドの背景色を設定すると、指定したセル領域を塗り潰します。カラー印刷が指定されている場合のみ有効です。

[コーディング例]

Dim ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
|
'顧客名テキストフィールドのフォント色を赤に変える
ret = jvSetFieldLong(jid, “顧客名”, JV_FORE_COLOR, RGB(255, 0, 0))
'明細グリッドフィールド3行目4列目のセルを緑で塗り潰す
ret = jvSetFieldLong(jid, “明細@R3C4”, JV_BACK_COLOR, RGB(0, 255, 0))
'テキストフィールドの輪郭線の色を変更する
ret = jjvSetFieldLong(pid,“顧客名”,JV_TEXT_LINECOLOR,RGB(255,0,0))


jvGetFieldLong

jvGetFieldLong（フィールド情報取得）

フィールドの情報を取得します。

[構文]

Function jvGetFieldLong(ByVal jid As Long, ByVal fieldName As String, ByVal mode As Long) As Long

C言語
int jvGetFieldLong(int jid, char *fieldName, int mode);

Java
int jvGetFieldLong(int jid, String fieldName, int mode);

Delphi
Function jvGetFieldLong(jid: Longint; fieldName: PAnsiChar; mode: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
mode | プロパティの種類（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0以上 | 取得した値
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FLD_GRIDCOLS | 11 | グリッドフィールドの列数を取得
JV_FLD_GRIDROWS | 12 | グリッドフィールドの行数を取得

[解説]

jvGetFieldLongは jvSetForm の後にコールします。

[コーディング例]

Dim cols As Long
Dim rows As long
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")

cols = jvGetFieldLong(jid, "明細", JV_FLD_GRIDCOLS)
rows = jvGetFieldLong(jid, "明細", JV_FLD_GRIDROWS)


jvGetDocument

jvGetDocument（各種ﾄﾞｷｭﾒﾝﾄﾃﾞｰﾀ取得）

帳票データを取得します。

[構文]

Function jvGetDocument(ByVal jid As Long, ByRef docData As Byte) As Long

C言語
int jvGetDocument(int jid, char *docData );

Delphi
Function jvGetDocument(jid: Longint; docData: array of Byte): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
docData | データを取得するバッファ

リターンコード

定数 | 値 | 内容
 | 0以上 | 取得した文字列の長さ
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[設定値]

docData には値を設定できません。

[解説]

jvGetDocument は、作成された帳票のデータを取得する時に使います。

取得できるデータの種類は、jvCreateの出力先デバイスによって異なります。(下表参照）

出力先デバイス | 取得データ
JV_RDF | RDF形式のデータ
JV_PDF | Adobe PDF形式のデータ
JV_BMP | BMP形式のデータ
JV_JPEG | JPEG形式のデータ
JV_TIFF | TIFF形式のデータ
JV_PNG | PNG形式のデータ
JV_XPS | XPS形式のデータ

docData には、帳票データが入ります。jvGetDocument をコールする前に、docData にデータを格納することができる領域を確保しておく必要があります。必要なサイズは、jvGetLongを使って取得することができます。

jvGetDocument は、jvEndDoc と jvClose の間でコールします。

64ビットのレポートライブラリDLL（X64対応版）の場合、jvGetDocument は、VisualBasic2005・VisualBasic2008では使用できません。

[コーディング例]

Visual Basicの場合

Dim iDocSize As Long
Dim sDocData() As Byte

pid= jvCreate(JV_RDF,...)
:
ret = jvEndDoc(pid)

'RDFデータサイズの取得
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)

If iDocSize > 0 Then
'RDFデータ取得用バッファの確保
ReDim sDocData(iDocSize)
'RDFデータの取得
ret = jvGetDocument(pid, sDocData(0))
End If
'レポートライブラリの終了処理を実行します。
ret = jvClose(pid)
'プレビューコントロールにRDFデータを渡す
If iDocSize > 0 Then
JiveView.DocumentData = sDocData
JiveView.Show
End If

JAVAの場合

int iPdfLen;
int jid;
String sLength;
jid = Jvalib.jvCreate(Jvalib.JV_PDF, 0, 0, 0, iFormWidth, iFormHeight, "");
：
：
//PDFデータの長さを取得し、データ取得用バッファを確保
iPdfLen = Jvalib.jvGetLong(jid,Jvalib.JV_PDF_SIZE);
byte baPdfData[] = new byte[iPdfLen];
if ( iPdfLen > 0 ){
//PDFデータを取得
Jvalib.jvGetDocment(jid, baPdfData);
}
//ﾚﾎﾟｰﾄﾗｲﾌﾞﾗﾘの終了処理を実行します。
Jvalib.jvClose(pid);
// PDFデータの出力
// ContentTypeを設定します。
response.setContentType("application/pdf");
sLength = Integer.toString(iPdfLen);
response.addHeader("content-length", sLength);
response.addHeader("content-disposition", "inline; filename=JIVE.PDF");
// バイナリ形式でPDFデータを出力します。
ServletOutputStream baos = response.getOutputStream();
baos.write(baPdfData,0,iPdfLen);
baos.flush();


jvSetForm

jvSetForm（フォーム指定）

描画するフォームを指定します。

[構文]

Function jvSetForm(ByVal jid As Long, ByVal formName As String, ByVal pageNo As Long, ByVal pageKey As String, ByVal scale As Long, ByVal mgX As Long, ByVal mgY As Long) As Long

C言語
int jvSetForm(int jid, char *formName, int pageNo, char *pageKey, int scale, int mgX, int mgY);

JAVA
int jvSetForm(int jid, String formName, int pageNo, String pageKey, int scale, int mgX, int mgY);

Delphi
Function jvSetForm(jid: Longint; formName: PAnsiChar; pageNo: Longint; pageKey: PAnsiChar; scale, mgX, mgY: Longint): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
formName | フォームファイル名称
pageNo | フォームのページ番号
pageKey | フォームのページキー
scale | フォームの拡大縮小率（1%～1000%）
mgX | フォームの横方向のマージン（1/100mm単位）
mgY | フォームの縦方向のマージン（1/100mm単位）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_OPEN_FILE | -42 | ファイルオープンエラー
JV_ERR_READ_FILE | -43 | ファイルリードエラー
JV_ERR_FORM_FORMAT | -40 | フォームのフォーマットが違う
JV_ERR_FORM_VERSION | -41 | フォームのバージョンが違う
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_PAGENO | -21 | ページ番号指定エラー
JV_ERR_PAGEKEY | -22 | ページキー指定エラー

[解説]

jvSetFormがコールされるとjvSetFieldTextなどで設定したフィールドデータはクリアされます。

フォームファイル中に複数のフォームが保存されている場合には、pageNo またはpageKey を使って使用するフォームを指定します。pageKey を使う時には、pageNo には0を指定します。
可変フォームでは、フォームファイル中に複数のフォームを作成することができないため、pageNo とpageKey パラメータは無視されます。

scale パラメータは、出力先がRDF形式、Adobe PDF形式、XPS形式の場合には無視されます。
RDF形式の場合には、プレビューコントロールのScaleプロパティを使って拡大縮小を行います。
Adobe PDF形式の場合には、Adobe Readerの機能を使って拡大縮小を行います。
XPS形式の場合には、XPS Viewerの機能を使って拡大縮小を行います。
拡大縮小率を設定しても、用紙の余白は変わりません。詳細は「付録／用紙の余白（マージン）設定」を参照してください。

mgX パラメータと mgY パラメータでは、余白を設定することができます。
ここで設定した余白は、formName で指定したフォームの余白に加算されます。
余白についての詳細は、用紙の余白（マージン）設定を参照してください。
余白は、ジャイブレポートのバージョンによって仕様が異なります。ご注意ください。

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
|
ret = jvDrawForm(jid, JV_FORM_ONLY)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetSection

jvSetSection（セクション指定）

描画するセクションを指定します。

[構文]

Function jvSetSection(ByVal jid As Long, ByVal sectionName As String) As Long

C言語
int jvSetForm(int jid, char *sectionName);

JAVA
int jvSetForm(int jid, String sectionName);

Delphi
Function jvSetForm(jid: Longint; sectionName: PAnsiChar): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
sectionName | セクション名称

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_OPEN_FILE | -42 | ファイルオープンエラー
JV_ERR_READ_FILE | -43 | ファイルリードエラー
JV_ERR_SECTIONKEY | -126 | セクションキー指定エラー
JV_ERR_OUTOFRANGE | -127 | 描画領域を超えるため指定不可

[解説]

jvSetSection は可変フォーム用のファンクションです。固定フォームでは使用できません。
jvSetSection がコールされると jvSetFieldText などで設定したフィールドデータはクリアされます。

sectionName で指定したセクションが、残りの描画領域に入らない場合には、「JV_ERR_OUTOFRANGE（-127）」が発生します。このエラーが発生した時には、セクションを変更するか、または、改ページを行います。
描画領域のサイズや現在の描画位置（座標）を取得するには、jvGetLong を使います。

[コーディング例]

Dim jid&, ret&

jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
ret = jvSetSection(jid, "ヘッダー")
ret = jvDrawSection(jid, JV_FORM_FIELD)

for i=1 to 20
ret = jvSetSection(jid, "明細1")
  |
ret = jvDrawSection(jid, JV_FORM_FIELD)
next i

ret = jvSetSection(jid, "フッター")
ret = jvDrawSection(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFieldText

jvSetFieldText（テキストフィールドデータ設定）

テキストフィールド、セレクトボタンフィールドに描画データを設定します。

[構文]

Function jvSetFieldText(ByVal jid As Long, ByVal fieldName As String, ByVal text As String) As Long

C言語
int jvSetFieldText(int jid, char *fieldName, char *text);

JAVA
int jvSetFieldText(int jid, String fieldName, String text);

Delphi
Function jvSetFieldText(jid: Longint; fieldName, text: PAnsiChar): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
text | 描画するデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_OVERFLOW | -72 | フィールドオーバーフロー
JV_ERR_FIELD_FORMAT | -71 | 編集子が不正
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvSetFieldTextはjvStartDocからjvEndDocまでの間でコールします。
UNICODEやサロゲートペアを含む文字列を描画する場合は、jvSetFieldTextWを使います。
描画文字列には、外字を使用することができます。

text の値が編集子の桁数を超えた場合はオーバーフローとなります。オーバーフロー時の処理は、編集子が文字型のフィールドではjvSetLong、編集子が数値型のフィールドではjvSetStringで設定することができます。
セレクトボタンフィールドの場合は、text に 1 または 0 を設定します。1は選択、0は選択解除です。

－外字の描画
－フィールド編集子

拡張機能・フォントの自動調整
拡張機能とは、テキストフィールドに設定されたプロパティをプログラムから変更する機能です。
フォントの自動調整とは、テキストフィールドに渡した文字列が枠からはみ出る場合に、フォントサイズを自動調整して枠内に収める機能です。
拡張機能やフォントの自動調整機能を使う場合には、フォームのデザイン時に設定しておく必要があります。

－拡張機能・フォントの自動調整の設定

拡張機能やフォントの自動調整が設定されたテキストフィールドは、以下のプロパティを変更または設定することができます。

  ・フォント：種類、横幅拡大率、サイズ、色、イタリック、ボールド
  ・文字の背景：色、高さ、縦位置
  ・下線：色、幅、位置、種類
  ・打ち消し線：色、幅、位置、種類

  ※フォントの自動調整では、以下のプロパティは使用できません。
  フォントの種類・横幅拡大率・サイズ、文字の背景の縦位置、下線の位置、打消し線の位置

これらのプロパティは、jvSetFieldLongを使って実行時に変えることもできますが、jvSetFieldLongでは、文字列全体のプロパティが変わります。拡張機能では、文字列を部分的に変えることができます。

プロパティは、予約語を使い、プログラムコードに記述して変更します。
拡張機能の使い方やコーディング例は、「付録／テキストフィールド拡張機能」を参照してください。

－フォントプロパティを変更
－文字の背景プロパティの設定
－下線プロパティの設定
－打ち消し線プロパティの設定

拡張機能とフォントの自動調整が設定されたテキストフィールドでは、オーバーフローエラーは起こりません。編集子の桁数に関係なく何文字でも渡すことができます。半角・全角に拘らず、最大2000文字まで渡すことができます。2000文字を超えた場合でもエラーは起こりませんが、そのテキストフィールドには何も描画されません。何も描画されない時には、渡した文字列の桁数を確認してください。

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\見積書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "見積書", "")
ret = jvSetFieldText(jid, "担当者名", "山田太郎")
ret = jvSetFieldText(jid, "チェック", "1")
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)

※拡張機能のコーディング例は、「付録／テキストフィールド拡張機能」の以下の項目を参照してください。

－フォントプロパティを変更
－文字の背景プロパティの設定
－下線プロパティの設定
－打ち消し線プロパティの設定


jvSetFieldTextW

jvSetFieldTextW（UNICODE用テキストフィールドデータ設定）

テキストフィールドにUNICODEやサロゲートペアのデータを設定します。

[構文]

Function jvSetFieldTextW(ByVal jid As Long, ByVal fieldName As String, ByVal text As String) As Long

C言語
int jvSetFieldTextW(int jid, wchar_t *fieldName, wchar_t *text);

JAVA
int jvSetFieldTextW(int jid, String fieldName, String text);

Delphi
Function jvSetFieldTextW(jid: Longint; fieldName, text: PWideChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
text | 描画するUNICODEデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_OVERFLOW | -72 | フィールドオーバーフロー
JV_ERR_FIELD_FORMAT | -71 | 編集子が不正
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvSetFieldTextWは、UNICODEやサロゲートペアの文字列を描画するためのファンクションです。UNICODEやサロゲートペアの文字を使用しない場合は、jvSetFieldTextを使います。jvStartDocからjvEndDocまでの間でコールします。
text の値が編集子の桁数を超えた場合はオーバーフローとなります。オーバーフロー時の処理は、文字型フィールドではjvSetLong、数値型フィールドではjvSetStringで設定することができます。text には、外字を使用することができます。

－基本的なコーディング
－外字の描画
－UNICODEの使用
－フィールド編集子
－ サロゲートペア

拡張機能・フォントの自動調整
拡張機能とは、テキストフィールドに設定されたプロパティをプログラムから変更する機能です。
フォントの自動調整とは、テキストフィールドに渡した文字列が枠からはみ出る場合に、フォントサイズを自動調整して枠内に収める機能です。
拡張機能やフォントの自動調整機能を使う場合には、フォームのデザイン時に設定しておく必要があります。

－拡張機能・フォントの自動調整の設定

拡張機能やフォントの自動調整が設定されたテキストフィールドは、以下のプロパティを変更または設定することができます。

  ・フォント：種類、横幅拡大率、サイズ、色、イタリック、ボールド
  ・文字の背景：色、高さ、縦位置
  ・下線：色、幅、位置、種類
  ・打ち消し線：色、幅、位置、種類

  ※フォントの自動調整では、以下のプロパティは使用できません。
  フォントの種類・横幅拡大率・サイズ、文字の背景の縦位置、下線の位置、打消し線の位置

これらのプロパティは、jvSetFieldLongを使って実行時に変えることもできますが、jvSetFieldLongでは、文字列全体のプロパティが変わります。拡張機能では、文字列を部分的に変えることができます。

プロパティは、予約語を使い、プログラムコードに記述して変更します。
拡張機能の使い方やコーディング例は、「付録／テキストフィールド拡張機能」を参照してください。

－フォントプロパティを変更
－文字の背景プロパティの設定
－下線プロパティの設定
－打ち消し線プロパティの設定

拡張機能とフォントの自動調整が設定されたテキストフィールドでは、オーバーフローエラーは起こりません。編集子の桁数に関係なく何文字でも渡すことができます。半角・全角に拘らず、最大2000文字まで渡すことができます。2000文字を超えた場合でもエラーは起こりませんが、そのテキストフィールドには何も描画されません。何も描画されない時には、渡した文字列の桁数を確認してください。

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\見積書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "見積書", "")
ret = jvSetFieldTextW(jid, "担当者名", "山田太郎")
ret = jvSetFieldTextW(jid, "チェック", "1")
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)

※拡張機能のコーディング例は、「付録／テキストフィールド拡張機能」の以下の項目を参照してください。

－フォントプロパティを変更
－文字の背景プロパティの設定
－下線プロパティの設定
－打ち消し線プロパティの設定


jvSetFieldGrid

jvSetFieldGrid（グリッドフィールドデータ設定）

グリッドフィールドに1行分のデータを設定します。

[構文]

Function jvSetFieldGrid(ByVal jid As Long, ByVal fieldName As String, ByVal row As Long, ByVal text As String) As Long

C言語
int jvSetFieldGrid(int jid, char *fieldName, int row, char *text);

JAVA
int jvSetFieldGrid(int jid, String fieldName, int row, String text);

Delphi
Function jvSetFieldGrid(jid: Longint; fieldName: PAnsiChar; row: Longint; text: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
row | データを設定する行番号
text | 描画するデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_OVERFLOW | -72 | フィールドオーバーフロー
JV_ERR_FIELD_FORMAT | -71 | 編集子が不正
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvSetFieldGridは、データを設定する行数分コールします。jvSetFieldGridは、jvStartDocからjvEndDocまでの間でコールします。
text には、列データと列データの間を区切り記号で区切った1行分の文字列を設定します。区切り記号はjvSetStringで任意の文字に変更することができます。区切り記号の初期値はカンマです。
編集子の桁数を超える文字列を渡した場合は、オーバーフローとなります。オーバーフロー時の処理は、列の編集子が文字型の場合にはjvSetLong、数値型の場合にはjvSetStringで設定することができます。
描画文字列には、外字を使用することができます。UNICODEやサロゲートペアを含む文字列を描画する場合には、jvSetFieldGridWを使います。

－外字の描画
－フィールド編集子

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\販売計画表.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "販売計画表", "")
for I=1 to 10
ret = jvSetFieldGrid(jid, "field1", I,
"No." & CStr(I) & ",100,200,150,60,70")
Next I
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFieldGridW

jvSetFieldGridW（UNICODE用グリッドフィールドデータ設定）

グリッドフィールドに1行分のUNICODEやサロゲートペアのデータを設定します。

[構文]

Function jvSetFieldGridW(ByVal jid As Long, ByVal fieldName As String, ByVal row As Long , ByVal text As String) As Long

C言語
int jvSetFieldGridW(int jid, wchar_t *fieldName, int row, wchar_t *text);

JAVA
int jvSetFieldGridW(int jid, String fieldName, int row, String text);

Delphi
Function jvSetFieldGridW(jid: Longint; fieldName: PWideChar; row: Longint; text: PWideChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
row | データを設定する行番号
text | 描画するUNICODEデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_OVERFLOW | -72 | フィールドオーバーフロー
JV_ERR_FIELD_FORMAT | -71 | 編集子が不正
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvSetFieldGridWは、UNICODEやサロゲートペアの文字列を描画するためのファンクションです。UNICODEやサロゲートペアの文字を使用しない場合は、jvSetFieldGridを使います。jvSetFieldGridWは、グリッドフィールドにデータを設定する行の数だけコールします。jvStartDocからjvEndDocまでの間でコールします。
text には、列データと列データの間を区切り記号で区切った1行分の文字列を設定します。区切り記号はjvSetStringで任意の文字に変更することができます。区切り記号の初期値はカンマです。
編集子の桁数を超える文字列を渡した場合は、オーバーフローとなります。オーバーフロー時の処理は、列の編集子が文字型の場合にはjvSetLong、数値型の場合にはjvSetStringで設定することができます。描画文字列には、外字を使用することができます。

－基本的なコーディング
－外字の描画
－UNICODEの使用
－フィールド編集子
－サロゲートペア

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\販売計画表.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "販売計画表", "")
for I=1 to 10
ret = jvSetFieldGridW(jid, "field1", I,
"No." & CStr(I) & ",100,200,150,60,70")
Next I
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFieldBarcodeEx

jvSetFieldBarcodeEx（ﾊﾞｰｺｰﾄﾞﾌｨｰﾙﾄﾞデータ設定）

バーコードフィールドにデータを設定します。JAVAの場合にはjvSetFieldBarcodeを使います。

[構文]

Function jvSetFieldBarcodeEx(ByVal jid As Long, ByVal fieldName As String, ByVal barcode As String, ByVal buflen As Long, ByVal retCode As String) As Long

C言語
int jvSetFieldBarcodeEx(int jid, char *fieldName, char *barcode, int buflen, char *retCode);

Delphi
Function jvSetFieldBarcodeEx(jid: Longint; fieldName, barcode: PAnsiChar; buflen: Longint; retCode: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
barcode | バーコードデータ
buflen | retCodeのバッファサイズ
retCode | 実際に描画したコードを返すバッファ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_BAR_CODE | -65 | 不正なコードがある
JV_ERR_BAR_LENGTH | -66 | コード長が不正
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvStartDocからjvEndDocまでの間でコールします。
buflenにはretCodeで確保したバッファサイズを指定します。
retCode には実際に描画したコードが返ります。コードの後ろにNULL文字が入るため、バッファは1バイト余分に確保してください。バーコードの種類がQRコード、マイクロQRコード、PDF417コード、マイクロQRコードの場合にはretCode に何も返りません。

barcode の値はバーコードの種類により異なります。 詳細は各バーコードの説明を参照してください。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マクロQRコード
－PDF417コード
－マイクロPDF417コード

[コーディング例]

Dim jid&, ret&
Dim retCode$
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\今期予算表.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "今期予算表", "")
retCode = space(14)
ret = jvSetFieldBarcodeEx(jid, "field1", "491234567890", 14, retCode)
|
retCode = space(100)
ret = jvSetFieldBarcodeEx(jid,"CST","460-0011愛知県名古屋市中区大須一丁目25番28号", 100, retCode)
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFieldBarcode

jvSetFieldBarcode（ﾊﾞｰｺｰﾄﾞﾌｨｰﾙﾄﾞデータ設定）

これは、旧バージョンの関数です。
旧バージョンとの互換性のため、及び、JAVAで開発するユーザーのために残されています。
JAVA以外で開発する場合には、jvSetFieldBarcodeExを使ってください。

[構文]

Function jvSetFieldBarcode(ByVal jid As Long, ByVal fieldName As String, ByVal barcode As String, ByVal retCode As String) As Long

C言語
int jvSetFieldBarcode(int jid, char *fieldName, char *barcode, char *retCode);

JAVA
int jvSetFieldBarcode(int jid, String fieldName, String barcode, StringBuffer retCode);

Delphi
Function jvSetFieldBarcode(jid: Longint; fieldName, barcode, retCode: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
barcode | バーコードデータ
retCode | 実際に描画したコードを返すバッファ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_BAR_CODE | -65 | 不正なコードがある
JV_ERR_BAR_LENGTH | -66 | コード長が不正
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvStartDocからjvEndDocまでの間でコールします。

retCode には実際に描画したコードが返ります。コードの後ろにNULL文字が入るため、バッファは1バイト余分に確保してください。バーコードの種類がQRコードの場合にはretCode に何も返りません。

barcode の値はバーコードの種類により異なります。 詳細は各バーコードの説明を参照してください。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マクロQRコード
－PDF417コード
－マイクロPDF417コード

[コーディング例]

Dim jid&, ret&
Dim retCode$
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\今期予算表.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "今期予算表", "")
retCode = space(14)
ret = jvSetFieldBarcode(jid, "field1", "491234567890", retCode)
|
retCode = space(100)
ret = jvSetFieldBarcode(jid,"CST","460-0011愛知県名古屋市中区大須一丁目25番28号", retCode)
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFieldImage

jvSetFieldImage（イメージフィールドデータセット）

イメージフィールドにイメージファイル名を設定します。

[構文]

Function jvSetFieldImage(ByVal jid As Long, ByVal fieldName As String, ByVal image As String) As Long

C言語
int jvSetFieldImage(int jid, char *fieldName, char *image);

JAVA
int jvSetFieldImage(int jid, String fieldName, String image);

Delphi
Function jvSetFieldImage(jid: Longint; fieldName, image: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
image | イメージファイル名（256バイト以下）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_IMAGE_FNAME | -90 | イメージファイルが見つからない
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvStartDocからjvEndDocまでの間でコールします。
jvSetStringでイメージ検索パスを設定することができます。

jvSetFieldImage は、イメージファイルを描画する時に使います。
メモリ上に読み込まれたイメージデータを描画する場合は、jvSetFieldImageDataを使います。

－対応イメージ形式

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\前期売上実績表.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "前期売上実績表", "")
ret = jvSetFieldImage(jid, "field1", "c:\temp\image.bmp")
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvSetFieldImageData

jvSetFieldImageData（イメージフィールドデータセット）

イメージフィールドにイメージデータを設定します。

[構文]

Function jvSetFieldImageData(ByVal jid As Long, ByVal fieldName As String, ByVal imageLength As Long, ByRef imageData As Byte) As Long

C言語
int jvSetFieldImageData(int jid, char *fieldName, int imageLength , char *imageData);

JAVA
int jvSetFieldImageData(int jid, String fieldName, int imageLength, byte[] imageData);

Delphi
Function jvSetFieldImageData(jid: Longint; fieldName: PAnsiChar; imageLength: Longint; imageData: array of Byte): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
imageLength | イメージデータの長さ(バイト数)
imageData | イメージデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvStartDocからjvEndDoc までの間でコールします。

jvSetFieldImageDataは、メモリ上に読み込まれたイメージデータを描画する時に使います。
ファイルに保存されたイメージを描画する時は、jvSetFieldImage を使います。

－対応イメージ形式

※ヘルプの「アプリケーション開発／イメージをデータ形式で設定」に言語ごとのコーディングサンプルがあります。

64ビットのレポートライブラリDLLの場合、jvSetFieldImageData はVisualBasic2005・VisualBasic2008では使用できません。

[コーディング例]

Dim fileNo As Integer 'ファイル番号
Dim imageLength As Long
Dim imageData() As Byte
Dim imageFileName As String

imageFileName = "c:\images\cup.dib"
fileNo = FreeFile 'ファイル番号取得
Open imageFileName For Binary As #fileNo 'ファイルオープン
imageLength = FileLen(imgFileName)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo
ret = jvSetFieldImageData(pid, "IMAGE_2", imageLength, imageData(0))


jvSetFieldGraph

jvSetFieldGraph（グラフフィールドデータセット）

グラフフィールドにデータを設定します。

[構文]

Function jvSetFieldGraph(ByVal jid As Long, ByVal fieldName As String, ByVal graph As String) As Long

C言語
int jvSetFieldGraph(int jid, char *fieldName, char *graph);

JAVA
int jvSetFieldGraph(int jid, String fieldName, String graph);

Delphi
Function jvSetFieldGraph(jid: Longint; fieldName, graph: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
fieldName | フィールド名称
graph | グラフデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_FIELD_NAME | -70 | 指定されたフィールドが存在しない

[解説]

jvStartDocからjvEndDocまでの間でコールします。

graph には、データ間をカンマで区切ったグラフデータを設定します。複数のデータ系列と複数の項目が存在する場合は、「項目１の系列１、項目１の系列２、．．．項目１の系列ｎ、．．．、項目ｎの系列１、項目ｎの系列２、．．．項目ｎの系列ｎ」の順番でセットします。散布図の場合はデータを1000倍してください。

－グラフデータの設定
－グラフの描画

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\来期売上見込表.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "来期売上見込表", "")
ret = jvSetFieldGraph(jid,"field1","10,22,15,45,25,68,33,45,78")
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawForm

jvDrawForm（フォームとフィールド描画）

フォームとフィールドを描画します。

[構文]

Function jvDrawForm(ByVal jid As Long , ByVal mode As Long) As Long

C言語
int jvDrawForm(int jid, int mode);

JAVA
int jvDrawForm(int jid, int mode);

Delphi
Function jvDrawForm(jid, mode: Longint): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | 描画するモード（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_FONTEMBED_FILE | -124 | Adobe PDF形式のデータに埋め込めないフォントがある
JV_ERR_FONTEMBED_CODE | -125 | Adobe PDF形式のデータにフォントを埋め込めない文字コードがある

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_FIELD | 1 | フォームとフィールドを描画
JV_FORM_ONLY | 2 | フォームのみ描画
JV_FIELD_ONLY | 3 | フィールドのみ描画

[解説]

jvDrawFormは固定フォーム用のファンクションです。可変フォームの場合はjvDrawSectionを使います。

mode は、帳票を部分的に描画する時に使います。

「JV_ERR_FONTEMBED_FILE(-124)」と「JV_ERR_FONTEMBED_CODE(-125)」は、Adobe PDF形式のデータを作成している時のエラーです。これらのエラーは、 jvSetString でフォントを埋め込むように設定した場合に発生します。「JV_ERR_FONTEMBED_FILE(-124)」エラーは、描画に使われている全てのフォントを埋め込むように設定した場合に発生します。このエラーは、帳票を描画中、埋め込むことができないフォントが見つかった時に発生します。エラーの原因となったフォント名は、エラー発生直後に、jvGetString で取得することができます。「JV_ERR_FONTEMBED_CODE(-125)」エラーは、帳票を描画中、埋め込むことができない文字コードが見つかった時に発生します。エラーの原因となった文字コードは、エラー発生直後に、jvGetLongで取得することができます。

－Adobe PDF形式のデータにフォントを埋め込む
－基本的なコーディング

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\請求明細.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "請求明細書", "")
ret = jvSetFieldText(jid, "field1", "山田太郎")
|
ret = jvDrawForm(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawSection

jvDrawSection（セクションとフィールド描画）

セクションとフィールドを描画します。

[構文]

Function jvDrawSection(ByVal jid As Long , ByVal mode As Long) As Long

C言語
int jvDrawSection(int jid, int mode);

JAVA
int jvDrawSection(int jid, int mode);

Delphi
Function jvDrawSection(jid, mode: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
mode | 描画するモード（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_REQ_ENDPAGE | 1 | 正常終了。改ページの要求
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_FONTEMBED_FILE | -124 | Adobe PDF形式のデータに埋め込めないフォントがある
JV_ERR_FONTEMBED_CODE | -125 | Adobe PDF形式のデータにフォントを埋め込めない文字コードがある
JV_ERR_OUTOFRANGE | -127 | 描画領域を超えるため描画不可

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_FORM_FIELD | 1 | フォームとフィールドを描画
JV_FORM_ONLY | 2 | フォームのみ描画
JV_FIELD_ONLY | 3 | フィールドのみ描画

[解説]

jvDrawSectionは可変フォーム用のファンクションです。固定フォームの場合はjvDrawFormを使います。

mode は、帳票を部分的に描画する時に使います。

セクションを正常に描画した後、指定中のセクションを描画する領域がまだ残っている場合には0が返ります。描画する領域が残っていない場合には「JV_REQ_ENDPAGE（1）」が返ります。「JV_REQ_ENDPAGE（1）」が返った場合には、改ページ、または、セクション変更のどちらかが必要です。

jvDrawSection をコールした時に、描画領域不足のためセクションが描画できない場合には「JV_ERR_OUTOFRANGE（-127）」が返ります。このエラーが起こると、セクションは描画されず、フィールドにセットされたデータはクリアされます。同じセクションを繰り返し描画する時には、「JV_REQ_ENDPAGE（1）」が返った時に改ページやセクション変更などの処理を行い、このエラーを起こさないようにします。

「JV_ERR_FONTEMBED_FILE(-124)」と「JV_ERR_FONTEMBED_CODE(-125)」エラーは、Adobe PDF形式のデータを作成している時のエラーです。どちらも jvSetString でフォントを埋め込むように設定した時に発生します。「JV_ERR_FONTEMBED_FILE(-124)」エラーは、全てのフォントを埋め込むように設定した場合に発生します。このエラーは、フォームファイルの中に埋め込めないフォントが見つかった時に発生します。エラーの原因となったフォント名は、、エラー発生直後に、jvGetString で取得することができます。「JV_ERR_FONTEMBED_CODE(-125)」エラーは、フォントを埋め込めない文字コードが見つかった時に発生します。エラーの原因となった文字コードは、エラー発生直後に、jvGetLongで取得することができます。

－Adobe PDF形式のデータにフォントを埋め込む
－基本的なコーディング

[コーディング例]

Dim jid&, ret&

jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
ret = jvSetSection(jid, "ヘッダー")
ret = jvDrawSection(jid, JV_FORM_FIELD)

for i=1 to 20
ret = jvSetSection(jid, "明細1")
  |
ret = jvDrawSection(jid, JV_FORM_FIELD)
next i

ret = jvSetSection(jid, "フッター")
ret = jvDrawSection(jid, JV_FORM_FIELD)
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawLine

jvDrawLine（直線描画）

直線を描画します。

[構文]

Function jvDrawLine(ByVal jid As Long , ByVal sx As Long , ByVal sy As Long , ByVal ex As Long, ByVal ey As Long) As Long

C言語
int jvDrawLine(int jid, int sx, int sy, int ex, int ey);

JAVA
int jvDrawLine(int jid, int sx, int sy, int ex int ey);

Delphi
Function jvDrawLine(jid, sx, sy, ex, ey: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | 直線の始点X座標（1/100mm単位）
sy | 直線の始点Y座標（1/100mm単位）
ex | 直線の終点X座標（1/100mm単位）
ey | 直線の終点Y座標（1/100mm単位）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_DRAW_MOVETOEX | -52 | MOVETOEXエラー
JV_ERR_DRAW_LINETO | -53 | LINETOエラー

[解説]

線の種類を線の幅などのプロパティはjvSetLongで設定します。

－基本的なコーディング


jvDrawBox

jvDrawBox（四角形描画）

四角形を描画します。

[構文]

Function jvDrawBox(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal ex As Long, ByVal ey As Long, ByVal round As Long, ByVal roundPtr As Long) As Long

C言語
int jvDrawBox(int jid, int sx, int sy, int ex, int ey, int round, int roundPtr);

JAVA
int jvDrawBox(int jid, int sx, nt sy, int ex, int ey, int round, int roundPtr);

Delphi
Function jvDrawBox(jid, sx, sy, ex, ey, round, roundPtr: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | 四角形の左上X座標（1/100mm単位）
sy | 四角形の左上Y座標（1/100mm単位）
ex | 四角形の右下X座標（1/100mm単位）
ey | 四角形の右下Y座標（1/100mm単位）
round | 四角形の角丸め半径（1/100mm単位）
roundPtr | 四角形の角丸め位置（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_CREATEPEN | -50 | CREATEPENエラー
JV_ERR_DRAW_RECTANGLE | -54 | 四角形描画エラー
JV_ERR_DRAW_BEGINPATH | -56 | BEGINPATHエラー
JV_ERR_DRAW_MOVETOEX | -52 | MOVETOEXエラー
JV_ERR_DRAW_LINETO | -53 | LINETOエラー
JV_ERR_DRAW_POLYBEZIERTO | -55 | ベジェ曲線描画エラー
JV_ERR_DRAW_ENDPATH | -57 | ENDPATHエラー
JV_ERR_DRAW_STROKE | -58 | STROKEエラー

[設定値]

roundPtr には次の値を設定します。複数設定する時はOrで連結します。

定数 | 値 | 内容
JV_ROUND_LT | 1 | 左上
JV_ROUND_RT | 2 | 右上
JV_ROUND_LB | 4 | 左下
JV_ROUND_RB | 8 | 右下

[解説]

線の種類、線の幅、塗り潰しパターンなどのプロパティはjvSetLongで設定します。


jvDrawEllipse

jvDrawEllipse（円・楕円描画）

円・楕円を描画します。

[構文]

Function jvDrawEllipse(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal ex As Long, ByVal ey As Long) As Long

C言語
int jvDrawEllipse(int jid, int sx, int sy, int ex, int ey);

JAVA
int jvDrawEllipse(int jid, int sx, int sy, int ex, int ey);

Delphi
Function jvDrawEllipse(jid, sx, sy, ex, ey: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | 円・楕円に外接する四角形の左上X座標（1/100mm単位）
sy | 円・楕円に外接する四角形の左上Y座標（1/100mm単位）
ex | 円・楕円に外接する四角形の右下X座標（1/100mm単位）
ey | 円・楕円に外接する四角形の右下Y座標（1/100mm単位）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_CREATEPEN | -50 | CREATEPENエラー
JV_ERR_DRAW_ELLIPSE | -59 | 円・楕円描画エラー

[解説]

線の種類、線の幅、塗り潰しパターンなどのプロパティはjvSetLongで設定します。


jvDrawArc

jvDrawArc（弧・弓・扇描画）

弧・弓・扇を描画します。

[構文]

Function jvDrawArc(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal ex As Long, ByVal ey As Long , ByVal mx1 As Long, ByVal my1 As Long, ByVal mx2 As Long, ByVal my2 As Long, ByVal arcMode As Long) As Long

C言語
int jvDrawArc(int jid, int sx, int sy, int ex, int ey, int mx1, int my1, int mx2, int my2, int arcMode);

JAVA
int jvDrawArc(int jid, int sx, int sy, int ex, int ey, int mx1, int my1, int mx2, int my2, int arcMode);

Delphi
Function jvDrawArc(jid, sx, sy, ex, ey, mx1, my1, mx2, my2, arcMode: Longint): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | 弧・弓・扇に外接する四角形の左上X座標（1/100mm単位）
sy | 弧・弓・扇に外接する四角形の左上Y座標（1/100mm単位）
ex | 弧・弓・扇に外接する四角形の右下X座標（1/100mm単位）
ey | 弧・弓・扇に外接する四角形の右下Y座標（1/100mm単位）
mx1 | 弧・弓・扇の開始X座標（1/100mm単位）
my1 | 弧・弓・扇の開始Y座標（1/100mm単位）
mx2 | 弧・弓・扇の終了X座標（1/100mm単位）
my2 | 弧・弓・扇の終了Y座標（1/100mm単位）
arcMode | 描画する種類（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_DRAW_ARC | -60 | 弧・弓・扇描画エラー
JV_ERR_PARAMETER | -2 | パラメータエラー

[設定値]

arcMode には次の値を設定します。

定数 | 値 | 内容
JV_ARC_ARC | 1 | 弧
JV_ARC_PIE | 2 | 扇
JV_ARC_CHORD | 4 | 弓

[解説]

線の種類、線の幅、塗り潰しパターンなどのプロパティはjvSetLongで設定します。


jvDrawPolygon

jvDrawPolygon（多角形描画）

多角形を描画します。

[構文]

Function jvDrawPolygon(ByVal jid As Long, ByVal close As Long, ByVal mode As Long, ByVal point As String) As Long

C言語
int jvDrawPolygon(int jid, int close, int mode, char *point);

JAVA
int jvDrawPolygon(int jid, int close, int mode, String point);

Delphi
Function jvDrawPolygon(jid, close, mode: Longint; point: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
close | 閉じた多角形/開いた多角形 (設定値参照）
mode | 座標間をつなぐ線の種類 （設定値参照）
point | 全座標（1/100mm単位）のカンマ区切りデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_CREATEPEN | -50 | CREATEPENエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_DRAW_POLYGON | -61 | 多角形描画エラー
JV_ERR_DRAW_POLYBEZIER | -63 | 多角形描画エラー

[設定値]

close には次の値を設定します。

定数 | 値 | 内容
JV_POLY_CLOSE | 1 | 閉じる
JV_POLY_OPEN | 0 | 開く

mode には次の値を設定します。

定数 | 値 | 内容
JV_POLYGON | 1 | 直線
JV_BEZIER | 0 | ベジェ曲線

[解説]

線の種類、線の幅、塗り潰しパターンなどのプロパティはjvSetLongで設定します。

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\採用実績.jfm", 1,"", 100, 0, 0)
ret = jvStartDoc(jid, "採用実績表", "")
ret = jvDrawPolygon(jid, JV_POLY_CLOSE,
JV_POLYGON, "0,0,1000,1000,2000,1000")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawText

jvDrawText（文字描画）

文字列を描画します。

[構文]

Function jvDrawText(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal ex As Long , ByVal ey As Long, ByVal charPitch As Long, ByVal linePitch As Long, ByVal format As Long, ByVal angle As Long, ByVal lineFeed As Long, ByVal kinsoku As Long, ByVal wordlap As Long, ByVal text As String) As Long

C言語
int jvDrawText(int jid, int sx, int sy, int ex, int ey, int charPitch, int linePitch, int format, int angle, int lineFeed, int kinsoku, int wordlap, char *text);

JAVA
int jvDrawText(int jid, int sx, int sy, int ex, int ey, int charPitch, int linePitch, int format, int angle, int lineFeed, int kinsoku, int wordlap, String text);

Delphi
Function jvDrawText(jid, sx, sy, ex, ey, charPitch, linePitch, format, angle: Longint; lineFeed, kinsoku, wordlap: Longint; text: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | 先頭文字の左上X座標（1/100mm単位）
sy | 先頭文字の左上Y座標（1/100mm単位）
ex | 文字編集領域の右下X座標（1/100mm単位）
ey | 文字編集領域の右下Y座標（1/100mm単位）
charPitch | 文字と文字の間のピッチ（ポイント単位）
linePitch | 行と行の間のピッチ（ポイント単位）
format | 文字編集（設定値参照）
angle | 文字列の描画方向（設定値参照）
lineFeed | 改行方向（設定値参照）
kinsoku | 禁則処理（設定値参照）
wordlap | 英文ワードラップ（設定値参照）
text | 描画文字列

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_FONTEMBED_CODE | -125 | Adobe PDF形式のデータにフォントを埋め込めない文字コードがある

[設定値]

format には次の値を設定します。

定数 | 値 | 内容
JV_TEXT_LEFT | 0 | 左寄せ
JV_TEXT_RIGHT | 1 | 右寄せ
JV_TEXT_CENTER | 2 | 中央揃え
JV_TEXT_EVEN | 3 | 均等割付

angle には次の値を設定します。

定数 | 値 | 内容
JV_ANGLE0 | 0 | 左から右方向へ描画
JV_ANGLE90 | 1 | 下から上方向へ描画
JV_ANGLE180 | 2 | 右から左方向へ描画
JV_ANGLE270 | 3 | 上から下方向へ描画

lineFeed には次の値を設定します。

定数 | 値 | 内容
JV_LF_U2D | 0 | 右から左（上から下）方向へ改行
JV_LF_D2U | 1 | 左から右（下から上）方向へ改行
JV_LF_NULL | 2 | 改行なし（シングルライン）

kinsoku には次の値を設定します。

定数 | 値 | 内容
JV_KINSOKU_OFF | 0 | 禁則処理を行わない
JV_KINSOKU_ON | 1 | 禁則処理を行う

wordlap には次の値を設定します。

定数 | 値 | 内容
JV_WORDLAP_OFF | 0 | 英文ワードラップを行わない
JV_WORDLAP_ON | 1 | 英文ワードラップを行う

[解説]

描画に使用するフォントは、jvSetFont で設定します。
UNICOCDEやサロゲートペアの文字列を描画する場合は、jvDrawTextW を使います。

charPitch と linePitch は、使用しない場合には 0 を設定します。
text には外字を使用することができます。

－外字の描画

「JV_ERR_FONTEMBED_CODE(-125)」は、Adobe PDF形式のデータを作成している時のエラーです。このエラーは、jvSetString でフォントを埋め込むように設定した場合に発生します。「JV_ERR_FONTEMBED_CODE(-125)」エラーは、帳票を描画中、埋め込むことができない文字コードが見つかった時に発生します。エラーの原因となった文字コードは、エラー発生直後に、jvGetLongで取得することができます。

－Adobe PDF形式のデータにフォントを埋め込む

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid,"納品書","")
ret = jvDrawText(jid, 1000, 1000, 5000, 1000, 0, 0, JV_TEXT_EVEN
, JV_ANGLE0, JV_LF_U2D, JV_KINSOKU_OFF
, JV_WORDLAP_OFF, "JIVEREPORT")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawTextW

jvDrawTextW（UNICODE用文字描画）

UNICODEやサロゲートペアの文字列を描画します。

[構文]

Function jvDrawTextW(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal ex As Long , ByVal ey As Long, ByVal charPitch As Long, ByVal linePitch As Long, ByVal format As Long, ByVal angle As Long, ByVal lineFeed As Long, ByVal kinsoku As Long, ByVal wordlap As Long, ByVal text As String) As Long

C言語
int jvDrawTextW(int jid, int sx, int sy, int ex, int ey, int charPitch, int linePitch, int format, int angle, int lineFeed, int kinsoku, int wordlap, wchar_t *text);

JAVA
int jvDrawTextW(int jid, int sx, int sy, int ex, int ey, int charPitch, int linePitch, int format, int angle, int lineFeed, int kinsoku, int wordlap, String text);

Delphi
Function jvDrawTextW(jid, sx, sy, ex, ey, charPitch, linePitch, format, angle: Longint; lineFeed, kinsoku, wordlap: Longint; text: PWideChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | 先頭文字の左上X座標（1/100mm単位）
sy | 先頭文字の左上Y座標（1/100mm単位）
ex | 文字編集領域の右下X座標（1/100mm単位）
ey | 文字編集領域の右下Y座標（1/100mm単位）
charPitch | 文字と文字の間のピッチ（ポイント単位）
linePitch | 行と行の間のピッチ（ポイント単位）
format | 文字編集（設定値参照）
angle | 文字列の描画方向（設定値参照）
lineFeed | 改行方向（設定値参照）
kinsoku | 禁則処理（設定値参照）
wordlap | 英文ワードラップ（設定値参照）
text | 描画文字列

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_FONTEMBED_CODE | -125 | Adobe PDF形式のデータにフォントを埋め込めない文字コードがある

[設定値]

format には次の値を設定します。

定数 | 値 | 内容
JV_TEXT_LEFT | 0 | 左寄せ
JV_TEXT_RIGHT | 1 | 右寄せ
JV_TEXT_CENTER | 2 | 中央揃え
JV_TEXT_EVEN | 3 | 均等割付

angle には次の値を設定します。

定数 | 値 | 内容
JV_ANGLE0 | 0 | 左から右方向へ描画
JV_ANGLE90 | 1 | 下から上方向へ描画
JV_ANGLE180 | 2 | 右から左方向へ描画
JV_ANGLE270 | 3 | 上から下方向へ描画

lineFeed には次の値を設定します。

定数 | 値 | 内容
JV_LF_U2D | 0 | 右から左（上から下）方向へ改行
JV_LF_D2U | 1 | 左から右（下から上）方向へ改行
JV_LF_NULL | 2 | 改行なし（シングルライン）

kinsoku には次の値を設定します。

定数 | 値 | 内容
JV_KINSOKU_OFF | 0 | 禁則処理を行わない
JV_KINSOKU_ON | 1 | 禁則処理を行う

wordlap には次の値を設定します。

定数 | 値 | 内容
JV_WORDLAP_OFF | 0 | 英文ワードラップを行わない
JV_WORDLAP_ON | 1 | 英文ワードラップを行う

[解説]

UNICODEやサロゲートペアの文字を使わない場合は、jvDrawTextを使います。描画するフォントはjvSetFontで設定します。

charPitch と linePitch は、使用しない場合には 0 を設定します。
text には外字を使用することができます。

－外字の描画
－UNICODEの使用
－ サロゲートペア

「JV_ERR_FONTEMBED_CODE(-125)」は、Adobe PDF形式のデータを作成している時のエラーです。jvSetString でフォントを埋め込むように設定した場合に発生します。「JV_ERR_FONTEMBED_CODE(-125)」エラーは、帳票を描画中、埋め込むことができない文字コードが見つかった時に発生します。エラーの原因となった文字コードは、エラー発生直後に、jvGetLongで取得することができます。

－Adobe PDF形式のデータにフォントを埋め込む

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid,"納品書","")
ret = jvDrawTextW(jid, 1000, 1000, 5000, 1000, 0, 0, JV_TEXT_EVEN
, JV_ANGLE0, JV_LF_U2D, JV_KINSOKU_OFF
, JV_WORDLAP_OFF, "JIVEREPORT")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)


jvDrawBarcodeEx

jvDrawBarcodeEx（バーコード描画）

バーコードを描画します。JAVAの場合にはjvDrawBarcodeを使います。

[構文]

Function jvDrawBarcodeEx(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal barHeight As Long, ByVal barSize As String, ByVal charGap As Long, ByVal codeType As Long, ByVal checkDigit As Long, ByVal angle As Long, ByVal barcode As String, ByVal buflen As Long, ByVal retCode As String) As Long

C言語
int jvDrawBarcodeEx(int jid, int sx, int sy, int barHeight, int barSize, int charGap, int codeType, int checkDigit, int angle, char *barcode, int buflen, char *retCode);

Delphi
Function jvDrawBarcodeEx(jid, sx, sy, barHeight: Longint; barSize: PAnsiChar; charGap, codeType, checkDigit, angle: Longint; barcode: PAnsiChar; buflen: Longint; retCode: PAnsiChar): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | バーコードの左上X座標（1/100mm単位）
sy | バーコードの左上Y座標（1/100mm単位）
barHeight | バーの高さ（1/100mm単位）
barSize | 設定する値はバーコードの種類によって異なります。（下記参照）
charGap | キャラクタ間ギャップ(1/100mm単位)
codeType | バーコードの種類（設定値参照）
checkDigit | チェックディジットの有無（設定値参照）
angle | 描画方向（設定値参照）
barcode | バーコードのコード
buflen | retCodeのバッファサイズ
retCode | 実際に描画したコードを返すバッファ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_BAR_CODE | -65 | 不正なコードがある
JV_ERR_BAR_LENGTH | -66 | コード長が不正

[設定値]

barsize には、次の値を指定します。データ間はカンマで区切ります。

カスタマーバーコードの場合
「ロングバーの長さ、タイミングバーの長さ、バーの幅、スペースの幅」をこの順番で設定します。未設定の場合は、デフォルト値で描画されます。

QRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードの場合
ここをクリックしてbarsize設定値を参照し値を指定してください。未設定の場合は、エラーになります。

上記以外のバーコード
「バー幅1,バー幅2,バー幅3,バー幅4,スペース幅1,スペース幅2,スペース幅3,スペース幅4」を細い方から順番に設定します。未設定の場合は、デフォルト値で描画されます。

codetype には次の値を設定します。

定数 | 値 | 内容
JV_BAR_JAN13 | 1 | JAN標準形
JV_BAR_JAN8 | 2 | JAN短縮形
JV_BAR_CODE39 | 3 | CODE39
JV_BAR_NW7 | 4 | NW7
JV_BAR_ITF | 5 | ITF
JV_BAR_CODE128 | 7 | CODE128
JV_BAR_CST | 8 | カスタマバーコード
JV_BAR_UPC | 9 | UPC
JV_BAR_QRCODE | 11 | QRコード
JV_BAR_MICROQR | 12 | マイクロQRコード
JV_BAR_PDF417 | 13 | PDF417コード
JV_BAR_MICROPDF417 | 14 | マイクロPDF417コード

checkdigit には次の値を設定します。

定数 | 値 | 内容
JV_CHECK_OFF | 0 | チェックディジットをつけない
JV_CHECK_ON | 1 | チェックディジットをつける

angle には次の値を設定します。

定数 | 値 | 内容
JV_ANGL_0 | 0 | 左→右
JV_ANGL_90 | 1 | 上→下
JV_ANGL_180 | 2 | 右→左
JV_ANGL_270 | 3 | 下→上

[解説]

barHeight はカスタマバーコードでは無視されます。
charGap はcode39とNW7の場合のみ有効です。
checkDigit はCODE39、CODE128、NW7の場合のみ有効です。
barcode はバーコードの種類によって使用できるキャラクタに制限があります。
buflen にはretCodeで確保したバッファのサイズを指定します。
retCode はコール前に必要な領域を確保しておきます。描画コードの後ろにNULL文字がセットされるため、バッファは1バイト余分に確保してください。バーコードの種類がQRコード、マイクロQRコード、PDF417コード、マイクロQRコードの場合にはretCode に何も返りません。

各バーコードの詳細は、以下を参照してください。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マクロQRコード
－PDF417コード
－マイクロPDF417コード

[コーディング例]

Dim jid&, ret&
Dim retCode$
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")

retCode$ = space(14)
ret = jvDrawBarcodeEx(jid, 1000, 1000, 3000, "", 0, JV_BAR_JAN13
, 0, JV_ANGLE0, "491234567890", 14, retCode)
retCode$ = space(100)
ret = jvDrawBarcodeEx(jid, 1000, 3000, 0, "360,120,60,60", 0, JV_BAR_CST
, 0, JV_ANGLE0, "460-0011名古屋市中区大須１－２５－２８", 100, retCode)

barsize = CStr(JV_QR_LEVEL_M) & "," & CStr(JV_QR_TYPE_AUTO) & "," & CStr(JV_QR_MASKNO_AUTO)
ret = jvDrawBarcodeEx(jid, 1000, 3000, 1000, barsize, 0, JV_BAR_QR , 0, 0, "QRコード", 0, retCode)

|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawBarcode

jvDrawBarcode（バーコード描画）

これは、旧バージョンの関数です。
旧バージョンとの互換性のため、及び、JAVAで開発するユーザーのために残されています。
JAVA以外で開発する場合には、jvSetDrawBarcodeExを使ってください。

[構文]

Function jvDrawBarcode(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long, ByVal barHeight As Long, ByVal barSize As String, ByVal charGap As Long, ByVal codeType As Long, ByVal checkDigit As Long, ByVal angle As Long, ByVal barcode As String, ByVal retCode As String) As Long

C言語
int jvDrawBarcode(int jid, int sx, int sy, int barHeight, int barSize, int charGap, int codeType, int checkDigit, int angle, char *barcode, char *retCode);

JAVA
int jvDrawBarcode(int jid, int sx, int sy, int barHeight, int barSize, int charGap, int codeType, int checkDigit, int angle, String barcode, StringBuffer retCode);

Delphi
Function jvDrawBarcode(jid, sx, sy, barHeight: Longint; barSize: PAnsiChar; charGap, codeType, checkDigit, angle: Longint; barcode, retCode: PAnsiChar): Longint;

設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | バーコードの左上X座標（1/100mm単位）
sy | バーコードの左上Y座標（1/100mm単位）
barHeight | バーの高さ（1/100mm単位）
barSize | 設定する値はバーコードの種類によって異なります。（下記参照）
charGap | キャラクタ間ギャップ(1/100mm単位)
codeType | バーコードの種類（設定値参照）
checkDigit | チェックディジットの有無（設定値参照）
angle | 描画方向（設定値参照）
barcode | バーコードのコード
retCode | 実際に描画したコードを返すバッファ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_BAR_CODE | -65 | 不正なコードがある
JV_ERR_BAR_LENGTH | -66 | コード長が不正

[設定値]

barsize には、次の値を指定します。データ間はカンマで区切ります。

カスタマーバーコードの場合
「ロングバーの長さ、タイミングバーの長さ、バーの幅、スペースの幅」をこの順番で設定します。未設定の場合は、デフォルト値で描画されます。

QRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードの場合
ここをクリックしてbarsize設定値を参照し値を指定してください。未設定の場合は、エラーになります。

上記以外のバーコード
「バー幅1,バー幅2,バー幅3,バー幅4,スペース幅1,スペース幅2,スペース幅3,スペース幅4」を細い方から順番に設定します。未設定の場合は、デフォルト値で描画されます。

codetype には次の値を設定します。

定数 | 値 | 内容
JV_BAR_JAN13 | 1 | JAN標準形
JV_BAR_JAN8 | 2 | JAN短縮形
JV_BAR_CODE39 | 3 | CODE39
JV_BAR_NW7 | 4 | NW7
JV_BAR_ITF | 5 | ITF
JV_BAR_CODE128 | 7 | CODE128
JV_BAR_CST | 8 | カスタマバーコード
JV_BAR_UPC | 9 | UPC
JV_BAR_QRCODE | 11 | QRコード
JV_BAR_MICROQR | 12 | マイクロQRコード
JV_BAR_PDF417 | 13 | PDF417コード
JV_BAR_MICROPDF417 | 14 | マイクロPDF417コード

checkdigit には次の値を設定します。

定数 | 値 | 内容
JV_CHECK_OFF | 0 | チェックディジットをつけない
JV_CHECK_ON | 1 | チェックディジットをつける

angle には次の値を設定します。

定数 | 値 | 内容
JV_ANGL_0 | 0 | 左→右
JV_ANGL_90 | 1 | 上→下
JV_ANGL_180 | 2 | 右→左
JV_ANGL_270 | 3 | 下→上

[解説]

barHeight はカスタマバーコードでは無視されます。
charGap はcode39とNW7の場合のみ有効です。
checkDigit はCODE39、CODE128、NW7の場合のみ有効です。
barcode はバーコードの種類によって使用できるキャラクタに制限があります。

retCode はコール前に必要な領域を確保しておきます。描画コードの後ろにNULL文字がセットされるため、バッファは1バイト余分に確保してください。バーコードの種類がQRコード、マイクロQRコード、PDF417コード、マイクロQRコードの場合にはretCode に何も返りません。

各バーコードの詳細は、以下を参照してください。

－JAN標準形・短縮形
－CODE39
－NW7
－ITF
－CODE128（EAN128）
－UPC
－カスタマーバーコード（郵便）
－QRコード
－マクロQRコード
－PDF417コード
－マイクロPDF417コード

[コーディング例]

Dim jid&, ret&
Dim retCode$
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")

retCode$ = space(14)
ret = jvDrawBarcode(jid, 1000, 1000, 3000, "", 0, JV_BAR_JAN13
, 0, JV_ANGLE0, "491234567890", retCode)
retCode$ = space(100)
ret = jvDrawBarcode(jid, 1000, 3000, 0, "360,120,60,60", 0, JV_BAR_CST
, 0, JV_ANGLE0, "460-0011名古屋市中区大須１－２５－２８", retCode)

barsize = CStr(JV_QR_LEVEL_M) & "," & CStr(JV_QR_TYPE_AUTO) & "," & CStr(JV_QR_MASKNO_AUTO)
ret = jvDrawBarcode(jid, 1000, 3000, 1000, barsize, 0, JV_BAR_QR , 0, 0, "QRコード", retCode)

|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawImage

jvDrawImage（イメージファイル描画）

BMP、DIB、JPEG、TIFF、PNG、EMF形式のイメージファイルを描画します。

[構文]

Function jvDrawImage(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long , ByVal ex As Long , ByVal ey As Long, ByVal dpi As Long, ByVal backMode As Long, ByVal image As String) As Long

C言語
int jvDrawImage(int jid, int sx, int sy, int ex, int ey, int dpi, int backMode, char *image);

JAVA
int jvDrawImage(int jid, int sx, int sy, int ex, int ey, int dpi, int backMode, String image);

Delphi
Function jvDrawImage(jid, sx, sy, ex, ey, dpi, backMode: Longint; image: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | イメージ描画領域の左上X座標（1/100mm単位）
sy | イメージ描画領域の左上Y座標（1/100mm単位）
ex | イメージ描画領域の右下X座標（1/100mm単位）
ey | イメージ描画領域の右下Y座標（1/100mm単位）
dpi | 解像度（0～10000）
backMode | 他のｵﾌﾞｼﾞｪｸﾄと重なった時の透過モード（設定値参照）
image | イメージファイル（フルパス）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_OPEN_FILE | -42 | ファイルオープンエラー
JV_ERR_READ_FILE | -43 | ファイルリードエラー
JJV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_DRAW_BITMAP | -64 | イメージ描画エラー

[設定値]

backMode には次の値を設定します。

定数 | 値 | 内容
JV_OPAQUE | 2 | 上書き
JV_TRANSPARENT | 1 | 透過

[解説]

dpi に０が設定された場合、イメージはsx , sy ～ ex , ey の領域で描画されます。
jvSetStringでイメージ検索パスを設定することができます。

jvDrawImage は、イメージファイルを描画する時に使います。
メモリ上に読み込まれたイメージデータを描画する場合は、jvDrawImageDataを使います。

－対応イメージ形式

[コーディング例]

Dim jid&, ret&
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
ret = jvDrawImage(jid, 1000, 1000, 5000, 1000, 0, JV_OPAQUE
, "c:\temp\image.bmp")
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvDrawImageData

jvDrawImageData（イメージデータ描画）

BMP、DIB、JPEG、TIFF、PNG、EMF形式のイメージデータを描画します。

[構文]

Function jvDrawImageData(ByVal jid As Long, ByVal sx As Long, ByVal sy As Long , ByVal ex As Long , ByVal ey As Long, ByVal dpi As Long, ByVal backMode As Long, ByVal imageLength As Long, ByRef imageData As Byte) As Long

C言語
int jvDrawImageData(int jid, int sx, int sy, int ex, int ey, int dpi, int backMode, int imageLength , char *imageData);

JAVA
int jvDrawImageData(int jid, int sx, int sy, int ex, int ey, int dpi, int backMode, int imageLength , byte[] imageData);

Delphi
Function jvDrawImageData(jid, sx, sy, ex, ey, dpi, backMode, imageLength : Longint; imageData: array of Byte): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
sx | イメージ描画領域の左上X座標（1/100mm単位）
sy | イメージ描画領域の左上Y座標（1/100mm単位）
ex | イメージ描画領域の右下X座標（1/100mm単位）
ey | イメージ描画領域の右下Y座標（1/100mm単位）
dpi | 解像度（0～10000）
backMode | 他のｵﾌﾞｼﾞｪｸﾄと重なった時の透過モード（設定値参照）
imageLength | イメージデータの長さ(バイト数)
imageData | イメージデータ

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JJV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_DRAW_BITMAP | -64 | イメージ描画エラー

[設定値]

backMode には次の値を設定します。

定数 | 値 | 内容
JV_OPAQUE | 2 | 上書き
JV_TRANSPARENT | 1 | 透過

[解説]

dpi に０が設定された場合、イメージはsx , sy ～ ex , ey の領域で描画されます。
jvSetStringでイメージ検索パスを設定することができます。

jvDrawImageData は、メモリ上に読み込まれたイメージデータを描画する時に使います。
イメージファイルを描画する場合は、jvDrawImageを使います。

－対応イメージ形式

※ヘルプの「アプリケーション開発／イメージをデータ形式で設定」に言語ごとのコーディングサンプルがあります。

64ビットのレポートライブラリDLLの場合、jvDrawImageData はVisualBasic2005・VisualBasic2008では使用できません。

[コーディング例]

Dim fileNo As Integer
Dim imageLength As Long
Dim imageData() As Byte
Dim imageFileName As String

imageFileName = "c:\images\cup.dib"
fileNo = FreeFile 'ファイル番号取得
Open imageFileName For Binary As #fileNo 'ファイルオープン
imageLength = FileLen(imgFileName)
ReDim imageData(imageLength) As Byte
Get #fileNo, , imageData
Close #fileNo
ret = jvDrawImageData(pid, sx, sy, ex, ey, imgDpi, backmode, imageLength, imageData(0))


jvDrawGraph

jvDrawGraph（グラフ描画）

グラフを描画します。

[構文]

Function jvDrawGraph(ByVal jid As Long, ByVal graphType As Long, ByVal sx As Long, ByVal sy As Long, ByVal width As Long, ByVal height As Long, ByVal data As String, ByVal fontInfo As String, ByVal numInfo As String, ByVal info1 As String , ByVal info2 As String) As Long

C言語
int jvDrawGraph(int jid, int graphType, int sx, int sy, int width, int height, char *data, char *fontInfo, char *numInfo, char *info1, char *info2);

JAVA
int jvDrawGraph(int jid, int graphType, int sx, int sy, int width, int height, String data, String fontInfo, String numInfo, String info1, String info2);

Delphi
Function jvDrawGraph(jid, graphType, sx, sy, width, height: Longint; data, fontInfo, numInfo, info1, info2: PAnsiChar): Longint;
設定項目 | 内容
jid | jvCreateで取得したジョブID
graphType | グラフの種類（設定値参照）
sx | 描画する左上X座標（1/100mm単位）
sy | 描画する左上Y座標（1/100mm単位）
width | 描画する領域の幅（1/100mm単位）
height | 描画する領域の高さ（1/100mm単位）
data | グラフデータ
fontInfo | 文字描画に使用するフォント情報
numInfo | 数値軸情報
info1 | データ系列情報または散布図X軸情報
info2 | 項目情報または散布図情報

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_DRAW_GRAPH | -67 | グラフ描画エラー
JV_ERR_FONTEMBED_FILE | -124 | Adobe PDF形式データに埋め込めないフォントがある
JV_ERR_FONTEMBED_CODE | -125 | Adobe PDF形式データにフォントを埋め込めない文字コードがある

[設定値]

graphType には次の値を設定します。

定数 | 値 | 内容
JV_GRAPH_COL | 1 | ２Ｄ横棒グラフ
JV_GRAPH_BAR | 2 | ２Ｄ縦棒グラフ
JV_GRAPH_PIE | 3 | 円グラフ
JV_GRAPH_RADAR | 4 | レーダーグラフ
JV_GRAPH_AREA | 5 | 面グラフ
JV_GRAPH_SCATTER | 6 | 散布図グラフ
JV_GRAPH_LINE | 7 | 折れ線グラフ

色には次の値を設定します。

定数 | 値 | 内容
JV_COLOR_BLACK | 0 | 黒
JV_COLOR_WHITE | 16777215 | 白
JV_COLOR_RED | 255 | 赤
JV_COLOR_GREEN | 65280 | 緑
JV_COLOR_BLUE | 16711680 | 青
JV_COLOR_LIGHTGRAY | 12632256 | 明るい灰色
JV_COLOR_GRAY | 8421504 | 灰色
JV_COLOR_DARKGRAY | 4210752 | 濃い灰色

ポイント種には次の値を設定します。

定数 | 値 | 内容
JV_POINT_NONE | 0 | なし
JV_POINT_BOX | 1 | 四角形
JV_POINT_CIRCLE | 2 | 円
JV_POINT_TRIANGLE1 | 3 | 三角形
JV_POINT_TRIANGLE2 | 4 | 逆三角形
JV_POINT_LOZENGE | 5 | ひし形

塗り潰しパターンには次の値を設定します。

定数 | 値 | 内容
JV_FILL_NULL | 0 | 塗り潰しなし
JV_FILL_SOLID | 1 | 前景色で塗り潰し（初期値）
JV_FILL_DKGRAY | 2 | 濃い灰色
JV_FILL_GRAY | 3 | 灰色
JV_FILL_LTGRAY | 4 | 薄い灰色
JV_FILL_WHITE | 5 | 白
JV_FILL_FDIAGONAL | 6 | 45度右上がりハッチ
JV_FILL_BDIAGONAL | 7 | 45度右下がりハッチ
JV_FILL_HORIZONTAL | 8 | 水平ハッチ
JV_FILL_VERTICAL | 9 | 垂直ハッチ
JV_FILL_CROSS | 10 | 水平と垂直のクロスハッチ
JV_FILL_DIAGCROSS | 11 | 45度のクロスハッチ
JV_FILL_BLACK | 12 | 黒

線種には次の値を設定します。

定数 | 値 | 内容
JV_PS_SOLID | 0 | 実線 （初期値）
JV_PS_DASH | 1 | 破線
JV_PS_DOT | 2 | 点線
JV_PS_DASHDOT | 3 | 一点鎖線
JV_PS_DASHDOTDOT | 4 | 二点鎖線

[解説]

グラフは、レポートエディタでグラフフィールドや固定グラフを描画することもできます。

「JV_ERR_FONTEMBED_FILE(-124)」と「JV_ERR_FONTEMBED_CODE(-125)」は、Adobe PDF形式データを作成している時のエラーです。これらのエラーは、jvSetString でフォントを埋め込む設定をした場合に発生します。「JV_ERR_FONTEMBED_FILE(-124)」エラーは、描画に使われている全てのフォントを埋め込む設定をした場合、埋め込むことができないフォントが見つかった時に発生します。エラーの原因となったフォント名は、、エラー発生直後に、jvGetString で取得することができます。「JV_ERR_FONTEMBED_CODE(-125)」エラーは、埋め込むことができない文字コードが見つかった時に発生します。エラーの原因となった文字コードは、エラー発生直後に、jvGetLongで取得することができます。

－Adobe PDF形式データへフォントを埋め込む

data には、整数のグラフデータをデータ間をカンマで区切って設定します。グラフデータに小数を設定しても切り捨てられて整数となります。散布図では、データの倍率と組み合わせて小数を表現することができます。

fontInfo にはフォント情報を「数値軸のフォント名、数値軸のフォントサイズ、info1 のフォント名、info1 のフォントサイズ、info2 のフォント名、info2 のフォントサイズ」の順に、カンマ区切りで設定します。フォントサイズの単位はポイントです。

numInfo には数値軸情報を「最小値、最大値、増分、目盛色、単位、凡例」の順に、カンマ区切りで設定します。最小値と最大値は数値軸の最小値と最大値になります。増分は数値軸の最小値から最大値までの目盛のスキップ分になります。目盛色は目盛を描画する文字の色でRGB値で設定します。単位は最大値の上に表示される文字列です。凡例には、表示（1）、非表示（0）を設定します。

info1 は、散布図以外の場合はデータ系列情報として扱われ、散布図の場合はX軸情報として扱われます。

データ系列情報
データ系列情報をデータ間をカンマで区切ってセットします。
データは、「系列名称、前景色、背景色、名称色、塗り潰しパターン、線種、ポイント種」の順番でデータ系列の数分先頭から繰り返してセットします。
系列名称はデータ系列の名称として表示されます。
前景色と背景色はグラフデータを描画する図形の色でRGB値でセットします。
名称色は系列名称を描画する色でRGB値でセットします。
塗り潰しパターンはグラフデータを描画する図形の塗り潰しパターンになります。
線種はグラフデータを描画する図形の線の種類になります。
ポイント種は折れ線グラフのポイント地点を示す図形の種類になります。

散布図X軸情報
X軸情報をデータ間をカンマで区切ってセットします。
データは、「最小値、最大値、増分、目盛色、単位」の順番でセットします。
最小値と最大値はX軸の最小値と最大値になります。
増分は数値軸の最小値から最大値までの目盛のスキップ分になります。目盛色は目盛を描画する文字の色でRGB値でセットします。
単位は最大値の横に表示される文字列です。

info2 は、散布図以外の場合は項目情報として扱われ、散布図の場合は散布図情報として扱われます。

項目情報
項目情報は必要な場合のみセットします。
項目情報がセットされない場合は、系列情報が軸となり、項目情報がセットされると系列情報は凡例として表示され、項目情報が軸となります。
項目情報をデータ間をカンマで区切ってセットします。
データは、「項目名称、名称色」の順番で項目の数分繰り返してセットします。
項目名称は項目の名称として表示されます。
名称色は項目名称を描画する色でRGB値でセットします。

散布図情報
散布図情報は必要な場合のみセットします。
散布図情報はデータ間をカンマで区切ってセットします。
データは、「ポイント種、ポイント色、データの倍率」の順番でセットします。
ポイント種はデータのポイントを表わす図形の形になります。
ポイント色はポイント種を描画する色でRGB値でセットします。
データの倍率は、グラフデータの倍率をセットします。10がセットされている場合、グラフデータは1/10倍され、100がセットされている場合、グラフデータは1/100倍されます。データの倍率は、グラフデータ（dataパラメータ）に小数データを設定したい場合に使用します。（整数の場合には１をセットしておきます。）グラフデータには整数しか設定できません。そこで、例えば1.58という値をセットしたい時、グラフデータには158をセットし、データの倍率に100をセットします。こうしておくと、内部では158を1/100倍してグラフを描画します。

[コーディング例]

//散布図以外の場合
Dim jid&, ret&
Dim graph&
Dim numI$, fontI$, i1$,i2$,data$
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\売上実績.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "売上実績", "")
graph = JV_GRAPH_COL
numI = "0, 100, 10, JV_COLOR_BLUE, mm, 1"
fontI = "ＭＳ 明朝,10,ＭＳ 明朝,10,ＭＳ 明朝,10"
i1 = "名古屋,,,,,,,東京,,,,,,,大阪,,,,,,,"
i2 = "1996,1997,1998"
data = "20,12,33,24,14,35,28,16,37"
名古屋のデータは20,24,28
東京のデータは12,14,16
大阪のデータは33,35,37
1996のデータは20,12,33
1997のデータは24,14,35
1998のデータは28,16,37
ret = jvDrawGraph(jid,graph,0,0,3000,4000,data,fontI,numI,i1,i2)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)
//散布図の場合
Dim jid&, ret&
Dim graph&
Dim numI$, fontI$, i1$,i2$,data$
jid = jvCreate(JV_PRINTER, form1.hWnd, Printer.hDC, 0)
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1, "", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
graph = JV_GRAPH_SCATTER
numI = "0,100,10,JV_COLOR_BLUE,mm, 1"
fontI = "ＭＳ 明朝,10,ＭＳ 明朝,10,ＭＳ 明朝,10"
i1 = "0,200,20,mm"
i2 = "JV_POINT_CIRCLE,JV_COLOR_BLACK,100"
data = "20,12,33,24,14,35,28,16,37,27"
ret = jvDrawGraph(jid,graph,0,0,3000,4000,data,fontI,numI,i1,i2)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)


jvGetJobStatus

jvGetJobStatus（印刷ジョブの状態取得）

プリンタの印刷ジョブの状態を取得します。

[構文]

Function jvGetJobStatus(ByVal printerName As String, ByVal printJobId As Long) As Long

C言語
int jvGetJobStatus(char *printerName, int printJobId);

JAVA
int jvGetJobStatus(String printerName, int printJobId);

Delphi
Function jvGetJobStatus(printerName:PAnsiChar; printJobId:Longint): Longint;
設定項目 | 内容
printerName | j状態を取得するプリンタ名称
printJobId | 印刷ジョブＩＤ

リターンコード

定数 | 値 | 内容
JV_JOBSTATUS_PAUSED | 1 | 一時停止
JV_JOBSTATUS_ERROR | 2 | エラー
JV_JOBSTATUS_DELETING | 4 | 削除中
JV_JOBSTATUS_SPOOLING | 8 | スプール中
JV_JOBSTATUS_PRINTING | 16 | 印刷中
JV_JOBSTATUS_OFFLINE | 32 | オフライン
JV_JOBSTATUS_PAPEROUT | 64 | 紙切れ
JV_JOBSTATUS_PRINTED | 128 | 印刷済み
 | 0以上 | ジョブの状態（上記の値の組合わせ）
JV_ERR_PRINTERNAME | -10 | プリンタ名称エラー
JV_ERR_GET_JOB | -92 | GetJobエラー

[解説]

印刷中のプリンタのプリンタ名称は、jvGetStringで取得することができます。使用できるプリンタの一覧はjvGetPrinterNameで取得することができます。
印刷中の印刷ジョブＩＤはjvStartDoc実行後にjvGetLongで取得することができます。

[コーディング例]

Dim jid&, ret&, PrintJobId&, PrinterName$
jid = jvCreate(JV_PRINTER, form1.hWnd, 0, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1,"", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
'印刷ジョブＩＤの取得
PrintJobId = jvGetLong(jid, JV_JOB_ID)
'プリンタ名の取得
PrinterName = Space(33)
ret = jvGetString(jid, JV_PRINTER_NAME,PrinterName)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)
'印刷ジョブの状態取得
ret = jvGetJobStatus(PrinterName, PrintJobId)
jobStatus = ""
If (ret And JV_JOBSTATUS_PAUSED) <> 0 Then
jobStatus = jobStatus + "一時停止 "
End If
If (ret And JV_JOBSTATUS_ERROR) <> 0 Then
jobStatus = jobStatus + "エラー "
End If
：
：
：


jvGetJobInfo

jvGetJobInfo（指定した印刷ジョブの全情報取得）

指定した印刷ジョブの全情報を取得します。

[構文]

Function jvGetJobInfo(ByVal printerName As String, ByVal printJobId As Long, ByVal bufLen As Long, ByVal info As String) As Long

C言語
int jvGetJobInfo(char *printerName, int printJobId, int bufLen, char *info);

JAVA
int jvGetJobInfo(String printerName, int printJobId, int bufLen, StringBuffer info);

Delphi
Function jvGetJobInfo(printerName: PAnsiChar; printJobId, bufLen: Longint; info: PAnsiChar): Longint;
設定項目 | 内容
printerName | プリンタ名称
printJobId | 印刷ジョブID
bufLen | 情報取得バッファの長さ（バイト単位）
info | 情報取得バッファ

リターンコード

定数 | 値 | 内容
 | 1以上 | 情報取得に必要なバッファのサイズ
 | 0 | 正常終了
JV_ERR_PRINTERNAME | -10 | プリンタ名称エラー
JJV_ERR_GET_JOB | -92 | GetJobエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[解説]

情報が正常に取得できた時は、リターンコードに0が返ります。バッファサイズの不足により情報が取得できない時は、リターンコードに必要なサイズが返ります。リターンコードが1以上の場合は、リターンコード分のバッファを確保し、もう一度コールしてください。
全情報の内容と並び順は次の通りです。項目間はカンマで区切られます。

１．プリンタ名
２．マシン名
３．ユーザー名
４．印刷ジョブ名（DocNameプロパティで指定した名称）
５．印刷ジョブを記録するために使われるデータの種類
６．印刷ジョブの状態（文字列）
７．印刷ジョブの状態（フラグ）
８．ジョブの優先順位
９．印刷キュー内のジョブの位置
10．文書のページ数
11．すでに印刷されたページ数
12．この文書がスプールされた時間（hh:mm:ss YY/MM/DD)

「7．印刷ジョブの状態」は、次の値のうち、該当する値の合計値となります。

定数 | 値 | 内容
JV_JOBSTATUS_PAUSED | 1 | 一時停止
JV_JOBSTATUS_ERROR | 2 | エラー
JV_JOBSTATUS_DELETING | 4 | 削除中
JV_JOBSTATUS_SPOOLING | 8 | スプール中
JV_JOBSTATUS_PRINTING | 16 | 印刷中
JV_JOBSTATUS_OFFLINE | 32 | オフライン
JV_JOBSTATUS_PAPEROUT | 64 | 紙切れ
JV_JOBSTATUS_PRINTED | 128 | 印刷済み

印刷中のプリンタ名称は、jvGetStringで取得することができます。使用できるプリンタの一覧はjvGetPrinterNameで取得することができます。
印刷中の印刷ジョブＩＤはjvStartDoc実行直後にjvGetLongで取得することができます。
bufLen に0を指定すると、必要なバッファサイズを取得します。 JAVAでは、この値は無視されます。

[コーディング例]

Dim jid&, ret&, bufLen&, PrintJobId&, PrinterName$
jid = jvCreate(JV_PRINTER, form1.hWnd, 0, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1,"", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
'印刷ジョブＩＤの取得
PrintJobId = jvGetLong(jid, JV_JOB_ID)
'プリンタ名の取得
PrinterName = Space(33)
ret = jvGetString(jid, JV_PRINTER_NAME,PrinterName)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)
'情報の取得に必要なﾊﾞｯﾌｧｻｲｽﾞを取得する
bufLen = jvGetJobInfo(PrinterName, PrintJobId, 0, jobInfo)
If bufLen > 0 Then
'取得用ﾊﾞｯﾌｧを確保し、再度実行する
jobInfo = Space(bufLen)
'ジョブのすべての情報を取得する
ret=jvGetJobInfo(PrinterName,PrintJobId,bufLen,jobInfo)
If ret <> 0 Then
MsgBox "jvGetJobInfo Error " + CStr(ret)
Else
JobStatus.Caption = jobInfo
End If
Else
MsgBox "jvGetJobInfo Error " + CStr(ret)
End If
：
：
：


jvGetAllJobInfo

jvGetAllJobInfo（全印刷ジョブの全情報取得）

指定したプリンタのすべてのジョブの全情報を取得します。

[構文]

Function jvGetAllJobInfo(ByVal printerName As String , ByVal bufLen As Long, ByVal info As String ) As Long

C言語
int jvGetAllJobInfo(char *printerName, int bufLen, char *info);

JAVA
int jvGetAllJobInfo(String printerName, int bufLen, StringBuffer info);

Delphi
Function jvGetAllJobInfo(printerName: PAnsiChar; bufLen: Longint; info: PAnsiChar): Longint;
設定項目 | 内容
printerName | プリンタ名称
bufLen | 情報取得バッファの長さ（バイト単位）
info | 情報取得バッファ

リターンコード

定数 | 値 | 内容
 | 1以上 | 情報取得に必要なバッファのサイズ
 | 0 | 正常終了
JV_ERR_PRINTERNAME | -10 | プリンタ名称エラー
JV_ERR_OPEN_PRINTER | -91 | OpenPrinterエラー
JJV_ERR_GET_JOB | -92 | GetJobエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[解説]

情報が正常に取得できた時は、リターンコードに0が返ります。バッファの不足により情報が取得できない時は、リターンコードに、必要なサイズが返ります。リターンコードが1以上の場合は、リターンコード分のバッファを確保し、もう一度コールしてください。
全情報の内容と並び順は次の通りです。項目間はカンマで区切られます。複数のジョブがある場合、ジョブとジョブの間には改行コード（CR+LF）が入ります。

１．印刷ジョブＩＤ
２．プリンタ名
３．マシン名
４．ユーザー名
５．印刷ジョブ名（DocNameプロパティで指定した名称）
６．印刷ジョブを記録するために使われるデータの種類
７．印刷ジョブの状態（文字列）
８．印刷ジョブの状態（フラグ）
９．ジョブの優先順位
10．印刷キュー内のジョブの位置
11．文書のページ数
12．すでに印刷されたページ数
13．この文書がスプールされた時間（hh:mm:ss YY/MM/DD)

「８．印刷ジョブの状態」は、次の値のうち、該当する値の合計値となります。

定数 | 値 | 内容
JV_JOBSTATUS_PAUSED | 1 | 一時停止
JV_JOBSTATUS_ERROR | 2 | エラー
JV_JOBSTATUS_DELETING | 4 | 削除中
JV_JOBSTATUS_SPOOLING | 8 | スプール中
JV_JOBSTATUS_PRINTING | 16 | 印刷中
JV_JOBSTATUS_OFFLINE | 32 | オフライン
JV_JOBSTATUS_PAPEROUT | 64 | 紙切れ
JV_JOBSTATUS_PRINTED | 128 | 印刷済み

印刷中のプリンタ名称は、jvGetStringで取得することができます。使用できるプリンタの一覧はjvGetPrinterNameで取得することができます。
bufLen に0を指定すると、必要なバッファサイズを取得します。 Javaでは、この値は無視されます。

[コーディング例]

Dim jid&, ret&, bufLen&, PrinterName$
jid = jvCreate(JV_PRINTER, form1.hWnd, 0, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1,"", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
'プリンタ名の取得
PrinterName = Space(33)
ret = jvGetString(jid, JV_PRINTER_NAME,PrinterName)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)
'情報の取得に必要なﾊﾞｯﾌｧｻｲｽﾞを取得する
bufLen = jvGetAllJobInfo(PrinterName, 0, jobInfo)
If bufLen > 0 Then
'取得用ﾊﾞｯﾌｧを確保し、再度実行する
jobInfo = Space(bufLen)
'全ジョブのすべての情報を取得する
ret=jvGetAllJobInfo(PrinterName,bufLen,jobInfo)
If ret <> 0 Then
MsgBox "jvGetAllJobInfo Error " + CStr(ret)
Else
JobStatus.Caption = jobInfo
End If
Else
MsgBox "jvGetAllJobInfo Error " + CStr(ret)
End If
：
：
：


jvSetJobStatus

jvSetJobStatus（印刷ジョブの状態設定）

プリンタの印刷ジョブの状態を設定します。

[構文]

Function jvSetJobStatus(ByVal printerName As String, ByVal printJobId As Long, ByVal Status As Long) As Long

C言語
int jvSetJobStatus(char *printerName, int printJobId, int Status);

JAVA
int jvSetJobStatus(String printerName, int printJobId, int Status);

Delphi
Function jvSetJobStatus(printerName:PAnsiChar; printJobId, Status:Longint): Longint;
設定項目 | 内容
printerName | プリンタ名称
printJobId | 印刷ジョブID
Status | 印刷ジョブの状態（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PRINTERNAME | -10 | プリンタ名称エラー
JV_ERR_OPEN_PRINTER | -91 | OpenPrinterエラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_SET_JOB | -93 | SetJobエラー

[設定値]

Status には次の値を設定します。

定数 | 値 | 内容
JV_JOBCONTROL_PAUSE | 1 | 印刷ジョブを一時停止
JV_JOBCONTROL_RESUME | 2 | 一時停止している印刷ジョブを再開
JV_JOBCONTROL_CANCEL | 3 | 印刷ジョブを削除
JV_JOBCONTROL_RESTART | 4 | 印刷ジョブを再開始

[解説]

印刷中のプリンタ名称は、jvGetStringで取得することができます。使用できるプリンタの一覧はjvGetPrinterNameで取得することができます。
印刷中の印刷ジョブＩＤはjvStartDoc実行直後にjvGetLongで取得することができます。

[コーディング例]

Dim jid&, ret&, Status&, PrinterName$
jid = jvCreate(JV_PRINTER, form1.hWnd, 0, 0, 0, 0, "")
ret = jvSetForm(jid, "c:\JiveReport\納品書.jfm", 1,"", 100, 0, 0)
ret = jvStartDoc(jid, "納品書", "")
'印刷ジョブＩＤの取得
PrintJobId = jvGetLong(jid, JV_JOB_ID)
'プリンタ名の取得
PrinterName = Space(33)
ret = jvGetString(jid, JV_PRINTER_NAME,PrinterName)
|
ret = jvEndPage(jid)
ret = jvEndDoc(jid)
ret = jvClose(jid)
：
：
：
'印刷ジョブの取消し
Status = JV_JOBCONTROL_CANCEL
ret = jvSetJobStatus(PrinterName, PrintJobId,Status)
：
：
：


JNIライブラリでのアプリケーション開発

アプリケーション開発

レポートライブラリJNIとは

レポートライブラリJNI(Javaネイティブメソッドインターフェースライブラリ)は、Javaアプリケーションを開発する時に使う帳票印刷用ライブラリです。

使用可能な開発環境

Javaアプリケーションは、Java Servlet、JSP(JavaServer Pages)、Java Strutsなどで開発します。
レポートライブラリJNIは、Windows環境で使用可能です。

ファンクションの使い方

レポートライブラリJNIは、レポートライブラリDLLとほぼ同じ機能を持っています。
解説には、レポートライブラリJNIとレポートライブラリDLLの両方を利用してください。

ファンクションの使い方などは、サンプルプログラムを参照してください。

jvCreateとｊｖCloseの2つのファンクションは、レポートライブラリDLLと違う部分があるため、注意が必要です。

プレビュー方法

１．Adobe PDF形式の場合
Adobe Readerを使います。

２．RDF形式の場合
RDFビューア（JvPreview10X.exe）を使います。
RDFビューアはRDFファイルをプレビューするツールで、インストールディレクトリにインストールされています。
アプリケーションからRDFビューアを操作するためのファンクションが用意されています。

－jvSetPrvString
－jvSetPrvLong
－jvSendPrvCommand
－RDFファイルを作成するコーディング方法

Javaアプリケーションのコンパイル

Javaアプリケーションをコンパイルする時は、srcディレクトリの下にjvrという名前のディレクトリを作成し、その下に、レポートライブラリJNI用Javaクラスファイル(jvalib.java)を入れておきます。
レポートライブラリJNI用Javaクラスファイルの名称を変更することはできません。

配布

レポートライブラリJNIを使ってアプリケーションを開発後、完成したアプリケーションを別の環境で実行する時には、実行環境に次のファイルを配布します。

１．レポートライブラリJNI
WindowsのシステムディレクトリにあるレポートライブラリJNIを実行環境のWindowsのシステムディレクトリにコピーします。

２．Javaクラスファイル
コンパイル時にJavaソースファイルから作成されたJavaクラスファイル(jvalib.class)は、クラスファイル用ディレクトリの下にjvrというディレクトリを作成し、その下にコピーします。

３．RDFビューアとプレビューコントロール
Windowsアプリケーションでは、RDFビューアとプレビューコントロールを実行環境にコピーします。
プレビューコントロールは、Windowsのシステムディレクトリへコピーし、レジストリ登録します。

配布の前に使用許諾契約書をお読みください。


JNIライブラリの概要

レポートライブラリJNIの詳細情報

レポートライブラリJNIの詳細情報

ファイル名 | jvalib102.dll
インストール先 | Windows￥システムディレクトリ
内容 | JNIライブラリの本体

Javaクラスファイルを作成するためのJavaソースファイル

ファイル名 | jvalib.java
パッケージ名 | jvr
クラス名 | Jvalib
インストール先 | インストールディレクトリ￥Include
内容 | レポートライブラリJNIを呼び出すためのJavaソースファイル


旧バージョンからの移行Java

旧バージョンからの移行（JNI）

旧バージョンのレポートライブラリJNIを使ったプログラムを最新のレポートライブラリJNIに置き換える場合は、移行作業が必要です。

相違点

◆ファイル名が変わりました。（Ver.7～Ver.10.1から移行する場合）

◆プロポーショナルフォントの文字の描画位置が変わりました。（Ver.1～Ver.10.0から移行する場合）

◆文字回転機能を使って文字を回転させた時の描画位置が変わりました。（Ver.1～Ver.10.0から移行する場合）

◆余白（マージン）とスケールの考え方が変わりました。 （Ver.7～Ver.9.1から移行する場合）

◆外字の描画方法が変わりました。（Ver.7～Ver.9.04から移行する場合）

◆jvCreateの定数定義名が変わりました。（Ver.7～Ver.8から移行する場合）
  旧）JV_RDFMEM　→　新）JV_RDFSVC

※定義値は同じです。古い定義名は、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しい定義名へ変更することをお薦めします。

◆jvGetLongの定義名が変わりました。（Ver.7～Ver.8から移行する場合）
  旧）JV_PDF_SIZE　→　新）JV_DOCMENT_SIZE

※定義値は同じです。古い定義名は、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しい定義名へ変更することをお薦めします。

◆Adobe PDFデータをメモリ上で取得するファンクションが変わりました。（Ver.7～Ver.8から移行する場合）
  旧）jvGetData　→　新）jvGetDocument

※古いファンクションは、旧バージョンとの互換のため残っていますが、今後サポートの対象外となる可能性があります。新しいファンクションへ変更することをお薦めします。

◆RDFビューアの動作が変わりました。（Ver.7～Ver.8の場合）
  旧）jvSetPrevLongでページを変更すると自動的に該当ページが表示されました。
  新）jvSetPrevLongでページを変更した時には、jvSendPrvCommandでページを表示する必要があります。

◆プロフェッショナル(X64)（Ver8.3～Ver9.08から移行する場合）
プロフェッショナル(X64)Ver8.3～Ver9.08でハンドルやデバイスコンテキストに関する問題が見つかりました。
この問題はインストールディレクトリの「ProX64アップデート方法.htm 」に詳しく記述されています。ご参照ください。

移行作業

◆ファイル名の変更
レポートライブラリJNIのファイルが変更されました。
新しい名前はJvalib102.javaです。
ジャイブレポートのインストールディレクトリの下のIncludeディレクトリにx64用とx86用が入っています。ご利用下さい。

◆プロポーショナルフォントの文字位置・回転文字の描画位置の確認（Ver.3～Ver.10.0から移行する場合）

プロポーショナルフォントや文字回転を使っている場合には、文字を描画する位置の確認が必要です。
旧バージョンの文字位置で描画する場合には、「文字列の描画をバージョン10.0以前の仕様で行う」をチェックします。

◆余白（マージン）の考え方が変わりました。

旧バージョンのフォームを使用する場合には、余白値の見直しが必要です。
－旧バージョンの余白（マージン）設定と変更

◆外字の描画方法が変わりました。

Ver.7を使って外字を描画している場合は、Ver.8以降では外字の描画方法が変わったため、外字が正しく描画されるかどうかのチェックが必要です。
また、Ver.7～Ver.9.04までのレポートライブラリでは、外字フォントを使って外字を描画していましたが、Ver.9.05でジャイブレポート外字ファイルを使って外字を描画する方法が追加されました。外字が正しく描画されない場合は、ジャイブレポート外字ファイルを使うことができます。
Webアプリケーションから外字を描画している場合、IIS7以降の環境では、外字フォントで外字を描画することができません。ジャイブレポート外字ファイルを使用する方法への変更が必要です。
－外字の描画

◆RDFビューアでページを指定した後に表示するコードを追加します。

ret = Jvalib.jvSetPrvLong(Jvalib.JV_PREVIEW_PAGE,3);　// ページ番号を指定
ret = Jvalib.jvSendPrvCommand(Jvalib.JV_PREVIEW_SHOW);　 // 再描画


コーディング上の注意

パッケージのインポート

レポートライブラリJNIを使うアプリケーションの先頭で、以下のようにコーディングし、パッケージをインポートします。
import jvr.*;

ライブラリの初期化

レポートライブラリJNIのファンクションをコールする前に、ライブラリの初期化を行います。
Jvalib.init();

コーディング

基本的なコーディング方法はＣ言語とほぼ同じです。

(1)基本的なコーディング

// ライブラリの初期化
Jvalib.init();

//初期処理　　注意：hwnd、prnhdc、winhdcにはNULLをセットします。
pid = Jvalib.jvCreate(Jvalib.JV_RDFMEM, 0, 0, 0, iFormWidth, iFormHeight, "");

//文書開始
ret = Jvalib.jvStartDoc(pid, "火災保険契約書", "");

//フィールドの設定
ret = Jvalib.jvSetFieldText(pid, "住所", “名古屋市中区”);
・
・
// フォーム描画
ret = Jvalib.jvDrawForm(pid, Jvalib.JV_FORM_FIELD);

//改ページ
ret = Jvalib.jvEndPage(pid);
//文書終了
ret = Jvalib.jvEndDoc(pid);
//終了処理
iRdfID = Jvalib.jvClose(pid);

(2)文字型パラメータには、以下の型を使用してください。

・文字列を渡すだけのパラメータ：String型

・文字列を受け取るパラメータ　：StringBuffer型

StringBuffer型の場合、バッファ長は０バイトで構いません。
また、バッファ長を指定するパラメータは無視されるため、０を指定して下さい。

例）
//指定した印刷ジョブの全情報取得
StringBuffer sJobInfo =new StringBuffer(0);
ret =Jvalib.jvGetJobInfo(sbpname.toString(),iPrintJobId,0,sJobInfo);


帳票をAdobe PDF形式でメモリ上に作成

//ライブラリの初期化
Jvalib.init();

//初期処理
pid = Jvalib.jvCreate(Jvalib.JV_PDF, 0, 0, 0, iFormWidth, iFormHeight, "");

//フォームファイルを指定
ret = Jvalib.jvSetForm(pid, sFormFile, 1, "", 100, 0, 0);

//文書開始
ret = Jvalib.jvStartDoc(pid, "火災保険契約書", "");

//フィールドデータセット
ret = Jvalib.jvSetFieldText(pid, "住所", “名古屋市中区”);
・
・
// フォーム描画
ret = Jvalib.jvDrawForm(pid, Jvalib.JV_FORM_FIELD);

//改ページ
ret = Jvalib.jvEndPage(pid);

//文書終了
ret = Jvalib.jvEndDoc(pid);

//PDFデータの長さを取得とデータ取得用バッファの確保
iPdfLen = Jvalib.jvGetLong(pid,Jvalib.JV_PDF_SIZE);
byte baPdfData[] = new byte[iPdfLen];

//PDFデータ取得
Jvalib.jvGetDocument(pid,iPdfLen,baPdfData);

//終了処理
Jvalib.jvClose(pid);

//PDFデータの出力
//ContentType設定
response.setContentType("application/pdf");
sLength = Integer.toString(iPdfLen);
response.addHeader("content-length", sLength);
response.addHeader("content-disposition", "inline; filename=JIVE.PDF");

//バイナリ形式でPDFデータを出力
ServletOutputStream baos = response.getOutputStream();
baos.write(baPdfData,0,iPdfLen);
baos.flush();

※Java Servletのサンプルです。
※弊社ホームページでは、Webサンプルのプログラムを参照することができます。
http://www.jive-comp.co.jp 　Webサンプルページ
※インストールディレクトリにもサンプルが入っています。


jvCreate(JNI)

jvCreate（初期処理-JNI）

レポートライブラリJNIの初期処理を行います。

[構文]

X86対応版

Int jvCreate(int outdev, int hwnd, int prnhdc, int winhdc, int width, int height, String filename);

X64対応版

Int jvCreate(int outdev, long hwnd, long prnhdc, long winhdc, int width, int height, String filename);

設定項目 | 内容
outdev | 出力先デバイス（設定値参照）
hwnd | 0を設定
prnhdc | プリンタデバイスコンテキスト
winhdc | 0を設定
width | 帳票の幅（1/100mm単位）
height | 帳票の高さ（1/100mm単位）
filename | 出力ファイル名

リターンコード

定数 | 値 | 内容
JV_ERR_JVCREATE以外 |  | 正常終了
JV_ERR_JVCREATE | -1 | オープンエラー

[設定値]

outdev には次の値を設定します。

定数 | 値 | 内容
JV_PRINTER | 2 | プリンタへ出力
JV_BMP | 3 | BMP形式で出力
JV_RDF | 5 | RDF形式で出力
JV_PDF | 9 | Adobe PDF形式で出力
JV_JPEG | 10 | JPEG形式で出力
JV_TIFF | 11 | TIFF形式で出力
JV_PNG | 12 | PNG形式で出力
JV_XPS | 13 | XPS形式で出力

[解説]

jvCreateのリターン値は、ジョブIDとして他のファンクションのパラメータとなります。
jvCreateをコールした場合は、最後に必ずjvCloseをコールしてください。jvCreateとjvCloseは対になるようにコーディングします。
エラーが発生した時は、jvGetOpenErrorを使って詳しいエラー内容を取得することができます。

出力先デバイス
outdev には帳票の出力先を設定します。「JV_PRINTER」を指定すると、帳票は直接プリンタへ出力されます。「JV_RDF」を指定すると、帳票はRDF形式で出力されます。RDF形式の帳票は、プレビューコントロールでプレビューや印刷を行います。「JV_PDF」を指定すると、帳票はAdobe PDF形式で出力されます。Adobe PDF形式の帳票は、Adobe Readerでプレビューします。「JV_XPS」を指定すると、帳票はXPS形式で出力されます。XPS形式の帳票は、XPSビューアでプレビューします。「JV_TIFF」「JV_BMP」「JV_PNG」「JV_JPEG」を指定すると、帳票はTIFF形式、BMP形式、PNG形式、JPEG形式で出力されます。これらの形式は、各々の形式に対応したイメージツールで表示します。帳票を取得する場合には、jvGetDocument と jvGetLong を使います。

ウィンドウハンドル／ウィンドウデバイスコンテキスト
hwnd とwinhdc は、常に0を指定します。

プリンタデバイスコンテキスト
prnhdc には印刷するプリンタのデバイスコンテキスト（Printer.hDC）を設定します。プリンタデバイスコンテキストが取得できない言語環境では ０ を設定することができます。０ を設定すると、レポートライブラリがprnhdc にデフォルトプリンタ（通常使うプリンタに指定されたプリンタ）のデバイスコンテキストを設定します。
レポートライブラリは、実行時に、プリンタドライバから様々な情報を取得し帳票を作成します。prnhdc で指定したプリンタは、情報を取得するプリンタとしても使われるため、フォーム作成時と同じプリンタにすると、フォーム作成時と同じ状態で印刷やプレビューを行うことができます。フォーム作成時と異なるプリンタにした場合は、線の太さや文字の印字位置などが変わることがあります。
次の場合、こprnhdc の値は無効となります。
(1) jvSetDevMode ファンクションでプリンタを設定した場合
(2) jvPrintDialogEx ファンクションで印刷ダイアログを表示した場合
(3) 帳票をRDF形式で作成した場合。プリンタドライバからの情報取得は、作成時ではなく、プレビューコントロールによるプレビュー時に行われます。

帳票の幅と高さ
outdev が「JV_RDF」「JV_BMP」「JV_JPEG」「JV_TIFF」「JV_PNG」「JV_XPS」で、且つ、帳票の幅と高さをフォームの幅と高さ以外の値にする場合に設定します。何も指定しないと、帳票はフォームの幅と高さで作成されます。

出力ファイル名
帳票をファイルに保存する場合には、filename に保存するファイル名を指定します。 outdev が「JV_RDF」「JV_PDF」「JV_BMP」「JV_JPEG」「JV_TIFF」「JV_PNG」「JV_XPS」の場合に有効です。

－基 本的なコーディング
－Acobe PDF形式で帳票を作成する
－Adobe PDF形式の制限


jvClose(JNI)

jvClose（終了処理－JNI）

レポートライブラリJNIの終了処理を行います。

[構文]

int jvClose(int jid);

設定項目 | 内容
jid | jvCreateで取得したジョブID

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_JOBID | -3 | ジョブIDエラー
 | 上記以外 | RDFサービスデータID

[解説]

jvCloseはjvCreateで確保した資源を解放します。jvCreateをコールした場合は、最後に必ずjvCloseをコールしてください。jvCreateとjvCloseは対になるようにコーディングします。
RDFファイルやAdobe PDFファイルを作成する場合は、jvCloseをコールするとファイルが作成されます。

※戻り値のRDFサービスデータIDは、古いバージョンとの互換性のために残された機能です。このバージョンでは利用しないようにしてください。


jvGetDocument(JNI)

jvGetDocument（各種ﾄﾞｷｭﾒﾝﾄﾃﾞｰﾀ取得-JNI）

帳票データを取得します。レポートライブラリDLLのjvGetDocumentとはパラメータが異なるので注意が必要です。

[構文]

int jvGetDocument(int jid, int length, byte[] docData );

設定項目 | 内容
jid | jvCreateで取得したジョブID
length | バッファの長さ
docData | データを取得するバッファ

リターンコード

定数 | 値 | 内容
 | 0以上 | 取得した文字列の長さ
JV_ERR_JOBID | -3 | ジョブ識別番号エラー
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_MEMORY | -4 | メモリ関連エラー

[設定値]

docData には値を設定できません。

[解説]

jvGetDocument は、作成された帳票のデータを取得する時に使います。

取得できるデータの種類は、jvCreateの出力先デバイスによって異なります。(下表参照）

出力先デバイス | 取得データ
JV_RDF | RDF形式のデータ
JV_PDF | Adobe PDF形式のデータ
JV_BMP | BMP形式のデータ
JV_JPEG | JPEG形式のデータ
JV_TIFF | TIFF形式のデータ
JV_PNG | PNG形式のデータ
JV_XPS | XPS形式のデータ

docData には、帳票データが入ります。jvGetDocument をコールする前に、docData にデータを格納することができる領域を確保しておく必要があります。必要なサイズは、jvGetLongを使って取得することができます。

jvGetDocument は、jvEndDoc と jvClose の間でコールします。


jvSetPrvString

jvSetPrvString（RDFビューアに文字列型情報送信）

RDFビューアが動作するための各種文字型情報をRDFビューアに送信します。

[構文]

int jvSetPrvString(int mode, String sParam);
設定項目 | 内容
mode | 情報の種類（設定値参照）
sParam | 設定値

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -3 | パラメータエラー
JV_ERR_PRV_REGIST | -120 | RDFビューアがレジストリに未登録
JV_ERR_PRV_EXEC | -121 | RDFビューアが起動できない
JV_ERR_PRV_SENDCOMMAND | -122 | RDFビューアにコマンドを送信できない

[設定値]

mode には次の値を指定します。

定数 | 値 | 内容
JV_PREVIEW_FILENAME | 11 | 表示するRDFファイル名
JV_PREVIEW_PRINTERNAME | 12 | 印刷するプリンタ名
JV_PREVIEW_PRINTERDEVMODE | 13 | プリンタドライバの設定値
JV_PREVIEW_POSITION | 14 | RDFﾋﾞｭｰｱの位置とｻｲｽﾞ（ﾋﾟｸｾﾙ単位）
JV_PREVIEW_EXENAME | 15 | RDFビューアの実行ファイル名
JV_PREVIEW_FIELDNAME | 16 | フィールドの名前
JV_PREVIEW_FIELDVALUE | 17 | 設定値

[解説]

RDFビューアは、帳票をプレビューするためのツールです。RDFビューアに情報を送る時には、jvSetPrvStringや、jvSetPrvLongを使います。文字型の情報を送る時はjvSetPrvString、数値型の情報を送る時はjvSetPrvLongを使います。

RDFビューアは、プレビューコントロールを使って作成されています。
mode と sParam では、プレビューコントロールのプロパティを設定するものがあります。
プレビューコントロールに関する情報の詳細は、プレビューコントロールのリファレンスで確認してください。

「JV_PREVIEW_FILENAME」は、プレビューコントロールのFileNameプロパティの値を設定します。
「JV_PREVIEW_PRINTERNAME」は、プレビューコントロールのPrinterNameプロパティの値を設定します。
「JV_PREVIEW_PRINTERDEVMODE」は、プレビューコントロールのPrinterDevModeプロパティの値を設定します。
「JV_PREVIEW_FIELDNAME」は、プレビューコントロールのFieldNameプロパティの値を設定します。
「JV_PREVIEW_FIELDVALUE」は、プレビューコントロールのFieldDataプロパティの値を設定します。

RDFビューアの画面の位置とサイズ（JV_PREVIEW_POSITION）
「画面左上のＸ座標、Ｙ座標、画面の幅、画面の高さ」の順に、データ間をカンマで区切って指定します。
例）
画面左上のＸ座標が100、Ｙ座標が150、画面の幅が400、高さが300の場合
100,150,400,300

RDFビューアの実行ファイル名（JV_PREVIEW_EXENAME）
RDFビューア（JvPreview80.exe）の実行ファイル名は、その他の情報より先にフルパスで設定します。
実行ファイル名が設定されなかった場合には、レジストリに登録された内容でRDFビューアが起動します。

ジャイブレポートをインストールしたパソコンでは、レジストリの内容は次の通りとなっています。

［キー名称]
HKEY_CURRENT_USER\Software\VB and VBA Program Settings\JiveReport102
[値の名前]
INSTALLDIR
[値のデータ ]
c:\Program Files\JiveReport102\

ジャイブレポートをインストールしていないパソコンでRDFビューアの実行ファイル名を設定しない場合には、インストーラーなどを利用して、RDFビューアのレジストリ登録が必要です。
レジストリ登録をする時には、［キー名称] と[値の名前]のディレクトリにある[値のデータ]に、RDFビューアをコピーしたディレクトリを登録します。

[コーディング例]

作成した帳票に、後からページ番号を入れるコーディングの例です。

// 設定するページのページ番号を指定します。
ret = Jvalib.jvSetPrvLong(Jvalib.JV_PREVIEW_PAGE,i);

// ページ番号を入れるテキストフィールド名を指定します。
ret = Jvalib.jvSetPrvString(Jvalib.JV_PREVIEW_FIELDNAME,"ページ番号");

// ページ番号の値を指定します。
ret = Jvalib.jvSetPrvString(Jvalib.JV_PREVIEW_FIELDVALUE,String.valueOf(i));


jvSetPrvLong

jvSetPrvLong（RDFビューアに数値型情報送信）

RDFビューアが動作するための各種数値型情報をRDFビューアに送信します。

[構文]

int jvSetPrvLong(int mode, int lvalue);
設定項目 | 内容
mode | 情報の種類（設定値参照）
lvalue | 設定値

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -3 | パラメータエラー
JV_ERR_PRV_REGIST | -120 | RDFビューアがレジストリに未登録
JV_ERR_PRV_EXEC | -121 | RDFビューアが起動できない
JV_ERR_PRV_SENDCOMMAND | -122 | RDFビューアにコマンドを送信できない

[設定値]

mode には次の値を指定します。

定数 | 値 | 内容
JV_PREVIEW_PAGE | 21 | RDFファイルの表示ページ
JV_PREVIEW_COPIES | 22 | 印刷ﾀﾞｲｱﾛｸﾞの印刷部数の初期値
JV_PREVIEW_SCALE | 23 | 画面表示と印刷時の拡大縮小率
JV_PREVIEW_MINPAGE | 24 | 印刷時の印刷開始ページ
JV_PREVIEW_MAXPAGE | 25 | 印刷時の印刷終了ページ
JV_PREVIEW_LEFTMARGIN | 26 | 印刷時の左マージン
JV_PREVIEW_TOPMARGIN | 27 | 印刷時の上マージン
JV_PREVIEW_LAYOUTTYPE | 28 | レイアウトタイプ
JV_PREVIEW_LOCK | 29 | 画面ロック

[解説]

RDFビューアは、帳票をプレビューするためのツールです。RDFビューアに情報を送る時には、jvSetPrvStringや、、jvSetPrvLongを使います。文字型の情報を送る時はjvSetPrvString、数値型の情報を送る時はjvSetPrvLongを使います。

RDFビューアは、プレビューコントロールを使って作成されています。
mode と sParam では、プレビューコントロールのプロパティを設定します。
各情報の詳細は、プレビューコントロールのリファレンスで確認することができます。

「JV_PREVIEW_PAGE」は、プレビューコントロールのPageプロパティの値を設定します。
「JV_PREVIEW_COPIES」は、プレビューコントロールのCopiesプロパティの値を設定します。
「JV_PREVIEW_SCALE」は、プレビューコントロールのScaleプロパティの値を設定します。
「JV_PREVIEW_MINPAGE」は、プレビューコントロールのMinPageプロパティの値を設定します。
「JV_PREVIEW_MAXPAGE」は、プレビューコントロールのMaxPageプロパティの値を設定します。
「JV_PREVIEW_LEFTMARGIN」は、プレビューコントロールのLeftMarginプロパティの値を設定します。
「JV_PREVIEW_TOPMARGIN」は、プレビューコントロールのTopMarginプロパティの値を設定します。
「JV_PREVIEW_LAYOUTTYPE」は、プレビューコントロールのLayoutTypesプロパティの値を設定します。
「JV_PREVIEW_LOCK」は、プレビューコントロールのLockedプロパティの値を設定します。

jvSetPrvLongを使って表示ページを変更した時は、jvSendPrvCommandで再描画が必要です。

[コーディング例]

表示ページを変更して画面を再描画するコーディング例です。

// ページ番号を指定します。
ret = Jvalib.jvSetPrvLong(Jvalib.JV_PREVIEW_PAGE,3);
// 再描画します。
ret = Jvalib.jvSendPrvCommand(Jvalib.JV_PREVIEW_SHOW);

作成した帳票に、後からページ番号を入れるコーディング例です。

// 設定するページのページ番号を指定します。
ret = Jvalib.jvSetPrvLong(Jvalib.JV_PREVIEW_PAGE,i);

// ページ番号を入れるテキストフィールド名を指定します。
ret = Jvalib.jvSetPrvString(Jvalib.JV_PREVIEW_FIELDNAME,"ページ番号");

// ページ番号の値を指定します。
ret = Jvalib.jvSetPrvString(Jvalib.JV_PREVIEW_FIELDVALUE,String.valueOf(i));


jvSendPrvCommand

jvSendPrvCommand（RDFビューアにコマンド送信）

RDFビューアにコマンドを送ります。

[構文]

int jvSendPrvCommand(int command);
設定項目 | 内容
command | コマンド（設定値参照）

リターンコード

定数 | 値 | 内容
 | 0 | 正常終了
JV_ERR_PARAMETER | -3 | パラメータエラー
JV_ERR_PRV_REGIST | -120 | RDFビューアがレジストリに未登録
JV_ERR_PRV_EXEC | -121 | RDFビューアが起動できない
JV_ERR_PRV_SENDCOMMAND | -122 | RDFビューアにコマンドを送信できない

[設定値]

command には次の値を設定します。

定数 | 値 | 内容
JV_PREVIEW_SHOW | 1 | 帳票を表示
JV_PREVIEW_PREVPAGE | 2 | 前のページを表示
JV_PREVIEW_NEXTPAGE | 3 | 次のページを表示
JV_PREVIEW_PRINTOUT | 4 | 表示中の帳票を印刷
JV_PREVIEW_PRINTDIALOG | 5 | 印刷ダイアログを表示
JV_PREVIEW_PAGECOPY | 6 | 表示中の帳票をBMP形式ｸﾘｯﾌﾟﾎﾞｰﾄﾞにｺﾋﾟｰ
JV_PREVIEW_END | 7 | ＲＤＦビューアを終了

[解説]

RDFビューアは、帳票をプレビューするためのツールです。RDFビュアーは、プレビューコントロールを使って作成されています。command では、プレビューコントロールのメソッドを実行します。
各内容の詳細は、プレビューコントロールのリファレンスで確認することができます。

「JV_PREVIEW_SHOW」は、プレビューコントロールのShowメソッドを実行します。
「JV_PREVIEW_PREVPAGE」は、プレビューコントロールのPrevPageメソッドを実行します。
「JV_PREVIEW_NEXTPAGE」は、プレビューコントロールの NextPageメソッドを実行します。
「JV_PREVIEW_PRINTOUT」は、プレビューコントロールの PrintOutメソッドを実行します。
「JV_PREVIEW_PRINTDIALOG」は、プレビューコントロールのPrintDialogメソッドを実行します。
「JV_PREVIEW_PAGECOPY」は、プレビューコントロールのPageCopyメソッドを実行します。

jvSetPrvLongを使って表示ページを変更した時は、「JV_PREVIEW_SHOW」を指定して再描画します。

[コーディング例]

// ページ番号を指定します。
ret = Jvalib.jvSetPrvLong(Jvalib.JV_PREVIEW_PAGE,3);
// 再描画します。
ret = Jvalib.jvSendPrvCommand(Jvalib.JV_PREVIEW_SHOW);


プレビューコントロールの概要

プレビューコントロールとは

１．帳票をプレビューするためのActiveXコントロールです。

前ページ、次ページ、ページジャンプ、印刷などのプレビューに必要な機能を持っています。
プレビューコントロールで使用する帳票は、RDF形式で作成します。RDF形式とは、ジャイブレポート専用のデータフォーマットです。レポートエディタ、またはレポートライブラリを使って作成することができます。

２．イメージ形式の帳票出力機能があります。

プレビューコントロールには、RDF形式で作成された帳票をJPEG、TIFF、XPS、PNG、BMPなどのイメージ形式で出力する機能があります。

３．帳票のフィールドにデータを入力する機能があります。

プレビュー中の帳票のフィールド部分に、画面から直接データを入力し、リアルタイムに帳票を作成することができます。入力データをXML形式でサーバーへ送信したり、ローカルディスクに保存したりする機能もあります。

プレビューコントロールを使ったアプリケーション開発

詳細は、「LAN環境やローカル環境での使い方」を参照してください。

プロフェッショナル(X64)には、2種類のプレビューコントロールが入っています。
プレビューコントロールのx64対応版とx86対応版です。
使用するInternetExplorerに合わせて使い分けてください。


プレビューコントロールの詳細情報

プロフェッショナル(X86)

ファイル名 | Jvrvw103.ocx
クラスID | 2F42CB7F-5233-4671-8EC4-E4B8ADDC3032
コントロールID | Jvrvw103Ctrl
インストール先 | Windowsのシステムディレクトリの下

プロフェッショナル(X64)

ファイル名 | Jvrvw103.ocx
クラスID | 2F42CB7F-5233-4671-8EC4-E4B8ADDC3032
コントロールID | Jvrvw103Ctrl
インストール場所 | Windows\SysWOW64ディレクトリの下 ※x86対応プレビューコントロール
 | Windows\System32ディレクトリの下 ※x64対応プレビューコントロール

※プレビューコントロールのx86版とx64版の各情報は、インストール先を除いて同じです。


旧バージョンからの移行(PREVIEW)

旧バージョンからの移行 （ﾌﾟﾚﾋﾞｭｰｺﾝﾄﾛｰﾙ）

旧バージョンのプレビューコントロールを使ったプログラムを最新のプレビューコントロールに置き換える場合は、移行作業が必要です。

相違点

１．プレビューコントロールの名称が変わりました。（Ver.4.10～Ver.9.1の場合）

２．IDとクラスIDが変わりました。（ASPの場合）
－プレビューコントロールのファイル名、クラスID、コントロールID

３．プレビューコントロールが1種類になりました。（Ver.4.10～Ver.6の場合）

４．余白（マージン）とスケールの考え方が変わりました。（Ver.4.10～Ver.9.1の場合）

５．署名付きプレビューコントロールが廃止となりました。

移行作業

１．コントロールの参照設定変更
(1)プロジェクトファイルを開き、古いプレビューコントロールを削除します。
(2)コンポーネントの参照を新しいプレビューコントロールに変更します。
(3)新しいプレビューコントロールを貼り付けます。

２．コントロールのIDとクラスIDの変更
ASPを利用している場合は、コントロールのIDとクラスIDを変更します。

３．プレビューコントロールの変更（Ver.4.10～Ver.6の場合）
プレビューコントロールが1種類になりました。

４．余白（マージン）の考え方が変わりました。
旧バージョンのフォームを使用する場合には、余白値の見直しが必要です。
－旧バージョンの余白（マージン）設定と変更

５．署名付きプレビューコントロールを使っている場合には、署名のついていないものを使ってください。


LAN環境やローカル環境での使い方

スタンドアロンやLANなどのネットワーク環境でのプレビューコントロールの使い方を解説します。

アプリケーション開発の概要

1．プレビューコントロールで帳票をプレビューするためには、まず、帳票をRDF形式で出力するプログラムを作成します。
メモリ上に作成されたRDF形式の帳票は、そのまま使うこともできますが、ファイルに保存してRDFファイルとして使うこともできます。

－RDFデータ作成（レポートライブラリOCX／レポートライブラリ.NETコントロール）
－RDFファイルの作成（レポートライブラリOCX ／レポートライブラリ.NETコントロール）

－RDFデータ作成（レポートライブラリDLL／レポートライブラリJNI）
－RDFファイルの作成（レポートライブラリDLL）

2．次に、作成したRDF形式の帳票をプレビューコントロールで表示するプログラムを作成します。
プレビューコントロールには印刷機能もあります。

－RDFデータのプレビュー
－RDFファイルのプレビュー

3．アプリケーションが完成したら、実行環境に、開発アプリケーション、レポートライブラリ、プレビューコントロールをインストールします。

環境整備

プレビューコントロールを使ったアプリケーションを別の環境で実行する時は、プレビューコントロールを実行環境に配布します。

1．プレビューコントロールを実行環境のWindowsディレクトリにコピーします。

  1-1．32ビットアプリケーションを開発した場合

    実行環境のOSがx86Editionの場合：　実行環境のc:\Windows\System32ディレクトリ
    実行環境のOSがx64Editionの場合：　実行環境のc:\Windows\SysWOW64ディレクトリ

  1-2．64ビットアプリケーションを開発した場合

    実行環境のc:\Windows\System32ディレクトリ

2．コピーしたプレビューコントロールをレジストリ登録します。
レジストリ登録は、以下のようにコマンドラインから行なうか、あるいはインストールツールを使用します。

Regsvr32.exe Jvrvw10X.ocx
※Regsvr32.exeは、Windowsのシステムディレクトリにあります。

プレビューコントロールは単独で動くため、他のファイルは必要ありません。

開発環境

プレビューコントロールは、ActiveXコントロールを利用できる開発環境で使用可能です。
「インストールディレクトリ￥SampleProgram」にサンプルプログラムがインストールされています。


プレビューコントロールからのデータ入力

プレビューコントロールでのデータ入力

プレビューコントロールのデータ入力機能

プレビューコントロールに表示した帳票上で、フィールド部分に直接データを入力することができます。
プレビューコントロールの入力機能は、Locked プロパティで設定します。

データ入力の種類

1．データ入力テキストボックス
テキストフィールドとグリッドフィールドでデータを入力できます。

2．コンボボックス、リストボックス
テキストフィールドをコンボボックスとリストボックスに変更することができます。
リストボックスでは、複数の選択肢から任意の項目を選択することができます。
コンボボックスでは、選択肢からの選択以外に、コンボボックスに直接データを入力することもできます。

3．セレクトボタン
セレクトボタンを表示するにはセレクトボタンフィールドを使います。
ラジオボタン型とチェックボックス型の2種類があります。

帳票の初期値設定

帳票の各フィールドに表示するデータは、帳票を作成する時に埋め込むこともできますが、帳票を表示する時に、あらかじめ用意しておいたデータを初期値として設定することもできます。
初期値はXML形式で作成します。

(1)XML形式の初期値には、以下の設定や値を含めることができます。

・フィールドの初期値
・テキストフィールドをコンボボックスやリストボックスに変更する設定
・コンボボックスやリストボックスに一覧表示する選択肢
・フィールドの入力可／不可の設定
・フィールドの入力制限（最小値／最大値の設定）
・コンボボックスやリストボックスのリンク先フィールド
※初期値を設定しない時には初期値データは不要です。

(2)プレビューコントロールは、XML形式の初期値をDataFileNameプロパティやXmlDataプロパティで取得します。

－初期値の設定

入力データのディスク保存と保存ファイルの読み込み

表示中の帳票と画面から入力したデータをディスクに保存することができます。
保存ファイルにはパスワードをつけることができます。
ディスクに保存したファイルを読み込むことができます。

－帳票と入力データの保存
－保存データの読み込み

入力データの取得

入力したデータをXML形式で取得することができます。

－入力データを取得する


初期データ(XML形式)の作り方

XML形式の初期値の作り方

プレビューコントロールに帳票を表示する時、帳票上のフィールドに初期値を設定することができます。

初期値を設定できるフィールドは、テキストフィールド、グリッドフィールド、セレクトボタンフィールドの3種類です。テキストフィールドは、初期値の中でコンボボックスやリストボックスに変更することができます。

初期値の内容

初期値は、XML形式で作成します。
初期値には、以下の設定や値を含めることができます。

1．フィールドの初期値
フィールドに初期表示する値です。初期値を設定すると、帳票作成時にフィールドにデータが埋め込まれていても上書きされます。

2．コンボボックスやリストボックスの設定
テキストフィールドをコンボボックスやリストボックスに変更する時に設定します。

3．コンボボックスとリストボックスの選択肢
コンボボックスとリストボックスのドロップダウンリストに一覧表示する項目を設定します。

4．フィールドの入力可／不可の設定
各フィールドごとに、入力可／不可の設定ができます。

5．フィールドの入力制限（最小値／最大値の設定）
数値型フィールド（編集子が数値型のもの）では、入力範囲（最小値と最大値）を設定できます。

6．コンボボックスとリストボックスのリンク先フィールド
コンボボックスとリストボックスは、フィールド（グリッドフィールドの場合はセル）とリンクさせることができます。例えば、コンボボックスで商品Ａを選択すると、金額用フィールドに商品Ａの金額を自動表示するなどの場合に利用します。

初期値にUNICODEを使う

初期値は、Shift-JIS、または、UNICODEで作成することができます。
初期値をUNICODEので作成する場合は、ファイルの先頭が「fffe」で始まるUNICODEファイル仕様で作成します。

初期値のXML仕様

XMLの仕様は、「XML初期値　エレメント解説」を参照してください。

実際の初期値のサンプルがインストールディレクトリに入っています。
解説とあわせて参照してください。
XMLサンプル：インストールディレクトリ￥SampleProgram￥WebInput￥teian.XML

弊社ホームページでは、プレビュー画面でのデータ入力が体験できます。
画面では、入力値で印刷したり、サーバーへ入力値を送信したり、ローカルディスクへ保存したりすることを体験できます。
http://www.jive-comp.co.jp　Webサンプルのページ


XML初期値を渡す

XML初期値の設定

初期値は、XMLファイル、または、変数などのメモリに読み込ませた状態で使うことができます。
初期値をXMLファイルで設定する場合は、プレビューコントロールのDataFileNameプロパティを使います。
初期値をメモリ上にある状態で設定する場合は、XmlDataプロパティを使います。

－変数に入れた初期値を表示する


XMLデータ エレメント解説

XML初期値　エレメント解説

初期値がXML形式で正しく記述されなかった場合は、読み込み時にエラーが発生します。エラーの内容は、プレビューコントロールのXmlErrorプロパティで取得することができます。

1.ページ情報

タグ名 | page
内容 | 1ページ分の情報を記述します。複数ページのデータを記述する時は、1ページ毎にpageタグで囲みます。
省略 | 不可
データ型 | なし
繰り返し | ページ数だけ繰り返します。

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
no | integer | 不可 |  | ページ番号

【例】
2ページある時は、pageタグを2回繰り返します。
<page no=“1“>
<label no=“1” >
<text fieldname=“品名”>
HIDランプ
</text>
<radiobutton fieldname=“新規” enabled = ”1“ value =“1” />
<check fieldname=“住民票” enabled = “1” value =“1” />
</label>
</page>
<page no=“2” >
<label no=“1” >
<text fieldname=“品名”>
ナンバープレートベース
</text>
<radiobutton fieldname=“新規” enabled = “1” value =“0” />
<check fieldname=“住民票” enabled = “1” value =“0” />
</label>
</page>

1.1 ラベル情報

タグ名 | label
内容 | 1ラベル分の情報を記述します。複数のラベルデータを記述する時は、ラベル毎にlabelタグで囲みます。
省略 | 不可
データ型 | なし
繰り返し | ラベル数だけ繰り返します。
説明 | labelタグはラベル印刷、可変フォーム印刷、複数フォーム（1ページの中に複数のフォームが描画されているもの）印刷のために用意されたタグです。 これら3パターンの印刷では、1ページの中に複数のフォーム（可変フォームの場合はセクション）が存在するため、各々のフォーム（可変フォームの場合はセクション）をラベル番号で指定します。 この3パターン以外の場合でもlabelタグは省略できません。その場合は、全体をlabelタグで囲み、noには1を設定します。 【ラベル印刷】 用紙左上をno=1とし、右側へ向かって、no=2、no=3と番号をつけます。最上段の右端まで進んだら、次は2段目の左端から同様に最後のラベルまで繰り返します。 【可変フォーム印刷】 DrawSectionまたはjvDrawSectionで描画したセクションの順に番号をつけます。最初に描画したセクションがno=1、次に描画したセクションがno=2となります。 【複数フォーム印刷】 DrawFormまたはjvDrawFormで描画したフォームの順に番号をつけます。最初に描画したフォームがno=1、次に描画したフォームがno=2となります。

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
no | integer | 不可 |  | ラベル番号

【例】
1ページに2つのラベルやフォームがある場合、labelタグを2回繰り返します。
<page no=“1” >
<label no=“1” >
<text fieldname=“品名”>
HIDランプ
</text>
<radiobutton fieldname=“新規” enabled = “1” value =“1” />
<check fieldname=“住民票” enabled = “1” value =“1” />
</label>
<label no=“2” >
<text fieldname=“品名”>
ナンバープレートベース
</text>
<radiobutton fieldname=“新規” enabled = “1” value =“0” />
<check fieldname=“住民票” enabled = “1” value =“0” />
</label>
</page>

1.1.1テキストフィールド情報

タグ名 | text
内容 | テキストフィールドの出力文字列を記述します。
省略 | 可
データ型 | string
繰り返し | 文字列の行数だけ繰り返します。
説明 | 数値型編集子のテキストフィールドでは、maxvalueとminvalueで入力値を制限することができます。計算式を設定したテキストフィールドには、初期値の設定や入力許可の設定はできません。

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
fieldname | string | 不可 |  | フィールド名
enabled | integer | 可 | 1 | 0:入力不可、1:入力可
maxvalue | integer | 可 |  | 最大値（数値型ﾌｨｰﾙﾄﾞ）
minvalue | integer | 可 |  | 最小値（数値型ﾌｨｰﾙﾄﾞ）

【例】
<text fieldname=“税込金額” enabled=“1” maxvalue=“999999” minvalue=“-999999”>
10000
</text>
<text fieldname=“備考” enabled=“1”>
新規のご契約。
臨時休業のお知らせ。
</text>

1.1.2グリッドフィールド情報

タグ名 | grid
内容 | グリッドフィールドの出力文字列を記述します。
省略 | 可
データ型 | string
繰り返し | 文字列の行数だけ繰り返します。
説明 | 数値型編集子のグリッドフィールドでは、maxvalueとminvalueで入力値を制限することができます。

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
fieldname | string | 不可 |  | フィールド名
col | integer | 不可 |  | 列番号(1～)
row | integer | 不可 |  | 行番号(1～)
enabled | integer | 可 | 1 | 0:入力不可、1:入力可
maxvalue | integer | 可 |  | 最大値（数値型ﾌｨｰﾙﾄﾞ）
minvalue | integer | 可 |  | 最小値（数値型ﾌｨｰﾙﾄﾞ）

【例】
明細フィールドの3列目、4行目の値が4500で、最大値10000、最小値0の場合。
<grid fieldname=“明細”col=“3”row=“1”enabled=“1”maxvalue=“10000”minvalue=“0”>
4500
</grid>

1.1.3リストボックス情報

タグ名 | list
内容 | テキストフィールドをリストボックスにする場合に、リストボックスの選択肢を記述します。計算式を設定したテキストフィールドはリストボックスにできません。
省略 | 可
データ型 | string
繰り返し | リストボックスの選択肢の数だけ繰り返します。
説明 | fieldnameにはテキストフィールド名を記述します。テキストフィールド以外を記述するとエラーとなり、そのタグは読み飛ばされます。refnameを使って、リストボックスと他のフィールドを関連付けることができます。例えば、車体を選択すると車体の金額を自動表示するというように使います。refnameを記述した時は、valueの値の後ろに、関連付ける値をコロン「:」で区切って記述します。

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
fieldname | string | 不可 |  | テキストフィールド名
enabled | integer | 可 | 1 | 0:入力不可、1:入力可
value | string | 可 |  | リストに表示する初期値
refname | string | 可 |  | 関連付けるフィールド名
refrow | integer | 可 |  | 行番号（refnameがｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞ）
refcol | integer | 可 |  | 列番号（refnameがｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞ）

【例】
品名リストでサイドバイザーを選択すると金額テキストフィールドに22000が入る。
<list fieldname=“品名” enabled = “1” refname =“金額”>
サイドバイザー:22000
スプラッシュボード:70000
ナンバープレートベース:3000
</ list >
品名リストでサイドバイザーを選択すると明細グリッドフィールドの2列目、3行目に22000が入る。
<list fieldname=“品名”enabled=“1”refname=“明細” refcol=“2” refrow=“3”>
サイドバイザー:22000
スプラッシュボード:70000
ナンバープレートベース:3000
</ list >

1.1.4コンボボックス情報

タグ名 | combo
内容 | テキストフィールドをコンボボックスにする場合に、コンボボックスの選択肢を記述します。コンボボックスは値を入力することもできます。計算式を設定したテキストフィールドはコンボボックスにできません。
省略 | 可
データ型 | string
繰り返し | コンボボックスの選択肢の数だけ繰り返します。
説明 | fieldnameにはテキストフィールド名を記述します。テキストフィールド以外を記述するとエラーとなり、そのタグは読み飛ばされます。refnameを使って、コンボボックスと他のフィールドを関連付けることができます。例えば、車体を選択すると車体の金額を自動表示するというように使います。refnameを記述した時は、valueの値の後ろに、関連付ける値をコロン「:」で区切って記述します。数値型編集子のテキストフィールドをコンボボックスにした時は、maxvalueとminvalueで入力値を制限することができます。

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
fieldname | string | 不可 |  | テキストフィールド名
enabled | integer | 可 | 1 | 0:入力不可、1:入力可
value | string | 可 |  | リストに表示する初期値
maxvalue | integer | 可 |  | 最大値（数値型ﾌｨｰﾙﾄﾞ）
minvalue | integer | 可 |  | 最小値（数値型ﾌｨｰﾙﾄﾞ）
refname | string | 可 |  | 関連付けるフィールド名
refrow | integer | 可 |  | 行番号（refnameがｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞ）
refcol | integer | 可 |  | 列番号（refnameがｸﾞﾘｯﾄﾞﾌｨｰﾙﾄﾞ）

【例】
品名コンボでサイドバイザーを選択すると金額テキストフィールドに22000が入る。
<combo fieldname=“品名” enabled = “1” refname =“金額”>
サイドバイザー:22000
スプラッシュボード:70000
ナンバープレートベース:3000
</combo>
品名コンボでサイドバイザーを選択すると明細グリッドフィールドの2列目、3行目に22000が入る。
<combo fieldname=“品名”enabled=“1”refname=“明細” refcol=“2” refrow=“3”>
サイドバイザー:22000
スプラッシュボード:70000
ナンバープレートベース:3000
</combo>
入力値の上限、下限のチェックを行なう。
<combo fieldname=“月” minvalue=“4” maxvalue=“6” >
4
5
6
</combo>

1.1.5チェックボックス情報

タグ名 | check
タグの種類 | 空要素
内容 | fieldnameで指定されたチェックボックス型セレクトボタンフィールドのプロパティを記述します。
省略 | 可
データ型 | なし
繰り返し | なし

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
fieldname | string | 不可 |  | セレクトボタンフィールド名
enabled | integer | 可 | 1 | 0:入力不可、1:入力可
value | string | 可 |  | 0:ﾁｪｯｸなし、1:ﾁｪｯｸあり

【例】
住民票チェックボックスをチェックし、印鑑証明チェックボックスを未チェックとする。
<check fieldname=“住民票” enabled = “1” value =“1” />
<check fieldname=“印鑑証明” enabled = “1” value =“0” />

1.1.6ラジオボタン情報

タグ名 | radiobutton
タグの種類 | 空要素
内容 | fieldnameで指定されたラジオボタン型セレクトボタンフィールドのプロパティを記述します。
省略 | 可
データ型 | なし
繰り返し | なし

【属性】
属性名 | ﾃﾞｰﾀ型 | 省略 | 省略時の値 | 説明
fieldname | string | 不可 |  | セレクトボタンフィールド名
enabled | integer | 可 | 1 | 0:入力不可、1:入力可
value | string | 可 |  | 0:ﾁｪｯｸなし、1:ﾁｪｯｸあり

【例】
新規ラジオボタンをチェックし、継続ラジオボタンを未チェックとする。
< radiobutton fieldname=“新規” enabled = “1” value =“1” />
< radiobutton fieldname=“継続” enabled = “1” value =“0” />


入力データをXML形式で取得しサーバーへ送信

入力データを取得する

プレビューコントロールの帳票画面上で入力した値は、XmlDataプロパティを使って、アプリケーション側で取得することができます。
入力値はXML形式で抽出されます。

入力データをXML形式で取得する

XmlDataプロパティには、次の形式で入力値が入っています。

例）
<?xml version = "1.0" encoding = "Shift_JIS"?>
<page no="1">
<label no="1">
<text fieldname="氏名" >
ジャイブ一郎
</text>
<text fieldname="車両本体課税額" enabled="0" >
2600000
</text>
<text fieldname="下取車価格" >
-500000
</text><text fieldname="総合計" enabled="0" >
2253100
</text>
<option fieldname="CLASS_1" value="0" />
<list fieldname="自動車税月" value="" >
</list>
<grid fieldname="税金等" row="1" col="1" >
</grid>
<grid fieldname="税金等" row="2" col="1" >
</grid>
</label>
</page>

XML形式の初期値でenabled属性に「0（入力不可）」を設定したテキストフィールドと、デザイン時に計算式を設定したテキストフィールドには、「enabled="0"」が書き出されます。


フォームからRDFレイアウトファイルを作る

フォームのみのRDFファイルを作る

プレビュー画面で、帳票のフォーマットのみを表示し、画面から直接データを入力して印刷する場合は、帳票のフォーマットのみ入ったRDFファイルを用意します。

可変フォームの場合には、レポートライブラリを使ってRDFファイルを作ります。
固定フォームの場合には、レポートライブラリを使って作ることもできますが、レポートエディタから簡単に作ることができます。

ここでは、レポートエディタを使ってRDFファイルを作る方法を解説します。

１ページの帳票を作成する場合

データを入力するページが1ページしかない場合には、1ページ分のフォームをRDFファイルに入れます。

※ラベルの場合は、ラベル1枚を1ページとして数えます。
  例えば、１枚の用紙に20枚のラベルがある場合は、１枚の用紙で20ページあることになります。

－レポートエディタでRDFファイルを作る

複数ページの帳票を作成する場合

データを入力するページが複数ページに渡る場合には、入力するページ数分のフォームをRDFファイルに入れます。

１．10ページ以下の帳票を作成する場合

1）レポートエディタを起動します。
2）使用するフォームファイル（jfmファイル）を開きます。

3）表示メニューから「帳票印刷モード」を選択します。
  ※フォーム設計モードから作成すると、1ページしか作成されません。

4）ファイルメニューの「RDFファイル作成」を実行し、RDFファイル作成画面を開きます。
  「範囲」の「ページ指定」で、作成するページ数を指定します。
    例　：　5ページ作成する場合は「1ページから5ページ」を指定します。

5）作成ボタンを押すと指定したページ数分のRDFファイルが作成されます。

２．10ページ以上の帳票を作成する場合

2-1．レポートエディタを使う場合

  1）レポートエディタを起動します。
  2）使用するフォームファイル（jfmファイル）を開きます。
  3）表示メニューから「帳票印刷モード」を選択します。
  4）表示メニューから「帳票データ」画面を開きます。

  5）帳票データ画面のオプションメニューから「行の追加」を実行します。
    必要なページ数分の「行の追加」を実行します。
    例　：　15ページ必要な場合は、5行追加します。

  6）ファイルメニューの「RDFファイル作成」を実行し、RDFファイル作成画面を開きます。
    「範囲」の「ページ指定」で、作成するページ数を指定します。
      例　：　15ページ作成する場合は「1ページから15ページ」を指定します。

  7）作成ボタンを押すと指定したページ数分のRDFファイルが作成されます。

2-2．レポートエディタとテキストファイルを使う場合

  30ページのRDFファイルを作成する場合を例として解説します。

  1）メモ帳などのテキストエディタで、改行のみの行を30行作成し保存します。
  2）レポートエディタを起動します。
  3）使用するフォームファイル（jfmファイル）を開きます。
  4）表示メニューから「帳票印刷モード」を選択します。
  5）表示メニューから帳票登録画面を開きます。

  6）帳票登録画面で、以下の設定をします。
    a．データ取得先をテキストファイルにします。
    b．テキストファイル名に１で作成したテキストファイルを指定します。
    c．区切り記号をカンマまたはタブにします。
    d．aからcを設定後、データの取り込みボタンを押します。
    e．終了ボタンで帳票登録ウィンドウを閉じます。

  7）ファイルメニューの「RDFファイル作成」を実行し、RDFファイル作成画面を開きます。
    「範囲」の「ページ指定」で、作成するページ数を指定します。
      例　：　30ページ作成する場合は「1ページから30ページ」を指定します。

  8）作成ボタンを押すと30ページのRDFファイルが作成されます。

  テキストファイルの行数を調整することで、必要なページのRDFファイルを作成することができます。


RDFドキュメントデータプレビュー

RDF形式データのプレビュー

RDF形式の帳票をプレビューするコーディングです。
（レポートライブラリOCXを使った場合）

JvrLib.OutDevice = JV_RDF | 出力先の設定
↓ |
JvrLib.FormName | フォームファイルの設定
↓ |
JvrLib.Start | 初期処理と印刷開始
↓ |
JvrLib.DrawForm | フォームとフィールドを描画
↓ |
JvrLib.NewPage | 改ページ
↓ |
JvrLib.End | 印刷終了と終了処理
↓ |
buf = JvrLib.DocumentData | レポートライブラリで作ったRDF形式データを取得
↓ |
JiveView.DocumentData = buf | RDF形式データをプレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | プレビューコントロールで表示
(JiveView.CtlShow) | NET2003環境の場合

※.NET2003環境では"Show"が予約語のため"CtlShow"を使用します。


基本的な使い方(プレビューコントロール)

RDFファイルのプレビュー

RDFファイルをプレビューするコーディングです。 （レポートライブラリOCXの場合）

JvrLib.OutDevice = JV_RDF | 出力先の設定
↓ |
JvrLib.ＯｕｔFileName = “C:\file.rdf” | RDFファイル名の設定
↓ |
JvrLib.FormName | フォームファイルの設定
↓ |
JvrLib.Start | 初期処理と印刷開始
↓ |
JvrLib.DrawForm | フォームとフィールドを描画
↓ |
JvrLib.NewPage | 改ページ
↓ |
JvrLib.End | 終了処理（RDFファイル完成）
JiveView.FileName = "C:\file.rdf" | プレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示するページを設定
↓ |
JiveView.Show | プレビューコントロールに表示
(JiveView.CtlShow) | （.NET2003の場合）

※.NET2003環境では"Show"が予約語のため"CtlShow"を使用します。


プレビューコントロールからJPEG出力

JPEG形式での帳票出力と取得

プレビューコントロールを使って、RDF形式のデータをJPEG形式でパネルに描画するコーディングです。 （レポートライブラリOCXの場合）

JvrLib.OutDevice = JV_RDF | 出力先をRDF形式にする
↓ |
JvrLib.FormName | フォームファイルの設定
↓ |
JvrLib.Start | 印刷開始
・ |
・ |
JvrLib.DrawForm | 帳票の描画
↓ |
JvrLib.NewPage | 改ページ
↓ |
JvrLib.End | 印刷終了
’RDFデータをプレビューコントロールへ入れる |
Call JiveView.set_DocumentData(Jvrlib.DocumentData) |
↓ |
JiveView.OutDevice = JV_JPEG | 出力形式をJPEGにする
↓ |
JiveView.MinPage = 1 | 出力するページを指定する
’JPEG形式のイメージデータをプレビューコントロールから取り出す |
Dim sDocData() As Byte |
sDocData = JiveView.get_DocumentData |
’イメージデータを画面上のパネルに描画 |
Dim imgconv As New ImageConverter() |
Dim img As Image = CType(imgconv.ConvertFrom(sDocData), Image) |
pictImage.Width = img.Width |
pictImage.Height = img.Height |
pictImage.Image = img |


印刷ダイアログを表示(プレビューコントロール)

印刷ダイアログを表示

印刷時に印刷ダイアログを表示するコーディングです。

JiveView.MinPage = 1 | 印刷ダイアログの開始ページを初期設定
↓ |
JiveView.MaxPage = Object.PageCount | 印刷ダイアログの終了ページを初期設定
↓ |
JiveView.Copies = 3 | 印刷ダイアログの印刷部数を初期設定
↓ |
JiveView.PrintDialog | 印刷ダイアログの表示


印刷時にプリンタドライバを設定(プレビューコントロール)

印刷時にプリンタドライバを設定

印刷時に、自動的にプリンタドライバのプロパティを設定するコーディングです。

JiveView.MinPage = 1 | 印刷開始ページを設定
↓ |
JiveView.MaxPage = Object.PageCount | 印刷終了ページを設定
↓ |
JiveView.Copies = 3 | 印刷部数を設定
↓ |
JiveView.PrinterName = "PC-PR201" | プリンタを設定
↓ |
JiveView.PrinterDevMode = "2,9" | プリンタドライバ情報の設定
↓ |
JiveView.PrintOut | 印刷

－プリンタドライバ情報とは
－ドライバ設定ファイルとは


XML初期データで初期設定を行う(プレビューコントロール)

XML初期値設定を行う（XMLファイル）

帳票を表示する時に、帳票の初期値をXMLファイルで設定するコーディングです。

JiveView.FileName = “納品書.rdf” | RDFファイル名の設定
↓ |
JiveView.DataFileName =“納品データ.XML” | XMLファイル名の設定
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | 表示
JiveView.CtlShow） | NET2003環境の場合

※.NET2003環境では"Show"が予約語のため"CtlShow"を使用します。


XML初期値設定(XMLデータ）

XML初期値設定を行う（XML変数）

帳票を表示する時に、変数などを使って帳票の初期値をメモリ上で設定するコーディングです。

JvrLib.End | 印刷終了
↓ |
JvrLib.DocumentData(jid, buf(0)) | レポートライブラリで作ったRDF形式データ取得
↓ |
JiveView.DocumentData = buf | プレビューコントロールにRDF形式データを渡す
↓ |
JiveView.XmlData = xmlbuf | メモリ上にあるXML初期値をプレビューコントロールに渡す
↓ |
JiveView.Page = 1 | 表示ページの設定
↓ |
JiveView.Show | 表示
JiveView.CtlShow） | NET2003環境の場合

※.NET2003環境では"Show"が予約語のため"CtlShow"を使用します。

Web環境では、XmlDataプロパティを使って初期値を渡すことはできません。


表示中の帳票と入力データの保存(プレビューコントロール)

表示中の帳票と入力データの保存

表示中の帳票と画面から入力したデータを保存するコーディングです。

１．ファイル名を設定して保存する

JiveView.SaveFileName ="c:\tmp\実績.rdf" | 保存ファイル名の設定
↓ |
JiveView.Password="ABC123" | パスワードの設定
↓ |
JiveView.SaveFile | 保存

２．ファイル選択ダイアログを使って保存する

JiveView.ShowFileDialog(0) | ダイアログを保存モードで開く
↓ |
JiveView.Password="ABC123" | パスワードの設定
↓ |
JiveView.SaveFile | 保存

ファイル選択ダイアログで設定したファイル名は、SaveFileNameプロパティに入ります。

－保存したファイルの読み込み


保存したRDFファイルの読込(プレビューコントロール)

プレビューコントロールで保存したRDFファイルの読込

プレビューコントロールで保存したファイルを読み込むコーディングです。

１．ファイル名を設定して読み込む

JiveView.FileName ="c:\tmp\実績.rdf" | 読み込むファイル名を設定
↓ |
JiveView.Password="ABC123" | パスワードの設定
↓ |
JiveView.Page = 1 | 表示するページの設定
↓ |
JiveView.Show | 表示
JiveView.CtlShow | NET2003環境の場合

２．ファイル選択ダイアログを使って読み込む

JiveView.ShowFileDialog(1) | ダイアログを読込モードで開く
↓ |
JiveView.Password="ABC123" | パスワードの設定
↓ |
JiveView.Page = 1 | 表示するページの設定
↓ |
JiveView.Show | 表示
JiveView.CtlShow | NET2003環境の場合

.NET2003環境では"Show"が予約語のため"CtlShow"を使用します。
ファイル選択ダイアログで選択したファイル名は、FileNameプロパティに入ります。
保存時にパスワードを設定した場合は、読み込み時に同じパスワードが必要です。


EmbedFontメソッド（プレビューコントロール）

EmbedFontメソッド

PDF形式の帳票に埋め込むフォントの設定を行います。

[構文]

Object.EmbedFont (fontname)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
fontname | string | フォント名

エラーコード

[解説]

EmbedFontメソッドは、Adobe PDF形式の帳票にフォントを埋め込む時に使います。埋め込むことができるフォントは、True Typeフォントのみです。 EmbedFontメソッドで指定しなかったフォントは、埋め込まれません。描画に使ったすべてのフォントを埋め込む場合は、fontname に * を指定します。

指定したフォントファイルが、実行環境にない場合には、-1042のエラーが発生します。指定したフォントがTrue Typeフォントではない場合にも、-1043のエラーが発生します。エラーの原因となったフォント名は、エラーメッセージで取得することができます。

EmbedFontメソッドは、SaveFileメソッドの前で実行してください。

－Adobe PDF形式の帳票にフォントを埋め込む
－Adobe PDF形式の制限

[コーディング例]

Call Jvrvw.EmbedFont("MS 明朝") | 'MS明朝埋め込み
Call Jvrvw.EmbedFont("*") | '全フォント埋め込み
Call Jvrvw.SaveFile |


NextPageメソッド(プレビューコントロール)

NextPageメソッド

現在表示しているページの次ページを表示します。

[構文]

Object.NextPage

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード


PrevPageメソッド(プレビューコントロール)

PrevPageメソッド

現在表示しているページの前ページを表示します。

[構文]

Object.PrevPage

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード


PageCopyメソッド(プレビューコントロール)

PageCopyメソッド

表示中のページをBMP形式でクリップボードにコピーします。

[構文]

Object.PageCopy

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード

[解説]

PageCopy メソッドを実行後に、BMP形式のイメージに対応したアプリケーションで「貼り付け」を行うと、帳票をコピーすることができます。


PrintDialogメソッド(プレビューコントロール)

PrintDialogメソッド

印刷ダイアログを表示し、印刷を行ないます。

[構文]

Object.PrintDialog
設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード

[解説]

印刷ダイアログを表示し、ユーザーが選択したプリンタやプロパティで印刷を行います。
印刷ダイアログの初期値を設定する時は、MinPageプロパティ（印刷開始ページ）、MaxPageプロパティ（印刷開始ページ）、Copiesプロパティ（印刷部数）を使います。
印刷時に印字開始位置を調整する場合には、印刷ダイアログを表示する前に、LeftMarginプロパティ、TopMarginプロパティでマージンを設定しておきます。
印刷時のドキュメント名は、DocNameプロパティで設定することができます。

帳票を作成する時に、レポートライブラリで用紙サイズ、用紙方向、プリンタ名が設定されていると、設定値で初期設定された印刷ダイアログがポップアップします。これらの情報が設定されている場合、このPrintDialogメソッドでポップアップした印刷ダイアログで、ユーザーが用紙サイズや用紙方向を変更しても有効とならず、レポートライブラリの設定値で印刷が行われます。 但し、プリンタの変更は可能です。
レポートライブラリでこれらの項目を設定する機能は、jvSetDevModeファンクション、SetPrinterプロパティ・ PrinterDevModeプロパティ・PrinterNameプロパティです。

用紙サイズや用紙方向の異なるページが混在する帳票を印刷する時に印刷ダイアログをポップアップする場合には、このPrintOutメソッドを使います。

－基 本的なコーディング

[コーディング例]

JvrVw.LeftMargin = 5 | ‘印字位置の調整
JvrVw.TopMargin = 5 |
JvrVw.DocName = “納品書” | ‘ドキュメント名の設定
JvrVw.MinPage = 1 | ‘印刷開始ページ
JvrVw.MaxPage = 10 | ‘印刷終了ページ
JvrVw.Copies = 2 | ‘印刷部数
JvrVw.PrintDialog | ‘印刷ダイアログの表示


PrintOutメソッド(プレビューコントロール)

PrintOutメソッド

帳票を印刷します。

[構文]

Object.PrintOut
設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード

[解説]

印刷するプリンタを設定する場合は、PrinterNameプロパティを使います。用紙サイズ・用紙方向などのプリンタプロパティを設定する場合は、PrinterDevModeプロパティを使います。

印刷時の各種設定には、MinPageプロパティ（印刷開始ページ）、MaxPageプロパティ（印刷終了ページ）、Copiesプロパティ（印刷部数）、LeftMarginプロパティ（印字位置の横マージン）、TopMarginプロパティ（印字位置の縦マージン）、DocNameプロパティ（文書名）を使います。

帳票を作成する時に、レポートライブラリのjvSetDevModeファンクション、SetPrinterプロパティ・PrinterDevModeプロパティで用紙サイズ、用紙方向が設定されていると、設定値で印刷を行います。用紙サイズや用紙方向が異なるページが混在する帳票をPrintOutメソッドで一括印刷する場合には、帳票作成時に、レポートライブラリのこれらの機能を使って用紙サイズや用紙方向を指定しておく必要があります。

プリンタ名やプリンタドライバ情報が、レポートライブラリとプレビューコントロールで共に設定された場合には、プレビューコントロールの値が優先されます。プリンタ名やプリンタドライバ情報が何も設定されていない場合は、デフォルトプリンタ（通常使うプリンタに指定されたプリンタ）で印刷します。

－基本的なコーディング

[コーディング例]
JvrVw.LeftMargin = 5 | ‘印字位置の調整
JvrVw.TopMargin = 5 |
JvrVw.DocName = “納品書” | ‘ドキュメント名の設定
JvrVw.MinPage = 1 | ‘印刷開始ページ
JvrVw.MaxPage = 10 | ‘印刷終了ページ
JvrVw.Copies = 2 | ‘印刷部数
JvrVw.PrinterName = “EPSON” | ‘プリンタの設定
JvrVw.PrinterDevMode = “1,9” | ‘プリンタドライバ情報の設定
JvrVw.PrintOut | ‘印刷


SaveFileメソッド(プレビューコントロール)

SaveFileメソッド

表示中の帳票をRDF形式、 Adobe PDF形式、TFF形式、XPS形式、JPEG形式、PNG形式、BMP形式でファイルに保存します。

[構文]

Object.SaveFile
設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード

[解説]

作成する形式は、OutDeviceプロパティで設定します。
作成するページの範囲は、MinPageプロパティとMaxPageプロパティで設定します。JPEG形式、PNG形式、BMP形式は複数ページに対応していないため、MinPageプロパティで指定されたページのみ作成します。

SaveFile メソッドを実行する時は、LockedプロパティをFalseにしておきます。
画面上でデータを入力した場合は、入力データも保存されます。

保存するファイル名は、SaveFileNameプロパティで設定します。
ShowFileDialogメソッドでファイル選択ダイアログを表示し、ユーザーにファイル名を設定させることもできます。
ファイルにパスワードをつける場合は、Passwordプロパティを使います。パスワードをつけた場合は、ファイルを開く時にも同じパスワードが必要です。

－基本的なコーディング

[コーディング例]

ファイル名を直接設定する場合
Jvrvw.Password = “xyz” | ‘パスワードの設定
SaveFileName = “c:\tmp\見積書.RDF” | ‘ファイル名の設定
Jvrvw.SaveFile | ‘ファイルの保存
Jvrvw.Show | ‘画面の再描画

ファイル選択ダイアログを表示する場合
Jvrvw.Password = “xyz” | ‘パスワードの設定
Jvrvw.ShowFileDialog(0) | ‘ダイアログの表示
Jvrvw.SaveFile | ‘ファイルの保存
Jvrvw.Show | ‘画面の再描画


Showメソッド(プレビューコントロール)

Showメソッド

RDF形式の帳票をプレビューコントロールに表示します。

[構文]

Object.Show
設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式

エラーコード

[解説]

メモリ上にあるRDFデータを表示する時は、DocumentDataプロパティでデータを取得します。
RDFファイルを表示する時は、FileNameプロパティでファイル名を指定します。

.NET2003環境では、Showの代わりにCtlShowを使います。（Showは予約語のため使用できません。）

－RDFデータを表示する
－RDFファイルを表示する

[コーディング例]

JvrVw.FileName = “納品書.rdf” | ‘RDFファイルの設定
JvrVw.Page = 1 | ‘ページの設定
JvrVw.Show | ‘表示


ShowFileDialogメソッド(プレビューコントロール)

ShowFileDialogメソッド

帳票の保存や帳票の読み込みの時に、ファイル選択ダイアログボックスを表示します。

[構文]

Object.ShowFileDialog(mode)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
mode | long | 保存モードまたは読込モード（設定値参照）

エラーコード

[設定値]

mode には次の値を設定します。

定数 | 値 | 内容
JV_WRITEFILE | 0 | ファイル保存モード
JV_READFILE | 1 | ファイル読込モード

[解説]

表示中の帳票をファイルに保存する時は、「JV_WRITEFILE」を指定します。ファイル選択ダイアログボックスを保存モードで表示すると、ユーザーが指定したファイル名は、 SaveFileNameプロパティに入ります。
保存されているRDFファイルを読み込む時は、「JV_READFILE」を指定します。ファイル選択ダイアログボックスを読み込みモードで表示すると、ユーザーが指定したファイル名は、FileNameプロパティに入ります。

－保存の基本的なコーディング
－読込の基本的なコーディング

[コーディング例]

保存の場合

Jvrvw.Password = “xyz” | ‘パスワードの設定
Jvrvw.ShowFileDialog(0) | ‘ダイアログボックスの表示
Jvrvw.SaveFile | ‘ファイルの保存

読み込みの場合

Jvrvw.Password = “xyz” | ‘パスワードの設定
Jvrvw.ShowFileDialog(1) | ‘ダイアログボックスの表示
Jvrvw.Show | ‘画面に表示


SetParamメソッド（プレビューコントロール）

SetParamメソッド

各種パラメータを設定します。

[構文]

Object.SetParam(mode, param)

設定項目 | 型 | 内容
Object |  | オブジェクトへの参照を表すオブジェクト式
mode | long | 設定する項目
param | string | 設定値

エラーコード

[設定値]

mode には次の値を指定します。

定数

値

内容

JV_PDF_OWNER_PASSWORD

20

Adobe PDF形式データのオーナーパスワード（20バイト以内）

JV_PDF_USER_PASSWORD

21

Adobe PDF形式データのユーザーパスワード （20バイト以内）

JV_PDF_AUTHOR

22

Adobe PDF形式データの作成者（256バイト以内）

JV_PDF_CREATOR

23

Adobe PDF形式データのアプリケーション（256バイト以内）

JV_PDF_TITLE

24

Adobe PDF形式データのタイトル（256バイト以内）

JV_PDF_SUBJECT

25

Adobe PDF形式データのサブタイトル（256バイト以内）

JV_PDF_KEYWORD

26

Adobe PDF形式データのキーワード（256バイト以内）

JV_JPEG_QUALITY

35

JPEG形式データの品質（1～100）

JV_JPEG_PROGRESSIVE

36

JPEG形式データのプログレッシブ（設定値参照）

JV_TIFF_COMPRESSION

37

TIFF形式データの圧縮（設定値参照）

JV_PDF_ENCRIPT_LEVEL

41

Adobe PDF形式データの暗号化レベル（設定値参照）

JV_PDF_ENABLE_PRINT

42

Adobe PDF形式データの文書の印刷（設定値参照）

JV_PDF_ENABLE_EDIT_ALL

43

Adobe PDF形式データの文書の変更 （設定値参照）

JV_PDF_ENABLE_COPY

44

Adobe PDF形式データの内容のコピーと抽出（設定値参照）

JV_PDF_ENABLE_EDIT

45

Adobe PDF形式データの注釈の追加と変更（設定値参照）

JV_PDF_OVERLAY

47

Adobe PDF形式データのオーバーレイ登録

JV_TEMP_PATH_NAME

51

XPS形式データの一時ファイル用ディレクトリ

JV_XPS_DRIVER_NAME

52

XPS形式データのプリンタ名

JPEG形式データのプログレッシブ（JV_JPEG_PROGRESSIVE）のparam には次の値を指定します。

定数 | 値 | 内容
JV_JPEG_PROGRESSIVE_OFF | 0 | プログレッシブを解除 (初期値)
JV_JPEG_PROGRESSIVE_ON | 1 | プログレッシブに設定

TIFF形式データの圧縮（JV_TIFF_COMPRESSION）のparam には次の値を指定します。

定数 | 値 | 内容
JV_TIFF_COMPRESSION_DEFLATE | 0 | デフレート圧縮 (初期値)
JV_TIFF_COMPRESSION_NONE | 1 | 圧縮なし

暗号化レベル（JV_PDF_ENCRIPT_LEVEL）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_ENCRIPT_RCL | "2" | RC4(40ビット)
JV_PDF_ENCRIPT_RCH | "3" | RC4（128ビット)(初期値)
JV_PDF_ENCRIPT_AES128 | "4" | AES(128ビット)
JV_PDF_ENCRIPT_AES256 | "5" | AES(256ビット)

文書の印刷（JV_PDF_ENABLE_PRINT）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

文書の変更（JV_PDF_ENABLE_EDIT_ALL）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

内容のコピーと抽出（JV_PDF_ENABLE_COPY）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

注釈の追加と変更（JV_PDF_ENABLE_EDIT）のparam には次の値を指定します。

定数 | 値 | 内容
JV_PDF_SEC_ENABLE | "1" | 許可（初期値）
JV_PDF_SEC_DISABLE | "0" | 許可しない

オーバーレイ登録（JV_PDF_OVERLAY）のparam には次の値を指定します。

定数 | 値 | 内容
JV_SPDFOVERLAY_ON | "1" | 登録する
JV_SPDFOVERLAY_OFF | "0" | 登録しない

[解説]

これらの各種パラメータは、レポートライブラリでRDFデータ作成時に設定しておくこともできます。レポートライブラリとプレビューコントロールの両方で設定された場合には、プレビューコントロールの設定値が優先されます。

JPEG形式データの品質（JV_JPEG_QUALITY）
JPEG形式で出力する帳票の品質を設定します。数値が低くなるほど、JPEGデータのサイズは小さくなりますが、品質は劣化します。

JPEG形式データのプログレッシブ（JV_JPEG_PROGRESSIVE）
JPEG形式で出力する帳票の表示形式を設定します。「JV_JPEG_PROGRESSIVE_OFF」にすると、JPEG形式の帳票は、上から徐々に表示されていきます。「JV_JPEG_PROGRESSIVE_ON」にすると、JPEG形式の帳票は、まず画像全体が荒く表示され、徐々に鮮明度を増していきます。

TIFF形式データの圧縮（JV_TIFF_COMPRESSION）
TIFF形式の帳票はデフレート圧縮されて出力されますが、「JV_TIFF_COMPRESSION_NONE」にすると圧縮をやめることができます。

オーナーパスワード
オーナーパスワードをつけると、次の利用許可制限を設定することができます。
文書の印刷、文書の変更、内容のコピーと抽出、注釈の追加と変更

ユーザーパスワード
ユーザーパスワードがついたAdobe PDFドキュメントは、利用時にユーザーパスワードが必要です。

文書の印刷
Adobe PDFドキュメント利用時の印刷に対する制限を指定します。

文書の変更
Adobe PDFドキュメント利用時の「テキスト注釈及び対話フォームフィールド以外の文書内容の変更」に対する制限を指定します。

内容のコピーと抽出
Adobe PDFドキュメント利用時の「文書からのテキストとグラフィックスのコピー」に対する制限を指定します。

注釈の追加と変更
Adobe PDFドキュメント利用時の「テキスト注釈及び対話フォームフィールドの追加または変更」に対する制限を指定します。

オーバーレイ登録
Adobe PDFデータの出力時に、フォームの固定部分をオーバーレイ登録するかどうかを指定します。
初期値は、フォームファイルに設定された値です。
－ Adobe PDF形式データのオーバーレイ登録

作成者、アプリケーション、タイトル、サブタイトル、キーワード
設定値は、Adobe PDFドキュメントのプロパティ画面で見ることができます。

XPS形式データの一時ファイル用ディレクトリ（JV_TEMP_PATH_NAME）
XPS形式で帳票を出力する時の一時ファイル用ディレクトリを設定します。jvCreatをコールした直後に設定します。何も指定しない場合には、Windowsの一時ファイル用ディレクトリが使われます。

XPS形式データのプリンタ名（JV_XPS_DRIVER_NAME）
帳票をXPS形式で作成する時には、XPSプリンタが必要です。通常、OSをインストールすると「Microsoft XPS Document Writer」という名前のXPSプリンタがインストールされます。このプリンタが、この名称で実行環境にある場合には、jvSetStringでプリンタ名を設定する必要はありません。このプリンタ名を変更した場合や、別のものを使用する場合には、jvCreatをコールした直後に、jvSetStringでプリンタ名を設定します。


BorderStyleプロパティ(プレビューコントロール)

BorderStyleプロパティ

プレビューコントロールの輪郭線の表示／非表示を設定します。

[構文]

Object.BorderStyle = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 輪郭線の状態（設定値参照）

[設定値]

long には次の値を設定します。

値 | 内容
0 | 3D表示 （初期値）
1 | 非表示
2 | 自動

[解説]

BorderStyleプロパティは、ToolBarプロパティと連動します。BorderStyleプロパティを「非表示（1）」にすると、ToolBarプロパティでツールバーを表示することができません。 ツールバーを表示する場合は、BorderStyleプロパティを「非表示（1）」以外にします。

プレビューコントロールの枠、スクロールバー、ツールバーは、設定値によって次の状態となります。

3D表示
プレビューコントロールの枠が表示されます。描画用に確保されているプレビューコントロールのサイズが帳票のサイズより小さい場合は、スクロールバーも表示されます。
BorderStyleプロパティでツールバーを表示するようにした場合は、ツールバーも表示されます。

非表示
プレビューコントロールの枠もスクロールバーも表示されません。
BorderStyleプロパティの設定値に拘わらず、ツールバーは表示されません。

自動
描画用に確保されているプレビューコントロールのサイズが帳票のサイズより小さい場合は、プレビューコントロールの枠とスクロールバーが表示されますが、大きい場合は、枠もスクロールバーも表示されません。
BorderStyleプロパティでツールバーを表示するようにした場合は、プレビューコントロールの枠が表示される場合のみ、枠と一緒にツールバーが表示されます。

値の設定と参照はデザイン時、実行時に可能です。


CharacterSetプロパティ(プレビューコントロール)

CharacterSetプロパティ

プレビュー画面のフィールドデータを取得する時の文字コードを設定します。

[構文]

Object.CharacterSet = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 文字コード（設定値参照）

[設定値]

long には次の値を設定します。

定数 | 値 | 内容
CHARSET_SJIS | 0 | Shift-JIS （初期値）
CHARSET_UNICODE | 1 | UNICODE

[解説]

XmlDataプロパティからフィールドデータを取得する時の文字コードを設定します。

UNICODE仕様で取得する場合は「CHARSET_UNICODE」、Shift-JIS仕様で取得する場合は「CHARSET_SJIS」を指定します。
フィールドデータは、CharacterSet プロパティで指定された文字コードのXMLファイル仕様で作成されますが、どちらの仕様を指定しても、XmlDataプロパティによって抽出される文字列はUNICODEです。

値の設定と参照はデザイン時、実行時に可能です。

－UNICODEの使用について

[コーディング例]
JvrVw.CharacterSet = CHARSET_UNICODE | ‘UNICODEを指定する
tmp = JvrVw.XMLData | ‘UNICODEを含むﾃﾞｰﾀの取得


Copiesプロパティ(プレビューコントロール)

Copiesプロパティ

印刷ダイアログの印刷部数の初期値を設定します。

[構文]

Object.Copies = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 印刷部数

[設定値]

long には1～10000の値を設定します。初期値は1です。

[解説]

Copiesプロパティの値は、PrintDialogメソッドで印刷ダイアログを表示した時に、印刷部数の初期値になります。

値の設定と参照はデザイン時、実行時に可能です。


DataFileNameプロパティ(プレビューコントロール)

DataFileNameプロパティ

帳票を表示する時に、帳票のフィールドに、XML形式の初期値を設定します。

[構文]

Object.DataFileName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | XMLファイル名

[設定値]

XMLファイルを使う時は、string にファイルの名前を設定します。

[解説]

DataFileName プロパティに初期値を設定すると、帳票作成時にプログラムから埋め込んだフィールドデータは初期値で上書きされます。

コンピュータのメモリ上にある初期値を使う時は、XmlDataプロパティを使います。

値の設定と参照はデザイン時、実行時に可能です。

－XML形式の初期値について
－基本的なコーディング（XMLファイルの場合）
－UNICODEの使用について

[コーディング例]

XMLファイルを使う場合

JvrVw.FileName = “c:\tmp\見積書.rdf”
JvrVw.DataFileName = “c:\tmp\見積データ.xml”
JvrVw.Page = 1
Call JvrVw.Show


DocNameプロパティ(プレビューコントロール)

DocNameプロパティ

印刷時、スプーラに表示されるドキュメント名を設定します。

[構文]

Object.DocName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | ドキュメント名（32バイト以下）

[設定値]

string にはドキュメント名を設定します。初期値はありません。

[解説]

ドキュメント名はレポートライブラリのDocNameプロパティやjvStartDocファンクションで指定することもできます。レポートライブラリとプレビューコントロールの両方で設定された場合は、プレビューコントロールの値が優先されます。

値の設定と参照はデザイン時、実行時に可能です。


DocumentDataプロパティプレビュー

DocumentDataプロパティ

表示や印刷を行なうRDF形式のデータを取得します。
表示中の帳票をRDF形式 、Adobe PDF形式、TIFF形式、XPS形式、JPEG形式、PNG形式、BMP形式で取得します。

[構文]

Variant = Object.DocumentData

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
Variant | ドキュメント

[設定値]

Variant にはRDF形式のデータが入ったVariant 型変数を設定します。
初期値はありません。

[解説]

RDF形式のデータ設定
D ocumentData プロパティは、メモリ上にあるRDF形式のデータを取得する時に使います。
帳票をRDFファイルで取得する場合には、FileNameプロパティを使います。

RDF形式、Adobe PDF形式、TIFF形式、XPS形式、JPEG形式、PNG形式、BMP形式のデータ取得
表示中の帳票を各種形式で取得することができます。データはVariant 型変数で取得します。
取得するデータの形式は、OutDeviceプロパティで設定します。
取得するページの範囲は、MinPageプロパティとMaxPageプロパティで設定します。

－基本的なコーディング

[コーディング例]

Dim iDocSize As Long
Dim sDocData() As Variant
pid= jvCreate(JV_RDF,...)
:
:
ret = jvEndDoc(pid)
'RDFデータサイズの取得
iDocSize = jvGetLong(pid, JV_DOCUMENT_SIZE)
If iDocSize > 0 Then
'バッファの確保
ReDim sDocData(iDocSize)
'RDFデータの取得
ret = jvGetDocument(pid, sDocData(0))
End If
'レポートライブラリの終了処理
ret = jvClose(pid)

'プレビューコントロールにRDFデータを渡す
If iDocSize > 0 Then
JiveView.DocumentData = sDocData
JiveView.Show
End If


FieldDataプロパティ(プレビューコントロール)

FieldDataプロパティ

帳票のフィールドに値を設定します。 フィールドの値を取得することもできます。

[構文]

Object.FieldData(fieldname) = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
fieldname | フィールド名
string | フィールドの値

[設定値]

string には、フィールドの値をUNICODEで設定します。

[解説]

fieldname には、値の取得や設定を行うフィールド名を設定します。
string には、UNICODEの文字列を設定します。

グリッドフィールドの場合は、フィールド名称と一緒に行と列を指定することができます。

例）明細という名称のグリッドフィールドの場合
明細グリッドフィールドの1行目2列目のセルを指定 | 明細@R1C2
明細グリッドフィールドの2行目のセルを指定 | 明細@R2
明細グリッドフィールドの3列目のセルを指定 | 明細@C3
明細グリッドフィールドの全てのセルを指定 | 明細

ラベル、可変フォームを使った帳票、1ページの中に同じフォームを2回以上使用する帳票では、同じフォーマットのラベルやセクション、フォームが、１ページの中に複数配置され、同名のフィールドが１ページの中に複数存在します。そこで、これらに該当する帳票に対してデータの取得や設定を行う場合には、LabelNoプロパティで、目的のフィールドがあるラベル、セクション、フィールドを指定しておきます。

値の設定と参照は実行時のみ可能です。

－U NICODEの使用について

[コーディング例]

tmp = JvrVw.FieldData(“伝票番号”) | ‘フィールドから値を取得する
JvrVw.FieldData(“顧客名”) = “” | ‘フィールドをクリアする


FieldFrameプロパティ(プレビューコントロール)

FieldFrameプロパティ

テキストフィールド、グリッドフィールド、セレクトボタンフィールドを点線の枠で表示します。

[構文]

Object.FieldFrame = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | フィールド枠の状態（設定値参照）

[設定値]

long には次の値を設定します。

値 | 内容
-1 | 表示
0 | 非表示（初期値）

[解説]

long に「表示(-1)」を指定すると、フィールドの枠が表示されます。
帳票を表示する時にXML形式の初期値を設定し、初期値の中で、enabledプロパティに「0」を設定したフィールドでは、FieldNameプロパティに「表示(-1)」を指定しても、枠は表示されません。

値の設定と参照はデザイン時、実行時に可能です。

－XML形式の初期値について


FileNameプロパティ(プレビューコントロール)

FileNameプロパティ

表示や印刷を行なうRDFファイルを設定します。

[構文]

Object.FileName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | RDFファイル名 （256バイト以下）

[設定値]

string にはRDFファイル名を設定します。
初期値はありません。

[解説]

メモリ上にあるRDF形式のデータの表示や取得には、DocumentDataプロパティを使います。

値の設定と参照はデザイン時、実行時に可能です。

－基本的なコーディング（RDFファイル）

[コーディング例]

''VBでRDFファイルを指定
Jvrvw.FileName="c:\tmp\kasai.rdf"


FormDragプロパティ(プレビューコントロール)

FormDragプロパティ

表示中の帳票をマウスでドラッグする機能を設定します。

[構文]

Object.FormDrag = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ドラッグ可／不可（設定値参照）

[設定値]

long には次の値を設定します。

値 | 内容
-1 | ドラッグ可 （初期値）
0 | ドラッグ不可

[解説]

FormDragプロパティに「ドラッグ可（-1）」を指定すると、プレビューコントロールに表示された帳票をマウスでドラッグして移動できます。

値の設定と参照はデザイン時、実行時に可能です。


Keyプロパティ(プレビューコントロール)

Keyプロパティ

帳票に設定されたキーを取得します。

[構文]

string = Object.Key (index)

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
index | 1～5
string | キーの値

[解説]

帳票作成時に、レポートライブラリのKeyプロパティやjvSetStringファンクションで設定したキーを取得します。
値の参照は実行時のみ可能です。


LabelNoプロパティ(プレビューコントロール)

LabelNoプロパティ

ラベル番号、セクション番号、フォーム番号を設定します。

[構文]

Object.LabelNo = ｌong

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ラベル番号／セクション番号／フォーム番号

[設定値]

long にはラベル番号、セクション番号、フォーム番号のいずれかを設定します。初期値は1です。

[解説]

LabelNoプロパティは、 FieldDataプロパティを使ってフィールド値の取得や設定を行う時に使います。

ラベル印刷の場合には、LabelNoプロパティにラベル番号を設定します。
可変帳票印刷の場合には、LabelNoプロパティにセクション番号を設定します。
1ページに同じフォームを複数回使用する帳票印刷の場合には、LabelNoプロパティにフォーム番号を設定します。

これらの帳票印刷では、1ページの中に、同じフォーマットのラベル、セクション、フォームが複数配置されます。そのため、1ページ中に、同名のフィールドが複数存在します。これらの帳票に対してデータの取得や設定を行う場合には、目的のフィールドがあるラベル番号、セクション番号、フォーム番号をLabelNoプロパティで設定します。

ラベル番号
ラベル番号は、用紙左上を1とし、右側へ向かって、2、3と付けられます。最上段の右端まで進んだら、次は2段目の左端から同様に最後のラベルまで繰り返します。
例）ラベルが横方向に２枚、縦方向に３枚ある場合
1 | 2
3 | 4
5 | 6

セクション番号
セクション番号は、DrawSectionまたはjvDrawSectionで描画したセクションの順に付けられます。最初に描画したセクションが1、次に描画したセクションが2となります。

フォーム番号
フォーム番号は、DrawFormまたはjvDrawFormで描画したフォームの順に付けられます。最初に描画したフォームが1、次に描画したフォームが2となります。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

JvrVw.LabelNo = 2 | ‘2つ目のラベルを指定する
JvrVw.FieldData(“氏名”) = “” | ‘2つ目のラベルのフィールドをクリアする


LastDllErrorプロパティ(プレビューコントロール)

LastDllErrorプロパティ

プレビューコントロールで発生したエラーのエラー番号を取得します。

[構文]

long = Object.LastDllError

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
Long | エラー番号

[解説]

プレビューコントロールでエラーが発生した時、エラー番号は、使用言語のエラーコードと、LastDllErrorで参照することができます。エラーコードやLastDllErrorで取得したエラー番号は、プレビューコントロールのエラーを参照し内容を確認します。

値の参照は、実行時のみ可能です。

[コーディング例]

On Error Goto Error_Trap
・
・
・
Error_Trap:
‘エラーコードでプレビューコントロールのエラー番号を参照
ErrorCode = Err
‘LastDllErrorの値を参照
ErrorCode = JvrVw.LastDllError


LastDllErrorMsgプロパティ(プレビューコントロール)

LastDllErrorMsgプロパティ

プレビューコントロールで発生したエラーのエラーメッセージを参照します。

[構文]

string = Object.LastDllErrorMsg

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | エラーメッセージ

[解説]

プレビューコントロールでエラーが発生した時、エラーメッセージは、使用言語のエラーコードによる参照と、LastDllErrorMsg プロパティで参照することができます。エラー番号はLastDllErrorプロパティで取得します。
値の参照は、実行時のみ可能です。


LayoutTypesプロパティ(プレビューコントロール)

LayoutTypesプロパティ

プレビュー画面の表示形式を設定します。

[構文]

Object.LayoutTypes = Long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | レイアウト（設定値参照）

[設定値]

long には次の値を設定します。

値 | 内容
0 | 標準レイアウト
1 | 印刷レイアウト（単一ページ）（初期値）
2 | 印刷レイアウト（連続ページ）

[解説]

標準レイアウト
帳票をそのままプレビュー画面上に表示します。ジャイブレポートVer.7までの表示形式です。

印刷レイアウト（単一ページ）
印刷した時と同じレイアウトで、帳票をプレビュー画面に1ページずつ表示します。ページ間は、前頁ボタンや次頁ボタンで移動します。

印刷レイアウト（連続ページ）
印刷した時と同じレイアウトで、帳票の全ページを連続して表示します。 ページ間は、スクロールバーやマウススクロールで移動することができます。プレビューコントロールのデータ入力機能を使う時は、「印刷レイアウト（連続ページ）」は使用できません。 RDFファイルに、可変帳票、固定帳票、異なる用紙サイズの帳票、異なる用紙方向の帳票が混在している場合には、連続ページ表示を選択しても、自動的に単一ページ表示になります。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

‘連続ページモードにする
JvrVw.LayoutTypes = 2


LeftMarginプロパティ(プレビューコントロール)

LeftMarginプロパティ

印刷時の用紙の左マージンを設定します。

[構文]

Object.LeftMargin = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 左マージン（1/100mm単位）

[設定値]

long には用紙の左マージンを設定します。 初期値は0です。

[解説]

用紙の上マージンの設定には、Top Margin プロパティを使用します。

フォームに余白が設定されている場合には、フォームの余白に加算されます。
マイナス値を設定することもできます。

詳細は「付録／用紙の余白（マージン）設定」を参照してください。

余白は、ジャイブレポートのバージョンによって仕様が異なります。ご注意ください。

値の設定と参照はデザイン時、実行時に可能です。


Lockedプロパティ(プレビューコントロール)

Lockedプロパティ

帳票画面のロックとロック解除を設定します。

[構文]

Object.Locked = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ロック／ロック解除（設定値参照）

[設定値]

long には次の値を設定します。

値 | 内容
-1 | ロック （初期値）
0 | ロック解除

[解説]

Locked プロパティに「ロック(-1)」を指定すると、画面上のフィールドでは入力ができなくなります。

「ロック解除(0)」を指定すると、フィールドに直接データを入力できるようになります。
データを入力する時はLayoutTypeプロパティを「印刷レイアウト（連続ページ）」以外に設定しておきます。

フォームファイルに計算式を設定した場合は、Locked プロパティのロックを解除すると計算結果が表示されます。
例）
JiveView.Locked = False
Call JiveView.Show
JiveView.Locked = True

値の設定と参照はデザイン時、実行時に可能です。


MaxPageプロパティ(プレビューコントロール)

MaxPageプロパティ

終了ページを設定します。

[構文]

Object.MaxPage = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 終了ページ

[設定値]

long には終了ページを設定します。初期値は1です。

[解説]

MaxPage プロパティでは、次の終了ページを設定します。

(1) PrintOutメソッドで印刷を実行する時に、印刷の終了ページを設定します。
(2) PrintDialogメソッドで印刷ダイアログを表示する時に、印刷の終了ページを初期設定します。

(3) SaveFileメソッドで表示中の帳票をファイルへ出力する時に、終了ページを設定します。OutDeviceプロパティの値が「0」の場合には、全ページ出力となり、MaxPageプロパティの値は無視されます。 OutDeviceプロパティの値が「JV_JPEG」「JV_PNG」「JV_BMP」の場合には、MinPageプロパティで指定したページのみの出力となり、MaxPageプロパティの値は無視されます。

(4) DocumentDataプロパティで表示中の帳票をメモリ上へ出力する時に、終了ページを設定します。OutDeviceプロパティの値が「0」の場合には、全ページ出力となり、MaxPageプロパティの値は無視されます。 OutDeviceプロパティの値が「JV_JPEG」「JV_PNG」「JV_BMP」の場合には、MinPageプロパティで指定したページのみの出力となり、MaxPageプロパティの値は無視されます。

開始ページは、MinPageプロパティで設定します。
帳票の総ページ数は、PageCountプロパティで取得することができます。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

‘全ページ印刷する
JvrVw.MinPage = 1
JvrVw.MaxPage = JvrVw.PageCount
JvrVw.PrintOut


MinPageプロパティ(プレビューコントロール)

MinPageプロパティ

開始ページを設定します。

[構文]

Object.MinPage = long
設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 開始ページ

[設定値]

long には開始ページを設定します。初期値は1です。

[解説]

MinPage プロパティでは、次の開始ページを設定します。

(1) PrintOutメソッドで印刷を実行する時に、印刷の開始ページを設定します。
(2) PrintDialogメソッドで印刷ダイアログを表示する時に、印刷の開始ページを初期設定します。

(3) SaveFileメソッドで表示中の帳票をファイルへ出力する時に、開始ページを設定します。OutDeviceプロパティの値が「0」の場合には、１ページ目から全ページ出力となり、MinPageプロパティの値は無視されます。

(4) DocumentDataプロパティで表示中の帳票をメモリ上へ出力する時に、開始ページを設定します。OutDeviceプロパティの値が「0」の場合には、１ページ目から全ページ出力となり、MinPageプロパティの値は無視されます。

終了ページは、MaxPageプロパティで設定します。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

‘全ページ印刷する
JvrVw.MinPage = 1
JvrVw.MaxPage = JvrVw.PageCount
JvrVw.PrintOut


OutDeviceプロパティプレビュー

OutDeviceプロパティ

プレビュー中の帳票を出力する時の出力形式を設定します。

[構文]

Object.OutDevice = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 出力先（設定値参照）

[設定値]

long には次の値を設定します。 初期値は0です。

定数 | 値 | 内容
JV_RDF | 5 | RDF形式で出力
JV_PDF | 9 | Adobe PDF形式で出力
JV_JPEG | 10 | JPEG形式で出力
JV_TIFF | 11 | TIFF形式で出力
JV_PNG | 12 | PNG形式で出力
JV_XPS | 13 | XPS形式で出力
JV_BMP | 3 | BMP形式で出力

[解説]

OutDeviceプロパティは、表示中の帳票をDocumentDataプロパティで取得する時や、表示中の帳票をSaveFileメソッドでファイルに保存する時に、出力形式を設定します。
出力先がRDF、PDF、TIFF、XPSの場合、出力するページは、MinPageプロパティとMaxPageプロパティを使います。 出力先がJPEG、PNG、BMPの場合、出力するページは、MinPageプロパティで指定したページのみとなります。

OutDeviceプロパティの初期値は「0」 です。「0」は、旧バージョンとの互換性のために用意された値で、出力形式はRDF形式となり、常に全ページを出力します。

[コーディング例]

RDF形式でファイルに保存
JvrVw.OutDevice = JV_RDF | 'RDF形式を設定
JvrVw.MinPage = 1 | '出力開始ページ
JvrVw.MaxPage = Jvrvw.PageCount | '出力終了ページ
Call Jvrvw.SaveFile() | 'ファイルに保存

JPEG形式でファイルに保存
JvrVw.OutDevice = JV_JPEG | 'JPEG形式を設定
JvrVw.SaveFileName = sImageFileName | '保存ファイル名の設定
JvrVw.MinPage = 1 | '出力開始ページ
Call Jvrvw.SaveFile() | 'ファイルに保存

XPS形式でバイト配列のバッファに読み込む
Dim sDocData() As Byte |
JvrVw.OutDevice = JV_XPS | 'XPS形式を設定
JvrVw.MinPage = 1 | '出力開始ページ
JvrVw.MaxPage = Jvrvw.PageCount | '出力終了ページ
sDocData = Jvrvw.get_DocumentData | 'バッファへ読み込む


OuterColorプロパティ(プレビューコントロール)

OuterColorプロパティ

プレビューコントロールに表示された帳票の外側の色を設定します。

[構文]

Object.OuterColor = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 色

[設定値]

long には色をRDG値で設定します。 初期値は白です。

[解説]

帳票と帳票以外の部分を区別することができます。

値の設定と参照はデザイン時、実行時に可能です。


Pageプロパティ(プレビューコントロール)

Pageプロパティ

表示するページを設定します。

[構文]

Object.Page = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | ページ

[設定値]

long にはページを設定します。初期値は1です。

[解説]

Page プロパティは、プレビュー画面に表示するページ番号を設定するためのプロパティです。
印刷する時のページ設定には、MinPageプロパティとMaxPageプロパティを使います。

値の設定と参照はデザイン時、実行時に可能です。

[コーディング例]

JvrVw.FileName = “c:\tmp\kasai.rdf”
JvrVw.Page = 1
JvrVw.Show


PageCountプロパティ(プレビューコントロール)

PageCountプロパティ

帳票の総ページ数を取得します。

[構文]

long = Object.PageCount

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 総ページ数

[解説]

値の参照は実行時のみ可能です。

[コーディング例]

‘全ページ印刷する
JvrVw.MinPage = 1
JvrVw.MaxPage = JvrVw.PageCount
JvrVw.PrintOut


Passwordプロパティ(プレビューコントロール)

Passwordプロパティ

表示中の帳票と入力値をファイルに保存する時のパスワードを設定します。

[構文]

Object.Password = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | パスワード

[設定値]

string にはパスワードを設定します。パスワードの長さの制限はありません。
初期値はありません。

[解説]

パスワードを設定すると、保存したファイルを開く時にも同じパスワードが必要です。
値の設定と参照はデザイン時、実行時に可能です

－ 基本的なコーディング


PopupMenuプロパティ(プレビューコントロール)

PopupMenuプロパティ

マウスの右ボタンをクリックした時、ポップアップメニューを表示するかどうかを設定します。

[構文]

Object.PopupMenu = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 表示／非表示 （設定値参照）

[設定値]

long には次の値を設定します。

値 | 内容
-1 | 表示
0 | 非表示（初期値）

[解説]

ポップアップメニューには、「開く」「印刷」「スケール」があります。「開く」ではRDFファイルを開きます。「印刷」では画面上の帳票を印刷します。「スケール」では帳票の表示倍率を変えることができます。

値の設定と参照はデザイン時、実行時に可能です。


PrinterDevModeプロパティ(プレビューコントロール)

PrinterDevModeプロパティ

印刷するプリンタドライバのプロパティを設定します。

[構文]

Object.PrinterDevMode = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリンタドライバ情報（ドライバ設定ファイル ）

[設定値]

string にはプリンタドライバ情報、またはプリンタドライバ設定ファイルを設定します。
初期値はありません。

[解説]

PrinterDevMode プロパティは、アプリケーションからプリンタドライバを自動的に設定して印刷する時に使います。帳票を作成する時に、レポートライブラリでプリンタドライバ情報を設定した場合でも、このPrinterDevModeプロパティの方が優先されます。
プリンタ名は、PrinterNameプロパティで設定します。
Web環境で印刷する場合には、プリンタドライバ設定ファイルは使用できません。
値の設定と参照はデザイン時、実行時に可能です。

－基 本的なコーディング
－ドライバ設定ファイルとは
－プリンタドライバ情報とは
－プリンタドライバ情報の取得方法

[コーディング例]

JvrVw.PrinterName = “EPSON”
JvrVw.PrinterDevMode = “1,9”
JvrVw.PrintOut


PrinterNameプロパティ(プレビューコントロール)

PrinterNameプロパティ

印刷するプリンタを設定します。

[構文]

Object.PrinterName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | プリンタ名

[設定値]

string にはプリンタ名を設定します。初期値はありません。

[解説]

PrintOut プロパティで印刷を行う時のプリンタを設定します。帳票を作成する時に、レポートライブラリでプリンタを指定した場合でも、このPrinterNameプロパティの方が優先します。
プリンタドライバ情報は、PrinterDevModeプロパティで設定します。
プリンタが何も設定されなかった場合は、デフォルトプリンタ（通常使うプリンタに指定されたプリンタ）で印刷します。

値の設定と参照はデザイン時、実行時に可能です。

－基本的なコーディング

[コーディング例]

JvrVw.PrinterName = “EPSON”
JvrVw.PrinterDevMode = “1,9”
Call JvrVw.PrintOut


SaveFileNameプロパティ(プレビューコントロール)

SaveFileNameプロパティ

プレビュー中の帳票と入力データをファイルに保存する時のファイル名を設定します。

[構文]

Object.SaveFileName = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | 保存ファイル名

[設定値]

string には保存ファイル名を設定します。初期値はありません。

[解説]

ファイル名のパスにはURLは指定できません。 ShowFileDialogメソッドでファイル選択ダイアログをポップアップしてファイル名を指定した場合は、SaveFileNameプロパティにユーザーが設定したファイル名が入ります。ファイルの保存には、SaveFileメソッドを使います。

値の設定と参照はデザイン時、実行時に可能です。

－基本的なコーディング

[コーディング例]

Jvrvw.Password = "xyz" | ‘パスワードの設定
SaveFileName = "c:\tmp\見積書.RDF" | ‘保存ファイル名の設定
Jvrvw.SaveFile | ‘ファイルを保存する


Scaleプロパティ(プレビューコントロール)

Scale(ScaleValue)プロパティ

印刷やプレビューの拡大縮小率を設定します。

[構文]

Object.Scale = long
Object.ScaleValue = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 拡大縮小率（％）

[設定値]

long には拡大縮小率を25%～1000%の範囲で設定します。初期値は100です。
0を設定すると、プレビューコントロールの枠サイズに自動調整されます。

拡大縮小率を設定しても、用紙の余白は変わりません。
詳細は「付録／用紙の余白（マージン）設定」を参照してください。

[解説]

「Scale」 が予約語になっている開発環境では、「ScaleValue」を使用してください。
値の設定と参照はデザイン時、実行時に可能です。


ToolBarプロパティ(プレビューコントロール)

ToolBarプロパティ

プレビューコントロールの下部にツールバーを表示するかどうかを設定します。

[構文]

Object.ToolBar = bool

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
bool | 表示／非表示（設定値参照）

[設定値]

bool には次の値を設定します。

値 | 内容
-1 | 表示
0 | 非表示（初期値）

[解説]

ツールバーには改ページボタンと拡大縮小率の変更ボタンがあります。
BorderStyleプロパティが非表示に設定されていると、ToolBarプロパティに「表示（-1）」を指定してもツールバーは表示されません。

値の設定と参照はデザイン時、実行時に可能です。


TopMarginプロパティ(プレビューコントロール)

TopMarginプロパティ

印刷時の用紙の上マージンを設定します。

[構文]

Object.TopMargin = long

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
long | 上マージン （1/100mm単位）

[設定値]

long には上マージンを設定します。初期値は0です。

[解説]

用紙の左マージンの設定には、LeftMarginプロパティを使用します。

フォームに余白が設定されている場合には、フォームの余白に加算されます。
マイナス値を設定することもできます。

詳細は「付録／用紙の余白（マージン）設定」を参照してください。

余白は、ジャイブレポートのバージョンによって仕様が異なります。ご注意ください。

値の設定と参照はデザイン時、実行時に可能です。


XmlDataプロパティ(プレビューコントロール)

XmlDataプロパティ

帳票を表示する時に、帳票のフィールドにXML形式の初期値を設定します。
帳票のフィールドに埋め込まれている値をXML形式で取得します。

[構文]

string = Object.XmlData
Object.XmlData = string

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | フィールドの値／XML形式の初期値

[設定値]

string には、XML形式の初期値を設定します。

[解説]

値の設定
XmlDataプロパティは、コンピュータのメモリ上にあるXML形式の初期値を指定する時に使います。XMLファイルや、Web環境で初期値を設定する場合は、DataFileNameプロパティを使います。

値の取得
XmlDataプロパティでフィールドの値を取得する時は、取得する前にLockedプロパティのロックを解除しておきます。また、フィールドの値を取得する前に、CharacterSetプロパティで取得する文字コードの仕様を指定しておきます。
XmlDataプロパティは、全ページ分のフィールド値を取得します。

値の参照は実行時のみ可能です。

－UNICODEの使用について

[コーディング例]

Dim xmlLength As Long
Dim XmlData() As Byte
Dim sXmlFileName As String
Dim fileNo As Integer 'ファイル番号

'XMLファイルのデータを変数に入れる
sXmlFileName = "C:\TEST\UNIteian.xml"
fileNo = FreeFile 'ファイル番号取得
Open sXmlFileName For Binary As #fileNo 'ファイルオープン
xmlLength = FileLen(sXmlFileName)
ReDim XmlData(xmlLength) As Byte
Get #fileNo, , XmlData
Close #fileNo

JiveView.LayoutTypes = 0
JiveView.DocumentData = rdfData
JiveView.XmlData = CStr(XmlData)
JiveView.Page = 1
JiveView.Show
JiveView.Locked = False


XmlErrorプロパティ(プレビューコントロール)

XmlErrorプロパティ

XML形式の初期値を読み込んだ時に発生したエラーメッセージを取得します。

[構文]

string = Object.XmlError

設定項目 | 内容
Object | オブジェクトへの参照を表すオブジェクト式
string | エラーメッセージ

[解説]

XmlError プロパティには、初期値を読み込んだ時に発生したすべてのエラーが入ります。帳票のフィールドに初期値が正常に表示されなかった場合は、XmlError プロパティでエラー内容を確認できます。エラーが発生しなかった時は空文字列が返ります。

値の参照は実行時のみ可能です。


レポートライブラリOCXのエラー

レポートライブラリOCX／レポートライブラリ.NETコントロールのエラー

メソッドを実行した時や、プロパティの値を設定・参照した時にエラーが発生することがあります。
エラーコードとエラー内容は、エラートラップで取得することができます。
LastDllErrorプロパティの値を参照してエラーの内容を詳しく分析することもできます。
1000 | 初期処理エラー
1001 | デバイスコンテキスト取得エラー
1002 | 印刷終了処理エラー
1003 | 改ページエラー
1004 | フィールドデータセットエラー
1005 | フォーム描画エラー
1006 | 印刷中止処理エラー
1007 | 文字型情報セットエラー
1008 | 数値型情報セットエラー
1009 | フィールド座標取得エラー
1010 | 印刷ダイアログエラー
1011 | 描画エラー
1012 | ジョブID取得エラー
1013 | プリンタ名取得エラー
1014 | ジョブステータス取得エラー
1015 | DEVMODE情報取得エラー
1016 | ジョブ情報取得エラー
1017 | フォント作成エラー
1018 | フォームが指定されていません
1019 | フォーム設定エラー
1020 | ビットマップファイル名が指定されていません
1021 | ビットマップファイルの作成に失敗しました
1022 | 用紙サイズ・方向の設定に失敗しました
1023 | DEVMODE情報設定エラー
1024 | ジョブステータス設定エラー
1025 | CreateDCエラー
1026 | StartDocエラー
1028 | フィールド名を指定してください
1029 | Startを行ってください
1030 | 用紙サイズ取得エラー
1031 | 用紙方向取得エラー
1032 | 用紙の幅取得エラー
1033 | 用紙の高さ取得エラー
1034 | フォーム名取得エラー
1035 | フォーム作成者取得エラー
1036 | フォームの説明取得エラー
1037 | ファイルオープンエラー
1038 | ファイルリードエラー
1039 | フォームのフォーマットが違います
1040 | フォームのバージョンが違います
1041 | メモリエラー
1042 | フィールドオーバーフロー
1043 | 編集子が不正です
1044 | 指定されたフィールドがありません
1045 | 不正なコードがあります
1046 | コード長が不正です
1047 | イメージファイルがありません
1048 | スプール用ディスク不足
1049 | スプール用メモリ不足
1050 | ENDPAGEエラー
1052 | OutDeviceプロパティエラー [1:ウィンドウ,2:プリンタ,3:ビットマップファイル,5:RDFファイル,7:RDFメモリ,9:PDF]から選択してください
1053 | PageNoプロパティエラー 値が不正です
1054 | FormScaleプロパティエラー [1～1000]の範囲で設定してください
1055 | FontSizeプロパティエラー[1～2000]の範囲で設定してください
1056 | FontScaleプロパティエラー [1～1000]の範囲で設定してください
1057 | FontAngleプロパティエラー[0～359]の範囲で設定してください
1058 | LineWidthプロパティエラー 0以上の値を設定してください
1059 | LineStyleプロパティエラー[0～4]の範囲で設定してください
1060 | FillPatternプロパティエラー[0～39]の範囲で設定してください
1061 | DrawFormModeプロパティエラー[1～3]の範囲で設定してください
1062 | PageKeyプロパティエラー PageKey設定エラー
1063 | LeftMarginプロパティエラー 左マージン設定エラー[-100000～100000]
1064 | TopMarginプロパティエラー 上マージン設定エラー[-100000～100000]
1065 | FromPage,TopPage,MinPage,MaxPageプロパティエラー[1～10000]の範囲で設定してください
1066 | Copiesプロパティエラー [1～10000]の範囲で設定してください
1067 | SetPrinterプロパティエラー [0～3]の範囲で設定してください
1068 | JobStatusプロパティエラー [1～4]の範囲で設定してください
1069 | PrinterNameプロパティに値をセットしてください
1071 | パラメータエラー
1072 | ウィンドウハンドルが指定されていません
1073 | ウィンドウのデバイスコンテキストが取得できません
1074 | 通常使用するプリンタが指定されていません
1075 | プリンタのデバイスコンテキストが作成できません
1076 | プリンタ解像度エラー
1077 | ウィンドウ解像度エラー
1078 | インデックスエラー[1～5]
1079 | 出力ファイル名が指定されていません
1080 | フォームマージン取得エラー
1081 | プリンタマージン取得エラー
1082 | フォームページ数取得エラー
1117 | RDFファイル作成エラー
1120 | 印刷ダイアログのキャンセル
1121 | Adobe PDFファイル作成エラー
1122 | ファイルライトエラー
1123 | Startが実行されています
1124 | AdobePDFデータに埋め込めないフォントがある
1125 | AdobePDFデータにフォントを埋め込めない文字コードがある
1126 | セクション描画エラー
1127 | デフォルトプリンタ名取得エラー
1128 | Collateプロパティエラー[0～1]の範囲で設定してください
1129 | AllowSelectionプロパティエラー[0～1]の範囲で設定してください
1131 | 正常終了だが改ページ要求
1132 | イメージデータエラー
1133 | ドキュメントデータ取得エラー
1134 | プリンタ情報取得エラー
1135 | プリンタ情報設定エラー


レポートライブラリDLLのエラー

レポートライブラリDLL／レポートライブラリJNIのエラー

各ファンクションでは、各種のWindowsAPIをコールします。
WindowsAPIでエラーが発生した時は、Windowsを再起動するなどの環境整備が必要です。

エラーコード | 値 | エラー内容
JV_ERR_JVCREATE | -1 | オープンエラー jvGetOpenError で詳しいエラーコードを取得できます
JV_ERR_PARAMETER | -2 | パラメータエラー
JV_ERR_JOBID | -3 | ジョブIDの値が不正
JV_ERR_MEMORY | -4 | メモリ関連エラー
JV_ERR_PRINTERNAME | -10 | プリンタ名称エラー
JV_ERR_DRVSET | -11 | プリンタドライバ設定エラー
JV_ERR_PRINTDLG_CANCEL | -12 | プリンタダイアログでキャンセルされた
JV_ERR_CREATEDC | -13 | デバイスコンテキスト作成エラー Windowsの再起動が必要です。
JV_ERR_STARTDOC | -14 | 印刷開始エラー WindowsAPIのStarDocでエラーが発生
JV_ERR_ENDDOC | -15 | 印刷終了エラー WindowsAPIのEndDocでエラーが発生
JV_ERR_ABORTDOC | -16 | 印刷中止エラー WindowsAPIのAbortDocでエラーが発生
JV_ERR_ENUMPRINTER | -17 | プリンタ名称取得エラー
JV_ERR_SP_OUTOFDISK | -18 | スプール用ディスク不足
JV_ERR_SP_OUTOFMEMORY | -19 | スプール用メモリ不足
JV_ERR_DEVMODEGET | -20 | ﾌﾟﾘﾝﾀﾄﾞﾗｲﾊﾞ情報取得エラー
JV_ERR_PAGENO | -21 | ページ番号指定エラー
JV_ERR_PAGEKEY | -22 | ページキー指定エラー
JV_ERR_STARTPAGE | -23 | ページ開始エラー WinAPI
JV_ERR_DELETEDC | -24 | プリンタデバイスコンテキスト削除エラー
JV_ERR_PRNSETUP | -25 | 印刷設定のみのダイアログ（ﾌﾟﾘﾝﾀｾｯﾄｱｯﾌﾟﾀﾞｲｱﾛｸﾞ）でエラー
JV_ERR_OPEN_NOT_EXEC | -30 | jvCreateが実行されていない
JV_ERR_STARTDOC_ALREADY_EXEC | -31 | STARTDOC済み
JV_ERR_STARTDOC_NOT_EXEC | -32 | STARTDOCが実行されていない
JV_ERR_STARTPAGE_NOT_EXEC | -33 | 出力するオブジェクトがない
JV_ERR_ENDPAGE_NOT_EXEC | -34 | ENDPAGEが実行されていない
JV_ERR_SP_ENDPAGE | -35 | ENDPAGEエラー WindowsAPIのEndPageでエラーが発生
JV_ERR_PRINTSET_ALREADY_EXEC | -36 | jvSetDevModeまたはjvPrintDialog実行済み
JV_ERR_DEVCAPS | -37 | Device情報取得エラー
JV_ERR_FORM_FORMAT | -40 | フォームのフォーマットが違う
JV_ERR_FORM_VERSION | -41 | フォームのバージョンが違う
JV_ERR_OPEN_FILE | -42 | ファイルオープンエラー
JV_ERR_READ_FILE | -43 | ファイルリードエラー
JV_ERR_WRITE_FILE | -44 | ファイルライトエラー
JV_ERR_CREATE_FILE | -45 | ファイル作成エラー
JV_ERR_CREATEPEN | -50 | WindowsAPIのCREATEPENでエラーが発生
JV_ERR_JV_ERR_CREATEBRUSH | -51 | WindowsAPIのCREATEBRUSHでエラーが発生
JV_ERR_DRAW_MOVETOEX | -52 | WindowsAPIのMOVETOEXでエラーが発生
JV_ERR_DRAW_LINETO | -53 | WindowsAPIのLINETOでエラーが発生
JV_ERR_DRAW_RECTANGLE | -54 | 四角形描画エラー
JV_ERR_DRAW_POLYBEZIERTO | -55 | ベジェ曲線描画エラー
JV_ERR_DRAW_BEGINPATH | -56 | WindowsAPIのBEGINPATHでエラーが発生
JV_ERR_DRAW_ENDPATH | -57 | WindowsAPIのENDPATHでエラーが発生
JV_ERR_DRAW_STROKE | -58 | WindowsAPIのSTROKEでエラーが発生
JV_ERR_DRAW_ELLIPSE | -59 | 円・楕円描画エラー
JV_ERR_DRAW_ARC | -60 | 弧・弓・扇描画エラー
JV_ERR_DRAW_POLYGON | -61 | 多角形描画エラー
JV_ERR_DRAW_POLYLINE | -62 | 多角形描画エラー
JV_ERR_DRAW_POLYBEZIER | -63 | 多角形描画エラー
JV_ERR_DRAW_BITMAP | -64 | イメージ描画エラー
JV_ERR_BAR_CODE | -65 | 不正なコードがある
JV_ERR_BAR_LENGTH | -66 | コード長が不正
JV_ERR_DRAW_GRAPH | -67 | グラフ描画エラー
JV_ERR_CREATEFONT | -68 | フォント作成エラー WinAPI
JV_ERR_FIELD_NAME | -70 | 指定されたﾌｨｰﾙﾄﾞ名称が存在しない
JV_ERR_FIELD_FORMAT | -71 | 編集子が不正
JV_ERR_FIELD_OVERFLOW | -72 | フィールドオーバーフロー
JV_ERR_IMAGE_FNAME | -90 | イメージファイルが見つからない
JV_ERR_OPEN_PRINTER | -91 | WindowsAPIのOpenPrinterでエラーが発生
JV_ERR_GET_JOB | -92 | WindowsAPIのGetJobでエラーが発生
JV_ERR_SET_JOB | -93 | WindowsAPIのSetJobでエラーが発生
JV_ERR_JOB_ID | -94 | JobIdエラー
JV_ERR_GET_PRINTER | -95 | WindowsAPIのGetPrinterでエラーが発生
JV_ERR_OPEN_PARAM | -100 | パラメータエラー(jvCreate時)
JV_ERR_OPEN_HWND | -101 | Windowハンドルが指定されていない(jvCreate時)
JV_ERR_OPEN_WINHDC | -102 | Windowのデバイスコンテキストが取得できない(jvCreate時)
JV_ERR_OPEN_STDPRN | -103 | 通常使用するプリンタが指定されていない(jvCreate時)
JV_ERR_OPEN_PRNCREATEDC | -104 | プリンタデバイスコンテキストが作成できない(jvCreate時)
JV_ERR_OPEN_MEMORY | -105 | メモリ関連エラー(jvCreate時)
JV_ERR_OPEN_PRNDPI | -106 | プリンタ解像度取得エラー(jvCreate時)
JV_ERR_OPEN_WINDPI | -107 | ウィンドウ解像度取得エラー(jvCreate時)
JV_ERR_CREATE_RDF | -111 | RDFファイル作成エラー
JV_ERR_PRV_REGIST | -120 | RDFビューアがレジストリに登録されていない
JV_ERR_PRV_EXEC | -121 | RDFビューアが起動できない
JV_ERR_PRV_SENDCOMMAND | -122 | RDFビューアにコマンドが送信できない
JV_ERR_CREATE_PDF | -123 | AdobePDFファイル作成エラー
JV_ERR_FONTEMBED_FILE | -124 | AdobePDFデータに埋め込めないフォントがある
JV_ERR_FONTEMBED_CODE | -125 | AdobePDFデータにフォントを埋め込めない文字コードがある
JV_ERR_SECTIONKEY | -126 | セクションキー指定エラー
JV_ERR_OUTOFRANGE | -127 | このセクションを指定すると印字範囲を超える
JV_ERR_GETPRINTER_INFO | -128 | プリンタ情報取得エラー
JV_ERR_SETPRINTER_INFO | -129 | プリンタ情報設定エラー


プレビューコントロールのエラー

メソッドを実行した時や、プロパティの値を設定・参照した時にエラーが発生することがあります。
エラーコードとエラー内容は、エラートラップやLastDllErrorプロパティで取得することができます。
-1001 | ﾌｧｲﾙの読み込みに失敗しました
-1002 | FileNameﾌﾟﾛﾊﾟﾃｨのﾌｧｲﾙがｵｰﾌﾟﾝできません
-1003 | FileNameﾌﾟﾛﾊﾟﾃｨを設定して下さい
-1004 | ﾌｧｲﾙﾌｫｰﾏｯﾄが不正です
-1005 | ﾒﾓﾘｱﾛｹｰﾄに失敗しました
-1006 | 描画ｴﾗｰ(ﾒﾓﾘﾃﾞﾊﾞｲｽｺﾝﾃｷｽﾄ)
-1007 | 描画ｴﾗｰ(ﾒﾀﾌｧｲﾙ)
-1008 | ｲﾝﾃﾞｯｸｽは1～5の値を設定してください
-1009 | 25～150の値を設定してください
-1010 | 1以上の値を設定してください
-1011 | 1～10000の値を設定してください
-1012 | 1～10000の値を設定してください
-1020 | ﾌﾟﾘﾝﾄﾀﾞｲｱﾛｸﾞｴﾗｰ
-1021 | jvCreateｴﾗｰ
-1022 | jvStartDocｴﾗｰ
-1023 | jvEndPageｴﾗｰ
-1024 | jvEndDocｴﾗｰ
-1025 | jvSetLongｴﾗｰ
-1026 | jvSetFontｴﾗｰ
-1027 | jvSetFormｴﾗｰ
-1028 | jvDrawFormｴﾗｰ
-1029 | jvSetStringｴﾗｰ
-1030 | ﾌﾟﾘﾝﾄﾀﾞｲｱﾛｸﾞでｷｬﾝｾﾙ
-1031 | ﾀﾞｳﾝﾛｰﾄﾞｴﾗｰ
-1032 | ﾊﾟｽﾜｰﾄﾞｴﾗｰ
-1033 | ﾌｧｲﾙﾀﾞｲｱﾛｸﾞでｷｬﾝｾﾙをした
-1034 | ファイルの書き込みに失敗しました
-1035 | フィールド名エラー
-1036 | 0～2の値を設定してください
-1037 | jvSetSectionエラー
-1038 | パラメータエラー
-1039 | データの読み込みに失敗しました
-1040 | 出力先エラー
-1041 | ドキュメントデータ取得エラー
-1042 | AdobePDFデータに埋め込めないフォントがある
-1043 | AdobePDFデータにフォントを埋め込めない文字コードがある


バーコードJAN標準形_短縮形

バーコード　ＪＡＮ（標準形・短縮形）

JANには、標準形と短縮形があります。
標準形は13桁、短縮形は8桁で構成されます。

使用可能なキャラクタセット
数字（0～9）

シンボルの長さ
固定長
標準形：13桁、短縮形：8桁

チェックディジット
モジュラス10

細いバーと太いバーの標準的な比率
1:2:3:4

コードの桁数
コードを13桁または8桁で指定する場合は、末尾にチェックディジットをつけてください。
12桁または7桁で指定した場合は、レポートライブラリが末尾にチェックディジットをつけます。

その他
実際に描画されるコードは、JAN標準形の場合は13桁、JAN短縮形の場合は8桁です。
Barcodeプロパティには、実際に描画されたコードが返ります。
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータは「上記のバイト数＋NULL文字1バイト」の領域を確保しておきます。


バーコードCODE39

バーコード　ＣＯＤＥ３９

CODE39は、使用可能な文字数が多く誤読率が低いため、官民各業界の規格に採用されています。

使用可能なキャラクタセット
数字（0～9）、アルファベット（A～Z）、記号（-.$/+%スペース）
スタート・ストップキャラクタ（*）
※スタート・ストップキャラクタは、ジャイブレポートが自動で付加します。

シンボルの長さ
可変長
※ジャイブレポートでは50桁まで設定可能です。

チェックディジット
モジュラス43
※チェックディジット付きを選択した場合、ストップキャラクタの前にチェックディジットを付加します。

細いバーと太いバーの標準的な比率
最小バー幅が0.508mm以下のとき1:2.2～3.0、
最小バー幅が0.508mmを超えるとき1:2.0～3.0

キャラクタ間ギャップ
標準値は、最小バー幅が0.25mm未満のとき、最小バー幅×5.3、
最小バー幅が0.25mm以上のとき、最小バー幅×3または1.35mmの大きい方の値

その他
実際に描画されるコードは、「入力コード＋スタート・ストップキャラクタ（2桁）」です。
チェックディジット付きを指定した場合は「チェックディジット（1桁）」の分が追加されます。
Barcodeプロパティには、実際に描画されたコードが返ります。
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータは「上記のバイト数＋NULL文字1バイト」の領域を確保しておきます。


バーコードNW7

バーコード　ＮＷ７

NW7は、CODABARとも呼ばれています。

使用可能なキャラクタセット
数字（0～9）、記号（-$:/.+）
スタートストップキャラクタ（A～D）

シンボルの長さ
可変長
※ジャイブレポートでは50桁まで設定可能です。

チェックディジット
モジュラス16
※チェックディジット付きの場合、ストップキャラクタの前にチェックディジットを付加します。

細いバーと太いバーの標準的な比率
最小バー幅が0.508mm以下のとき1:2.2～3.0、
最小バー幅が0.508mmを超えるとき1:2.0～3.0

キャラクタ間ギャップ
標準値は、最小バー幅が0.25mm未満のとき、最小バー幅×5.3、
最小バー幅が0.25mm以上のとき、最小バー幅×3または1.35mmの大きい方の値

その他
実際に描画されるードは、「入力コード」です。
チェックディジット付きを指定した場合は「チェックディジット（1桁）」の分が追加されます。
Barcodeプロパティには、実際に描画されたコードが返ります。
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータは「上記のバイト数＋NULL文字1バイト」の領域を確保しておきます。


バーコードITF

バーコード　ＩＴＦ

ITFは、標準物流シンボルに使われるバーコードです。
文字密度が大きい、誤読率が低い、粗面への印刷が他に比べて容易などの特長を持っています。

使用可能なキャラクタセット
数字（0～9）

シンボルの長さ
可変長
※ジャイブレポートでは50桁まで設定可能です。

チェックディジット
モジュラス10

コードの桁数
コードに奇数の桁数を指定した場合は、レポートライブラリが末尾にチェックディジットを付加し偶数桁にします。

細いバーと太いバーの標準的な比率
最小バー幅が0.508mm以下のとき1:2.2～3.0、
最小バー幅が0.508mmを超えるとき1:2.0～3.0

その他
実際に描画されるコードは、「入力コード」です。
入力コードの桁数が奇数の場合は「チェックディジット（1桁）」の分が追加されます。
Barcodeプロパティには、実際に描画されたコードが返ります。
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータは「上記のバイト数＋NULL文字1バイト」の領域を確保しておきます。


バーコードCODE128(EAN128)

バーコード　ＣＯＤＥ１２８（EAN128）

CODE128は、機能キャラクタの使い分けで高度の情報伝達が可能なバーコードです。
CODE128を使用する場合は、CODE128キャラクタ構成表が必要です。
（バーコード関連書籍等で入手して下さい。）

使用可能なキャラクタセット
スタートキャラクタ：START CODE A,B,C
非データ機能文字：FNC 1,2,3,4
コードセット機能文字：CODE A,B,C、SHIFT
データ文字：ASCII 128文字
ストップキャラクタ

シンボルの長さ
可変長
※ジャイブレポートでは200バイトまで設定可能です。

チェックディジット
モジュラス103
必須

細いバーと太いバーの標準的な比率
1:2:3:4

コードの入力形式
コードは、ASCII文字に対応する数字をカンマ区切りで設定します。
最大100バイトまで設定できます。（カンマも1バイトとして数えます。）
例：105,102,12,34,56→16バイト
ストップキャラクタは、内部で自動的に付加します。

チェックディジット付きを指定した場合は、レポートライブラリがストップキャラクタの前にチェックディジットをつけます。
チェックディジットなしを指定した場合は、コードの末尾にチェックディジットをつけてください。

UCC/EAN128について
UCC/EAN128は、スタートキャラクタの後にFNC1(102)というキャラクタをつけます。
この2つのキャラクタのセットで始まるキャラクタの集まりがUCC/EAN128となります。
例）
EAN128でバーコード「123」を描画する場合は、以下の文字列をパラメータとして渡します。
「103,102,17,18,19」　または「105,102,17,18,19」
  ↑　↑　↑ ↑ ↑
  ①　②　③ ③ ③

①＝ｽﾀｰﾄｷｬﾗｸﾀ
②＝FNC1
③＝１、２、３

その他
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータや、Barcodeプロパティには、3桁のチェックディジットが返ります。
retCodeパラメータは「3バイト＋NULL文字1バイト」の領域を確保しておきます。
例）
retCode = Space(4)
ret = jvSetFieldBarcode(pid,"CODE128","103,102,33,34,35,36,37,38",retCode)


バーコードUPC

バーコード　ＵＰＣ

UPC-AバージョンとUPC-Eバージョンを描画することができます。
UPC-Aバージョンは12桁、UPC-Eバージョンは8桁で構成されます。

使用可能なキャラクタセット
数字（0～9）

シンボルの長さ
固定長
UPC-A：12桁、UPC-E：8桁

チェックディジット
モジュラス10

細いバーと太いバーの標準的な比率
1:2:3:4

コードの桁数
コードを12桁または8桁で指定する場合は、末尾にチェックディジットをつけてください。
11桁または7桁で指定した場合は、レポートライブラリが末尾にチェックディジットをつけます。

その他
実際に描画されるコードは、UPC-Aの場合は12桁、UPC-Eの場合は8桁です。
Barcodeプロパティには、実際に描画されたコードが返ります。
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータは「上記のバイト数＋NULL文字用バイト」の領域を確保しておきます。


カスタマバーコード

カスタマーバーコード（郵便）

カスタマーバーコードは、住所をバーコードで表現したものです。

使用可能なキャラクタセット
郵便番号と住所
郵便番号には、全角または半角の算用数字が使用できます。
丁目、番地を表す数字には、算用数字と漢数字を使用することができます。
例）
４６０００１１名古屋市中区大須一丁目二十五番二十八号
460-0011名古屋市中区大須1-25-28

シンボルの長さ
可変長
※カスタマーバーコードの仕様では長さ30文字までという制限があります。

バーの長さとバーの幅
カスタマバーコードは、4種類のバーで構成されます。
バーの幅はすべて同じで、長さの違いによってコードを表します。
ロングバーの長さは3.4mm～3.6mm、タイミングバーの長さは1.05mm～1.35mmで、3:1の比率になるように設定します。

バーの幅は0.5mm～0.7mm、スペースの幅は0.45mm～0.6mmで設定します。
基準値は、ロングバーが3.6mm、タイミングバーが1.2mm、バーの幅とスペースの幅が0.6mmです。

その他
jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータや、Barcodeプロパティには、住所表示番号（XX丁目XX番XX号の部分）が返ります。

retCodeパラメータには、住所表示番号を受け取るための充分なバッファを確保して下さい。
例）
barcode = “460-0011愛知県名古屋市中区大須一丁目25番28号”
ret = jvSetFieldBarcode(jid, "CST", barcode, retcode)
retcodeには、「1-25-28」が返ります。


QRコード

QRコードとは、日本で開発されたマトリックス型二次元コードの一つです。
高速に全方向での読み取りができ、多種のデータ表現が可能などの特長を持っています。

コードの大きさ
最小21×21モジュール～最大177×177モジュール
（縦横方向にそれぞれ4モジュール分のクワイエットゾーンが必要 ）

情報の種類及び情報量
数字 | 最大7,089文字
英数字 | 最大4,296文字
バイナリ（8ビット） | 最大2,953文字
漢字・カナ | 最大1,817文字
（混在も可能）
最大文字数は、誤り訂正レベルがレベルLの時の値です。他のレベルでは最大文字数は少なくなります。

誤り訂正能力（データ復元機能）
レベルL | コードワードの約7%が復元可能
レベルM | コードワードの約15%が復元可能
レベルQ | コードワードの約25%が復元可能
レベルH | コードワードの約30%が復元可能

誤り訂正レベルに高レベルを設定すると、復元率は高まりますが、誤り訂正コードの含有率が高くなるため、表現できる情報量は減少します。

型番
QRコードには、1～40までの40種類の型番があります。
型番によって、表現できる情報量が異なります。
1型21×21モジュール、2型25×25モジュール・・・40型177×177モジュール
（型番が1つ上がるごとに1辺につき4モジュールずつ増加）

マスク処理
マスク処理とは、QRコードの読み出しを確実にするため、明暗（白黒）のモジュールバランスを最適化する処理です。
8種類のパターンがあります。
QRコードがうまく読み取れない時には、マスクパターンを変更し読み取れるものを見つけます。

その他
１．型番に「自動」を指定すると、ジャイブレポートが最適な型番を自動選択します。
ジャイブレポートでは、表現する情報量より小さな型番を選択するとエラーになります。

2．マスク処理に「自動」を指定すると、ジャイブレポートが最適なマスクパターンを自動選択しますが、読み取れない時にはマスクパターンを変更してください。

3．QRコードは、小さなボックスの集合により描画されますが、プリンタによってボックスの太さに違いが出ます。
ボックスの太さは、jvSetLongファンクションや SetParamメソッドで微調整することができます。
大きすぎたり、小さすぎたりした場合には、微調整してください。

4．ジャイブレポートは、コード連結機能には対応していません。

5．QRコードの場合には、 Barcodeプロパティは使用できません。また、jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータには何も返りません。


マイクロQRコード

切り出しシンボルが一つという特長を持つマイクロQRコードは、QRコードより小型化され、小さなスペースにも印字可能です。

コードの大きさ
最小11×11モジュール～最大17×17モジュール
（型番が一つ上がるごとに一辺につき2モジュールずつ増加 ）

情報の種類及び情報量
数字 | 最大21文字
英数字 | 最大13文字
バイナリ（8ビット） | 最大9文字
漢字・カナ | 最大5文字
（混在も可能）
最大文字数は、誤り訂正レベルがレベルLの時の値です。他のレベルでは最大文字数は少なくなります。

誤り訂正能力（データ復元機能）
レベルL | コードワードの約7%が復元可能
レベルM | コードワードの約15%が復元可能
レベルQ | コードワードの約25%が復元可能

誤り訂正レベルに高レベルを設定すると、復元率は高まりますが、誤り訂正コードの含有率が高くなるため、表現できる情報量は減少します。

型番
マイクロQRコードには、1～4までの型番があります。

マスク処理
マスク処理とは、マイクロQRコードの読み出しを確実にするため、明暗（白黒）のモジュールバランスを最適化する処理です。
4種類のパターンがあります。
マイクロQRコードがうまく読み取れない時には、マスクパターンを変更し読み取れるものを見つけます。

その他
１．型番に「自動」を指定すると、ジャイブレポートが最適な型番を自動選択します。
ジャイブレポートでは、表現する情報量より小さな型番を選択するとエラーになります。

2．マスク処理に「自動」を指定すると、ジャイブレポートが最適なマスクパターンを自動選択しますが、読み取れない時にはマスクパターンを変更してください。

3．マイクロQRコードは、小さなボックスの集合により描画されますが、プリンタによってボックスの太さに違いが出ます。
ボックスの太さは、jvSetLongファンクションや SetParamメソッドで微調整することができます。
大きすぎたり、小さすぎたりした場合には、微調整してください。

4．マイクロQRコードの場合には、 Barcodeプロパティは使用できません。また、jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータには何も返りません。


PDF417コード

PDF417コードは、スタック型の二次元バーコードです。多くの情報量を必要とする用途で使用されています。

最大情報量
英数字1850字、数字2710桁。
漢字、図形、画像、音声等もコード化可能。

コードワード
1行当り最小1、最大30、シンボル当り最小3行、最大90行。
各段は、スタートパターン、左右の段インジケータ、１個～30個のシンボルキャラクタ、ストップパターンで構成されます。

誤り訂正能力（データ復元機能）
誤り訂正レベルに高レベルを設定すると、復元率は高まりますが、誤り訂正コードの含有率が高くなるため、表現できる情報量は減少します。

縦横比率
印字するスペースの制約に応じて比率を設定できます。

その他
１．PDF417コードの場合には、 Barcodeプロパティは使用できません。また、jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータには何も返りません。


マイクロPDF417コード

マイクロPDF417コードは、スタック型の二次元バーコードです。PDF417コードを簡略化させ小型化を図ったコードです。

最大情報量
英数字250字、数字366桁。
漢字等もコード化可能。

サイズ
1行当り最小1、最大30、シンボル当り最小3行、最大90行。
各段は、スタートパターン、左右の段インジケータ、１個～30個のシンボルキャラクタ、ストップパターンで構成されます。

縦横比率
印字するスペースの制約に応じて比率を設定できます。

その他
１．マイクロPDF417コードの場合には、 Barcodeプロパティは使用できません。また、jvDrawBarcodeファンクションとjvSetFieldBarcodeファンクションのretCodeパラメータには何も返りません。


DrawBarcodeのbarsize設定値

DrawBarcode／jvDrawBarcode のbarsize設定値

DrawBarcodeメソッドやjvDrawBarcode関数を使ってQRコード、マイクロQRコード、PDF417コード、マイクロPDF417コードを描画する場合、barsize パラメータには、次の値を指定します。

データ間はカンマで区切ります。

QRコード、マイクロQRコード | 誤り訂正レベル、型番、マスク処理（未設定の場合エラーになります）
PDF417コード | 誤り訂正レベル、列数、行数、縦横比率
マイクロPDF417コード | サイズ、縦横比率

[ QRコードの場合 ]

QRコードでは、barsize の誤り訂正レベルに次の値を指定します。

定数 | 値 | 内容
JV_QR_LEVEL_L | 0 | 約7%が復元可能
JV_QR_LEVEL_M | 1 | 約15%が復元可能
JV_QR_LEVEL_Q | 2 | 約25%が復元可能
JV_QR_LEVEL_H | 3 | 約30%が復元可能

QRコードでは、barsize の型番に次の値を指定します。
定数 | 値 | 内容
JV_QR_TYPE_AUTO | 0 | 自動
1～40 |  | 型番1～40

QRコードでは、barsize のマスク処理に次の値を指定します。

定数 | 値 | 内容
0～7 |  | パターン0～7
JV_QR_MASKNO_AUTO | 8 | 自動

[ マイクロQRコードの場合 ]

マイクロQRコードでは、barsize の誤り訂正レベルに次の値を指定します。

定数 | 値 | 内容
JV_QR_LEVEL_L | 0 | 約7%が復元可能
JV_QR_LEVEL_M | 1 | 約15%が復元可能
JV_QR_LEVEL_Q | 2 | 約25%が復元可能

マイクロQRコードでは、barsize の型番に次の値を指定します。
定数 | 値 | 内容
JV_QR_TYPE_AUTO | 0 | 自動
JV_QR_KATABAN_M1 | 1 | 型番1
JV_QR_KATABAN_M2 | 2 | 型番2
JV_QR_KATABAN_M3 | 3 | 型番3
JV_QR_KATABAN_M4 | 4 | 型番4

マイクロQRコードでは、barsize のマスク処理に次の値を指定します。

定数 | 値 | 内容
0、1、2、3 |  | 型番1～3
JV_QR_MASKNO_AUTO | 8 | 自動

[ PDF417コードの場合 ]

PDF417コードでは、barsize の誤り訂正レベルに次の値を指定します。

定数 | 値 | 内容
0～9 |  | 誤り訂正レベル0～9
JV_PDF417_ERROR_AUTO | 9 | 自動

PDF417コードでは、barsize の列数に 1～30 の値を指定します。

PDF417コードでは、barsize の行数に 3～90 の値を指定します。

PDF417コードでは、barsize の縦横比率に 10～1000（幅／高さ％） の値を指定します。

[ マイクロPDF417コードの場合 ]

マイクロPDF417コードでは、barsize のサイズに次の値を指定します。
定数 | 値 | 内容
JV_MICROPDF417_SIZE_AUTO | 0 | 自動
JV_MICROPDF417_SIZE_1X11 | 1 | 列数 1 : 行数 11
JV_MICROPDF417_SIZE_1X14 | 2 | 列数 1 : 行数 14
JV_MICROPDF417_SIZE_1X17 | 3 | 列数 1 : 行数 17
JV_MICROPDF417_SIZE_1X20 | 4 | 列数 1 : 行数 20
JV_MICROPDF417_SIZE_1X24 | 5 | 列数 1 : 行数 24
JV_MICROPDF417_SIZE_1X28 | 6 | 列数 1 : 行数 28
JV_MICROPDF417_SIZE_2X8 | 7 | 列数 2 : 行数 8
JV_MICROPDF417_SIZE_2X11 | 8 | 列数 2 : 行数 11
JV_MICROPDF417_SIZE_2X14 | 9 | 列数 2 : 行数 14
JV_MICROPDF417_SIZE_2X17 | 10 | 列数 2 : 行数 17
JV_MICROPDF417_SIZE_2X20 | 11 | 列数 2 : 行数 20
JV_MICROPDF417_SIZE_2X23 | 12 | 列数 2 : 行数 23
JV_MICROPDF417_SIZE_2X26 | 13 | 列数 2 : 行数 26
JV_MICROPDF417_SIZE_3X6 | 14 | 列数 3 : 行数 6
JV_MICROPDF417_SIZE_3X8 | 15 | 列数 3 : 行数 8
JV_MICROPDF417_SIZE_3X10 | 16 | 列数 3 : 行数 10
JV_MICROPDF417_SIZE_3X12 | 17 | 列数 3 : 行数 12
JV_MICROPDF417_SIZE_3X15 | 18 | 列数 3 : 行数 15
JV_MICROPDF417_SIZE_3X20 | 19 | 列数 3 : 行数 20
JV_MICROPDF417_SIZE_3X26 | 20 | 列数 3 : 行数 26
JV_MICROPDF417_SIZE_3X32 | 21 | 列数 3 : 行数 32
JV_MICROPDF417_SIZE_3X38 | 22 | 列数 3 : 行数 38
JV_MICROPDF417_SIZE_3X44 | 23 | 列数 3 : 行数 44
JV_MICROPDF417_SIZE_4X4 | 24 | 列数 4 : 行数 4
JV_MICROPDF417_SIZE_4X6 | 25 | 列数 4 : 行数 6
JV_MICROPDF417_SIZE_4X8 | 26 | 列数 4 : 行数 8
JV_MICROPDF417_SIZE_4X10 | 27 | 列数 4 : 行数 10
JV_MICROPDF417_SIZE_4X12 | 28 | 列数 4 : 行数 12
JV_MICROPDF417_SIZE_4X15 | 29 | 列数 4 : 行数 15
JV_MICROPDF417_SIZE_4X20 | 30 | 列数 4 : 行数 20
JV_MICROPDF417_SIZE_4X26 | 31 | 列数 4 : 行数 26
JV_MICROPDF417_SIZE_4X32 | 32 | 列数 4 : 行数 32
JV_MICROPDF417_SIZE_4X38 | 33 | 列数 4 : 行数 38
JV_MICROPDF417_SIZE_4X44 | 34 | 列数 4 : 行数 44

マイクロPDF417コードでは、barsize の縦横比率に10～1000（幅／高さ％）の値を指定します。


拡張機能ーフォントプロパティ

フォントプロパティの変更

拡張機能が設定されたテキストフィールドは、アプリケーション実行時に、フォントのプロパティを変更することができます。

拡張機能は、レポートエディタでフォームを作成する時、テキストフィールドに指定します。

変更可能なフォントプロパティは、種類、横幅拡大率、サイズ、色、イタリック、ボールドです。
※「フォントの自動調整」機能を指定した場合、種類、横幅拡大率、サイズを変更しても無効となります。

プロパティは、予約語、または、略式の予約語をプログラムコードの中に記述して変更します。
文字列の前に予約語と変更する値が記述されると、それ以降の文字列は指定されたプロパティで描画されます。
元に戻す場合には、再び予約語と元のプロパティを記述します。

フォントの種類を変更する

書式 <font name="ＭＳ 明朝">
略式 <@FNＭＳ 明朝>

例）
stext1 = "地震保険契約を希望されない場合は<font name=""ＭＳ Pゴシック"">ご署名またはご捺印<font name=""ＭＳ 明朝"">下さい。"
ret = jvSetFieldText(pid, "Field_1", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@FNＭＳ Pゴシック>ご署名またはご捺印<@FNＭＳ 明朝>下さい。"
ret = jvSetFieldText(pid, "Field_2", stext1)

出力結果）

フォントの横幅拡大率を変更する

書式 <font wscale="110">
略式 <@FW110>
  拡大率はパーセント単位で設定します。設定可能な範囲は10 ～ 200です。初期値は100です。

例）
stext1 = "地震保険契約を希望されない場合は<font wscale=""120"">ご署名またはご捺印<font wscale=""100"">下さい。"
ret = jvSetFieldText(pid, "Field_3", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@FW120>ご署名またはご捺印<@FW100>下さい。"
ret = jvSetFieldText(pid, "Field_4", stext1)

出力結果）

フォントのサイズを変更する

書式 <font size="120">
略式 <@FS120>
  サイズは1/10ポイント単位で設定します。設定可能な範囲は1 ～ 1000です。

例）
stext1 = "地震保険契約を希望されない場合は<font size=""130"">ご署名またはご捺印<font size=""110"">下さい。"
ret = jvSetFieldText(pid, "Field_5", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@FS130>ご署名またはご捺印<@FS110>下さい。"
ret = jvSetFieldText(pid, "Field_6", stext1)

出力結果）

フォントの色を変更する

書式 <font color="#ff0000"> 赤に変える
略式 <@FC#ff0000> 赤に変える
  色の設定は16進数でRGB値を256深度で記述して下さい。例）　ff0000は赤、00ff00は緑

例）
stext1 = "地震保険契約を希望されない場合は<font color=""#ff0000"">ご署名またはご捺印<font color=""#000000"">下さい。"
ret = jvSetFieldText(pid, "Field_7", stext1)
略式で記述する場合
ret = jvSetFieldText(pid, "Field_8", stext1)

出力結果）

フォントをイタリックに変更する

書式 <font italic="true">　イタリックフォントに変える
書式 <font italic="false">　イタリックフォントを解除する
略式 <@FIT>　イタリックフォントに変える
略式 <@FIF>　イタリックフォントを解除する

例）
stext1 = "地震保険契約を希望されない場合は<font italic=""true"">ご署名またはご捺印<font italic=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_9", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@FIT>ご署名またはご捺印<@FIF>下さい。"
ret = jvSetFieldText(pid, "Field_10", stext1)

出力結果）

フォントをボールドに変更する

書式 <font bold="true">　ボールドフォントに変える
書式 <font bold="false">　ボールドフォントを解除する
略式 <@FBT>　ボールドフォントに変える
略式 <@FBF>　ボールドフォントを解除する

例）
stext1 = "地震保険契約を希望されない場合は<font bold=""true"">>ご署名またはご捺印<font bold=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_11", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@FBT>ご署名またはご捺印<@FBF>下さい。"
ret = jvSetFieldText(pid, "Field_12", stext1)

出力結果）


拡張機能ー文字の背景プロパティ

文字の背景プロパティの設定

拡張機能が設定されたテキストフィールドは、アプリケーション実行時に、文字の背景プロパティを設定することができます。

拡張機能は、レポートエディタでフォームを作成する時、テキストフィールドに指定します。

設定可能な文字の背景プロパティは、色、高さ、縦位置です。
※「フォントの自動調整」機能を指定した場合、縦位置を設定しても無効となります。

プロパティは、予約語、または、略式の予約語をプログラムコードの中に記述して変更します。
文字列の前に予約語と変更する値が記述されると、それ以降の文字列は指定されたプロパティで描画されます。
元に戻す場合には、再び予約語と元のプロパティを記述します。

文字の背景を描画する

書式 <background draw="true"> 文字の背景を描画する
書式 <background draw="false"> 文字の背景を描画しない(初期値)
略式 <@BDT> 文字の背景を描画する
略式 <@BDF> 文字の背景を描画しない(初期値)

文字の背景色を変更する

書式 <background color="#ff0000"> ※赤を指定
略式 <@BC#ff0000>※赤を指定
  色の設定は16進数でRGB値を256深度で記述して下さい。例）　ff0000は赤、00ff00は緑

例） 文字の背景色を指定し、背景を描画する

stext1 = "地震保険契約を希望されない場合は<background color=""#ff0000""><background draw=""true"">ご署名またはご捺印<background draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_13", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@BC#ff0000><@BDT>ご署名またはご捺印<@BDF>下さい。"
ret = jvSetFieldText(pid, "Field_14", stext1)

出力結果）

文字の背景の高さを変更する

書式 <background height="100">
略式 <@BH100>
  高さは1/100mm単位で設定します。設定可能な範囲は-300～300です。文字の高さに対して加算、減算されます。

文字の背景の縦位置を変更する

書式 <background vpos="-10">
略式 <@BV-10>
  位置は1/100mm単位で設定します。設定可能な範囲は-300～300です。プラス値は下方へ、マイナス値は上方へ移動します。

例） 文字の背景の高さ、背景の縦位置を指定し、背景を描画する

stext1 = "地震保険契約を希望されない場合は<background color=""#ff0000""><background height=""100""><background vpos=""-50""><background draw=""true"">ご署名またはご捺印<background draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_15", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@BC#ff0000><@BH100><@BV-50><@BDT>ご署名またはご捺印<@BDF>下さい。"
ret = jvSetFieldText(pid, "Field_16", stext1)

出力結果）


拡張機能ー下線プロパティ

下線プロパティの設定

拡張機能が設定されたテキストフィールドは、アプリケーション実行時に、下線プロパティを設定することができます。

拡張機能は、レポートエディタでフォームを作成する時、テキストフィールドに指定します。

設定可能な下線プロパティは、描画の有無、色、幅、位置、種類です。
※「フォントの自動調整」機能が設定されている場合、位置を設定しても無効となります。

プロパティは、予約語、または、略式の予約語をプログラムコードの中に記述して変更します。
文字列の前に予約語と変更する値が記述されると、それ以降の文字列は予約語と一緒に指定されたプロパティで描画されます。
元に戻す場合には、再び予約語と元のプロパティを記述します。

下線を描画する

書式 <underline draw="true"> 下線を描画する
書式 <underline draw="false"> 下線を描画しない(初期値)
略式 <@UDT> 下線を描画する
略式 <@UDF> 下線を描画しない(初期値)

下線の色を変更する

書式 <underline color="#ff0000"> 赤を指定
略式 <@UC#ff0000> 赤を指定
  色の設定は16進数でRGB値を256深度で記述して下さい。例）　ff0000は赤、00ff00は緑

例） 下線の色を指定し、下線を描画する

stext1 = "地震保険契約を希望されない場合は<underline color=""#ff0000""><underline draw=""true"">ご署名またはご捺印<underline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_17", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@UC#ff0000><@UDT>ご署名またはご捺印<@UDF>下さい。"
ret = jvSetFieldText(pid, "Field_18", stext1)

出力結果）

下線の幅を変更する

書式 <underlinewidth="10">
略式 <@UW10>
  幅は1/100mm単位で設定します。設定可能な範囲は0～100です。

下線の位置を変更する

書式 <underline vpos="-10">
略式 <@UV-10>
  位置は1/100mm単位で設定します。設定可能な範囲は-300～300です。プラス値は下方へ、マイナス値は上方へ移動します。

下線の種類を変更する

書式 <underline type="1">
略式 <@UT1>
  0:実線,1:破線,2:点線 ,3:一点鎖線,4:二点鎖線,5,二重線

例） 下線の幅、下線の位置を指定し、下線を描画する

stext1 = "地震保険契約を希望されない場合は<underline color=""#ff0000""><underline width=""80""><underline vpos=""-30""><underline draw=""true"">ご署名またはご捺印<underline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_19", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@UC#ff0000><@UW80><@UV-30><@UDT>ご署名またはご捺印<@UDF>下さい。"
ret = jvSetFieldText(pid, "Field_20", stext1)

出力結果）

例） 下線の種類を指定し、下線を描画する

stext1 = "地震保険契約を希望されない場合は<underline color=""#ff0000""><underline type=""2""><underline draw=""true"">ご署名またはご捺印<underline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_21", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@UC#ff0000><@UT2><@UDT>ご署名またはご捺印<@UDF>下さい。"
ret = jvSetFieldText(pid, "Field_22", stext1)

出力結果）


拡張機能打ち消し線プロパティ

打ち消し線プロパティの設定

拡張機能が設定されたテキストフィールドは、アプリケーション実行時に、打ち消し線プロパティを設定することができます。

拡張機能は、レポートエディタでフォームを作成する時、テキストフィールドに指定します。

設定可能な打ち消し線線プロパティは、描画の有無、色、幅、位置、種類です。
※「フォントの自動調整」機能が設定されている場合、位置を設定しても無効となります。

プロパティは、予約語、または、略式の予約語をプログラムコードの中に記述して設定します。
文字列の前に予約語と設定する値が記述されると、それ以降の文字列は予約語と一緒に指定されたプロパティで描画されます。
元に戻す場合には、再び予約語と元のプロパティを記述します。

打ち消し線を描画する

書式 <deleteline draw="true"> 打ち消し線を描画する
書式 <deleteline draw="false"> 打ち消し線を描画しない(初期値)
略式 <@DDT> 打ち消し線を描画する
略式 <@DDF> 打ち消し線を描画しない(初期値)

打ち消しの色を変更する

書式 <deleteline color="#ff0000"> 赤を指定
略式 <@DC#ff0000>赤を指定
  色の設定は16進数でRGB値を256深度で記述して下さい。例）　ff0000は赤、00ff00は緑

例） 打ち消し線の色を指定し、打ち消し線を描画する

stext1 = "地震保険契約を希望されない場合は<deleteline color=""#ff0000""><deleteline draw=""true"">ご署名またはご捺印<deleteline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_23", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@DC#ff0000><@DDT>ご署名またはご捺印<@DDF>下さい。"
ret = jvSetFieldText(pid, "Field_24", stext1)

出力結果）

打ち消し線の幅を変更する

書式 <deleteline width="10">
略式 <@DW10>
  幅は1/100mm単位で設定します。設定可能な範囲は0～100です。

打ち消し線の位置を変更する

書式 <deleteline vpos="-10">
略式 <@DV-10>
  位置は1/100mm単位で設定します。設定可能な範囲は-300～300です。プラス値は下方へ、マイナス値は上方へ移動します。

打ち消し線の種類を変更する

書式 <deleteline type="0">
略式 <@DT0>
  0:実線,1:破線,2:点線 ,3:一点鎖線,4:二点鎖線,5,二重線

例） 打ち消し線の幅、打ち消し線の位置を指定し、打ち消し線を描画する

stext1 = "地震保険契約を希望されない場合は<deleteline color=""#ff0000""><deleteline width=""80""><deleteline vpos=""-30""><deleteline draw=""true"">ご署名またはご捺印<deleteline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_25", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@DC#ff0000><@DW80><@DV-30><@DDT>ご署名またはご捺印<@DDF>下さい。"
ret = jvSetFieldText(pid, "Field_26", stext1)

出力結果）

例） 打ち消し線の種類を指定し、打ち消し線を描画する

stext1 = "地震保険契約を希望されない場合は<deleteline color=""#ff0000""><deleteline type=""2""><deleteline draw=""true"">ご署名またはご捺印<deleteline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_27", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@DC#ff0000><@DT2><@DDT>ご署名またはご捺印<@DDF>下さい。"
ret = jvSetFieldText(pid, "Field_28", stext1)

出力結果）


プリンタドライバ情報とは

プリンタドライバ情報とは、用紙サイズや用紙方向などの印刷設定値をカンマ区切りの文字列で表現した値です。この値をプリンタドライバに送って用紙サイズや用紙方向などのプロパティを変更することができます。

例）
A4用紙、縦方向で印刷する場合 → 1,9　　※この値はWindows準拠の値です。
B4用紙、横方向で印刷する場合 → 2,12

プリンタドライバ情報は、レポートライブラリOCXのPrinterDevModeプロパティ、レポートライブラリDLLのjvSetDevModeファンクション、プレビューコントロールのPrinterDevModeプロパティで使用します。これらのプロパティやファンクションで設定されたプリンタドライバ情報は、Windowsが使用するDEVMODE構造体に格納されます。プリンタドライバは、DEVMODE構造体に格納された値でプロパティを変更し印刷を行います。

以下にWindows準拠の値を紹介します。

注意1：プリンタドライバ情報は、項目間をカンマ区切りで記述しますが、カンマは省略できるものとできないものがあります。設定項目より前のカンマは省略できません。後ろのカンマは一般的には省略できますが、プリンタドライバによっては、カンマを省略すると有効にならないことがあります。

注意2：以下の項目にない特殊な内容を設定する場合や、プリンタドライバ情報ではコントロールできない場合は、プリンタドライバ設定ファイルを使う方法があります。

注意3：大半のプリンタドライバは以下の値で設定することができますが、独自の値を使用しているプリンタドライバもあり、以下の値では設定できないことがあります。

注意4：プリンタドライバが実際に使用しているプリンタドライバ情報は、レポートエディタやレポートライブラリから取得できます。プリンタドライバがうまくコントロールできない時や、ユーザー定義サイズの時は、プリンタドライバ情報値を取得して確認することが必要です。

－プリンタドライバ情報の取得方法
－プリンタドライバ設定ファイル

［設定（取得）順序と設定（取得）内容］※以下はWindows準拠の値です。

１．dmOrientation
用紙の向きを指定します。１（PORTRAIT）または２（LANDSCAPE）の値を取ります。

２．dmPaperSize
規定の用紙サイズを番号で指定します。dmPaperLengthとdmPaperWidthが設定されている場合は０をセットすることができます。この番号は、Windows/SDKでは以下の様に定義されていますが、プリンタドライバによっては独自の番号を使用しているものがあります。
  1. Letter 8 1/2 x 11 in
  2. Letter Small 8 1/2 x 11 in
  3. Tabloid 11 x 17 in
  4. Ledger 17 x 11 in
  5. Legal 8 1/2 x 14 in
  6. Statement 5 1/2 x 8 1/2 in
  7. Executive 7 1/4 x 10 1/2 in
  8. A3 297 x 420 mm
  9. A4 210 x 297 mm
  10. A4 Small 210 x 297 mm
  11. A5 148 x 210 mm
  12. B4 (JIS) 250 x 354
  13. B5 (JIS) 182 x 257 mm
  14. Folio 8 1/2 x 13 in
  15. Quarto 215 x 275 mm
  16. 10x14 in
  17. 11x17 in
  18. Note 8 1/2 x 11 in
  19. Envelope #9 3 7/8 x 8 7/8
  20. Envelope #10 4 1/8 x 9 1/2
  21. Envelope #11 4 1/2 x 10 3/8
  22. Envelope #12 4 \276 x 11
  23. Envelope #14 5 x 11 1/2
  24. C size sheet
  25. D size sheet
  26. E size sheet
  27. Envelope DL 110 x 220mm
  28. Envelope C5 162 x 229 mm
  29. Envelope C3 324 x 458 mm
  30. Envelope C4 229 x 324 mm
  31. Envelope C6 114 x 162 mm
  32. Envelope C65 114 x 229 mm
  33. Envelope B4 250 x 353 mm
  34. Envelope B5 176 x 250 mm
  35. Envelope B6 176 x 125 mm
  36. Envelope 110 x 230 mm
  37. Envelope Monarch 3.875 x 7.5 in
  38. 6 3/4 Envelope 3 5/8 x 6 1/2 in
  39. US Std Fanfold 14 7/8 x 11 in
  40. German Std Fanfold 8 1/2 x 12 in
  41. German Legal Fanfold 8 1/2 x 13 in
  42. B4 (ISO) 250 x 353 mm
  43. Japanese Postcard 100 x 148 mm
  44. 9 x 11 in
  45. 10 x 11 in
  46. 15 x 11 in
  47. Envelope Invite 220 x 220 mm
  48. RESERVED--DO NOT USE
  49. RESERVED--DO NOT USE
  50. Letter Extra 9 \275 x 12 in
  51. Legal Extra 9 \275 x 15 in
  52. Tabloid Extra 11.69 x 18 in
  53. A4 Extra 9.27 x 12.69 in
  54. Letter Transverse 8 \275 x 11 in
  55. A4 Transverse 210 x 297 mm
  56. Letter Extra Transverse 9\275 x 12 in
  57. SuperA/SuperA/A4 227 x 356 mm
  58. SuperB/SuperB/A3 305 x 487 mm
  59. Letter Plus 8.5 x 12.69 in
  60. A4 Plus 210 x 330 mm
  61. A5 Transverse 148 x 210 mm
  62. B5 (JIS) Transverse 182 x 257 mm
  63. A3 Extra 322 x 445 mm
  64. A5 Extra 174 x 235 mm
  65. B5 (ISO) Extra 201 x 276 mm
  66. A2 420 x 594 mm
  67. A3 Transverse 297 x 420 mm
  68. A3 Extra Transverse 322 x 445 mm
  69. Japanese Double Postcard 200 x 148 mm
  70. A6 105 x 148 mm
  71. Japanese Envelope Kaku #2
  72. Japanese Envelope Kaku #3
  73. Japanese Envelope Chou #3
  74. Japanese Envelope Chou #4
  75. Letter Rotated 11 x 8 1/2 11 in
  76. A3 Rotated 420 x 297 mm
  77. A4 Rotated 297 x 210 mm
  78. A5 Rotated 210 x 148 mm
  79. B4 (JIS) Rotated 364 x 257 mm
  80. B5 (JIS) Rotated 257 x 182 mm
  81. Japanese Postcard Rotated 148 x 100 mm
  82. Double Japanese Postcard Rotated 148 x 200 mm
  83. A6 Rotated 148 x 105 mm
  84. Japanese Envelope Kaku #2 Rotated
  85. Japanese Envelope Kaku #3 Rotated
  86. Japanese Envelope Chou #3 Rotated
  87. Japanese Envelope Chou #4 Rotated
  88. B6 (JIS) 128 x 182 mm
  89. B6 (JIS) Rotated 182 x 128 mm
  90. 12 x 11 in
  91. Japanese Envelope You #4
  92. Japanese Envelope You #4 Rotated
  93. PRC 16K 146 x 215 mm
  94. PRC 32K 97 x 151 mm
  95. PRC 32K(Big) 97 x 151 mm
  96. PRC Envelope #1 102 x 165 mm
  97. PRC Envelope #2 102 x 176 mm
  98. PRC Envelope #3 125 x 176 mm
  99. PRC Envelope #4 110 x 208 mm
  100. PRC Envelope #5 110 x 220 mm
  101. PRC Envelope #6 120 x 230 mm
  102. PRC Envelope #7 160 x 230 mm
  103. PRC Envelope #8 120 x 309 mm
  104. PRC Envelope #9 229 x 324 mm
  105. PRC Envelope #10 324 x 458 mm
  106. PRC 16K Rotated
  107. PRC 32K Rotated
  108. PRC 32K(Big) Rotated
  109. PRC Envelope #1 Rotated 165 x 102 mm
  110. PRC Envelope #2 Rotated 176 x 102 mm
  111. PRC Envelope #3 Rotated 176 x 125 mm
  112. PRC Envelope #4 Rotated 208 x 110 mm
  113. PRC Envelope #5 Rotated 220 x 110 mm
  114. PRC Envelope #6 Rotated 230 x 120 mm
  115. PRC Envelope #7 Rotated 230 x 160 mm
  116. PRC Envelope #8 Rotated 309 x 120 mm
  117. PRC Envelope #9 Rotated 324 x 229 mm
  118. PRC Envelope #10 Rotated 458 x 324 mm
256 User

３．dmPaperLength
このメンバーは、ユーザー定義サイズなどの不定形の用紙を設定する場合に使用します。用紙の長さを1/10mm単位で設定します。dmPaperSizeより優先します。

４．dmPaperWidth
このメンバーは、ユーザー定義サイズなどの不定形の用紙を設定する場合に使用します。用紙の幅を1/10mm単位で設定します。dmPaperSizeより優先します。

５．dmScale
印刷する倍率を%単位で設定します。

６．dmCopies
印刷する部数を設定します。プリンタが複数ページのコピー印刷をサポートする場合にのみ有効です。

７．dmDefaultSource
予約領域。必ず0を設定してください。

８．dmPrintQuality
プリンタの解像度を設定します。

９．dmColor
カラー プリンタの場合、カラーで出力するかモノクロで出力するかを指定します。１（モノクロ）または２（カラー）の値をセットします。

１０．dmDuplex
両面印刷が可能なプリンタの場合に､ 両面印刷の方法を選択します。１（SIMPLEX）、２（VERTICAL）、３（HORIZONTAL）のいずれかの値をセットします。

１１．dmYResolution
プリンタのy方向の解像度をDPIで示します。

１２．dmTTOption
TrueType(R) フォントの印刷方法を指定します。１（グラフィックとして印刷）、２（ソフトフォントとしてダウンロード）、３（デバイスフォントで代替）のいずれかの値をセットします。

１３．dmCollate
複数部数を印刷する際に､ ページの丁合いを行うかどうかを指定します。１（丁合いを行う）または０（丁合いを行わない）の値をセットします。


プリンタドライバ情報の取得

プリンタドライバ情報は、レポートエディタやレポートライブラリから取得できます。

○レポートライブラリ
レポートライブラリから取得する場合は、以下の機能を使います。

レポートライブラリDLL／JNI：jvGetPrinterDevMode
レポートライブラリOCX／.NETコントロール：PrinterDevMode、PrinterName

○レポートエディタ
レポートエディタから取得する場合は、以下の手順で行ないます。

A4やB5などの規定の用紙サイズの場合

1．レポートエディタを起動します。
2．「ファイル／環境設定」で環境設定画面を開きます。
3．「プリンタ設定時にプリンタ情報をコピーする」をチェックして環境設定画面を閉じます
4．「ファイル／印刷」で印刷ダイアログを開きます。
5．「プリンタの設定」ボタンでプリンタのプロパティ設定画面を開きます。
6．プリンタのプロパティ設定画面で、使用するプリンタを選択します。
7．用紙サイズや用紙方向などの必要な項目をすべて設定します。
8．プロパティ設定画面で、OK（または印刷）ボタンを押します。
9．「プリンタ情報をコピーしました」というメッセージが出て、取得したプリンタ情報はクリップボードにコピーされます。
10．印刷ダイアログの終了ボタンを押して印刷ダイアログを閉じます。
11．レポートエディタ上で固定文字を選択し「貼り付け」を行うと、クリップボードにコピーされたプリンタ情報を目で確認することができます。
プリンタ情報は、例えば「1,9,,,・・・」のようなカンマ区切りの値です。

ユーザー定義サイズ（A4やB5などの規定サイズ以外）の場合

1．印刷を実行するPCで、次の1～5の方法で用紙を作成します。
2．コントロールパネルのプリンタからプリンタ画面を開きます。
3．「ファイル／サーバーのプロパティ」でプリントサーバーのプロパティ画面を開きます。
4．用紙タブで「新しい用紙を作成する」をクリックします。
5．ユーザー定義サイズの寸法を入力し、「用紙の保存」ボタンで用紙を保存します。
ログインユーザーに用紙を作成する権限がない場合は用紙を作成できません。権限を設定するか、Administrator等の権限があるユーザーでログインしてください。
6．レポートエディタを起動します。
7．「ファイル／環境設定」で環境設定画面を開きます。
8．「プリンタ設定時にプリンタ情報をコピーする」をチェックして環境設定画面を閉じます
9．「ファイル／印刷」で印刷ダイアログを開きます。
10．「プリンタの設定」ボタンでプリンタのプロパティ設定画面を開きます。
11．プリンタのプロパティ設定画面で、使用するプリンタを選択します。
12．用紙サイズに5で保存したユーザー定義サイズを選択します。ここでユーザー定義サイズが選択できない時は、そのプリンタドライバがユーザー定義サイズに対応していないことになり、そのプリンタでは印刷できません。
13．プロパティ設定画面で、OK（または印刷）ボタンを押します。
14．「プリンタ情報をコピーしました」というメッセージが出て、取得したプリンタ情報はクリップボードにコピーされます。
15．印刷ダイアログの終了ボタンを押して印刷ダイアログを閉じます。
16．レポートエディタ上で固定文字を選択し「貼り付け」を行うと、クリップボードにコピーされたプリンタ情報を目で確認することができます。
プリンタ情報は、例えば「1,16,,,・・・」のようなカンマ区切りの値です。

Windowsの仕様により、用紙番号は取得するPCによって異なります。値は印刷を実行するPCで取得してください。開発環境と実行環境が異なる場合は、開発完了時には、実行環境の値に変更する必要があります。


プリンタドライバ設定ファイル

プリンタドライバ設定ファイルとは、プリンタドライバのプロパティを設定するための値を保存したバイナリ形式のファイルです。
プリンタドライバ毎に内容やサイズが異なります。

１．プリンタドライバ設定ファイルは、プリンタドライバ情報より強力です。
プリンタドライバ情報でプリンタドライバをコントロールできない場合は、プリンタドライバ設定ファイルを使うとコントロールできることがあります。

２．プリンタドライバ設定ファイルでは、特殊な項目を設定することができます。
プリンタドライバ情報の設定項目は、どのプリンタにも共通する項目です。プリンタ独自の特殊な項目を設定する場合は、ドライバ設定ファイルを使います。

３．プリンタドライバ設定ファイルはプリンタに依存します。
プリンタドライバ設定ファイルは、作成したプリンタドライバ以外では使用できません。使用するプリンタドライバが複数ある場合は、各々のプリンタドライバ設定ファイルが必要です。

プリンタドライバ設定ファイルの作成

プリンタドライバ設定ファイルは、以下のファンクションやメソッドで作成します。

レポートライブラリDLL／JNI：jvMakeDevFileファンクション
レポートライブラリOCX／.NETコントロール：MakeDevFileメソッド

プリンタドライバ設定ファイルの使用

プリンタドライバ設定ファイルは、以下のファンクションやプロパティで使います。

レポートライブラリDLL／JNI：jvSetDevModeファンクション
レポートライブラリOCX／.NETコントロール： PrinterDevModeプロパティ
プレビューコントロール：PrinterDevModeプロパティ


プリンタドライバのレジストリ登録

プリンタドライバのレジストリ登録が必要な環境では、以下の手順でレジストリ登録を行います。

まず、デフォルトプリンタのプロパティダイアログを起動し、共有タブで”共有する”を指定します。
次に、．プリンタドライバのレジストリ登録を以下の手順で行います。
  1. 使用するプリンタをインストール済みのユーザーでログオンする
  2. regedit.exe を起動
  3. 次のキーを選択
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\Current Version\Devices
  4. [レジストリ] メニューから [レジストリ ファイルの書き出し] をクリック
  5. ファイル名に、"Devices.reg" と入力し保存
  6. 次のキーを選択
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\Current Version\PrinterPorts
  7. [レジストリ] メニューから [レジストリ ファイルの書き出し] をクリック
  8. ファイル名に、"PrinterPorts.reg" と入力し保存
  9. 次のキーを選択
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\Current Version\Windows
  10. [レジストリ] メニューから [レジストリ ファイルの書き出し] をクリック
  11. ファイル名に、"Windows.reg" と入力し保存
  12. メモ帳で Devices.reg ファイルを開く
  13. HKEY_CURRENT_USER を HKEY_USERS\.DEFAULT に変更する
  14. ファイルを上書き保存する。
  15. Windows ExplorerからDevices.regファイルをダブルクリックし、レジストリをインポート
  16. PrinterPorts.regファイルとWindows.regファイルに対し、ステップ12～15を繰り返す


Adobe PDFドキュメントの制限

Adobe PDFデータの制限

帳票をPDF形式で作成する時には、次の点を注意してください。

機能制限

１．次のグラフィックス機能は正常に描画できないことがあります。

  シャドウ、フェードアウト、ソフトエッジ、グラデーション、テクスチャ、
  カスタムブラシ、３Ｄ、文字変形、　EMFファイル描画機能。

２．UNICODEの外字は使用できません。

フォント

フォントは、MS明朝やMSゴシック等のTrue Typeフォントを使用してください。
True Type以外のフォントを使うと、正常に描画されないことがあります。

＜推奨フォント：＞
MS明朝、MSゴシック、MSP明朝、MSPゴシック、Courier New、Times New Roman、Arialなど

実行環境が変わっても、同じフォントで印刷したい場合には、フォントの埋め込み機能を使います。

－PDF形式データにフォントを埋め込む
－サロゲートペア

縦書きフォントを使用した場合には、縦書きフォントのみ自動で埋め込まれます。
サロゲートペアの文字を縦書きフォントで描画する場合には、影付き文字、フェードアウト、ソフトエッジ、３Ｄ文字は出力できません。

プリンタドライバ

レポートライブラリはプリンタドライバを使ってフォント情報を取得するため、アプリケーションを実行する環境にはプリンタドライバが必要です。

Adobe Readerのバージョン

Adobe Readerは、Version6.0以上を使用してください。


PDFドキュメントのセキュリティ

Adobe PDFデータのセキュリティ

帳票をPDF形式で作成する時に、パスワードや利用制限をつけてセキュリティを強化することができます。

パスワード

パスワードには、次の2種類を設定することができます。

1．オーナーパスワード
データの利用許可制限を設定する時に使うパスワードです。

2．ユーザーパスワード
データを利用する時に使うパスワードです。
ユーザーパスワードがついたデータは、開く時にパスワードの入力が必要です。
データに利用許可制限がつけられている場合は、制限内での利用となります。
ユーザーパスワードでは、利用許可制限を設定することはできません。

利用許可制限

次の4種類の利用許可制限をつけることができます。

1．文書の印刷
2．テキスト注釈及び対話フォームフィールド以外の文書内容の変更
3．文書からのテキストとグラフィックスのコピー
4．テキスト注釈および対話フォームフィールドの追加または変更

暗号化

高レベルの暗号化（128ビット）と、低レベルの暗号化（40ビット）を設定できます。
高レベルの暗号化は、Adobe Reader 5.0以降に対応しています。
（ジャイブレポートのPDF機能は、Adobe Reader 6.0以降の対応となります。 ）

各セキュリティ設定には、以下のプロパティまたはファンクションを使います。

レポートライブラリOCX／.NETコントロール ：SetParamメソッド
レポートライブラリDLL／JNI：jvSetString, jvSetLong
プレビューコントロール：SetParamメソッド


PDFドキュメントへのフォント埋め込み

Adobe PDFデータのフォント埋め込み

Adobe PDF形式のデータにはフォントを埋め込むことができます。

作成時と同じフォントで文字を描画

フォントを埋め込むと、作成時と同じフォントで文字を描画できます。
Linuxなどのフォントがない環境で利用する場合には、フォントを埋め込むと、作成時と同じフォントで文字を出力することができます。

作成した環境にのみ存在する特殊なフォントを使用した場合には、フォントを埋め込みます。
サロゲートペアの文字を使用した場合にも、フォントを埋め込みます。
フォントが埋め込まれなかった文字は、実行環境のフォントで文字が描画されるため、作成時とは異なる書体となることがあります。

埋め込むフォントの設定

埋め込みフォントの設定には、レポートライブラリOCXやレポートライブラリ.NETコントロールでは、EmbedFontメソッドを使います。レポートライブラリDLLやレポートライブラリJNIでは、jvSetStringファンクションを使います。

これらのメソッドやファンクションでは、特定のフォントのみを設定することもできますが、「*」 を使って、帳票の中で使用するすべてのフォントを埋め込むように設定することもできます。
個別に指定した場合、帳票の中で使われているフォントの指定漏れがあっても、そのフォントのフォントサブセットは埋め込まれません。

フォントを埋め込むと、データサイズが大きくなります。実行環境に必ず存在するフォントは、なるべく埋め込まないようにします。

指定できるフォントはTrue Typeフォントです。 True Type以外のフォントは埋め込むことができません。

埋め込まれるフォントとは

埋め込みフォントを指定すると、文字を描画するために必要なフォントサブセットが、ファイルの中に埋め込まれます。
埋め込みを指定することができるフォントは以下のものです。

１．フォーム中の固定文字と固定グラフで出力される文字のフォント
２．フォーム中のテキストフィールド・グリッドフィールド・グラフフィールドで出力される文字 のフォント
３．レポートライブラリの文字描画機能で出力される文字のフォント
４．レポートライブラリのグラフ描画機能で出力される文字のフォント

フォントの埋め込みエラー

埋め込むフォントファイルが実行環境になかったり、True Type以外のフォントを指定したりするとエラーが発生します。
エラーの発生場所は次の通りです。

１．埋め込むフォントを個別に指定した場合
EmbedFontやjvSetString で、フォント名を一つ一つ個別に指定した時には、問題となるフォントを指定したEmbedFontやjvSetString の実行時にエラーが発生します。

２．すべてのフォントを指定した場合
EmbedFontやjvSetString で 、「*」 を使ってすべてのフォントを指定した時には、次の箇所でエラーが発生します。

①フォーム中に問題となるフォントがあった時
DrawForm、jvDrawForm、jvDrawSection 実行時にエラーが発生します。

②レポートライブラリのフォント設定機能で指定したフォントに問題があった時
FontName、jvSetFont を使ってフォントを設定する時にエラーが発生します。

③レポートライブラリのグラフ描画機能で指定したフォントに問題があった時
DrawGraph、jvDrawGraph 実行時にエラーが発生します。

エラーフォント名の取得

エラー原因となったフォント名を取得することができます。

１．レポートライブラリOCX、レポートライブラリ.NETコントロール
エラーが発生した時のエラーメッセージの中に、エラー原因のフォント名が入っています。

２．レポートライブラリDLL、レポートライブラリJNI
エラーが発生した直後に、jvGetString を使ってエラー原因のフォント名を取得することができます。

埋め込み文字コードエラー

描画する文字列中に、フォントファイルの中にフォントサブセットがない特殊な文字コードが使われている場合には、その文字を埋め込む時にエラーが発生します。エラーの発生場所は次の通りです。

１．フォームの固定文字・固定グラフ・テキストフィールド・グリッドフィールド・グラフフィールドで出力される文字列の中に問題となる文字があった時
DrawForm、jvDrawForm、jvDrawSection 実行時にエラーが発生します。

２．レポートライブラリの文字描画機能で描画する文字列中に問題となる文字があった時
DrawText、jvDrawText、jvDrawTextW 実行時にエラーが発生します。

３．レポートライブラリのグラフ描画機能で描画する文字列中に問題となる文字があった時
DrawGraph、jvDrawGraph 実行時にエラーが発生します。

エラー文字コードの取得

エラー原因となった文字コードを取得することができます。

１．レポートライブラリOCX、レポートライブラリ.NETコントロール
エラーが発生した時のエラーメッセージの中に、エラー原因の文字コードが表示されます。

２．レポートライブラリDLL、レポートライブラリJNI
エラーが発生した直後に、jvGetLong を使って問題となった文字コードを取得することができます。


PDFフォーム機能

Adobe PDFのフォーム機能

Adobe PDFのフォームを作ることができます。
フォームでは、データを入力したり、項目を選択したりすることができます。

フォーム作成に使用できる機能

入力ボックスフィールド、チェックボックス、ラジオボタンの3種類を設定できます。
※ラジオボタン型は、可変長モードでは使用できません。

注意：
作成されたPDFファイルをAdobe Acrobat Reader 以外のツールで表示した場合には、Adobe Acrobat Reader の場合とは異なる動きをすることがあります。

フォームのオーバーレイ登録


Adobe PDF形式データのオーバーレイ登録

Adobe PDFデータのオーバーレイ登録

PDF形式のデータを出力する時に、フォームの固定部分をオーバーレイ登録することができます。
同じフォーマットの帳票が複数ページ続く場合には、何度も繰り返される固定部分をオーバーレイ登録することで、出力するデータ量を減らすことができます。出力されるページ数が多い場合に効果を発揮します。

オーバーレイ登録は、レポートエディタとレポートライブラリのどちらからも設定できます。

１．レポートエディタで設定する

オーバーレイ登録は、ファイル情報画面で設定します。

「PDF出力時にフォームオーバーレイ登録を行う」をチェックすると、レポートライブラリを使ったアプリケーションからPDF形式の帳票を出力する時や、レポートエディタから帳票印刷モードでPDF形式の帳票を出力する時に、帳票の固定部分がオーバーレイ登録されます。

２．レポートライブラリで設定する

オーバーレイ登録の設定には、以下のプロパティやファンクションを使います。

レポートライブラリOCX／.NETコントロール ：SetParamメソッド
レポートライブラリDLL／JNI： jvSetLong
プレビューコントロール：SetParamメソッド

オーバーレイ登録を利用する場合の注意：
オーバーレイ登録の出力では、まず、フォームの固定部分としての罫線やボックスが描画され、その後で、フィールドが描画されまず。そのため、フィールドは、常に固定部分の上に描画されます。罫線やボックスをフィールドの上から上書きする場合には、固定部分にせず、プログラムの中から描画するようにしてください。


外字の描画

帳票に外字を使用する場合、帳票を作成する環境には、使用する外字が必要です。
外字は、以下のどちらかの方法で実行環境に準備しておきます。

１．外字フォントを使う方法（下記参照）
２．ジャイブレポート外字ファイルを使う方法（下記参照）

RDF形式やAdobe PDF形式の帳票では、外字は、イメージに変換されてデータの中に埋め込まれます。
変換された外字イメージは透過ではありません。文字や図形などのオブジェクトを外字と重ねあわせて配置している場合には、外字の下になったオブジェクトは、きれいに印刷されないことがあります。

TIFF形式、XPS形式、JPEG形式、PNG形式、BMP形式の帳票では、外字はイメージの一部として帳票に描画されます。
外字では、影付き文字、フェードアウト、ソフトエッジ、３Ｄ文字、文字の変形機能は利用できません。

１．外字フォントを使う方法

帳票を作成する環境に、帳票で使用する外字フォントをインストールしておきます。
アプリケーションが実行されると、レポートライブラリは、外字フォントを使って帳票を作成します。
レポートライブラリは、外字を描画する時にプリンタドライバを使います。実行環境にはプリンタドライバのインストールが必要です。カラーの外字を描画する時は、カラー対応のプリンタドライバが必要です。

（注意）
サーバー環境がIIS7以降でWebアプリケーションの場合は、この方法では外字を描画できません。
２のジャイブレポート外字ファイルを使用してください。

２．ジャイブレポート外字ファイルを使う方法

レポートエディタでジャイブレポート外字ファイルを作成し、帳票を作成する環境にコピーします。
アプリケーションが実行されると、レポートライブラリは、ジャイブレポート外字ファイルを使って帳票を作成します。

－ジャイブレポート外字ファイルの使い方

注意：
・外字は、フォームファイルには埋め込まれません。フォームに外字が含まれる時は、帳票を作成する環境に、外字フォントまたはジャイブレポート外字ファイルを用意します。
・レポートエディタからフォームファイルをRDFファイルに保存した場合には、外字はRDFファイルにイメージで埋め込まれます。


外字ファイル

ジャイブレポート外字ファイルの使い方

外字フォントを使わず、ジャイブレポート専用の外字ファイルを使って外字を描画することができます。
ジャイブレポート外字ファイルを使用すると、OSなどの環境に左右されることがありません。

※IIS7以降の環境でWebアプリケーションから外字を出力する場合は、ジャイブレポート外字ファイルを使います。

ジャイブレポート外字ファイルを使って外字を出力する場合は、以下の手順で行います。

１．レポートエディタを使って、ジャイブレポート外字ファイルを作成します。

－レポートエディタでジャイブレポート外字ファイルを作る

２．レポートライブラリで、次の機能を使ってジャイブレポート外字ファイル名を指定します。

レポートライブラリOCX／.NETコントロール：　SetParam メソッド
レポートライブラリDLL／JNI：　 jvSetString ファンクション

３．アプリケーションを実行する環境に、１のジャイブレポート外字ファイルをコピーします。

４．アプリケーションを実行します。

１から４の手順で作成した帳票には、外字が埋め込まれています。
外字のない環境でも、外字を含む帳票のプレビューや印刷を行うことができます。


変形文字

変形文字は、以下の手順で作成します。
１．文字ツールで画面上に文字を入力します。
２．文字プロパティ画面を開き、フォントタブで、フォント名とサイズを設定します。
３．変形タブで、変形したいタイプを選択します。
４．変形度のバーで変形の度合いを調節します。
※「文字の描画／文字プロパティの設定／変形タブ」にも説明があります。

変形タブ

・フォントサイズを大きくし、フォント横幅拡大率を縮小するときれいに変形します。
・円形や斜めのタイプは、Trueタイプフォントにするときれいです。

・円形タイプは、変形度100の時、先頭と末尾の文字が重なります。変形度80～90程度の時、文字が重ならず円形になります。

例１．

この文字と図形は以下の値で作成しました。

「JiveReport」
＜ﾌｫﾝﾄ＞種類：MS明朝、ﾌｫﾝﾄｻｲｽﾞ：21ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：90％
＜文字変形＞ﾊﾟﾀｰﾝ：19番目
＜描画領域＞Width：1701、Height：2070
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：黒、2色：白、種類：縦、ﾊﾞﾘｴｰｼｮﾝ：左右
「HELP」
＜ﾌｫﾝﾄ＞種類：MS明朝、ﾌｫﾝﾄｻｲｽﾞ：35ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：65％
＜文字変形＞ﾊﾟﾀｰﾝ：6番目、変形度：80
＜描画領域＞Width：1225、Height：1110
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：赤、2色：黄、種類：縦、ﾊﾞﾘｴｰｼｮﾝ：左右
「version7」
＜ﾌｫﾝﾄ＞種類：MS明朝、ﾌｫﾝﾄｻｲｽﾞ：35ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：65％
＜文字変形＞ﾊﾟﾀｰﾝ：1番目、変形度：80
＜描画領域＞Width：1885、Height：1907
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：紫、2色：白、種類：縦、ﾊﾞﾘｴｰｼｮﾝ：左右
図形（楕円）
＜ｿﾌﾄｴｯｼﾞ＞色：赤、ｻｲｽﾞ：7.00mm
＜ｿﾌﾄｴｯｼﾞ＞色：緑、ｻｲｽﾞ：7.00mm
＜ｿﾌﾄｴｯｼﾞ＞色：青、ｻｲｽﾞ：7.00mm

例２．

この文字と図形は以下の値で作成しました。

「帳票作成ツール」
＜ﾌｫﾝﾄ＞種類：HGｺﾞｼｯｸE、ﾌｫﾝﾄｻｲｽﾞ：20ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：90％、ﾎﾞｰﾙﾄﾞ、前景色：白
＜描画領域＞Width：2516、Height：1602
＜輪郭線＞実線：0.20ﾐﾘ、色：赤
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：0.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度40%、ｿﾌﾄｴｯｼﾞ：1.50mm
「version7」
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：45ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：45％、ﾎﾞｰﾙﾄﾞ、前景色：赤
＜描画領域＞Width：1991、Height：1157
＜輪郭線＞実線：0.61ﾐﾘ、色：黄
＜ﾌｪｰﾄﾞｱｳﾄ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：0.00mm、Y軸ｵﾌｾｯﾄ：3.00mm、色1：黒、色2：白
「JIVEREPORT」
＜ﾌｫﾝﾄ＞種類：Impact、ﾌｫﾝﾄｻｲｽﾞ：22ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：80％、ﾎﾞｰﾙﾄﾞ、前景色：ｵﾚﾝｼﾞ
＜描画領域＞Width：2445、Height：1920
＜輪郭線＞実線：0.61ﾐﾘ、色：白
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：0.00mm、Y軸ｵﾌｾｯﾄ：3.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度45%、ｿﾌﾄｴｯｼﾞ：2.00mm
図形（楕円）
＜ﾃｸｽﾁｬ＞種類：2番目、色相：0、明度：0、彩度：0
＜ﾌｪｰﾄﾞｱｳﾄ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：7.00mm、色1：黒、色2：白
「文字の描画／文字プロパティの設定／変形タブ」にも設定例があります。ご参照ください。


文字・図形の3D

文字の3Dは、以下の手順で作成します。
１．文字ツールで画面上に文字を入力します。
２．文字プロパティ画面を開き、フォントタブで、フォント名とサイズを設定します。
３．3Dタブで、スタイルに凸型、凹型のどちらかを選びます。
４．サイズバーで斜面サイズを設定します。値が大きい程斜面の面積が増え立体感が増します。
５．3Dの深さバーで、3Dの深さを設定します。値が大きい程3Dが深くなり立体感が強調されます。
※「文字の描画／文字プロパティの設定／3Dタブ」にも説明があります。

３Ｄタブ（文字）

図形（四角形／楕円）の3Dは、以下の手順で作成します。
１．四角形ツールで画面上に四角形を描画します。
２．図形プロパティ画面を開き、線種や線幅などの必要な項目を設定します。
３．3Dタブで、4種類のスタイルから3Dスタイルを選びます。
４．枠全体のサイズバーでイズを設定します。値が大きい程立体部分が増え立体感が増します。
５．枠の平坦部のサイズバーで立体上部の平坦部のサイズを設定します。
    この項目は、スタイルにより設定できない場合があります。
６．3Dの深さバーで、3Dの深さを設定します。値が大きい程3Dが深くなり立体感が強調されます
※「図形の描画／図形プロパティの設定／」にも説明があります。

３Ｄパネルタブ（図形）

・文字や図形の3Dでは、3Dの深さが25の時、文字や図形が光を浴びたように表現されます。

    ↑3Dの深さ「25」　　　↑3Dの深さ「40」

例１．

この文字と図形は以下の値で作成しました。

「JiveReport」
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：45ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：70％、ﾎﾞｰﾙﾄﾞ、前景色：ｵﾚﾝｼﾞ
＜描画領域＞Width：3375、Height：930
＜3D＞ｽﾀｲﾙ：凸型　ｻｲｽﾞ：100%　3Dの深さ：25
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度30%、ｿﾌﾄｴｯｼﾞ：2.00mm
四角形
＜線種＞線種：なし、角丸め：なし
＜3D＞ｽﾀｲﾙ：凸型　枠全体ｻｲｽﾞ：2.80ﾐﾘ　3Dの深さ：35
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：濃紺、2色：白、種類：中央から、ﾊﾞﾘｴｰｼｮﾝ：枠側から

例２．

この文字と図形は以下の値で作成しました。

「Ver7 HELP」
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：40ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：70％、ﾎﾞｰﾙﾄﾞ、前景色：白、文字ﾋﾟｯﾁ：-1ﾎﾟｲﾝﾄ
＜3D＞ｽﾀｲﾙ：凹型　ｻｲｽﾞ：100%　3Dの深さ：25
＜ﾌｪｰﾄﾞｱｳﾄ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：0.00mm、Y軸ｵﾌｾｯﾄ：3.00mm、色1：黒、色2：白
四角形
＜線種＞線種：なし、角丸め：4角
＜3D＞ｽﾀｲﾙ：凹型(3番目)、枠全体ｻｲｽﾞ：3.40ﾐﾘ、枠の平坦部のｻｲｽﾞ：1.60ﾐﾘ、3Dの深さ：35
＜ﾃｸｽﾁｬ＞種類：12番目、色相：0、明度：0、彩度：0
＜ｼｬﾄﾞｳ＞種類：上段6番目、X軸ｵﾌｾｯﾄ：5.00mm、Y軸ｵﾌｾｯﾄ：0.00mm、ｼｬﾄﾞｳｻｲｽﾞ90%、傾斜角度：45度、透明度50%、ｿﾌﾄｴｯｼﾞ：2.00mm
「文字の描画／文字プロパティの設定／変形タブ」にも設定例があります。ご参照ください。


特殊効果

特殊効果・塗り潰し効果

特殊効果は、以下の手順で作成します。
１．文字や図形を描画します。
２．特殊効果画面を開きシャドウ、フェードアウト、ソフトエッジのどれかを選択します。
３．細かな設定を行います。
※各項目の説明は、「レポートエディタ／特殊効果」を参照してください。

特殊効果タブ

・図形（四角形、楕円、扇、弓、クローズした多角形）にシャドウとフェードアウトを設定する場合は、背景モードを「上書き」にしておきます。「透過」にすると、設定した塗り潰し効果の種類によっては、シャドウやフェードアウトが浮き出ることがあります。
塗り潰し効果は、以下の手順で作成します。
１．文字や図形を描画します。
２．塗り潰し効果画面を開きグラデーション、テクスチャ、パターンのどれかを選択します。
３．それぞれのタブで、細かな設定を行います。
※各項目の説明は、「レポートエディタ／塗り潰し効果」を参照してください。

塗り潰し効果タブ

・図形（四角形、楕円、扇、弓、クローズした多角形）の塗り潰し効果にパターンを設定し、特殊効果のシャドウやフェードアウトを付ける場合は、背景モードを「上書き」にします。背景モードを「透過」にすると、選択したパターンによっては、シャドウやフェードアウトが浮き上がります。

例１．

この文字と図形は以下の値で作成しました。

「JIVE」
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：40ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：110％、ﾎﾞｰﾙﾄﾞ、文字ﾋﾟｯﾁ：-1ﾎﾟｲﾝﾄ
＜輪郭線＞種類：実線、幅：0.60ﾐﾘ、色：白
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：青、2色：赤、種類：右上対角線、ﾊﾞﾘｴｰｼｮﾝ：右上から
＜ﾌｪｰﾄﾞｱｳﾄ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：4.00mm、Y軸ｵﾌｾｯﾄ：4.00mm、色1：黒、色2：白
四角形
＜線種＞線種：なし
＜ｸﾞﾗﾃﾞｰｼｮﾝ＞1色：緑、2色：黄、種類：右上対角線、ﾊﾞﾘｴｰｼｮﾝ：右上から
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：2.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度45%、ｿﾌﾄｴｯｼﾞ：2.00mm

例２．

この文字と図形は以下の値で作成しました。

「JIVE」
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：43ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：105％、ﾎﾞｰﾙﾄﾞ、文字ﾋﾟｯﾁ：-1ﾎﾟｲﾝﾄ
＜ﾃｸｽﾁｬ＞種類：18番目、色相：0、明度：0、彩度：0
＜ｼｬﾄﾞｳ＞種類：下段2番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：1.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度40%、ｿﾌﾄｴｯｼﾞ：1.50mm
四角形（下）
＜線種＞線種：なし
＜ﾃｸｽﾁｬ＞種類：18番目、色相：0、明度：0、彩度：0
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度50%、ｿﾌﾄｴｯｼﾞ：2.00mm
四角形（上）
＜線種＞線種：なし、前景色：白
＜ｼｬﾄﾞｳ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：1.00mm、Y軸ｵﾌｾｯﾄ：2.00mm、ｼｬﾄﾞｳｻｲｽﾞ100%、透明度50%、ｿﾌﾄｴｯｼﾞ：2.00mm

例３．

この文字と図形は以下の値で作成しました。

「REPORT」
＜ﾌｫﾝﾄ＞種類：Arial Black、ﾌｫﾝﾄｻｲｽﾞ：40ﾎﾟｲﾝﾄ、ﾌｫﾝﾄ横拡大率：90％、ﾎﾞｰﾙﾄﾞ、前景色：ﾋﾟﾝｸ、文字ﾋﾟｯﾁ：-1ﾎﾟｲﾝﾄ
＜3D＞ｽﾀｲﾙ：凸型　ｻｲｽﾞ：100%　3Dの深さ：25
＜ﾌｪｰﾄﾞｱｳﾄ＞種類：上段4番目、X軸ｵﾌｾｯﾄ：6.00mm、Y軸ｵﾌｾｯﾄ：6.00mm、色1：紺、色2：白
楕円
＜線種＞線種：なし
＜ｿﾌﾄｴｯｼﾞ＞ｻｲｽﾞ：7.00mm、色：青
「特殊効果」にも設定例があります。ご参照ください。


サロゲートペア

サロゲートペアでは、従来のUnicodeでは未使用だった領域を使って文字を表現します。これによって、「吉」の上の棒が短い文字や、「琢」に点が入った文字などを表現することができます。サロゲートペアの文字は、UNICODE(UTF16)では４バイトで表されます。
ジャイブレポートは、サロゲートペアに対応しています。
※サロゲートペアの文字を縦書きフォントで描画する場合には、影付き文字、フェードアウト、ソフトエッジ、３Ｄ文字の機能を利用できません。

レポートエディタでのフォーム作成時、固定文字にサロゲートペアを使う

レポートエディタで、固定文字にサロゲートペアを使う場合には、文字プロパティ画面の入力ボックスで入力します。
レポートエディタの画面上で直接入力することはできません。

レポートエディタでのPDFファイル作成時、サロゲートペアを使う

PDF作成画面に、「サロゲートペア用代替フォント」を入力する欄があります。ここで、代替フォント（※注1）を指定します。
「サロゲートペア用代替フォント」欄には、初期値として「*,SimSun-ExtB」が表示されます。
「フォントを埋め込む」をチェックすると、使用されたフォントと、指定されたサロゲートペア用のフォントがPDFファイルに埋め込まれます。

アプリケーション実行時、テキストフィールドやグリッドフィールドにサロゲートペアを使う（PDF出力以外）

テキストフィールドやグリッドフィールドの文字列に、サロゲートペアを含む文字列を指定すると、Windowsのフォントリンク機能が自動的に使用されます。そのため、フィールドに指定されたフォントがサロゲートペアの文字フォントを含まない場合でも、サロゲートペアの文字フォントを持つフォントにリンクされ、表示や印刷を行なうことができます。但し、サロゲートペアには代替フォントが使用されるため、文字幅や字体が他の文字と異なることがあります。

サロゲートペアは、UNICODEです。サロゲートペアを描画する場合には、UNICODEの使用を参照してください。

PDF出力時、テキストフィールドやグリッドフィールドにサロゲートペアを使う

PDF出力の場合には、Windowsのフォントリンク機能が使用されません。サロゲートペアを使う場合には、代替フォントの指定が必要です。
代替フォントを埋め込むには、フォントの埋め込み機能を使ってください。
サロゲートペアの描画には代替フォントが使われるため、レポートエディタ上の字体と、Adobe Readerによる画面表示や印刷の字体が異なります。

代替フォントは、以下のように指定します。

●レポートライブラリDLL、レポートライブラリJNIの場合
jvSetString(pid, JV_SURROGATEPAIR_FONT, 代替フォントの指定※注1)

●レポートライブラリOCX、レポートライブラリ.NETコントロール.の場合
SetParam(JV_SURROGATEPAIR_FONT, 代替フォントの指定※注1)

※注1：
代替フォントの指定には、元フォント名と代替フォント名をカンマで区切って指定します。
複数ある場合は、それぞれの組み合わせをカンマで区切って指定します。
すべてのフォントに対して同一の代替フォントを指定する場合は、元フォント名に * を指定 して下さい。

例
１．「ＭＳ明朝」フォントに代替フォント「SimSun-ExtB」を指定する場合
"ＭＳ 明朝 , SimSun-ExtB"

２．「ＭＳ明朝」フォントに代替フォント「SimSun-ExtB」を指定し、その他のフォントに代替フォント「MingLiU-ExtB」を指定する場合
"ＭＳ 明朝 , SimSun-ExtB , * , MingLiU-ExtB"

３．「ＭＳ明朝」フォントに代替フォント「SimSun-ExtB」を指定し、「ＭＳゴシック」フォントに代替フォント「メイリオ」を指定し、その他のフォントに代替フォント「MingLiU-ExtB」を指定する場合
"ＭＳ 明朝 , SimSun-ExtB , ＭＳ ゴシック , メイリオ , * , MingLiU-ExtB"

サロゲートペアは、ＭＳ 明朝やＭＳ ゴシック等には含まれておらず、SimSun-ExtBフォントやMingLiU-ExtBフォントに含まれています。また、IPAmjPUPフォントにも多数のサロゲートペアが含まれています。これは、「文字情報技術促進協議会」のサイトからダウンロードして使用することができます。


UNICODEの使用

.NET環境では、UNICODEの文字を使用することができます。
UNICODEを使う場合は、プログラムソースをUNICODE（UTF-8 シグニチャ付き）で保存してください。

レポートライブラリOCX／レポートライブラリ.NETコントロール

１．CharacterSetプロパティを使って、UNICODEの設定を行います。

２．１の設定後に、次のメソッドやプロパティでUNICODEの文字を描画することができます。
SetFieldTextメソッド、SetFieldGridメソッド、DrawTextメソッド、BookMarkプロパティ

－基本的なコーディング

レポートライブラリDLL／レポートライブラリJNI

１．次のファンクションでUNICODEを描画することができます。
jvSetFieldTextW、jvSetFieldGridW 、 jvDrawTextW 、jvSetStringW

（２．レポートライブラリJNIのみ）
XML形式の初期値の中にUNICODEが含まれる時は、jvWriteRdfSvcWを使います。

－基本的なコーディング

プレビューコントロール

１．帳票の中にUNICODEの文字が含まれている場合
そのままプレビューコントロールで表示することができます。

２．XML初期値の中にUNICODEの文字が含まれている場合
初期値の中にUNICODEの文字を使う場合は、先頭が「fffe」で始まるUNICODEファイル仕様で作成します。プレビューコントロールは、ファイル仕様から文字コードを判別して表示します。

３．プレビュー画面からUNICODEの文字が入力された場合
画面から入力されたUNICODE文字列をXmlDataプロパティで取得する時は、CharacterSetプロパティにUNICODEを指定して取得します。
XMLData以外のプロパティやメソッドを使う時は、プレビューコントロールが自動で文字コードをコントロールするため、特別な操作は不要です。

レポートエディタでUNICODEの固定文字を使う

１．レポートエディタで、フォームにUNICODEの固定文字を描画することができます。


フィールド編集子

編集子には、文字型、数値型、日付型があります。
テキストフィールドには、文字型、数値型、日付型のいずれかを指定することができます。
グリッドフィールドには、文字型、数値型のどちらかを指定することができます。

文字型編集子

文字型編集子には、［&@］があります。
表示する文字列が設定した桁数より少ない場合、＆は出力文字数のみ出力されますが、＠は不足分のスペースが出力文字の前に追加されて出力されます。

＜例＞
出力文字が、ABCDの時
編集子が@@@@@@では、スペース２つとABCD → "　ABCD"と出力される
編集子が&&&&&&では、ABCD → "ABCD"と出力される
編集子は、文字列の最大桁数を指定します。桁数は、全角文字を2桁、半角文字を1桁として数えます。
表示する文字列が設定された桁数を超える場合は、オーバーフローエラーが発生します。

オーバーフロー時の処理方法は、以下の機能で指定することができます。
レポートエディタからの帳票印刷→環境設定
レポートライブラリOCX、レポートライブラリ.NETコントロール：　CharOverFlowプロパティ
レポートライブラリDLL、レポートライブラリJNI：　jvSetLongファンクション

数値型編集子

数値型編集子には、［#0,.］があります。
編集子は、数値の最大桁数を指定します。
表示する値が設定された桁数を超える場合は、オーバーフローエラーが発生します。

オーバーフロー時の処理方法は、以下の機能で指定することができます。
レポートエディタからの帳票印刷→環境設定
レポートライブラリOCX／.NETコントロール：　NumOverFlowプロパティ
レポートライブラリDLL／JNI：　jvSetStringファンクション

設定された編集子と出力文字の関係を示します。（＊はオーバーフロー）

設定値

"1"

"-1"

"6532"

"-6532"

""

00 | 01 | -1 | ** | ** | 00
## | 1 | -1 | ** | ** |
00,000 | 00,001 | -0,001 | 06,532 | -6,532 | 00,000
##,##0 | 1 | -1 | 6,532 | -6,532 | 0
##,### | 1 | -1 | 6,532 | -6,532 |

設定値

"0.5"

"-0.5"

"10.5"

"-10.5"

""

0.0 | 0.5 | *** | *** | *** | 0.0
#.0 | .5 | *** | *** | *** | .0
000.00 | 000.50 | -00.50 | 010.50 | -10.50 | 000.00
000.0# | 000.5 | -00.5 | 010.5 | -10.5 | 000.0
###.## | .5 | -.5 | 10.5 | -10.5 |

日付型編集子

テキストフィールドには、日付型編集子を指定することができます。
日付型フィールドにする場合は、編集子に「Y、M、D、H、N、S」を使います。（大文字、小文字のどちらでも使用できます。）
和暦で表示する場合は、編集子「Y、y」の変わりに「G、E、g、e」を使います。
編集子の中に「年、月、日」などの文字を含ませて、編集スタイルを指定することができます。

編集スタイルと出力文字は下表を参照してください。

編集スタイル 設定値）2002/06/22 15:05:05
YYYY年MM月DD日HH時NN分SS秒 | 2002年06月22日15時05分05秒
YYYY年M月D日H時N分S秒 | 2002年6月22日15時5分5秒
yyyy/mm/dd hh:nn:ss | 2002/06/22 15:05:05
yy年度 m月度売上 報告d日 | 02年度 6月度売上 報告22日
GE年mm月dd日HH時NN分SS秒 | H14年06月22日15時05分05秒
GGE年m月d日 | 平14年6月22日
GGGE年mm月dd日 | 平成14年06月22日
GGGE年度 M月度売上 報告D日 | 平成14年度 6月度売上 報告22日

MM/DD HH:NN:SSとM/D H:N:Sについて
MM/DD HH:NN:SS　→　出力文字が1桁の時は前に0がつき、2桁の時はそのまま表示されます。
  例）　06/01 09:05:05　　12/10 10:30:55
M/D H:N:S　→　出力文字が1桁の時は1桁、2桁の時は2桁で表示されます。
  例）　6/1 9:5:5　　12/10 10:30:55

データセットについて
日付型フィールドにデータをセットする時には、西暦で「yyyy/mm/dd」という形式でセットしてください。時間まで表示する場合は「yyyy/mm/dd hh:nn:dd」という形式でセットします。この形式以外でセットした場合は、正しく表示されないことがあります。

和暦について
和暦は、「令和、平成、昭和、大正、明治」のみ自動的に表示されます。それ以外の元号で表示する場合には、以下の機能で任意の元号を設定しておくことができます。
レポートライブラリDLL、JNIの場合：　jvSetString
レポートライブラリOCX、.NETの場合：　SetParam

例えば、編集子に「GGGE年m月d日」が設定されているフィールドに、「2018/07/01」というデータをセットすると、「平成30年7月1日」と表示されます。


網掛パターン

下図は、レポートライブラリからオブジェクトを描画する時の網掛パターンです。
FillPatternプロパティ、jvSetLongファンクションで使います。


対応イメージ形式

ジャイブレポートでは、以下の形式のイメージファイルを描画することができます。

対応イメージ形式 | ファイル拡張子
Windows BMP形式 | BMP
Windows DIB形式 | DIB
JPEG形式 | JPG,JPEG
PNG形式(ﾎﾟｰﾀﾌﾞﾙﾈｯﾄﾜｰｸｸﾞﾗﾌｨｯｸｽ) | PNG
TIFF形式 (圧縮形式はﾊﾟｯｸﾋﾞｯﾄ圧縮、非圧縮のみ対応) | TIF,TIFF
EMF形式(拡張ﾒﾀﾌｧｲﾙ) | EMF

各々のイメージ形式は、ファイル拡張子によって判断されます。


用紙の余白(マージン)設定

用紙の余白（ﾏｰｼﾞﾝ）設定

レポートエディタ、レポートライブラリ、プレビューコントロールでは、用紙の余白を設定することができます。
ここでは、これらのツールやコントロールで余白を設定した場合の印字開始位置を解説します。

解説中に、プリンタの印字原点という言葉が頻繁に登場します。
この言葉の意味は、用語集　印字領域と印字原点　で確認してください。

注意）
ジャイブレポートは、バージョンによって余白の仕様が異なります。

ジャイブレポートVersion10の余白

※レポートライブラリやプレビューコントロールでスケールを設定しても、余白はスケールの影響を受けません。
※プリンタドライバのスケールを使って印刷をした場合には、プリンタドライバに依存します。

１．レポートエディタでフォームに余白を設定した場合

  1-1．余白がプリンタの印字原点より大きい場合
  印字開始位置は、用紙の左上端から余白分移動した位置となります。
  例）
  プリンタ印字原点が5mm、余白が6mmの場合、用紙の左上端から6mmが印字開始位置です。

  1-2．余白がプリンタの印字原点より小さい場合
  印字開始位置は、プリンタの印字原点となります。
  例）
  プリンタ印字原点が5mm、余白が2mmの場合、用紙の左上端から5mmが印字開始位置です。
  余白が未設定の場合には、余白0mmとなり、印字開始位置はプリンタの印字原点となります。

２．レポートライブラリで余白を設定した時の印字開始位置
  レポートライブラリで設定した余白は、フォームの余白に加算されます。
  余白は、 jvSetFormや TopMarginとLeftMargin で設定することができます。

  2-1．余白の合計値がプリンタの印字原点より大きい場合
  印字開始位置は、用紙の左上端から余白の合計値分移動した位置となります。

  例）
  プリンタ印字原点が5mm、フォームの余白が6mm、jvSetFormの余白が4mmの場合
  余白：　6mm（フォームの余白）＋4mm（jvSetFormの余白）
  印字開始位置：　用紙の左上端から10mm

  例）
  プリンタ印字原点が5mm、フォームの余白が未設定、jvSetFormの余白が6mmの場合
  余白：　0mm（フォームの余白）＋6mm（jvSetFormの余白）
  印字開始位置：　用紙の左上端から6mm

  2-2．余白の合計値がプリンタの印字原点より小さい場合
  印字開始位置は、プリンタの印字原点となります。

  例）
  プリンタ印字原点が5mm、フォームの余白が未設定、jvSetFormの余白が4mmの場合
  余白：　0mm（フォームの余白）＋4mm（jvSetFormの余白）
  印字開始位置：　プリンタの印字原点（用紙の左上端から5mm）

  例）
  プリンタ印字原点が5mm、フォームの余白が2mm、jvSetFormの余白が2mmの場合
  余白：　2mm（フォームの余白）＋2mm（jvSetFormの余白）
  印字開始位置：　プリンタの印字原点（用紙の左上端から5mm）

３．プレビューコントロールで余白を設定した時の印字開始位置
  プレビューコントロールで設定した余白は、すべての余白に加算されます。
  余白は、プレビューコントロールのTopMarginとLeftMargin で設定することができます。

  3-1．余白の合計値がプリンタの印字原点より大きい場合
  印字開始位置は、用紙の左上端から余白の合計値分移動した位置となります。

  例）
  プリンタ印字原点が5mm、フォームの余白が6mm、jvSetFormの余白が4mm、プレビューコントロールの余白が5mmの場合
  余白：　6mm（フォームの余白）＋4mm（jvSetFormの余白）＋5mm（プレビューコントロールの余白）
  印字開始位置：　用紙の左上端から15mm

  例）
  プリンタ印字原点が5mm、フォームの余白が未設定、jvSetFormの余白が未設定、プレビューコントロールの余白が7mmの場合
  余白：　0mm（フォームの余白）＋0mm（jvSetFormの余白）＋7mm（プレビューコントロールの余白）
  印字開始位置：　用紙の左上端から7mm

  3-2．余白の合計値がプリンタの印字原点より小さい場合
  印字開始位置は、プリンタの印字原点となります。

  例）
  プリンタ印字原点が5mm、フォームの余白が未設定、jvSetFormの余白が未設定、プレビューコントロールの余白が3mmの場合
  余白：　0mm（フォームの余白）＋0mm（jvSetFormの余白）＋3mm（プレビューコントロールの余白）
  印字開始位置：　プリンタの印字原点（用紙の左上端から5mm）

  例）
  プリンタ印字原点が5mm、フォームの余白が1mm、jvSetFormの余白が1mm、プレビューコントロールの余白が2mmの場合
  余白：　1mm（フォームの余白）＋1mm（jvSetFormの余白）＋2mm（プレビューコントロールの余白）
  印字開始位置：　プリンタの印字原点（用紙の左上端から5mm）

ジャイブレポートVer.8～Ver.9の余白

※レポートライブラリやプレビューコントロールでスケールを設定すると、余白もスケールの倍率に変わります。
※プリンタドライバのスケールを使って印刷した場合には、プリンタドライバに依存します。

１．レポートエディタでフォームに余白を設定した場合

  1-1．余白がプリンタの印字原点より大きい場合（①）
  印字開始位置は、用紙の左上端から余白分移動した位置となります。
  例）
  プリンタ印字原点が5mm、余白が6mmの場合、用紙の左上端から6mmが印字開始位置です。

  1-2．余白がプリンタの印字原点より小さい場合（②）
  印字開始位置は、プリンタの印字原点となります。
  例）
  プリンタ印字原点が5mm、余白が2mmの場合、用紙の左上端から5mmが印字開始位置です。
  余白が未設定の場合には、余白0mmとなり、印字開始位置はプリンタの印字原点となります。

２．レポートライブラリで余白を設定した時の印字開始位置
  余白は、 jvSetFormや TopMarginとLeftMargin で設定することができます。

  2-1．フォームの余白が上記①の場合（④）
  レポートライブラリで設定した余白は、フォームの余白に加算されます。
  例）
  プリンタ印字原点が5mm、フォームの余白が6mm、jvSetFormの余白が4mmの場合
  余白：　6mm（フォームの余白）＋4mm（jvSetFormの余白）
  印字開始位置：　用紙の左上端から10mm

  2-2．フォームの余白が上記②の場合（⑤）
  レポートライブラリで設定した余白は、プリンタの印字原点に加算されます。
  例）
  プリンタ印字原点が5mm、フォームの余白が2mm、jvSetFormの余白が3mmの場合
  余白：　5mm（プリンタ印字原点）＋3mm（jvSetFormの余白）
  印字開始位置：　用紙の左上端から8mm

３．プレビューコントロールを使って余白を設定した時の印字開始位置
  余白は、プレビューコントロールのTopMarginとLeftMargin で設定することができます。

  3-1．RDFファイルが上記④で作成されている場合
  プレビューコントロールで設定した余白は、すべての値に加算されます。
  例）
  プリンタ印字原点が5mm、フォームの余白が6mm、jvSetFormの余白が4mm、プレビューコントロールの余白が5mmの場合
  余白：　6mm（フォームの余白）＋4mm（jvSetFormの余白）＋5mm（プレビューコントロールの余白）
  印字開始位置：　用紙の左上端から15mm

  3-2．RDFファイルが上記⑤で作成されている場合
  プレビューコントロールで設定した余白は、プリンタの印字原点を基準に加算されます。
  例）
  プリンタ印字原点が5mm、フォームの余白が2mm、jvSetFormの余白が3mm、プレビューコントロールの余白が5mmの場合
  余白：　5mm（プリンタ印字原点）＋3mm（jvSetFormの余白）＋5mm（プレビューコントロールの余白）
  印字開始位置：　用紙の左上端から13mm

ジャイブレポートVer.１～Ver.７の余白

※レポートライブラリやプレビューコントロールでスケールを設定すると、余白もスケールの倍率に変わります。
※プリンタドライバのスケールを使って印刷した場合には、プリンタドライバに依存します。

プリンタの印字原点が基準となります。
設定されたすべての余白は、印字原点の値に加算されます。
例）
プリンタ印字原点が5mm、フォームの余白が2mmの場合、用紙の左上端から7mmが印字開始位置です。
プリンタ印字原点が5mm、フォームの余白が7mmの場合、用紙の左上端から12mmが印字開始位置です。

レポートライブラリの余白や、プレビューコントロールの余白は、すべて加算されます。

異なるバージョン間での余白処理

SetParam、または、jvSetLongを使ってライブラリバージョンを指定すると、ジャイブレポートVer.10から、ジャイブレポートVer.8とVer.9の仕様で余白を設定することができます。


ナナフォームでのラベル印刷

レポートエディタではラベルを簡単に印刷することができます。
ラベルはレポートエディタで定義するだけで印刷できますが、ジャイブレポートには、ナナフォームのラベル定義ファイルが添付しています。
すぐに宛名ラベルなどのラベルを印刷したい場合は、ナナフォームのラベルを用意するだけで印刷が行なえます。
ここでは、ナナフォームの「ＳＣＪ２」というラベルを使って宛名ラベルを印刷する手順を解説します。

１．ラベルフォームの作成

ａ．レポートエディタを起動し、「ファイル／環境設定」で環境設定画面を開きます。
  ラベル定義ファイルに、ジャイブレポートをインストールしたディレクトリのナナフォームラベル定義.txtを設定します。

ｂ．「フォーム／フォーム情報」でフォーム情報画面を開きます。
  用紙情報タブの「ラベル印刷」をマウスでクリックし、ラベル印刷タブを開きます。

ｃ．ラベル印刷タブの先頭にあるラベル名コンボボックスには、ナナフォームのラベルが一覧されていますので、「SCJ2」を選択します。

ｄ．ラベル名を選択すると、ラベルサイズやラベル用紙のプレビューが「SCJ2」ラベルに変わります。

ｅ．レポートエディタの画面に戻ると、ラベル１枚のフォームが表示されています。
  そこで、宛名ラベルの設計をします。

ｆ．まず、どのラベルにも必ずある「〒」と「様」を描画します。
  文字ツール（Ａの絵）を選択し、マウスポインタを「〒」を印刷したい位置へ移動し、「〒」を入力します。「様」も同じようにして描画します。

ｇ．次に、ラベルごとに変わる郵便番号や住所などのためにフィールドを貼り付けます。

ｈ．画面左のツールボックスからテキストフィールド（＃＃の絵）を選択します。
  マウスポインタを郵便番号を印刷したい位置へ移動しクリックします。そのまま編集子を入力します。
  編集子とは、テキストフィールドに最大何文字まで入るかを設定するものです。数字しか入らない場合は「#」または「0」で最大文字数を入力します。どんな文字でも入る場合は「&」または「@」で最大文字数を入力します。
  ここでは、郵便番号なので、「&」を８個入力してください。
  編集子を入力したら、次にフィールドに名前を付けます。画面右のプロパティウィンドウのフィールド名称に「郵便番号」と入力します。
※フィールド名称は、デフォルトで「TEXT」になっていますが、わかりやすい名前につけかえると便利です。

ｉ．同じようにして、住所、会社名、名前のテキストフィールドを貼り付けます。

ｊ．「フォーム／フィールド順指定」でフィールド順指定画面を開き、フィールドの順番が「郵便番号、住所、会社名、名前」になっていることを確認します。
  なっていない場合は、↑ボタン、↓ボタンでこの順番に変更します。

ｋ．「ファイル／名前を付けてフォームの保存」で作成したフォームを保存します。

２．ラベルデータの準備

ラベルフォームに貼り付けたテキストフィールドのデータを準備します。ここでは、最も簡単なテキストファイルにデータを準備する方法を解説します。

ａ．メモ帳などのテキストエディタを起動します。

ｂ．印刷する住所録データを以下のように入力します。
  460-0011,名古屋市中区大須一丁目,株式会社ジャイブコンピュータ,山田太郎
  460-0012,名古屋市中区栄,ジャイブ商事,山田花子

ｃ．郵便番号、住所、会社名、名前の順番に入力します。
  これは、１のｊで指定したフィールドの順番に対応しています。

ｄ．項目と項目の間はカンマまたはタブで区切ります。
  １件分の終わりには改行コードを入力します。

ｅ．テキストファイルに名前をつけて保存します。

３．帳票登録

フォームとデータが準備できたら、帳票印刷の準備のため帳票登録を行ないます。

ａ．「表示／帳票印刷モード」で帳票印刷モードに切り替えます。
  帳票印刷モードにすると、帳票登録画面がポップアップします。

ｂ．「データの取得先」にテキストファイルを選び、２で作成したテキストファイル名と項目間の区切り記号を設定します。キーフィールドには会社名を設定しておきます。

ｃ．設定した内容に帳票名を付けます。名前は何でも良いのですが、とりあえず、「宛名ラベルテスト」と入力して、帳票登録ボタンを押します。

ｄ．これで帳票の登録ができたので、終了ボタンで帳票登録画面を閉じます。

４．帳票印刷

これで準備が整いましたので、宛名ラベルを印刷します。

ａ．帳票選択コンボボックスには、３で登録した「宛名ラベルテスト」という帳票が一覧されています。「宛名ラベルテスト」を選択します。
※一覧には、ジャイブレポートのサンプルとして添付している帳票名も入っています。

ｂ．画面には「SCJ2」のラベルが表示されましたが、まだデータが読み込まれていません。
  データ読込ボタン（CDの絵）を押してデータを読み込んでください。
  画面に２で入力した宛名が表示されました。

ｃ．あとは、印刷ボタン（プリンタの絵）押して印刷するだけです。


網掛文字

文字は、黒（色が指定されている場合は指定した色）一色で描画されますが、任意の網掛パターンで描画することもできます。このような網掛けで描画された文字を＜網掛文字＞と呼びます。


アンドゥ/リドゥ

アンドゥ／リドゥ

直前に行った操作を取り消し、元の状態に復帰する機能を＜アンドゥ＞といいます。
アンドゥを行った後、アンドゥを取り消したい場合には、＜リドゥ＞を実行するとアンドゥを行わない状態に復帰します。


イメージ

画像のことを＜イメージ＞と呼びます。イメージファイルには様々なファイル形式がありますが、ジャイブレポートでは、BMP、DIB、JPEG、TIFF、PNG（ポータブルネットワークグラフィックス）、EMF（拡張メタファイル）のファイル形式に対応しています。BMP形式のイメージファイルは、Windowsのペイントブラシで作成することができます。


イメージフィールドとは

イメージフィールド

描画するイメージが常に同じではない場合には、＜イメージフィールド＞を使います。ジャイブレポートでは、BMP、DIB、JPEG、TIFF、PNG（ポータブルネットワークグラフィックス）、EMF（拡張メタファイル）のイメージ形式に対応しています。BMP形式のイメージファイルは、Windowsのペイントブラシで作成することができます。


印字領域と印字原点

＜印字領域＞とは、プリンタが印字可能な領域のことです。
＜印字原点＞とは、プリンタの印字領域の原点です。

印字領域と印字原点は、プリンタによって異なります。

ほとんどのページプリンタには、左右に2～7mm程度、上下に2～7mm程度の印字できない領域があります。
例えば、あるページプリンタで、印字できない領域が上下左右に5mmあるとします。

このプリンタの印字原点は、上から5mm、左から5mmの位置となります。
このプリンタの印字領域は、A4用紙（210mm×297mm）では、200mm×287mmとなります。

使用するプリンタの印字領域は、以下の機能で調べることができます。

レポートライブラリOCX／.NETコントロール ：PrinterXMargin、PrinterYMargin
レポートライブラリDLL／JNI ：j vGetLong


インデント

和文の場合に行頭を一文字だけ字下げしたり、箇条書き等の場合に２行目以降を字下げしたりすることを＜インデント＞いいます。レポートエディタでは、マルチラインの文字列、テキストフィールドの場合にインデントを設定することができます。


英文ワードラップ

改行によって英文の単語が2行に分断されたり、英文の各行の長さが不揃いになったりするのを防ぐ機能を＜英文ワードラップ＞といいます。


オブジェクト

レポートエディタでフォームに描画した文字、図形、イメージ、バーコード、グラフ、フィールドを＜オブジェクト＞と呼びます。


禁則処理

行頭に句読点や終わり括弧がきたり、行末に始まり括弧がきたりしないようにする処理を＜禁則処理＞といいます。


グラフフィールドとは

グラフフィールド

描画するグラフデータが常に同じではない場合には＜グラフフィールド＞を使います。ジャイブレポートでは、横棒グラフ、縦棒グラフ、折れ線グラフ、面グラフ、円グラフ、レーダーチャート、散布図を描画することができます。


グラデーション

色を徐々にぼかして表現する方法をグラデーションと言います。
（塗り潰し効果／グラデーション参照）


グリッド

レポートエディタの画面に表示されている桝目を＜グリッド＞と呼びます。グリッドの間隔は変更することができます。グリッドは、表示と非表示を切り替えることができます。また、グリッドを他のオブジェクトと一緒に印刷することもできます。


グリッドフィールドとは

グリッドフィールド

縦横の表形式の可変データを描画する場合には、＜グリッドフィールド＞を使います。グリッドフィールドは、列ごとにフォント、編集子、幅、文字位置等を設定することができます。


グルーピング

複数のオブジェクトをグループ化し、１つのオブジェクトにする機能を＜グルーピング＞と呼びます。グルーピングされた複数のオブジェクトは、１つのオブジェクトとしてコピーや移動、サイズ変更などが行なわれます。


高速印刷モード

ジャイブレポートには、通常印刷モードと高速印刷モードの2種類の印刷モードがあります。

高速印刷モードは、高速を目的として印刷処理を行うため、一部機能制限がありますが、印刷時間が速いのが特長です。大量に印刷を行なう場合や、印刷速度が要求される場合には、高速印刷モードが適しています。

通常印刷モードは、ジャイブレポートのすべての機能を使用できますが、３Ｄやシャドウ、グラデーションなどの高機能なグラフィックス描画に対応するため、印刷時にイメージ描画と同様の処理を行います。そのため、プリンタの性能によっては、印刷に時間がかかることがあります。

高速印刷モードを指定した場合は、シャドウ、フェードアウト、ソフトエッジ、グラデーション、テクスチャ、カスタムブラシ、３Ｄ、文字変形が使用できません。これらの機能を使用する場合は、通常印刷モードにします。

通常印刷モードで作成したフォームファイルを高速印刷モードで印刷した時、フォームファイル中に上記の修飾機能を使ったオブジェクトが含まれている場合、これらのオブジェクトは、次のように印刷されます。
グラデーションとテクスチャはクロスの網掛けで印刷されます。
カスタムブラシは類似したストックブラシで印刷されます。
変形文字は変形なしの文字で印刷されます。
３Ｄ・シャドウ・フェードアウト・ソフトエッジはオブジェクトのみ印刷されます。

高速印刷モードの指定は、レポートエディタでフォーム設計時、または、レポートライブラリで指定します。
レポートライブラリで指定する場合、レポートライブラリDLLとレポートライブラリJNIではjvSetLongを使用します。レポートライブラリOCXとレポートライブラリ.NETコントロールではPrintModeプロパティを使用します。


ジャイブレポート外字ファイル

ジャイブレポート外字ファイルとは、レポートエディタで作成されたジャイブレポート専用の外字ファイルです。
ジャイブレポート外字ファイルには、レポートエディタをインストールした環境にある外字がイメージとして保存されます。レポートライブラリから外字を描画する時にジャイブレポート外字ファイルを使うと、環境に左右されず外字を描画することができます。

－外字の描画


数値フィールド

テキストフィールド、グリッドフィールドに設定された編集子が、『#、0』のフィールドを＜数値フィールド＞と呼びます。
数値フィールドには、半角の数字以外は入れることができません。
設定された編集子の数より渡したデータの桁数が多い場合は、桁あふれ（オーバーフロー）となります。

例）####と設定されているフィールドに、12345のデータを渡すと桁あふれになります。


セレクトボタンフィールド

アンケートの回答のように、複数項目の中から決められた数の項目を選択する場合には、セレクトボタンフィールドのラジオボタンタイプを使用します。
項目が選択された状態、または、選択されていない状態にあることを表現する場合には、セレクトボタンフィールドのチェックボックスタイプを使用します。


ソフトエッジ

縁をぼかして表現する方法をソフトエッジと言います。
（特殊効果／ソフトエッジ参照）


段組

一つの文章を指定された枠内で何段かにわけて表示する機能です。レポートエディタでは、マルチラインの文字列とテキストフィールドに段組機能があります。


帳票印刷モード

＜帳票印刷モード＞とは、レポートエディタ上で帳票を完成させて印刷を行うためのモードです。
表示メニューの「帳票印刷モード」を選択すると、帳票印刷モードになります。
帳票印刷モードにすると、レポートエディタ上で、外部ファイルやデータベースからフィールドにデータを読み込み、帳票印刷ができます。
データはMicrosoft Excel、Access、SQL Serverやテキストファイルから読み込むことができます。
帳票印刷モードでは、フォームに変更を加えることはできません。
帳票印刷モードは、可変フォームでは使用できません。


テキストフィールドとは

テキストフィールド

納品書の相手先会社名や納品年月日のように、表形式のデータとして扱われることがない可変データをフォームに設定する場合には、＜テキストフィールド＞を使います。テキストフィールドには、フォント種類やサイズ、文字位置など様々なプロパティを設定することができます。


テクスチャ

布やタイルなどの柄をイメージとして表現する方法をテクスチャと言います。
（塗り潰し効果／テクスチャ参照）


透過／上書き

複数のオブジェクトが重なり合っている時、重なり合った部分で下のオブジェクトが透けてみえる状態を＜透過＞と呼び、透けてみえない状態を＜上書き＞と呼びます。


ドライバ設定ファイル

プリンタドライバ設定ファイルは、プリンタドライバの設定値を保存したファイルです。バイナリ形式でプリンタドライバ毎にサイズが異なります。

プリンタドライバ情報でプリンタドライバを設定しても有効にならない場合は、ドライバ設定ファイルを使うと有効になることがあります。ドライバ設定ファイルは、プリンタドライバ情報より強力です。

ドライバ設定ファイルを使うと、プリンタドライバ情報にない特殊な項目も設定できる場合があります。

・プリンタドライバ設定ファイル


バーコード

文字や数字を細いバーと太いバーの組み合わせで表現するコードを＜バーコード＞といいます。様々な種類のバーコードがありますが、ジャイブレポートでは、JAN標準形、JAN短縮形、CODE39、NW7、ITF、CODE128、UPC、カスタマバーコード、QRコードに対応しています。


バーコードフィールドとは

バーコードフィールド

描画するバーコードが常に同じではない場合には、＜バーコードフィールド＞を使います。バーコードは、JAN標準形、JAN短縮形、CODE39、NW7、ITF、CODE128、UPC、カスタマバーコード、QRコードに対応しています。


パーツ登録とは

パーツ登録

レポートエディタで描画した複数のオブジェクトを１つのパーツ（部品）として登録する機能があります。登録したパーツはいつでも呼び出してフォームに貼り付けることができます。社名ロゴや頻繁に使用するフォームなどはパーツ登録しておくと便利です。


ピッチ

＜ピッチ＞には、文字ピッチと行ピッチがあります。文字ピッチは、文字の左端から次の文字の左端までの距離を指します。行ピッチは、行の左上から次の行の左上までの距離を指します。レポートエディタで、文字列やテキストフィールドのピッチを指定する場合、デフォルトのピッチを０ポイントとし、広げる場合にはプラス値、狭くする場合にはマイナス値を指定します。


フィールド

帳票や伝票を作成する時、ページが変わるごとに変化する部分があります。例えば、カード型の住所録を作成する場合、氏名や住所はページが変わるごとに別な内容となります。このような可変部分をフォーム上に設定するための機能として、＜フィールド＞が用意されています。フィールドには、テキストフィールド、グリッドフィールド、イメージフィールド、バーコードフィールド、グラフフィールドの5種類があります。


フィールドの並び順

フォームに貼り付けられたフィールドには、作成された順に番号がつけられます。
この番号を＜フィールド並び順＞と呼びます。
フィールド並び順は、レポートエディタから帳票印刷モードで帳票を印刷する場合に使われます。テキストファイルからデータを取り込む時や、Excelファイルから列名を指定せずにデータを取り込む時には、データの並び順とフィールドの順番を一致させておく必要があります。

－フィールドの並び替え


フィールド名称

フォームに貼り付けられたフィールドには、各々を特定するための名前が付いています。この名前を＜フィールド名称＞と呼びます。フィールド名称は、レポートエディタから帳票印刷をする時やレポートライブラリを使ってアプリケーションを開発する時に使用します。
フィールドをフォームに貼り付けると、フィールド名称は自動的に前のフィールド名の連番で付けられます。フィールド名称は、プロパティウィンドウで変更することができます。


フィールド名の行

フィールド名の行（または列）

＜フィールド名の行（または列）＞とは、Excelのワークシート上に、フィールドのフィールド名称を貼り付けている場合、その貼り付けた行（または列）を指します。
ワークシートに＜フィールド名の行（または列）＞がある場合、レポートエディタは、各フィールド名称と同じ名称のセルを探し、そのセルからデータを取得します。
ワークシートに＜フィールド名の行（または列）＞がない場合、レポートエディタは、ワークシートの先頭のセルから順番にデータを取得し、フィールドの並び順が若いフィールドから順にデータを埋め込みます。この場合は、ワークシートのデータの順番とフィールドの並び順は、一致していなくてはなりません。
フィールド名称は、帳票データウィンドウ画面のオプションメニュー「フィールド名称の取得」で取得することができます。


フェードアウト

徐々に消えていくように表現する方法をフェードアウトと言います。

（特殊効果／フェードアウト参照）


フォーム

レポートエディタを使って作成した帳票のレイアウトを＜フォーム＞と呼びます。
作成したフォームをファイルに保存したものを＜フォームファイル＞と呼びます。
レポートエディタの帳票印刷モードでは、フォームのフィールド部分に外部ファイルからデータを読み込んで帳票を完成させることができます。
レポートライブラリを使って、フォームのフィールド部分に外部データを読み込み帳票を完成させるアプリケーションを開発することもできます。


フォーム設計モード

＜フォーム設計モード＞とは、レポートエディタでフォームを設計する時のモードです。
表示メニューの「フォーム設計モード」を選択すると、フォーム設計モードになります。
フォーム設計モードでは、レポートエディタ上でフォームにオブジェクトを貼り付けたり、オブジェクトの移動や修正が行えます。
フォーム設計モードでは、帳票データの取り込みや帳票印刷はできません。


フォント

＜フォント＞とは、特定のデザインの文字セットで、MS明朝、MSゴシック、Courier、Arialなど様々な種類があります。レポートエディタでは、レポートエディタを起動したパソコンにインストールされているフォントをすべて使うことができます。
フォントをうまく使い分けるためには、日本語フォントと欧文フォント、横書きフォントと縦書きフォント、ビットマップフォントとアウトラインフォントなど、あらかじめ必要な知識があります。
日本語を描画するのに欧文フォントを選んでしまったり、横書きなのに縦書きフォントを選んでしまったり、大きく拡大するのにビットマップフォントを選んでしまったりすると、希望通りの文字描画ができなかったりします。


プリンタの解像度

＜プリンタの解像度＞とは、プリンタが1インチ当たりに描画できるドット数のことで、DPIという単位で表わします。ドットインパクトプリンタでは160DPIのものが多く、レーザープリンタでは300DPIから600DPIのものが多いです。


プロパティ

フォント名称やサイズなどの文字に付随する様々な属性や、線の太さや線の種類などの図形に付随する様々な属性を＜プロパティ＞と呼びます。


ページキー

1つのフォームファイルに複数のフォームを作成すると、フォームファイルには作成したフォームの数分のページが出来上がります。各フォーム（ページ）は、1、2というようなページ番号で識別することができますが、各ページに＜ページキー＞をつけてページキーで識別することもできます。ページキーには、わかりやすい名称などをつけることができます。

－ページキーの設定


編集子

＜編集子＞とは、テキストフィールドとグリッドフィールドのフィールドの型、最大桁数、編集スタイルを設定するためのものです。
フィールドの型には、数値型、文字型、日付型の3種類があります。
金額などの数値が入るものは数値型、住所や氏名などの文字列が入るものは文字型を設定します。日付型は、テキストフィールドに設定することができます。

－フィールド編集子


マージン

帳票の上下左右の余白を＜マージン＞といいます。


マルチページ編集とは

マルチページ編集

レポートエディタでは、1つのフォームファイルの中に、複数のフォームを作成することができます。各フォームは、それぞれ別のページに作成され、それぞれのページで編集することができます。ページ間のコピー・ペーストもできます。


文字フィールド

＜文字フィールド＞とは、編集子に『&、@』を設定したテキストフィールドやグリッドフィールドです。
文字フィールドには、全角、半角を問わずどのような文字も入れることができます。
フィールドに渡したデータの桁数が設定された編集子の桁数より多い場合は、桁あふれ（オーバーフロー）となります。桁数は、全角文字を2桁、半角文字を1桁として数えます。
例）「名古屋市1-2-12」というデータを表示する場合は、編集子の数が14個必要です。
（全角文字4つと半角文字6）


予約語

テキストフィールドのクエリープロパティには予約語を指定することができます。予約語は、レポートエディタから帳票印刷モードで印刷を行う時に使われます。

－予約語の設定


Adobe PDF

Adobe PDF形式

PDF（Portable Document Format）形式は、アドビシステムズ社によって開発された文書交換フォーマットです。

PDF形式の帳票は、Adobe Readerから使用することができます。Adobe Readerは、PDF形式のファイルビューアです。レポートライブラリで作成したAdobe PDF形式の帳票を使う場合は、Adobe Reader Version6.0以上を使用してください。


CPI

ＣＰＩ

＜ＣＰＩ＞（キャラクタ／インチ）とは、1インチ当たりの文字数を表わします。10CPIは、1インチ当たりの文字数が10キャラクタということです。


LPI

ＬＰＩ

＜ＬＰＩ＞（ライン／インチ）とは、1インチ当たりの行数を表わします。10LPIは、1インチ当たりの行数が10行ということです。


RDF

RDF形式の帳票

RDFとは、帳票のプレビュー用に作られたジャイブレポート独自のフォーマット形式の名称です。

RDF形式の帳票は、アプリケーションやレポートエディタから実行されたレポートライブラリの描画命令と、描画や印刷に使用するフォームファイル・イメージファイル・プリンタドライバ設定ファイルで構成されています。データサイズが小さいのが特長です。

レポートエディタでRDF形式の帳票を作成すると、帳票はファイルに保存されます。このファイルをRDFファイルと呼びます。

レポートライブラリでRDF形式の帳票を作成すると、帳票は、コンピュータのメモリ上に出力されます。このメモリ上に出力された状態のものをRDFデータと呼びます。メモリ上に出力されたRDFデータをファイルに保存したものをRDFファイルと呼びます。


TrueTypeフォント

画面上で見たままのイメージで印刷ができるフォントを＜TrueTypeフォント＞といいます。
レポートエディタのフォントリストで、先頭に何の記号も付いていないフォントがTrueTypeフォントです。
文字を回転させる場合には、TrueTypeフォントを選ぶときれいに回転します。


固定フォームと可変フォームの違い

固定フォームと可変フォーム

レポートエディタでは、固定フォームと可変フォームを作ることができます。

１．固定フォーム

帳票のレイアウトがいつも同じで変わることがない場合には固定フォームを作成します。
固定フォームでは、帳票のフォームをページ単位で作成します。
固定フォームは、レポートエディタから帳票印刷モードで帳票印刷ができます。

２．可変フォーム

印刷時に、出力するデータによって帳票のレイアウトが変わる場合は、可変フォームを作成します。
可変フォームでは、帳票のフォームを複数のセクションに分割して作成します。
可変フォームの場合は、レポートエディタの帳票印刷モードを利用できません。可変フォームを印刷するには、レポートライブラリを使って専用のアプリケーションを作成する必要があります。

－可変フォームの印刷


アンダーラインの位置を調整するには

文字プロパティ画面を開き、フォントタブの［下線と文字の距離］で、アンダーラインを引く位置を調整することができます。アンダーラインの位置調整は、-5ミリから5ミリの間で設定します。
文字プロパティ画面は、文字列やテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると開きます。マウスの右ボタンをクリックして表示されたポップアップメニューから「プロパティ」を選択して開くこともできます。


アンダーラインを引くには

文字プロパティ画面を開き、フォントタブの［下線］で［なし］以外の項目を選択するとアンダーラインが引かれます。［なし］を選択するとアンダーラインは引かれません。アンダーラインの種類は、破線、点線、一点鎖線、二点鎖線、一重線、二重線、太線の中から選択できます。
文字プロパティ画面は、文字列やテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると開きます。マウスの右ボタンをクリックして表示されたポップアップメニューから「プロパティ」を選択して開くこともできます。


イタリックやボールドに設定するには

イタリックを設定する場合は、文字プロパティ画面を開き、フォントタブの［イタリック］のボックスをマウスでクリックしチェックマークを付けます。チェックマークをはずすと、イタリックは解除されます。ボールドを設定する場合は、［ボールド］のボックスをマウスでクリックしチェックマークを付けます。チェックマークをはずすと、ボールドは解除されます。
文字プロパティ画面は、文字列やテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると開きます。マウスの右ボタンをクリックして表示されたポップアップメニューから「プロパティ」を選択して開くこともできます。
イタリックとボールドは、プロパティウィンドウでも変更することができます。


イメージフィールドを設定するには

レポートエディタ左側ツールバーのイメージボタン（魚の絵）をマウスでクリックして選択します。イメージを描画する位置へマウスポインタを移動し、マウスの左ボタンをクリックとイメージ領域が描画され、イメージのプロパティを設定する画面が開きます。イメージ画面で、［可変（フィールド）］を選択すると、フォームにイメージフィールドが設定されます。


イメージを透過にするには

イメージ画面を開き、［背景］に［透過］を選択すると、イメージを透過にすることができます。
イメージ画面は、イメージやイメージフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると開きます。マウスの右ボタンをクリックして表示されたポップアップメニューから「プロパティ」を選択して開くこともできます。


打ち消し線を引くには

文字プロパティ画面を開き、フォントタブの［打ち消し線］で、［なし］以外の項目を選択すると打ち消し線が引かれます。［なし］を選択すると打ち消し線は引かれません。打ち消し線の種類は、破線、点線、一点鎖線、二点鎖線、一重線、二重線、太線の中から選択できます。
文字プロパティ画面は、文字列やテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると開きます。マウスの右ボタンをクリックして表示されたポップアップメニューから「プロパティ」を選択して開くこともできます。


オブジェクトの色を変えるには

オブジェクトを選択し、プロパティウィンドウの前景色、背景色プロパティで色を選択して下さい。


オブジェクトのサイズや位置を揃えるには

位置を揃えるオブジェクトをすべて選択し、編集メニューの［オブジェクトを揃える］を実行してオブジェクトを揃える画面をポップアップさせます。揃えるオブジェクトの種類（文字列、テキストフィールド、直線、ボックス）とプロパティの種類（横位置、縦位置、幅、高さ）を指定し実行ボタンをクリックすると、選択中のオブジェクトが揃えられます。
プロパティの種類が横位置の場合は一番上のオブジェクトに、その他の場合は一番左のオブジェクトに揃えられます。


オブジェクトのサイズを変更するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。サイズ変更するオブジェクトの上にマウスポインタを移動し、マウスの左ボタンをクリックして目的のオブジェクトを選択状態にします。選択されたオブジェクト上でマウスカーソルが左右（上下）矢印の時、マウスの左ボタンを押したままの状態でマウスをブラウズするとオブジェクトのサイズが変更できます。


オブジェクトを移動するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。移動したいオブジェクトの上にマウスポインタを移動し、マウスの左ボタンをクリックして目的のオブジェクトを選択状態にします。選択されたオブジェクト上でマウスカーソルが十字の時、マウスの左ボタンを押したままの状態でマウスをブラウズするとオブジェクトは移動します。


オブジェクトを削除するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。削除したいオブジェクトの上にマウスポインタを移動し、マウスの左ボタンをクリックして目的のオブジェクトを選択状態にします。［編集／切り取り］の実行、［編集／削除］の実行、Deleteキーの押下、［Ctrl＋X］キーの押下のいずれかの操作でオブジェクトは削除されます。


オブジェクトを選択するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。選択したいオブジェクトの上にマウスポインタを移動し、マウスの左ボタンをクリックすると目的のオブジェクトが選択状態になります。


オブジェクトを複写するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。複写するオブジェクトの上にマウスポインタを移動し、マウスの左ボタンをクリックして目的のオブジェクトを選択状態にします。［編集／コピー］の実行または［Ctrl＋C］キーの押下で、選択されているオブジェクトと同じオブジェクトが、画面に複写されます。


拡大／縮小表示するには

作成しているフォームを拡大したり縮小したりして画面表示する場合には、表示メニューの［倍率］を選択したり、倍率ボタン（虫眼鏡の絵）の押下で行ないます。倍率は、10%、25%、50%、75%、100%、150%、200%、300%、400%の中から選択できます。倍率を選択すると、マウスカーソルが虫眼鏡に変わります。マウスポインタを画面の任意の場所へ移動しクリックすると、クリックした点を中心にフォームが拡大または縮小表示されます。


禁則処理や英文ワードラップを設定するには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。禁則処理を設定する場合は、［禁則処理］のボックスをマウスでクリックしチェックマークを付けます。チェックマークをはずすと、禁則処理は設定されません。英文ワードラップを設定する場合は、［英文ワードラップ］のボックスをマウスでクリックしチェックマークを付けます。チェックマークをはずすと、英文ワードラップは設定されません。

文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。

禁則処理の対象となる禁則文字は、［フォーム／フォームファイル情報］でフォームファイル情報画面を開き、禁則文字ボックスに任意の文字を入力することで、独自の禁則文字を設定することができます。


均等割付にするには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［文字位置］で、［均等割付］を選択すると均等割付が設定できます。その他、右寄せ、左寄せ、中央揃えも設定することができます。文字位置の調整は、文字列を描画するために確保した領域の範囲内で行われます。

文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。


グラフフィールドを設定するには

レポートエディタ左側ツールバーのグラフボタン（グラフの絵）をマウスでクリックして選択します。グラフを描画する位置へマウスポインタを移動し、マウスの左ボタンを押すとダミーのグラフが描画され、グラフのプロパティを設定する画面が開きます。グラフ画面で、［可変（フィールド）］を選択すると、フォームにグラフフィールドが設定されます。


グリッドの間隔を変更するには

横方向のグリッドの間隔を変更する場合は、［フォーム／グリッドの間隔（横）］を実行します。10mm、5mm、1mm、5CPI、6CPI、7.5 CPI、8 CPI、9 CPI、10 CPI、12 CPI、15 CPI、16 CPI、20 CPI、30 CPI の中から選択できます。CPIとは「キャラクタ／インチ」のことで、1インチ当たりの文字数を表わします。

縦方向のグリッドの間隔を変更する場合は、［フォーム／グリッドの間隔（縦））］を実行します。10mm、5mm、1mm、5LPI、6 LPI、7.5 LPI、8 LPI、9 LPI、10 LPI、12 LPI、15 LPI、16 LPI、20 LPI、30 LPIの中から選択できます。LPIとは「ライン／インチ」のことで、1インチ当たりの行数を表わします。


グルーピングを行なうには

描画した文字や図形をグループ化し、１かたまりのオブジェクトにすることができます。この機能をグルーピングといいます。グルーピングされたオブジェクトは１つのオブジェクトとして移動やコピーを行なうことができます。
レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。以下の２つのどちらかの方法でグルーピングするオブジェクトをすべて選択します。

１）グルーピングしたい1つ目のオブジェクト上にマウスポインタを移動し、マウスの左ボタンをクリックして選択状態にします。２つ目のオブジェクト上にマウスポインタを移動し、シフトキーを押しながらマウスの左ボタンをクリックし２つ目も選択状態にします。このようにしてグルーピングしたいオブジェクトを順番に選択します。

２）グルーピングしたいオブジェクトをすべて囲む矩形の頂点にマウスポインタを移動し、マウスの左ボタンを押したままの状態で、矩形を描きながらマウスをブラウズします。
グルーピングするオブジェクトをすべて選択したら、［編集／グルーピング］の実行または［Ctrl＋G］キーの押下でオブジェクトをグルーピングすることができます。


グルーピングを解除するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。グルーピングを解除するオブジェクト上にマウスポインタを移動し、マウスの左ボタンをクリックして選択状態にします。［編集／グルーピング解除］の実行または［Ctrl＋H］キーの押下でオブジェクトのグルーピングを解除することができます。


弧を描画するには

レポートエディタ左側ツールバーの弧・弓・扇ボタンをマウスでクリックします。プロパティウィンドウの弧扇弓プロパティで、弧を選択します。

弧を描画する位置へマウスポインタを移動し、マウスの左ボタンを押しながらブラウズすると弧が描画されます。弧の始点または終点をマウスでブラウズすると弧を好みの形に変えることができます。
［編集／グリッドに合わせる］が設定されていると、弧は15度単位で描画されます。


四角形の角を丸めるには

四角形を選択し、プロパティウィンドウのプロパティページボタンをクリックすると、ダイアログが表示されます。ダイアログの角丸めタブをクリックすると、画面右側に、小さな4つのボックスとそれに囲まれたボタンが表示されます。ボタンを押すと小さな４つのボックスの色が青になったり白になったりします。青の状態の時は、四角形のすべての角が丸められ、白の状態の時は、すべての角は直角となります。小さな４つのボックスは、四角形のそれぞれの頂点に対応していますが、任意のボックスをマウスでクリックするとクリックされた角が丸められたり直角になったりします。

角の丸め半径は、同じ画面の左側で指定します。


下のオブジェクトが透けるようにするには

オブジェクト同士が重なり合っている時、下のオブジェクトが透けて見えるようにするには、プロパティウィンドウの背景モードプロパティを使用します。背景モードプロパティが透過のオブジェクトは、下のオブジェクトが透けて見え、背景モードプロパティが上書きのオブジェクトは、下のオブジェクトは透けて見えません。
オブジェクトの塗り潰しパターンによっては、透過にしても透けて見えません。


下のオブジェクトを選択するには

重なり合ったオブジェクトの下のオブジェクトを選択する場合は、下のオブジェクト上にマウスポインタを移動し、マウスの右ボタンをクリックします。ポップアップメニューが表示されるので、その中の［下のオブジェクトを選択］を実行すると、下のオブジェクトを選択することができます。


指定した枠にイメージを収めるには

描画済みのイメージを選択し、マウスの右ボタンをクリックしてポップアップメニューを表示させます。その中のプロパティを選択し、イメージ画面を開きます。［表示サイズ］に［枠指定］を選択すると、フォームに描画されている枠の中にイメージを収めることができます。


線の形状を変えるには

直線や四角形、円等を選択し、プロパティウィンドウのプロパティページボタンをクリックすると、線種／線幅指定画面が開きます。

線の種類は、［線種指定］で、破線、点線、一点鎖線、二点鎖線、実線から選択することができます。


線の幅を変えるには

直線や四角形、円等を選択し、プロパティウィンドウのプロパティページボタンをクリックすると、線種／線幅指定画面が開きます。
線の幅は、［線幅指定］でドット単位の場合は1ドットから100ドットの間で、1/100ミリ単位の場合は0.01ミリから5.00ミリの間で指定することができます。
ドット単位で指定すると、プリンタの解像度により線の幅が変わります。ミリ単位の指定は、プリンタに関係なく同じ幅となります。


操作を取り消すには

操作を取り消し元の状態に復帰させる場合は、［編集／アンドゥ］の実行または［Ctrl＋Z］キーの押下を行ないます。アンドゥは、複数回繰り返すことができます。アンドゥの繰返し回数は、［環境設定／アンドゥバッファサイズ］で指定したサイズに依存します。サイズを多くとるとよりたくさんのアンドゥを実行することができます。


多角形の線を曲線にするには

多角形を選択し、プロパティウィンドウの多角形／ベジェプロパティで［ベジェ］を選択すると多角形の線は曲線になります。


多角形を選択するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。選択したい多角形の上にマウスポインタを移動し、マウスの左ボタンをクリックすると目的の多角形が選択状態になります。


多角形を描画するには

レポートエディタ左側ツールバーの多角形ボタンをマウスでクリックします。
プロパティウィンドウの多角形／ベジェプロパティ、オープン／クローズプロパティを設定します。多角形／ベジェプロパティでは、描画する多角形の点と点を結ぶ線を直線にするかベジェ曲線にするかを設定します。オープン／クローズプロパティでは、描画する多角形の開始点と終了点を結び閉じた図形にするか、結ばず開いた図形にするかを設定します。
次に、多角形を描画する位置へマウスポインタを移動し、マウスの左ボタンを押してマウスをブラウズしながら多角形の点をすべて設定します。

頂点が２つ以下の場合には多角形は描画されません。頂点が３つ以下の場合にはベジェ曲線による図形は描画されません。


縦書きにするには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［文字方向］で、［縦書き］を選択すると上から下への縦書きとなります。［縦書き逆］を選択すると下から上への縦書きとなります。
文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。

「サッカー」などの長音記号を含む文字列を縦書きにして、長音記号を上から下へ描画したい場合は、フォントの種類で縦書きフォント（先頭に＠マークが付いたもの）を選択し、文字回転角度を270度に設定し、文字方向を縦書きにするときれいに描画できます。


取り消した操作をもう一度行なうには

取り消した操作をもう一度行なう場合は、［編集／リドゥ］の実行または［Ctrl＋Q］キーの押下を行ないます。リドゥは、複数回繰り返すことができます。リドゥの繰返し回数は、［環境設定／アンドゥバッファサイズ］で指定したサイズに依存します。サイズを多くとるとよりたくさんのリドゥを実行することができます。


塗り潰しパターンを変えるには

塗り潰しパターンを変更する場合は、変更したいオブジェクトを選択し、プロパティウィンドウの塗り潰しパターンプロパティで行ないます。


バーコードが読み取れない場合には

バーやスペースの幅が小さすぎると、バーコードリーダーで読み取れないことがあります。
読み取れない場合は、レポートエディタのバーコード画面で、バーやスペースの幅を大きくし、読み取れるように調整します。
小さなバーコードの場合は、プリンタの解像度によりバーコードが読み取れないこともあります。
プリンタインクのにじみよりバーコードが読み取れないこともあります。
バーコード左端・右端の空白領域が狭すぎることによりバーコードが読み取れないこともあります。
それぞれ原因を取り除きます。


バーコードフィールドを設定するには

レポートエディタ左側ツールバーのバーコードボタン（バーコードの絵）をマウスでクリックして選択します。バーコードを描画する位置へマウスポインタを移動し、マウスの左ボタンを押すとダミーのバーコードが描画され、バーコードのプロパティを設定する画面が開きます。バーコード画面で、［可変（フィールド）］を選択すると、フォームにバーコードフィールドが設定されます。


パーツを登録するには

パーツ登録は、［表示／パーツウィンドウ］で、パーツ画面を開いて行ないます。

新しいファイルにパーツを登録する時は、［パーツ画面／ファイル／新規作成］を実行し、パーツ登録用のウィンドウを表示します。既に作成済みのファイルにパーツを追加登録する時は、［パーツ画面／ファイル／開く］を実行し、パーツファイルを開き、［パーツ画面／編集／パーツの追加］で新しい登録用のウィンドウを表示します。
レポートエディタに戻り、パーツ登録するオブジェクトをすべて選択します。［編集／コピー］の実行または［Ctrl＋C］キーの押下で、選択したオブジェクトをコピーします。パーツ画面の登録するウィンドウをマウスでクリックし、［パーツ画面／編集／貼り付け］を実行すると、オブジェクトがウィンドウに貼り付けられ登録されます。

登録したパーツを新しいパーツファイルとして保存する場合は［パーツ画面／ファイル／新規保存］、既に作成済みのファイルに追加保存する場合は［パーツ画面／ファイル／上書き保存］を実行し、パーツを保存します。


パーツを利用するには

［表示／パーツウィンドウ］でパーツ画面を開き、［パーツ画面／ファイル／開く］で、パーツが登録されているパーツファイルを開きます。利用したいパーツウィンドウをマウスでクリックし、［パーツ画面／編集／コピー］を実行します。レポートエディタに戻り、［編集／貼り付け］の実行または［Ctrl+X］キーの押下でコピーしたパーツが画面に貼り付けられます。


バーのサイズを変更するには

レポートエディタ左側ツールバーのバーコードボタン（バーコードの絵）をマウスでクリックして選択します。バーコードを描画する位置へマウスポインタを移動し、マウスの左ボタンを押すとダミーのバーコードが描画され、バーコードのプロパティを設定する画面が開きます。
バーの長さは、バーコード画面の［バーの長さ］で任意の値を設定します。
バーの幅は、バーコード画面の［バーの幅］で、バーの幅を細い方から順番に設定します。最も細いバーの幅を設定すると、他のバー幅は自動的に設定されますが、任意の値にすることもできます。
細いバーと太いバーの標準的な比率は、JAN標準形・JAN短縮形・CODE128、UPCでは1:2:3:4、CODE39・ITF・NW7では、最小バー幅が0.508mm以下のとき1:2.2～3.0、0.508mmを超えるとき1:2.0～3.0となっています。


描画位置を微調整するには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［文字位置の微調整］では、文字の横と縦の微調整を-3ミリから3ミリまでの間で設定することができます。
文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。


描画済みの多角形の頂点を増やすには

描画された多角形を選択しマウスの右ボタンを押すと［はさみ］を選択することができます。はさみを使うと、既に描画された多角形の頂点を増やし、多角形の形を変えることができます。はさみを選択するとマウスカーソルがはさみの形になります。多角形の線上の頂点を増やす位置にマウスポインタを移動し、マウスの左ボタンをクリックすると、新しい頂点が作成されます。作成された頂点をマウスでひっぱり、多角形の形を変更します。


フィールドの順序を変更するには

［フォーム／フィールド順指定］を実行し、フィールド順指定画面を開きます。フィールド順指定画面のリストボックスでは、フォームに貼り付いているすべてのフィールド名称が先頭から順番に並んでいます。順番を変更したいフィールド名称をマウスの左ボタンでクリックして選択し、上へ移動する場合は上矢印ボタン、下へ移動する場合は下矢印ボタンを移動する位置まで押し続けます。フィールド名称をマウスの左ボタンでクリックしたままマウスをブラウズしても移動することができます。OKボタンを押下するとフィールド順が変わります。
フィールドはリサイズしたり、プロパティを変更したり、移動したりすると順番が変わります。フィールドの順序の設定は、フォーム作成の最後で行なうのがよいでしょう。
計算式が設定されているテキストフィールドには、フィールド名の先頭に * が付いています。


フィールド名を画面に表示させるには

［環境設定／環境］で、［フィールド名称を表示する］の先頭のボックスをマウスでクリックしチェックマークを付けると、フォームに貼り付けられた各フィールドの先頭にフィールド名称が表示されます。


フィールド名を変更するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。名称を変更するフィールド上にマウスポインタを移動し、マウスの左ボタンをクリックして選択状態にします。プロパティウィンドウのフィールド名称の欄でフィールド名称を入力することができます。


フィールドを探すには

プロパティウィンドウの一番上のフィールド名称リストボックスをクリックすると、フォームに貼り付いているフィールド名称が一覧されます。目的のフィールド名称をマウスでクリックすると、そのフィールドがフォーム上で選択状態になります。
一つ以上のオブジェクトが選択状態の場合、この機能は使用できません。


フォームに固定のイメージを描画するには

レポートエディタ左側ツールバーのイメージボタン（魚の絵）をマウスでクリックして選択します。イメージを描画する位置へマウスポインタを移動し、マウスの左ボタンを押すとイメージ領域が描画され、イメージのプロパティを設定する画面が開きます。イメージ画面で、［固定］を選択し、描画するイメージファイルを設定するとフォームに固定イメージが描画されます。描画するイメージファイルは、参照ボタン（..．の絵）でも選択することができます。


フォームに固定のグラフを描画するには

レポートエディタ左側ツールバーのグラフボタン（グラフの絵）をマウスでクリックして選択します。グラフを描画する位置へマウスポインタを移動し、マウスの左ボタンを押すとダミーのグラフが描画され、グラフのプロパティを設定する画面が開きます。グラフ画面で、［固定］を選択するとフォームに固定グラフが描画されます。
固定グラフの場合は、［グラフデータ］ボタンを押して、グラフデータを設定します。


フォームに固定のバーコードを描画するには

レポートエディタ左側ツールバーのバーコードボタン（バーコードの絵）をマウスでクリックして選択します。バーコードを描画する位置へマウスポインタを移動し、マウスの左ボタンを押すとダミーのバーコードが描画され、バーコードのプロパティを設定する画面が開きます。バーコード画面で、［固定］を選択すると、フォームに固定バーコードが描画されます。

固定バーコードでは、［コード］に描画するコードを入力します。コードはバーコードの種類］で選択した種類により入力制限がありますので注意してください。


フォームを別のパソコン上で開く

レポートエディタで作成したフォームを別のパソコン上のレポートエディタで開く場合には、フォントに注意してください。パソコンＡで作成したフォームに固定文字やテキストフィールド・グリッドフィールドが貼り付いている時、その文字やフィールドはパソコンＡにインストールされているフォントが使われています。そのフォームをパソコンＢで開いた時、使われているフォントがパソコンＢになかった場合、文字やフィールドにはそのフォントに最も近いフォントが使われます。また、このような、フォームに使われているにも拘わらずパソコン上にないフォントは、レポートエディタのフォントリストでは、*付きで表示されます。


フォントの種類やサイズを変更するには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［フォント名称］のリストには、パソコンにインストール済みのフォントが一覧されおり、任意のフォントを選択することができます。［フォントサイズ］では、フォントのサイズを1ポイントから200ポイントの間で設定することができます。

文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。
フォントの種類とサイズは、プロパティウィンドウでも変更することができます。


複数のオブジェクトを選択するには

複数のオブジェクトを選択する場合は、次の2通りの方法があります。

１）選択したい1つ目のオブジェクト上にマウスポインタを移動し、マウスの左ボタンをクリックして選択状態にします。２つ目のオブジェクト上にマウスポインタを移動し、シフトキーを押しながらマウスの左ボタンをクリックするとと、１つ目が選択されたままで２つ目も選択状態になります。このようにして選択したいオブジェクトを順番に選択します。

２）選択したいオブジェクトをすべて囲む矩形の頂点にマウスポインタを移動し、マウスの左ボタンを押したままの状態で、矩形を描きながらマウスをブラウズします。


複数行のフィールドを設定するには

テキストフィールド、グリッドフィールドは複数行に対応しています。
テキストフィールド
プロパティウィンドウのプロパティページをクリックして文字属性画面を開き、［改行方向］で［改行なし］以外の項目を選択します。［順改行］を選択すると上から下へ改行され、［逆改行］を選択すると下から上へ改行されます。
文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。
グリッドフィールド
プロパティウィンドウのプロパティページをクリックしてグリッドフィールド画面を開き、列情報タブをクリックします。列情報タブでは、列ごとにプロパティを設定できます。複数行にする場合は、「マルチライン」チェックボックスをクリックして選択状態にします、
グリッドフィールド画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。


複数行の文字列を設定するには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［改行方向］の項目で、［改行なし］が選択されていると複数行の文字列を入力できません。［順改行］または［逆改行］を選択します。順改行では上から下に改行され、逆改行では下から上へ改行されます。


２つのオブジェクトの前後を変更するには

レポートエディタの左ツールバーの選択ツール（矢印の絵）をマウスでクリックします。前後を変更するオブジェクトの上にマウスポインタを移動し、マウスの左ボタンをクリックして目的のオブジェクトを選択状態にします。目的のオブジェクトを他のオブジェクトの上にする場合は、［編集／上層へ移動］の実行または［Ctrl＋F］キーの押下で選択されたオブジェクトは上へ移動します。他のオブジェクトの下にする場合は、［編集／下層へ移動］の実行または［Ctrl＋B］キーの押下で選択されたオブジェクトは下へ移動します。


ページを追加するには

編集中のフォームファイルに新しくページを追加する場合は、［フォーム／ページの追加］を実行すると追加されます。ページの追加は、ツールバーの「ページの追加」ボタンでも行なうことができます。


ページを複写するには

編集中のページを複写する場合は、ツールバーの「ページのコピー」で行なうことができます。


ページを削除するには

編集中のページを削除する場合は、ツールバーの「ページ削除」で行なうことができます。。


ページを入れ替えるには

編集中のページを前のページと入れ替える場合は、［表示／ページウィンドウ］でページウィンドウを開き、ツールバーの「上に移動ボタン」（上矢印の絵のボタン）を押下すると前のページと入れ替わります。編集中のページを後ろのページと入れ替える場合は、［表示／ページウィンドウ］でページウィンドウを開き、ツールバーの「下に移動ボタン」（下矢印の絵のボタン）を押下すると後ろのページと入れ替わります。


ページキーを指定するには

ツールバーの「ページキーの変更」をクリックすると入力ボックスが開きます。任意のページキーを入力した後、リターンキーを押すとページキーが指定されます。


編集子の指定方法

＜テキストフィールド＞
テキストフィールドボタン（##の絵）を選択し、テキストフィールドを描画する位置にマウスポインタを移動します。マウスの左ボタンをクリックすると、テキストフィールドの領域が自動的に確保され文字が入力可能な状態になります。この状態で編集子を入力します。編集子には、全角文字（2バイト文字）は設定できません。
数値型フィールドにする場合は、「#、0、カンマ、小数点」を使います。
文字型フィールドにする場合は、「&、@」を使います。
日付型フィールドにする場合は、「Y、M、D、H、N、S」を使います。

＜グリッドフィールド＞
グリッドフィールドボタン（表の絵）を選択し、グリッドフィールドを描画する位置にマウスポインタを移動します。マウスの左ボタンをクリックすると、横2列縦2行のグリッドフィールドが貼り付けられ、グリッドフィールドのプロパティを設定する画面が開きます。グリッドフィールドの編集子は、この画面で設定します。
グリッドフィールドは、2列でそれぞれの編集子が###のものが自動的に貼り付けられます。列を増やす場合は、［フィールド全体のプロパティ］の列数を増やします。編集子は、［列毎のプロパティ］で設定します。まず、［列指定］で設定対象となる列を指定します。1列目を設定する場合は1列目、2列目を設定する場合は2列目を指定します。次に、［編集子］のボックスに設定する編集子を入力します。編集子には、全角文字（2バイト文字）は設定できません。入力できる最大数は100バイトまでです。数値型フィールドにする場合は、「#、0、カンマ、小数点」を使います。文字型フィールドにする場合は、「&、@」を使います。
その他、列毎にフォント、列の幅や文字位置、文字位置の微調整等を設定することができます。列幅は、描画されたグリッドフィールドの列と列を区切る線上にマウスポインタを移動し、マウスカーソルが左右矢印の時、マウスをブラウズして変更することもできます。


文字を回転させるには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［フォント回転角度］では、文字の回転角度を0度から360度までの間で設定することができます。フォントを回転させる場合は、フォントの種類でTrueTypeフォントを選択しておくときれいに回転します。
文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。


用紙サイズを変更するには

フォームの用紙サイズを変更する場合は、［フォーム／用紙サイズ］または［フォーム／フォーム情報］を実行します。用紙サイズは、A3、B4、A4、B5、A5、はがき、15ｘ11inch、10x11inch、ユーザー定義サイズの中から選択できます。


用紙の縦横を指定するには

フォームの用紙方向を指定する場合は、［フォーム／用紙方向］または［フォーム／フォーム情報］を実行し、用紙方向に縦または横を選択します。


輪郭線の種類を変えるには

四角形、円、多角形等を選択し、プロパティウィンドウのプロパティページボタンをクリックすると、線種／線幅指定画面が開きます。
輪郭線の種類は、［線種指定］で、破線、点線、一点鎖線、二点鎖線、実線から選択することができます。


輪郭線のない文字を描画するには

文字列またはテキストフィールドを選択し、プロパティウィンドウのプロパティページボタンをクリックすると、文字属性画面が開きます。［輪郭線］のボックスをマウスでクリックしチェックマークをはずすと輪郭線のない文字が描画されます。チェックマークを付けると輪郭線のある文字が描画されます。

文字属性画面は、マウスの右ボタンをクリックするとポップアップメニューが表示されますが、その中のプロパティを選択して開くこともできます。


輪郭線の幅を変えるには

四角形、円、多角形等を選択し、プロパティウィンドウのプロパティページボタンをクリックすると、線種／線幅指定画面が開きます。
輪郭線の幅は、［線幅指定］でドット単位の場合は1ドットから100ドットの間で、1/100ミリ単位の場合は0.01ミリから5.00ミリの間で指定することができます。


レポートエディタで不定形用紙を使うには

レポートエディタで不定形の用紙を使う場合は、［環境設定／ユーザー定義サイズ］で不定形用紙を登録します。用紙方向、用紙サイズ、余白に任意の値を入力し、登録ボタンを押下すると不定形用紙サイズが登録されます。登録された不定形用紙サイズは、ユーザー定義サイズとして［フォーム／用紙サイズ］や［フォーム／フォーム情報］で選択することができます。ユーザー定義サイズは30個まで登録することができます。


レポートエディタから不定形用紙の印刷を行なうには

コントロールパネルでプリンタを選択し、［ファイル／サーバーのプロパティ］でサーバーのプロパティ画面を開きます。［新しい用紙を作成する］にチェックマークを付け、用紙の説明、用紙サイズ、余白に任意の値を入力し、用紙の保存ボタンを押下すると、設定したユーザー定義サイズが登録されます。レポートエディタで［印刷／プリンタの設定／プロパティ］を実行し、プリンタ設定画面を開きます。［用紙］で、登録したユーザー定義サイズを選択リストの中から選択します。


印刷するには

レポートエディタのファイルメニューから「印刷」を実行すると印刷ダイアログが開きます。
印刷ダイアログで印刷ボタンを押すと、印刷を開始します。
印刷する前に、プリンタ設定ボタンを押して、プリンタや用紙の設定をしておきます。


項目（フィールド）の順序を並べ替えるには

まず、レポートエディタの表示メニューの「フォーム設計」を実行してフォーム設計モードにします。
次に、フォームメニューの「フィールド順指定」を実行しフィールド順指定ダイアログを開きます。
フィールド順指定ダイアログでフィールドの順番を並べ替えることができます。
（フィールドの並べ替え参照）


テキストファイルからデータを取り込むには

まず、レポートエディタの表示メニューで「帳票印刷モード」を実行し帳票印刷モードにします。
次に、レポートエディタの表示メニューで「帳票登録ウィンドウ」を実行し帳票登録ウィンドウを開きます。
帳票登録ウィンドウでは、データ取得先にテキストファイルを選ぶことができます。
取得したいテキストファイル名と区切り記号を指定してデータ読込ボタンをクリックするとテキストファイルからデータを取得します。
（帳票登録の方法参照）


入力したデータをファイルに保存するには

レポートエディタの帳票印刷モードで入力したデータはテキストファイルに保存することができます。帳票データウィンドウの［ファイル／テキストファイルへデータ保存］で保存したいテキストファイル名を指定して下さい。
（帳票登録の方法参照）


フィールドデータを直接入力するには

帳票印刷モードに切り替わったレポートエディタで帳票のフィールド部分に直接データを入力する場合は、まず、印刷に使用するフォームを開きます。次に、レポートエディタの上部にあるデータ入力ボタンを押下するとレポートエディタの画面からデータを直接入力できるようになります。入力したいフィールドをマウスでクリックし値を入力してください。イメージフィールドの場合は、イメージファイルを選択するダイアログがポップアップします。グリッドフィールドの場合は、入力用シートがポップアップします。


フィールドの数が２５６を超える場合

帳票印刷の時にExcelからデータを取り込む場合には、フィールドの総数に注意してください。
Microsoft Excelには256列しかないため、フォームに貼り付けられたフィールドが必要とする総セル数が256を超える場合には、横1行を1ページ分のデータとすることができません。その場合には、縦1列を1ページ分のデータとしてください。そして、帳票登録画面でページデータの向きを縦並びに設定して下さい。


フォームが印刷済みの用紙へ印刷するには

印刷ダイアログで、印刷対象に「フィールドのみ」を指定して印刷します。
「フィールドのみ」を指定すると、フィールドデータのみ印刷され、フォームの部分は印刷されません。


プリンタドライバを設定するには

印刷ダイアログの「プリンタの設定」ボタンをクリックすると、プリンタ設定ダイアログボックスがポップアップします。そこで、出力プリンタの切り替えやプリンタドライバのプロパティ（用紙サイズ等）を設定することができます。


プレビューするには

帳票印刷モードでデータ読み込み後、ページウィンドウ上で表示するページをクリックします。
ツールバーの表示ページ入力ボックスにページ番号を入力し、リターンキーを押してもプレビューすることができます。


Excelからデータを取り込むには

帳票印刷モードで帳票登録ウィンドウを表示し、データ取得先をExcelにして取得したいファイル名、ワークシート名等を指定して下さい。データ読込ボタンをクリックするとExcelファイルからデータを取得します。
Excelファイルのデータを読み込むにはMicrosoft Excelがインストールされている必要があります。
（Excelからデータを取得する参照）


印刷ジョブの状態を確認するには

レポートライブラリOCX／レポートライブラリ.NETコントロールの場合

JobStatusプロパティでジョブ状態を取得します。印刷ジョブの状態以外にユーザー名、文書名等の情報も取得したい場合は、JobInfoプロパティで取得します。
すべての印刷ジョブの情報を取得するには、AllJobInfoプロパティで取得して下さい。
印刷ジョブのジョブＩＤは、StartメソッドからEndメソッドの間でJobIdプロパティから取得することができます。また、プリンタ名を取得するには、StartメソッドからEndメソッドの間でPrinterNameプロパティから取得して下さい。

レポートライブラリDLL／レポートライブラリJNIの場合

jvGetJobStatusで取得します。印刷ジョブの状態以外にユーザー名、文書名等の情報も取得したい場合は、jvGetJobInfoを使います。
すべての印刷ジョブの情報を取得するには、jvGetAllJobInfoを使います。
印刷ジョブのジョブＩＤは、jvStartDocからjvEndDocの間でjvGetLongを使用して取得することができます。また、プリンタ名を取得するには、jvStartDocからjvEndDocの間でjvGetStringを使います。


印刷スピードを早くするには

印刷スピードを速くするには

印刷モードには、通常印刷モードと高速印刷モードがあります。
印刷モードを高速印刷モードにすると、印刷スピードを速くすることができます。

高速印刷モードは、一部機能制限がありますが、通常モードに比べて印刷時間が速いのが特長です。
高速印刷モードの指定は、レポートエディタでフォーム設計時に指定します。
レポートライブラリでアプリケーション実行時に指定することもできます。

レポートライブラリで指定する場合は、レポートライブラリDLLやレポートライブラリJNIではjvSetLong、レポートライブラリOCXやレポートライブラリ.NETコントロールでは PrintModeプロパティを使用します。

－印刷スピードを高速にするコーディング（OCX／.NETコントロール）
－印刷スピードを高速にするコーディング（DLL／JNI）


外字を使うには

ジャイブレポートには外字の埋め込み機能があります。
出力先がRDFデータ、RDFファイル、Adobe PDFデータ、Adobe PDFファイルの場合、使用した外字は、ファイル（またはデータ）の中に埋め込まれます。外字が用意されていない環境でも、これらのファイル（またはデータ）を使うことで、外字を含む帳票のプレビューや印刷が可能です。

－外字の描画


拡大縮小印刷するには

レポートライブラリOCX／レポートライブラリ.NETコントロールの場合

FormScaleプロパティに拡大縮小率を設定します。

レポートライブラリDLL／レポートライブラリJNIの場合

jvSetFormファンクションで、拡大縮小率を設定します。


画面にプレビューするには

帳票を画面でプレビューするには

ジャイブレポートで帳票をプレビューする方法は４通りあります。

１．帳票をRDF形式で作成し、プレビューコントロールを使ってプレビューします。

－RDFドキュメントデータのプレビュー（OCX／.NETコントロール ）
－RDFドキュメントデータのプレビュー（DLL／ JNI）

－RDFファイルのプレビュー（OCX／.NETコントロール）
－RDFファイルのプレビュー（DLL／ JNI）

２．帳票をAdobe PDF形式で作成し、Adobe Readerでプレビューします。

－AdobePDFファイルの作り方（OCX ／.NETコントロール）
－AdobePDFファイルの作り方（DLL／ JNI）

３．アプリケーションのウィンドウやピクチャーボックスでプレビューします。

この方法は、出力先のデバイスコンテキストを取得しデバイスコンテキストへ出力します。
デバイスコンテキストが取得できない開発環境では、この方法は使えません。

OCX／.NET： OutDeviceプロパティとWinHdcプロパティを使います。
DLL／JNI： ｊｖCreateファンクションパラメータをウィンドウへ出力するように指定します。

４．帳票をBMP形式のファイルに保存し、イメージファイルが表示できるコントロールを使ってプレビューします。

OCX／.NET： OutDeviceプロパティとOutFileNameプロパティを使います。
DLL／JNI： ｊｖCreateファンクションパラメータをビットマップへ出力するように指定します。


実行環境にインストールするには

１．開発したアプリケーションを別の実行環境にインストールする場合には、使用したコントロールやライブラリも一緒にインストールする必要があります。

－レポートライブラリOCX／レポートライブラリ.NETコントロールを使用した場合
－レポートライブラリDLLを使用した場合
－ レポートライブラリJNIを使用した場合
－プレビューコントロールを使用した場合

２．ActiveXコントロールはレジストリに登録する必要があります。
登録は、以下のようにコマンドラインから行なうか、あるいはインストールツールを使用します。

Regsvr32.exe JvrlibXX.ocx


ダイアログボックスを表示しないでプリンタの設定を行なうには

実行時、アプリケーションで自動的にプリンタの設定を行なうには

レポートライブラリOCX／レポートライブラリ.NETコントロールの場合

Startメソッドを実行する前に、以下の設定を行います。

１．Outdeviceプロパティに「JV_PRINTER」を指定します。

２．SetPrinterプロパティに「JV_SPDEVMODE」を指定します。

３．PrinterNameプロパティでプリンタを指定します。
  プリンタが指定されなかった場合は、デフォルトプリンタ（通常使うプリンタ）が使われます。

４．PrinterDevModeプロパティでプリンタドライバ情報を指定します。
  プリンタドライバ情報が設定された場合は、PrnHdcプロパティの値は無効になります。

－基本的なコーディング

レポートライブラリDLL／レポートライブラリJNIの場合

１．jvCreateファンクションの出力先に「JV_PRINTER」を指定します。

２．jvSetDevModeファンクションでプリンタドライバ情報とプリンタ名を指定します。
  プリンタが指定されなかった場合は、デフォルトプリンタ（通常使うプリンタ）が使われます。
  プリンタドライバ情報が設定された場合は、jvCreateのプリンタデバイスコンテキストの値は無効になります。

－基 本的なコーディング


一つの文書内で複数のフォームを切り替えて印刷するには

レポートライブラリOCX／レポートライブラリ.NETコントロールの場合

StartメソッドとEndメソッドの間で、FormName プロパティを使ってフォームを変更します。
フォームを変更する前に、DrawFormメソッドで変更前のフォームを描画しておきます。

レポートライブラリDLL／レポートライブラリJNIの場合

jvStartDocファンクションとjvEndDocファンクションの間で、jvSetFormファンクションを使ってフォームを変更します。
フォームを変更する前に、jvDrawFormファンクションで変更前のフォームを描画しておきます。

※可変フォームの場合は、一つの文書内で複数のフォームを使うことはできません。


フィールドデータのみを印刷するには

レポートライブラリOCX／レポートライブラリ.NETコントロールの場合

DrawFormModeプロパティに「JV_FIELD_ONLY」を指定します。

レポートライブラリDLL／レポートライブラリJNIの場合

jvDrawFormファンクションで、描画モードに「JV_FIELD_ONLY」を指定します。


プリンタ設定のダイアログボックスを表示するには

実行時、印刷ダイアログボックスを表示するには

レポートライブラリOCX／レポートライブラリ.NETコントロールの場合

Startメソッドを実行する前に、以下を設定します。

１． Outdeviceプロパティに「JV_PRINTER」を指定します。

２． SetPrinterプロパティに「JV_SPSHOWDIALOG」を指定します。
  この設定をすると、 PrnHdcプロパティ（プリンタデバイスコンテキスト）の値は無効になります。

－基本的なコーディング

レポートライブラリDLL／レポートライブラリJNIの場合

１．jvCreateファンクションの出力先に「JV_PRINTER」を指定します。

２．jvPrintDialogExファンクションをコールすると印刷ダイアログが表示されます。
  jvPrintDialogExをコールすると、jvCreateで設定したプリンタデバイスコンテキストの値は無効になります。

－基本的なコーディング


Adobe PDFファイルを作成するには

レポートライブラリOCX／レポートライブラリ.NETコントロールを使う場合

Startメソッドを実行する前に、以下を設定します。

１．OutDeviceプロパティで、出力先を「JV_PDF」にします。

２．ファイルに保存する場合は、OutFileNameプロパティを使います。

－基本的なコーディング

レポートライブラリDLL／レポートライブラリJNIを使う場合

１．jvCreateファンクションの出力先に「JV_PDF」を指定します。

－基本的なコーディング


WebでAdobe PDF形式の帳票を使うには

レポートライブラリOCX、レポートライブラリ.NETコントロール、レポートライブラリJNIでは、帳票をAdobe PDF形式で作成し、Web上で使うことができます。
クライアントのPCには、Adobe Readerをインストールしておく必要があります。

－レポートライブラリOCX／レポートライブラリ.NETコントロールでのコーディング
－Adobe PDF形式を使ったWeb帳票システム

－ レポートライブラリJNIでのコーディング


DELPHIでレポートライブラリOCXを使用するには

DelphiでレポートライブラリOCXのサンプルを使用するには

Delphiのサンプルプログラムでは、2種類のActiveXコントロールを使っています。
DelphiでActiveXコントロールを使う時には、事前にActiveXコントロールのインストールが必要です。

そこで、Delphiのサンプルプログラムを開く前にActiveXコントロールのインストールを行ってください。
サンプルプログラムでは、レポートライブラリOCX（Jvrlib10X.OCX）とプレビューコントロール（Jvrvw10X.OCX）の2種類のOCXを使用しています。両方のインストールが必要です。

ActiveXコントロールのインストールは次の手順で行います。

１．メニューバーの「コンポーネント／ActiveXコントロール」の取り込みを実行し、「ActiveXの取り込み」ダイアログを表示します。

２．リストボックスで、Jvrlib10X 1.0 ﾀｲﾌﾟﾗｲﾌﾞﾗﾘ(Version 1.0)を選択し、インストールボタンをクリックして、レポートライブラリOCXをインストールします。

３．「ActiveXの取り込み」ダイアログのリストボックスで、JVRVW10X 1.0 Type Library (Version 1.0)を選択し、インストールボタンをクリックして、プレビューコントロールをインストールします。


PDF出力でサロゲートペアの文字を出力するには

サロゲートペアでは、従来のUnicodeでは未使用だった領域を使って文字を表現します。これによって、「吉」の上の棒が短い文字や、「琢」に点が入った文字などを表現することができます。サロゲートペアの文字は、UNICODE(UTF16)では４バイトで表されます。
サロゲートペアを含んだ文字列を出力する場合、画面や印刷、イメージ画像での出力では、Wiindowsのフォントリンク機能が自動的に使用されます。そのため、サロゲートペアの文字フォントを含まないフォントでも、そのフォントがサロゲートペアの文字フォントを持つフォントにリンクしていれば、表示や印刷を行なうことができます。
ＰＤＦ出力では、Windowsのフォントリンク機能が使用されません。そこで、以下の機能を使って代替フォントを指定して下さい。

レポートライブラリDLL／レポートライブラリJNIを使う場合

jvSetString(pid,JV_SURROGATEPAIR_FONT,代替フォントの指定)

例） ＭＳ 明朝の代替フォントをSimSun-ExtBに設定し、その他のフォントの代替フォントをMingLiU-ExtBに設定する

ret = jvSetString(pid, JV_SURROGATEPAIR_FONT, "ＭＳ 明朝,SimSun-ExtB,*,MingLiU-ExtB")

レポートライブラリOCX／レポートライブラリ.NETを使う場合

SetParam(JV_SURROGATEPAIR_FONT,代替フォントの指定）

例） ＭＳ 明朝の代替フォントをSimSun-ExtBに設定し、その他のフォントの代替フォントをMingLiU-ExtBに設定する

Jvrlib.SetParam(JV_SURROGATEPAIR_FONT, "ＭＳ 明朝,SimSun-ExtB,*,MingLiU-ExtB")


PDF出力でオーバーレイ登録をするには

オーバーレイ登録は、レポートエディタとレポートライブラリのどちらからも設定できます。

レポートエディタで設定する

オーバーレイ登録は、ファイル情報画面で設定します。

レポートライブラリで設定する

オーバーレイ登録には、以下のプロパティやファンクションで設定します。

レポートライブラリOCX／.NETコントロール ：SetParamメソッド
レポートライブラリDLL／JNI： jvSetLong
プレビューコントロール：SetParamメソッド


テキストフィールドのプロパティを実行時に変更するには

テキストフィールドのプロパティは、実行時に、一部または全部を変更することができます。

１．一部を変更する

部分的に変更する場合には、まず、フォーム設計時に、レポートエディタで拡張機能を設定します。

レポートエディタでテキストフィールドに拡張機能を設定する方法

次に、プログラムコードに予約語を記述してプロパティを変更します。変更できるのは以下のプロパティです。

  ・フォント：種類、横幅拡大率、サイズ、色、イタリック、ボールド
  ・文字の背景：色、高さ、縦位置
  ・下線：色、幅、位置、種類
  ・打ち消し線：色、幅、位置、種類

詳細は「付録／テキストフィールド拡張機能」で変更するプロパティを参照してください。

フォントプロパティを変更
文字の背景プロパティの設定
下線プロパティの設定
打ち消し線プロパティの設定

２．全部を変更する

テキストフィールド全体を変更する場合には、以下の機能を使います。

レポートライブラリOCX／.NETコントロール ：SetFieldLongメソッド
レポートライブラリDLL／JNI： jvSetFieldLong


テキストフィールドの枠の大きさに合わせてフォントサイズを調整するには

テキストフィールドの枠に合わせてフォントサイズを自動的に調整する場合には、まず、フォーム設計時に、レポートエディタでフォントの自動調整を設定します。

レポートエディタでテキストフィールドにフォントの自動調整を設定する方法

フォントの自動調整が設定されたテキストフィールドでは、文字列が枠からはみ出る場合には、枠内に収まるようにフォントサイズが自動的に調整されます。

フォントの自動調整が設定されると、実行時にプロパティを変更することができます。
変更できるのは以下のプロパティです。

  ・フォント：色、イタリック、ボールド
  ・文字の背景：色、高さ
  ・下線：色、幅、種類
  ・打ち消し線：色、幅、種類

詳細は「付録／テキストフィールド拡張機能」で変更するプロパティを参照してください。

フォントプロパティを変更
文字の背景プロパティの設定
下線プロパティの設定
打ち消し線プロパティの設定


バージョンアップ内容

バージョン 10.3
１．テキストフィールドに、フォントや下線などのプロパティを実行時に変更する機能が追加されました。
２．テキストフィールドの文字列が枠からはみ出した時、フォントを自動調整して枠内に収める機能が追加されました。
３．PDFデータのオーバーレイ登録機能が追加されました。

バージョン 10.2
１．PDFフォームを作成する機能が追加されました。
  以下の３種類のフィールドが設定できるようになりました。
  テキストフィールド、チェックボックス、ラジオボタン
２．印刷ダイアログ表示時にプリンタを指定する機能が追加されました。
３．PDF暗号化レベルの種類が追加されました。

バージョン 10.1
１．サロゲートペアの文字を表示する機能が追加されました。
２．新元号に対応しました。
３．プロポーショナルフォントと回転文字の描画位置が改良されました。

バージョン 10.0
１．出力する形式にJEPG、PNG、TIFF、XPSが追加されました。
２．1つの印刷ジョブの中に、用紙サイズや用紙方向の異なる帳票を混在できるようになりました。
３．1つの印刷ジョブの中に、固定帳票と可変帳票を混在できるようになりました。。
４．Windows10に対応しました。

バージョン 9.10
１．レポートライブラリ.NETコントロールが追加されました。
２．マイクロQRコード、PDF417コード、マイクロPDF417コードに対応しました。
３．印刷スプーラ関連の機能が追加されました。

バージョン 9.06
１．プロフェッショナル(X64)の64ビット版レポートライブラリの不具合を修正しました。
２．Windows8に対応しました。

バージョン 9.05
１．ジャイブレポート外字ファイル機能を追加しました。

バージョン 9.0
１．可変フォームに対応しました。
２．Adobe PDFドキュメントにフォントを埋め込む機能を追加しました。
３．フォームの固定文字をUNICODEに対応させました。
４．RDF形式の帳票を変数などを使ってメモリ上でプレビューコントロールに設定する機能を追加しました。
５．プレビューコントロールで表示中の帳票をAdobe PDF形式で取得する機能を追加しました。

バージョン 8.30
１．各種類の名称に(X86)がつきました。
２．製品の種類に、X64環境に対応したプロフェッショナル(X64)が追加されました。
３．Tomcat Ver.6に対応しました。

バージョン 8.25
１．レポートライブラリ／レポートエディタ
・QRコードに対応しました。
２．レポートライブラリ
・PDFのセキュリティ機能を追加しました。

バージョン 8.2
１．レポートライブラリ／プレビューコントロール
・Visual Studio 2008に対応しました。
２．署名付プレビューコントロールを追加（プロフェッショナル版のみ）

バージョン 8.1
・Windows Vistaに対応しました。

バージョン 8.02
１．JNIライブラリ
・Java Servlet、JSP、Java、Strutsに対応しました。

バージョン 8.0
１．レポートライブラリOCX
・UNICODEに対応しました。
・外字の埋め込み機能に対応しました。
・CharacterSetプロパティ追加。
２．レポートライブラリDLL
・Adobe PDF（Portable Document Format）形式でのファイル出力機能を追加しました。
・UNICODEに対応しました。
・外字の埋め込み機能に対応しました。
・jvSetFieldTextWファンクション、jvSetFieldGridWファンクション、jvDrawTextWファンクション、jvSetStringWファンクション追加
３．プレビューコントロール
・UNICODEに対応しました。
・外字の埋め込み機能に対応しました。
・表示レイアウトに印刷レイアウトモードを追加しました。
・複数ページの帳票をスクロールしながら移動する機能を追加しました。
・CharacterSetプロパティ、FieldDataプロパティ、 LabelNoプロパティ、LayoutTypesプロパティ、SaveFileNameプロパティを追加。
４．レポートエディタ
・Adobe PDF（Portable Document Format）形式でのファイル出力機能を追加しました。
・フィールド名称一覧ウィンドウを追加しました。
・フィールド編集子の設定画面を追加しました。
・フィールド情報の取得画面を追加しました。
・縦方向の文字位置編集機能を追加しました。
・矢印キーでオブジェクトを移動する機能を追加しました。
・用紙のマージン設定方法を変更しました。
・ユーザー定義サイズの設定方法を変更しました。
・ユーザー定義サイズの最大値を縦横1000mmに変更しました。
・フォームファイルにパスワードの設定機能を追加しました。

バージョン 7.4
１．レポートライブラリOCX
・Adobe PDF（Portable Document Format）形式での出力機能を追加しました。
・SaveFileメソッド、BookMarkプロパティ、PdfDataプロパティ追加。

バージョン 7.3
１．高速印刷モードを追加しました。

バージョン 7.2
１．プレビューコントロール
・プレビューコントロール上で直接データを入力する機能を追加しました。
・SaveFileメソッド、ShowFileDialogメソッド、BorderStyleプロパティ、DataFileNameプロパティ、FieldFrameプロパティ、FormDragプロパティ、Lockedプロパティ、OuterColorプロパティ、Passwordプロパティ、PopupMenuプロパティ、XmlDataプロパティ追加。
２．RDFインターフェースライブラリ
・プレビューコントロールに表示する帳票の初期値ファイルをRDFサービスへ渡すライブラリを追加しました。

バージョン 7.1
１．レポートライブラリ
・Javaネイティブメソッドインターフェースライブラリを追加しました。

バージョン 7.0
１．レポートエディタ
・塗り潰し効果（ｸﾞﾗﾃﾞｰｼｮﾝ･ﾃｸｽﾁｬ・ﾊﾟﾀｰﾝ）機能を追加しました。（文字、四角形、楕円、円弧、多角形）
・特殊効果（ｼｬﾄﾞｳ･ﾌｪｰﾄﾞｱｳﾄ･ｿﾌﾄｴｯｼﾞ）機能を追加しました。（文字、直線、四角形、楕円、円弧、多角形）
・3D機能を追加しました。（文字、四角形、楕円、グラフ［縦棒/横棒/円］）
・文字変形、文字輪郭線設定の機能を追加しました。
・線端と接合部の設定機能を追加しました。（直線、四角形、多角形、円弧、文字）
・矢印機能を追加しました。（直線、多角形）
・実線以外（点線、破線など）の線幅設定機能を追加しました。
・グリッドフィールドの罫線に3D機能を追加しました。
・グリッドフィールドの改行幅（右余白）を調整する機能を追加しました。
・グラフ凡例の表示／非表示選択機能を追加しました。
・対応バーコードにUPCを追加しました。
・ユーザー定義サイズの最小値を12ミリに変更しました。
※WindowsME,98,95では、以下の機能は対応していません。
塗り潰し効果（ｸﾞﾗﾃﾞｰｼｮﾝ･ﾃｸｽﾁｬ・ﾊﾟﾀｰﾝ/ｶｽﾀﾑﾌﾞﾗｼ）、実線以外（点線、破線など）の線幅設定、先端と接合部
※Version７では、レポートマネージャ（電子帳票）とERFファイル作成機能がなくなりました。
２．レポートライブラリ
・プログラム中からテキストフィールド、グリッドフィールドの前景色(ﾌｫﾝﾄ色)、背景色(背面の色)を変更する機能を追加しました。
・プログラム中からフィールド情報を取得する機能を追加しました。
・１つの印刷ジョブの中でプリンタドライバの設定を何度も行えるように変更しました。
・バーコード描画機能の対応バーコードにUPCを追加しました。
・CMFファイル作成機能を削除しました。
・レポートマネージャを使う電子帳票機能が無くなりました。
３．レポートライブラリOCX
・SetFieldLongメソッド、FieldInfoプロパティ追加。
・Owner,Group,Access,Password,ErfOwner,ErfGroup,ErfAccess,ErfUpdateTime,ErfPage削除。
４．レポートライブラリDLL
・jvSetFieldLongファンクション追加。
・jvCreateERF,jvGetErfLong,jvGetErfString削除。
５．プレビューコントロール
・PageCopyメソッド（表示中のページをBMP形式でクリップボードにコピー）追加。
・3種類のプレビューコントロール(jiveview.dll,jvitview.ocx,jvitvimg.ocx)を1種類に変更しました。

バージョン 6.20
１．RDFサービス
・Web帳票システムで利用するRDFサービス機能を追加しました。
（RDFサービスマネージャ、RDF転送ライブラリ）
２．レポートライブラリ
・レポートライブラリOCXにRDFデータ作成機能を追加しました。

バージョン 6.11
１．レポートエディタ、レポートライブラリ
・対応イメージにJPEG,PNG,TIFF,EMF(拡張メタファイル)を追加しました。
・対応バーコードに郵便カスタマバーコードを追加しました。

バージョン 6.1
１．レポートライブラリ
・レポートライブラリがVB.NET、ASPに対応しました。
・VB.NET、ASPのサンプルプログラムが追加されました。

バージョン 6.0
１．レポートエディタ
・帳票を電子帳票として保存する機能が追加されました。
  帳票印刷モードからExcel／テキストファイル／ACCESSやSQL Serverからデータを取り込み完成した帳票を電子帳票として保存できるようになりました。
・フォーム設定ウィザードが追加されました。
  フォームを作成する時に、用紙サイズや用紙方向などの基本的なフォーム情報をウィザードで順番に設定することができるようになりました。
・帳票登録ウィザードが追加されました。
  帳票登録する時に、データの取得先などの情報をウィザードで順番に設定することができるようになりました。
・帳票登録モードがなくなりました。
  帳票登録モードがなくなり、帳票印刷モードから直接帳票登録したり、登録変更したりできるようになりました。
・Excelファイルへデータを書き込めるようになりました。 　帳票印刷時に、Excelからデータを取り込み、データウィンドウや画面からデータを修正した場合、修正内容をExcelへ更新できるようになりました。
・帳票印刷モードでの印刷時、環境設定画面のイメージ検索パスが、有効にならないバグを修正。
２．レポートマネージャ
・電子帳票の管理ツールであるレポートマネージャが追加されました。
・レポートマネージャには、電子帳票のツリー表示、検索、閲覧、印刷、承認、コメント付与、ブックマーク、帳票のイメージファイル保存などの機能あり、電子帳票を充分に活用することができます。
・電子帳票システムを利用するユーザーやグループの管理、帳票のアクセス権管理などセキュリティ機能もついています。
・電子帳票システムは、ネットワーク環境でもスタンドアロン環境でもどちらでも簡単に構築できます。 ネットワーク環境で構築する場合は、電子帳票ファイルをサーバーに置き、レポートマネージャをクライアントにインストールするだけで準備完了です。 スタンドアロン環境で構築する場合は、利用するPCに電子帳票ファイルを置き、レポートマネージャをインストールするだけで準備完了です。
３．レポートライブラリ OCX DLL 共通
・帳票を電子帳票として保存する機能が追加されました。
  今までの印刷プログラムやプレビュープログラムをそのまま利用して、帳票を電子帳票として保存できるようになりました。
・電子帳票ファイルの情報を取得する機能が追加されました。
  作成された電子帳票ファイルの情報を取得することができます。
４．レポートライブラリ OCX
・電子帳票関連プロパティ(Owner、Group、Password、Access、ErfOwner、ErfGroup、ErfAccess、ErfUpdateTime、ErfPage)の追加。
５．レポートライブラリ DLL
・jvCreateERF（電子帳票作成初期処理）ファンクション追加。
・jvGetErfString（電子帳票情報取得）ファンクション追加。
・jvGetErfLong（電子帳票情報取得））ファンクション追加。

バージョン 5.1
１．レポートエディタ
・帳票印刷モードの時、レポートエディタの画面から直接値を入力する機能を追加。
・ナナフォーム用ラベル定義ファイルを追加。
２．レポートエディタ、レポートライブラリ
・バーコードにCODE128を追加。

バージョン 5
１．レポートエディタ
・レポートエディタの画面全体のレイアウトを変更。
・レポートエディタの帳票印刷モードを帳票登録モード・帳票印刷モードの２つに分割。
・帳票印刷モードで、Microsoft Access、SQL Serverからのデータ読込に対応。
・帳票印刷モードで、Microsoft Excelからのデータ読込方法をDDEからExcelドライバに変更。
・フィールドとフォームにクエリー登録機能を追加。
・テキストフィールドに計算式機能を追加。
・ラベル印刷に対応。
・グリッドフィールドをマルチラインに対応。また、列毎のフォント情報指定機能を追加。
２．レポートライブラリ OCX
・プロパティ LabelNo 、LabelPrint 、LabelWidth 、LabelHeight 、LabelHNo 、LabelVNo 、LabelHGap 、LabelVGap 、FormQuery 、FieldQueryを追加。
３．レポートライブラリ DLL
・jvGetFormStringファンクションを追加。
・jvGetFieldStringファンクションを追加。
・jvGetLongファンクションにラベル情報を取得する機能を追加。
・jvSetLongファンクションにラベル番号を指定する機能を追加。
４．プレビューコントロール
・プレビューコントロールをマウスホイールに対応。

バージョン 4.1
１．インターネット/イントラネット専用プレビューコントロール
・プレビューコントロール jvitview.ocx を追加。

バージョン 4.0
１．プレビューコントロール
・プレビューコントロール jiveview.dll を追加。
２．レポートライブラリ OCX,DLL共通
・RDF(レポート記述フォーマット)、CMF(カスタムメタファイルフォーマット)形式の帳票ファイル作成機能を追加。
・ドライバ設定ファイル作成機能を追加。
３．レポートライブラリ OCX
・メソッド MakeDevFile を追加。
・プロパティ Key を追加。
・プロパティ PrinterName,PrinterDevModeの機能を追加した。
・プロパティ OutDevice に 値 JV_CMF,JV_RDF を指定可能にした。
・プロパティ PageCount , FormXMargin , FormYMargin , PrinterXMargin , PrinterYMarginを追加。
４．レポートライブラリ DLL
・jvCreateファンクションを追加。
・jvMakeDevFileファンクションを追加。
・jvSetStringに RDF,CMFファイルの Key1～Key5 の値を設定する機能を追加した。
・jvSetDevModeにドライバ設定ファイルを指定する機能を追加した。
・jvGetLongファンクションに機能を追加。

バージョン 3.0
１．レポートライブラリOCX
・従来のDLL形式のレポートライブラリに加え、ActiveXコントロール形式のレポートライブラリを追加した。


QandA

 Ｑ ＆ Ａ （目次）

フォーム設計

オブジェクトを選択するには

多角形を選択するには

下のオブジェクトを選択するには

複数のオブジェクトを選択するには

オブジェクトを移動するには

オブジェクトを削除するには

オブジェクトのサイズを変更するには

オブジェクトのサイズや位置を揃えるには

操作を取り消すには

取り消した操作をもう一度行なうには

オブジェクトを複写するには

２つのオブジェクトの前後を変更するには

フォームを別のパソコン上で開く

拡大／縮小表示するには

グルーピングを行なうには

グルーピングを解除するには

グリッドの間隔を変更するには

用紙サイズを変更するには

用紙の縦横を指定するには

レポートエディタで不定形用紙を使うには

レポートエディタから不定形用紙の印刷を行なうには

ページを追加するには

ページを複写するには

ページを削除するには

ページを入れ替えるには

ページキーを指定するには

パーツを登録するには

パーツを利用するには

オブジェクトの色を変えるには

フィールド名を変更するには

フィールドの順序を変更するには

フィールドを探すには

フィールド名を画面に表示させるには

複数行の文字列を設定するには

フォントの種類やサイズを変更するには

文字を回転させるには

描画位置を微調整するには

縦書きにするには

均等割付にするには

アンダーラインを引くには

アンダーラインの位置を調整するには

打ち消し線を引くには

イタリックやボールドに設定するには

網掛け文字を描画するには

輪郭線のない文字を描画するには

禁則処理や英文ワードラップを設定するには

複数行のフィールドを設定するには

線の幅を変えるには

線の形状を変えるには

輪郭線の幅を変えるには

輪郭線の種類を変えるには

塗り潰しパターンを変えるには

下のオブジェクトが透けるようにするには

四角形の角を丸めるには

弧を描画するには

多角形を描画するには

描画済みの多角形の頂点を増やすには

多角形の線を曲線にするには

多角形を選択するには

フォームに固定のバーコードを描画するには

バーコードフィールドを設定するには

バーのサイズを変更するには

バーコードが読み取れない場合には

フォームに固定のイメージを描画するには

イメージフィールドを設定するには

イメージを透過にするには

指定した枠にイメージを収めるには

フォームに固定のグラフを描画するには

グラフフィールドを設定するには

レポートエディタからの帳票印刷（帳票印刷モード）

項目（フィールド）の順序を並べ替えるには

グリッドフィールドにデータを入れるには

行数（ページ数）を変更するには

プレビューするには

改ページするには

フィールドデータを直接入力するには

テキストファイルからデータを取り込むには

Excelからデータを取り込むには

入力したデータをファイルに保存するには

フィールドの数が２５６を超える場合

プリンタドライバを設定するには

印刷するには

フォームが印刷済みの用紙へ印刷するには

アプリケーション開発

実行時、印刷ダイアログを表示するには

実行時、アプリケーションで自動的にプリンタの設定を行なうには

画面にプレビューするには

印刷ジョブの状態を確認するには

フィールドデータのみを印刷するには

一つの文書内で複数のフォームを切り替えて印刷するには

拡大縮小印刷するには

DelphiでレポートライブラリOCXのサンプルを使用するには

実行環境にインストールするには

印刷スピードを早くするには

外字を使うには

Adobe PDFファイルを作成するには

WebでAdobe PDF形式の帳票を使うには


エラーコード一覧

 エラーコード

  1. レポートライブラリＯＣＸのエラー
  2. レポートライブラリＤＬＬのエラー
  3. プレビューコントロールのエラー


レポートライブラリDLLとは

レポートライブラリDLLとは、レポートライブラリJNIとは

レポートライブラリDLLとレポートライブラリJNI

レポートライブラリDLLは、帳票アプリケーション開発に使用するDLL形式のライブラリです。
レポートライブラリJNI(Javaネイティブメソッドインターフェースライブラリ)は、Javaアプリケーションを開発する時に使う帳票印刷用ライブラリです。

様々な機能を持つメソッドやプロパティ

プリンタ制御、帳票フォームやフォーム上のフィールド描画、プログラムからのオブジェクト描画など、豊富な機能を持っています。
UNICODE描画、外字埋め込み機能などもあります。
レポートライブラリDLLは、RDF、PDF、XPS、TIFF、JPEG、PNG、BMPなどの様々な形式で帳票を出力できます。

－レポートライブラリJNIの詳細情報


 付録

  1. プリンタドライバの設定

  1. 1 プリンタドライバ情報とは

  1. 2 プリンタドライバ情報の取得

  1. 3 プリンタドライバ設定ファイル

    2. フィールド編集子

    3. 網掛けパターン

    4. 対応イメージ形式

    5. 外字の描画

    6. UNICODEの使用

    7. Adobe PDFドキュメントの制限

    8. バーコード

8.1 JAN（標準形・短縮形）

8.2 CODE39

8.3 NW7

8.4 ITF

8.5 CODE128（EAN128）

8.6 UPC

8.7 カスタマーバーコード（郵便バーコード）

  9. ナナフォームでのラベル印刷


各部の名称と機能(帳票印刷ﾓｰﾄﾞ)

帳票印刷モード画面　各部の名称と機能

レポートエディタから帳票を印刷する時には、表示メニューから「帳票印刷モード」を選択します。
帳票印刷モード画面では、帳票印刷に必要なツールバーやプロパティウィンドウが表示されます。
ここでは、帳票印刷モードのレポートエディタ画面に表示されている各部分の名称と機能を解説します。

※帳票印刷モード機能は、可変フォームでは使用できません。

１．メニューバー
メニューバーには、レポートエディタを操作するためのコマンドが並んでいます。メニューバーからそれぞれの項目を選択すると、ポップアップメニューが表示されます。

２．ツールバー
ツールバーには、メニューバーのよく使われるコマンドが並んでいます。

３．ページウィンドウ
各ページのページキーをツリー状に表示します。

４．ルーラー
ルーラーは、設定されているグリッドの縦横の間隔に合わせて表示されます。

５．ステータスバー
ステータスバーには、表示中のフォームに関する情報が表示されています。1行目のステータスバーには［用紙寸法、マウスポインタの座標、ページ番号］、2行目のステータスバーには［用紙サイズ、用紙方向、グリッドの間隔、倍率、ラベル印刷］が表示されています。

６．画面スクロールバー
表示中のページ内をスクロールします。

７．ページスクロールバー
表示中のファイル内をページ単位にスクロールします。


変形文字・3D・特殊効果の使い方

   変形文字・3D・特殊効果・塗り潰し効果の使い方
変形文字、3D、特殊効果、塗り潰し効果などの機能で、様々な文字や図形を表現できます
。
  1. 変形文字
  2. 文字・図形の3D
  3. 特殊効果・塗り潰し効果


 多角形を選択するには

Windows95を使用している場合、多角形は、直線上をクリックしないと選択できません。また、ベジェ曲線で描かれている多角形は、点と点を結ぶ直線上をクリックしないと選択できません。（WindowsNTでは、多角形のどこでも選択可能です。）


帳票メニュー(帳票印刷モード)

帳票メニュー

１．データ読込
帳票データを読み込みます。実行前に帳票登録を行っておきます。

２．先頭ページ
先頭ページへ移動します。複数ページ分の帳票データを読み込んだ時に使います。

３．前ページ
前のページへ移動します。複数ページ分の帳票データを読み込んだ時に使います。

４．次ページ
次のページへ移動します。複数ページ分の帳票データを読み込んだ時に使います。

５．最終ページ
最終ページへ移動します。複数ページ分の帳票データを読み込んだ時に使います。

６．データ入力
データ入力を選択すると、レポートエディタの画面上で値を入力することができます。
フィールドの位置でマウスをクリックすると、入力用のグレーボックスが表示されます。
イメージフィールドの場合は、イメージを選択するダイアログボックスが開きます。
グリッドフィールドの場合は、グリッドと同じ形式のシートが開きます。
計算式が設定されているテキストフィールドには値を入力することはできません。

７．データ保存
レポートエディタ画面で入力した値や、データウィンドウで入力した値をファイルへ書き込みます。実行前に帳票登録を行っておきます。

８．帳票の削除
帳票登録で登録済みの帳票を削除します。

削除する帳票を選択し、削除ボタンを押します。


新規トピック

打ち消し線プロパティの設定

拡張機能が設定されたテキストフィールドは、アプリケーション実行時に、打ち消し線プロパティを設定することができます。

拡張機能は、レポートエディタでフォームを作成する時、テキストフィールドに指定します。

変更可能な打ち消し線線プロパティは、描画の有無、色、幅、位置、種類です。
※「フォントの自動調整」機能が設定されている場合、位置を設定しても無効となります。

プロパティは、予約語、または、略式の予約語をプログラムコードの中に記述して設定します。
文字列の前に予約語と設定する値が記述されると、それ以降の文字列は予約語と一緒に指定されたプロパティで描画されます。
元に戻す場合には、再び予約語と元のプロパティを記述します。

打ち消し線を描画する

書式 <deleteline draw="true"> 打ち消し線を描画する
書式 <deleteline draw="false"> 打ち消し線を描画しない(初期値)
略式 <@DDT>
略式 <@DDF>

打ち消しの色を変更する

書式 <deleteline color="#ff0000"> 赤を指定
略式 <@DC#ff0000>
  色の設定は16進数でRGB値を256深度で記述して下さい。例）　ff0000は赤、00ff00は緑

例） 打ち消し線の色を指定し、打ち消し線を描画する

stext1 = "地震保険契約を希望されない場合は<deleteline color=""#ff0000""><deleteline draw=""true"">ご署名またはご捺印<deleteline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_23", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@DC#ff0000><@DDT>ご署名またはご捺印<@DDF>下さい。"
ret = jvSetFieldText(pid, "Field_24", stext1)

出力結果）

打ち消し線の幅を変更する

書式 <deleteline width="10">
略式 <@DW10>
  幅は1/100mm単位で設定します。設定可能な範囲は0～100です。

打ち消し線の位置を変更する

書式 <deleteline vpos="-10">
略式 <@DV-10>
  位置は1/100mm単位で設定します。設定可能な範囲は-300～300です。プラス値は下方へ、マイナス値は上方へ移動します。

打ち消し線の種類を変更する

書式 <deleteline type="0">
略式 <@DT0>
  0:実線,1:破線,2:点線 ,3:一点鎖線,4:二点鎖線,5,二重線

例） 打ち消し線の幅、打ち消し線の位置を指定し、打ち消し線を描画する

stext1 = "地震保険契約を希望されない場合は<deleteline color=""#ff0000""><deleteline width=""80""><deleteline vpos=""-30""><deleteline draw=""true"">ご署名またはご捺印<deleteline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_25", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@DC#ff0000><@DW80><@DV-30><@DDT>ご署名またはご捺印<@DDF>下さい。"
ret = jvSetFieldText(pid, "Field_26", stext1)

出力結果）

例） 打ち消し線の種類を指定し、打ち消し線を描画する

stext1 = "地震保険契約を希望されない場合は<deleteline color=""#ff0000""><deleteline type=""2""><deleteline draw=""true"">ご署名またはご捺印<deleteline draw=""false"">下さい。"
ret = jvSetFieldText(pid, "Field_27", stext1)

略式で記述する場合
stext1 = "地震保険契約を希望されない場合は<@DC#ff0000><@DT2><@DDT>ご署名またはご捺印<@DDF>下さい。"
ret = jvSetFieldText(pid, "Field_28", stext1)

出力結果）


 用語集

網掛文字

アンドゥ／リドゥ

イメージ

イメージフィールド

インデント

英文ワードラップ

オブジェクト

禁則処理

グラフフィールド

グラデーション

グリッド

グリッドフィールド

グルーピング

数値フィールド

セレクトボタンフィールド

ソフトエッジ

段組

帳票印刷モード

テキストフィールド

テクスチャ

透過／上書き

ドライバ設定ファイル

バーコード

バーコードフィールド

パーツ登録

ピッチ

フィールド

フィールドの並び順

フィールド名称

フィールド名の行

フェードアウト

フォーム

フォーム設計モード

フォント

プリンタの解像度

プロパティ

ページキー

編集子

マルチページ編集

文字フィールド

予約語

ＣＰＩ

ＬＰＩ

RDFファイル

RDFデータ

Adobe PDF形式

TrueTypeフォント

高速印刷モード

印字領域と印字原点

印字領域・印字原点と余白